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Abstract
This tutorial is going to take you on a walk through the 
digital world, showing you the skills and techniques re-
quired to create an animation in Interiors Professional. 
Many of the key elements in this tutorial will help you 
to understand the potential of animation. 

The tutorial has been written using the Decimal Feet & 
Inches Unit type.

For any queries during the tutorial, please use the Inte-
riors Professional documentation or contact our tech-
nical support from our website. You can also use the 
Forum on our website for reference. 

Tutorial Difficulty  (Shown on Front)
Microspot Tutorials are graded in a level of difficulty, 
where:

Beginners Tutorial - Requires no previ-
ous knowledge of the application.

Intermediate Tutorial - Requires some 
limited knowledge of the application.

Advanced Tutorial - Comfortable in us-
ing all aspects in the application.
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1.0 Setting up the Scene

This chapter is to help you to setup 
the scene for which we are going to 
create the animation in. It will also 
describe the elements of the Anima-
tion Tweener palette to control the 
animation.
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1.1 Introduction

The following tutorial will show you how to operate the basic functions in Microspot Interiors Professional to create 
animations. In this tutorial you will learn how to animate movement of objects, camera angles and lights. You will 
also learn how to export your animation into a QuickTime movie to view or share. We will create an animation of a 
barbecue opening to reveal a glowing heat underneath the grill, as the sun sets over the scene.

1.2 Creating the Scenery

With Microspot Interiors Professional launched a new untitled document will appear along with the Tools, Library 
and Camera palette:

Note: When working with this tutorial, all dimensions and units are in Decimal Feet & Inches, therefore it is important 
that you set your Unit Options under the Options menu to English with decimal place set to 0.XX.
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Begin by changing the grid size to 8 grid squares at 1’ 8” each in the Grid Options. We will first create the scene 
where the barbecue animation will take place. Select Add Base Plate from the Actions menu on the Menu bar:

You have now inserted a solid floor for the scene which we can add a texture or color to from the Library palette. 
From the Library, open the Tutorial library. Drag the Grass Texture and drop it on the Base Plate you have just added. 
The texture will appear to be distorted as it is stretched across the surface, we can adjust the texture by opening the 
Texture Options palette either from the Inspector or the Palettes menu on the Menu bar.
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Making sure that the Horizontal and Vertical sliders are both locked (symbolized by a tick on the right), drag one of 
the sliders up to approximately 4. For a more accurate method, you can type 4 either inside the Horizontal or Vertical 
field, or hold the Shift key while dragging the slider.

Once you are happy with the size of the texture on the base plate we can create a small path, where the barbecue 
will sit. By selecting the Cube tool from the Tools palette, create a rectangular object by initially clicking (and holding) 
on top of the base plate and drag upwards. 
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Edit the dimensions of the object using the Info palette to the following sizes, press enter after each entry. Then click 
on the Gravity tool, and with the tool selected click on the object just created to ensure that it is directly on top of 
the base plate:
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Enter the position values for the block as shown below and also you can now lock the Y-Position of the cube, to be 
able to reposition it without accidentally lifting it of the ground. Click on the Y Position padlock on the Info palette 
so that the padlock symbol becomes locked. (Remember to press enter after each value is entered)

Go to the View menu and select Top from the Change View sub-menu or use the Command (Apple) - 5 shortcut. 
Click on the shape and then select duplicate from the Edit menu or hold down the Option key and drag the item to 
duplicate. Using the Nudge tool rotate the duplicated shape 90 degrees and position the two objects to create a ‘T’ 
shaped area similar to the screenshot below.

When you are satisfied with the position of the objects, select both objects and group them using the Edit menu or 
Command (Apple) - G shortcut. Select Home view from the View menu (command (Apple) - 3). You can now drag  
and drop the Outdoor Tarmac texture from the Tutorial library onto the group, and set a scale value of 4 on the tex-
ture palette to make the texture look more realistic.
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Before we continue any further with the tutorial, it is a good idea to save the document with the title ‘BBQ anima-
tion’.

1.3 Animation Tweener Palette

Open the Animation Tweener palette from the Palettes menu:

The Animation Tweener palette displays all animated objects, the camera and light animations that have been added 
to a document. The Tween Increment Time value determines the time interval between each tween added, this may 
be varied for each animation. The Animation Tweener palette also allows you to control the playing of the animation 
using the player buttons in the top left-hand corner.

Tween Increment (Time Value)
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The Animation Tweener palette displays the time line signified by starting and ending arrowheads. Click and drag the 
End arrowhead to the 10 second time mark or click the Options button and type 10 in the End time field and press 
the Enter key. This has set the animation time to run for 10 seconds.



2.0 Creating the Animation

In this chapter we are going to work 
on the animation of the barbecue, 
where we will be focusing on the 
lights as well as the components of 
the barbecue.
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2.1 Animating the Objects

With the Library palette open, bring up the Tutorial library and select the Barbecue. Drag and drop the Barbecue onto 
the pavement created previously, as shown below.

Our aim is to animate the lid of the Barbecue opening, and have point lights animated to glow a brighter red as the 
control knobs on the barbecue turn higher. In order to animate several different parts of an object separately we 
need to break down the barbecue into its components.

2.1.1 Animating the Barbecue Lid

By Option double clicking the Barbecue or by using the Menu commands (Options - Dismantleable and then Edit 
Group), a new sub document window will open with the Barbecue broken down into its components.
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Click anywhere on the grid to deselect everything, then select the lid of the Barbecue and go to the Animation 
Tweener palette and type 5 into the Tween Increment Time field. Now click once on the Add Object button on the 
Animation Tweener palette, you will notice that the lids original position has now been recorded into the time line.

We must now record the position of the lid in its final, open position. Change to the Right view and use the Nudge 
palette to rotate the lid 45 degrees counter clockwise. Then move the view to view the lid as follows:
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Now using the Nudge palette again, nudge the lid upward 7”, the lid should now look as though it is on a hinge 
attached to the body of the barbecue:

Click once again on the Add Object button, you will notice its final position is now recorded at the 5 seconds mark. 
This means that from the first until the second tween points, the lid will be animated opening.
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To see the animation created so far click the Rewind button and then the Play Forward button on the Animation 
Tweener palette.

Before we begin adding the objects positions into the Animation Tweener, reset the animation to the start. We will 
have the control knobs start to turn at the beginning of the animation, you can however have the animation of a 
particular object start and end at any specific time with the use of the Animation Tweener.

2.1.2 Animating the Barbecue Control Knobs

We can animate the turning of the control knobs in the same time frame as the first animation. After returning to 
Home view, adjust the view with the NaviCam, so that you have a close up of the control knobs on the front of the 
barbecue.
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We can now indicate the final position we want the knob to turn to at the 4 second mark. With the same knob se-
lected, use the Nudge tool to rotate it 150 degrees clockwise. Once the knob appears to be turned towards a higher 
temperature mark, click once again on the Add Object button. Repeat the same process to create an animation for 
the second knob, remember to rewind the animation back to 0 seconds before recording the first position of the 
second knob.

This time we will have the animation of the control knobs run for the first 4 seconds. So set the Tween Increment 
Time field to 4:

Select one of the control knobs and click once on the Add Object button. This will record the first position of the 
knob at 0 seconds, and the time line should now have moved to the 4 seconds mark.
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NOTE: When setting up the animation of the second knob, you can set the rotation to what ever amount you want. 
Experiment with the effects of the tween movements on the objects.
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2.2 Animating the Lights

There are three types of lighting that we are going to loo at animating, which are the Point Light, Sun Light and 
Ambient Light.

2.2.1 Animating the Point Light

To create the glowing effect of the heat underneath the grill we need to insert point lights and position them under 
the grill of the barbecue.

Select the Point Light tool from the Tools palette and forward the animation time on the Animation Tweener palette 
until the barbecue lid is open and click on top of the grill to place the Point Light:

Before we correctly position the point light, change the color of the light, using the Info palette, to a red:

Move the Animation timer bar to 2 seconds, and nudge the point light, downwards 3”, so that it is hidden un-
derneath the grill of the barbecue. In this case rather than animating the position of the light, we will animate the 
brightness of the light, as the control knobs on the barbecue turn. To begin with we will have the light with mini-
mum brightness. So, using the Light Brightness slider on the Info palette change the brightens for the light down to 
around 15%.
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With the point light still selected, click the Add Object button to record its initial brightness.
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The time line should now be at 6 seconds, increase the brightness of the point light to about 85% in the Info palette 
and click the Add object button once again in the Animation Tweener palette.

You have now created all three animations involving the barbecue. Now close the sub document window to return to 
the original window where the barbecue should be standing on the scenery created earlier. You can see the anima-
tion so far by clicking on the Rewind and Play Forward buttons on the Animation Tweener palette.

Save the document.
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2.2.2 Animating the Sun Light

To create the effect of the sun setting, we can animate the movement of the sun by recording two positions for the 
sun. The angular position of the sun is always measured from the center of the grid. Holding down the Option key, 
click on the Sun Direction tool in the Tools menu:

Keep the Angle CW from North at 135 degrees, and change the Angle of Elevation to 20 degrees and press OK. The 
Top view of the grid will now illustrate the position of the sun and its direction.

Go back to the Home view (Command (Apple) - 3). Before clicking on the Add Sun button to record the suns initial 
position at time 0 seconds, change the Tweener Increment Time value to 9 seconds and change the color of the sun 
in the Lights palette to a pale yellow. Now click the Add Sun button to record the suns initial position.
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The time line should now be at 9 seconds, where we can perform the final position and angle of the sun that it will 
move to. Using the Option key to select the Sun Direction tool again, enter 315 degrees in the Angle CW from North 
field and 10 degrees in the Angle of Elevation. Change the color of the sunlight to dark red before recording the new 
position of the sun in the Animation Tweener palette at 9 seconds. Now click on the Add Sun button once again.
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2.2.3 Animating the Ambient Light

To add a more realistic effect to the sunrise and sunset, we can animate the Ambient Light to start out dark. When 
the sun is at 90 degrees elevation the ambient light will increase and then dim again as the angle of the sun drops.

To do this we have to record 3 different levels of ambient brightness using the Lights palette. Rewind the time line 
back to 0 seconds and set the Tween Increment Time value to 5, set the ambient light to a low level of brightness in 
the Lights palette.

Click on the Add Ambient button, once the time line moves to 5 seconds; increase the ambient brightness to 75% 
and click on the Add Ambient button again. Finally as the time line moves to 10 seconds, decrease the brightness 
back to the minimum (15%) and click on the Add ambient button once again. The tweener should have 3 tweens 
for the ambient light animation.
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2.3 Animating the Camera

We can now create an animation individually for the camera movement. Rewind the animation to time 0 seconds 
and adjust the NaviCam so that you have a close up of the barbecue grill:

Change the Tween Increment Time to 5 and then click on the Add Camera button. This will record the first position 
of the camera view into a tween at time 0 seconds.
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We can now adjust the final position of the camera view using the NaviCam once again, into the position similar to 
the one below:

Click on the Add Camera button once again. We have now finished creating the barbecue animation scene. You 
can view the whole animation by rewinding the animation back to time 0 seconds and clicking on the play forward 
button. Save the document.

2.4 Exporting a Movie

Once you are satisfied with the animation, you can export the animation as a QuickTime movie. The movie will be 
exported with the current renderer options settings. For higher quality graphics use the Microspot Renderer. The 
higher the Microspot Renderer settings are set, the longer the movie will take to export, in this case we will export 
using Microspot Preview Renderer.

Note: A large document window size will effect the size of the movie and time to export. We recommend editing 
the Window Size in the Options menu to 600x480.

You can now elect the Microspot Preview Renderer from the Renderer pop-up menu in the Renderer Options pal-
ette:
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Just as the scene begins to render, go to the File menu and Select Export then select Movie... from the sub menu.

The standard save dialog will then open for you to allocate where you want the file to be saved and what name it 
should have. Once you have clicked save a status window will appear after a few moments to inform you of the 
expected time remaining to export the movie to file. 

NOTE: These times are only estimates and depend on the complexity, length and quality of the scene.

2.5 Summary

This tutorial has shown you how to use the basic tools to create an animation. A QuickTime of this animation is avail-
able in the Microspot Interiors Professional package to compare with your animation. There are many more options 
and combinations of animations you can use once you become familiar with the essential animation functions as 
shown throughout this tutorial.
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