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Chapter 1 Introduction1

�   1.1 Welcome to Microspot MacDraft Personal Edition

This User Guide has information about the features and capabilities of Microspot 
MacDraft Personal Edition. It is laid out to let you refer directly to a particular feature 
and obtain detailed instructions about its use. 

Before you proceed you should be comfortable with terms such as click, drag, select and 
choose. You should also be familiar with the general methods used in most Macintosh® 
applications such as moving, resizing and scrolling a window. If you are not, refer to your 
Macintosh owner’s guide.

Hardware and Software Requirements

�� Macintosh System Mac OS X (10.4.11 or Higher) 
�� Power Mac G4 700MHz or Higher 
�� 256 MB RAM 
�� 150 MB of Hard disk space
�� CD-ROM (to install).

Installing Microspot MacDraft Personal Edition

After installing MacDraft it must be run from your hard disk not the CD.
To install Microspot MacDraft PE

��� Insert the MacDraft PE CD into the CD drive. 
��� Double-click the MacDraft PE Installer. 
��� Follow the instructions that appear. 

7KH�0DF'UDIW�3(�VRIWZDUH�DQG�LWV�VXSSOHPHQWDO�ÀOHV�ZLOO�EH�LQVWDOOHG�ZKHUH�\RX�
specify on your hard disk. 

Starting Microspot MacDraft Personal Edition

7KH�ÀUVW�WLPH�\RX�ODXQFK�0DF'UDIW�3(�\RX�PXVW�HQWHU�D�QDPH�DQG�YDOLG�VHULDO�QXPEHU�WR�
enable the software.

Chapter 1.0

Introduction
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To enable Microspot MacDraft PE

��� Double-click the MacDraft PE application icon to launch the software. 
��� Enter a name and valid serial number (the organization name is optional) into the 

dialog that appears. 

��� The serial number must be valid for the version you are using. This will be sup-
plied with the program or upgrade when purchased. 

��� Only when you have typed in your serial number, the OK button becomes avail-
able. Click it to open the application. 
If you click the Cancel button, the application will run in demo mode and some of 
the features and menu options will be dimmed.

�   1.2 The Help Menu

The Help menu is used to open the MacDraft manual, product registration and upgrade 
information.
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Microspot MacDraft Manual

The MacDraft Manual in pdf format will be included on disk with the application and 
Adobe™ Acrobat™ Reader. The manual will be installed on your hard drive during the 
installation process. 

Choose MacDraft Manual from the Help menu and a PDF of the Manual will open. 
You can then navigate through and read the manual on screen or print sections for your 
reference.

Registration Information

You can register MacDraft product via the Internet.
To register via the internet 

��� Choose Registration Information from the Help menu. 
The following dialog appears.

��� Click the Connect button to direct your web browser to go to the Microspot prod-
uct registration web page, then follow the registration instructions. 

Once you have registered MacDraft, Microspot will be able to send you infor-
mation about upgrades and new products. Alternatively, contact Microspot via 
telephone, fax or email.
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Upgrade Information

You can also obtain information (if any) about upgrades from the MacDraft PE web page 
by choosing Upgrade Information from the Help menu.

�   1.3 Document Handling

MacDraft allows you to have up to 16 documents open at the same time. You can open 
documents from the desktop or from within the application. See Appendix C - File formats 
IRU�LQIRUPDWLRQ�DERXW�RSHQLQJ�DQG�VDYLQJ�GRFXPHQWV�LQ�GLͿHUHQW�IRUPDWV�

Creating a New Document

To open a new document when launching Microspot MacDraft PE 

�� When you launch MacDraft PE, the application automatically opens with a new 
document. 

To open a new document when Microspot MacDraft PE is already running 

�� Choose New from the File menu.

NOTE: If the application is already running, but no documents are open, double-
clicking the application icon opens a new document.
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Opening an Existing Document

Existing documents can be opened from the Finder or from MacDraft’s File menu.

Opening a Document with the Finder

To open an existing document from the Finder 

�� In the Finder, locate the document you want to open and double-click it.

Opening a Document from the File Menu

You can open a document from the File menu, even if you already have another docu-
ment open.

NOTES:
�� Only documents compatible with MacDraft version 4.x or later (drawings, 

symbol libraries, MacDraft PICT documents or enhanced PICT drawings) can be 
opened by the current version of MacDraft. Drawings created with earlier ver-
sions of MacDraft (or with Dreams®) require special treatment.

�� Files created in versions prior to 4.x (e.g. 2.1 to 3.0), need to be opened in at least 
MacDraft version 4.x and then re-saved, before they can be opened in the version 
�����7KH�GRFXPHQW�ZLOO�KDYH�D��Ј��V\PERO�SUHÀ[HG�WR�WKH�ÀOH�QDPH�WR�GLVWLQJXLVK�
it from the document created with the older version of the software.

NOTES:
�� Files created in MacDraft versions 4.3.5 to 5.5.x are interchangeable with Mi-

FURVSRW�3&�'UDIW�������DQG�ODWHU��VR�3&�'UDIW�ÀOHV�FDQ�EH�RSHQHG�GLUHFWO\�LQWR�WKH�
YHUVLRQ�����RI�0DF'UDIW��KRZHYHU�ÀOHV�FUHDWHG�LQ�WKH�FXUUHQW�YHUVLRQ�RI�0DF'UDIW�
FDQQRW�EH�RSHQHG�LQ�3&�'UDIW��0DF'UDIW�ÀOHV�FUHDWHG�LQ�YHUVLRQ�����RU�KLJKHU��FDQ-
not be opened in previous version.

�� 0DF'UDIW�FDQ�RSHQ�ÀOHV�LQ�PDQ\�RWKHU�IRUPDWV�LQFOXGLQJ�':*�DQG�';)��VHH�
Appendix C File formats on page C-1 for more details).

NOTE: If a document is already open, double-clicking its name in the Finder 
brings that document window to the front.

To open a document from the File Menu 

��� Choose Open from the File menu
The standard open dialog appears. Locate the document you want to open and 
either double-click its name or click once its name and then click the Open button.
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��� 7R�VKRZ�RQO\�ÀOHV�RI�D�SDUWLFXODU�W\SH��VHOHFW�WKH�GHVLUHG�W\SH�IURP�WKH�6KRZ�SRS�
up menu.

Opening Drawings made with older versions of MacDraft

$V�0DF'UDIW�KDV�EHFRPH�D�PRUH�SRZHUIXO�GUDIWLQJ�WRRO��LW
V�ÀOH�IRUPDWV�KDYH�EHFRPH�
more sophisticated. This means that some older MacDraft drawings must be converted 
through intermediate versions of the application before they can be opened with the 
current version of MacDraft. For example, drawings created with MacDraft 2.1 must be 
opened and saved using MacDraft 4.x or higher before they can be opened in the version 
6.0 of MacDraft. Microspot provides these versions for registered owners of the current 
YHUVLRQ��$Q\�ÀOHV�FUHDWHG�LQ�YHUVLRQV�SULRU�WR�����QHHG�WR�EH�RSHQHG�DQG�UHVDYHG�LQ������
before they can be opened and resaved in 4.x or higher.

NOTE: When opening documents created with MacDraft 1.2b, text objects lose any 
EDFNJURXQG�ÀOOV��VHH�2EMHFW�ÀOO�FRORU��&K����S����). It is important to remember when 
RSHQLQJ�ÀOHV�WKDW�KDYH�PXOWLSOH�OD\HUV�DQG�D�GUDZLQJ�VL]H�ODUJHU�WKDQ����E\����LQFKHV��
MacDraft PE will only display the top layer and the top left hand 17 by 17 inches of 
the document.
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�   1.4 The Microspot MacDraft PE Environment

The Document Window

The MacDraft document window allows you to access your document for viewing, 
FUHDWLQJ�DQG�HGLWLQJ�WKH�GUDZLQJ�DUHD��,W�LV�GHVLJQHG�WR�RͿHU�\RX�D�GUDZLQJ�DUHD�ZLWK�DOO�
of the essential features of MacDraft within easy reach of your mouse. When you open 
the MacDraft application, the following screen appears. 

Fill and Line Indicators

The two small boxes in the lower left corner of the window are the Fill and Line Indicator 
boxes.

�� 7KH�)LOO�,QGLFDWRU�VKRZV�WKH�FRORU��VKDGH�RI�JUD\��RU�SDWWHUQ�WKDW�ZLOO�EH�XVHG�WR�ÀOO�WKH�
objects you draw. 

�� The Line Indicator shows line weight that will be used to draw lines and object bor-
ders. 

See 7KH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��&K����S���� for more information. 

Fill indicator box Line indicator box
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The Drawing Area

The drawing area is the part of the window that shows dotted line divisions. These divi-
sions are called grid lines. In English units, the distance between the grid lines represents 
one inch; in decimal feet, one tenth of a foot; and in metric units, one centimeters. You can 
use the grid lines as visual aids to assist you in your drawing (VHH�*ULG�OLQHV��&K����S����).

Wen you create a new document, MacDraft shows a document based on a single sheet of 
paper for the current output device. However, you can change the size of your document 
at any time to include multiple pages, allowing you to create very large drawings (see 
&KDQJLQJ�WKH�GUDZLQJ�VL]H��&K����S���).

:KHQ�\RX�ÀUVW�RSHQ�\RXU�GRFXPHQW��\RX�ZLOO�VHH�RQO\�WKH�XSSHU�OHIW�FRUQHU�RI�WKH�WRWDO�
drawing area.

As MacDraft Personal Edition has a limited drawing size, if you have a printer that can 
print to large paper sizes, the drawing size may not be as great as a single page.

The Toolbar

The Toolbar at the top of the document window can be made available, if it is not already, 
by clicking the toolbar button in the top right hand corner as shown below. This button 
can also be used to hide the toolbar.

Customizing the Toolbar

With the MacDraft Toolbar you have a selection of the most commonly used and useful 
options and menu items from within the application, which you can customize at any 
time.
To Customize the Toolbar 

��� Select the Customize button shown in the image above.
��� The toolbar sheet will appear showing you the available tools and options as fol-

lows.

Toolbar button - Show and Hide Toolbar
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As with most Apple Macintosh applications, clicking a title in the menu bar gives a drop-
down list of the options available (VHH�)LOH�PHQX��$SS��$).

Using Hierarchical Menus

MacDraft uses hierarchical menus. These submenus list further options available. For 
example, the Border Position submenu in the Options menu lists the possible positions 
for object borders (VHH�%RUGHU�SRVLWLRQV��&K����S����).

��� Locate the Tool or Option and drag it to the toolbar to place it.
��� You can also select whether or not you want to Use Small Size or If you want to see 

Icons. Icons & Text or just Text.

The Menu Bar

The menu bar across the top of the screen contains all the MacDraft pull-down menus 
available.

A rightward pointing triangle beside a menu item indicates that more options relating to 
that menu item are available.
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To choose an Option from a submenu 

��� Choose the menu item that contains the submenu you want to access. 
��� Drag horizontally across and down the submenu until the item you want is high-

lighted, then click the desired item.

8VLQJ�.H\ERDUG�command equivalents

Certain menu items can be chosen directly from the keyboard. The Command key symbol 
and a keyboard character appear beside menu items that can be chosen from the key-
board. 

Choose these menu items by holding down the Command key, then pressing the relevant 
character key on the keyboard. For example, to choose Duplicate (from the Edit menu), 
hold down the Command key and press D (uppercase or lowercase). The Edit menu is 
highlighted for a moment, and a duplicate of the selected object appears (see Appendix B - 
6SHFLDO�XVDJH�RI�NH\V).

The Palettes

0DF'UDIW�3(
V�PRVW�LPSRUWDQW�WRROV�DSSHDU�LQ�WZR�ÁRDWLQJ�SDOHWWHV��7KH�Tool Palette 
and the Dimension Palette. The Attribute, Resize and Alignment palettes control various 
attributes of the objects created using the other palettes and the Library Palette has all the 
Symbols and other items you wish to use in your document.

Resize Palette

Library Palette
Align Palette

Tool Palette

Dimension
 Palette

Attributes Palette
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Using Palettes

7KH�SDOHWWHV�DUH�FDOOHG�ÁRDWLQJ�SDOHWWHV�EHFDXVH�WKH\�FDQ�EH�PRYHG�DURXQG�WKH�VFUHHQ��
DQG�WKH\�ÁRDW�DERYH�WKH�GUDZLQJ�DUHD��DOORZLQJ�\RX�WR�GUDZ�EHQHDWK�WKHP�

Displaying a Palette

To display a Palette 

�� Choose the palette’s name from the Window menu, or 
�� Choose the palette’s name from the pop-up menu at the bottom left of the 

document window. 
The palette appears, and a checkmark appears against its name in the list. 
Checkmarks appear beside the names of palettes that are currently displayed.

Hiding a Palette

You can hide a palette when you no longer need it.
To hide a Palette 

�� Click the palette’s close box in the top left corner the palette window, or
�� Choose the palette’s name from the pop-up menu at the bottom left of the 

document window.
The palette disappears, and the checkmark beside the palette’s name in the list will 
be removed.
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Moving a Palette

You can move a palette around the screen to place it in a more convenient position.
To move a Palette 

��� Position the cursor on the top or left part of the palette, then press and hold down 
the mouse button.

��� Drag the palette to the desired location and release the mouse button.

Using the Palette Tools

7KH�SDOHWWHV�IXQFWLRQ�OLNH�ER[HV�RI�WRROV�WKDW�\RX�FDQ�XVH�WR�HQWHU�WH[W��GUDZ�GLͿHUHQW�
objects and lines, and change objects. Each tool is represented by an icon in a palette. To 
use a tool, you activate, or select, the appropriate icon. 

You can activate any tool in a palette by positioning the pointer on the icon and clicking 
it. As long as the icon is highlighted, you can draw the object or perform the action 
associated with the icon. 

When you start to use MacDraft, each tool has the default current option shown in the 
palette. To change the current tool, choose the desired tool from a pop-up menu that 
shows those available.

Pop-up menus

Each palette holds icons that represent certain tools or functions. Some tools and 
functions have more than one option associated with them. These options relate either to 
KRZ�WKH�REMHFWV�DUH�FUHDWHG�RU�WR�GLͿHUHQW�FKDUDFWHULVWLFV�RI�WKH�REMHFWV��)RU�H[DPSOH��LQ�
the Tool palette the square-corner rectangle options relate to how you create a rectangle; 
either from a corner or from its center. On the other hand, the rounded-corner rectangle 
options relate to the characteristics of the rectangles’ corners; proportional, constant, or 
elliptical. 

The options for each function and tool can be selected from pop-up menus. 

Icons used to open pop-up menus have clipped corners (which appear black). Unlike 
pull-down menus, which are opened by clicking a word in the menu bar, pop-up menus 
are opened by clicking an icon in the palette and holding down the mouse button.

To choose an option from a pop-up menu 

��� Click the appropriate icon in the palette and hold down the mouse button. A pop-
up menu appears.
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��� Holding down the mouse button, drag to the tool that represents the desired 
option.

��� When the desired tool is highlighted, release the mouse button. 

The pop-up menu disappears and the tool icon will be changed to show you the 
currently selected option.

As you drag, the menu items will be highlighted.

Tool Options

Some tools have options associated with them. These can be displayed by holding down 
the Option key and clicking the tool icon, or by selecting the tool and choosing Tool 
Options from the Options menu. See details of individual tools for information about any 
options available.
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The Microspot MacDraft Palettes

Following are brief descriptions of the tools available on the Tool and Dimension palettes.

Tool Palette

Pointer Tool

Use to move and change the shape of objects, make menu choices and activate palette 
functions.

Rotation Tool

Use to rotate a selected object freely (VHH�5RWDWH�WRRO�DQG�5RWDWH�FRPPDQG��&K����S����).

Selection Tool
Use to select objects by drawing a selection rectangle around them (VHH�6HOHFWLQJ�PXOWLSOH�
REMHFWV��&K����S���).

Hand Tool

Use to change the position of a drawing as an alternative to using the scroll bars (see 
&KDQJLQJ�WKH�SRVLWLRQ�RI�WKH�GUDZLQJ�LQ�WKH�GRFXPHQW�ZLQGRZ��&K����S����).

Line Tool

Use to draw straight lines at any angle (unconstrained lines) or lines that are restricted to 
a certain angle (constrained lines) (VHH�'UDZLQJ�EDVLF�OLQHV��&K����S���).

Pointer Tool

Selection Tool

Line Tool

Square - Corner Rectangle Tool

Regular Polygon Tool

Circle Tool

Polygon Tool

Parallel Line Tool

90 Degree Rotation Tool

Zoom Tool

Rotation Tool

Hand Tool

Special Line Tool

Text Tool

Rounded - Corner Rectangle Tool

Arc Tool

Freehand Tool

Marker Symbol Tool

Attribute Tool

1:1 Tool
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Special Line Tool

8VH�WR�GUDZ�OLQHV�WKDW�DUH�SHUSHQGLFXODU�WR��WDQJHQW�WR�RU�RͿVHW�IURP�VRPH�RWKHU�REMHFW��
or lines that start at the mid, end or center point of an existing object (VHH�'UDZLQJ�VSHFLDO�
OLQHV��&K����S���).

Square - Corner Rectangle Tool

Use to draw squares and rectangles with square corners (VHH�6TXDUH�FRUQHU�UHFWDQJOHV��
&K����S���).

Text Tool

Use to add text to a drawing or edit existing text (VHH�7H[W��&K����S����).

Regular Polygon Tool

Use to draw symmetrical objects with from 3 to 16 equal sides, such as triangles, 
hexagons, and octagons (VHH�'UDZLQJ�UHJXODU�SRO\JRQV��&K����S���).

Rounded - Corner Rectangle Tool

Use to draw rounded-corner rectangles or squares (VHH�5RXQGHG�FRUQHU�UHFWDQJOHV��&K����
S���).

Circle Tool

Use to draw circles by diameter (D), by radius (R) or by three (3) points; and concentric 
circles (VHH�'UDZLQJ�FLUFOHV��&K����S���). 

Arc Tool

8VH�WR�GUDZ�DUFV�E\�UDGLXV��5��RU�WKUHH�SRLQWV������HOOLSWLFDO�DUFV��(���DQG�RͿVHW�DUFV��see 
'UDZLQJ�DUFV��&K����S���).

Polygon Tool

Use to draw objects with two or more sides (VHH�'UDZLQJ�LUUHJXODU�SRO\JRQV�DQG�SRO\OLQHV��
&K����S���).

Freehand Tool

Use to draw freehand lines and shapes, including Bezier and spline curves (VHH�'UDZLQJ�
IUHHKDQG�OLQHV��VKDSHV�DQG�FXUYHV��&K����S���).

Parallel Line Tool

8VH�WR�GUDZ�SDUDOOHO�OLQH�ÀJXUHV��ERWK�VLQJOH�VHJPHQWV�DQG�RSHQ�RU�FORVHG�SDUDOOHO�
SRO\JRQ�ÀJXUHV��DQG�H[WUXGHV�SDLUV�RI�OLQHV�IURP�VWUDLJKW�HGJHV��VHH�'UDZLQJ�SDUDOOHO�OLQH�
REMHFWV��&K����S���).
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Marker Symbol Tool

Use to draw a standard marker symbol (VHH�7KH�0DUNHU�6\PERO��&K����S����).

90 Degree Rotation Tool

Use to rotate selected objects by 90° (VHH�5RWDWH�E\�����WRRO��&K����S����).

Attribute Tool

Use to copy and assign object attributes (VHH�&RS\LQJ�DWWULEXWHV�XVLQJ�WKH�$WWULEXWHV�WRRO��
&K����S����). 

Zoom Tool

Use to zoom in or out on areas of a drawing (VHH�=RRPLQJ�LQ�RU�RXW�RQ�D�GUDZLQJ��&K����
S����).

1:1 Tool

6HOHFW�WR�UHWXUQ�WR�D�VLQJOH�PDJQLÀFDWLRQ�YLHZ�RI�WKH�FXUUHQW�GUDZLQJ�DUHD��VHH�����WRRO��
&K����S����). 

Dimension Palette

Vertical DimensionHorizontal Dimension

Perpendicular DimensionSlope Dimension

Radial DimensionDiameter Dimension

Angular DimensionCircle Center Mark

Horizontal Dimension Tool

Use to draw horizontal dimension lines (VHH�+RUL]RQWDO�GLPHQVLRQ�REMHFWV��&K����S����).

Vertical Dimension Tool

Use to draw vertical dimension lines (VHH�9HUWLFDO�GLPHQVLRQ�REMHFWV��&K����S����).

Slope Dimension Tool

Use to draw sloped dimension lines (VHH�6ORSH�GLPHQVLRQ�REMHFWV��&K����S����).
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Perpendicular Dimension Tool

Use to draw dimension lines perpendicular to straight lines and edges (see Perpendicular 
GLPHQVLRQ�REMHFWV��&K����S����).

Diameter Dimension Tool

Use to draw diameter dimension objects (VHH�'LDPHWHU�GLPHQVLRQV��&K����S����).

Radial Dimension Tool

Use to draw radial dimension objects (VHH�5DGLXV�GLPHQVLRQV��&K����S����). 

Circle center mark Tool

Use to draw center mark for circles, arcs and ellipses (VHH�&LUFOH�FHQWHU�PDUNV��&K����S����). 

Angular Dimension Tool

Use to draw angular dimension objects (VHH�$QJXODU�GLPHQVLRQ�REMHFWV��&K����S����).

The Window menu

<RX�FDQ�KDYH�XS�WR����GRFXPHQW�ÀOHV�RSHQ�DW�RQH�WLPH�LQ�0DF'UDIW��7KH�:LQGRZ�PHQX�
provides you with options for displaying multiple document windows and for moving 
easily to a particular open drawing. 

Displaying Multiple Document Windows

Tiling Windows

If you want to see the contents of several document windows at the same time, you 
can choose to show all the windows on the screen at the same time by using the Tile 
command.

To tile windows

�� Choose Tile Windows from the Window menu.
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The open documents will be reduced in size, if necessary, and displayed next to each 
other across and down the screen.

Stacking Windows
If you want to keep the drawing windows open at a reasonable size, and be able to easily 
click a document to bring it to the front of the open documents, you can choose to stack 
the windows.

To stack windows

�� Choose Stack Windows from the Window menu.
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7KH�RSHQ�GRFXPHQWV�ZLOO�EH�GLVSOD\HG�RQH�DERYH�WKH�RWKHU��DQG�VOLJKWO\�RͿVHW�IURP�HDFK�
other.
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Switching to a Particular Open Drawing

To switch to a different drawing or symbol library

��� Open the Window menu.

At the bottom of the Window menu, all the open MacDraft documents will be 
shown, with the active (topmost) drawing indicated by a checkmark.

��� Select the name of the drawing you want to work on. 
The drawing you choose becomes active and will be shown in front of the other 
document windows.
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�   1.5 Getting Started

 MacDraft is a software tool that emulates a drafting board while giving you the advan-
tages of creating and working with scaled images on a computer. You can easily make 
changes without physically erasing or discarding sheets of paper. 

One of MacDraft’s greatest strengths as a drafting and design tool is the way it allows 
\RX�WR�GHÀQH�\RXU�GUDZLQJ�HQYLURQPHQW��8VLQJ�VLPSOH�PHQX�FRPPDQGV�DQG�SDOHWWH�
choices, you can specify the default scale, drawing units and page setup you need for the 
drawing.

The scaled environment automatically keeps track of the size and area of the objects you 
draw. You can display their dimensions using the Show Size feature (VHH�6KRZ�6L]H��&K����
S����), the various dimension tools (VHH�'LPHQVLRQ�REMHFWV��&K����S����), or the on-screen 
rulers (VHH�5XOHUV��&K����S����).

Setting the Units

0DF'UDIW�OHWV�\RX�GHÀQH�GHIDXOWV�WKDW�DͿHFW�RWKHU�0DF'UDIW�GRFXPHQWV��7KH�VHWWLQJV�
\RX�VDYH�DV�DSSOLFDWLRQ�GHIDXOWV�DͿHFW�DOO�GRFXPHQWV��HYHQ�H[LVWLQJ�GRFXPHQWV��EXW�
GRFXPHQW�OHYHO�GHIDXOWV�DͿHFW�RQO\�QHZ�GRFXPHQWV�\RX�RSHQ�

Setting Application Defaults

With MacDraft you can draw using either feet and inches (English) or metric units. 
0DF'UDIW�RͿHUV�WKH�PRVW�FRPPRQO\�XVHG�(QJOLVK�DQG�PHWULF�XQLW�VFDOHV��2QFH�\RX�
FKRRVH�D�XQLW�V\VWHP�IRU�\RXU�GUDZLQJ�\RX�FDQ�GHÀQH�WKH�VFDOH�\RX�ZDQW�WR�XVH��
To set the units for a drawing

��� Open the Layout menu and choose Set Scale/Units.
The Documents Scale & Units dialog appears.
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��� Click the button beside English or Metric, depending on the type of units you want 
to use in the document. 
Whether you use the English or Metric system, you can choose the basic units 
for the drawing: Decimal Inches, Decimal Feet & Inches, Decimal Feet, Fractional 
Inches or Fractional Feet & Inches in English drawings; Millimeters, Centimeters, 
Decimeters or Meters in metric drawings. 

��� If necessary, change the units in the Units pop-up menu.

NOTES:
�� In metric drawings, you can choose Hide Metric Units, which prevent the 

unit abbreviations (mm, cm and so on) from appearing when dimensions are 
displayed on the drawing. 

�� You can also control the number of places displayed behind the decimal point in 
both metric and English decimal drawings (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����
S����).

�� When using fractional inches, the number of decimal places is set only for area 
displays in the show area option in the View menu.
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Setting the Scale

Before starting a drawing, you need to determine the sizes of the objects and the paper 
you are going to use. For large drawings it is impractical to draw objects at their actual 
sizes; it is necessary to reduce them, yet still maintain their proper proportions. 
A scale, the ratio of the object’s size on the drawing to its size in the real world, 
accomplishes this. For example, if you choose a scale ratio of one-quarter inch equals one 
foot (1/4” = 1’), a line drawn ten inches long on a drawing would represent a 40 foot line 
in the real world.

127(��:KHQ�\RX�SDVWH�DQ�H[LVWLQJ�REMHFW�LQWR�D�GUDZLQJ�ZLWK�D�GLͿHUHQW�VFDOH��WKH�
size the object is drawn at will automatically adjust to conform to the scale of the new 
drawing.

To specify the default scale

��� Open the Layout menu and choose Set Scale/Units. The Document Scale & Units 
dialog appears. 

��� Click the Default Scale pop-up menu. The Default Scale pop-up menu shows the 
scales available for the chosen unit system. Select the scale you want. 
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��� The new scale will be displayed. 
��� Click the 2. button to close the dialog and apply the changes.

Setting the Drawing Page Size

You can set a drawing’s page size, page orientation and total size depending on your 
needs. The maximum drawing size for MacDraft PE is 17 by 17 inches.

If necessary, you can create a drawing that will print over several sheets of paper, up to 
the drawing size limit of MacDraft PE. 

The choice of page size is subject to the page sizes available with the currently active 
printer or printing device. For example, if the printer you’ve selected supports only letter 
size and legal-size paper, you cannot print to larger or smaller sheets (VHH�'UDZLQJ�OD\RXW��
&K����S����).
To set the drawing page size and orientation:

��� Choose Page Setup from the File menu.
The Page Setup dialog appears.

��� Select the paper size you want for printing your drawing.
��� Select the page orientation (horizontal or vertical) you want for printing your 

drawing. 
��� Click the 2. button to close the dialog. Your drawing will now have the desired 

page size and orientation assigned.

NOTE: As MacDraft PE has a limited drawing size, if your printer can print to 
large paper sizes, the drawing size may not be as great as a single page.
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Changing the Drawing Size

Open the Layout menu and choose Drawing Size. A dialog appears displaying the current 
total drawing size in the form of a block diagram.

This diagram represents the maximum drawing size available; each block represents 
a single page. The blocks that are darkened indicate the current drawing size. You can 
control the overall size and shape of the drawing by clicking in the diagram.
To change the drawing size

��� Click one of the page blocks and hold down the mouse button. 
��� Drag until you have activated the number of page blocks required for the drawing 

size you want and release the mouse button. 
��� Click the 2. button to close the dialog.

The MacDraft drawing window generally shows only a portion of the overall drawing. 
Therefore, when you change the drawing size it might not be noticeable in the window 
until you zoom out or scroll to another area of the drawing (VHH�=RRPLQJ�LQ�RU�RXW�RQ�D�
GUDZLQJ��&K����S����).
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Rulers and Cursors

MacDraft’s on-screen rulers can help you draw and position objects in precise locations 
on your drawing. They appear along the top and left sides of the drawing window, and 
UHÁHFW�WKH�FXUUHQW�SRVLWLRQ�RI�WKH�ZLQGRZ�GXULQJ�VFUROOLQJ��$W�PDJQLÀHG�YLHZV��]RRPHG�
in or out), they change size accordingly. 
The rulers are especially useful in conjunction with MacDraft’s crosshair drawing cursor. 
The crosshair cursor extends horizontally and vertically across the window, into the 
rulers, when a drawing tool is active.

Rulers

The rulers can show either on-screen sizes (standard rulers) or values that match the 
current scale and units. For example, on a 1/8” = 1' scale, the major scale ruler divisions 
will be in increments of 10 (10 ft., 20 ft., and so on) (VHH�5XOHUV��&K����S����).
To display Microspot MacDraft rulers

�� Choose Show Rulers from the Layout menu 
The rulers will be displayed and a checkmark appears by the Show Rulers 
command in the Layout menu. 

To display scale rulers (if Show Rulers is on)

�� Choose Scale Rulers from the Layout menu.
To display standard rulers (if Show Rulers is on)

�� Choose Standard Rulers from the Layout menu.
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Cursors

To activate the crosshair cursor

�� Choose Cross Cursor from the Options menu. 
When a drawing tool is selected, the crosshair cursor appears. A checkmark 
appears by the Cross Cursor command in the Options menu. 

To activate the small cursor

�� Choose Cross Cursor from the Options menu again.
The checkmark disappears from the Cross Cursor command in the Options menu. 
When a drawing tool is selected, the cursor appears as a small plus sign.

Starting a Drawing

:LWK�WKHVH�VHWWLQJV�LQ�SODFH��\RX·UH�UHDG\�WR�VWDUW�GUDZLQJ��7KH�VHWWLQJV�\RX�GHÀQHG��
units, scale, page setup, drawing size, rulers and drawing cursor remain active until you 
change them. 

(For details on using MacDraft’s drawing tools VHH�&UHDWLQJ�DQG�HGLWLQJ�REMHFWV��&K����S�����
VHH�&KDQJLQJ�WKH�DSSHDUDQFH�RI�REMHFWV��&K����S����, and VHH�$QQRWDWLQJ�\RXU�GUDZLQJ�&K����
S����).

�   1.6 Selecting Objects

You must always select an object before you can make any changes to it. Two 
fundamental principles of using MacDraft are as follows:
��� You select an item. 
��� You choose what to do to the item you have selected. 

)RU�H[DPSOH��LI�\RX�ZDQW�WR�FKDQJH�WKH�OLQH�ZHLJKW�RI�DQ�REMHFW��\RX�ÀUVW�VHOHFW�LW��
then click the line weights pop-up in the Attributes palette and make a selection.

You can select a single object which you want to change or (for some operations) you 
can select multiple objects in order to make the same change to each selected object 
simultaneously. 

Once you have selected an object, small black squares appear on its borders or at each 
end. These squares are called edit handles. For example, a selected rectangle will have 
eight edit handles; a selected line will have one handle at each end point. The following 
procedures will show you various ways of selecting objects on your drawing.
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Activating the Pointer Mode

%HIRUH�\RX�FDQ�VHOHFW�DQ�REMHFW�RQ�\RXU�GUDZLQJ��\RX�PXVW�ÀUVW�DFWLYDWH�WKH�SRLQWHU��7KH�
pointer is used to resize, edit and move objects on a drawing.

Choosing the pointer

To choose the pointer

�� Position the cursor on the Pointer icon in the Tool palette and click it. 

NOTE: When you move the cursor over the Tool palette, the cursor will 
temporarily turn into the arrow pointer to allow you to select a tool.

NOTE: You can also return to the pointer mode by clicking an unused area of the 
drawing (except when the Text tool is active).

Selecting an object

An object is anything that you have created, including rectangles, circles, lines, arcs, 
freehand shapes and text.
To select an object

��� Return to the pointer mode by clicking the Pointer icon or by clicking a blank area 
of your drawing. 

��� Position the tip of the pointer on the object and click.
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��� The object is selected and selection handles appear.

Once the hidden object is selected, you can move it or choose Bring to Front from the 
Arrange menu to move it in front of other objects (VHH�0RYLQJ�REMHFWV�EDFNZDUGV�DQG�
IRUZDUGV��&K����S����).

127(��7R�VHOHFW�D�QRQ�ÀOOHG�REMHFW��SRVLWLRQ�WKH�SRLQWHU�H[DFWO\�RQ�WKH�HGJH�RI�WKH�
object.

Selecting hidden objects

To select an object hidden behind other objects

��� Position the pointer over the hidden object’s estimated location. 
��� Double-click this place (once to select the front object and then once again to select 

the object hidden behind it). 
��� You should now see the handles of the hidden object showing through the visible 

object.
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��� Position the pointer above and to the left (for example) of the objects to be selected. 
��� Holding down the mouse button, drag diagonally across until you have enclosed 

all the objects you want to select in a selection box and release the mouse button.

Selecting multiple objects

Select multiple objects to make the same change to all the selected objects at the same 
time.
To select multiple objects using the Pointer

��� �6HOHFW�WKH�ÀUVW�REMHFW�E\�FOLFNLQJ�LW��
��� Press and hold down the Shift key. 
��� Select additional objects by clicking them, then release the Shift key.

To select multiple objects using the Selection tools

��� Click the Inclusive Selection tool in the Tool palette.
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NOTE: If you choose the Exclusive Selection tool             and drag out a selection box 
to select multiple objects, all objects that the selection box touches will be selected, not 
just those that are completely enclosed.

Deselecting objects

You can use the Shift-click method to deselect selected objects. This capability allows you 
WR�H[FOXGH�D�VSHFLÀF�REMHFW�IURP�D�VHOHFWLRQ�
To deselect an object

��� Return to the pointer mode by clicking the Pointer tool. 
��� Hold down the Shift key. 
��� Click the object you want to deselect and release the Shift key. 

The edit handles will no longer appear on the deselected object.

Select None

To deselect all selected objects, use the Select None command.
To select none

��� Hold down the Shift key. 
The Select All command in the Edit menu will be changed to Select None. 

��� Choose Select None from the Edit menu. 
All objects in the document will be deselected.

Selecting all objects in a document

To select all objects in a document

�� Open the Edit menu and choose Select All. 
Notice that all objects and text in the document are selected. If you choose Select 
All while you are in the text mode and have an insertion point selected in a text 
block, the entire text block will be selected.



Chapter 1 Introduction 32

Selecting text on your drawing

The two techniques for selecting text are: using the I-beam pointer (the text cursor) to 
select all or part of a piece of text; and using the arrow pointer to select a whole text 
object. The steps for each are outlined below. For more details about selecting text, (see 
6HOHFWLQJ�HGLWLQJ�WH[W��&K����S����).
Using the I-beam cursor to select text

��� Activate the Text tool in the Tool palette by clicking it. 

��� Position the I-beam pointer on one side of the text you want to select. 
��� Holding down the mouse button, drag the cursor through the character(s) until all 

the text you want to select is highlighted, and release the mouse button. 
Using the arrow cursor to select text

�� Click with the pointer on a text object. 
Notice that edit handles appear around the text.

�   1.7 Saving and Exporting

Saving Documents

The Save function allows you to save a new document or any changes you have made to 
an existing document.

Saving a document in MacDraft format

Saving and naming  an untitled document

:KHQ�\RX�ÀUVW�FUHDWH�D�QHZ�GRFXPHQW�LW�ZLOO�KDYH�WKH�QDPH�XQWLWOHG�����LQGLFDWHV�WKH�
number of your new document, for example untitled3).

127(��$OWKRXJK�0DF'UDIW�3(�FDQ�RSHQ�ÀOHV�FUHDWHG�LQ�3&�'UDIW�������DQG�ODWHU��3&�
'UDIW�FDQQRW�RSHQ�ÀOHV�FUHDWHG�LQ�0DF'UDIW�3(�YHUVLRQ�����RU�ODWHU���,I�FRPSDWLELOLW\�
with PC draft is needed then you need to use a MacDraft PE version prior to 5.6.)
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To save and name the document

��� Choose Save or Save As from the File menu. 
The standard Save dialog appears. 

��� Specify the location to save the document and enter a name for it. 
��� You may use any character or symbol on the keyboard (except a colon {:} and {/}) 

You can also use uppercase or lowercase characters, with spaces between words. 
��� Click the Save button. 

7KH�GRFXPHQW�ZLOO�EH�VDYHG�DW�WKH�ORFDWLRQ��DQG�ZLWK�WKH�QDPH��VSHFLÀHG�

Save changes made to a previously saved document

While working on your document, you should save it regularly to avoid possible losses.

To save changes made to a previously saved document

�� Select Save from the File menu. 
The document on the disk will be updated to include the changes you have made.

Saving a copy of a document

By using the Save As command you can save an existing document using another name 
without altering your original document.

To save a copy of a  document

��� Choose Save or Save As from the File menu. 
The standard Save dialog appears. 

��� Specify the location to save the document and enter a name for it. 
Specify a location and enter a name for the new document. 

��� Click the Save button. 
7KH�GRFXPHQW�ZLOO�EH�VDYHG�ZLWK�WKH�QDPH�DQG�DW�WKH�ORFDWLRQ�VSHFLÀHG�

Saving a document in another format

127(��$OWKRXJK�0DF'UDIW�3(�FDQ�RSHQ�ÀOHV�FUHDWHG�LQ�3&�'UDIW�������DQG�ODWHU��3&�
'UDIW�FDQQRW�RSHQ�ÀOHV�FUHDWHG�LQ�0DF'UDIW�3(�YHUVLRQ�����RU�ODWHU���,I�FRPSDWLELOLW\�
with PC draft is needed then you need to use a MacDraft PE version prior to 5.6.) See 
$SSHQGL[�&���)LOH�IRUPDWV��$SS�& for information about opening and saving documents 
LQ�GLͿHUHQW�IRUPDWV�
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Saving a document as stationary

0DF'UDIW�DOORZV�\RX�WR�VDYH�VWDWLRQHU\�ÀOHV�ZKLFK�FDQ�DFW�DV�WHPSODWHV�IRU�QHZ�
GRFXPHQWV��)RU�H[DPSOH��\RX�FDQ�FUHDWH�D�ÀOH�FRQWDLQLQJ�FHUWDLQ�LPDJHV��WH[W�DQG�
VHWWLQJV��WKHQ�VDYH�LW�DV�D�VWDWLRQHU\�ÀOH��:KHQ�\RX�RSHQ�WKDW�VWDWLRQHU\�ÀOH��0DF'UDIW�
gives you a new untitled drawing containing the images, text and settings from the 
VWDWLRQHU\�ÀOH��<RX�FDQ�WKHQ�DGG�WR�WKH�GUDZLQJ�DV�UHTXLUHG�IRU�D�VSHFLÀF�VLWXDWLRQ��

8VLQJ�VWDWLRQHU\�ÀOHV�LV�VLPLODU�WR�FUHDWLQJ�D�SDG�RI�VWDWLRQHU\��SHUKDSV�IHDWXULQJ�D�
FRPSDQ\�ORJR�DW�D�SDUWLFXODU�VFDOH��WKHQ�WHDULQJ�RͿ�VKHHWV�RI�SDSHU�WR�XVH�DV�WKH�EDVLV�IRU�
new drawings. 

6HWWLQJV�WKDW�DUH�VDYHG�LQ�D�VWDWLRQHU\�GRFXPHQW�LQFOXGH�WKH�VFDOH��XQLWV��JULG�VQDS��ÀOO�
patterns and colors in the document.

To save a document as stationery

��� Choose Save As from the File menu. 
��� In the standard Save dialog that appears, choose Stationery from the Format pop-

up menu. 
��� (QWHU�D�QDPH�IRU�WKH�ÀOH��
��� Click the Save button.

To ‘tear off’ a piece of stationery to use it for a new document

�� Double-click the stationery document’s icon. 
A new untitled document appears. The new document will contain the settings 
DQG�REMHFWV�GHÀQHG�IRU�WKH�VWDWLRQHU\�GRFXPHQW�

Saving a document in another format

6HH�$SSHQGL[�&���)LOH�IRUPDWV��$SS�& for information about opening and saving documents 
LQ�GLͿHUHQW�IRUPDWV�
To save a document in another format:

To save a document in another format, choose Save from the File menu then select the 
desired format from the Format pop-up menu in the standard Save dialog that appears. If 
DSSURSULDWH�DQ�H[WHQVLRQ�ZLOO�DXWRPDWLFDOO\�EH�DGGHG�WR�WKH�ÀOH�QDPH�DQG�WKH�ÀOH�ZLOO�EH�
VDYHG�LQ�WKH�VSHFLÀHG�IRUPDW�
To open a document in another format:

7R�RSHQ�ÀOHV�LQ�DQRWKHU�IRUPDW��ODXQFK�0DF'UDIW�DQG�FKRRVH�Open from the File menu. 
In the standard Open�GLDORJ��VHOHFW�WKH�GHVLUHG�ÀOH�IRUPDW�IURP�WKH�Format pop-up menu, 
WKHQ�FKRRVH�WKH�ÀOH�WR�RSHQ�
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Exporting a document

The Export File command in the File�PHQX�FDQ�EH�XVHG�WR�H[SRUW�ÀOHV�LQ�DQ\�IRUPDW�
supported by QuickTime Graphic Exporters, for example JPEG and PNG formats.

To H[SRUW�ÀOHV

��� Choose Export File from the File menu. 
A standard dialog appears. 

��� 6HOHFW�WKH�DSSURSULDWH�ÀOH�IRUPDW�IURP�WKH�SRS�XS�PHQX�DW�WKH�ERWWRP�RI�WKH�
dialog.

7KH�UHOHYDQW�H[WHQVLRQ�ZLOO�EH�DGGHG�WR�WKH�ÀOH�QDPH�DQG�WKH�ÀOH�ZLOO�EH�H[SRUWHG�LQ�WKDW�
format. Notice, that some extensions may have extra options available. Click the Options 
button to open the corresponding QuickTime dialog and make additional settings. See 
your QuickTime documentation for further details.

�   1.8 Closing Documents

Closing MacDraft Documents
To close the current document

��� Open the File menu and choose Close. 
If the document contains unsaved changes, a dialog appears asking if you want to 
save changes made to your document before closing it. 

��� Click one of the following buttons:
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�� Click the Save button to close the document and save the changes. 
�� Click the Don’t Save button to close the document without saving the changes. 
�� Click the Cancel button to return to the document.

To close all documents

��� Hold down the Option key. 
The Close command in the File menu will be changed to Close All. 

��� Choose Close All from the File menu. 
If any documents contain unsaved changes, dialogs appear asking if you want to 
save changes made to your documents before closing them. 

��� Click one of the following buttons: 
�� Click the Save button to close the document and save the changes. 
�� Click the Don’t Save button to close the document without saving the changes. 
�� Click the Cancel button to return to the document. 
All the open documents will be closed.

�   1.9 Quitting Microspot MacDraft Personal Edition

:KHQ�\RX�DUH�ÀQLVKHG�XVLQJ�0DF'UDIW�3(�\RX�FDQ�TXLW�WKH�DSSOLFDWLRQ�DQG�UHWXUQ�WR�WKH�
desktop.

To quit MacDraft PE:

��� Open the MacDraft PE application menu and choose Quit MacDraft PE. 
If your open document contains unsaved changes, a dialog appears giving you the 
chance to save changes made to your document before quitting. 

��� Click one of the following buttons: 
�� Click the Save button to save the changes before quitting. 
�� Click the Don’t Save button to quit MacDraft PE without saving the changes. 
�� Click the Cancel button to avoid the Quit command and return to the docu-

ment.
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�   2.1 Getting Started

The Drawing Environment

When you open a new document in MacDraft PE, the following conditions are preset 
unless you use stationery (VHH�6DYLQJ�D�GRFXPHQW�DV�VWDWLRQHU\��&K����S���):
�� Document size is a single sheet of paper. 

�� Scale is set at 1:1 (one inch equals one inch). 
�� Grid lines are shown on the drawing area. 
�� Snap Grid is turned on. 
�� All lines and borders of objects will be drawn with an one-pixel, solid-black line. 
�� All closed rectangles, circles, arcs polygons and freehand objects will be shaded 

ZLWK�D�ZKLWH�ÀOO��2SHQ�REMHFWV�ZLOO�KDYH�QR�ÀOO�
The method of drawing most objects is very similar: choose the tool, decide on a starting 
SRLQW��FOLFN�WKH�PRXVH�EXWWRQ��GUDJ�WR�FUHDWH�WKH�REMHFW��WKHQ�FOLFN�WR�ÀQLVK��'UDZLQJ�
SRO\JRQV��DUFV�DQG�FXUYHV�LV�D�OLWWOH�GLͿHUHQW��6WHS�E\�VWHS�LQVWUXFWLRQV�RQ�KRZ�WR�GUDZ�
and change the size of each type of object are in the following pages.

Chapter 2.0

Creating and Editing Objects

NOTES: 
�� See &KDSWHU�����'UDZLQJ�DLGV��&K����S���� for details of several useful features 

that make your drawing tasks easier. 
�� See &XUVRUV��&K����S��� for details of the crosshair cursor which can be of use 

when drawing objects. 

Cancelling Actions

The current action can be cancelled (in most cases), while it is in progress.
To cancel the current action while it is in progress

�� Hold down the Command key and press the period key (.), or 
�� Press the Escape key

NOTE: As MacDraft PE has a limited drawing size, the drawing size may not 
be as great as a single sheet of paper if the paper size chosen is larger than the 
drawing size limit.
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For example, when drawing a rectangle using a rectangle drawing tool, press Escape or 
Command-period to cancel the entire drawing operation.

Choosing Drawing Tools

The tools used to create objects are located on the Tool palette.

Displaying the Tool palette

If the Tool palette is not shown, you can open it in the following way.

To open the Tool palette 

�� Choose Tool from the Window menu, or 
�� Choose Tool from the pop-up menu at the bottom left of the document window. 

The Tool palette appears.

Selecting Tools

The palette holds icons that represent certain tools. Some tools are stacked with related 
WRROV��7KHVH�SURYLGH�GLͿHUHQW�ZD\V�RI�FUHDWLQJ�WKH�VDPH�W\SH�RI�REMHFW��RU�FUHDWH�VLPLODU�
REMHFWV�ZLWK�VOLJKWO\�GLͿHUHQW�FKDUDFWHULVWLFV��)RU�H[DPSOH��WKH�GLͿHUHQW�VTXDUH�FRUQHU�
rectangle tools relate to how you create a rectangle; either from a corner or from its center. 
On the other hand, the rounded-corner rectangle tools relate to the characteristics of the 
rectangles’ corners; proportional, constant, or elliptical.

Pointer Tool

Selection Tool

Line Tool

Square - Corner Rectangle Tool

Regular Polygon Tool

Circle Tool

Polygon Tool

Parallel Line Tool

90 Degree Rotation Tool

Zoom Tool

Rotation Tool

Hand Tool

Special Line Tool

Text Tool

Rounded - Corner Rectangle Tool

Arc Tool

Freehand Tool

Marker Symbol Tool

Attribute Tool

1:1 Tool
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When you start to use MacDraft PE, each tool has the default option shown on the 
palette. To use a tool, you activate, or select, the appropriate icon. As long as the icon is 
highlighted, you can draw the object associated with the icon. 

You can activate any visible tool in the Tool palette by positioning the pointer on the icon 
and clicking it. To change the current tool in a set, choose the desired item from a pop-up 
menu that shows the tools available. 

To exit a drawing tool mode, click the Pointer icon in the Tool palette, or double click 
without moving the cursor.

Pop-up Menus

The tools in a tool set are accessed by pop-out menus. 

Icons used to access pop-out menus have arrow heads in corners. Pop-up menus are 
opened by clicking an icon in the palette and holding down the mouse button.

To select an option from a pop-up menu 

��� Click the appropriate icon in the Tool palette and hold down the mouse button. 
A pop-up menu appears. 

��� Drag to the menu item that represents the desired tool.

As you drag, the menu items will be highlighted. 
��� When the desired menu item is highlighted, release the mouse button. 

The pop-up menu disappears and the tool icon will be changed to show you the 
currently selected tool.
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Tool Options

Some tools have options associated with them. These can be displayed by holding down 
the Option key and clicking the tool icon, or by selecting the tool and choosing Tool 
Options from the Options menu. See details of individual tools for information about any 
options available.

�   2.2 Drawing Basic Lines

MacDraft PE has two types of line tools: constrained and unconstrained. The constrained 
OLQH�WRROV�DUH�XVHG�WR�GUDZ�VWUDLJKW�OLQHV�WKDW�VQDS�WR�VSHFLÀHG�DQJOH�LQFUHPHQWV��WKH�
unconstrained line tool is used to draw straight lines at any angle. 
Constrained lines can be drawn at increments of 5°, 15°, 30°, 45° and 90°.

Choosing line tools

Line tools are chosen from the Line tools pop-up menu in the Tool palette. 
To choose a line tool 

��� Hold down the mouse button on the line icon on the Tool palette. 
The Line tools pop-up menu appears. 

��� Drag until the type of line you want is highlighted, and release the mouse button. 
The tool you choose appears on the Tool palette.

Constrained Line Tools

Constrained Line Tools

127(��7KH�ÀQDO�SRLQW�RI�D�OLQH�FDQ�EH�VQDSSHG�WR�WKH�PLG�SRLQW��HQG�SRLQW�RU�FHQWHU�
point of some existing objects (VHH�/LQH�VQDSSLQJ��&K����S����).

NOTE: Drawing objects using the Show Size palette and using the Resize palette for 
correcting.
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Drawing unconstrained lines

To choose a line tool 

��� Click the Unconstrained line tool in the Tool palette. (If the Unconstrained line tool 
is not visible, select it from the Line pop-up menu.) 

��� Position the cursor and click the point on the drawing you want the line to begin. 
��� Drag the mouse until the line is of the desired length and click the mouse button to 

ÀQLVK�

NOTE: If you hold down the Shift key while you draw using the Unconstrained line 
WRRO��WKH�OLQH�ZLOO�VQDS�WR���Ý�DQJOHV�

NOTE: If you hold down the Shift key while you draw using a constrained line tool, 
the line can be drawn at any angle.

Drawing Constrained Lines

To draw a constrained line 

��� Choose the line tool showing the desired angle of constraint from the Line pop-up 
menu in the Tool palette. 

��� Position the cursor and click the point on the drawing you want the line to begin. 
��� Drag the mouse until the line is of the desired length and click the mouse button to 

ÀQLVK��
7KH�OLQH�ZLOO�EH�GUDZQ�DW�WKH�DQJOH�VSHFLÀHG��7KH�GLDJUDP�EHORZ�VKRZV�D�OLQH�
FRQVWUDLQHG�WR���Ý�
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Changing the Length of a Line

It is easy to edit a line to change its length.
To change the length of a line 

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the line you want to change. 
��� Position the tip of the pointer on one of the line’s handles. 
��� Holding down the mouse button, drag until the line is the length you want and 

release the mouse button.

Snap to Grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S���), when you 
draw or resize a line, the end of the line will snap to the nearest grid intersection point.
�� Hold down the Command key when drawing or resizing a line to avoid the line 

snapping to the grid. 
�� Hold down the Option key when drawing a line and the line length will increase 

in grid increment steps.
If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw an unconstrained line, it will snap to the angular grid.
�� Hold down the Shift key when drawing an unconstrained line to avoid the line 

snapping to the angular grid.

127(��7KH�&RQVWUDLQHG�OLQH�WRROV�DUH�QRW�DͿHFWHG�E\�WKH�DQJXODU�JULG�
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�   2.3 Drawing Rectangles

Rectangles can be drawn with square or rounded corners.

Square-corner rectangles

Square-corner rectangles can be drawn in two ways: from the corner (Diagonal) or from 
the center (Centered). 

Choosing square-corner rectangle tools

To choose a square-corner rectangle tool: 

��� Hold down the mouse button on the Square-corner rectangle tool in the Tool 
palette. 
The Square-corner rectangle pop-up menu appears.

��� Choose either the Diagonal or the Centered tool and release the mouse button.

Drawing a square-corner rectangle from its corner

When you use the Diagonal tool for drawing a square-corner rectangle, you choose the 
position of one corner of the rectangle, then drag out the rest of the rectangle from that 
corner point.

To draw a rectangle from its corner 

��� Choose the Diagonal square-corner rectangle tool from the Square-corner rectangle 
pop-up menu. 

��� Position the cursor where you want one corner of the rectangle to appear on the 
drawing. 

��� Press the mouse button.

CENTERED
DIAGONAL
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��� Drag in any direction until the rectangle is the desired size, then click the mouse 
EXWWRQ�WR�ÀQLVK�

NOTE: Hold down the Shift key while drawing a rectangle and it will be restricted to 
a square.

NOTE: Hold down the Shift key while drawing a rectangle and it will be restricted to 
a  square. 

Drawing a square-corner rectangle from its centre

When you use the Centered tool to draw a square-corner rectangle, you center the 
UHFWDQJOH�URXQG�D�VSHFLÀHG�SRLQW�RQ�WKH�GUDZLQJ�

To draw a rectangle from its center 

��� Choose the Centered square-corner rectangle tool from the Square-corner 
rectangle pop-up menu. 

��� Position the cursor where you want the center of the rectangle to appear on the 
drawing. 

��� Click the mouse button. 
��� Drag in any direction until the rectangle is the desired size and click the mouse 

EXWWRQ�WR�ÀQLVK�
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NOTE: Hold down the Shift key and resize a rectangle using one of the corner edit 
handles and it will be restricted to its original proportions.

Changing the size of a square-corner rectangle

It is easy to edit a rectangle to change its size.
To change the size of a rectangle:

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the rectangle to resize. 
��� Position the tip of the pointer on one of the edit handles. 
��� Holding down the mouse button, drag until the rectangle is the size you want and 

release the mouse button. 
The rectangle will be resized either diagonally or by its center, depending on the 
tool originally used to draw it.

Snap to Grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize a rectangle, the corners of the rectangle will snap to the nearest grid 
intersection points. 

Hold down the Command key when drawing or resizing a rectangle to avoid the corners 
snapping to the grid.

Rounded-corner rectangles

Rounded-corner rectangles can be drawn with proportional (P), constant (C) or elliptical 
(E) corners. The type of rounded-corner rectangle you choose to draw will be determined 
by the way you wish the size and shape of the corners to change when you edit the 
rectangle.
�� Rounded-corner rectangles with proportional corners
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When you resize a rounded-corner rectangle with proportional corners, the radius 
of the corners will remain proportional to the size of the rectangle as shown below.

�� Rounded-corner rectangles with constant corners 
When you resize a rounded-corner rectangle with constant corners, the corners 
will always have the same radius regardless of the size of the rectangle.

�� Rounded-corner rectangles with elliptical corners 
When you draw a rectangle with elliptical corners, the major and minor axes of 
the elliptical arcs that form the corners are determined by the size of the rectangle; 
the size of the elliptical arcs on the corners grows or shrinks in proportion to the 
rectangle’s size.

Choosing a rounded-corner rectangle tool

Choose the desired tool from the Rounded-corner rectangle pop-up menu.
To choose the Rounded-corner rectangle tool: 

��� Click the Rounded-corner rectangle tool in the Tool palette and hold down the 
mouse button.
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The Rounded-corner rectangle pop-up menu appears.

Proportional Corners
Constant Corners

Elliptical Corners

��� Holding down the mouse button, drag through the menu until the tool you want is 
highlighted, and release the mouse button. 
The icon representing the tool you selected (P for proportional, C for constant, or E 
for elliptical) appears on the palette.

Drawing a rounded-corner rectangle

All the rounded-corner rectangles are drawn in the same way.
To draw a rectangle with the chosen corner style 

��� Choose the desired tool from the Rounded-corner rectangle pop-up menu. 
��� Position the cursor at the point you want one corner of the rectangle to appear on 

your drawing.

��� Press the mouse button. 
��� Drag in any direction until the rectangle is the desired size and click the mouse 

EXWWRQ�WR�ÀQLVK�

NOTE: As the rectangle has rounded-corners this point will determine the 
corner position for the rectangle’s bounding frame.

NOTE: Hold down the Shift key as you draw a rounded-corner rectangle and the 
shape of the rectangle will be restricted to a rounded-corner square.
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Editing rounded-corner rectangles

Changing the size of rounded-corner rectangles

Rounded-corner rectangles can be resized in the same way as square-corner rectangles 
(VHH�&KDQJLQJ�WKH�VL]H�RI�D�VTXDUH�FRUQHU�UHFWDQJOH��&K����S���).

Changing the corner shape of rounded-corner rectangles

When you select a rounded-corner rectangle, an extra edit handle called the corner-edit 
handle appears, normally inside and near the upper left corner. 
This edit handle is used to change the shape of the corners.

To change the corner shape of proportional and constant-corner rectangles

With proportional and constant-corner rectangles, you can drag the corner-edit handle in 
a diagonal direction to change the radius of the corner arc and reshape the rectangle. 

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the rectangle you want to change. 
��� Position the tip of the pointer on the corner-edit handle. 
��� Hold down the mouse button and drag in one of the following directions: 

�� Drag downwards to the right to increase the radius of the corners. 
�� Drag upwards to the left to decrease the radius of the corners.

��� When the corners are the desired shape, release the mouse button.

To change the corner shape of elliptical-corner rectangles

When you draw a rectangle with elliptical corners, the elliptical arcs at the corners cover 
90°. By dragging the corner-edit handle, you can change the radius of the arcs to change 
the shape of the corners. The arcs will still cover 90°. 

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the elliptical-corner rectangle you want to change. 
��� Position the tip of the pointer on the corner-edit handle.
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Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize a rectangle, the corners of the rectangle will snap to the nearest grid 
intersection points. 

Hold down the Command key when drawing or editing a rectangle to avoid the edit 
handles snapping to the grid.

�   2.4 Drawing Regular Polygons

A regular polygon is a closed object with equal sides and angles of equal length. The 
tools can be preset to draw shapes with from 3 to 16 sides. Depending on which regular 
polygon tool you select, you can draw a regular polygon from edge to edge, center to 
edge, vertex to vertex, or center to vertex.

Choosing a regular polygon tool

Choose the desired tool from the Regular polygon tool pop-up menu. 

To choose a regular polygon tool 

��� Click the Regular polygon tool in the Tool palette and hold down the mouse 
button.

��� Holding down the mouse button, drag until the corners are the shape you want 
and release the mouse button. 
Unlike other rectangles with rounded corners, you can drag the corner-edit handle 
on elliptical-corner rectangles in any direction. The direction in which you drag the 
KDQGOH�GHWHUPLQHV�WKH�VKDSH�RI�WKH�FRUQHUV��7KH�ÀJXUH�EHORZ�VKRZV�KRZ�\RX�FDQ�
use the corner-edit handle to reshape the corners. 
�� If you drag the handle to the extreme upper left corner, the corners appear 

almost square. 
�� If you drag the handle to the center, the entire rectangle appears as an ellipse.
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The Regular polygon tool pop-up menu appears.

��� Enter the number of sides desired, then press the 2. button.

Drawing a regular polygon

To draw a regular polygon 

��� Choose the desired tool from the Regular Polygon pop-up menu. 
��� According to the tool chosen, position the cursor at the point you want the center, 

edge or vertex of the polygon to appear on your drawing.

��� Hold down the mouse button, drag through the menu until the tool you want is 
highlighted, and release the mouse button. 
The icon representing the tool you selected appears on the palette. 

Setting the number of sides

The number of sides can be set before drawing the object.

To set the number of sides before drawing a regular polygon 

��� Make sure that nothing is selected on the drawing. 
�� Press and hold down the Option key, then click the Regular polygon icon in the 

Tool palette, or 
�� Click the Regular polygon icon in the Tool palette and select Tool Options from 

the Options menu. 
The Regular Polygon dialog appears.

Vertex to vertex

Center to vertexCenter to edge

Edge to edge
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��� Click the mouse button, drag until the polygon is the desired size and click the 
PRXVH�EXWWRQ�WR�ÀQLVK�

NOTE: Hold down the Shift key while drawing a regular polygon, and the angle of 
the diameter or radius of the polygon will snap to 45° increments. 

NOTE: When you release the mouse button, the polygon is drawn as a single 
grouped object. If necessary, use the Ungroup command in the Arrange menu 
to ungroup the polygon for reshaping, breaking into separate items and so 
on (VHH�*URXSLQJ�DQG�XQJURXSLQJ�REMHFWV��&K����S�������&KDQJLQJ�ÀOOV�DQG�OLQH�
attributes (VHH�&KDQJLQJ�WKH�DSSHDUDQFH�RI�REMHFWV��&K����S���), and resizing can 
be performed while the object is still grouped. 

Changing the size of a regular polygon

It is easy to edit a regular polygon to change its size.

To change the size of a regular polygon 

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the regular polygon to resize. 
��� Position the tip of the pointer on one of the edit handles. 
��� Holding down the mouse button, drag until the regular polygon is the size you 

want and release the mouse button.
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NOTE: Resize a regular polygon using one of the corner edit handles and it will be 
restricted to its original proportions.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize a regular polygon, the cursor will snap to the nearest grid intersection 
point. 
�� Hold down the Command key when drawing or editing a regular polygon to 

avoid the cursor snapping to the grid. 

If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw a regular polygon, its diameter or radius will snap to the angular grid. 
�� Hold down the Shift key when drawing a regular polygon to avoid its diameter or 

radius snapping to the angular grid. 

�   2.5 Drawing Circles

You can draw a circle by its diameter (D), by its radius (R), by three points (3) or 
concentric to an existing circle.

Choosing Circle Tools

Choose how you want to draw circles by selecting one of the tools in the Circle pop-up 
menu. 

To choose a circle tool 

��� Click the Circle icon in the Tool palette and hold down the mouse button. 
The Circle pop-up menu appears.

Circle drawn by three points

Concentric circle tool

Circle drawn by radius

Circle drawn 
by diameter 

��� Holding down the mouse button, drag through the menu until the option you 
want is highlighted and release the mouse button.
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Drawing a circle by diameter

To draw a circle by diameter

��� Choose Diameter from the Circle pop-up menu. 
��� Position the cursor at the point you want to begin drawing the circle. 
��� Click the mouse button, drag until the circle is the size you want, and click the 

PRXVH�EXWWRQ�WR�ÀQLVK�

Drawing a circle by radius

To draw a circle by radius

��� Choose Radius from the Circle pop-up menu. 
��� Position the cursor at the point you want the center of the circle to be on your 

drawing.
��� Click the mouse button, drag until the circle is the size you want, and click the 

PRXVH�EXWWRQ�WR�ÀQLVK�

��� The tool you selected appears in the Tool palette.

NOTE: The other tools in this pop-up menu are used to draw ellipses (VHH�'UDZLQJ�
HOOLSVHV��&K����S���). 

NOTE: Hold down the Shift key while drawing a circle by diameter and the diameter 
will be restricted to 45° increments.
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NOTE: Hold down the Shift key while drawing a circle by radius and the radius will 
be restricted to 45° increments. 

Changing the size of a circle drawn by diameter or radius

After you have drawn a circle by diameter or radius, you can change its size by dragging 
one of its edit handles.

To change the size of a circle drawn by diameter or radius

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the circle you want to change. 
��� Position the tip of the pointer on one of its handles. 
��� Press and hold down the mouse button, drag the handle until the circle is the 

desired size, and release the mouse button.

The circle will be resized either by diameter or by radius, depending on the tool 
originally used to draw it.

Drawing a circle by three points

Use the Circle by three points�WRRO�WR�GUDZ�D�FLUFOH�WKDW�SDVVHV�WKURXJK�WKUHH�VSHFLÀF�
points on your drawing.
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To draw a circle by three points

��� Choose the Circle by three points tool from the Circle pop-up menu in the Tool 
palette. 

��� 3RVLWLRQ�WKH�FXUVRU�RQ�WKH�ÀUVW�SRLQW�WKURXJK�ZKLFK�\RX�ZDQW�WKH�FLUFOH�WR�SDVV��
��� Click the mouse button. 
��� Move to the second point through which you want the circle to pass and click the 

mouse button. 
��� Move the cursor to the third point through which you want the circle to pass and 

click this point.

Three edit handles appear on the circle. The edit handles correspond to the three 
SRLQWV�XVHG�WR�GHÀQH�LW�

Changing the size of a circle drawn by three points

You can change the size of a circle drawn by three points by moving its edit handles.

To change the size of a circle drawn by three points

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the circle you want to resize. 
��� Position the cursor on one of the edit handles. 
��� Press and hold down the mouse button.
��� Drag until the circle is the size you want and release the mouse button.
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The circle will be redrawn to pass through the three points represented by the edit 
handles. 

Snap to Grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize a circle drawn by three points, the edit handles will snap to the nearest 
grid  intersection point. 

Hold down the Command key when drawing or editing a circle to avoid the edit handles 
snapping to the grid.

Drawing concentric circles

With MacDraft’s Concentric circle tool, you can create new circles concentric to existing 
FLUFOHV��VRPHWLPHV�FDOOHG�RͿVHW�FLUFOHV���7KH�FRQFHQWULF�FLUFOH�ZLOO�EH�RI�WKH�VDPH�W\SH�DQG�
have the same line weight, line style and pen model as the original circle. 

Concentric circles can be drawn in relation to any existing circle. Once drawn, a 
concentric circle is an independent circle that can be edited, moved or changed as 
required.

NOTE: The parent circle for the concentric circle must be in place before you choose 
the concentric circle tool. 

To draw a concentric circle

Drawing a concentric circle from an existing circle takes two steps: Selecting the parent 
circle then clicking to specify the distance between the two.
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The cursor returns to ‘Click Circle’, to let you draw more concentric circles. 

��� 7R�H[LW�WKH�RͿVHW�FXUVRU�PRGH��FOLFN�WKH�Pointer icon on the Tool palette. 

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw a concentric circle, the radius of the concentric circle will snap to the nearest grid 
increment.

To draw a circle concentric to an existing circle

��� Choose the Concentric circle tool from the Circle tools pop-up menu in the Tool 
palette. 

The cursor will now read ‘Click Circle’, to let you know that you need to select a 
parent circle. 

��� Click the parent circle. 
The cursor will now read ‘Anchor’ and appears near a dotted copy of the parent 
circle to help you judge the distance between them.

��� Move the cursor until the concentric circle is the desired diameter, then click. As 
you move the cursor, the dotted sketching circle follows it. 
The concentric circle is drawn.
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�   2.6 Drawing Elipses

MacDraft provides two methods of drawing ellipses: diagonal and centered. The two 
W\SHV�RI�HOOLSVHV�GLͿHU�LQ�WKH�ZD\�\RX�GUDZ�DQG�HGLW�WKH�HOOLSVH��7KH�HOOLSVH�WRROV�DUH�
located in the Circle pop-up menu in the Tool palette. When drawn, an ellipse has eight 
HGLW�KDQGOHV��IRXU�RQ�LWV�FLUFXPIHUHQFH�DQG�IRXU�GHÀQLQJ�LWV�ERXQGLQJ�UHFWDQJOH�

Choosing an ellipse tool

To choose an ellipse tool

��� Click the Circle tool in the Tool palette and hold down the mouse button. 
The Circle pop-up menu appears. 

��� Holding down the mouse button, drag until the ellipse tool you require is 
highlighted, and release the mouse button. 
The icon representing the tool selected appears in the Tool palette.

Drawing a diagonal ellipse

To draw a diagonal ellipse click a starting point and drag until the ellipse is the desired 
size and shape.

To draw a diagonal ellipse:

��� Choose the Diagonal ellipse tool from the Circle pop-up menu. 
��� Click the point you want a corner of the ellipse’s bounding rectangle to appear on 

your drawing.
��� Drag in a diagonal direction until the ellipse is the desired size, and click the 

PRXVH�EXWWRQ�WR�ÀQLVK��

Diagonal Ellipse

Centered Ellipse
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Changing the size of an ellipse

You change the size of an ellipse by dragging one of its eight edit handles.

NOTE: Hold down the Shift key as you draw an ellipse and the shape of the ellipse 
will be restricted to a circle. 

NOTE: Hold down the Shift key as you draw an ellipse and the shape of the ellipse 
will be restricted to a circle.

Drawing a centered ellipse

7R�GUDZ�DQ�HOOLSVH�IURP�LWV�FHQWHU��\RX�ÀUVW�VSHFLI\�LWV�FHQWHU�SRLQW��WKHQ�GUDJ�WR�GHÀQH�LWV�
RYHUDOO�VL]H�DQG�VKDSH��7KH�HOOLSVH�LV�SURMHFWHG�IURP�WKH�VSHFLÀHG�FHQWHU�SRLQW�

To draw a centered ellipse

��� Choose the Centered ellipse tool from the Circle pop-up menu. 
��� Click the point you want to be the ellipse’s center. 
��� 'UDJ�XQWLO�WKH�HOOLSVH�LV�WKH�GHVLUHG�VL]H��DQG�FOLFN�WKH�PRXVH�EXWWRQ�WR�ÀQLVK�
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To change the size of an ellipse

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the ellipse you want to resize. 
��� Position the tip of the pointer on one of the edit handles, then press and hold down 

the mouse button.

��� Holding down the mouse button, drag the handle until the ellipse is the size you 
want, and release the mouse button.

NOTE: Hold down the Shift key and resize an ellipse using one of the corner edit 
handles and it will be restricted to its original proportions. 

127(��:KHQ�DQ�DUF�LV�GUDZQ�ZLWK�D�ÀOO��LW�DSSHDUV�DV�DQ�REMHFW�VKDSHG�OLNH�D�SLHFH�
of pie. To draw only the arc line, make sure that no objects are selected, then choose 
´µ��IRU�1R�ÀOO��IURP�WKH�Fill Color�VXEPHQX�RU�´1µ��IRU�1R�ÀOO��IURP�WKH�Fill Pattern 
submenu before you draw the arc. 6HH�2EMHFW�ÀOO�FRORU��&K����S���� and 2EMHFW�ÀOO�
SDWWHUQV��&K����S���� for more information.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize an ellipse, the edit handles will snap to the nearest grid intersection point. 

Hold down the Command key when drawing or editing an ellipse to avoid the edit 
handles snapping to the grid.

�   2.7 Drawing Arcs

You can draw circular and elliptical arcs; circular arcs can be drawn by radius or by three 
points. You can also draw arcs concentric to existing circular arcs.

Choosing an arc tool

Choose the arc tool required from the Arc pop-up menu in the Tool palette.
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To choose an arc tool

��� Click the Arc tool in the Tool palette and hold down the mouse button. 
The Arc pop-up menu appears.

��� Holding down the mouse button, drag through the menu until the desired tool is 
highlighted, and release the mouse button. 
The icon representing the tool chosen appears in the Tool palette.

Arc by Radius

Drawing an arc by radius

7R�GUDZ�DQ�DUF�E\�UDGLXV��ÀUVW�GHÀQH�D�UDGLXV��WKHQ�SURMHFW�WKH�DUF�WKH�GHVLUHG�QXPEHU�RI�
degrees around a circle.

To draw an arc by its radius

��� Choose Arc by radius from the Arc pop-up menu in the Tool palette. 
��� Position the cursor where you want to begin the radius of the arc, then the mouse 

button. 
��� Drag in any direction to draw a line that represents the radius of the arc. 
��� Click the mouse button again. 

$�GRWWHG�FLUFOH�DSSHDUV��7KLV�LV�WKH�FLUFOH�IURP�ZKLFK�\RX�ZLOO�EH�DEOH�WR�GHÀQH�D�
segment for the arc. 

Arc by Radius Elliptical Arc

Concentric ArcArc by 3 points
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��� Move the cursor away from the end of the radius line until you have created an arc 
of the desired number of degrees and click this place.  

NOTE: Hold down the Shift�NH\�ZKLOH�GHÀQLQJ�WKH�DUF·V�UDGLXV�WR�UHVWULFW�WKH�UDGLXV�
to an angle of increments of 45°. 

NOTE: If you drag outside the border of the arc, a line extending from the arc’s 
border to the cursor will be drawn. This line allows you to align the ending 
point of the arc with other points on your drawing.

Changing the size of an arc drawn by radius

You can change the size of an arc drawn by radius either by changing the length of the 
radius or by changing the length of the arc. The following steps and diagrams will show 
\RX�ERWK�PHWKRGV��DV�ZHOO�DV�WKHLU�HͿHFW�RQ�WKH�VKDSH�RI�WKH�DUF�

Changing the radius of an arc drawn by radius
To change the radius

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the arc you want to change. 
��� Position the tip of the pointer on the edit handle in the middle of the arc’s border, 

then press and hold down the mouse button. 
��� Drag until the radius is the length you want and release the mouse button. 

Changing the length of an arc drawn by radius
To change the length

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
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��� Select the arc you want to change. 
��� Position the tip of the pointer on one of the handles at either end of the arc, then 

press and hold down the mouse button. 
��� Drag until the arc is the length you want, then release the mouse button.

NOTE: You cannot create a complete circle using the arc tool. If you drag past 
the beginning of the arc, it will collapse back to a shorter length.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw an arc by radius, the cursor will snap to the nearest grid intersection point. 
�� Hold down the Command key when drawing or resizing an arc drawn by radius 

to avoid the cursor snapping to the grid. 
If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw or edit an arc by radius, the radius line will snap to the angular grid. 
�� Hold down the Shift key when drawing or editing an arc by radius to avoid the 

radius line snapping to the angular grid.

Arc by three points

Drawing an arc by three points

When drawing an arc by three points, you specify three points on the drawing through 
which you want the arc to pass. This tool is useful when you do not know the length of 
WKH�UDGLXV�RI�DQ�DUF��EXW�GR�NQRZ�WKDW�WKH�DUF�VKRXOG�SDVV�WKURXJK�WKUHH�GLͿHUHQW�SRLQWV�
in a drawing.

To draw an arc by three points

��� Choose Arc by 3 points from the Arc pop-up menu in the Tool palette. 
��� 3RVLWLRQ�WKH�FXUVRU�RQ�WKH�ÀUVW�SRLQW�WKURXJK�ZKLFK�\RX�ZDQW�WKH�DUF�WR�SDVV��WKHQ�

click the mouse button. 
��� Move to the second point through which you want the arc to pass. 
��� Click the mouse button. 
��� Move the cursor to the third point through which you want the arc to pass, and 

click this point.
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NOTE: You cannot create a complete circle by using the arc tool. If you drag past the 
beginning of the arc, it will collapse back to a shorter length. 

Changing the size of an arc drawn by three points

You can change the size of an arc drawn by three points by moving any one of the three 
KDQGOHV�WKDW�UHSUHVHQW�WKH�WKUHH�SRLQWV�RULJLQDOO\�XVHG�WR�GHÀQH�WKH�DUF�

To change the size of an arc drawn by three points

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the arc you want to resize. 
��� Position the tip of the pointer on the edit handle you want to move, then press and 

hold down the mouse button.

��� Drag the handle to a new location on the drawing.

��� Release the mouse button.
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��� Move the cursor until you have projected an arc that is the length you want and 
click this point. 

Elliptical Arcs

Drawing an elliptical arc

<RX�FDQ�XVH�WKH�(OOLSWLFDO�$UF�WRRO�WR�FUHDWH�HOOLSWLFDO�DUFV�RI�D�VSHFLÀF�VL]H�DQG�OHQJWK��
:KHQ�\RX�FUHDWH�DQ�HOOLSWLFDO�DUF��\RX�GHÀQH�DQ�HOOLSVH��WKHQ�SURMHFW�DQ�DUF�WKDW�LV�D�
portion of the ellipse. The actual size of the arc is determined by the size of the ellipse and 
the arc’s length is determined by the number of degrees you project it during creation.

To draw an elliptical arc

��� Choose Elliptical arc from the Arc pop-up menu in the Tool palette. 
��� Position the cursor on the point to be used as the center point for the ellipse that 

ZLOO�EH�XVHG�WR�GHÀQH�WKH�DUF��WKHQ�FOLFN�WKH�PRXVH�EXWWRQ��
��� Drag until you have created an ellipse that is the size and shape you want, and 

click the mouse button.

NOTE: A line will extend from the center of the ellipse to the cursor. This is used to 
GHÀQH�WKH�HQGLQJ�DQJOH�RI�WKH�DUF��,I�\RX�GUDJ�RXWVLGH�WKH�HOOLSVH��WKH�OLQH�ZLOO�H[WHQG�
past the ellipse’s border; this allows you to align the ending angle of the arc with 
other points on your drawing.
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The elliptical arc will be drawn.

Changing the starting angle of an elliptical arc

3DUW�RI�WKH�SURFHVV�RI�GHÀQLQJ�HOOLSWLFDO�DUFV�LQYROYHV�GHÀQLQJ�WKH�VWDUWLQJ�DQJOH�RI�WKH�
arc. The starting angle of the elliptical arc is determined by the position of the cursor 
ZKHQ�\RX�UHOHDVH�WKH�PRXVH�EXWWRQ�DIWHU�GHÀQLQJ�WKH�LQLWLDO�HOOLSVH��KRZHYHU��E\�XVLQJ�
the Shift key to constrain the size of the ellipse, you can change the position of the 
starting angle without changing the size of the ellipse.

To change the starting angle of the arc

��� Choose Elliptical arc from the Arc pop-up menu in the Tool palette. 
��� Position the cursor on the point to be used as the center point for the ellipse that 

ZLOO�EH�XVHG�WR�GHÀQH�WKH�DUF��WKHQ�FOLFN�WKH�PRXVH�EXWWRQ��
��� Drag until you have created an ellipse that is the size and shape you want, then 

hold down the Shift key. 
��� Drag the line that marks the starting angle to a new position. 
��� The line marking the starting angle of the arc will follow the cursor’s movement, 

but the ellipse will not be resized. 
��� Click the mouse button and the Shift key when the line is in the desired position 

for the starting angle of the arc. 
��� Move the cursor until you have projected an arc that is the length you want, then 

click this place.

Editing an elliptical arc

There are two ways you can edit an elliptical arc: you can change its shape and you can 
change its length. When you change its shape, you change the major and minor axes 
of the arc. When you change its length, you either increase or decrease the number of 
degrees the arc is projected.
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Changing the length of an elliptical arc

You can use the edit handles on the end points of an elliptical arc to change its length.

To change the length of an elliptical arc:

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the arc you want to change. 
��� Position the tip of the pointer on one of the handles at either end of the arc, then 

press and hold down the mouse button. 
��� Drag until the arc is the length you want, and release the mouse button.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw an elliptical arc, the cursor will snap to the nearest grid intersection point. 

�� Hold down the Command key when drawing or resizing an elliptical arc to avoid 
the cursor snapping to the grid. 

If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw or edit an elliptical arc, the line of the ending angle will snap to the 
angular grid.

Changing the shape of an elliptical arc

You can change the arc’s shape, without moving its end points, by dragging the edit 
handle in the middle of the arc’s border.

To change the shape of an elliptical arc

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the elliptical arc you want to change. 
��� Position the tip of the pointer on the edit handle located in the center of the arc’s 

border, then press and hold down the mouse button. 
��� Drag until the elliptical arc is the shape you want, and release the mouse button.
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�� Hold down the Shift key when drawing or editing an elliptical arc to avoid the 
line of the ending angle snapping to the angular grid. 

Concentric arcs

Using the Concentric arc tool you can create new arcs that are concentric to existing 
circular arcs. The concentric arc will be the same type (radial or three-point) and have the 
same line weight, line style and pen model as the original arc.

Concentric arcs can be created from any circular arc. Once drawn, a concentric arc is an 
independent object that can be edited, moved or otherwise manipulated as required.

NOTE: The “parent” arc for the concentric arc must be in place before you choose the 
Concentric arc tool. 

Drawing a concentric arc

Drawing a concentric arc requires two steps: selecting the source arc and specifying the 
RͿVHW�GLVWDQFH�

To draw an arc concentric to an existing arc

��� Choose the Concentric arc tool from the Arc pop-up menu.

The cursor now reads “Click Arc”, to let you know that you need to select an arc.
��� Click the source arc. 

The cursor now reads “Anchor” and appears near a dotted copy of the source arc, 
which helps you to position the concentric arc.

Concentric Arc
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Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw a concentric arc, the radius of the arc will snap to the nearest grid increment. 
7R�FKDQJH�WKH�LQFUHPHQW��FKRRVH�D�GLͿHUHQW�YDOXH�IURP�WKH�Layout menu’s Set Grid 
submenu.

�   2.8 Drawing irregular polygons and polylines

You can draw two types of multi sided irregular shapes: closed polygons and open 
polylines. Drawing irregular polygons and polylines is discussed in this section, 
information about drawing regular polygons can be found earlier in this chapter (see 
'UDZLQJ�UHJXODU�SRO\JRQV��&K����S���). 
A polygon is a closed object made of three or more sides. It can be a complex, irregularly 
shaped object made up of many straight line segments. A polyline is an open object made 
of at least two straight line segments. The line segments used for either type of object can 
be of any length and drawn at any angle.

Choosing polygon tools

The type of multisided shape you can draw depends on the tool you choose from the 
Polygon pop-up menu in the Tool palette.

��� Move the cursor until the concentric arc is in the desired position.

As you move the cursor, the ‘ghost’ arc gets larger or smaller.

The concentric arc is drawn. The cursor returns to “Click Arc”, allowing you to 
create more concentric arcs if desired. 

NOTE: To exit the Concentric arc tool, click the Pointer icon in the Tool palette.
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To choose a polygon tool

��� Click the Polygon tool in the Tool palette and hold down the mouse button. 
The Polygon pop-up menu appears.

��� Click the mouse button. 
��� Move the cursor to draw the second line segment. 

��� When the second line is the desired length and angle, click this point.

��� Holding down the mouse button, drag until the Irregular polygon or Polyline tool 
is highlighted. 

��� Release the mouse button. 

Drawing an irregular polygon or polyline

7R�GUDZ�DQ�LUUHJXODU�SRO\JRQ�RU�SRO\OLQH��\RX�SRVLWLRQ�WKH�FXUVRU�DQG�FOLFN�WR�GHÀQH�WKH�
end points of the lines that make up the shape.

To draw an irregular polygon or a polyline

��� Choose the Irregular polygon or Polyline tool from the Polygon pop-up menu in the 
Tool palette. 

��� Place the cursor at the point you want to begin drawing the object, then click the 
mouse button. 

��� 0RYH�XQWLO�\RX�KDYH�FUHDWHG�D�OLQH�WKDW�LV�WKH�GHVLUHG�OHQJWK�DQG�DQJOH�IRU�WKH�ÀUVW�
side or line segment of the object.

PolylineIrregular Polygon
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��� Move the cursor to draw the next line segment.

The line will be drawn to the new position. 
����Continue to draw the rest of the object. 

����When you reach the last point to be placed, double-click the point. 
This double-click action completes the object. 
�� If you are drawing an irregular polygon, the last point you clicked will be 

connected to the starting point of the shape by a straight line.

��� When the line is the desired length and angle, click this place. 
You may decide that you want to change a line segment after you have drawn it. 
You can change the length and orientation of the last line segment drawn by using 
the dynamic Editing feature. 

��� 7R�FKDQJH�WKH�ODVW�OLQH�VHJPHQW�GUDZQ��PRYH�WKH�FXUVRU�EDFN�WR�WKH�ODVW�GHÀQHG�
point and click it. 
The previous line will reattach to the cursor, allowing you to move the end of the 
line to a new position on the drawing. 

����Move the cursor to a new position on the drawing and click it. 

NOTE: You can also press the Backspace (Delete) key to delete he last point 
placed. 
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�� If you are drawing a polyline, the object remains open.

NOTES: 
�� Hold down the Shift key while drawing an irregular polygon or polyline and 

the angle of the current line segment will snap to increments of 45°. 
�� 7KH�ÀQDO�SRLQW�RI�D�SRO\OLQH�FDQ�EH�VQDSSHG�WR�WKH�PLG�SRLQW��HQG�SRLQW�RU�

center point of some existing objects (VHH�/LQH�VQDSSLQJ��&K����S����).

Changing the shape of an irregular polygon or a polyline

Irregular polygons and polylines, like other objects, have handles when they are selected 
8QOLNH�PRVW�REMHFWV��WKH\�KDYH�WZR�GLͿHUHQW�NLQGV�RI�KDQGOHV��PDMRU��WKH�KDQGOHV�RQ�WKH�
vertex points or corners) and minor (the handles at the mid points of the line segments). 

A major handle is used to move the end point of a line, which could change both the 
length and angle of the lines connected at that handle. A minor handle is used to move a 
line segment without changing its length or angle.

Changing the shape using the major handles

To change the shape using the major handles

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the irregular polygon or polyline you want to change. 
��� Position the tip of the pointer on one of the major handles, then press and hold 

down the mouse button. 
��� Drag the handle to a new location on the drawing, and release the mouse button.
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When you move the handle, the connecting lines will follow. As soon as you 
release the mouse button, both lines will be redrawn according to the new handle 
location.

As you drag the minor handle, the line moves, but its length and angle remain the 
same.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or edit an irregular polygon or polyline, the ends of the line segments or the edit 
handles will snap to the nearest grid intersection points.

�� Hold down the Command key when drawing or editing an irregular polygon or 
polyline to avoid the lines or edit handles snapping to the grid. 

�� Hold down the Option key when drawing an irregular polygon or polyline and 
the line lengths will snap to the nearest grid increment.

Changing the shape using the minor handles

To change the shape using the major handles

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the irregular polygon or polyline you want to change. 
��� Position the tip of the pointer on one of the minor handles, then press and hold 

down the mouse button. 
��� Drag the handle to a new location on the drawing, and release the mouse button.
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If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw an irregular polygon or polyline, the line segments will snap to the 
angular grid. 
�� Hold down the Shift key when drawing an irregular polygon or polyline to avoid 

the line segments snapping to the angular grid. 

�   2.9 Drawing freehand lines, shapes and curves

$W�WLPHV�\RX�PD\�ZDQW�WR�GUDZ�DQ�REMHFW�WKDW�KDV�D�GLͿHUHQW�VKDSH�WR�WKRVH�SURYLGHG�
for you in the Tool palette. For this reason, four freehand drawing tools are provided: 
Freehand lines, Freehand shapes, Bezier curves and Spline curves. 
�� The Freehand lines tool is used to draw open freehand objects. 
�� The Freehand shape tool is used to draw closed freehand objects. 
�� The Bezier curve�WRRO�LV�XVHG�WR�GUDZ�FXUYHV�WKDW�DUH�GHÀQHG�E\�IRXU�FRQWURO�

points. The curve passes through only two of the control points, the other two 
FRQWURO�SRLQWV�DUH�XVHG�WR�GHÀQH�WKH�VKDSH�RI�WKH�FXUYH��

�� The Spline curve�WRRO�LV�XVHG�WR�GUDZ�FXUYHV�WKDW�DUH�ÀWWHG�WR�D�VHULHV�RI�GHÀQHG�
SRLQWV�RQ�\RXU�GUDZLQJ��7KH�FXUYH�SDVVHV�WKURXJK�DOO�WKH�GHÀQHG��RU�FRQWURO��
points. 

Choosing a freehand drawing tool

Draw either an open freehand line, a closed freehand shape, a Bezier curve or a spline 
curve by choosing the appropriate tool from the Freehand drawing tools pop-up menu in 
the Tool palette.

To choose a freehand drawing tool

��� Click the Freehand drawing tool in the Tool palette, then press and hold down the 
mouse button. 
The Freehand drawing tools pop-up menu appears. 

Freehand Shape Spline Curve

Bezier CurveFreehand Line
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��� Drag until the Freehand line, Freehand shape, Bezier curve or Spline curve tool is 
highlighted. 

��� Release the mouse button. 
The icon representing the tool chosen appears in the palette. 

Freehand lines or shapes

Drawing a freehand line or shape

To draw a freehand line or shape

��� Choose the Freehand line or Freehand shape tool from the Freehand drawing tools 
pop-up menu. 

��� Position the cursor at the point you want to begin drawing, then press and hold 
down the mouse button. 

��� Drag the cursor in any direction, creating a line just as you would with a pencil. 
��� When you have completed the freehand line or shape, release the mouse button. 

�� If you are using the Freehand line tool the object remains open. 
�� If you are using the Freehand shape tool, the start and end points of your 

freehand line will be automatically joined by a straight line.

Closed Freehand 
Shape

Open Freehand 
Shape

Correcting a freehand line or shape while drawing

When you are using the Freehand line or the Freehand shape tool, you can erase portions 
of the line that you are drawing by using the Shift key.

To correct a freehand line

��� When you have made an error while drawing a freehand line, continue to hold 
down the mouse button, but stop drawing the line by ceasing to move the mouse. 

��� Press and hold down the Shift key.
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An icon of an inverted pencil with eraser appears at the end of your freehand line. 
��� Using the mouse to move the eraser, retrace the portion of the line that you want to 

delete. The line will be erased.

��� Release the Shift key to continue drawing the object.

Drawing a straight line as part of a freehand object

The constrained drawing mode for a freehand tool allows you to draw straight line 
segments as part of a freehand object.

To draw a straight line as part of a freehand object

��� Start drawing an object using the Freehand line or Freehand shape tool. 
��� When you want to draw a straight line, hold down the Option key and drag the 

cursor in any direction until you have created a straight line that is the required 
length.

��� Release the Option key.

Changing the shape of a freehand object

You can drag the edit handles of a freehand object to change its shape.

To change the shape of a freehand object

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the freehand object you want to change by clicking it. 
��� Position the tip of the pointer on one of its edit handles, then press and hold down 

the mouse button.
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��� Drag the handle until you have created the shape you want, and release the mouse 
button. 

��� Continue to move other edit handles in the same way until you have obtained the 
shape you want. 

Bezier curves

Drawing using the Bezier curve�WRRO�JLYHV�\RX�D�JUHDW�GHDO�RI�ÁH[LELOLW\�LQ�FUHDWLQJ�
original designs that feature elegant S shapes and loops. 

$�%H]LHU�FXUYH�LV�D�W\SH�RI�FXUYH�GHÀQHG�E\�IRXU�SRLQWV��FDOOHG�´FRQWURO�SRLQWV�µ�7ZR�
FRQWURO�SRLQWV�GHÀQH�WKH�HQG�SRLQWV�RI�WKH�FXUYH��WKH�RWKHUV�GHÀQH�WKH�GLUHFWLRQ�LQ�
which the curve is projected. When you select a Bezier curve, the four control points are 
represented by edit handles on the screen: two handles appear on the end points of the 
curve and two other handles appear on either side of the curve. 

The two handles on the end points are called “end point handles,” and the other two 
handles are called “direction point handles.” You can move the handles to modify and 
change the size of the Bezier curve.

When you create a Bezier curve, direction lines are used to indicate the slope and 
direction of the curves you draw. A direction line is a line between two control points, 
and is tangent to an end point.

Direction point handles

End point handle

Direction point handles

Joint control handle

End point handle
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You can draw a series of Bezier curves using the Bezier curve tool. Each individual curve 
DFWXDOO\�SDVVHV�WKURXJK�RQO\�WKH�WZR�HQG�FRQWURO�SRLQWV��7KH�GLUHFWLRQ�OLQHV�GHÀQH�WKH�
overall shape of the curve. When you draw a series of curves, the curves are connected at 
“joints” or end control points that are shared by two curves. 

Creating Bezier curves

To create a Bezier curve

��� Choose the Bezier curve tool from the Freehand drawing tools pop-up menu in the 
Tool palette.

��� Position the cursor at the point you want the curve to begin, then press and hold 
down the mouse button. 
7KLV�GHÀQHV�WKH�ÀUVW�HQG�FRQWURO�SRLQW�RI�WKH�FXUYH��

��� Drag in the direction you want to project the curve.

A line with a handle at either end will be projected, the curve’s start point being at 
the center of the line. This is a direction line. One of the handles will be attached 
to the cursor. By dragging the handle, you indicate the direction and slope of the 
curve. For example, if you drag the handle down all the way to the lower right 
corner of the screen, a curve sloping toward the lower right corner will result. 

��� Release the mouse button. 
7KH�SRVLWLRQ�RI�WKH�FXUVRU�ZKHQ�\RX�UHOHDVH�WKH�PRXVH�EXWWRQ�GHÀQHV�WKH�ÀUVW�
direction point. 

��� Without pressing down the mouse button, move the cursor to the point you want 
WKH�VHFRQG�HQG�FRQWURO�SRLQW��WKH�HQG�SRLQW�RI�WKH�ÀUVW�FXUYH�DQG�WKH�VWDUW�SRLQW�IRU�
a next curve) to be, then press and hold down the mouse button. As you move the 
cursor the curve appears on the screen. 

��� +ROGLQJ�GRZQ�WKH�PRXVH�EXWWRQ��GUDJ�WR�GHÀQH�WKH�FXUYH·V�VHFRQG�GLUHFWLRQ�SRLQW�
�WKLV�ZLOO�DOVR�GHÀQH�WKH�ÀUVW�GLUHFWLRQ�SRLQW�RI�WKH�QH[W�FXUYH��
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��� Release the mouse button. 
��� To continue drawing curves, repeat steps six and seven above. 
��� :KHQ�\RX�KDYH�GHÀQHG�WKH�FRQWURO�KDQGOH�IRU�WKH�FXUYH·V�ÀQDO�SRLQW��GRXEOH�FOLFN�

to complete the shape.

Correcting a Bezier curve while drawing

When you are using the Bezier curve tool, you can erase portions of the curve that you 
are drawing by using the Shift key.

To correct a Bezier curve

��� When you have made an error while drawing a Bezier curve, continue to hold 
down the mouse button, but stop drawing the curve by ceasing to move the 
mouse. 

��� Press and hold down the Shift key. 
An icon of an inverted pencil with eraser appears at the end of your Bezier curve. 

��� Using the mouse to move the eraser, retrace the portion of the curve that you want 
to delete. The curve will be erased.

7KH�ÀUVW�GLUHFWLRQ�SRLQW�RI�WKH�QH[W�FXUYH�LV�DVVRFLDWHG�ZLWK�WKH�KDQGOH�WKDW�LV�
DWWDFKHG�WR�WKH�FXUVRU��7KH�VHFRQG�GLUHFWLRQ�SRLQW�RI�WKH�ÀUVW�FXUYH�LV�DVVRFLDWHG�
with the handle at the opposite end of the direction line.
7KH�FXUYH·V�VKDSH�ZLOO�FKDQJH�DV�\RX�GHÀQH�WKH�VHFRQG�GLUHFWLRQ�SRLQW�

��� Release the Shift key to continue drawing the object.

NOTE: You can also press the Backspace (Delete) key to delete the last point placed.
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Drawing straight line segments

While drawing Bezier curves, you can draw straight line segments by clicking the mouse 
button instead of dragging the cursor with the mouse button held down.

To create a straight line segment

��� While drawing a Bezier curve, and after you have drawn at least one complete 
curve, move the cursor and click the new place. 
The resulting line will be curved, but the next line will be straight. 

��� Without pressing and holding down the mouse button, move the cursor to where 
you want the end point of the line to be, then click this point. 

��� Continue moving the cursor and clicking to create a series of straight line 
segments.

Modifying Bezier curves

You can modify a Bezier curve by dragging the edit handles. Edit handles appear on 
Bezier curves that are selected. When you move the end point handles, you move the 
end point of the curve; when you drag a direction handle, it exerts a “pull” on the curve 
closest to it and so changes its shape.

Moving the end point of a Bezier curve

To move the end point a Bezier curve

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 

��� Select the Bezier curve object you want to change by clicking it.
Edit handles appear on the selected curve. 

��� Position the tip of the pointer on one of the handles at either end of the curve, then 
press and hold down the mouse button. 

��� Drag until the curve is the length you want, and release the mouse button.

Changing the shape of a Bezier curve

To change the shape of a Bezier curve

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette.
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��� Select the Bezier curve object you want to change by clicking it.

Edit handles appear on the selected curve. 
��� Position the cursor on one of the direction handles, then press and hold down the 

mouse button. 
��� Drag until the curve is the shape you want, and release the mouse button. 

7KH�FXUYH�ZLOO�EH�UHVKDSHG�WR�UHÁHFW�WKH�QHZ�SRVLWLRQ�RI�WKH�GLUHFWLRQ�KDQGOH�

NOTE: Hold down the Shift key while selecting and moving the direction 
handle, and the direction handle and its opposite direction handle will pivot 
around the point on the curve. This will change the shape of the two curves 
controlled by those two direction control points, and will keep the curve 
smooth.

NOTES: 
�� If you drag a direction handle for the end point of a straight line segment, 

you reshape the straight line segment, causing it to become curved. 
�� You can create sharp corners on a Bezier curve by pulling both direction 

handles to one side or by dragging the direction handles of a direction 
line on top of an end control point.

Spline curves

<RX�FDQ�GUDZ�D�W\SH�RI�FXUYH�WKDW�SDVVHV�WKURXJK�D�VHULHV�RI�GHÀQHG�SRLQWV�RQ�\RXU�
drawing. This type of curve, called a spline curve, allows you to pick a series of points on 
D�GUDZLQJ�DQG�ÀW�D�FXUYH�WR�WKRVH�SRLQWV�
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Drawing a spline curve

To draw a spline curve

��� Choose the Spline curve tool from the Freehand drawing tools pop-up menu in the 
Tool palette.

��� Position the cursor at the point you want the spline curve to start, then click the 
mouse button. 

��� Move until you reach one of the points through which you want the curve to pass. 
��� Click the mouse button again. 

A straight line appears between the starting point and the cursor to show you the 
slope of the curve segment. 

��� Move the cursor to the next point you want the curve to pass through and click it. 
$�FXUYH�ZLOO�EH�GUDZQ�WKURXJK�WKH�WKUHH�SRLQWV�GHÀQHG�VR�IDU�

��� &RQWLQXH�PRYLQJ�WKH�FXUVRU�DQG�FOLFNLQJ�WKH�PRXVH�EXWWRQ�XQWLO�\RX�KDYH�GHÀQHG�
all the points the curve is to pass through.

��� When you reach the last point, to complete the spline curve either 
�� Double-click this point or, 
�� Hold down the Command key and click this point.

NOTE: Press the Backspace (Delete) key at any time to delete the last point 
placed.
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Changing the shape of a spline curve

You can change the shape of a spline curve by dragging its control points.

To change the shape of a spline curve

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the spline curve object you want to change by clicking it. 
��� Position the cursor on one of the edit handles (the edit handles represent the 

FRQWURO�SRLQWV�WKDW�ZHUH�XVHG�WR�GHÀQH�WKH�FXUYH���WKHQ�SUHVV�DQG�KROG�GRZQ�WKH�
mouse button.

��� Drag to reposition the control point and modify the curve.

The completed spline curve will be drawn. Edit handles appear on the control 
SRLQWV�XVHG�WR�GHÀQH�WKH�FXUYH�

127(��7R�PDNH�WKH�VSOLQH�FXUYH�D�FORVHG�REMHFW��ÀQLVK�WKH�FXUYH�RQ�WKH�VWDUWLQJ�
point.

��� When the curve is the shape you want, release the mouse button.

�   2.10 Drawing special lines

MacDraft provides a selection of special line tools to make it easy to draw lines in relation 
to existing objects. Lines can be drawn perpendicular to existing lines or edges; from the 
mid, end and center points of existing objects; at a tangent to, or at a tangent between, 
H[LVWLQJ�FLUFOHV�RU�DUFV��RͿVHW�IURP�H[LVWLQJ�OLQHV�
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Choosing special line tools

To draw a perpendicular line; a mid point, end point, or center point line; a tangent line; 
RU�DQ�RͿVHW�OLQH��FKRRVH�WKH�DSSURSULDWH�WRRO�IURP�WKH�Special line tools pop-up menu in 
the Tool palette.

To choose a special line tool

��� Click the Special line tool in the Tool palette, then press and hold down the mouse 
button.
The Special line tools pop-up menu appears.

��� Drag until the desired tool is highlighted. 
��� Release the mouse button. 

The icon representing the tool chosen appears in the palette.

Perpendicular lines

The Perpendicular line tool is used for drawing lines perpendicular to existing lines, 
or perpendicular to the edges of polygons, circles, circular arcs or square-cornered 
rectangles. 

Once a perpendicular line is drawn, it becomes a normal unconstrained line. You can edit 
it, resize it, or move it away from its original position.

Drawing a line perpendicular to an existing object takes two steps: selecting the object to 
draw the line perpendicular to and specifying the end point.

Perpendicular Line 2ͿVHW�/LQH

Tangent Between
Center Point Line

Mid Point Line

End Point Line

Tangent From

NOTE: The “anchoring” object for the perpendicular line must be in place before you 
choose the Perpendicular tool. 
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Drawing perpendicular lines

To draw a line perpendicular to an existing object

��� Choose the Perpendicular line tool from the Special line tools pop-up menu in the 
Tool palette. 

The cursor will now read “Click Line/Arc”, to let you know that you need to select 
a line, circular arc or the edge of an object. 

��� Click the line, arc or object edge that the line is to be drawn perpendicular to. 
The cursor will now read “Click Point”, to let you know that you need to select an 
end point for the perpendicular line. 

��� Move the cursor to the point where you want the perpendicular to end. 
The perpendicular line’s starting point slides along the anchoring edge or line as 
you move the cursor. 

��� Click to specify the end point of the line.

NOTE: It is possible to draw a perpendicular line from a point not on the 
original shape, but on an invisible line or circle extended from it.
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The perpendicular line is then drawn.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw a perpendicular line, the end of the line will snap to the nearest grid intersection 
point.

�� Hold down the Command key when drawing a perpendicular line to avoid the line 
snapping to the grid. 

�� Hold down the Option key when drawing a perpendicular line and the line length 
will snap to the nearest grid increment.

Mid point, end point and center point lines

The Mid point, End point and Center point line tools are used to draw lines from the mid 
point, or end point of an existing straight edge or circular arc, or from the center of an 
existing object. These tools are found in the Special line tools pop-up menu in the Tool 
palette. 

Once a line is drawn with a Mid point, End point or Center point line tool, it becomes a 
normal unconstrained line and can be edited, resized and moved. 

The Mid point and End point line tools can be used with straight-edged objects (lines, 
polylines, polygons and square-corner rectangles) and circular arcs. Any of these objects 
can be part of a group. The Center point line tool can be used with any individual shape.

NOTE: The “anchoring” object for the line must be in place before you choose the Mid 
point, End point or Center point line tool.

Drawing Mid point, End point and Center point lines

Drawing a line from the mid, end or center point of an existing object takes two steps: 
selecting the object to draw the line from and specifying the end point. 
All of these lines are drawn in the same way.
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127(��7KH�ÀQDO�SRLQW�RI�D�PLG�SRLQW��HQG�SRLQW�RU�FHQWHU�SRLQW�OLQH�FDQ�EH�VQDSSHG�
to the mid point, end point or center point of some existing object (VHH�/LQH�VQDSSLQJ��
&K����S����).

To draw a line from the mid, end or center point of an existing object

��� Choose the Mid, End or Center point line tool from the Special line tools pop-up 
menu in the Tool palette.

The cursor will now read “Click Line/Arc” or “Click Object”, to let you know that 
you need to select a line, edge, circular arc or object. 

��� Click the line, edge arc or object that the line is to be drawn in relation to. 
The cursor will now read “Click Point”, to let you know that you need to select an 
end point for the line. 

��� Move the cursor to the point where you want the line to end. 
��� Click to specify the end point of the line. 

The line will be drawn.

Mid Point Line

Center Point Line

End Point Line

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw a mid, end or center point line, the end of the line will snap to the nearest grid 
intersection point.
�� Hold down the Command key when drawing a mid, end or center point line to 

avoid the line snapping to the grid. 
�� Hold down the Option key when drawing a mid point, end point or center point 

line and the line length will snap to the nearest grid increment.
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Tangent Lines

MacDraft provides two ways to draw tangent lines from circles and circular arcs. The 
Tangent from tool draws a tangent from a circle or arc to any point, and the Tangent 
between tool draws a tangent from one circle or arc to another. Both of these tools are 
located in the Special line tools pop-up menu in the Tool palette. 

Once a tangent is drawn, it becomes a normal unconstrained line. You can edit and resize 
it or even move it away from its original position if necessary.

NOTE: The circles or arcs the tangent line is to be drawn in relation to must be in 
place before you choose a tangent line tool. 

Drawing a tangent from a circle or arc to a point

Drawing a tangent from a circle or arc to a point involves two steps: selecting the object 
the line is to be drawn at a tangent to, then specifying the end point for the tangent line.

To draw a tangent from a circle or arc to a point

��� Select the Tangent from tool from the Special line tools pop-up menu in the Tool 
palette.

The cursor now reads “Click Circle/Arc,” to let you know that you need to select a 
circle or arc. 

��� Click the circle or arc. 
The cursor now reads “Click Point,” to let you know that you need to select an end 
point for the tangent line. 

��� Move the cursor; the tangent's starting point slides around the circle or arc. 

Tangent From
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NOTE: Normally the tangent will be drawn clockwise away from the arc or circle. 
You can draw the tangent counterclockwise by holding down the Option key before 
selecting the circle or arc, and keeping the Option key held down until the end point 
LV�VSHFLÀHG�

��� Position the cursor on the point you want the tangent line to end and click it. 
The tangent line is drawn. 

The cursor now reads “1st Circle/Arc”, to let you know that you need to select a 
circle or an arc. 

Tangent Between

NOTE: When drawing a tangent line from an arc, it is possible to draw a 
tangent line from a point not on the visible arc, but on its “invisible circle.” 

Drawing a tangent between circles or arcs

Drawing a tangent from a circle or arc to another circle or arc involves two steps: 
VHOHFWLQJ�WKH�ÀUVW�REMHFW��WKHQ�VHOHFWLQJ�WKH�VHFRQG�REMHFW��
7KH�WDQJHQW·V�ÀQDO�SRVLWLRQ�GHSHQGV�RQ�ZKLFK�KDOI�RI�HDFK�REMHFW�\RX�FOLFN��

To draw a tangent from a circle or arc to another circle or arc

��� Choose the Tangent between tool from the Special line tools pop-up menu in the 
Tool palette.
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��� Click the circle or arc near the desired starting point for the tangent. 

The cursor now reads “2nd Circle/Arc”, to let you know that you need to select 
another object. 

��� Move the cursor to the other object the tangent is to be drawn to and click close to 
the point you want the tangent line to end.

The tangent line is drawn.

127(��7KH�ÀQDO�SDWK�RI�WKH�WDQJHQW�LV�GHWHUPLQHG�E\�ZKLFK�KDOI�RI�HDFK�
object you select. For any pair of circles or arcs, there are four possible tangent 
arrangements, as shown below.



Chapter 2 Creating and Editing Objects91

The cursor now reads “Click Line/Edge”, to let you know that you need to select a 
line or the straight edge of an object.

��� Click the line or edge. 

Offset Lines

MacDraft’s Offset line tool is used to create single lines parallel to existing straight lines 
RU�HGJHV��7KH�RͿVHW�OLQH�ZLOO�KDYH�WKH�VDPH�OHQJWK��DQJOH��OLQH�ZHLJKW��OLQH�VW\OH�DQG�SHQ�
model as the original line or edge.

2ͿVHW�OLQHV�FDQ�EH�FUHDWHG�IURP�DQ\�VWUDLJKW�OLQH�RU�IURP�DQ\�HGJH�RI�D�SRO\JRQ��SRO\OLQH�
RU�VTXDUH�FRUQHUHG�UHFWDQJOH��2QFH�GUDZQ��DQ�RͿVHW�OLQH�LV�DQ�LQGHSHQGHQW�VWUDLJKW�OLQH�
object that can be edited, moved or otherwise manipulated as required.

NOTE: Parallel line objects can be created using the Parallel line tools, VHH�'UDZLQJ�
SDUDOOHO�OLQH�REMHFWV��&K����S���. 

127(��7KH�´SDUHQWµ�REMHFW�IRU�WKH�RͿVHW�OLQH�PXVW�EH�LQ�SODFH�EHIRUH�\RX�FKRRVH�WKH�
RͿVHW�OLQH�WRRO��

Drawing an offset line from an existing object

'UDZLQJ�DQ�RͿVHW�OLQH�IURP�DQ�H[LVWLQJ�REMHFW�LQYROYHV�WZR�VWHSV��VHOHFWLQJ�WKH�VRXUFH�OLQH�
RU�HGJH�DQG�VSHFLI\LQJ�WKH�RͿVHW�GLVWDQFH���

To draw an offset line from an existing object

��� Select the Offset line tool from the Special line tools pop-up menu in the Tool 
palette.
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The cursor now reads “Click Point” and appears near a dotted copy of the source 
OLQH��KHOSLQJ�\RX�WR�GHWHUPLQH�WKH�RͿVHW�GLVWDQFH�

��� 0RYH�WKH�FXUVRU�WR�WKH�GHVLUHG�SRVLWLRQ�IRU�WKH�RͿVHW�OLQH�DQG�FOLFN�LW�

7KH�RͿVHW�LV�D�QRUPDO�XQFRQVWUDLQHG�OLQH��ZKLFK�\RX�FDQ�HGLW�RU�DOWHU�DV�QHHGHG��
<RX�FDQ�DOVR�XVH�LW�DV�WKH�EDVH�IRU�D�QHZ�RͿVHW�OLQH��

��� To exit the Offset line tool, click the Pointer icon in the Tool palette.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
GUDZ�DQ�RͿVHW�OLQH��WKH�RͿVHW�GLVWDQFH�IRU�WKH�OLQH�ZLOO�VQDS�WR�WKH�QHDUHVW�DFWLYH�JULG�OLQH�
�� Hold down the Command�NH\�ZKHQ�GUDZLQJ�DQ�RͿVHW�OLQH�WR�DYRLG�WKH�RͿVHW�

distance for the line snapping to the grid. 
�� Hold down the Option�NH\�ZKHQ�GUDZLQJ�D�OLQH�DQG�WKH�RͿVHW�GLVWDQFH�IRU�WKH�OLQH�

will snap to the nearest grid increment.

�   2.11 Drawing parallel line objects

MacDraft’s Parallel line tools are used to draw single sets of parallel lines or polygons 
and polylines with double lines. You can use parallel lines to create drawings of such 
things as walls, beams and frames. Various options can be set to specify how the parallel 
lines should be drawn.

Choosing parallel line tools

You can use parallel line tools to draw a single set of straight lines, polylines or polygons, 
parallel line objects can also be extruded from existing straight edged objects. The 
appropriate parallel line tool is chosen from the Parallel line tools pop-up menu in the 
Tool palette.

7KH�RͿVHW�OLQH�LV�GUDZQ�
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To choose a parallel line tool

��� Press and hold down the mouse button on the Parallel line tool in the Tool palette. 
The Parallel line tools pop-up menu appears.

��� Holding down the mouse button, drag until the desired tool is highlighted, and 
release the mouse button. 
The tool chosen appears in the Tool palette.

Parallel line tool options

Various options (alignment, end caps, line joints and distance between lines) can be set 
for parallel line objects. These options are found in the Parallel Line Setup dialog.

The parallel line tool options can be set as defaults to be used for all parallel objects 
drawn, or can be changed for some individual existing objects.

Extrude Parallel Polyline

Parallel PolygonParallel Line

Extrude Parallel LineParallel Polyline

NOTE: Parallel line options for extruded parallel line objects cannot be changed once 
they have been drawn. 

Setting default parallel line tool options

To set parallel line tool options to be used for all parallel line objects drawn

��� Ensure that nothing is selected on the drawing. 
��� Either:
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Alignment

There are three alignment choices for parallel line objects: left, center and right. The 
alignment options are represented by three icons at the top of the Parallel Line Setup 
dialog. The small arrow indicates what part of the line is active.

�� Press and hold down the Option key and click the Parallel line tools icon in the 
Tool palette, or 

�� Select a Parallel line tool in the Tool palette and choose Tool Options from the 
Options menu. 

The Parallel Line Setup dialog appears. 
��� Set the various options as desired. A complete description of the options available 

DQG�WKHLU�HͿHFWV�RQ�SDUDOOHO�OLQH�REMHFWV�IROORZV�ODWHU�LQ�WKLV�VHFWLRQ��
��� Click 2. to close the dialog. 

The options set will be used for all parallel line objects drawn.

Setting parallel line tool options for selected objects

To set parallel line tool options for selected objects

��� Select the parallel line object you wish to change the attributes of. 
��� Either: 

�� Press and hold down the Option key and click the Parallel line tools icon in the 
Tool palette, or 

�� Select a Parallel line tool in the Tool palette and choose Tool Options from the 
Options menu. 

The Parallel Line Setup dialog appears. 
��� Set the various options as desired. A complete description of the options available 

DQG�WKHLU�HͿHFWV�RQ�SDUDOOHO�OLQH�REMHFWV�IROORZV�ODWHU�LQ�WKLV�VHFWLRQ��
��� Click 2. to close the dialog. 

7KH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�\RXU�FKRLFHV�

NOTE: Parallel line options for extruded parallel line objects cannot be changed 
once they have been drawn. 
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Select the desired option by clicking the appropriate icon in the Alignment section of the 
Parallel Line Setup dialog. 

Alignment controls how parallel lines, polylines and polygons are drawn and how 
HGLWLQJ�DͿHFWV�WKHP��6SHFLÀFDOO\��WKH�DOLJQPHQW�RSWLRQV�GHWHUPLQH�ZKDW�LV�WKH�OHDGLQJ�
edge of the parallel line object and what part of the shape is active. For example, when 
align left is the current option, the left parallel line will be drawn on the grid and edit 
handles appear on the left line when the parallel lines are selected. 

How the alignment options affect parallel lines 

Align Center 

When Align Center is on, the cursor appears between the lines during drawing. The 
center of the two lines will lie on the grid. When the parallel lines are selected, the edit 
handles appear between the ends of the line segments.

Align Left 

The Align Left option is used to specify which of the parallel lines is active. The active line 
is the one that lies on the grid and is used to edit the parallel lines. If you draw parallel 
lines while the Align Left option is on, the active line is determined by the direction you 
ÀUVW�GUDJ�GXULQJ�WKH�FUHDWLRQ�RI�WKH�VKDSH��,Q�JHQHUDO��LI�\RX�GUDJ�XS��WKH�OHIW�OLQH�LV�
active. If you drag down, the right line is active.

Align Right 

As with Align Left, the Align Right option determines which of the two lines is active. 
When the Align Right�RSWLRQ�LV�RQ��WKH�GLUHFWLRQ�LQ�ZKLFK�\RX�ÀUVW�GUDJ�GXULQJ�FUHDWLRQ�
determines which line is active. In general, if you drag up, the right line is active. If you 
drag down, the left line is active.

Alignment and parallel polylines 

The active alignment option determines how the parallel lines pivot around each ending 
SRLQW��:KHQ�\RX�GHÀQH�WKH�HQGLQJ�SRLQW�IRU�D�VLGH��WKH�HQG�SRLQW�RI�WKH�DFWLYH�OLQH��RU�WKH�
center of the two lines in the case of center alignment) is used as the ending point of the 
side. The inactive line pivots around the ending point, following the movement of the 
mouse.
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End Caps

You can draw parallel lines and polylines with butt end caps, that is, with line segments 
that join the ends of parallel lines. You can choose to draw parallel lines and polylines 
with no end caps, with an end cap at either end or with end caps at both ends. Extruded 
SDUDOOHO�OLQHV�DQG�SRO\OLQHV�FDQ�EH�GUDZQ�ZLWK�RU�ZLWKRXW�D�ÀQDO�HQG�FDS��

Select the appropriate icon from the End Caps section in the Parallel Line Setup dialog.

�� Parallel lines drawn without end caps.

�� End caps at the start of the parallel lines. (That is, the end at which you pressed 
and held down the mouse button and started to draw the lines.)

�� (QG�FDSV�DW�WKH�HQG�RI�WKH�SDUDOOHO�OLQHV���7KDW�LV��WKH�HQG�DW�ZKLFK�\RX�ÀQLVKHG�
drawing the line or shape.) 

�� End caps at both ends of the parallel lines.

NOTE: Extruded parallel lines cannot have end caps at the start of the parallel 
line segment. 

NOTE: Extruded parallel lines cannot have end caps at the start of the parallel 
line segment.
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Parallel lines

You can set the options for parallel lines (alignment, end caps, line joints and distance 
between lines) in the Parallel Line Setup dialog (VHH�3DUDOOHO�OLQH�WRRO�RSWLRQV��&K����S���).

Line joints

You can choose to draw parallel polyline shapes and polygons with line joints at the 
corners. When you choose this option, a line is drawn between the inside and outside 
lines where the sides meet. (This feature can be used to indicate miter joints.) 

Select the appropriate icon from the Line Joints section in the Parallel Line Setup dialog.

Line Width

You can specify the distance between parallel lines by entering a value in the Line Width 
ÀHOG�LQ�WKH�Parallel Line Setup dialog. The values you enter for the distance are real-world 
YDOXHV�WKDW�UHÁHFW�WKH�FXUUHQW�VL]H�XQLWV��)RU�H[DPSOH��LI�\RX�DUH�ZRUNLQJ�RQ�D�GRFXPHQW�
LQ�ZKLFK�)UDFWLRQDO�)HHW�	�,QFKHV�DQG�WKH�VFDOH����µ� ��
�ZHUH�FXUUHQWO\�GHÀQHG��LI�\RX�
entered “6” as the distance, the distance between the lines would represent 6 inches in the 
real world.

NOTE: Extruded parallel lines cannot be drawn with line joints

127(��<RX�FDQ�XVH�SDWWHUQV�DQG�FRORUV�WR�ÀOO�WKH�JDS�EHWZHHQ�SDUDOOHO�OLQHV��See 
3DUDOOHO�ÀOO�SDWWHUQ��&K����S���� and 3DUDOOHO�ÀOO�FRORU��&K����S����. 

With Line 
Joints

Without 
Line Joints
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Drawing a single set of straight parallel lines

To draw a single set of parallel lines

��� Choose the Parallel line icon from the Parallel line tools pop-up menu in the Tool 
palette:

Editing a pair of parallel lines

To edit a pair of parallel lines

��� Return to the pointer mode by clicking the Pointer tool in the Tool palette. 
��� Select the parallel lines to be edited. 
��� Position the cursor on one of the edit handles, then press and hold down the 

mouse button. 
��� Drag in any direction until the lines are the desired length and orientation, and 

release the mouse button.

��� Position the cursor on the point you want the parallel lines to start, then press and 
hold down the mouse button. 

��� Drag until the lines are the desired length, and release the mouse button.

When you release the mouse button, edit handles appear at the ends of the parallel 
line object. These can be used to change the length and orientation of the lines.

Parallel Line

NOTES: 
�� Hold down the Shift key while drawing a single set of parallel lines and 

angle of the lines will snap to 45° increments. 
�� 7KH�ÀQDO�SRLQW�RI�D�SDUDOOHO�OLQH�FDQ�EH�VQDSSHG�WR�WKH�PLG�SRLQW��HQG�

point or center point of some existing objects (VHH�/LQH�VQDSSLQJ��&K����
S����).
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��� Place the cursor at the point you want to begin drawing the object, then click the 
mouse button. 

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or resize a single parallel line, the end of the parallel line will snap to the nearest 
grid intersection point.
�� Hold down the Command key when drawing or resizing a parallel line to avoid 

the line snapping to the grid. 
�� Hold down the Option key when drawing a parallel line and the line length will 

snap to the nearest grid increment.
If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw a parallel line, it will snap to the angular grid.
�� Hold down the Shift key when drawing a parallel line to avoid the line snapping to 

the angular grid. 

Parallel polylines and parallel polygons

You can draw two types of multi sided irregular shapes using parallel lines: closed 
polygons and open polylines. A parallel polygon is a closed object made of three or more 
sides. It can be a complex, irregularly shaped object made up of many straight parallel 
line segments. A parallel polyline is an open object made of at least two straight parallel 
line segments. The line segments used for either type of object can be of any length and 
drawn at any angle. 

You can set the options for parallel polylines and polygons (alignment, end caps, line 
joints and distance between lines) in the Parallel Line Setup dialog (see Parallel line tool 
RSWLRQV��&K����S���).

Drawing polygons and polylines with parallel lines

To draw an irregular polygon or polyline with parallel lines, you position the cursor and 
FOLFN�WR�GHÀQH�WKH�HQG�SRLQWV�RI�WKH�SDUDOOHO�OLQHV�WKDW�PDNH�XS�WKH�VKDSH�
To draw a polygon or a polyline with parallel lines

��� Choose the Parallel polygon or Parallel polyline tool from the Parallel line tools 
pop-up menu in the Tool palette.

Parallel Polyline

Parallel Polygon
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��� Move until you have created a parallel line that is the desired length and angle for 
WKH�ÀUVW�VLGH�RU�OLQH�VHJPHQW�RI�WKH�REMHFW���

��� Click the mouse button. 
��� Without pressing and holding down the mouse button, move the cursor to draw 

the second parallel line segment.

��� When the second parallel line is the desired length and angle, click this point. 
��� Without pressing the mouse button, move the cursor to draw the next parallel line 

segment. 

The parallel line will be drawn to the new position. 
����Continue to draw the rest of the object.

��� When the parallel line is the desired length and angle, click this point. 
You may decide that you want to change a parallel line segment after you have 
FOLFNHG�WR�GHÀQH�LWV�HQG�SRLQW��<RX�FDQ�FKDQJH�WKH�OHQJWK�DQG�RULHQWDWLRQ�RI�WKH�
last parallel line segment drawn by using the Dynamic Editing feature. 

��� To change the last parallel line segment drawn, move the cursor back to the last 
GHÀQHG�SRLQW�DQG�FOLFN�LW�
The previous parallel line will reattach to the cursor, allowing you to move the end 
of the parallel line to a new position on the drawing. 

����Move the cursor to a new position on the drawing and click it.
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����When you reach the last point to be placed, double-click this place. 
This double-click action completes the object. 

�� If you are drawing a parallel polygon, the last point you clicked will be connected 
to the starting point of the shape by a straight parallel line.  

�� If you are drawing a parallel polyline, the object will remain open.  

NOTES:
�� Hold down the Shift key while drawing a parallel polygon or polyline and the 

angle of the current parallel line segment will snap to increments of 45°. 
�� 7KH�ÀQDO�SRLQW�RI�D�SDUDOOHO�SRO\OLQH�FDQ�EH�VQDSSHG�WR�WKH�PLG�SRLQW��HQG�SRLQW�

or center point of some existing objects (VHH�/LQH�VQDSSLQJ��&K����S����). 

Changing the shape of parallel polygons and polylines

You can edit parallel polygons and polylines in the same way as you would normal 
polygons and polylines, VHH�&KDQJLQJ�WKH�VKDSH�RI�DQ�LUUHJXODU�SRO\JRQ�RU�D�SRO\OLQH��&K����
S��� for details.

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS��&K����S����), when you 
draw or edit a parallel polygon or polyline, the ends of the parallel line segments or the 
edit handles will snap to the nearest grid intersection points.
�� Hold down the Command key when drawing or editing a parallel polygon or 

polyline to avoid the lines or edit handles snapping to the grid. 
�� Hold down the Option key when drawing a parallel polygon or polyline and the 

line lengths will snap to the nearest grid increment.
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If there is an angular snapping grid set for the document (VHH�$QJOH�VQDS��&K����S����), 
when you draw a parallel polygon or polyline, the line segments will snap to the angular 
grid.
�� Hold down the Shift key when drawing a parallel polygon or polyline to avoid the 

line segments snapping to the angular grid.

Extruding parallel lines and parallel polylines

MacDraft’s Extrude parallel line and Extrude parallel polyline tools are used to draw 
parallel lines or parallel polylines from existing straight-edged objects, such as lines, 
rectangles or polygons. Although the extruded lines are actually separate line segments, 
they give the appearance of parallel lines.

Lines can also be extruded from parallel-line objects, although the parallel line object 
PXVW�EH�EURNHQ�GRZQ�LQWR�LWV�LQGLYLGXDO�OLQH�FRPSRQHQWV�ÀUVW��7KLV�LV�XVHIXO�LQ�DGGLQJ�
LQWHULRU�ZDOOV�WR�D�ÁRRU�SODQ��IRU�H[DPSOH�

The Extrude parallel line and Extrude parallel polyline tools are located in the Parallel line 
tools pop-up menu in the Tool palette. 

You can set the options for extruded parallel lines and polylines (alignment, end caps, 
line joints and distance between lines) in the Parallel Line Setup dialog (see Parallel line 
WRRO�RSWLRQV��&K����S���).
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Extruding parallel lines from an edge or line

To extrude parallel lines from a straight-edged object or line

��� Choose the Extrude parallel line tool from the Parallel line tools pop-up menu in 
the Tool palette.

Extruding parallel polylines from an edge or line

To extrude parallel polylines from a straight-edged object or line

��� Choose the Extrude parallel polyline tool from the Parallel line tools pop-up menu 
in the Tool palette.

��� Position the cursor over the edge you wish to extrude the parallel polylines from, 
then press and hold down the mouse button. 

��� Drag until you have created an extruded parallel line that is the desired length and 
DQJOH�IRU�WKH�ÀUVW�VHJPHQW�RI�WKH�REMHFW��WKHQ�FOLFN�WKH�PRXVH�EXWWRQ��

��� Continue to draw the extruded parallel polylines as per the instructions for 
drawing parallel polylines (VHH�'UDZLQJ�SRO\JRQV�DQG�SRO\OLQHV�ZLWK�SDUDOOHO�OLQHV��
&K����S���).

��� Position the cursor over the edge you wish to extrude the parallel lines from, then 
click the mouse button. 

��� Drag until the extruded lines are the desired length and orientation, then click the 
mouse button. 

��� The extruded parallel line segment appears on the drawing. It is added to the 
earlier object as a pair of line segments.

Extrude Parallel Line

NOTE: Hold down the Option key to constrain the extruded parallel line to be 
perpendicular to the original edge and make its length snap to the currently 
active grid-snap distance.

Extrude Parallel Polyline
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Extruding parallel lines or polylines from a parallel object

To extrude parallel lines or polylines from a parallel-line object

��� Choose the Extrude parallel line or Extrude parallel polyline tool from the Parallel 
line tools pop-up menu in the Tool palette.

��� Position the cursor over the parallel line object you wish to extrude the parallel 
lines or polylines from, then press and hold down the mouse button. 
An alert appears asking if you wish to break the parallel line object into individual 
lines. 

��� Click the Break Up button to break up the parallel line object and continue 
drawing the extruded parallel line or polylines. 
The dialog will close and you will return to the drawing with the Extrude parallel 
line or Extrude parallel polyline tool still active. 

��� Position the cursor over the line you wish to extrude the parallel lines or polylines 
from, then press and hold down the mouse button. 

��� Continue drawing as for extruded lines, VHH�([WUXGLQJ�SDUDOOHO�OLQHV�IURP�DQ�HGJH�RU�
OLQH��&K����S����, or polylines, VHH�([WUXGLQJ�SDUDOOHO�SRO\OLQHV�IURP�DQ�HGJH�RU�OLQH��
&K����S����.  

Snap to grid

If there is a snapping grid set for the document (VHH�*ULG�VQDS�RQ�SDJH�����), when you 
draw or edit an extruded parallel line or polyline, the ends of the parallel line segments 
or the edit handles will snap to the nearest grid intersection point.
�� Hold down the Command key when drawing or editing an extruded parallel line 

or polyline to avoid the lines or edit handles snapping to the grid. 

Extrude Parallel Polyline

Extrude Parallel Line
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��� Place the cursor where you want the marker symbol to appear on the drawing and 
click this place. 
7KH�PDUNHU�V\PERO�DSSHDUV�RQ�WKH�GUDZLQJ�FHQWHUHG�RQ�WKH�SRLQW�VSHFLÀHG�

��� To add more marker symbols, repeat steps 2 as many times as necessary. 
��� :KHQ�\RX�KDYH�ÀQLVKHG�DGGLQJ�PDUNHUV��FOLFN�WKH�Pointer tool in the Tool palette, 

or hold down the Command key and click a blank area of the drawing. 

�� Hold down the Option key when drawing an extruded parallel line or polyline 
and the initial parallel line segment will be constrained to be perpendicular to the 
original edge, and the line lengths will snap to the nearest grid increment.

�   2.12 The Marker Symbol

The Marker Symbol tool is used to add a registration-type marker to a drawing in one 
simple step.

Select the Marker tool, then click the drawing one or more times to add as many markers 
as you need; each marker is centered on the point you click. Leave the Marker Symbol 
tool by holding down the Command key and clicking a blank area of the drawing or by 
clicking the Pointer tool in the Tool palette. 

Once a marker symbol is drawn, it exists as a group. It can be ungrouped to a circle and 
two crossed lines (VHH�*URXSLQJ�DQG�XQJURXSLQJ�REMHFWV��&K����S����).

Adding marker symbols to a drawing

To add marker symbols to a drawing

��� Choose the Marker symbol tool from the Miscellaneous tools pop-up menu in the 
Tool palette.

Marker Symbol Tool
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�   2.13 Datum Points

Each object in MacDraft has a datum point; this is a reference point used when you paste 
the object, rotate it, or manipulate it in other ways. Grouped objects also have datum 
points. The default datum point for a grouped object is  the default datum point of the 
item in the group that is farthest back on the drawing. 

��� Choose Smooth or Unsmooth (detailed explanations of the choices follow) and 
release the mouse button. 
The object will be reshaped as you requested.

Reshape options

The Smooth and Unsmooth�FRPPDQGV�DͿHFW�GLͿHUHQW�VKDSHV�LQ�GLͿHUHQW�ZD\V�

�   2.14 Reshaping objects

There may be occasions when you want to reshape an object so that straight lines and 
sharp corners become curved lines and rounded corners; the irregular lines of an object to 
smooth lines. You can accomplish this conversion by using the Reshape submenu in the 
Edit menu. 

The objects that the Reshape command can modify are polygons (drawn with the 
irregular polygon tool), polylines, freehand lines and freehand shapes.

Reshaping an object

To reshape an object

��� Select the object you want to reshape by clicking it. 
��� Open the Edit menu and drag down until Reshape is highlighted. 

The Reshape submenu appears.
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Reshaping polygons and polylines

A polygon can be smoothed to a curve that lies inside the original object (intersecting 
the midpoints of each line segment). When the smoothed polygon is selected, its original 
shape appears as a ghost outline. 

A polyline can be smoothed to a curve that intersects the midpoints of each line segment 
of the original object, except for the segments closest to the ends. That is, the curve will 
VNLS�RYHU�WKH�ÀUVW�DQG�ODVW�PLGSRLQWV�RI�WKH�RULJLQDO�SRO\OLQH�

If you select a freehand line or shape that has been smoothed using the Smooth 
command, and choose Unsmooth, the last stage in the smooth process will be undone.

If you select a polygon or polyline that has been smoothed using the Smooth command, 
and choose Unsmooth, the object will revert to its original shape.

Reshaping freehand lines and shapes

A freehand line or shape can be smoothed to a curve that lies close to the original object 
and passes near to the original vertices (the new edit handles appear at the old vertices). 
7KLV�QHZ�VKDSH�FDQ�EH�VPRRWKHG�UHSHDWHGO\�XQWLO�WKH�GHVLUHG�HͿHFW�LV�REWDLQHG�

Freehand Shape Smoothed Freehand Shape

Polyline Smoothed Polyline

Selected Smoothed Polyline

NOTE: A polygon or polyline can be smoothed only once.



Chapter 2 Creating and Editing Objects 108

The Resize palette shows the size values and position of the currently selected object, if 
nothing is selected, the palette will not show any values. The palette can be positioned 
anywhere on screen as needed.

Resizing objects

'LͿHUHQW�W\SHV�RI�REMHFWV�DUH�UHVL]HG�LQ�GLͿHUHQW�ZD\V��)RU�H[DPSOH��\RX�FDQ�UHVL]H�D�
rectangle by specifying the exact height and width of the rectangle, whereas resizing 
an arc includes entering various angle values and a radius length. The individual 
VHFWLRQV�IROORZLQJ�GHVFULEH�WKH�UHVL]LQJ�RSWLRQV�IRU�WKH�GLͿHUHQW�W\SHV�RI�REMHFWV�DQG�WKH�
information you can enter to resize them.

Close Button

�   2.15 Resizing Objects

Objects can be resized manually by dragging their edit handles, as discussed in the 
sections about drawing the various types of objects. MacDraft also includes a Resize 
palette. This provides a method for resizing objects by typing exact size values and gives 
you more precise control over the size of objects on your drawing.

Displaying the Resize palette

To display the Resize palette

�� Choose the palettes name from the Window menu, or 
�� Choose Resize from the pop-up menu at the bottom left of the document window. 

The Resize palette appears.
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You can resize objects by entering absolute or relative values for the whole object or, for 
VRPH�REMHFWV��D�VHOHFWHG�SRLQW�RQ�WKH�REMHFW��0HDVXUHPHQWV�DUH�GHÀQHG�LQ�WKH�FXUUHQW�
layer’s scale and units, and changes are applied relative to the object’s datum point (see 
'DWXP�SRLQWV��&K����S����), unless the Select Point button is used. When relative values 
are entered, positive values increase measurements, negative values decrease them. 

Absolute resize values

�� For a whole object, enter the values for the desired dimensions for the object. 
�� For a point on the object, enter the values for the desired location of the point.

Relative resize values

�� For a whole object, enter values to be added to current dimensions of the object. 
�� For a point on the object, enter values to move the point by.

Resizing a whole object by absolute values

In general terms, to resize an object by changing its absolute size values

��� Select the object you want to resize.

��� Ensure the Absolute radio button is on. 
��� Enter the new size values (such as Width and Height) that you want for the object. 
��� Click the Apply button or press the Return or Enter key. 

The new size will be applied to the object.
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NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds. 

Resizing an object by changing the absolute values of one point

To resize an object by editing a single edit handle

��� Select the object you want to resize. 
��� Ensure the Absolute radio button is on. 
��� Click the Select Pt button on the Resize palette. 

A select point gun sight cursor appears on the drawing. 
��� Position the cursor on the point (edit handle) you want to edit and click it.

The Resize palette shows the location of the point.
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Resizing a whole object by relative values

In general terms, to resize an object by changing its relative size values

��� Select an object. Its current measurements are shown in the Resize palette.

��� Enter values for the new location for the edit handle and click the Apply button or 
press the Return or Enter key. 

The new values will be applied to that edit handle, moving it and so resizing the 
object. 

NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds. 
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��� Click the Relative button in the Resize palette.

��� Enter values to increase (positive numbers) or decrease (negative numbers) the 
measurements to be changed.

��� Click the Apply button or press the Return or Enter key. 
The measurement changes are applied to the object, making the appropriate 
dimensions larger or smaller.
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NOTE: If the resize operation requires the object to be enlarged beyond the 
drawing area, a system beep sounds. 

Resizing an object by changing the relative values of one point

To resize an object by editing a single edit handle

��� Select an object. Its current measurements are shown in the Resize palette. 
��� Click the Relative radio button in the Resize palette. 
��� Click the Select Pt. button in the Resize palette. 

The select point gun sight cursor appears on the drawing. 
��� Position the cursor on the point (edit handle) you want to edit and click it. 

Zeros are shown in the Resize palette for the horizontal and vertical changes, 
showing that no new values have been entered.

��� Enter values to increase (positive numbers) or decrease (negative numbers) the 
point’s position. 

��� Click Apply or press the Return or Enter key. 
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The measurement changes are applied to the selected point, moving it and so 
resizing the object. 

NOTE: If the resize operation requires the object to be enlarged beyond the drawing 
area, a system beep sounds. 

WARNING: If you enter unscaled units in a scaled drawing (for example, a width “4" 
” in a 1/8”=1' drawing), you may get unexpected results (in that example, the four 
inches would appear in the drawing as 1/24 of an inch on screen and on paper). 

Resize Units

The Resize palette uses the scale and units of the current layer. When you select an object 
ZLWK�WKH�5HVL]H�SDOHWWH�YLVLEOH��WKH�YDOXHV�VKRZQ�ZLOO�UHÁHFW�WKH�VFDOH��:KHQ�\RX�HQWHU�
values to resize an object, you should use values appropriate to the current scale. 

If you don’t specify units with the values you enter, MacDraft will interpret the values 
according to the document’s current size units. The size units are set using the Document 
Scale and Units dialog (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����S����). 

Below are some examples of valid size and coordinate entries for some of the available 
types of size units.

Decimal feet and inches

12.0' 
110.3' 
10' 
10 in 
12.3 is interpreted as 12.3'
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Fractional feet and inches

23" = 1’11” 
1 3/4” 
1' 10-3/8” 

Fractional inches

1" 
123-3/4” 
15 1/2 
1/2 
2-1/4 
You can enter values greater than 12 inches if fractional inches are the current size units.

Resizing lines and parallel lines

Lines drawn with the unconstrained, constrained, parallel and special line tools can all be 
resized in the same way. 

Length & angle

&KDQJHV�WKH�GHVLUHG�OHQJWK�DQG�DQJOH�RI�WKH�OLQH��7KH�VSHFLÀHG�DQJOH�LV�PHDVXUHG�UHODWLYH�
WR�WKH�;�D[LV�DQG�WKH�ODVW�SRLQW�GUDZQ�RQ�WKH�OLQH��WKLV�´ÀQLVKLQJ�SRLQWµ��ZLOO�QRUPDOO\�EH�
the one that moves.

Select point

Allows you to select which end point of the line moves when you apply a new length or 
angle value.

NOTE: If you change the angle of a constrained line, it will become an unconstrained 
OLQH��DV�FRQVWUDLQHG�DQG�VSHFLDO�OLQHV�DUH�RQO\�FRQVWUDLQHG�ZKHQ�WKH\�DUH�ÀUVW�HQWHUHG�
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Resizing rectangles

Square corner rectangles

Width and height

Changes the width and height of a rectangle. For example, to enlarge a 1" x 1" rectangle to 
���[�����HQWHU����LQ�ERWK�ÀHOGV��$�GLDJRQDOO\�GUDZQ�UHFWDQJOH�ZLOO�EH�UHVL]HG�E\�VKLIWLQJ�LWV�
bottom edge or right-hand edge (or both).

Select point 

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

Rounded corner rectangles

With proportional and constant corners
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Width, height, and radius

Changes the width and height of a rectangle and the radius of the corner arc. Normally, 
the width and height values resize the rectangle by shifting its bottom edge or right-hand 
edge (or both). 

Select point 

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

With elliptical corners

Width, height, X-radius and Y-radius

Changes the width and height of a rectangle, and the vertical and horizontal radii of 
the elliptical corner arc. Normally, the width and height values resize the rectangle by 
shifting its bottom edge or right-hand edge (or both).

Select point 

Allows you to select which edge or corner of the rectangle moves when you apply a new 
width or height (or both). For example, if you click Select Pt and select the rectangle’s top 
middle handle, then enter a new height, the top edge moves up.

Resizing regular polygons

Regular polygons are resized in the same way as groups (VHH�5HVL]LQJ�JURXSV��&K����S����)
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Diameter

Changes the diameter of the circle. The last point drawn normally moves as the circle is 
resized.

Select point 

Allows you to select which end of the diameter line moves when you apply a new 
diameter value.

Drawn by radius

Radius

Changes the radius of the circle. The handle on the circle’s circumference normally moves 
as the circle is resized.

Select point 

Allows you to select which end of the radius line moves when you apply a new radius 
value. For example, if you click Select Pt and select a radial circle’s center handle, then 
enter a new radius, the center handle moves as the circle is resized.

Resizing circles

Drawn by diameter
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Drawn by three points

X and Y locations

Changes the X and Y coordinates for the circle’s three edit handles. Absolute coordinates 
you specify are measured from the zero origins of the rulers.

Select point 

Use of the Select Pt�EXWWRQ�KDV�QR�DGGLWLRQDO�HͿHFW�RQ�WKLV�REMHFW�

Resizing Ellipses

Width and height

Changes the width and height of an ellipse. A diagonally drawn ellipse will normally be 
resized by shifting its bottom right edit handle, a centered ellipse will normally be resized 
without the center point moving.
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Select point 

Allows you to select what portion of the ellipse moves when you apply a new width or 
height (or both). For example, if you click Select Pt and select the ellipse’s top middle 
handle, then enter a new height, the top moves up.

Resizing arcs

Drawn by radius

1st A°

Changes the angle of the arc’s starting point, measured in relation to the X-axis. 

End A° 

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

Radius

Changes the radius of the arc. 

Select point 

Use of the Select Pt EXWWRQ�KDV�QR�DGGLWLRQDO�HͿHFW�RQ�WKLV�REMHFW�
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X & Y locations

Changes the X and Y coordinates for the arc’s three edit handles. Absolute coordinates 
you specify are measured from the zero origins of the rulers. 

Select point 

Use of the Select Pt�EXWWRQ�KDV�QR�DGGLWLRQDO�HͿHFW�RQ�WKLV�REMHFW�

Elliptical Arcs

Drawn by three points

1st A°

Changes the angle of the arc’s starting point, measured in relation to the X-axis.
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X and Y coordinates

Changes the X and Y coordinates of a selected handle. Absolute values are measured 
from the zero origins of the rulers. 

Select point 

Allows you to select the handle to edit.

End A° 

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

X-radius and Y-radius

Changes the horizontal and vertical radius of the arc. 

Select point 

Use of the Select Pt�EXWWRQ�KDV�QR�DGGLWLRQDO�HͿHFW�RQ�WKLV�REMHFW�

Resizing polygons and polylines, (including parallel polylines and parallel 
polygons), freehand shapes and curves

Because of the complexity of these objects, you can edit them only by using the Select 
Point cursor. 

For example, if an object has several edit handles, each handle cannot be shown in the 
Resize palette. Instead, you use the Select Point button to select a single handle, then 
specify a new location for it on the drawing.

NOTE: The Resize palette treats the direction handles on Bezier curve objects like any 
other edit handles.
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Resizing groups

Percent

Changes the size of the group proportionally by a percentage of its current size. Absolute 
values larger than 100% or positive relative values increase its size; absolute values 
smaller than 100% or negative relative values reduce it. Normally, the lower right corner 
moves as the group becomes larger or smaller. 

Width and height

Changes the width and height of the group. A group will normally be resized by shifting 
its bottom edge or right-hand edge (or both).

Select point

Allows you to select which corner of the groups bounding frame moves when you resize 
it. For example, if you click Select Pt and select the top left handle of the groups bounding 
frame, then enter an absolute percentage value of 200%, the top edge moves up and the 
left edge moves left. 

Resizing groups manually

There may be times when you would like to enlarge or reduce the size of a grouped 
object. MacDraft gives you the ability to change a group’s size proportionally or non- 
proportionally (vertically or horizontally) by dragging the groups edit handles.

By changing the size of a group proportionally, you can maintain the original shapes 
of the individual objects within the group. Objects within the group become larger or 
smaller without becoming distorted.

To resize a group of objects proportionally

��� Select the group you want to resize.
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��� Position the tip of the pointer on one of the edit handles on the corners of the 
group. 

��� Press and hold down the mouse button. 
��� Drag until the group is the size you want, and release the mouse button. 
��� The grouped object will be changed in size proportionally to its original size.

To resize a group non-proportionally

��� Select the group you want to resize. 
��� Position the tip of the pointer on one of the edit handles on the corners of the 

group. 
��� Press and hold down the mouse button and press the Option key. 
��� Holding down the mouse button and the Option key, drag until the group is the 

size you want, and release the mouse button and Option key.

Resizing dimension objects

When objects (not circles) are resized, any dimension objects linked to them will be 
automatically resized as well. Also, when dimension objects are resized, if they are linked 
to an object, the object will also be resized.

Linear and radial dimensions

Length

&KDQJHV�OHQJWK�RI�WKH�GLPHQVLRQ�REMHFW��1RUPDOO\��WKH�ÀUVW�UHIHUHQFH�SRLQW��WKH�OHIW�HQG�RI�
D�GLDPHWHU�RU�WKH�FHQWHU�RI�D�UDGLXV��UHPDLQV�À[HG��

Select point

Allows you to select which reference point moves when you apply a new length.
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1st A°

Changes the angle of the dimension’s starting point, measured in relation to the X-axis.

End A° 

Changes the angle of the dimension’s ending point, measured in relation to the X-axis.

Radius

Changes the radius of the dimension object.

Select point 

Use of the Select Pt EXWWRQ�KDV�QR�DGGLWLRQDO�HͿHFW�RQ�WKLV�REMHFW�

�   2.16 Expand and contract objects

All MacDraft objects can be increased or reduced in size by multiplying or dividing the 
REMHFW·V�GLPHQVLRQV�E\�VSHFLÀHG�YDOXHV��<RX�FDQ�FKRRVH�ZKHWKHU�RU�QRW�WR�PDLQWDLQ�WKH�
object’s proportions. The Expand and Contract commands in the Edit menu are used to 
resize objects in this way. 

Expand

To resize an object using the Expand command

��� Select the object to be expanded. 
��� Choose Expand from the Edit menu.

Angular dimensions
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The Expand dialog appears.

��� To maintain the object’s proportions, ensure that the Linked checkbox is on. 
��� To change the object’s proportions, click the Linked checkbox to turn this option 

RͿ��
��� Enter a value to multiply the X dimension of the object by.

��� (QWHU�D�GLͿHUHQW�YDOXH�WR�PXOWLSO\�WKH�<�GLPHQVLRQ�RI�WKH�REMHFW�E\��LI�QHFHVVDU\��
��� Click the 2. button. 
��� 7KH�GLPHQVLRQV�RI�WKH�REMHFW�DUH�PXOWLSOLHG�E\�WKH�VSHFLÀHG�YDOXHV�DQG�WKH�REMHFW�

is expanded around its center point.

NOTE: If the Linked checkbox is on, the same value will automatically be 
HQWHUHG�LQ�WKH�<�ÀHOG��

NOTE: The screen shot below shows a copy of the original shape in front of the 
expanded shape.

Contract

To resize an object using the Contract command

��� Select the object to be contracted. 
��� Choose Contract from the Edit menu.
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The Contract dialog appears.

��� To maintain the object’s proportions, ensure that the Linked checkbox is on. 
��� To change the object’s proportions, click the Linked checkbox to turn this option 

RͿ��
��� Enter a value to divide the X dimension of the object by.

��� (QWHU�D�GLͿHUHQW�YDOXH�WR�GLYLGH�WKH�<�GLPHQVLRQ�RI�WKH�REMHFW�E\��LI�QHFHVVDU\��
��� Click the 2. button. 
��� 7KH�GLPHQVLRQV�RI�WKH�REMHFW�DUH�GLYLGHG�E\�WKH�VSHFLÀHG�YDOXHV�DQG�WKH�REMHFW�

contracts around its center point.

NOTE: If the Linked checkbox is on, the same value will automatically be 
HQWHUHG�LQ�WKH�<�ÀHOG��

NOTE: The screen shot below shows a copy of the original shape behind the 
contracted shape. 

�   2.17 Editing bitmap images

There may be occasions when you want to enlarge, reduce, distort or clip the shape of 
pictures or photos produced from a program such as Photoshop. MacDraft allows you to 
enlarge or reduce the size of a bitmap image without distorting the image; to change the 
size of a bitmap image in one direction only; and to clip an image. 
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Resizing bitmap images

To resize a bitmap image in one direction only

��� Select the bitmap image you want to resize. 
��� Position the cursor on one of the edit handles in the middle of the bitmap’s 

bounding box, (that is, one of the handles on the top, bottom, left or right side). 
��� Press and hold down the mouse button. 
��� Drag until the bitmap image is the size you want.

��� Release the mouse button. The image will be resized in the direction chosen.
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To resize a bitmap image in two directions without maintaining its proportions

��� Select the bitmap image you want to resize. 
��� Position the cursor on one of the corner edit handles. 
��� Press and hold down the mouse button. 
��� Drag until the bitmap image is the size you want.

To resize a bitmap image while maintaining its proportions

��� Select the bitmap image you want to resize. 
��� Position the cursor on one of the corner edit handles. 

��� Release the mouse button. The image will be resized, in two directions, but it could 
be distorted.
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��� Hold down the Shift key, then press and hold down the mouse button. 
��� Holding down the mouse button and the Shift key, drag until the bitmap image is 

the size you want.

��� Release the mouse button and the Shift key. The image will be resized, and its 
proportions maintained.

To resize a bitmap image using the Resize palette

You can now use the Resize palette to correctly resize your images, by units (physical 
size), pixels or resolution. You can also change the Canvas size for the selected image, 
using the resize palette.
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Absolute and Relative

The Resize palette has 2 available modes when resizing an image or the canvas. 
Absolute allows you to resize the image or canvas with respect to the current size of the 
image being shown. The Relative mode allows you to resize the image or canvas in an 
incremental increase.

Canvas

The Canvas tab allows you to increase the size of the space around the actual image 
ZLWKRXW�HͿHFWLQJ�WKH�LPDJH�LWVHOI��7KLV�ZLOO�WKHQ�DOORZ�\RX�WR�SODFH�D�EDFNJURXQG�FRORU�RU�
border around the image. You can also reposition the image within the canvas using the 
select point button, VHH�5HVL]LQJ�WKH�&DQYDV��&K����S����.

Absolute Relative
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To resize an image using the Resize palette

��� Select the bitmap image you want to resize.
��� Go to the Window menu and select the Resize menu item.

The Resize palette will appear.

��� Type a value into one of the areas may be it be for resizing the pixels, the units 
(physical size) or the Resolution, taking into consideration the recommendations 
below:
�� Locking the resolution: Resizing using the Units or the Pixels with the 

resolution locked will physically change the size of the image on the screen to 
suit.

�� Locking the Units: Resizing the Pixels or Resolution will re-sample the image 
decreasing or increasing the resolution to suit.

�� Locking the Pixels: Resizing the Units or Resolution will re-sample the image 
decreasing or increasing the resolution to suit.

NOTE: To lock the particular values click the padlock icon. A locked set of 
values is depicted by a closed padlock and the unlocked values are denoted by 
an unlocked padlock.
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��� Release the mouse button and the Shift and Option keys. The image will be 
clipped, and only the portion selected will be shown.

Clipping bitmap images

To clip a bitmap image

��� Select the bitmap image you want to clip. 
��� Position the cursor on one of the edit handles. 
��� Hold down the Shift and Option keys, then press and hold down the mouse 

button. 
��� Holding down the mouse button and the Shift and Option keys, drag to select a 

portion of the bitmap.
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MacDraft doesn’t normally discard the unseen part of a cropped image; you can move 
the edit handles back out any time to reveal the unclipped image.  

On the other hand, cutting a cropped image from a drawing, pasting it to the Clipboard, 
then copying it back into MacDraft will reduce the document’s size on disk, because the 
cropped data discarded during the cut/paste operation will no longer be stored.

NOTES: 
�� MacDraft does not allow cropping of grouped objects. You must ungroup any 

bitmap image you wish to crop 
�� Some pixel maps and bitmaps, when ungrouped, become a set of several 

objects that together form one image. Each of these objects can be cropped 
individually. 

�� If a bitmap has a very low resolution (for example, if it has been resized to 
be much larger than it was originally), it may resize itself slightly during 
cropping. This is because its own pixels may be larger than the standard screen 
pixels. The image will expand or shrink so that none of its own large pixels are 
split by the cropped edge. 

�� 0DF'UDIW�VWRUHV�HDFK�SL[HO�PDS�RQO\�RQFH�LQ�HDFK�GRFXPHQW�ÀOH��7KLV�PHDQV�
that you can copy a pixel map within a MacDraft drawing without increasing 
the drawing’s size on disk.

�   2.18 Reversing changes

If you do something unintentionally or want to correct a mistake, MacDraft allows you to 
UHYHUVH�FHUWDLQ�DFWLRQV��7KH�8QGR�FRPPDQG�UHYHUVHV�H[HFXWLRQ�RI�WKH�ODVW�DFWLRQ�RͿHULQJ�
100 levels of undo; the Redo command executes the previously reversed action; the 
Revert command returns you to the last saved version of the document.
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Undo

If you choose a command or perform an action and then wish that you had not done so, 
LQ�PRVW�FDVHV�\RX�FDQ�FKRRVH�8QGR�WR�UHYHUVH�WKH�DFWLRQ�RU�WKH�HͿHFWV�RI�WKH�FRPPDQG��
There are 100 levels of Undo in MacDraft. 

To undo an action or command

�� Open the Edit menu and choose Undo. 
If the action or command can be undone, the command will be listed beside Undo 
at the top of the Edit menu (Undo Delete after a deletion, for example). 
If the action or command cannot be undone, Undo will be dimmed in the Edit 
menu. 

Redo

You can use the Redo command to re-execute an action or command that you just 
reversed using the Undo command. By using Undo and Redo you can experiment with 
your drawing and MacDraft’s features. For example, you could delete an object, observe 
WKH�HͿHFW�RQ�\RXU�GUDZLQJ��DQG�FKRRVH�Undo to reverse the deletion. If you then decided 
WKDW�WKH�GHOHWLRQ�SURGXFHG�WKH�GHVLUHG�HͿHFW��\RX�FRXOG�FKRRVH�Redo and the same object 
would be re-deleted.

To redo an action or command

�� Open the Edit menu and choose Redo. 
The action or command you just reversed by choosing Undo will be listed beside 
Redo at the top of the Edit menu (Redo Delete after undoing a delete, for example).
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�   2.19 Drawing views 

0DF'UDIW�RͿHUV�YDULRXV�IHDWXUHV�IRU�FKDQJLQJ�WKH�YLHZ�RI�\RXU�GUDZLQJ��8VLQJ�WKHVH�
IHDWXUHV�\RX�FDQ�PRYH�WKH�GUDZLQJ�LQ�WKH�GRFXPHQW�ZLQGRZ�VR�WKDW�\RX�YLHZ�D�GLͿHUHQW�
part of the drawing, or you can zoom in or out on a portion of the drawing to see it in 
more detail or to see an overall view. Any view can be saved.

Changing the position of the drawing in the document window

To change the position of the drawing within the document window, you can scroll the 
drawing, use the Hand tool or use the arrow keys on the keyboard.

Revert

If you execute a command that cannot be undone using the Undo command, or you make 
changes you are unable to delete but do not wish to save, you can eliminate any unsaved 
changes by reverting to the last saved version of your document.

To revert to a previously saved version of your document

��� Open the File menu and choose Revert. 
$�GLDORJ�DSSHDUV�DVNLQJ�\RX�WR�FRQÀUP�WKDW�\RX�ZDQW�WR�SURFHHG��7KH�GLDORJ�ZLOO�
show you the date and time when the document was last saved. 

��� Click one of the following buttons 
�� Revert: To revert to the last saved version of the document. 
�� Cancel: To return to the current version of your document. 

WARNING: If you revert to a previously saved version of the document, all 
changes made since the last time it was saved will be deleted. 

NOTE: You can easily return to the top left corner of your drawing by using the Home 
View command (VHH�+RPH�YLHZ��&K����S����). 

Scrolling

Scrolling in MacDraft drawings is accomplished just as it is in other Macintosh document 
windows by using the scroll bars at the edges of the windows. See your system 
documentation for details.
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The Hand tool

The Hand tool provides an alternative method of moving the drawing within the 
document window.

To use the Hand tool

��� Click the Hand tool in the Tool palette. 

The cursor turns into a hand. 
��� Position the cursor over the drawing area, then press and hold down the mouse 

button.

��� Drag in any direction.

Hand Tool

Pointer Tool
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��� Release the mouse button when the desired section of the drawing is shown in the 
document window.

The view moves with the hand.

NOTE: You can also activate the Hand tool by pressing the space bar while the 
Pointer tool is on. 

Zooming in or out on a drawing

When you work with a large document you may need to see the entire drawing at one 
time or you might need to obtain a close up view of a particular area so that you can add 
small details. MacDraft gives you the possibility to change the view of your drawing 
in either of these cases by providing features that allow you to zoom in or out on an 
area of the drawing. Zoom controls are provided via the Zoom tool in the Tool palette, 
by commands in the View menu and by a pop-up menu at the bottom of the document 
window. There are also features that allow you to easily return to a preset or saved view.  

MacDraft usually allows you to magnify a drawing up to 32 times, or down to -8 times its 
normal size.
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127(��7KH�FXUUHQW�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�LV�VKRZQ�DW�WKH�ERWWRP�RI�WKH�
document window. 

NOTE: If you zoom out several consecutive times, and have text on your drawing, the 
text becomes too small to be displayed and only its edit handles will be shown.

Using the Zoom tool 

Zoom Tool

Click the Zoom tool in the Tool palette to select it.

Zoom In

To use the Zoom tool to zoom in on an area of the drawing

��� Select the Zoom tool. 
The cursor will change to a magnifying glass with a plus sign inside it to show that 
\RX�DUH�DERXW�WR�LQFUHDVH�WKH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�



Chapter 2 Creating and Editing Objects 140

Zoom Out

To use the Zoom tool to zoom out on an area of the drawing

��� Select the Zoom tool. 
��� Press and hold down the Option key. 

The cursor will change to a magnifying glass with a minus sign inside it to show 
WKDW�\RX�DUH�DERXW�WR�GHFUHDVH�WKH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ��

��� Position the cursor over the area of the drawing you wish to zoom out on and 
click. 

��� Position the cursor over the area of the drawing you wish to zoom in on and click.

7KH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�ZLOO�EH�LQFUHDVHG�RQH�OHYHO��DQG�WKH�YLHZ�
will be centered around the position of the cursor.
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7KH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�ZLOO�EH�GHFUHDVHG�RQH�OHYHO��DQG�WKH�YLHZ�
will be centered around the position of the cursor. 

��� Continue clicking to zoom out further.

Marquee zoom

The Zoom tool can also be used to perform marquee zooms.

To use the Zoom tool to perform a marquee zoom

��� Select the Zoom tool. 
The cursor will change to a magnifying glass with a plus sign inside it to show that 
\RX�DUH�DERXW�WR�LQFUHDVH�WKH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ��

��� Position the cursor over the drawing. 
��� Press and hold down the mouse button, and drag over the area you want to zoom 

in on.

The inner rectangle shown in the screen shot above is the area selected with the 
Zoom tool. The outer rectangle represents the actual area that will be shown in the 
document window when the mouse button is released.
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��� Release the mouse button to display the portion of the document selected.

Zoom commands

The Zoom commands are found in the Zoom submenu in the View menu. 

NOTE: You can choose Zoom commands several consecutive times, each time further 
LQFUHDVLQJ�RU�GHFUHDVLQJ�WKH�OHYHO�RI�PDJQLÀFDWLRQ�RI�\RXU�YLHZ�
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Zoom Out

To use the Zoom out commands

�� Choose Zoom Out 2X or Zoom Out 4X from the Zoom submenu in the View menu. 
7KH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�ZLOO�EH�GHFUHDVHG�E\�WKH�VSHFLÀHG�DPRXQW��

Zoom In

To use the Zoom in command

��� Choose Zoom In 2X or Zoom In 4X from the Zoom submenu in the View menu. 

7KH�YLHZ�ÀQGHU�ER[�DQG�D�FURVV�FXUVRU�DSSHDUV�RQ�\RXU�GUDZLQJ��7KLV�JLYHV�\RX�
a visual indication of the portion of your drawing that will be included in the 
PDJQLÀHG�YLHZ��

��� 0RYH�WKH�FXUVRU�WR�SRVLWLRQ�WKH�YLHZ�ÀQGHU�RYHU�WKH�DUHD�RI�WKH�GUDZLQJ�\RX�ZDQW�
to zoom in on and click.
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7KH�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�ZLOO�EH�LQFUHDVHG�E\�WKH�VSHFLÀHG�DPRXQW��DQG�WKH�
selected portion will be shown in the document window. 

127(��,I�WKH�FRPSOHWH�]RRPHG�LQ�YLHZ�ZLOO�ÀW�LQ�WKH�GRFXPHQW�ZLQGRZ��WKH�YLHZ�
ÀQGHU�ZLOO�QRW�EH�GLVSOD\HG��WKH�QHZ�YLHZ�ZLOO�EH�GLVSOD\HG�LPPHGLDWHO\��

0DJQLÀFDWLRQ�SRS�XS�PHQX

7KH�FXUUHQW�PDJQLÀFDWLRQ�RI�WKH�GUDZLQJ�YLHZ�LV�VKRZQ�DW�WKH�ERWWRP�RI�WKH�GRFXPHQW�
ZLQGRZ��,I�\RX�FOLFN�WKLV�DUHD��D�PDJQLÀFDWLRQ�SRS�XS�PHQX�DSSHDUV�
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�� &KRRVH�D�PDJQLÀFDWLRQ�YDOXH�IURP�WKLV�SRS�XS�PHQX�WR�]RRP�LQ�RU�RXW�RQ�\RXU�
drawing. 

Restore previous zoom

7KH�5HVWRUH�3UHYLRXV�=RRP�IXQFWLRQ�DOORZV�\RX�WR�UHWXUQ�WR�WKH�SUHYLRXV�PDJQLÀFDWLRQ�
RI�\RXU�GUDZLQJ��UHJDUGOHVV�RI�WKH�FXUUHQW�PDJQLÀFDWLRQ�

7R�UHWXUQ�WR�WKH�SUHYLRXV�PDJQLÀFDWLRQ

�� Choose Restore Previous Zoom from the View menu. 
7KH�YLHZ�ZLOO�]RRP�LQ�RU�RXW�WR�WKH�SUHYLRXV�PDJQLÀFDWLRQ��

127(��<RX�FDQ�XVH�WKLV�FRPPDQG�WR�DOWHUQDWH�EHWZHHQ�WZR�PDJQLÀFDWLRQ�
OHYHOV��)RU�H[DPSOH��\RX�FRXOG�GR�VRPH�GHWDLOHG�HGLWLQJ�DW�KLJK�PDJQLÀFDWLRQ��
use Restore Previous Zoom to examine the whole image, then use Restore 
Previous Zoom again to zoom back in and continue the detailed work.

Home view

7KH�YLHZ�ZKLFK�DSSHDUV�RQ�WKH�VFUHHQ�ZKHQ�\RX�ÀUVW�RSHQ�D�0DF'UDIW�GRFXPHQW�LV�
FDOOHG�WKH�+RPH�9LHZ��7KLV�YLHZ�VKRZV�WKH�DQ�XQPDJQLÀHG�YLHZ�RI�WKH�XSSHU�OHIW�FRUQHU�
of the document.

To display the home view

�� Choose Home View from the View menu. 
$Q�XQPDJQLÀHG�YLHZ�RI�WKH�XSSHU�OHIW�FRUQHU�RI�WKH�GRFXPHQW�LV�VKRZQ��

1:1 tool

<RX�FDQ�HDVLO\�UHWXUQ�WR�DQ�XQPDJQLÀHG�YLHZ�RI�WKH�FXUUHQW�DUHD�RI�WKH�GRFXPHQW�E\�
using the 1:1 tool in the Tool palette. This is useful if you have zoomed in on a detail 
DQG�QRZ�ZDQW�WR�VHH�LW�DW�VLQJOH�PDJQLÀFDWLRQ��EXW�GRQ·W�ZDQW�WR�UHWXUQ�WR�WKH�XSSHU�OHIW�
corner of the drawing as when using the Home View command (VHH�+RPH�YLHZ��&K����
S����).

7R�UHWXUQ�WR�DQ�XQPDJQLÀHG�YLHZ�RI�WKH�FXUUHQW�ZRUNLQJ�DUHD

�� Click the 1:1 tool on the Tool palette. 



Chapter 2 Creating and Editing Objects 146

7KH�YLHZ�ZLOO�EH�FKDQJHG�WR�DQ�XQPDJQLÀHG�YLHZ�RI�WKH�FXUUHQW�DUHD�

1:1 Tool

Interrupting the screen redraw

If you are working on a large, complicated drawing and you perform an action (such as 
zooming) that requires the screen to be redrawn, it may take some time for the screen 
redraw to be completed. If you decide that you want to interrupt the screen redraw 
before it is completed, you can do so.

To interrupt the screen redraw

��� Press and hold down the Command key. 
��� While holding down the Command key, press and hold down the period key (.) on 

the keyboard.

To redo the screen redraw

��� Press and hold down the Option key. 
��� Click the Pointer tool icon in the Tool palette.
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In many drawings, you may want to change the appearance of objects to help 
GLͿHUHQWLDWH�EHWZHHQ�WKHP��<RX�FDQ�FKDQJH�WKHLU�DSSHDUDQFH�E\�ÀOOLQJ�REMHFWV�ZLWK�
ZDVKHV��VROLG�ÀOOV��DQG�SDWWHUQV��E\�GUDZLQJ�OLQHV�DQG�REMHFW�ERUGHUV�ZLWK�GLͿHUHQW�
FRORUV��SDWWHUQV��OLQH�ZHLJKWV��OLQH�VW\OHV�DQG�SHQ�VW\OHV��E\�GUDZLQJ�OLQHV�ZLWK�GLͿHUHQW�
HQG�PDUNV��DQG�E\�FKRRVLQJ�GLͿHUHQW�SRVLWLRQV�IRU�REMHFW�ERUGHUV��
<RX�FDQ�GHÀQH�DWWULEXWHV�IRU�ÀOOV�DQG�OLQHV�WKDW�ZLOO�EH�DSSOLHG�WR�DOO�REMHFWV�\RX�GUDZ�RU�
you can change the attributes of existing objects. 
:KHQ�WKH�DSSOLFDWLRQ�LV�ODXQFKHG��WKH�GHIDXOW�YDOXHV�DUH�ZKLWH�ÀOO��EODFN�SHQ��QR�SDWWHUQ��
line weight 1 point, plain line style.

�   3.1 Object Attributes

Most attributes are chosen from various pop-up menus on the Attribute palette or the 
indicator boxes at the bottom left of the document window. Others are chosen from the 
Options menu.

The Attributes palette

Displaying the Attribute palette

To open the Attribute palette

�� Choose Attribute from the Window menu, or 
�� Choose Attribute from the pop-up menu at the bottom left of the document 

window. 

Chapter 3.0

Changing the Appearance of Objects
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Selecting attributes using the Attributes palette

Selecting attributes is discussed in detail in later sections of this chapter, but in general:
�� Change the attributes of existing objects by selecting the object, opening the 

appropriate menu in the Attribute palette, then making your choice. 
�� &KDQJH�WKH�GUDZLQJ·V�GHIDXOW�DWWULEXWHV��WKH�ÀOO�OLQH�ZHLJKW�DQG�VR�RQ�WKDW�ZLOO�

be applied to all new objects you draw) by making sure nothing is selected, then 
opening the appropriate menu and choosing an attribute.

7KH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV�RͿHU�DQ�DOWHUQDWLYH�PHWKRG�RI�VHOHFWLQJ�VRPH�DWWULEXWHV�

The ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV

7KH�GHIDXOW�DWWULEXWHV�IRU�WKH�ÀOO�FRORU�RU�SDWWHUQ�DQG�WKH�OLQH�ZHLJKW�DUH�VKRZQ�LQ�WKH�Fill 
and Line indicator boxes in the lower left corner of the document window.

Selecting DWWULEXWHV�XVLQJ�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV

The Fill and Line indicator boxes can be used to select attributes by accessing the 
appropriate pop-up menu and selecting the desired attribute. 

Opening the DWWULEXWH�SRS�XS�PHQXV�IURP�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV

To open the Fill color and pattern pop-up menus

�� Click the Fill color/pattern box. 
�� Hold down the Command key and click the Fill color/pattern box to open the 

alternate pop-up menu.

7R�RSHQ�WKH�3DUDOOHO�OLQH�ÀOO�FRORU�DQG�SDWWHUQ�SRS�XS�PHQXV

�� Hold down the Option key and click the Fill color/pattern box. 
�� Hold down the Option and Command keys and click the Fill color/pattern box to 

open the alternate pop-up menu.

To open the Pen color and pattern pop-up menus

�� Hold down the Control key and click the Fill color/pattern box. 
�� Hold down the Control and Command keys and click the Fill color/pattern box to 

open the alternate pop-up menu.

Line WeightFill Color/Pattern
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To open the Line weight pop-up menu

�� Click the Line weight box. 

To open the Line style pop-up menu

�� Hold down the Option key and click the Line weight box.

Default attributes

The attributes that you can select for objects before you draw them are Fill color and 
SDWWHUQ��DQG�3DUDOOHO�OLQH�ÀOO�FRORU�DQG�SDWWHUQ��7KH�SHQ�DWWULEXWHV��WKDW�LV��WKH�DWWULEXWHV�
DVVRFLDWHG�ZLWK�OLQHV�DQG�REMHFW�ERUGHUV��WKDW�\RX�FDQ�GHÀQH�IRU�REMHFWV�EHIRUH�\RX�GUDZ�
them include pen style, color and pattern, line weight (thickness), line style (solid and 
dashed lines), end marks (symbols at the ends of lines), and border position. The option 
for each of these attributes that is currently active is called the ‘default attribute’. 

7KH�FXUUHQW�GHIDXOW�ÀOO�DQG�SHQ�DWWULEXWHV�DSSHDU�RQ�WKH�OLQHV�DQG�ERUGHUV�RI�WKH�REMHFWV�
you draw. 

When nothing is selected on the drawing, the default attributes are shown on the 
Attributes palette. When an object is selected, the Attributes palette shows the attributes 
of that object. 

Setting default attributes

7R�FKDQJH�WKH�FXUUHQW�GHIDXOW�DWWULEXWHV�IRU�ÀOOV�DQG�OLQHV

��� Activate the Pointer tool on the Tool palette. 

127(��<RX�FDQQRW�DSSO\�ERWK�D�ÀOO�FRORU�DQG�ÀOO�SDWWHUQ�WR�DQ�REMHFW�XQOHVV�\RX�
GHÀQH�D�FRORUHG�ÀOO�SDWWHUQ��VHH�&XVWRPL]LQJ�SDWWHUQV��&K����S����). 

NOTE: Make sure that nothing is selected on the drawing.
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��� )URP�WKH�SRS�XS�PHQXV�RQ�WKH�$WWULEXWH�SDOHWWH��RU�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�
ER[HV���FKRRVH�WKH�ÀOO�DQG�RU�OLQH�DWWULEXWHV�\RX�ZDQW�WR�DSSO\�WR�DOO�REMHFWV�\RX�
create. 

The attributes you choose will automatically be applied to all objects until you 
make other choices for the default attributes. 

Selecting attributes for VSHFLÀF�REMHFWV

<RX�FDQ�FKDQJH�WKH�ÀOO�DQG�OLQH�DWWULEXWHV�IRU�VHOHFWHG�REMHFWV�ZLWKRXW�DͿHFWLQJ�WKH�
GHIDXOW�ÀOO�DQG�OLQH�DWWULEXWHV��
7R�GHÀQH�WKH�ÀOO�DQG�RU�OLQH�DWWULEXWHV�IRU�VHOHFWHG�REMHFWV

��� Select the object or objects you want to change. 

��� From the pop-up menus on the Attribute�SDOHWWH��RU�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�
ER[HV���FKRRVH�WKH�ÀOO�DQG�RU�OLQH�DWWULEXWHV�\RX�ZDQW�WR�DSSO\�WR�WKH�VHOHFWHG�
objects. 

The chosen attributes will be applied only to the selected objects. The default 
attributes will not be changed. 

�   3.2 Using color

:LWK�0DF'UDIW�\RX�FDQ�XVH�FRORU�LQ�D�YDULHW\�RI�ZD\V��WR�ÀOO�REMHFWV�ZLWK�VROLG�FRORUV��WR�
ÀOO�REMHFWV�ZLWK�FRORU�SDWWHUQV��WR�GUDZ�WKH�ERUGHUV�RI�REMHFWV�DQG�WR�FRORU�WH[W��7KH�XVH�
of solid colors is referred to as a “wash,” and the use of colors to draw lines and object 
borders is referred to as the “pen color.” The color you choose for the pen is applied to 
WH[W�DV�ZHOO��<RX�FDQ�DOVR�XVH�FRORUV�LQ�ÀOO�SDWWHUQV�DQG�WR�ÀOO�WKH�JDSV�EHWZHHQ�SDUDOOHO�
lines.
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Choosing the number of colors to display

A color Macintosh system is capable of reproducing over 16 million colors, but the 
number of colors you can display depends on the amount of video RAM (Random Access 
0HPRU\��LQ�\RXU�FRPSXWHU��DQG�RQ�WKH�VSHFLÀFDWLRQ�RI�\RXU�PRQLWRU��

To set the number of colors to display

7KH�GLVSOD\�FKRLFHV�DYDLODEOH�WR�\RX�ZLOO�EH�GHWHUPLQHG�E\�WKH�VSHFLÀFDWLRQ�RI�\RXU�
monitor and the system software you are running. Refer to the system software 
documentation for details of setting the number of colors to display on your monitor.

The color table

The color table contains the colors used in a document. Each new document contains a 
number of preset colors, which you can edit. The preset colors and the colors you edit or 
create are stored in the document’s color table. 

The color table is represented on your screen as a submenu that shows all the preset 
colors and all the colors that have been used in the document.

The colors in the color table can be chosen from the Attribute palette, the Fill indicator box 
and the Edit Colors command in the Options menu.
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Editing colors

You can edit the existing colors in the color table to add your own colors. 

When you edit an existing color, the existing color is replaced with the new color in the 
color table.

127(��:KHQ�\RX�SDVWH�REMHFWV�IURP�D�GLͿHUHQW�GRFXPHQW�WKDW�KDV�FRORUV�WKDW�DUH�QRW�
present in the target document’s color table, the colors from the source document are 
preserved in the objects that are pasted, but are not added to the target document’s 
color table.

NOTE: If you edit a color that has been used in the document, the objects that contain 
the edited color will be updated with the new color.

To edit a color in the color table

��� Choose Edit Colors from the Options menu. 

The color table appears. 

��� Drag through the table until the color you want to edit is highlighted. 

��� Click the mouse button. 

The Color Picker dialog appears.
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��� Use the controls in the Color Picker dialog to choose a new color.

��� When you have chosen a new color, click the OK button to close the Color Picker 
and return to MacDraft. 

The new color you chose replaces the color you selected to edit.

127(��<RX�FDQQRW�HGLW�WKH�1R�ÀOO�����WKH�VROLG�ZKLWH�RU�WKH�VROLG�EODFN�FRORUV��,I�
you try to edit one of these colors, the Color Picker dialog will not open, and an 
DOHUW�ZLOO�LQIRUP�WKDW�\RX�DUH�XQDEOH�WR�PRGLI\�WKLV�ÀOO�

NOTE: The Color Picker�GLDORJ�LV�VSHFLÀF�WR�WKH�RSHUDWLQJ�V\VWHP��)RU�IXOO�
details on how to use it refer to the operating system documentation.
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NOTES:
�� ,I�\RX�FKRRVH�¶�¶�IRU�1R�ÀOO��IURP�WKH�Fill Color�VXEPHQX�DV�WKH�FXUUHQW�ÀOO�

color, the objects you draw will be wire frame shapes. 
�� <RX�PXVW�GUDZ�SRO\OLQHV��IUHHKDQG�OLQHV�DQG�FXUYHV�ZLWK�1R�ÀOO�LI�\RX�

want end marks to appear on the lines (VHH�(QG�PDUNV��&K����S����).

2EMHFW�ÀOO�FRORU

<RX�FDQ�XVH�D�VROLG�FRORU�WR�ÀOO�WKH�LQWHULRUV�RI�REMHFWV��)LOOHG�REMHFWV�DUH�RSDTXH�DQG�\RX�
FDQ�VHOHFW�WKHP�E\�FOLFNLQJ�WKHLU�ERUGHUV�RU�DQ\ZKHUH�ZLWKLQ�WKHP��,I�D�ÀOOHG�REMHFW�LV�RQ�
top of another object, it hides the object beneath it from view. 

6HOHFWLQJ�WKH�ÀOO�FRORU

7R�VHOHFW�WKH�ÀOO�FRORU

��� Open the Fill Color pop-up menu in the Attribute palette. 

��� 'UDJ�XQWLO�WKH�ÀOO�FRORU�\RX�ZDQW�LV�KLJKOLJKWHG��

��� 5HOHDVH�WKH�PRXVH�EXWWRQ��7KH�VHOHFWHG�ÀOO�FRORU�ZLOO�EH�VKRZQ�RQ�WKH�Attribute 
palette.

<RX�FDQ�FKDQJH�WKH�ÀOO�FRORU�EHIRUH�RU�DIWHU�\RX�GUDZ�WKH�REMHFW�

'UDZLQJ�DQ�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�FRORU

7R�GUDZ�DQ�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�FRORU

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 
��� 6HOHFW�WKH�GHVLUHG�ÀOO�FRORU�IURP�WKH�)LOO�&RORU�SRS�XS�PHQX�LQ�WKH�$WWULEXWH�

palette. 
��� Draw an object. 

7KH�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�ÀOO�FRORU�
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The Fill Color Indicator box in the lower left corner of the window will change 
color to indicate the color you chose. 

7KH�ÀOO�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�ÀOO�FRORU�

3DUDOOHO�ÀOO�color

MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and closed 
SDUDOOHO�SRO\JRQV��FDQ�LQFOXGH�ÀOO�FRORUV��LQFOXGLQJ�1R�)LOO��EHWZHHQ�WKHLU�FRPSRQHQW�
edges (VHH�'UDZLQJ�SDUDOOHO�OLQH�REMHFWV��&K����S���).

127(��7KH�FKRVHQ�ÀOO�FRORU�ZLOO�EH�XVHG�IRU�REMHFWV�XQWLO�\RX�FKRRVH�DQRWKHU�ÀOO�
color as the default. 

&KDQJLQJ�WKH�ÀOO�FRORU�RI�DQ�H[LVWLQJ�REMHFW

7R�FKDQJH�WKH�ÀOO�FRORU�RI�DQ�H[LVWLQJ�REMHFW

��� 6HOHFW�WKH�REMHFW�WR�FKDQJH�WKH�ÀOO�FRORU�RI��
��� &KRRVH�WKH�GHVLUHG�ÀOO�FRORU�IURP�WKH�Fill Color pop-up menu in the Attribute 

palette. 

6HOHFWLQJ�WKH�SDUDOOHO�ÀOO�FRORU

7R�VHOHFW�WKH�SDUDOOHO�ÀOO�FRORU

��� Open the Parallel Fill color pop-up menu in the Attribute palette.

127(��,Q�DGGLWLRQ�WR�SDUDOOHO�ÀOOV��SDUDOOHO�REMHFWV�FDQ�DOVR�KDYH�SHQ�FRORUV��SDWWHUQV�
DQG�REMHFW�ÀOOV�
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&KDQJLQJ�WKH�ÀOO�FRORU�RI�DQ�H[LVWLQJ�SDUDOOHO�OLQH�REMHFW

7R�FKDQJH�WKH�ÀOO�FRORU�RI�DQ�H[LVWLQJ�SDUDOOHO�OLQH�REMHFW

��� 6HOHFW�WKH�SDUDOOHO�OLQH�REMHFW�WR�FKDQJH�WKH�ÀOO�FRORU�RI�
��� 6HOHFW�WKH�GHVLUHG�SDUDOOHO�ÀOO�FRORU�IURP�WKH�Parallel Fill color pop-up menu in the 

Attribute palette.

127(��7KH�FKRVHQ�SDUDOOHO�ÀOO�FRORU�ZLOO�EH�XVHG�IRU�REMHFWV�XQWLO�\RX�FKRRVH�
DQRWKHU�SDUDOOHO�ÀOO�FRORU�DV�WKH�GHIDXOW�

��� 'UDJ�XQWLO�WKH�SDUDOOHO�ÀOO�FRORU�\RX�ZDQW�LV�KLJKOLJKWHG�

��� 5HOHDVH�WKH�PRXVH�EXWWRQ��7KH�VHOHFWHG�SDUDOOHO�ÀOO�FRORU�ZLOO�EH�VKRZQ�RQ�WKH�
Attribute palette. 
<RX�FDQ�FKDQJH�WKH�SDUDOOHO�ÀOO�FRORU�EHIRUH�RU�DIWHU�\RX�GUDZ�WKH�SDUDOOHO�OLQH�
object.

'UDZLQJ�D�SDUDOOHO�OLQH�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�FRORU

7R�GUDZ�D�SDUDOOHO�OLQH�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�FRORU

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 
��� 6HOHFW�WKH�GHVLUHG�SDUDOOHO�ÀOO�FRORU�IURP�WKH�Parallel Fill color pop-up menu in the 

Attribute palette. 
��� Draw a parallel line object. 

7KH�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�ÀOO�FRORU��



Chapter 3 Changing the Appearance Objects157

7KH�ÀOO�RI�WKH�VHOHFWHG�SDUDOOHO�OLQH�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�ÀOO�
color. 

Pen color

This section describes how to use colors to draw lines, borders and text. You use the Pen 
Color pop-up menu in the Attribute�SDOHWWH�WR�FKRRVH�SHQ�FRORUV��<RX�FDQ�XVH�GLͿHUHQW�
pen colors to help distinguish between objects.

Selecting the pen color for lines, borders and text

To select the pen color

��� Open the Pen Color pop-up menu in the Attribute palette. 
��� Drag until the pen color you want is highlighted.

��� Release the mouse button. The selected pen color will be shown on the Attribute 
palette.
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You can change the pen color before or after you draw the object or enter the text.

Drawing a line or object, or entering text, with a selected pen color

To draw a line or object, or enter text, with a selected pen color

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 

��� Select the desired pen color from the Pen Color pop-up menu in the Attribute 
palette. 

��� Draw a line or object or enter the text. 

7KH�OLQH��REMHFW�RU�WH[W�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�SHQ�FRORU�

Changing the pen color of an existing line, object or piece of text

To change the pen color of an existing line, object or piece of text

��� Select the line, object or text to change the pen color of. 

��� Choose the desired pen color from the Pen Color pop-up menu in the Attribute 
palette.

NOTE: If you choose ‘* ‘(for No ink) from the Pen Color submenu as the current 
pen color, the lines, borders or text you draw will be invisible. Edit handles 
appear on selected objects drawn with no ink, but the lines, borders or text will 
not appear on the screen or on printed drawings. 

NOTE: The chosen pen color will be used for lines, borders and text until you 
choose another pen color as the default. 
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�   3.3 Using patterns

)LOO�SDWWHUQV�SURYLGH�DQ�HͿHFWLYH�ZD\�WR�GLVWLQJXLVK�EHWZHHQ�REMHFWV��7ZR�UHDVRQV�\RX�
PLJKW�ZDQW�WR�XVH�GLͿHUHQW�ÀOO�SDWWHUQV�ZLWKLQ�D�GUDZLQJ�ZRXOG�EH�WR�LPSURYH�LWV�
esthetics or to add meaningful information to the drawing. In a technical drawing, an 
DUFKLWHFW�RU�HQJLQHHU�PLJKW�XVH�D�YDULHW\�RI�ÀOO�SDWWHUQV�DQG�LQNV�WR�GLͿHUHQWLDWH�EHWZHHQ�
YDULRXV�REMHFW�W\SHV�RU�WH[WXUHV�ZLWKLQ�WKH�GUDZLQJ��0DF'UDIW�RͿHUV�D�PHQX�VHOHFWLRQ�RI�
VWDQGDUG�ÀOO�SDWWHUQV�WR�FRPSOHPHQW�\RXU�GUDZLQJ��<RX�FDQ�XVH�WKH�H[LVWLQJ�SDWWHUQV��
customize them or create your own. You can have up to 64 patterns in each MacDraft 
document.

Customizing patterns

The Edit Patterns�IHDWXUH�DOORZV�\RX�WR�FKDQJH�WKH�SDWWHUQV�DYDLODEOH�LQ�WKH�SDWWHUQ�ÀOO�
submenus from the Attribute�SDOHWWH��:KHQ�D�SDWWHUQ�LV�HGLWHG��WKH�SDWWHUQ�ÀOO�VXEPHQXV�
will be updated to show the new pattern, and the new pattern will be saved with the 
GRFXPHQW��,I�D�SDWWHUQ�WKDW�KDV�EHHQ�XVHG�WR�ÀOO�REMHFWV�LV�HGLWHG��WKH�REMHFWV�ZLOO�EH�
FKDQJHG�WR�UHÁHFW�WKH�UHYLVHG�SDWWHUQ�

The Edit Pattern dialog

Opening the Edit pattern dialog

To open the Edit Pattern dialog

��� Open the Options menu and drag until Edit Pattern is highlighted. 

The Edit Patterns submenu appears.

��� Holding down the mouse button, drag until the pattern you want to edit is 
highlighted and release the mouse button. 
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The Edit Pattern dialog appears.

127(��<RX�FDQQRW�HGLW�WKH�1R�ÀOO��´1µ���WKH�VROLG�ZKLWH�RU�VROLG�EODFN�SDWWHUQV��
If you try to do so, the Edit Pattern dialog will not open, and an alert appears 
informing that the selected pattern may not be edited.

NOTE: 16 x 16, or 32 x 32 patterns will not be printed on some printers or 
output devices.

7KH�HGLW�SDWWHUQ�ÀHOG

The large box in the center of the Edit Patterns�GLDORJ�LV�WKH�HGLW�SDWWHUQ�ÀHOG��,W�VKRZV�
D�PDJQLÀHG�YLHZ�RI�WKH�ELWV�WKDW�PDNH�XS�WKH�SDWWHUQ��7KH�SDWWHUQ�LV�HGLWHG�ZLWKLQ�WKLV�
ÀHOG�

Pattern preview

The box in the upper left corner of the Edit Pattern dialog shows a preview of the pattern 
as it appears on the drawing. It is updated as the pattern is edited in the Edit Pattern�ÀHOG�

The pattern grid

7KH�SDWWHUQ�JULG�FDQ�EH�GHÀQHG�DV���[�������[����RU����[����JULG�VTXDUHV�

To specify the pattern grid

�� Click the 8 x 8, 16 x 16, or 32 x 32 buttons on the left of the Edit Pattern dialog.
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Scale

Scale turned OFF

Grid Size Increased

If the Scale�ER[�LV�WXUQHG�RͿ��DV�WKH�JULG�VL]H�LV�LQFUHDVHG��WKH�SDWWHUQ�LV�UHSOLFDWHG�WR�ÀOO�
the new area. 

For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 16, then 
to 32 x 32. At each stage, four copies of the contents of the Edit Pattern�ÀHOG�DUH�XVHG�WR�
ÀOO�WKH�QHZ�JULG��1RWLFH�WKDW�DOWKRXJK�WKH�FRQWHQWV�RI�WKH�Edit Pattern�ÀHOG�FKDQJH��WKH�
Pattern Preview�ÀHOG�UHPDLQV�WKH�VDPH�

Scale turned ON

Grid Size Increased

If the Scale box is on, as the grid size is increased, the pattern in the Edit Pattern�ÀHOG�
remains the same, but is divided up into more squares. 

Grid size decreased

If the Scale�ER[�LV�WXUQHG�RͿ��DV�WKH�JULG�VL]H�LV�GHFUHDVHG��WKH�SDWWHUQ�LV�GLYLGHG�DQG�
applied to the new area. 

For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 x 16, then 
to 8 x 8. At each stage, the contents of the top left quarter of the Edit Pattern�ÀHOG�DUH�XVHG�
WR�ÀOO�WKH�QHZ�JULG�
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For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 16, then 
to 32 x 32. At each stage, the contents of the Edit Pattern ÀHOG�UHPDLQ�WKH�VDPH��EXW�WKH�
pattern is divided into more grid squares. Notice that the contents of the Pattern Preview 
ÀHOG�DUH�VFDOHG�XS�DW�HDFK�VWDJH�

Grid size decreased

,I�WKH�6FDOH�ER[�LV�RQ��DV�WKH�JULG�VL]H�LV�GHFUHDVHG��WKH�SDWWHUQ�LQ�WKH�(GLW�3DWWHUQ�ÀHOG�
remains the same but is divided into less grid squares. Colors are averaged out in this 
process.  

For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 x 16 then 
to 8 x 8. At each stage, as four grid squares are combined to make one new grid square, 
the average color of the four squares is used for the new square. Notice that the contents 
of the Pattern Preview box are scaled down at each stage.

Color mode

Patterns can be edited in two modes: black and white, and color/grayscale. 

Pattern editing tools

7KH�WRROV�DW�WKH�ULJKW�RI�WKH�SDWWHUQ�HGLW�ÀHOG�DUH�XVHG�WR�HGLW�WKH�FXUUHQW�SDWWHUQ��
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The Overlay tool

The Overlay tool is used to apply a pattern over the one in the Edit Pattern�ÀHOG�
7R�DSSO\�D�SDWWHUQ�RYHU�WKH�RQH�LQ�WKH�(GLW�3DWWHUQ�ÀHOG

��� Click the Overlay tool and hold down the mouse button. 

The Fill Patterns submenu appears. 

��� Holding down the mouse button, drag the cursor over the pattern you wish to 
apply, and release the mouse button 

The selected pattern will be applied over the current contents of the Edit Pattern 
ÀHOG�XVLQJ�WKH�FXUUHQW�FRORU�

The Invert tool

7KH�,QYHUW�WRRO�LV�XVHG�WR�LQYHUW�WKH�FRORU�RI�WKH�ELWV�LQ�WKH�(GLW�3DWWHUQ�ÀHOG��,Q�EODFN�DQG�
white mode, this action will change all the black bits to white and all the white bits to 
black. If color bits are included in the pattern, when the Invert tool is used, each bit will 
be changed to the color on the opposite side of the color wheel to the original color, and 
the brightness will also be inverted. For example, a light pink color will become a dark 
green/blue, while a dark red will become a light green/blue.

7R�LQYHUW�WKH�FRORU�RI�WKH�ELWV�LQ�WKH�(GLW�3DWWHUQ�ÀHOG

�� Click the Invert tool.
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The color of the bits in the Edit Pattern�ÀHOG�ZLOO�EH�LQYHUWHG

The Flip horizontal tool

The Flip Horizontal�WRRO�LV�XVHG�WR�ÁLS�WKH�SDWWHUQ�LQ�WKH Edit Pattern�ÀHOG�DURXQG�WKH�
vertical axis. 

7R�ÁLS�WKH�SDWWHUQ�LQ�WKH�(GLW�3DWWHUQ�ÀHOG�DURXQG�WKH�YHUWLFDO�D[LV

�� Click the Flip Horizontal tool. 

7KH�SDWWHUQ�ZLOO�EH�ÁLSSHG�

The Flip vertical tool

The Flip Vertical�WRRO�LV�XVHG�WR�ÁLS�WKH�SDWWHUQ�LQ�WKH�Edit Pattern�ÀHOG�DURXQG�WKH�
horizontal axis.  

7R�ÁLS�WKH�SDWWHUQ�LQ�WKH�(GLW�3DWWHUQ�ÀHOG�DURXQG�WKH�KRUL]RQWDO�D[LV

�� Click the Flip Vertical tool. 
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7KH�SDWWHUQ�ZLOO�EH�ÁLSSHG�

The Pencil tool

The Pencil tool is used to add or delete individual bits or series of bits, or to draw lines in 
the Edit Pattern�ÀHOG��
7R�DGG�ELWV�WR�WKH�(GLW�3DWWHUQ�ÀHOG�RQH�DW�D�WLPH

��� Click the Pencil tool and move the cursor over the Edit Pattern�ÀHOG��
��� Click the Edit Pattern�ÀHOG�WR�DGG�D�VTXDUH�RI�WKH�FXUUHQW�FRORU��

To add a series of bits

��� Click in the Edit Pattern�ÀHOG�DQG�GUDJ��KROGLQJ�GRZQ�WKH�PRXVH�EXWWRQ��
��� Bits showing the current color will be added to the pattern as you drag. 
��� 5HOHDVH�WKH�PRXVH�EXWWRQ�ZKHQ�\RX�DUH�ÀQLVKHG��

To draw lines 

�� Constrain the movement of the Pencil tool to a horizontal or vertical direction by 
holding down the Shift key while you drag.

To delete black bits in Black and White mode 

�� Select the Pencil tool and click the black bits you want to delete.

To delete color bits in the Color mode 

�� Hold down the Command key, then click the color bits to be deleted.

The Eye dropper tool

You can use the Option key to change the pencil tool to an eye dropper, and use this to 
choose the color of any bit in the Edit Pattern�ÀHOG�DV�WKH�FXUUHQW�FRORU�
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��� Select the Pencil tool, hold down the Option key and move the pointer into the Edit 
Pattern�ÀHOG��
The pointer will change to an Eye Dropper tool. 

��� Click the Eye Dropper tool on the bit of the color you require to be the current 
color. 
7KH�FXUUHQW�FRORU�ZLOO�EH�FKDQJHG�WR�UHÁHFW�\RXU�FKRLFH��

The Finger tool 

The Finger tool is used to blend together the current color and the color of any bit in the 
Edit Pattern�ÀHOG��RU�WKH�FRORUV�RI�DGMDFHQW�ELWV�LQ�WKH�Edit Pattern�ÀHOG��
7R�EOHQG�WKH�FXUUHQW�FRORU�ZLWK�WKH�FRORU�RI�DQ\�ELW�LQ�WKH�(GLW�3DWWHUQ�ÀHOG

��� Select the Finger tool. 
The Finger�FXUVRU�VKRZV�WKH�FXUUHQW�FRORU��ZKLFK�LV�WKH�ÀUVW�RI�WKH�WZR�FRORUV�WR�EH�
used in the blending process. 

��� Move the cursor over the Edit Pattern�ÀHOG�DQG�FOLFN�WKH�ELW�ZLWK�ZKLFK�\RX�ZDQW�
to blend the current color. 
The bit clicked will change to a new color that is the average of the Finger cursor 
color and the color of the bit clicked. The Finger cursor color will also be updated 
to show the new color. 

To blend the colors of a series of bits

��� Select the Finger tool. 
��� Click in the Edit Pattern�ÀHOG�DQG��KROGLQJ�GRZQ�WKH�PRXVH�EXWWRQ��GUDJ�WKH�Finger 

cursor across bits of varying colors. 
The average of the color values of the Finger cursor color and the bits dragged 
across will be calculated, and applied to the bit. 
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NOTE: If you hold down the Shift key while dragging, the movement of the 
Finger cursor will be constrained to a horizontal or vertical direction. 

When you release the mouse button, the Finger cursor shows the color last applied 
to a bit. To reset the Finger cursor color to the current color, click the Finger tool 
icon again. To reset the Finger cursor color to a color in the pattern, hold down the 
Option key and click one of the colors in the pattern.

NOTE: The Finger tool can be selected in Black and White mode, but the mode is 
automatically changed to color.

The Paint bucket tool

The Paint Bucket tool is used to change bits in the Edit Pattern ÀHOG�WR�WKH�FXUUHQW�FRORU��
7R�FKDQJH�ELWV�LQ�WKH�(GLW�3DWWHUQ�ÀHOG�WR�WKH�FXUUHQW�FRORU

��� Click the Current Color button and choose the color from the Pattern Color pop- 
up menu. 

��� Click the Paint Bucket icon and then click a bit in the Edit Pattern�ÀHOG��
The bit clicked and all bits of the same color connected to it, are changed to the 
current color. 

��� If you hold down the Option key with the Paint Bucket tool selected, the tool will 
be changed to the Eye Dropper tool. Click a bit in the Edit Pattern�ÀHOG�ZLWK�WKH�Eye 
Dropper tool to select the color of that bit as the current color.

The Hand tool

The Hand tool is used to move the pattern within the Edit Pattern�ÀHOG�
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7R�PRYH�WKH�SDWWHUQ�ZLWKLQ�WKH�(GLW�3DWWHUQ�ÀHOG

���  Click the Hand tool and move the cursor over the Edit Pattern�ÀHOG��
��� Holding down the mouse button, drag the pattern to reposition it within the Edit 

Pattern�ÀHOG��DQG�UHOHDVH�WKH�PRXVH�EXWWRQ��

The Black and White tool

This tool is used to convert patterns to black and white. 

To convert patterns to black and white

�� Click the Black and White tool.
Any bits used in the pattern that are more than 50% saturated will be changed to 
black. Bits that are less than 50% saturated will be changed to white. 

The Current color tool

You can work with only one color at a time while editing patterns. The selected color is 
called the current color and is shown in the tool palette of this dialog. With this tool you 
open the Pattern Color menu.
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To change the current color

��� Click the Current Color button and hold down the mouse button. 
The Pattern Color pop-up menu appears

��� Holding down the mouse button, drag to select the color you want to use, and 
release the mouse button. 
The selected color will be shown on the Current Color tool. This color will be used 
for pattern editing until another color is chosen.

NOTE: The current color is always black when you operate in black and white 
mode. 

Choosing a color which is not available in the Pattern Color menu

The Other button in the Pattern Color pop-up menu allows you to select colors that are 
not available in the Pattern Color menu.

To choose a color which is not available in the Pattern Color menu

��� Click the Current Color button and hold down the mouse button.
The Pattern Color pop-up menu appears 

��� Click the Other button.
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The Color Picker dialog appears.

��� Select a color from the Color Picker. 
��� Click 2. to close the Color Picker dialog and return to the Edit Pattern dialog. 

The color selected from will be shown on the Current Color button.

Clearing the current pattern

$W�WLPHV��\RX�PD\�ZDQW�WR�FOHDU�DOO�WKH�ELWV�IURP�WKH�(GLW�3DWWHUQ�ÀHOG�DQG�VWDUW�DIUHVK�
rather than alter an existing pattern.

7R�FOHDU�DOO�WKH�ELWV�IURP�WKH�(GLW�3DWWHUQ�ÀHOG

�� Click the Clear button 
7KH�ÀHOG�ZLOO�EH�FOHDUHG�

)LOOLQJ�WKH�HQWLUH�ÀHOG

,I�\RX�QHHG�WR�ÀOO�WKH�HQWLUH�ÀHOG�ZLWK�WKH�FXUUHQW�FRORU�\RX�FDQ�GR�WKLV�ZLWK�RQH�PRXVH�
click using the Fill button. 

7R�ÀOO�WKH�HQWLUH�ÀHOG

�� Click the Fill button.
The entire Edit Pattern�ÀHOG�ZLOO�EH�ÀOOHG�ZLWK�WKH�FXUUHQW�FRORU�

Revert

�� Click the Revert button to return to the pattern you originally selected to edit. Any 
changes you have made will be lost.
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Undo

�� Click the Undo�EXWWRQ�WR�UHPRYH�WKH�HͿHFWV�RI�\RXU�ODVW�DFWLRQ�RQO\�

Cancel

�� Click the Cancel button to close the Edit Pattern dialog and return to your 
0DF'UDIW�GUDZLQJ�ZLWKRXW�PDNLQJ�DQ\�FKDQJHV�WR�WKH�ÀOO�SDWWHUQV�

2.

�� Click the 2. button to close the Edit Pattern dialog and return to your MacDraft 
GUDZLQJ�DFFHSWLQJ�WKH�FKDQJHV�\RX�KDYH�PDGH�WR�WKH�VHOHFWHG�ÀOO�SDWWHUQ��7KH�ÀOO�
submenu will be updated to show the new pattern, and the new pattern will be 
VDYHG�ZLWK�WKH�GRFXPHQW��,I�D�SDWWHUQ�WKDW�KDV�EHHQ�XVHG�WR�ÀOO�REMHFWV�LV�HGLWHG��
WKH�REMHFWV�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�UHYLVHG�SDWWHUQ�

2EMHFW�ÀOO�SDWWHUQV

<RX�FDQ�XVH�D�SDWWHUQ�WR�ÀOO�WKH�LQWHULRUV�RI�REMHFWV��)LOOHG�REMHFWV�DUH�RSDTXH�DQG�\RX�FDQ�
VHOHFW�WKHP�E\�FOLFNLQJ�WKHLU�ERUGHUV�RU�DQ\ZKHUH�ZLWKLQ�WKHP��,I�D�ÀOOHG�REMHFW�LV�RQ�WRS�
of another object, it hides the object beneath it from view. 

6HOHFWLQJ�WKH�ÀOO�SDWWHUQ

7R�VHOHFW�WKH�ÀOO�SDWWHUQ

��� Open the Fill Pattern pop-up menu in the Attribute palette. 

��� 'UDJ�XQWLO�WKH�ÀOO�SDWWHUQ�\RX�ZDQW�LV�KLJKOLJKWHG�
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��� 5HOHDVH�WKH�PRXVH�EXWWRQ��7KH�VHOHFWHG�ÀOO�SDWWHUQ�ZLOO�EH�VKRZQ�RQ�WKH�Attribute 
palette.

<RX�FDQ�FKDQJH�WKH�ÀOO�SDWWHUQ�EHIRUH�RU�DIWHU�\RX�GUDZ�WKH�REMHFW�

'UDZLQJ�DQ�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ

7R�GUDZ�DQ�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 

��� 6HOHFW�WKH�GHVLUHG�ÀOO�SDWWHUQ�IURP�WKH�Fill Pattern pop-up menu in the Attribute 
palette. 

��� Draw an object. 

7KH�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�ÀOO�SDWWHUQ��

The Fill Pattern Indicator box in the lower left corner of the window will change to 
indicate the pattern you chose.

&KDQJLQJ�WKH�ÀOO�SDWWHUQ�RI�DQ�H[LVWLQJ�REMHFW

7R�FKDQJH�WKH�ÀOO�SDWWHUQ�RI�DQ�H[LVWLQJ�REMHFW

��� 6HOHFW�WKH�REMHFW�WR�FKDQJH�WKH�ÀOO�SDWWHUQ�RI��

NOTES:
�� ,I�\RX�FKRRVH�¶1�¶�IRU�1R�ÀOO��IURP�WKH�Fill Pattern submenu as the current 

ÀOO�SDWWHUQ��WKH�REMHFWV�\RX�GUDZ�ZLOO�EH�ZLUH�IUDPH�VKDSHV��
�� <RX�PXVW�GUDZ�SRO\OLQHV��IUHHKDQG�OLQHV�DQG�FXUYHV�ZLWK�1R�ÀOO�LI�\RX�

want end marks to appear on the lines (VHH�(QG�PDUNV��&K����S����).

127(��7KH�FKRVHQ�ÀOO�SDWWHUQ�ZLOO�EH�XVHG�IRU�REMHFWV�XQWLO�\RX�FKRRVH�DQRWKHU�
ÀOO�SDWWHUQ�DV�WKH�GHIDXOW��
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��� 6HOHFW�WKH�GHVLUHG�ÀOO�SDWWHUQ�IURP�WKH�Fill Pattern pop-up menu in the Attribute 
palette. 

��� 7KH�ÀOO�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�ÀOO�SDWWHUQ�

3DUDOOHO�ÀOO�SDWWHUQ

MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and closed 
SDUDOOHO�SRO\JRQV��FDQ�LQFOXGH�ÀOO�SDWWHUQV��LQFOXGLQJ�1R�)LOO��EHWZHHQ�WKHLU�FRPSRQHQW�
edges.

6HOHFWLQJ�WKH�SDUDOOHO�ÀOO�SDWWHUQ

7R�VHOHFW�WKH�SDUDOOHO�ÀOO�SDWWHUQ

��� Open the Parallel Fill Pattern pop-up menu in the Attribute palette. 

127(��,Q�DGGLWLRQ�WR�SDUDOOHO�ÀOOV��SDUDOOHO�REMHFWV�FDQ�DOVR�KDYH�SHQ�FRORUV�DQG�
SDWWHUQV��DQG�REMHFW�ÀOOV��
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��� 'UDJ�XQWLO�WKH�SDUDOOHO�ÀOO�SDWWHUQ�\RX�ZDQW�LV�KLJKOLJKWHG��

��� 5HOHDVH�WKH�PRXVH�EXWWRQ��7KH�VHOHFWHG�SDUDOOHO�ÀOO�SDWWHUQ�ZLOO�EH�VKRZQ�RQ�WKH�
Attribute palette. 

<RX�FDQ�FKDQJH�WKH�SDUDOOHO�ÀOO�SDWWHUQ�EHIRUH�RU�DIWHU�\RX�GUDZ�WKH�SDUDOOHO�OLQH�
object.

'UDZLQJ�D�SDUDOOHO�OLQH�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ

7R�GUDZ�D�SDUDOOHO�OLQH�REMHFW�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 

��� 6HOHFW�WKH�GHVLUHG�SDUDOOHO�ÀOO�SDWWHUQ�IURP�WKH�Parallel Fill pattern pop-up menu in 
the Attribute palette. 

��� Draw a parallel line object. 
7KH�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�ÀOO�SDWWHUQ���

127(��7KH�FKRVHQ�SDUDOOHO�ÀOO�SDWWHUQ�ZLOO�EH�XVHG�IRU�REMHFWV�XQWLO�\RX�FKRRVH�
DQRWKHU�SDUDOOHO�ÀOO�SDWWHUQ�DV�WKH�GHIDXOW��

&KDQJLQJ�WKH�ÀOO�SDWWHUQ�RI�DQ�H[LVWLQJ�SDUDOOHO�OLQH�REMHFW

7R�FKDQJH�WKH�ÀOO�SDWWHUQ�RI�DQ�H[LVWLQJ�SDUDOOHO�OLQH�REMHFW

��� 6HOHFW�WKH�SDUDOOHO�OLQH�REMHFW�WR�FKDQJH�WKH�ÀOO�SDWWHUQ�RI�
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��� &KRRVH�WKH�GHVLUHG�SDUDOOHO�ÀOO�SDWWHUQ�IURP�WKH�Parallel Fill pattern pop-up menu 
in the Attribute palette. 

7KH�ÀOO�RI�WKH�VHOHFWHG�SDUDOOHO�OLQH�REMHFW�ZLOO�FKDQJH�WR�UHÁHFW�WKH�FKRVHQ�ÀOO�
pattern. 

Pen Pattern

This section describes how to use patterns to draw lines and borders. Use the Pen Pattern 
pop-up menu in the Attribute�SDOHWWH�WR�FKRRVH�SHQ�SDWWHUQV��<RX�FDQ�XVH�GLͿHUHQW�SHQ�
patterns to help distinguish between objects.

Selecting the pen pattern for lines and borders

To select the pen pattern

��� Open the Pen Pattern pop-up menu in the Attribute palette.
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��� Drag until the pen pattern you want is highlighted.

��� Release the mouse button. The selected pen pattern will be shown on the Attribute 
palette. 

NOTE: If you choose ‘N ‘(for No ink) from the Pen Pattern submenu as the 
current pen pattern, the lines and borders you draw will be invisible. Edit 
handles appear on selected objects drawn with no ink, but the lines or borders 
will not appear on the screen or on printed drawings.

You can change the pen pattern before or after you draw the object.

Drawing a line or object with a selected pen pattern

To draw a line or object with a selected pen pattern

��� Return to the pointer mode. (Make sure that nothing on the drawing is selected.) 

��� Choose the desired pen pattern from the Pen Pattern pop-up menu in the Attribute 
palette. 

��� Draw a line or object. 

7KH�OLQH�RU�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�SHQ�SDWWHUQ�

NOTE: The chosen pen pattern will be used for lines and borders until you 
choose another pen pattern as the default.
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Changing the pen pattern of an existing line or object

To change the pen pattern of an existing line or object

��� Select the line or object to change the pen pattern of. 

��� Choose the desired pen pattern from the Pen Pattern pop-up menu in the Attribute 
palette.

7KH�OLQH�RU�ERUGHU�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�SHQ�
pattern. 
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�   3.4 Line and Border Attributes

7KH�DWWULEXWHV�WKDW�GHÀQH�WKH�DSSHDUDQFH�RI�OLQHV�DQG�ERUGHUV�DUH�VRPHWLPHV�UHIHUUHG�WR�
as the ‘pen model’ or simply, the ‘pen’. The attributes for the pen include pen style, line 
ZHLJKW��OLQH�VW\OH�DQG�HQG�PDUNV��7KH�ERUGHU�SRVLWLRQ�RI�DQ�REMHFW�FDQ�DOVR�EH�VSHFLÀHG��
The various options for each attribute are selected using pop-up menus in the Attribute 
palette or, in the case of border position, from the Options menu. 

Pen color or pattern are discussed in other sections of this chapter; VHH�3HQ�FRORU��&K����
S���� and VHH�3HQ�SDWWHUQ��&K����S����.

127(��0DQ\�RI�WKH�SHQ�PRGHO�DWWULEXWHV�\RX�FKRRVH�GR�QRW�DͿHFW�RQO\�OLQHV��WKH\�
DOVR�DͿHFW�WKH�ERUGHUV�RI�REMHFWV��)RU�H[DPSOH��ZKHQ�\RX�VHOHFW�D�FHUWDLQ�OLQH�ZHLJKW�
and color, these attributes will be applied to line segments used to draw rectangles, 
circles, polygons and so on.

Selecting line weights

To select the line weight

��� Open the Line Weight pop-up menu in the Attribute palette.

Line weight

Line weight refers to the thickness of lines and borders. Line weight is measured in pixels 
(picture elements). 

7KHUH�DUH�HOHYHQ�GLͿHUHQW�OLQH�ZHLJKWV��7KH\�YDU\�LQ�VL]H�IURP�KDLUOLQH�WR����SL[HOV��7KH�
numbers beside the line weights indicate the number of pixels that make up the line 
weight.

NOTE: Although the hairline, 0.5 and 0.75 line weights appear as one point thick on 
the screen, they will print at their designated weights on any printer with a resolution 
of 300 dpi or more. 
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��� Drag until the line weight you want is highlighted.

��� Release the mouse button. The selected line weight will be shown on the pop-up 
menu. 

You can change the line weight before or after you draw the line or object.

Drawing a line or object with a selected line weight

To draw a line or object with a selected line weight

��� Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.) 

��� Choose the desired line weight from the Line Weight pop-up menu in the Attribute 
palette. 

��� Draw a line or object. 
7KH�OLQH�RU�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�OLQH�ZHLJKW�

NOTE: The chosen line weight will be used for lines and borders until you 
choose another line weight for the default line weight attribute.
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Changing the line weight of an existing line or object

To change the line weight of an existing line or object

��� Select the line or object to change the line weight of. 

��� Choose the desired line weight from the Line Weight pop-up menu in the Attribute 
palette.

7KH�OLQH�RU�ERUGHU�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�OLQH�
weight. 

Line style

The term ‘line style’ refers to whether a line is solid or one of an assortment of dashed 
lines. You can use the preset line styles provided with MacDraft or customize them to 
make your own. You can use line styles in object borders and straight lines.

Selecting line styles

To select the line style

��� Open the line style pop-up menu in the Attribute palette.
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��� Release the mouse button. The selected line style will be shown on the pop-up 
menu. 
You can change the line style before or after you draw the line or object. 

Drawing a line or object with a selected line style

To draw a line or object with a selected line style 

��� Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.) 

��� Choose the desired line style from the line style pop-up menu in the Attribute 
palette. 

��� Draw a line or object. 
7KH�OLQH�RU�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�OLQH�VW\OH��

��� Drag until the line style you want is highlighted.

NOTE: The chosen line style will be used for lines and borders until you choose 
another line style for the default line-style attribute.
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Changing the line style of an existing line or object

To change the line style of an existing line or object

��� Select the line or object to change the line style of. 

��� Choose the desired line style from the line style pop-up menu in the Attribute 
palette.

7KH�OLQH�RU�ERUGHU�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�OLQH�
style.

End marks

End marks are symbols on the ends of lines that are used for annotating drawings. You 
can make end marks appear on lines by using a set of end marks in combination with the 
Line tools, the Polyline tool, the Freehand Line tool, the Bezier curve tool or the Spline 
tool.
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Selecting end marks

To select end marks

��� Open the end marks pop-up menu in the Attribute palette. 

��� Drag until the desired end marks are highlighted.

�� Drag down the left side of the pop-up menu to choose a left end mark; it 
appears at the beginning of a line. 

�� Drag down the right side of the pop-up menu to choose a right end mark; it 
appears at the end of a line. 

�� Drag down the centre of the pop-up menu to choose both left and right end 
marks; these appear at each end of a line.

��� Release the mouse button. The selected end marks will be shown on the pop-up 
menu. 

You can change the line style before or after you draw the line or object.
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Drawing a line or object with selected end marks

To draw a line or object with selected end marks

��� Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.) 

��� Choose the desired end marks from the end marks pop-up menu in the Attribute 
palette. 

��� Draw a line or object. 
7KH�OLQH�RU�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�HQG�PDUNV�

Changing the end marks of an existing line or object

To change the end marks of an existing line or object

��� Select the line or object to change the end marks of. 

��� Choose the desired end marks from the end marks pop-up menu in the Attribute 
palette. 

NOTE: Polylines, freehand lines, Bezier curves or splines must contain No Fill if you 
wish to add end marks to them. 6HH�'UDZLQJ�LUUHJXODU�SRO\JRQV�DQG�SRO\OLQHV��&K����S����
and VHH�'UDZLQJ�IUHHKDQG�OLQHV��VKDSHV�DQG�FXUYHV��&K����S��� for details of drawing 
these objects.

NOTE: The chosen end marks will be used for lines and borders until you 
choose other end marks for the default end marks attribute.



Chapter 3 Changing the Appearance Objects185

7KH�OLQH�RU�ERUGHU�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�OLQH�
weight.  

Border positions

There are three types of border position: Line Inside, Line Centered and Line Outside. 
The border position options apply to objects only, not to lines. 

$OO�WKUHH�ERUGHU�SRVLWLRQV�DͿHFW�REMHFWV�GLͿHUHQWO\��WKHVH�GLͿHUHQFHV�DUH�GLVFXVVHG�ODWHU�LQ�
this chapter. In general though, border position is important with regard to how objects 
are aligned. MacDraft uses the position of an object's edit handles to align objects. It is 
important to keep this in mind when you align objects, as border position controls the 
position of the edit handles relative to the width (that is the line weight) of the border see 
$OLJQLQJ�REMHFWV��&K����S����.

Border Line Inside Border Line Centered Border Line Outside
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Border position applies only to square-corner and rounded-corner rectangles, parallel 
line objects, circles and arcs. You can draw these objects with a certain border position or 
change the border position of selected objects. 

Selecting border positions

To select a border position

��� Open the Border Position submenu in the Options menu. 

��� Drag until the desired border position is highlighted.

��� Release the mouse button. A checkmark appears next to the selected border 
position on the submenu. 

You can change the border position before or after you draw the line or object.  

Drawing an object with a selected border position

To draw an object with a selected border position

��� Return to the pointer mode. (Make sure that no objects on the drawing are 
selected.) 

��� Choose the desired border position from the Border Position submenu in the 
Options menu. 

��� Draw an object. 
7KH�REMHFW�ZLOO�EH�GUDZQ�ZLWK�WKH�VSHFLÀHG�ERUGHU�SRVLWLRQ�

NOTE: The chosen border position will be used for objects until you choose 
another border position as the default.

Changing the border position of an existing object

To change the border position of an existing object

��� Select the object to change the border position of. 
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How border position affects objects

Border position determines the location of the edit handles on the border of an object, and 
as MacDraft uses the edit handles as reference points for alignment and size calculations, 
ERUGHU�SRVLWLRQ�DͿHFWV�WKH�DOLJQPHQW�DQG�VL]H�UHDGLQJV�RI�REMHFWV���6HH�$OLJQLQJ�REMHFWV��
&K����S���� and VHH�6KRZ�6L]H��&K����S�����)

��� Choose the desired border position from the Border Position submenu in the 
Options menu. 

7KH�ERUGHU�RI�WKH�VHOHFWHG�REMHFW�ZLOO�EH�FKDQJHG�WR�UHÁHFW�WKH�FKRVHQ�ERUGHU�
position.

When you draw an object with the border position Line Inside, the 
border of the object appears between the cursor and the object during 
creation. When you select an object created with the border position 
Line Inside, the edit handles appear on the outside of the object. When 
Show Size is on, the size shown represents the entire object, including 
its borders.

When you draw an object with the border position Line Centered, the 
cursor appears centered within the object’s borders during creation. 
When you select an object created with the border position Line 
Centered, the edit handles appear in the center of the objects borders. 
When Show Size is on, the size shown is the size of the object 
measured from the center of the object’s borders.

Line Centered

Line Inside



Chapter 3 Changing the Appearance Objects 188

�   3.5 Copying Attributes

$Q�REMHFW·V�JUDSKLF�DWWULEXWHV��ÀOO��SHQ�FRORU�RU�SDWWHUQ��OLQH�ZHLJKW�DQG�OLQH�VW\OH�HWF���
and object information can be copied and applied to another object using either the 
Attributes tool or the Copy Attributes and Apply Attributes commands in the Edit menu. 
The Apply Attributes command can be used to apply changes to all of the objects selected, 
while the Attributes tool applies changes only to the object clicked. 

Any settings for applying attributes will be stored only while the application is running. 

The default options for applying attributes are to apply only graphic attributes, not object 
information.

Copying attributes using the Attributes tool

To copy attributes using the Attributes tool

��� Click the Attributes tool in the Tool palette

When you draw an object with the border position Line Outside, the 
border of the object appears outside the cursor during creation. When 
you select an object created with the border position Line Outside, the 
edit handles appear on the inside of the object. When Show Size is on, 
the size shown is the size of the object’s interior, excluding the object’s 
borders.

Line Outside

��� Click an object. 

The default attributes will be applied to the object. 

��� With the Attributes tool still selected, hold down the Option key and click an 
object.
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The cursor turns into an empty eye dropper.

7KH�REMHFW·V�SHQ�DQG�ÀOO�DWWULEXWHV�ZLOO�EH�FRSLHG�

��� Release the Option key, the cursor turns into a full eye dropper. 

��� &OLFN�DQRWKHU�REMHFW�WR�DSSO\�WKH�FRSLHG�SHQ�DQG�ÀOO�DWWULEXWHV�WR�LW�

NOTES:
�� Attributes will be applied only to the object clicked, even if that object is 

part of a group. 
�� The apply action can be undone by selecting Undo Eye Dropper from the 

Edit menu immediately after the apply action. 
�� Hold down the Command key and click in the drawing window with the 

Attributes tool, and the tool reverts to the Arrow tool.
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��� Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to the object you have clicked. Any 
changes made to the Apply Attributes dialog relate to this apply action only.

Using the Attributes Options dialog

To open the Attributes Options dialog

��� Hold down the Option key and click the Attribute tool, or select the Attribute tool 
and choose Tool Options from the Options menu.

Checking and changing attributes before applying them

You can check and, if necessary, change copied attributes before applying them. There are 
two ways of doing this when you use the Attributes�WRRO��7KH�ÀUVW�LV�WR�XVH�WKH�Apply 
Attributes dialog, in which case any changes will be applied to that action only. The 
second is to use the Attributes Options dialog, in which case the settings remain as 
VSHFLÀHG�XQWLO�FKDQJHG�RU�XQWLO�WKH�DSSOLFDWLRQ�LV�FORVHG�

Using the Apply Attributes dialog

To open the Apply Attributes dialog before applying attributes to an object

��� Select the Attributes tool and hold down the Shift key. 

The full eye dropper icon is followed by three dots to show that the Apply 
Attributes dialog will appear when an object is clicked. 

��� Click an object. 
The Apply Attributes dialog appears.
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The Attribute Options dialog appears.

The object’s graphical attributes and object information will be stored. 

��� Select the object or objects to which you want to apply these attributes.

��� Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to objects. Settings remain as 
VSHFLÀHG�XQWLO�FKDQJHG�RU�XQWLO�WKH�DSSOLFDWLRQ�LV�FORVHG��UDWKHU�WKDQ�MXVW�IRU�WKH�
next use of the tool. 

Copying attributes using the Edit menu

To copy attributes using the Edit menu

��� Select the object from which you want to copy attributes. 

��� Open the Edit menu and choose Copy Attributes.
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��� Open the Edit menu and choose Apply Attributes.

The copied attributes will be applied to the selected object or objects.

Checking and changing the attributes before applying them

As when using the Attributes tool, there are two ways of checking and changing the 
attributes before applying them when you use the Edit menu. You can use the Apply 
Attributes dialog, or use the Attributes Options dialog. 

Using the Apply Attributes dialog

To open the Apply Attributes dialog before applying attributes to an object

��� Hold down the Shift key when you choose the Apply Attributes command in the 
Edit menu. 

The Apply Attributes dialog appears. 

��� Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to the selected object or objects. Any 
changes made to the Apply Attributes dialog relate to this apply action only.
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Using the Attributes Options dialog

To open the Attributes Options dialog

��� Choose Attributes Options from the Edit menu. 

The Attributes Options dialog appears. 

��� Click the Object Fill, Pen Model, Object Information and Parallel Fill boxes to 
specify that these attributes should be applied to objects. The settings remain as 
VSHFLÀHG�XQWLO�FKDQJHG�RU�XQWLO�WKH�DSSOLFDWLRQ�LV�FORVHG��UDWKHU�WKDQ�MXVW�IRU�WKH�
next use of the Apply Attributes command.

�   3.6 Picture Backgrounds 

Transparent picture backgrounds

There may be occasions when you position a picture object on top of another object, 
and want the lower object to show through the background of the foremost. Do this by 
importing images such as PNG or Photoshop PSD that have transparent backgrounds

To make the background of a superimposed picture transparent

�� Make sure that the images already have transparent backgrounds with them, you 
FDQ�WKHQ�GUDJ�WKHP�LQWR�0DF'UDIW�RU�LPSRUW�WKHP�IURP�WKH�ÀOH�PHQX�
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Opaque picture backgrounds

�� Choose a color from the Fill Color pop-up menu, or a pattern from the Fill Pattern 
pop-up menu in the Attributes palette. 

What was a transparent background will now be the color or pattern you selected. 
You can make it transparent again by selecting the No Fill option in either of the 
pop-ups.
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Annotation describes or gives information about an object in a drawing. In MacDraft, 
annotation is of three kinds: text, dimension objects and area calculation.

�   4.1 Text

Text, in a MacDraft document, consists of all letters, punctuation and numbers. Once text 
is created, it is recognized as a single object and you can then use most functions with it, 
such as moving and duplicating. 
The Text function allows you to use a variety of fonts, styles, and character sizes. You can 
arrange text lines with single spacing, one and a half spacing, or double spacing. Text can 
DOVR�EH�MXVWLÀHG�ZLWKLQ�HDFK�LQGLYLGXDO�WH[W�EORFN�DQG�DOO�WH[W�FDQ�EH�KLGGHQ�RU�GLVSOD\HG�

Entering Text

You can enter text in two ways: using the regular text mode or the paragraph text mode. 
,Q�WKH�SDUDJUDSK�WH[W�PRGH��\RX�GUDJ�WR�GHÀQH�D�WH[W�UHFWDQJOH�RI�D�FHUWDLQ�VL]H��HLWKHU�
with the Text tool or another drawing tool), and the text you enter into the rectangle 
automatically “wraps” when it reaches the side of the rectangle. 

Regular Text

,Q�WKH�UHJXODU�WH[W�PRGH��\RX�FOLFN�WKH�GUDZLQJ�WR�GHÀQH�DQ�LQVHUWLRQ�SRLQW��WKHQ�W\SH�LQ�
WKH�WH[W��<RX�GHÀQH�WKH�HQG�RI�D�OLQH�RI�WH[W�E\�SUHVVLQJ�WKH�Return key.

To enter regular text (i.e. text that does not automatically “wrap”)

��� Activate the Text icon in the Tool palette by clicking it.

Chapter 4.0

Annotating your Drawing
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Notice that when you activate the text icon and then move the cursor onto the 
drawing area, the cursor turns into an I-beam pointer. The I-beam pointer indicates 
that you are in the text insertion mode.

��� Position the I-beam pointer where you want to begin inserting text and click. 

$�ÁDVKLQJ�YHUWLFDO�EDU�DSSHDUV�DW�WKH�SRLQW�ZKHUH�\RX�FOLFNHG�WR�VKRZ�WKDW�\RX�FDQ�
now begin typing. 

��� Enter the text by typing on the keyboard. 

You can continue to enter text in various places on your drawing by moving the I- 
beam pointer to the desired place, clicking it, and typing.

��� $IWHU�\RX�KDYH�ÀQLVKHG�HQWHULQJ�WH[W��FOLFN�WKH�Pointer tool.

Paragraph text

On many occasions, you may wish to enter a paragraph of text and restrict it to a certain 
rectangular shape, such as a column. MacDraft’s paragraph text feature allows you 
WR�GHÀQH�D�UHFWDQJOH�RI�DQ\�VL]H��WKHQ�W\SH�WH[W�LQWR�LW��$V�\RX�HQWHU�WKH�WH[W�LQWR�WKH�
rectangle, the words will automatically wrap around to the next line when the letters 
reach the edge of the rectangle. If you type to the bottom of the rectangle, the text will 
be scrolled within the rectangle to keep the line you are typing visible. Paragraph text 
cannot extend beyond the drawing edge.

Entering paragraph text 

<RX�FDQ�GHÀQH�WKH�SDUDJUDSK�WH[W�UHFWDQJOH�E\�GUDZLQJ�D�UHFWDQJOH�ZLWK�WKH�Text tool, by 
drawing a rectangle or other shape, or by selecting an existing rectangle or other shape. 
(If you draw or select a non-rectangular object and start typing, the text appears in a 
rectangle superimposed over the object.)

NOTES:
�� If you make a typing mistake as you are entering text, simply use the Delete 

key to remove the error and then type the correct character. 
�� To start a new line in the same text block, just press the Return key and 

continue to type. 

NOTES:
��  If you draw or select a rectangle and enter text, the text and the rectangle are 

automatically linked. 
�� Non rectangular objects remain separate objects from the text object; you can 

move and reshape them separately. 
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To enter paragraph text with the Text tool

��� Activate the Text tool. 
��� Position the I-beam pointer where you want to begin entering text. 
��� Press and hold down the mouse button. 
��� 'UDJ�LQ�D�GLDJRQDO�GLUHFWLRQ�XQWLO�\RX�KDYH�GHÀQHG�D�UHFWDQJOH�WKDW�LV�WKH�VL]H�\RX�

want, and release the mouse button.

��� Start entering text from the keyboard. 
��� :KHQ�\RX�DUH�ÀQLVKHG��FOLFN�WKH�Pointer tool to end the text entry.

To enter paragraph text with the Circle (or other drawing) tool

��� Activate the Circle tool (or other drawing tool). 
��� Position the pointer where you want to begin entering text. 
��� Press and hold down the mouse button. 
��� 'UDJ�LQ�D�GLDJRQDO�GLUHFWLRQ�XQWLO�\RX�KDYH�GHÀQHG�DQ�REMHFW�WKDW�LV�WKH�VL]H�\RX�

want, and release the mouse button. 
��� Start entering text from the keyboard.

��� :KHQ�\RX�KDYH�ÀQLVKHG��FOLFN�WKH�Pointer tool to end the text entry.

To enter paragraph text feature into an existing rectangle or other shape

��� Select the object. 
��� Start entering text from the keyboard. 
��� When you are done, click the Pointer tool to end the text entry. 
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Reshaping a block of paragraph text

To reshape a block of paragraph text

Once the paragraph of text is entered, you can reshape the paragraph using the edit 
handles.

��� Return to the pointer mode. 
��� Select the paragraph of text by clicking it. 
��� Edit handles appear on the text block. 
��� Position the tip of the pointer on one of the edit handles. 
��� Press and hold down the mouse button. 
��� Drag until the paragraph is the shape you want.

��� Release the mouse button.

NOTE: If you select regular text (entered using the Text tool) and try to reshape the 
paragraph using the edit handles, you will actually resize the font rather than the 
paragraph. 

Selecting/editing text

Sometimes you need to edit text you have previously entered on your drawing. MacDraft 
gives you various ways to edit text: replacing an existing word or line of text by selecting 
it and retyping in its place; inserting characters or words at the end of existing text or at 
any selected point in the text; and backspacing to delete text. 

Before you can edit a piece of text, you must select it. You can select text by using the 
pointer while in the pointer mode, or by using the I-beam pointer. (When you select text 
XVLQJ�WKH�SRLQWHU�PRGH��DQ\�FKDQJHV�\RX�PDNH�ZLOO�DͿHFW�WKH�HQWLUH�WH[W�EORFN��
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Selecting text

Using the I-beam pointer

To select text

��� Click the Text tool icon in the palette. 
��� Position the I-beam pointer to either side of the text you want to change. 
��� Press and hold down the mouse button. 
��� Drag through all the text you want to edit, and release the mouse button.

Notice that the text becomes highlighted as you drag through it. Using this method 
of selecting allows you to select a single character or an entire block of text.

To select a word:

�� Position the I-beam pointer on the word you want to select and double-click. 

To extend the selection of text

��� 3RVLWLRQ�WKH�,�EHDP�SRLQWHU�RQ�WKH�ÀUVW�ZRUG�\RX�ZDQW�WR�VHOHFW��
��� Double-click and, after the second click, hold down the mouse button. 
��� Drag through the text until all the words you want to select are highlighted, then 

release the mouse button.

To select a range of text

��� Position the I-beam pointer at the starting point for the range and click. 
��� Press down the Shift key. 
��� Position the I-beam pointer on the ending point for the range. 
��� Still holding down the Shift key, click this point. 
��� Release the mouse button and the Shift key. 

7KH�WH[W�EHWZHHQ�WKH�VSHFLÀHG�VWDUWLQJ�DQG�HQGLQJ�SRLQWV�ZLOO�EH�VHOHFWHG�
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Using the Arrow tool

To select text

��� Position the pointer tip on the block of text that you want to select and click it.

Notice that a rectangle and/or a set of edit handles appears around the text, 
indicating that it is selected. This method of selecting text allows you to change 
the text attributes (including the font, size, and style) of the selected text block (see 
)RUPDWWLQJ�WH[W��&K����S����). 

If you select text in this way and immediately start typing, the new text is 
automatically added to the end of the existing text.

Selecting rotated text for editing

To select rotated text

��� Activate the Text tool in the palette. 
��� Click the block of rotated text you want to edit. 

The text will temporarily be rotated to zero degrees (horizontal orientation) 
allowing you to edit it. 

��� When you are through editing the text, click the Pointer tool. 
Once you click the Pointer tool, the text returns to its rotated position. 

NOTE: If you print rotated text on a printer that is not PostScript®-compatible, the 
text will print out at the resolution of the printer hardware. 

Selecting all text

You can select all the text in the active document if you want to make a global change to 
text attributes.

To select all text in the active document

��� Return to the pointer mode. 
��� Open the Text menu, from the menu bar or the Text tool, and choose Select All 

Text. 
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Editing text

Replacing existing text

Once you have selected any portion of text, you can immediately replace it by simply 
typing in the new text. As soon as you begin typing, the old text disappears. As you enter 
the new text, all of the non-selected text in the line will automatically adjust to make 
room for the text you are entering.

Inserting text into existing text

On many occasions you may need to insert a single character, word or sentence into an 
existing piece of text. 

To insert text

��� Activate the Text tool in the palette by clicking it. 
��� Position the I-beam pointer on the desired insertion point and click it. 
��� Type in the character or words that you wish to insert. (Keep in mind that you can 

press the Delete key to delete characters or words.) 
In this mode, you can continue to pick insertion points in other pieces of text on 
your drawing and edit them as well. 

��� Once you have completed all the editing that you want to do, click the Pointer icon 
in the palette.

Deleting selected text

There are two simple ways to delete text that you have selected. Either:

�� Open the Edit menu and choose Cut or Clear, or 

�� Press the Delete key. 
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Formatting text

You can choose the way you want to present text either before entering the text, or by 
changing the text after it has been entered. There are many options to choose from to 
REWDLQ�WKH�HͿHFW�WKDW�\RX�GHVLUH��0DF'UDIW�DOORZV�\RX�WR�XVH�PDQ\�GLͿHUHQW�IRQW�W\SHV��
sizes and styles for text. You can format text by choosing options from the Text menu in 
the menu bar or the Text tool in the Tool palette.

Formatting text before entering it 

To format text before entry

��� Make sure that no text is selected on the drawing before you make each choice. 
��� Choose the text attributes you want from the Text menu’s submenus. 

The current attributes for text, such as font, size, and style are marked with 
checkmarks in the appropriate menus. These checkmarks show you what 
attributes will be applied to the text you enter. 

Formatting existing text

You can change the font, size and style of any existing text. You can change the text 
attributes for a given piece of text by selecting the text and then opening the submenu 
associated with the attribute you want to change. 

To format existing text

��� Select the text you wish to change (VHH�6HOHFWLQJ�WH[W��&K����S����). 
��� Choose the text attributes you want from the Text menu’s submenus. 

Each time you make a choice from the Text menu, the selected text will change to 
UHÁHFW�WKDW�FKRLFH�
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'HÀQH�attributes for text

7R�GHÀQH�WKH�IRQW

��� Open the Font submenu from the Text menu. 
��� Holding down the mouse button, drag until the font you want is highlighted, and 

release the mouse button. 

7R�GHÀQH�WKH�SRLQW�VL]H�IRU�WH[W

��� Open the Text menu’s Size submenu. 

��� Holding down the mouse button, drag until the size you want (measured in 
points) is highlighted, and release the mouse button; or choose Other… to enter a 
point size (up to 1024 point) that is not listed in the submenu.

NOTE: The font size of regular text can also be adjusted by clicking the text and 
dragging one of its edit handles to resize the text. 

7R�GHÀQH�WKH�VW\OH

��� Open the Style submenu from the Text menu.
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��� Holding down the mouse button, drag until the line spacing you want is 
highlighted, and release the mouse button.

Changing the case of text

On some occasions you may enter a piece of text in one case, such as lowercase, and 
then decide that you want it in uppercase or in title format. You could clear the text and 
reenter it; however, MacDraft allows you to change the case of existing text.

To change the case of existing text

��� Select the text that you want to change by clicking it. 

��� Holding down the mouse button, drag until the style you want is highlighted, and 
release the mouse button.

<RX�FDQ�PDNH�VHYHUDO�GLͿHUHQW�FKRLFHV�IURP�WKH�Style submenu. Each choice has an 
DGGLWLYH�HͿHFW�RQ�WKH�DSSHDUDQFH�RI�WH[W��)RU�H[DPSOH��\RX�FRXOG�FKRRVH�Bold and then 
Italic to create Bold/Italic text. 

 To justify text

��� Open the Text menu’s -XVWLÀFDWLRQ submenu. 
��� +ROGLQJ�GRZQ�WKH�PRXVH�EXWWRQ��GUDJ�XQWLO�WKH�W\SH�RI�KRUL]RQWDO�MXVWLÀFDWLRQ�\RX�

want (Left, Center, or Right) is highlighted, and release the mouse button. 
��� 5HSHDW�VWHSV���DQG���WR�FKRRVH�WKH�GHVLUHG�YHUWLFDO�MXVWLÀFDWLRQ��Top, Middle or 

Bottom).

To set the line spacing

0DF'UDIW�RͿHUV�\RX�ÁH[LELOLW\�LQ�FKRRVLQJ�OLQH�VSDFLQJ��DOVR�NQRZQ�DV�´OHDGLQJµ��RSWLRQV�
to suit your needs. You can have one, one and a half, or two spaces between lines of text.
��� Choose Line Spacing from the Text menu. 
��� The Line Spacing submenu appears.
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��� Open the Text menu’s Case submenu.

��� Holding down the mouse button, drag until the case option you want is 
highlighted. 

The results of each choice are as follows: 

�� UPPERCASE: Converts all selected text to uppercase. 
�� lowercase: Converts all selected text to lowercase. 
�� Title Text��&DSLWDOL]HV�WKH�ÀUVW�FKDUDFWHU�RI�HDFK�ZRUG�LQ�VHOHFWHG�WH[W�

Positioning text

Moving text

2QFH�\RX�KDYH�FUHDWHG�D�EORFN�RI�WH[W��\RX�FDQ�PRYH�LW�WR�D�GLͿHUHQW�ORFDWLRQ�RQ�\RXU�
drawing if necessary. Notice that when you create a line of text and then click anywhere 
else, the text becomes surrounded by a box or edit handles. This indicates that MacDraft 
recognizes the piece of text as an object. You can move the text just as you would move 
any other object.

127(��7H[W�FDQ�DOVR�EH�URWDWHG�DQG�ÁLSSHG��6HH�5RWDWLQJ�REMHFWV��&K����S���� and see 
)OLSSLQJ�REMHFWV��&K����S����.

To move a piece of text

��� Position the cursor over the text block. 
��� Press and hold down the mouse button until the white arrow pointer appears. 
��� Drag the text to its new position, and release the mouse button.
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Aligning Text

There are two ways to align text. Justifying text within the text block (VHH�7R�MXVWLI\�WH[W��
&K����S����), and aligning text with an object or another piece of text that is treated as an 
object.

To align text with another piece of text or an object

��� Click the text to be aligned to select it. 
��� Open the Arrange menu and choose Align Objects. 
��� The Alignment dialog appears. 
��� Choose the alignment method you want, and click the 2. button. 
��� Click the object with which you want the text block aligned (if necessary). 
��� 7KH�VHOHFWHG�WH[W�DQG�REMHFWV�ZLOO�VQDS�LQWR�DOLJQPHQW�DFFRUGLQJ�WR�WKH�VSHFLÀHG�

alignment attribute.

For more information on using the Align command VHH�$OLJQLQJ�REMHFWV��&K����S����.

Hiding/displaying all text

Hiding text

At times, you may want to temporarily hide all of the text on a document. If you choose 
to hide all the text, and then print the document, the text will not appear on the output. 
You might use this feature to hide all the text before you produce a test print of a drawing 
to shorten the printing time. If you are working on a complex drawing with many 
elements, you could use this feature to minimize the amount of time it takes to redraw 
the screen after you scroll or zoom.

To hide all text

�� Open the Text menu and choose Hide Text. 
All the text on the drawing will be temporarily removed from the screen and from 
any printed output until you choose to re-display the text. A checkmark appears 
beside Hide Text in the Text menu. 

Re-displaying text

When you want to make the text visible again on the screen and on your output, you can 
choose the Hide Text command again.

To re-display all text:

�� Open the Text menu and choose Hide Text again. The checkmark disappears from 
beside Hide Text in the Text menu, and the text in the drawing will be visible.
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�   4.2 Dimension Objects

About dimension objects

MacDraft’s Dimension tools allow you to add dimension lines to your drawing so that 
you can display and print the sizes of (or distances between) various lines and objects. 
Dimensions show sizes and distances in real-world units according to the scale of 
the drawing. In addition, MacDraft can show and print the size of an angle. Angular 
dimensions appear in degrees of arc, regardless of the scale of a drawing. 

The Dimension palette

The dimension objects are created and controlled using the tools and pop-up menus of 
the Dimension Palette.

To display the Dimension palette

�� Choose the Dimension palette from the Window menu, or 
�� Choose Dimension from the pop-up menu at the bottom left of the document 

window. 

Vertical dimension

Perpendicular dimension

Radial dimension

Angular dimension

Horizontal dimension

Sloped dimension

Diameter dimension

Circle centre mark
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To close the Dimension palette

�� Click the palette’s close button.

Types of dimension objects

The dimension tools can create linear (horizontal, vertical, sloped, or perpendicular), 
radial (radius or diameter), and angular dimensions. In addition the Dimension palette 
includes a Circle center mark tool, for marking the center of a circle, arc, or ellipse.

Linear dimensions

Linear (horizontal, vertical, sloped, or perpendicular) dimensions can consist of a single 
dimension span.

Linear dimensions can use existing vertices, corners, and so on as their points of 
reference. If the Snap to Object feature is active, the dimension tools will snap the 
reference points to existing corners and handles (VHH�6QDS�WR�REMHFW��&K����S����).

Radial dimensions

Radial dimensions appear as straight lines (like linear dimensions), but measure the 
radius or diameter of an existing circle, ellipse, or arc. 
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Angular dimensions

Angular dimensions measure the angle of arc between any two straight lines or edges of 
square-cornered rectangles, polygons, or polylines (single-line or parallel). The lines or 
edges need not intersect.

Drawing dimension objects

MacDraft’s dimension objects include linear (horizontal, vertical, sloped, or 
perpendicular), radial (radius or diameter), and angular dimensions. 

Once created, dimension object’s attributes, such as color, line style, text font, and so on 
can be controlled in the standard fashions (VHH�&KDQJLQJ�WKH�DSSHDUDQFH�RI�REMHFWV��&K����
S����).

NOTE: Dimension objects are drawn using the current default pen model. Hold down 
the Control key when drawing dimension objects to draw the lines using ‘hairline’ 
weight.

Linear dimensions

Reference points

7KH�XVHU�GHÀQHG�UHIHUHQFH�SRLQWV�IRU�OLQHDU�GLPHQVLRQV�FDQ�EH�HLWKHU�SDUW�RI�H[LVWLQJ�
objects (on corners or edges) or independent points on the drawing. 

To show an object’s size precisely, and to automatically link the dimension object to the 
existing object, it is usually necessary to put the dimension’s reference points on the 
object’s corner points (or other edit handles).
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Horizontal dimension objects

The horizontal dimension tool creates dimension lines that are constrained to horizontal 
orientation. When edited, moved, or resized, horizontal dimension objects retain their 
original angle of orientation.

To draw a single horizontal dimension line

��� Choose the Horizontal dimension tool from the Dimension palette.

The cursor will now read “1st point.” 

��� &OLFN�WKH�ÀUVW�SRLQW�IRU�WKH�GLPHQVLRQ�OLQH��DQ�REMHFW
V�FRUQHU��LI�GHVLUHG���

The cursor will now read “2nd Point.” 

��� Click the second point for the dimension line. 

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box. 

��� Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the horizontal distance between the 
WZR�SRLQWV�GLVSOD\HG�ZKHUH�\RX�VSHFLÀHG��

��� Click the Arrow tool to exit dimension mode.

Vertical dimension objects

The vertical dimension tool creates dimension lines that are constrained to vertical 
orientation. When edited, moved, or resized, vertical dimension objects retain their 
original angle of orientation.
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The cursor will now read “1st point.”

��� &OLFN�WKH�ÀUVW�SRLQW�IRU�WKH�GLPHQVLRQ�OLQH�
The cursor will now read “2nd Point.”

��� Click the second point for the dimension line. 

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box. 

��� Click the drawing where you want the text value to appear.

The dimension object will be complete, with the vertical distance between the two 
SRLQWV�GLVSOD\HG�ZKHUH�\RX�VSHFLÀHG��

To draw a single vertical dimension line

��� Select the Vertical dimension tool from the Dimension palette.

��� Click the Arrow tool to exit dimension mode.

Slope dimension objects

The slope dimension tool is used to create dimension lines running in any direction on a 
drawing. Slope dimensions can be edited, moved, or resized, and the angle changed.

To draw a single slope dimension line

��� Select the Slope dimension tool from the Dimension palette.



Chapter 4 Annotating your Drawing 212

The cursor will now read “1st point”.

��� &OLFN�WKH�ÀUVW�SRLQW�IRU�WKH�GLPHQVLRQ�OLQH�
The cursor will now read “2nd Point”.

��� Click the second point for the dimension line.

The cursor will now read “Anchor”, and include an outline of the dimension’s text 
box.  

��� Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the distance between the two points 
GLVSOD\HG�ZKHUH�VSHFLÀHG�DORQJ�WKH�VORSH�

��� Click the Arrow tool to exit dimension mode.

Perpendicular dimension objects

The perpendicular dimension tool creates dimensions perpendicular to lines or to the 
edges of square-cornered rectangles, polygons, and polylines (single-line or parallel-line). 
When edited, moved, or resized, perpendicular dimension objects retain their original 
angles of orientation.

To create a perpendicular dimension line

��� Select the Perpendicular dimension tool from the Dimension palette.
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The cursor will now read “Click Line/Edge.”

��� &OLFN�WKH�OLQH�RU�HGJH�IRU�WKH�ÀUVW�SRLQW�RI�WKH�GLPHQVLRQ�OLQH�
The cursor will now read “2nd Point.”

��� Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

��� Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the perpendicular distance from the 
edge of the object to the point you chose. 

��� Click the Arrow tool to exit dimension mode.

Cirlce dimension objects

MacDraft’s circle dimension tools let you display and print the radius or diameter of a 
circle, arc, or ellipse.

NOTES:
�� Radial dimensions are not rotated together with the ellipses and elliptical arcs 

after dimensions are applied. 
�� Also, ellipses or elliptical arcs can display a radius or diameter only along their 

major and minor axes.
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The cursor will now read “Click Circle/Arc”. 

��� Click the circle, arc, or ellipse. 

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

��� Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the radial distance shown where you 
VSHFLÀHG�

��� Click the Arrow tool to exit dimension mode.

Radius dimensions

To apply a radius dimension to an object

��� Select the Radius dimension tool from the Dimension palette.

NOTE: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point 
where the dimension text is to appear. This option does not work with ellipses 
and elliptical arcs.
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The cursor will now read “Click Circle/Arc.”

��� Click the circle, arc, or ellipse.

The cursor will now read “Anchor,” and include an outline of the dimension’s text 
box.

��� Click the place in the drawing area where you want the text box to appear.

The dimension object will be complete, with the diameter distance appearing 
ZKHUH�\RX�VSHFLÀHG�

��� Click the Arrow tool to exit dimension mode.

Diameter dimensions

To draw a diameter dimension

��� Select the Diameter dimension tool from the Dimension palette.

NOTE: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point 
where the dimension text is to appear.
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The cursor will read “Click Circle/Arc”.

��� Click the circle, arc, or ellipse.

The Circle Center mark appears over the object

��� Click the Arrow tool to exit dimension mode.

Angular dimension objects

MacDraft’s Angular dimension tool lets you display and print the angles between 
GLͿHUHQW�OLQHV�RU�HGJHV��ZKHWKHU�WKH\�LQWHUVHFW�RU�QRW��<RX�FDQ�DSSO\�DQ�DQJXODU�
dimension object to any pair of straight lines or edges of square-cornered rectangles, or to 
polygons or polylines (single-line or parallel-line).

Circle center marks

MacDraft’s Dimension palette includes a special tool for indicating the center of circles, 
ellipses, and arcs.

To apply a Circle center mark

��� Choose the Circle center mark tool in the Dimension palette.
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To apply an angular dimension

��� Decide which two lines or edges you want to apply the dimension object to. 

��� Select the Angular dimension tool from the Dimension palette. 

��� Click the Arrow tool to exit dimension mode. 

The cursor will now read “Click 1st Line”.

��� &OLFN�WKH�ÀUVW�OLQH�RU�HGJH��
The cursor will now read “Click 2nd Line”.

��� Click the second line or edge.

The cursor will now read “Anchor”, and include an outline of the dimension’s text 
box. 

��� Click the drawing where you want the text value to appear.

The dimension object will be complete, with the angle between the two edges 
GLVSOD\HG�ZKHUH�\RX�VSHFLÀHG��

NOTE: To display the obtuse rather than acute angle between two lines or edges, hold 
down the Option key after selecting the second edge, while clicking the point where 
the dimension text is to appear.
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�   4.3 Area calculation

MacDraft’s automatic Area Calculation feature can determine and show the area of a 
selected object for you. If you later change the size of the object, the size shown changes 
automatically. 

This feature can calculate the areas of simple objects, like rectangles and circles, or 
complex objects, such as complex polygons and freehand shapes. When the area of an 
REMHFW�LV�FDOFXODWHG��LW�DOZD\V�UHÁHFWV�WKH�FXUUHQW�VFDOH�DQG�XQLWV�RI�WKH�GUDZLQJ�

Show Area

To calculate the area of an object

��� Select the object whose area you want to determine. 
��� Open the View menu and choose Show Area. 

The result of the area calculation will be shown in approximately the center of the 
object.

Modifying area calculation values

MacDraft allows you to change the appearance and/or positioning of area calculation 
values. The current font attributes, including font type and size, are used for these values. 
MacDraft uses the Macintosh system font (usually 13-point Lucida Grande) as the preset 
font and size when you create a new document. There may be times when this font size 
is inconvenient, such as when area values are shown on small objects, and the size of the 
text value overwhelms the size of the object. 

0DF'UDIW�JLYHV�\RX�WKH�ÁH[LELOLW\�WR�FKDQJH�WKH�YDOXH·V�IRQW�W\SH�DQG�VL]H��,Q�DGGLWLRQ��
it allows you to separate the values from their related objects and move them to any 
location on your drawing. In the case of small objects with area values, you can move the 
area values away from the object. If you want to tidy up your drawing, you can move 
these values into an information table. If you change the size of an object, the calculated 
YDOXH�LQ�WKH�WDEOH�ZLOO�EH�XSGDWHG�DXWRPDWLFDOO\�WR�UHÁHFW�WKH�REMHFW·V�RU�OLQH·V�QHZ�VL]H�
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Changing font attributes

To change the font attributes before you use show area

��� Return to the pointer mode and make sure that no objects on the drawing are 
selected. 

��� Open the Text menu’s Font submenu and choose the font you want. 

��� Open the Text menu’s Size submenu and choose the text size you want. 

��� Implement the area calculation feature. 

The area calculation value text (and any subsequent text entered) will be shown in 
WKH�IRQW�DQG�DW�WKH�WH[W�VL]H�VSHFLÀHG��VHH�'HÀQH�DWWULEXWHV�IRU�WH[W��&K����S����).

To change the font attributes for existing area calculation values

��� Select the area calculation value you want to change. 

��� Open the Text menu’s Font submenu and choose the font you want. 

��� Open the Text menu’s Size submenu and choose the text size you want. 

��� The area calculation value text selected will be shown in the font and at the text 
VL]H�VSHFLÀHG��VHH�'HÀQH�DWWULEXWHV�IRU�WH[W��&K����S����). 

Moving area calculation values

Area calculation text can be moved away from an object, but if the object is subsequently 
moved, the area calculation text maintains its position relative to the object. For example: 
If you moved the area calculation text from the center of a rectangle, repositioned the text 
above the rectangle, then moved the rectangle, the text would follow the movement of 
the rectangle and remain above it. 

Alternatively, the area calculation text can be detached from an object and placed in a 
À[HG�ORFDWLRQ��,I�WKH�REMHFW�LV�PRYHG�WKH�DUHD�FDOFXODWLRQ�WH[W�UHPDLQV�LQ�LWV�VSHFLÀHG�
SRVLWLRQ��7KLV�XQLTXH�IHDWXUH�RͿHUV�DQ�H[WUHPH�OHYHO�RI�ÁH[LELOLW\��HVSHFLDOO\�LI�\RX�ZDQW�
to place the values into an information table. 

In both cases, the area calculation value remains associated with the object, and will be 
updated if the object is edited.

NOTE: If you are printing to a PostScript printer, choose a laser printer font to obtain 
a high-quality output. 
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Moving attached area calculation values

Use this method if you want the area calculation text to remain attached to the object it is 
associated with. The text maintains its position relative to the object. 

To move an attached area value

��� Position the cursor on the area value. 
��� Press and hold down the Shift key. 
��� Press and hold down the mouse button. 
��� Release the Shift key. 
��� Holding down the mouse button, drag the value to the desired location, then 

release the mouse button. 
��� 7KH�DUHD�YDOXH�WH[W�ZLOO�EH�VKRZQ�DW�WKH�VSHFLÀHG�ORFDWLRQ��EXW�PDLQWDLQV�LWV�

position relative to the object if the object is moved.

Detaching and moving area calculation values

Use this method if you want the area calculation text to be detached from the object it is 
DVVRFLDWHG�ZLWK��7KH�WH[W�UHPDLQV�LQ�WKH�À[HG�SRVLWLRQ�HYHQ�LI�WKH�REMHFW�LV�PRYHG��7KH�
value remains associated with the object and will be updated if the object is edited. 

To detach and move area calculation values

��� Select the area value you want to detach and move. 
��� Drag it to the desired position, and it will be detached from the object.
��� 7KH�WH[W�UHPDLQV�LQ�WKH�SRVLWLRQ�VSHFLÀHG�HYHQ�LI�WKH�REMHFW�LV�PRYHG�

NOTE: To constrain the movement of the value to a horizontal or vertical direction, 
keep holding the Shift key down as you drag the value to its new location. 
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��� You can reattach the area value by using the Shift key, as explained in "Moving 
attached area calculation values".

Hide Area

If a selected object shows an area calculation, the View menu command Hide Area will be 
available.

To hide the area calculation display

��� Select the object with the area you wish to hide. 

��� Open the View menu and choose Hide Area. 

The area calculation for the selected object will be no longer shown.
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�   5.1 Moving objects

You may create an object, then decide you want to move it to a new location on your 
GUDZLQJ�RU�LQWR�D�GLͿHUHQW�GUDZLQJ��0DF'UDIW�SURYLGHV�VHYHUDO�GLͿHUHQW�PHWKRGV�RI�
moving objects: drag and drop; cut/copy and paste; the Move command; the Resize 
palette; the arrow keys; and the Position command. Objects can also be removed 
permanently from the drawing using the Clear function.

Drag and drop

Drag and drop can be used to move objects to/from a MacDraft document to/from a 
variety of locations. 

Drag and drop an object or group of objects from a MacDraft document to: 
�� The same document window (to move or copy the object or group). 
�� Another MacDraft document window. 
�� A Media Assistant Lite catalog. 6HH�6\PERO�OLEUDULHV��$SS�' for more information 

about using symbol libraries and Media Assistant Lite.
�� The Library Palette. 6HH�0LFURVSRW�/LEUDU\�3DOHWWH��&K����S������
�� The desktop to create a picture clipping. 
�� Any application that accepts PICT data by drag and drop. 

Drag and drop an object or group of objects into a MacDraft document: 
�� $Q\�3,&7�ÀOH�FDQ�EH�GUDJJHG�GLUHFWO\�LQWR�D�0DF'UDIW�GRFXPHQW�ZLQGRZ��
�� ,WHPV�LQ�RWKHU�LPDJH�DQG�JUDSKLFV�ÀOH�IRUPDWV��VXFK�DV�-3(*�DQG�*,)�ÀOHV��FDQ�EH�

dragged into MacDraft.

Chapter 5.0

Transforming & Arranging Objects

NOTE: The application can convert units for you. (i.e. If you are working in inches but 
type "mm" after the number the appication will convert those millimeters to inches.)

Once created, objects in your MacDraft drawing can be moved, duplicated, transformed, 
DQG�DUUDQJHG�LQ�PDQ\�GLͿHUHQW�ZD\V��7R�DYRLG�REMHFWV�EHLQJ�DOWHUHG�LQ�HUURU��LWHPV�FDQ�
EH�ORFNHG��7KHVH�IHDWXUHV�DUH�GLVFXVVHG�LQ�WKLV�FKDSWHU��0DF'UDIW�RͿHUV�VHYHUDO�XVHIXO�
drawing aids that help you to position objects easily (VHH�'UDZLQJ�DLGV��&K����S����).
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The drag and drop process

In its simplest form, drag and drop can be used to move an object or group of objects 
within a MacDraft document. To perform other drag and drop actions, you must press 
DGGLWLRQDO�´PRGLÀHUµ�NH\V��7KH�PRGLÀHU�NH\V�UHTXLUHG�WR�SHUIRUP�VSHFLÀF�DFWLRQV�DUH�
described later in this chapter.
To use drag and drop

��� Select the object you want to move by clicking it.

��� Position the cursor over the object. 

��� 3UHVV�GRZQ�D�PRGLÀHU�NH\�LI�UHTXLUHG��VHH�QH[W�VHFWLRQ���
��� Press and hold down the mouse button until the white arrow pointer appears. 

��� Holding down the mouse button, drag the object to its new location.

NOTE: Be careful not to position the pointer on an edit handle when you move 
an object. Edit handles are for changing the size and shape of an object (see 
&UHDWLQJ�DQG�HGLWLQJ�REMHFWV��&K����S���).
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��� �3UHVV�GRZQ�D�PRGLÀHU�NH\�LI�UHTXLUHG��VHH�QH[W�VHFWLRQ���
��� Release the mouse button. 

When you drag objects, “ghost” images of the objects will be visible as you drag 
them. The original stays in place until you release the mouse button. 

Drag and drop PRGLÀHU�NH\V

Various keys perform a special function when used during the process of clicking the 
REMHFW�V��WR�EH�GUDJJHG��2QFH�WKH�GUDJ�DFWLRQ�LV�VWDUWHG��WKHVH�PRGLÀHU�NH\V�KDYH�QR�HͿHFW�
DQG�FDQ�EH�UHOHDVHG��7KH�VDPH�PRGLÀHU�NH\V�PD\�SHUIRUP�RWKHU�IXQFWLRQV�ZKHQ�XVHG�
during the process of releasing the mouse button to drop the dragged object(s).

Using drag and drop within a MacDraft document

To move an object within a MacDraft document using drag and drop

�� 1R�PRGLÀHU�NH\�LV�UHTXLUHG�
To copy an object within a MacDraft document using drag and drop

�� Hold down the Option key at any time. 

The original object selected remains in place, and a copy of it will be placed at the 
new location.

To constrain the movement of an object

�� Hold down the Shift key while dragging an object to constrain the object's 
movement to either a horizontal or vertical direction.

NOTE: If you drag an object beyond the borders of the drawing area, the drawing 
automatically scrolls.
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Using drag and drop to copy an object out of a MacDraft document

�� Hold down the Command key to turn Autoscroll�RͿ�DQG�DOORZ�DQ�REMHFW�WR�EH�
dragged out of the active MacDraft document. 

The object can then be dropped into another MacDraft document window, the 
Library palette, the desktop or any other image supporting applications.

To drag an object from the active MacDraft document to another document

��� Select the Arrow tool. 

��� Hold down the Command key, click the object and, holding down the mouse 
button, drag the cursor over the destination document window. 

A gray rectangle appears, showing the bounding frame of the object being 
dragged. If more than one object is dragged, a second rectangle, encompassing all 
the objects being dragged, is also shown. The maximum size of these rectangles is 
the size of the source document window.

��� Release the mouse button to drop a copy of the object into the second document. 

The object remains the same size when placed in the new document, but may 
EH�GLVSOD\HG�DW�D�GLͿHUHQW�VFDOH�DFFRUGLQJ�WR�WKH�FXUUHQW�YLHZ�VFDOH�VHW�IRU�HDFK�
document.
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NOTE: Press and hold down the Shift key and then release the mouse button to 
drop the dragged object(s) unscaled if the current scale of the destination MacDraft 
GRFXPHQW�GLͿHUV�IURP�WKH�VFDOH�RI�WKH�REMHFW�

127(��,W�PD\�EH�GLFXOW�WR�DFFXUDWHO\�SODFH�DQ�REMHFW�ZKHQ�XVLQJ�GUDJ�DQG�GURS�
WR�FRS\�DQ�REMHFW�LQWR�D�GRFXPHQW�ZLWK�D�GLͿHUHQW�YLHZ�VFDOH��2EMHFWV�GURSSHG�ZLOO�
always be aligned to the active grid, and MacDraft places the part of the object that 
was clicked in the original document, at the point that the mouse button is released 
in the new document, or as close to it as grid constraints allow (VHH�3RVLWLRQLQJ�REMHFWV��
&K����S����). 
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Using drag and drop with multiple objects

To move multiple objects or grouped objects, simply select the objects or group you want 
to move, then drag the objects or group to a new position. 

Alternatively, hold down the Shift key to drag only the object or group clicked, rather 
than all of the selected objects. Release the Shift key once the drag action has been started.

Cut/copy and paste

By using the Cut, Copy and Paste functions, you can remove or copy objects from one 
location on your drawing, then paste them into another location in the same drawing, a 
GLͿHUHQW�GUDZLQJ��RU�D�GLͿHUHQW�DSSOLFDWLRQ��

The Cut function deletes selected objects from the drawing and places them on the 
Clipboard. 

The Copy function makes a copy of selected objects and places the copy on the Clipboard, 
while leaving the original objects in place. 

You can place several objects on the Clipboard as long as they are selected and cut or 
copied at the same time. The objects are stored on the Clipboard until you are ready to 
paste them onto the drawing, or until you use Cut or Copy function again.

Using cut/copy and paste within a single MacDraft document

Cut and paste

To cut and paste an object

��� Select the object you want to move. 

��� Open the Edit menu and choose Cut. 

The selected object is removed from the drawing. 

��� Click the place where you want to paste the cut object. 

��� Open the Edit menu again and choose Paste. 

The object reappears at the location where you clicked.
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You can continue to paste objects that have been cut into as many areas on your drawing 
as you like by simply selecting the insertion point and choosing Paste from the Edit 
menu. The objects remain on the Clipboard�XQWLO�\RX�FXW�RU�FRS\�D�GLͿHUHQW�REMHFW�RQ�
\RXU�GUDZLQJ��WKHQ�WKH�ÀUVW�REMHFW�ZLOO�EH�UHSODFHG�ZLWK�WKH�QHZ�REMHFW�RQ�WKH�Clipboard.

Copy and paste

The Copy and Paste functions allow you to make a copy of an object and paste the copy 
LQWR�DQRWKHU�DUHD�RI�WKH�GUDZLQJ�ZLWKRXW�DͿHFWLQJ�WKH�VWDWXV�RI�WKH�RULJLQDO.
To copy an object and paste the copy into a different location

��� Select the object you want to copy. 

��� Open the Edit menu and choose Copy. 

��� A copy of the object will be stored on the Clipboard for your use. 

��� Click the place where you want to paste the copy. 

��� Open the Edit menu again and choose Paste. 

��� The object will be pasted in at the new location. 

��� You can continue to paste objects that have been copied into as many areas on your 
drawing as you like by simply selecting the insertion point and choosing Paste 
from the Edit menu. The objects remain on the Clipboard until you cut or copy a 
GLͿHUHQW�REMHFW�RQ�\RXU�GUDZLQJ��DW�WKDW�WLPH�WKH�ÀUVW�REMHFW�ZLOO�EH�UHSODFHG�ZLWK�
the new object on the Clipboard.

Using cut/copy and paste to transfer items from one MacDraft document to another

Cut and paste

MacDraft allows you to cut/copy and then paste all or part of a drawing into another 
MacDraft document. 

To cut or copy part of a drawing

��� Select all or the part of the drawing you wish to place in another document. 

��� Open the Edit menu and choose Cut or Copy. 
The selected objects will be stored on the Clipboard.

To paste objects into a different MacDraft document

��� Open the document into which you wish to paste the objects stored on the 
Clipboard. 

��� Click the place where you want to paste the objects into the drawing. 
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��� Open the Edit menu and choose Paste. 

7KH�REMHFWV�WKDW�\RX�FXW�RU�FRSLHG�ZLOO�EH�SDVWHG�LQWR�WKH�VSHFLÀHG�ORFDWLRQ�

The cursor changes to an “X”. 

��� Click the point you want to paste the object.

NOTE: When you cut or copy objects from one drawing and paste them into 
another drawing, the objects that you pasted take on the scale of the new 
drawing. For example, if you copy an object from a drawing with a scale of 1" = 
20', then paste it into a drawing with a scale of 1" = 10', the object would appear 
twice as large as it did on the original drawing. In reality, the object is still the 
same size, but it is represented at the new scale. To avoid this use the Paste 
Unscaled feature (VHH�3DVWH�XQVFDOHG��&K����S����).

Paste unscaled

If you hold down the Shift key, the Paste command in the Edit menu changes to Paste 
Unscaled. Use the Paste Unscaled command to paste an object into a document and have 
LW�DSSHDU�DW�LWV�RULJLQDO�VL]H��UHJDUGOHVV�RI�DQ\�GLͿHUHQFHV�LQ�YLHZ�VFDOH�EHWZHHQ�WKH�REMHFW�
and the destination document window.

Repeated paste

You may often want to use an object on your drawing in more than one location. To 
accomplish this you can use either the Copy and Paste functions (see Copy and paste on 
page 5-7), the Duplicate function (VHH�'XSOLFDWLQJ�REMHFWV��&K����S����) or the Repeated 
Paste function. These functions save you the time of redrawing the object again and 
again. 

The Repeated Paste function is used to paste multiple copies of the same object into 
various locations on a drawing. When using Repeated Paste, any object on the Clipboard 
is pasted into the drawing at each point you click. While in this mode, you can scroll the 
window and continue to paste in objects.

To use the repeated paste function

��� Cut or copy the object you want to paste. 

��� Select the Repeated Paste tool in the Tool palette or open the Edit menu and choose 
Repeated Paste. 
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��� Continue to move the cursor and click the areas on the drawing until you’ve 
pasted as many copies of the object as you want into your document. 

A copy of the object appears at each point you click the drawing. The object’s 
datum point will be used as the reference point for the paste operation (see Datum 
SRLQWV��&K����S����).

��� Click the Pointer�WRRO�ZKHQ�\RX�KDYH�ÀQLVKHG�SDVWLQJ�

Viewing the Clipboard

You may sometimes want to see exactly what information, if any, is stored on the 
Clipboard.

To view the Clipboard

��� Open the Edit menu and choose Show Clipboard. 
The Clipboard appears.
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Using cut/copy and paste to transfer items from MacDraft to other applications 

At times you may want to use MacDraft in conjunction with other applications, such as 
a word processor or a chart program. For example, you may want to paste a chart into 
MacDraft to enhance its graphics appearance, then paste it into a page layout document.

Transferring objects from Microspot MacDraft

To transfer objects to other applications using the clipboard:

��� Select the object or objects you want to move. 

��� Open the Edit menu and choose Cut or Copy. 

The selected objects will be placed on the Clipboard. 

��� Switch to another application. 

Once you leave MacDraft, all objects on the Clipboard will be converted to the 
PICT format. 

��� In the new application, open the Edit menu and choose Paste. 

The cut or copied objects appear as a PICT image in the new application’s 
document window.
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The Move command

With the Edit menu’s Move command, you can move objects or groups with great 
precision by entering values from the keyboard. 

2EMHFWV�FDQ�HLWKHU�EH�PRYHG�WR�D�VSHFLÀF�ORFDWLRQ��DEVROXWH�PRYH���RU�PRYHG�E\�D�
VSHFLÀHG�DPRXQW��UHODWLYH�PRYH���7KH�VHWWLQJ�IRU�Absolute or Relative mode in the Move 
dialog will be stored for subsequent openings of the dialog, until the application is 
closed. 

The coordinates or distances are shown in the current layer's scale and units. 

The Move a Copy�RSWLRQ�SODFHV�D�FRS\�RI�WKH�VHOHFWLRQ�LQ�D�VSHFLÀHG�ORFDWLRQ�ZKLOH�
leaving the original in place. 

The datum point of the selected object or group (VHH�'DWXP�SRLQWV��&K����S����) is used as 
the reference for moving. Therefore, to move an object, you specify the desired location 
(the X and Y coordinates) of the object’s datum point. If you select multiple objects or 
groups, MacDraft uses the datum point of the top left item as the reference. 

Absolute move

To move objects or groups to a particular location on the drawing

��� Select the objects or groups you want to move.

��� Open the Edit menu and choose Move. 

The Move dialog appears.
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��� Click the Absolute radio button if necessary. The current location of the selection 
will be shown.

��� Type in the X and Y coordinate values for the new location. 

��� Click one of the following buttons: 

�� Apply: To apply the changes and leave the dialog open. 

�� Close: To close the dialog without applying the changes. 

�� Done: To apply the changes and close the dialog. 

The selection (or a copy of it) is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the coordinate 
system is the upper left corner of the window. The rulers along the top and left sides 
of the window are used to control the zero origins. In this default coordinate system, X 
values increase from left to right and Y values increase from top to bottom. 

You can change the zero origins of the rulers (VHH�5XOHUV��&K����S����).

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.
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Relative move

,Q�UHODWLYH�PRYHPHQW��SRVLWLYH�YDOXHV�IRU�GLVWDQFH�PRYH�LWHPV�WR�WKH�ULJKW��LQ�WKH�Ј;�
ÀHOG��RU�GRZQZDUG��LQ�WKH�Ј<�ÀHOG���1HJDWLYH�YDOXHV�PRYH�LWHPV�WR�WKH�OHIW�RU�XSZDUGV�
To move items relative to their original position

��� Select the objects or groups you want to move. 

��� Open the Edit menu and choose Move. The Move dialog appears. 

��� Click the Relative radio button if necessary. The starting position will be shown as 
]HURHV�LQ�WKH�Ј;��KRUL]RQWDO�FKDQJH��DQG�Ј<��YHUWLFDO�FKDQJH��ÀHOGV��

��� (QWHU�YDOXHV�WR�PRYH�WKH�VHOHFWLRQ�E\�LQWR�WKH�Ј;�DQG�Ј<�ÀHOGV��

��� Click one of the following buttons: 

�� Reverse: To apply the entered values as though they were negative amounts. 

�� Apply: To apply the changes and leave the dialog open. 

�� Close: To close the dialog without applying the changes. 

�� Done: To apply the changes and close the dialog. 
The selection (or a copy of it) is moved to the new location. 

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.
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Moving objects using the Resize palette

The Resize�SDOHWWH·V�3RVLWLRQ�;�DQG�<�ÀHOGV�FDQ�EH�XVHG�WR�PRYH�D�VHOHFWHG�REMHFW�RU�
group to an absolute position on the drawing or by relative horizontal and vertical 
GLVWDQFHV��$OO�PRYHPHQW�LV�GHÀQHG�LQ�WKH�XQLWV�DQG�VFDOH�RI�WKH�DFWLYH�OD\HU�

Absolute move

To move objects or groups to a particular location on the drawing

��� Select the objects or groups you want to move. 

��� Open the Resize palette 

��� Click the Absolute radio button if necessary. The current location of the selection 
appears.

The Resize palette

Most of the controls on the Resize Palette are discussed in Chapter 2 (VHH�5HVL]LQJ�REMHFWV��
&K����S����). However the Resize palette can also be used to move a single object or 
group, within the current active layer, and these controls are discussed in this section.

To display the Resize palette

�� Choose Resize from the Palettes menu in the View menu, or 

�� Choose Resize from the pop-up menu at the bottom left of the document window.

Close Palette

NOTE: The Select Pt button is not relevant to the move operation.
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��� Type in the X and Y position values for the new location.

��� Click the Apply button. 

The selection is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the coordinate 
system is the upper left corner of the window. The rulers along the top and left sides 
of the window are used to control the zero origins. In this default coordinate system, X 
values increase from left to right and Y values increase from top to bottom. 

You can change the zero origins of the rulers (VHH�5XOHUV��&K����S����).

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears. 

Relative move

,Q�UHODWLYH�PRYHPHQW��SRVLWLYH�YDOXHV�IRU�GLVWDQFH�PRYH�LWHPV�WR�WKH�ULJKW��LQ�WKH�;�ÀHOG��
RU�GRZQZDUG��LQ�WKH�<�ÀHOG���1HJDWLYH�YDOXHV�PRYH�LWHPV�WR�WKH�OHIW�RU�XSZDUGV��
To move items relative to their original position

��� Select the objects or groups you want to move. 

��� Open the Resize palette. 

��� Click the Relative radio button if necessary. The starting position will be shown as 
]HURHV�LQ�WKH�;��KRUL]RQWDO�FKDQJH��DQG�<��YHUWLFDO�FKDQJH��ÀHOGV�
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��� (QWHU�YDOXHV�WR�PRYH�WKH�VHOHFWLRQ�E\�LQWR�WKH�;�DQG�<�ÀHOGV�

��� Click the Apply button. 

The selection is moved to the new location.

NOTE: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears. 

Moving using the arrow keys

Selected objects and groups can be moved using the arrow keys on the keyboard. 

When a grid is on (VHH�*ULG�VQDS��&K����S����), each press of an arrow key moves (or 
“nudges”) the current selection one grid increment in the appropriate direction: left, 
right, up, or down. If no grid is on, the selection moves one screen pixel (1/72 of an inch) 
for each keystroke. 

Press and hold down the Command key and press an arrow key to release the selection 
from an active grid and allow the selection to be moved one pixel at a time.
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The Clear function

Objects can be removed permanently from the drawing using the Clear function. The 
object can only be recalled by using Undo.

Using the Clear function

To clear a single object

��� Select the object to be deleted from the drawing by clicking it. 

��� Open the Edit menu and choose Clear. 

The selected object will be removed from the drawing.

To clear multiple objects

��� Select the objects to be deleted from the drawing by Shift-clicking them, or by 
using the selection rectangle (VHH�6HOHFWLQJ�REMHFWV��&K����S���). 

��� Open the Edit menu and choose Clear. 

The selected objects will be removed from the drawing.

To clear the entire contents of a layer

There may be times when you want to throw away all the contents of the active layer and 
start over again. To accomplish this:

��� Open the Edit menu and choose Select All. 

All the objects on the active layer will be selected. 

��� Open the Edit menu again and choose Clear. 

All objects will be removed from the drawing.

NOTE: You can also press the Delete key to delete selections.
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�   5.2 Duplicating objects

Objects can be duplicated by using the Duplicate command or by using the Option drag 
command. 

The Duplicate command

The Duplicate command is used to make an exact copy of any object or line on the 
GUDZLQJ��7KH�GXSOLFDWH�REMHFW�LV�SODFHG�LQ�IURQW�RI�WKH�RULJLQDO�LQ�D�VOLJKWO\�RͿVHW�SRVLWLRQ��
and is selected. You can then drag the duplicate into the desired position on your 
drawing.

Using the Duplicate command

To duplicate an object

��� Select the object you want to duplicate.
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��� Open the Edit menu and choose Duplicate.

The object is duplicated. The duplicate object is placed in front of the original in an 
RͿVHW�SRVLWLRQ��ZKLFK�LV���LQFUHPHQW�RI�WKH�FXUUHQW�JULG�KRUL]RQWDOO\�DQG�YHUWLFDOO\�

��� To make a second or third duplicate, simply choose the Duplicate command again, 
and again. Each new duplicate appears in front of the previous one.

NOTES: 
�� Hold down the Shift key and the Duplicate command changes to Duplicate 

without offset. Use this option to create a duplicate that is placed directly on 
top of the original. 

�� Hold down the Control key to avoid duplicating locked objects. All other 
objects in the selection will be duplicated.

�� Hold down the Option key and drag the item to duplicate.
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Auto-spacing of duplicate objects

If you want to create a row or column of identical, evenly spaced objects, the Duplicate 
function incorporates an auto-spacing feature that allows you to determine the distance 
and angle you want between objects. You can then make new duplicates that will be 
automatically placed at that distance and angle. 

To use auto-spacing during creation

��� Select the object to be duplicated.

��� Open the Edit menu and choose Duplicate. 

��� Position the cursor over the selected duplicate, hold down the mouse button, drag 
the duplicated object to the desired position relative to the original, and release the 
mouse button. (Alternatively move the duplicate using the arrow keys.)
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��� Open the Edit menu and choose Duplicate again. 

Notice that the second duplicate is automatically placed in the same position 
UHODWLYH�WR�WKH�ÀUVW�GXSOLFDWH�DV�WKH�ÀUVW�GXSOLFDWH�LV�WR�WKH�RULJLQDO��

��� Keep choosing Duplicate to produce as many duplicates as you need.

�   5.3 Arranging objects

You can use some of the commands in the Arrange menu to manipulate the positions 
of objects. You can perform the following actions using these commands: move objects 
backwards and forwards; group and ungroup objects; align and distribute objects. 
The tools in the Alignment palette can be used also to distribute and align objects. The 
commands in the Arrange�PHQX�DͿHFW�RQO\�WKH�REMHFWV�RQ�WKH�DFWLYH�GRFXPHQW�

Moving objects backwards and forwards

When you create multiple objects, the newest object created appears on the top plane, 
while the oldest object appears on the bottom plane, that is, each new object appears on 
the plane above the previous object. At times, you might want to move an object in front 
of or behind other objects on the same layer. The functions that allow you to do this are 
Bring to Front, Send to Back, Move Forward One, and Move Back One. 

Bring to front

If an object is currently behind other objects, you can move it in front of the other objects 
on the layer by using the Bring to Front function.
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To bring an object to the front

��� Select the object you want to move to the foreground. 

��� Open the Arrange menu and choose Bring to Front. 

The selected object will be moved in front of the other objects. 
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��� Open the Arrange menu and choose Send to Back.

The selected object will be moved behind the other objects. 

Send to back

To reposition an object behind all other objects on the layer

��� Select the object you want to move to the background.
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��� Open the Arrange menu and choose Move Forward One.

The selected object will be moved forward one level. 

Move forward one

To move an object forward one level

��� Select the object you want to move forward.
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��� Open the Arrange menu and choose Move Back One.

The selected object will be moved back one level.

Move back one

To move an object back one level

��� Select the object you want to move back one level.
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Grouping and ungrouping objects

Grouping objects

In a drawing that contains several individual objects, you might want to group some 
objects together so that you can treat them as a single object. When objects are grouped 
together, most functions you choose will be performed on the entire group just as though 
it were a single object. 

To group several objects together

��� Select all the objects that you want in the group.
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��� Open the Arrange menu and choose Group.

Notice that the objects are now surrounded by a single set of edit handles. This 
indicates that all objects within the edit handles are part of this group and will 
be treated as a single object. You can perform any function on the group, such as 
PRYH��GXSOLFDWH�RU�ÀOO��DQG�WKH�HQWLUH�JURXS�UHVSRQGV�WR�WKDW�FRPPDQG��2QFH�\RX�
have grouped several objects, you cannot reposition or edit any individual object 
RU�SLHFH�RI�WH[W�ZLWKLQ�WKH�JURXS�XQOHVV�\RX�ÀUVW�XQJURXS�WKH�REMHFWV�

Ungrouping objects

If you no longer require a set of objects to be grouped, or if you need to edit one of 
the individual objects, you can use the Ungroup function to return the objects to their 
individual status. 

To ungroup objects:

��� Select the group of objects by clicking one of the objects. 

��� Open the Arrange menu and choose Ungroup. 

Notice that each object has its own set of edit handles again. This is an indication 
that the objects are no longer part of a grouped set, and that you can now select 
and edit each object individually.
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Aligning and distributing objects

Alignment palette

The Alignment palette provides tools for you to carry out the most common alignments 
without having to access the Alignment Options dialog.

To display the Alignment palette

�� Choose Alignment from the Palettes menu in the View menu, or 

�� Choose Alignment from the pop-up menu at the bottom left of the document 
window 

NOTE: The remaining buttons are used to distribute objects along a line (see 
'LVWULEXWLQJ�REMHFWV��&K����S����). 

Align Bottom Edges Align Vertical CentersAlign Top Edges

Align Right EdgesAlign Left Edges Align Horizontal Centers 

To use the  alignment palette

��� Select the object(s) to be aligned. 

��� In the Alignment palette, click the desired alignment button. 
The cursor will be displayed as ‘Click Reference Object’. 

��� Click the object to align the other object(s) with. 

The selected object(s) will be aligned with the reference object according to the 
alignment tool chosen. 
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Distributing objects

2EMHFWV�FDQ�EH�SRVLWLRQHG�DQG�DOLJQHG�DORQJ�D�GHÀQHG�OLQH��7KLV�FDQ�EH�GRQH�XVLQJ�WKH�
Distribute on Line command or using options in the Alignment palette.

Distribute on Line command

The Distribute on Line function allows you to position and align selected objects along a 
OLQH�WKDW�\RX�GHÀQH��7KH�REMHFWV�DUH�GLVWULEXWHG�DFFRUGLQJ�WR�WKHLU�OHYHO�RQ�WKH�GUDZLQJ��
L�H��WKH�REMHFW�IDUWKHVW�EDFN�DSSHDUV�RQ�WKH�GLVWULEXWLRQ�OLQH�ÀUVW��DQG�WKH�IRUHPRVW�REMHFW�
appears last. By default, the objects automatically align themselves along their centers, 
and will be equally spaced apart on the line. You can also choose to align the objects 
according to their datum points.

To distribute objects on a line

��� Select the objects to be distributed. 

NOTE: To align objects to one element of a group (rather than to the group 
as a whole), hold down the Option key when the click reference object cursor 
appears, then click the element of the group to which you want to align the 
other objects. 

��� Open the Arrange menu and choose Distribute on Line. 

��� Move the pointer to the point on your drawing where you would like to place the 
ÀUVW�REMHFW��

��� Press and hold down the mouse button.
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��� Drag in the direction you want to distribute the objects.

��� Release the mouse button. 

7KH�REMHFWV�ZLOO�EH�GLVWULEXWHG�DORQJ�WKH�OLQH�\RX�VSHFLÀHG��7KHLU�FHQWHU�SRLQWV�ZLOO�
be spaced equally apart along the line.

NOTES: 
�� To align objects according to their datum points, press and hold down the 

Option key before you open the Arrange menu and choose Distribute on Line. 
�� To constrain the line the objects are to be distributed along, hold down the Shift 

NH\�DV�\RX�GHÀQH�WKH�OLQH�DQG�LW�ZLOO�VQDS�WR����GHJUHH�LQFUHPHQWV�
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Alignment palette

The distribute controls in the Alignment palette distribute objects in the same way as the 
GLVWULEXWH�FRPPDQG��EXW�WKH�OLQH�LV�GHÀQHG�IRU�\RX�
To display the Alignment palette

�� Choose Alignment from the Palettes menu in the View menu, or 

�� Choose Alignment from the pop-up menu at the bottom left of the document 
window. 

Distribute horizontally 
by center

Distribute horizontally 
by datum

Distribute vertically 
by center

Distribute vertically 
by datum

To use the distribute controls in the Alignment palette

��� Select the objects on the drawing to be distributed. 

��� Click the appropriate button to distribute the objects horizontally or vertically by 
center or by datum point. 

7KH�REMHFWV�ZLOO�EH�GLVWULEXWHG�DORQJ�D�OLQH�LQ�WKH�PDQQHU�VSHFLÀHG�

�   5.4 Transforming objects

2EMHFWV�FDQ�EH�WUDQVIRUPHG�E\�URWDWLQJ��ÁLSSLQJ�RU�PLUURULQJ�WKHP�

Rotating objects

MacDraft provides several tools and commands that can be used to rotate objects freely 
RU�E\�VSHFLÀHG�DPRXQWV��
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To rotate an object 90° anti-clockwise around its center

�� Select an object in the drawing then click the Rotate 90° tool.

To rotate an object 90° clockwise around its center

�� Select an object in the drawing and holding down the Shift key, click the Rotate 90° 
tool.

Rotate by 90° tool

The MacDraft Tool palette includes a Rotate by 90° tool:
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To rotate an object 90° anti-clockwise around its datum point

�� Select an object in the drawing and holding down the Option key, click the Rotate 
90° tool. In this example the datum point is marked by a small circle (see Datum 
SRLQWV�RQ�SDJH�����). 

To rotate an object 90° clockwise around its datum point

�� Select an object in the drawing and holding down the Option and Shift keys, click 
the Rotate 90° tool. 

Rotate tool and Rotate command

The Rotate tool and Rotate command allow you to rotate objects by any angle you want. 
<RX�FDQ�URWDWH�REMHFWV�LQ�YDULRXV�LQFUHPHQWV�XVLQJ�WKH�PRXVH��WR�HQWHU�D�VSHFLÀF�YDOXH�
through the keyboard, use the Rotate Options (VHH�5RWDWH�RSWLRQV��&K����S����). 

You can rotate single objects, multiple objects, or grouped objects. Unless you specify 
otherwise, selected single or multiple objects will rotate around their individual centers. 
If you wish you can also specify the center of rotation for selected objects.

To enter rotation mode

�� Choose Rotate from the Arrange menu, or 

�� Click the Rotate tool in the Tool palette

To exit rotation mode:

�� Click the Pointer tool.
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7R�URWDWH�DQ�REMHFW�LQ�VSHFLÀF�GHJUHH�LQFUHPHQWV

�� Go to the Layout menu and change Set Angle Snap to what you want.

Changing the rotation units

To rotate an object in minutes or decimal fractions

��� Press and release the Shift key while rotating an object. 

��� Continue to drag in a circular direction to rotate the objects in minutes. 

Rotating an object

To rotate an object:

��� Select the object to be rotated. 

��� Choose the Rotate tool or the Rotate command from the Arrange menu. 

��� Position the cursor in the window, then press and hold down the mouse button. 

The cursor changes into a rotation indicator. 

��� Holding down the mouse button, drag in a circular direction until you have 
rotated the object the desired number of degrees, and release the mouse button. 

To see the exact number of degrees an object is being rotated, open the Show Size 
palette (VHH�6KRZ�6L]H��&K����S����). 
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7KH�QXPEHU�RI�GHJUHHV�UHPDLQV�À[HG�
To rotate an object in seconds

��� Press and release the Shift key twice while rotating an object. 

��� Continue to drag to rotate the objects in seconds. 

As you rotate the object in seconds, the number of degrees and minutes are 
constrained. 

Returning to previous rotation units

You can return to the previous rotation units (from seconds to minutes, and minutes to 
degrees) by using the Command key.

To return to the previous rotation units

�� Press the Command key while in the rotation mode.

Rotating multiple objects

When rotating multiple objects, by default each object rotates around its individual 
center.

Rotating grouped objects

When rotating a grouped object, all the objects in the group rotate around the center of 
WKH�JURXS��XQOHVV�\RX�VSHFLI\�D�GLͿHUHQW�FHQWHU�RI�URWDWLRQ��

Rotating text

The rotation feature works exactly the same way when you rotate a text block as it 
does when you rotate other objects. (6HH�6HOHFWLQJ�URWDWHG�WH[W�IRU�HGLWLQJ��&K����S���� for 
information about selecting and editing rotated text blocks.) 

Rotating bitmaps

Rotate your bitmap image in the same way you would rotate another object. 

Choosing the centre of rotation

Objects are usually rotated about their centers, however you can also specify any point 
on the drawing as the center of rotation.
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7R�URWDWH�REMHFWV�DURXQG�D�VSHFLÀHG�SRLQW

��� Select the objects you want to rotate. 

��� Choose the Rotate tool or the Rotate command from the Arrange menu. 

��� Position the cursor on the point you want to use as the center of rotation. 

You can use the scroll controls to move to a part of the drawing that is outside your 
current view. 

��� Press and hold down the Option key. 

��� Press and hold down the mouse button. 

��� Holding down the mouse button and the Option key, drag in a circular direction 
until you have rotated the object the desired number of degrees. 

��� Release the mouse button and the Option key.

Rotate to zero command

The Rotate to zero command allows you to return an object to its original angle of 
rotation.
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To return an object to its original angle of rotation

��� Select a rotated object.

��� Choose Rotate to Zero from the Arrange menu. 

The object will be returned to its original angle of rotation. 

Rotate options

You can use the keyboard to directly enter the rotation values in degrees, minutes, and 
seconds using the Rotate Options dialog. 

The Rotate Options dialog

To display the Rotate Options dialog

��� Select the object or objects you want to rotate.
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��� Choose Rotate Options from the Arrange menu. 

The Rotate Options dialog appears.

Amount of rotation

7KH�ÀHOGV�DYDLODEOH�WR�HQWHU�WKH�URWDWLRQ�DPRXQW�YDU\�GHSHQGLQJ�RQ�WKH�Angular Display 
option selected in the Document Scale and Units dialog (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��
&K����S�������7KH�DERYH�VFUHHQ�VKRW�VKRZV�WKH�ÀHOG�WKDW�DSSHDUV�ZKHQ�GHFLPDO�GHJUHHV�
are selected. 

7R�HQWHU�DQ�DPRXQW�IRU�URWDWLRQ��GRXEOH�FOLFN�WKH�DSSURSULDWH�ÀHOG�DQG�W\SH�LQ�D�YDOXH��

Direction of rotation

The default direction for rotation is counterclockwise. To rotate an object in a clockwise 
direction, click the Clockwise checkbox. 

Center of rotation

The default center of rotation is the center of the selected object or objects. To rotate 
objects about their datum points, click the Datum of object(s) radio button (see Datum 
SRLQWV��&K����S�������7R�URWDWH�REMHFWV�DERXW�D�VSHFLÀHG�UHIHUHQFH�SRLQW��FOLFN�WKH�A 
reference point radio button. 

If the A reference point radio button is on, the Rotate Options dialog disappears and the 
Rotation cursor will be shown over the drawing. Click the point you want to use as the 
center of rotation.



Chapter 5 Transforming & Arranging Objects 260

To rotate an object or objects

��� Select the object or objects you want to rotate.

��� Choose Rotate Options from the Arrange menu. 
The Rotate Options dialog appears. 

��� Enter the desired angle of rotation. 

��� Specify the direction and center of rotation. 

��� Click the Rotate button.
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��� Specify the reference point to rotate about if necessary.

7KH�VHOHFWHG�REMHFW�RU�REMHFWV�ZLOO�EH�URWDWHG�WKH�VSHFLÀHG�QXPEHU�RI�GHJUHHV��
minutes, and seconds around the requested center of rotation. 

Flipping objects

Sometimes you may want to display the reverse image of an object. For this, MacDraft 
has the Flip Horizontal and Flip Vertical commands. 

You can duplicate an object and then use one of the Flip functions to create the other side 
of that object for the sake of symmetry, as well as convenience. 

127(��3LFWXUHV�FDQ�EH�ÁLSSHG�DV�ZHOO�DV�REMHFWV��KRZHYHU�WH[W�LV�WUHDWHG�VOLJKWO\�
GLͿHUHQWO\��VHH�)OLSSLQJ�WH[W��&K����S����).
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Flipping an object or picture

7R�ÁLS�DQ�REMHFW�KRUL]RQWDOO\

��� 6HOHFW�WKH�REMHFW�\RX�ZDQW�WR�ÁLS�

��� Open the Arrange menu and choose Flip Horizontal. 

7KH�REMHFW�ZLOO�EH�ÁLSSHG�DERXW�LWV�YHUWLFDO�D[LV�
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7R�ÁLS�DQ�REMHFW�YHUWLFDOO\

��� 6HOHFW�WKH�REMHFW�WKDW�\RX�ZDQW�WR�ÁLS�

��� Open the Arrange menu and choose Flip Vertical.

7KH�REMHFW�ZLOO�EH�ÁLSSHG�DERXW�LWV�KRUL]RQWDO�D[LV�

Flipping text

7H[W�LV�QRW�ÁLSSHG�LQ�WKH�VDPH�ZD\�DV�REMHFWV��DV�RIWHQ�LW�GRHV�QRW�PDNH�VHQVH�WR�SURGXFH�
D�PLUURU�LPDJH�RI�WH[W��+RZHYHU�\RX�PD\�ZHOO�ZDQW�WR�ÁLS�D�JURXS�WKDW�LQFOXGHV�WH[W��
and have the text shown in its correct position and orientation in relation to the objects in 
the group. If you do want to produce a mirror image of text, use the Mirror text style (see 
'HÀQH�DWWULEXWHV�IRU�WH[W��&K����S����).
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�   5.5 Lock and Unlock 

You may sometimes want to make sure that objects on your drawing are not moved or 
changed by mistake. To do this you can use MacDraft’s Lock feature to make sure certain 
objects remain unchanged. 

Locking and unlocking objects

To lock objects

Locked objects on the drawing cannot be edited, moved, copied, pasted, or deleted. None 
RI�0DF'UDIW·V�IXQFWLRQV�DͿHFW�ORFNHG�REMHFWV�

�� Flip horizontal: 7KH�SRVLWLRQ�RI�WKH�WH[W�LQ�WKH�JURXS�LV�ÁLSSHG��EXW�WKH�WH[W�UHPDLQV�
at the same orientation. 

�� Flip vertical: 7KH�SRVLWLRQ�RI�WKH�WH[W�LQ�WKH�JURXS�LV�ÁLSSHG��DQG�WKH�WH[W�LV�URWDWHG�
through 180°.

Original group Flip horizontal Flip vertical 
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To unlock objects

<RX�PD\�ODWHU�UHDOL]H�WKDW�\RX�QHHG�WR�HGLW�ORFNHG�REMHFWV��7R�GR�WKLV��\RX�PXVW�ÀUVW�
unlock them.

To unlock objects

��� Select the locked objects you want to unlock. 

��� Open the Arrange menu and choose Unlock. 

The objects will be unlocked and the edit handles will be shown normally to 
indicate this. 

To lock objects

��� Select the objects you want to lock. 

��� Open the Arrange menu and choose Lock. 

The objects will be locked and the edit handles are dimmed to indicate this. 
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0DF'UDIW�RͿHUV�VHYHUDO�XVHIXO�IHDWXUHV�WKDW�PDNH�\RXU�GUDZLQJ�WDVNV�PXFK�HDVLHU��VKRZ�
size, rulers, cursor position indicator, grid snap, angle snap, grid lines, snap to object and 
line snapping, and document units and scale. This chapter discusses these drawing aids 
in detail.

�   6.1 Show Size

MacDraft is a precision drawing application designed to help you create detailed 
drawings. The Show Size function makes it easier to draw objects precisely because it 
provides a continuous display of an object’s size as you draw or resize it. It also shows 
the degree of rotation as you rotate objects. 

The units displayed in the Show Size palette are determined by the current options 
chosen in the Document Scale & Units dialog (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����S����).

Displaying the Show Size palette

To open the Show Size palette 

�� Choose Show Size from the Window menu, or 
�� Choose Show Size from the pop-up menu at the bottom left of the document 

window. 
The Show Size palette appears. 

Chapter 6.0

Drawing Aids
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Using Show Size with drawing tools 

Line tools

When using line tools (including the Perpendicular, Tangent, Parallel, and Extrude tools), 
the Show Size palette displays the length (X) of the line and the angle(A°) at which the 
line is drawn. 

Square-corner rectangles

When drawing square-corner rectangles, the Show Size palette displays the width (X) and 
height(Y) of the rectangle. 

Text tool

:KHQ�GUDZLQJ�D�UHFWDQJOH�WR�GHÀQH�WKH�EORFN�IRU�SDUDJUDSK�WH[W��WKH�Show Size palette 
displays the width (X) and height(Y) of the rectangle.
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Center to side

When drawing a regular polygon from center to side, the Show Size palette displays the 
center to side radius (R) of the polygon. 

Vertex to vertex

When drawing a regular polygon from vertex to vertex, the Show Size palette displays 
the vertex to vertex diameter (D) of the polygon.

Regular polygons

Side to side

When drawing a regular polygon from side to side, the Show Size palette displays the 
side to side diameter (D) of the polygon. 
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Center to vertex

When drawing a regular polygon from center to vertex, the Show Size palette displays 
the center to vertex radius (R) of the polygon. 

Elliptical-corner rectangles

When drawing an elliptical-corner rectangle, the Show Size palette displays the height (Y) 
and width(X) of the rectangle, and the major and minor radii of the arcs on the corners.

Rounded-corner rectangles

Proportional- and constant-corner rectangles

When drawing a proportional- or constant-corner rectangle, the Show Size palette 
displays the height(Y) and width(X) of the rectangle, and the radius(R) of the corners. 
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Circle by radius

When drawing a circle by radius, the Show Size palette displays the radius (R) of the 
circle. 

Ellipses

When drawing an ellipse, the Show Size palette displays the width(X) and height (Y) 
diameters of the ellipse.

Circles and ellipses

Circles by diameter

When drawing a circle by diameter, the Show Size palette displays the diameter (D) of the 
circle. 
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Concentric circles

When drawing a concentric circle, the Show Size palette displays the radius (R) of the 
circle. 

Arcs by three points

As you create an arc by three points, the Show Size palette does not become active until 
you are moving from the second to the third point in the arc. At that time, it shows the 
entire arc angle (A°).

Arcs

By radius

As you drag to create the radius of an arc, the Show Size palette displays the length of 
WKH�UDGLXV�5��DQG�WKH�VWDUWLQJ�DQJOH�$Ý���7KH�VWDUWLQJ�DQJOH�LV�WKH�DQJOH�EHWZHHQ�WKH�OLQH�
attached to the cursor and the X-axis. 

Once you release the mouse button and move the mouse to create the arc, the Show Size 
SDOHWWH�FKDQJHV�WR�GLVSOD\��WKH�GLͿHUHQFH�EHWZHHQ�WKH�VWDUWLQJ�DQJOH�DQG�WKH�HQGLQJ�DQJOH�
RI�WKH�DUF��L�H���WKH�DFWXDO�QXPEHU�RI�GHJUHHV�WKURXJK�ZKLFK�WKH�DUF�SDVVHV�Ј$Ý���WKH�DQJOH�
between the ending angle (shown on-screen by the line attached to the cursor) and the 
;��D[LV��$Ý���



Chapter 6 Drawing Aids 272

Elliptical arcs

When you start drawing an elliptical arc, the Show Size palette displays the height(Y) and 
ZLGWK�;��RI�WKH�HOOLSVH�XVHG�WR�GHÀQH�WKH�VL]H�RI�WKH�DUF��,W�DOVR�VKRZV�\RX�WKH�VWDUWLQJ�
DQJOH��$Ý���ZKLFK�LV�WKH�DQJOH�EHWZHHQ�WKH�OLQH�DWWDFKHG�WR�WKH�FXUVRU�DQG�WKH�;�D[LV��

:KHQ�\RX�ÀQLVK�GHÀQLQJ�WKH�VL]H�DQG�WKH�VWDUWLQJ�DQJOH�RI�WKH�DUF��WKH�ZLQGRZ�VKRZV�
\RX��WKH�GLͿHUHQFH�EHWZHHQ�WKH�VWDUWLQJ�DQJOH�DQG�WKH�HQGLQJ�DQJOH��L�H��WKH�DFWXDO�
QXPEHU�RI�GHJUHHV�WKURXJK�ZKLFK�WKH�DUF�SDVVHV�Ј$Ý���WKH�DQJOH�EHWZHHQ�WKH�HQGLQJ�
DQJOH��VKRZQ�RQ�VFUHHQ�E\�WKH�OLQH�DWWDFKHG�WR�WKH�FXUVRU��DQG�WKH�;�D[LV��$Ý���

Irregular polygons

When using irregular polygon or polyline tools (including the double-line polygon or 
polyline tools), the Show Size palette displays the length (X) of the line and the angle(A°) 
of the line, for each side of the polygon as it is drawn.

Using Show Size with rotation 

When rotating an object, the Show Size palette displays how much you have rotated the 
object(A°).
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Angles of rotation range from zero to 360 degrees, moving counterclockwise from a 
rightward-pointing or “due East” orientation. 

You can rotate objects in degrees, minutes and seconds, or in degrees and decimal 
fractions (VHH�5RWDWLQJ�REMHFWV��&K����S����). 

Hiding the Show Size palette 

To remove the Show Size palette from the screen

�� Click the palette’s close box, or 
�� Choose Show Size from the Window menu, or 
�� Choose Show Size from the pop-up menu at the bottom left of the document 

window. 

The Show Size palette disappears, and there will no longer be a checkmark against its 
name in the View menu’s Palettes submenu etc. 

�   6.2 Rulers

Rulers are used as drawing aids to help you position objects in precise locations on your 
drawing. Rulers appear along the top and on the left side of the drawing window. 

7KH�GLVSOD\HG�UXOHUV�UHÁHFW�WKH�FXUUHQW�SRVLWLRQ�RI�WKH�ZLQGRZ�GXULQJ�VFUROOLQJ��DQG�WKHLU�
VFDOH�UHÁHFWV�WKH�FXUUHQW�PDJQLÀFDWLRQ�OHYHO��

Displaying rulers

To display rulers

�� Open the Layout menu and choose Show Rulers.
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The rulers will be displayed, and a checkmark appears by the Show Rulers 
command in the Layout menu. 

Types of rulers

0DF'UDIW�RͿHUV�WZR�W\SHV�RI�UXOHUV��VWDQGDUG�DQG�VFDOH�

Standard rulers

6WDQGDUG�UXOHUV�VKRZ�WKH�DFWXDO�VL]H�RI�WKH�GUDZLQJ�LQ�WKH�XQLWV�VSHFLÀHG�LQ�WKH�Set Scale 
and Units dialog (VHH�8QLWV��&K����S����). 

To display standard rulers (if Show Rulers is checked)

�� Open the Layout menu and choose Standard Rulers. 
The rulers show the actual size of the drawing, in this example, in inches.

Scale rulers

6FDOH�UXOHUV�UHÁHFW�WKH�FXUUHQW�GUDZLQJ�VFDOH�RI�\RXU�GRFXPHQW��)RU�H[DPSOH��RQ�D����µ�
= 1' scale, the major ruler divisions will be in increments of four: 4 ft., 8 ft., and so on (see 
'RFXPHQW�XQLWV�DQG�VFDOH��&K����S����). 

To display scale rulers (if Show Rulers is active)

�� Open the Layout menu and choose Scale Rulers.
7KH�UXOHUV�VKRZ�WKH�GUDZLQJ�PHDVXUHPHQWV�DFFRUGLQJ�WR�WKH�VFDOH�VSHFLÀHG�
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In this example, the scale is 1/4" = 1' and the size units are set at fractional feet and inches 
(VHH�8QLWV��&K����S����). 

Setting the rulers’ zero points

There may be occasions when you want to change the zero point of the rulers from the 
upper left corner of your drawing to some other convenient point on the drawing. For 
instance, you may want to set the zero point of the rulers to one edge of an object so that 
you can position other objects relative to that particular point. For this reason, MacDraft 
allows you to change the zero points of the rulers. 

When you change the zero point of one or both of the rulers, the positioning of the new 
zero point is dependent upon the grid snap (VHH�8VLQJ�WKH�JULG�VQDS�IXQFWLRQ��&K����S����). 
You can change the zero point of either the top or left ruler independently, or change the 
zero points of both rulers at the same time.
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Setting the zero points of the rulers independently

To change the zero point of either the top or the left edge ruler independently of the other

��� Position the tip of the pointer on either ruler, at the place you want the new zero 
point for that ruler to be, and click. 

7KH�]HUR�SRLQW�LV�UHSRVLWLRQHG�DV�VSHFLÀHG�

To change the zero point of either the top or the left edge ruler back to the upper left corner

��� Hold down the Option key. 

��� Position the tip of the pointer on the ruler you want to change and click. 

The zero point for that ruler reverts to the upper left corner, while the other ruler’s 
zero point stays unchanged. 

Setting the zero points of both rulers simultaneously

You can change the zero points of both rulers simultaneously by using the cursor. In 
this way, you can easily align the zero points of both rulers to a particular point on your 
drawing.
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To set the zero points for both rulers at the same time

��� Position the tip of the pointer in the box where the two rulers cross at the upper 
left corner of the drawing window. 

��� Press and hold down the mouse button. 

��� Drag diagonally downward and to the right until the cursor is positioned on the 
new zero point you want for both rulers. 

To reset the zero points of both rulers to the upper left corner of your drawing

�� Click the small box where the two rulers cross at the upper left corner of the 
drawing window. 

The zero points will be reset.

Release the mouse button. 

��� 7KH�]HUR�SRLQWV�RI�ERWK�UXOHUV�DUH�UHSRVLWLRQHG�DV�VSHFLÀHG��
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As you move the cursor around on your drawing, the cursor position indicator 
shows the cursor’s X/Y position relative to the zero points of the rulers. 

�   6.3 Cursor position indicator

The cursor position indicator shows the position of the cursor (that is, the crosshair 
cursor, the arrow pointer, and the various other cursor icons) on your drawing. This 
allows you to determine accurately the starting and ending points of an object, and also 
gives you the ability to discover the precise position of any point on your drawing. 

The cursor position indicator shows the absolute position of the cursor in relation to the 
zero origin. The zero origin of the cursor position (X=0, Y=0) is determined by the zero 
points on the rulers. Therefore, if you move the zero points on the rulers, the zero origin 
of the cursor position indicator also changes. This feature is very useful, especially when 
\RX�ZDQW�WR�PDNH�PHDVXUHPHQWV�UHODWLYH�WR�D�VSHFLÀF�SRLQW�RQ�\RXU�GUDZLQJ��VHH�6HWWLQJ�
WKH�UXOHUV·�]HUR�SRLQWV��&K����S����). 

7KH�FXUVRU�SRVLWLRQ�LQGLFDWRU�UHÁHFWV�WKH�GUDZLQJ�HQYLURQPHQW��7KH�;�<�SRVLWLRQ�RI�WKH�
cursor’s position is displayed according to the scale of the drawing and in the size units 
that are currently selected (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����S����). 

Activating the cursor position indicator

To activate the cursor position indicator

�� Open the View menu and choose Show Cursor Position. 
The X/Y position of the cursor will be shown on the bottom left edge of the 
document window as shown below.

Cursor Position
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NOTE: If you click the cursor position indicator, the Palette menu appears 
providing an additional method of opening/closing palettes. 

Hiding the cursor position indicator

To hide the cursor position indicator

�� Open the View menu and choose Show Cursor Position. 

�� The cursor position disappears, and the checkmark will be removed from the Show 
Cursor Position command in the View menu. 

�   6.4 Positioning objects

MacDraft provides several features to aid in the precise positioning of objects: grid snap, 
angle snap, grid lines, snap to object and line snapping. The grid snap and angle snap 
features allow you to superimpose an invisible network of “magnets” over your drawing 
so that objects can be drawn, moved, or resized precisely and easily. Grid lines provide 
visual guidelines that assist you in drawing. Snap to object allows you to position one 
object directly next to another, and line snapping allows you to snap the end of lines to a 
VSHFLÀHG�SRLQW�RQ�DQRWKHU�REMHFW��

For more information about drawing objects, VHH�&UHDWLQJ�DQG�HGLWLQJ�REMHFWV��&K����S���. 

Grid snap

You should set the grid snap to the smallest length you need in or between objects in 
your drawing. For example, if you wanted to draw a line that is 5 3/4 inches long, you 
should set the grid snap to one-quarter inch. With the grid snap set this way, the cursor 
will snap to every quarter-inch increment as you draw the line. 

Values shown in the Set Grid submenu will be always given in the current scale and unit 
system (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����S����).

Setting the grid snap

Before you set the grid snap, you should choose a scale to be used for your drawing. The 
grid snap setting should be appropriate for that scale (VHH�'RFXPHQW�XQLWV�DQG�VFDOH��&K����
S����).
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To choose a new grid snap

��� Open the Layout menu and drag until Set Grid is highlighted. 

The Set Grid submenu appears. A checkmark indicates the document’s current 
grid snap. 

The Set Grid submenu shows the grid spacing for the current scale. Each scale 
has its own set of possible grid spacings. For example, a scale of 1:1 (1"=1") in 
fractional units will have increments as small as 1/64th of an inch and as large as 
1/4 of an inch.

��� Holding down the mouse button, drag through the submenu until the grid snap 
you want is highlighted, and release the mouse button. 

The grid snap remains as set until it is changed again.

Using the grid snap function

When a grid snap other than None is chosen, any object you draw or move will 
automatically be positioned to the nearest grid snap position. You will not be able to 
begin or end a draw or move action between the grid snap positions. For example, if you 
were moving an object with the grid spacing set at 1/4 inch, the object would move in 
TXDUWHU��LQFK�LQFUHPHQWV��)RU�LQIRUPDWLRQ�DERXW�WKH�DͿHFWV�RI�JULG�VQDS�RQ�VSHFLÀF�REMHFWV�
VHH�&UHDWLQJ�DQG�HGLWLQJ�REMHFWV��&K����S���. 

You can activate or deactivate the grid snap to suit your needs at the time. 
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Turning the grid snap off and on

$W�WLPHV�\RX�PD\�ZDQW�WR�WXUQ�RͿ�WKH�JULG�VQDS�ZKHQ�\RX�GUDZ�RU�PRYH�REMHFWV�
To turn off grid snap

��� Open the Layout menu and drag until Set Grid is highlighted. 

The Set Grid submenu appears. 

��� Choose None�WR�WXUQ�RͿ�WKH�JULG�VQDS���
To turn on grid snap

��� Open the Layout menu and drag until Set Grid is highlighted. 

The Set Grid submenu appears. 

��� Choose the desired grid snap.  

Releasing objects from the grid snap

You can temporarily suspend the grid snap function by holding down the Command 
key as you move or draw an object. This technique allows you to position an object on a 
location that does not fall at a grid snap point.

:$51,1*��,I�\RX�WXUQ�WKH�JULG�VQDS�RͿ�ZKLOH�GUDZLQJ�RU�PRYLQJ�DQ�REMHFW��WKDW�
REMHFW�ZLOO�EH�UHPRYHG�IURP�WKH�JULG��7KLV�PHDQV�WKDW�LW�ZLOO�EH�GLFXOW�IRU�\RX�WR�
draw lines or borders tangential to the object, or align the object with other objects.

Snapping edges and lines along their lengths

As you draw an object with grid snap on, its edges get longer by small increments as they 
jump to the closest grid snap point. Rather than a line or edge snapping to the grid, hold 
down the Option key as you draw and the line or edge length will snap to increments 
of the current grid snap. For example, if the current grid snap is 1/4" and you draw a 
30º line while holding down the Option key, the line length will grow in quarter-inch 
increments. 
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Angle snap

You should set the angle snap to the angle you need in or between objects in your 
drawing. For example, if you wanted to draw a line at an angle of 14 °, you should set 
the angle snap to 2º. With the angle snap set this way, the cursor will snap to two degree 
increment as you draw the line. 

Setting the angle snap

To choose a new angle snap

��� Open the Layout menu and drag until Set Angle Snap is highlighted. 

The Set Angle Snap submenu appears. A checkmark indicates the document’s 
current angle snap.

The Set Angle Snap submenu shows the possible angle choices.

��� Choose the angle snap you want.

The angle snap remains as set until it is changed again.
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Using the angle snap function

When an angle snap other than None is chosen, objects you draw or edit (that angle is 
relevant to) will be positioned automatically to the nearest angle snap position. You will 
not be able to draw lines between the angle snap positions. For information about the 
DͿHFWV�RI�DQJOH�VQDS�RQ�VSHFLÀF�REMHFWV�VHH�&UHDWLQJ�DQG�HGLWLQJ�REMHFWV��&K����S���. 

You can activate or deactivate the angle snap to suit your needs at the time.

Turning the angle snap off and on

$W�WLPHV�\RX�PD\�ZDQW�WR�WXUQ�RͿ�WKH�DQJOH�VQDS�ZKHQ�\RX�GUDZ�REMHFWV�
To turn off angle snap

��� Open the Layout menu and drag until Set Angle Snap is highlighted. 

The Set Angle Snap submenu appears. 

��� Choose None�WR�WXUQ�RͿ�WKH�DQJOH�VQDS���
To turn on angle snap

��� Open the Layout menu and drag until Set Angle Snap is highlighted. 

The Set Angle Snap submenu appears. 

��� Choose the angle snap you want.  

Releasing objects from the angle snap

You can temporarily suspend the angle snap function by holding down the Shift key as 
you draw an object. This technique allows you to draw an object at an angle that is not an 
angle snap line.

NOTE: The default angle for Angle Snap is set to zero.
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Grid lines

Grid lines provide visual guidelines that assist you in drawing.

Hide/show the grid lines

The grid lines are shown by default, but you can hide them if you wish.

To hide grid lines

�� Open the Layout menu and drag until Hide Grid Lines is highlighted. 

The grid lines are hidden and a checkmark appears by Hide Grid Lines in the 
Layout menu. 

To show grid lines

�� Open the Layout menu and drag until Hide Grid Lines is highlighted.

The grid lines will be shown again, and the checkmark will be removed from 
beside Hide Grid Lines in the Layout menu.
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Snap to object

The snap to object feature allows you to position one object directly next to another. 
When snap to object is enabled, the cursor will snap to the vertices of existing objects. For 
example, you could draw a line and make one of its end points coincide precisely with 
the corner of a rectangle. 
By default, the Snap to Object function is active when you open a new MacDraft 
document. 

To turn off snap to object

�� Open the Layout menu and choose Snap to Object.
The checkmark will be removed from the command, and snap to object will be 
WXUQHG�RͿ��

To turn on snap to object

�� Open the Layout menu and choose Snap to Object.
Snap to object will be turned on, and a checkmark appears next to its name in the 
Layout menu. 

Line snapping

0DF'UDIW�LV�DEOH�WR�VQDS�WKH�ÀQDO�SRLQW�RI�D�OLQH�WR�WKH�PLG�SRLQW�RU�HQG�SRLQW�RI�D�VWUDLJKW�
edge or circular arc, or to the center of an object. This is done by holding down the M, E 
or C key while drawing a line. 

NOTE: These snap keys can be used when drawing unconstrained lines (VHH�'UDZLQJ�
EDVLF�OLQHV��&K����S���), including lines drawn with the Mid point, End point and 
Center point line tools and Tangent from line tool (VHH�'UDZLQJ�VSHFLDO�OLQHV��&K����
S���). 

The mid point and end point snap keys, M and E, can be used when drawing a line to 
straight edged objects (lines, polylines, polygons and square-corner rectangles); any of 
these objects can be part of a group. The end point key, E, can also be used to snap the 
end of a line to the end of a circular arc. The center key, C, can be used to snap the end of 
a line to the center of any closed shape, including shapes within groups, but not with text 
objects, dimension objects, bitmap or pixel objects. 

Drawing a line to the mid point of an existing edge or line

To draw a line to the mid point of an existing edge or line

��� Choose a line tool from the Tool palette and begin drawing the line (VHH�'UDZLQJ�
XQFRQVWUDLQHG�OLQHV��&K����S���).
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The line appears on the drawing between the starting point and the mid point of 
WKH�VSHFLÀHG�HGJH�RU�OLQH��7KH�FXUVRU�UHYHUWV�WR�WKH�OLQH�WRRO��DOORZLQJ�DQRWKHU�OLQH�
to be drawn. 
A line can be drawn to an end point of an existing edge, line, arc or center of an 
object in the same way, by holding down the “E” or “C” key instead of the “M” key. 

�   6.5 Document units and scale

When setting up the drawing environment, you can choose the units in which you want 
WR�ZRUN��7KH�XQLWV�FKRVHQ�DͿHFW�WKH�Show Size palette, the grid lines and grid snap, the 
scale options and rulers, dimension and area calculations and the units of rotation. The 
unit options can be set in the Document Scale and Units dialog. 

Displaying the Document Scale and Units dialog

��� Open the Layout menu and choose Set Scale/Units.

��� Press and hold down the “M” key. The cursor will read “Mid?”.

��� Still holding down the “M” key, bring the cursor near to the edge or line you wish 
to snap the end point of the line to. 
The line will snap to the mid point of the existing edge or line that is near the 
cursor. 

��� Finish the line by releasing the mouse button. 

Mid?
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The Document Scale & Units dialog appears.

��� Make any changes as discussed in the next section, and click the 2. button to close 
the dialog and apply the changes. 

Units

English or metric units

To choose the units

�� Click the radio button beside English or Metric, depending on the type of units you 
want to use in the document.
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Unit size

To select the unit size

��� Click the unit size pop-up menu.

��� Choose the desired number of decimal places.

��� Choose the unit size option you want. Your choice appears on the button. 
7KH�QXPHULFDO�YDOXHV�VKRZQ�RQ�WKH�GUDZLQJ�UHÁHFW�WKH�FKRVHQ�XQLWV��

Decimal places

If you chose a metric or decimal English unit size, you can also specify the number of 
decimal places that you want to be displayed in numerical values. You can choose either 
one, two, three, or four places behind the decimal point, as well “None” (no places) to 
VKRZ�LQWHJHUV�RQO\��9DOXHV�ZLOO�EH�URXQGHG�RͿ�WR�WKH�VHOHFWHG�QXPEHU�RI�GHFLPDO�SODFHV��
The default number of places behind the decimal is two. In larger scales, the number of 
decimal places allowed for display may be reduced automatically. 

To change the number of decimal places

��� In the Document Scale and Units dialog click the Places button.
The decimal places pop-up menu appears.
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Once you have made your choice and closed the dialog, all numerical values will 
EH�URXQGHG�RͿ�WR�WKH�VHOHFWHG�QXPEHU�RI�GHFLPDO�SODFHV��

Hide metric units

Once you have made your choice and closed the dialog, all numerical values will be 
URXQGHG�RͿ�WR�WKH�VHOHFWHG�QXPEHU�RI�GHFLPDO�SODFHV��
To hide metric units

��� In the Document Scale & Units dialog, click the Metric units checkbox. The Hide 
Metric Units check button becomes available. 

��� Click the Hide Metric Units checkbox. 
The option will be on, and the unit names will not be shown with the drawing’s 
dimension line and area values. 

Scales

Before starting a drawing, you need to determine the sizes of the objects, and the paper 
you are going to use. For large drawings it is impractical to draw objects at their actual 
sizes; it is necessary to reduce them, yet still maintain their proper proportions. 

A scale accomplishes this. A scale is the ratio of the object’s size on the drawing to its size 
in the real world. For example, if you choose a scale ratio of one inch equals ten feet (1" = 
10'), a line drawn ten inches long on a drawing would represent a 100-foot line in the real 
world. To avoid having to calculate the size of each object to the scale of the drawing, use 
the Show Size function (VHH�6KRZ�6L]H��&K����S����). 

0DF'UDIW�RͿHUV����GLͿHUHQW�)HHW�	�,QFKHV�VFDOHV�DQG����0HWULF�VFDOHV�IRU�\RXU�XVH�SOXV�D�
custom scale facility. This versatility allows you to create a drawing at one scale, and then 
KDYH�LW�DXWRPDWLFDOO\�FRQYHUWHG�WR�D�GLͿHUHQW�VFDOH��

<RX�FDQ�DOVR�KDYH�PXOWLSOH�GUDZLQJV��DOO�DW�GLͿHUHQW�VFDOHV��GLVSOD\HG�RQ�WKH�VFUHHQ�DW�WKH�
same time. This makes it easy for you to copy and paste between drawings. When you 
SDVWH�DQ�REMHFW�LQWR�D�GUDZLQJ�ZLWK�D�GLͿHUHQW�VFDOH��WKH�REMHFW�DXWRPDWLFDOO\�DGMXVWV�LQ�
size to conform to the scale of the new drawing (VHH�&XW�FRS\�DQG�SDVWH��&K����S����). 
Alternatively you can use the Paste Unscaled command to paste an object into another 
document at its original size (VHH�3DVWH�XQVFDOHG��&K����S����). 
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Specifying the scale

To specify the Default scale

��� In the Document Scale & Units dialog, click the Default Scale button to open the 
Scale pop-up menu. The options available depend on the units chosen. 

��� Choose the scale you want. 
The new scale will be shown in the Default Scale button. 

��� Click the 2. button to close the dialog and apply the changes. 
7KH�GLDORJ�GLVDSSHDUV�DQG�\RXU�GUDZLQJ�QRZ�UHÁHFWV�WKH�QHZ�VFDOH�

To specify the Custom scale

��� (QWHU�WKH�VFDOH�\RX�ZLVK�WR�XVH�LQ�WKH�WH[W�ÀHOGV�SURYLGHG�
��� Click the Apply button or press the Enter key.

If you create a drawing at one scale, and then decide later to change to a new scale, 
simply follow the steps outlined above to choose a new scale. In most cases the 
appearance of the objects on the drawing will either grow or shrink depending on the 
new scale chosen, however if there is text on the document you can choose if you want 
the text to be scaled or not.
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Scaling text

If you change the scale of a document that contains text, an alert appears asking if you 
want to scale the text or not. 

6HH�$QJXODU�GLPHQVLRQ�REMHFWV��&K����S���� and VHH�5RWDWLQJ�REMHFWV��&K����S���� for 
information on using angular dimensions and rotating objects.

�� Click Yes if you want the text to be resized according to the new scale, or 

�� Click No if you wish the text to be shown at the size it currently is on screen. 

Angular display

The Angular Display choices let you specify the units in which you want rotation and 
angular dimensions to be shown and calculated. 

You can choose to display the rotation units in decimal degrees (e.g. 63.58º), in degrees 
and minutes (e.g. 51º 14'), in degrees, minutes and seconds (e.g. 47º 22' 30"), or in user 
GHÀQHG�XQLWV��
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Setting the rotation units

To specify the rotation units

�� In the Document Scale & Units dialog, click one of the radio buttons in the Angular 
Display section, depending on the type of units you want to use in the document.

User GHÀQHG�XQLWV

If you click 8VHU�GHÀQHG�XQLWV, you can specify the number of units to a circle by typing a 
value in the Units to a circle�ÀHOG�

Decimal places

,I�\RX�FKRRVH�GHFLPDO�GHJUHHV�RU�XVHU�GHÀQHG�XQLWV�IRU�WKH�XQLWV�RI�DQJXODU�GLVSOD\��\RX�
can also select the number of decimal places you would like to be displayed for angular 
values. 

To change the number of decimal places

��� Click the Places button.

With a value of 16 units to a circle, at one decimal place, 90º will be displayed as 4.0.
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The decimal places pop-up menu appears.

��� Choose the desired number of decimal places. 
Once you have made your choice and closed the dialog, all angular values will be 
URXQGHG�RͿ�WR�WKH�VHOHFWHG�QXPEHU�RI�GHFLPDO�SODFHV�
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�   7.1 Symbol libraries

Symbol libraries give you the ability to save, catalog, and reuse standard images or 
symbols. Previously created symbols can be taken out of symbol libraries and placed 
directly into your drawings. You can also create your own electrical and architectural 
symbols or commonly used images; these can then be stored in easy-to-access libraries, 
and inserted into drawings as required. The symbols in the libraries retain their drawing 
attributes, such as their scale and rotation.

Symbol libraries available

0LFURVSRW�RͿHUV�D�VHW�RI�Microspot Symbol Libraries. These contain graphic images ready 
for use in MacDraft documents and provide you with many of the elements you need to 
complete or embellish your drawings quickly and easily. 

Each component has been professionally drawn, using vectors rather than bitmaps, 
providing you with the highest possible quality of printing. Once placed in a drawing, a 
symbol can easily be edited to suit your own needs. 

Sample library

A sample library ‘MacDraft Libraries Sampler’ is included with MacDraft. To use any of 
the items in the library, simply drag and drop them into your MacDraft drawing.

Chapter 7.0

Symbol Libraries
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Library contents

Graphics Volume 1

Over 200 images of people, cars, trucks, trees and other landscape elements. This set 
is ideal for architects, illustrators and designers as well as for general graphics and 
presentations.

Graphics Volume 2

Contains over 200 graphic elements to help you create professional-looking 
organizational charts, design computer logic diagrams, embellish business charts, or add 
character to your correspondence and presentations.
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Electronic Schematic

Incorporates over two hundred symbols for a wide array of electronic components and 
elements used to create schematic diagrams. Everything from vacuum tubes to transistors 
and logic gate symbols is included.

Architecture

A comprehensive set of over 1100 commonly used symbols for the creation of residential 
and light commercial construction drawings. These libraries provides architects, 
HQJLQHHUV�DQG�FRQVWUXFWRUV�ZLWK�V\PEROV�WKDW�DGGUHVV�WKH����VWDQGDUG�VSHFLÀFDWLRQ�
formats used in construction drawings.
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Volume 5

Over 200 images including computers and peripherals; road signs and lights; landscape 
elements; stars; signs to write on; maps; furniture and installations. 

Purchasing symbol libraries

Contact your local supplier, or Microspot to purchase drafting symbol libraries. For 
contact details (VHH�5HJLVWUDWLRQ�LQIRUPDWLRQ��&K����S��). 

Old symbol library formats

MacDraft symbol libraries

MacDraft symbol libraries were at one time provided in MacDraft Symbol Library 
format. These libraries and symbols are still supported by the current version of 
MacDraft, but as the library technology has been improved, symbols and libraries in 
this format are now discussed in a separate document. For details see your previous 
documentation or the relevant PDF document on your CD. 

Microspot Media Assistant Lite

MacDraft symbol libraries were previously shipped in Microspot Media Assistant format. 
These libraries and symbols are still supported by the current version of MacDraft, but as 
the library technology has been improved, symbols and libraries in this format are now 
discussed in a separate document, see Appendix D for more details.
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Microspot Library Palette

0LFURVSRW�/LEUDULHV�DUH�QRZ�DYDLODEOH�DV�D�/LEUDU\�ÀOH���VSRWOLEUDU\���7KH�/LEUDU\�YLHZHU�
LV�EXLOW�LQWR�WKH�DSSOLFDWLRQ�PDNLQJ�WKH�XVH�RI�WKH�OLEUDULHV�PXFK�IDVWHU�DQG�PRUH�HFLHQW��
You can use the library to drag and drop existing Microspot Symbols or create new 
libraries of your own items.

Opening a Library in the Library Palette

/LEUDU\�ÀOHV�FDQ�EH�RSHQHG�E\�GUDJJLQJ�WKHP�RQWR�WKH�/LEUDU\�9LHZHU�
To open a library 

��� Open the Library palette from the Window menu or the Toolbar.

If not already open the then the Library palette will appear.
��� 2QFH�WKH�/LEUDU\�SDOHWWH�KDV�RSHQHG�\RX�FDQ�ORFDWH�\RXU�/LEUDU\�ÀOH�RQ�\RXU�

computer.
��� 'UDJ�DQG�GURS�WKH�/LEUDU\�ÀOH�RQWR�WKH�/LEUDU\�SDOHWWH�ZLQGRZ�

NOTE: You can only drag and drop libraries that were created in the new Library 
SDOHWWH��ZLWK�ÀOH�H[WHQVLRQ���VSRWOLEUDU\��,I�\RX�KDYH�OLEUDULHV�WKDW�DUH�LQ�0$/�RU�
older format, then you can either open them using the Media Assistant Lite or 
create new libraries from them yourself.

NOTE: To make the adding of the library easier you can press the F11 key to hide 
DOO�ZLQGRZV��WKHQ�ORFDWH�WKH�ÀOH��+ROG�WKH�PRXVH�EXWWRQ�GRZQ�RQ�WKH�ÀOH��SUHVV�
WKH�)���NH\�WR�VKRZ�DOO�ZLQGRZV�DJDLQ�DQG�GUDJ�WKH�ÀOH�RQWR�WKH�/LEUDU\�SDOHWWH�

Drag and drop the 
OLEUDU\�ÀOH�LQWR�WKLV�
area.
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The library will appear in the library palette, select it to see the items.

Adding items to a new library

If you draw an object or group of objects in your MacDraft document, and wish to store 
that object or group in a library it can be done using the following.

1HZ�/LEUDU\�ÀOH

7R�FUHDWH�D�QHZ�OLEUDU\�ÀOH�

��� Open the Library palette from the Window menu or the Toolbar.

��� Click the Options pop-up menu in the bottom left hand corner of the palette.

��� Select the New Library option.
The standard Save dialog will appear.
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��� With the Save dialog open you can now give the library a name and select a 
location to save it to. Then click Save.
The new library will appear in the Library palette.

NOTE: When selecting the location to save the library to, try to select a place that 
is easy for you to get to and that can keep your libraries together.
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Drag and Drop the items

To drag and drop an object into a library

��� Select the Library you wish to copy the item to in the Library palette.
��� Select the object or group in the MacDraft document that you want to put into the 

library.
��� Hold down the Command key.
��� Whilst holding the Command key down, drag the selection to the Library palette 

window.

The library item will appear in the library palette, inside the library.

Drag and drop the 
object or group into 
this area.

NOTE: When adding objects or groups to the library you can only add one at a 
time. You cannot add multiple items at once.
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Retrieving items from a library

When you want to use a symbol or graphic stored in a library in a MacDraft document, 
you can retrieve items for use by the following.

Using drag and drop

To drag and drop an item out of a catalog into an open MacDraft document

��� Click the required item in the library to select it. 
��� Holding down the mouse button, drag the item over the MacDraft document 

window. 
��� Release the mouse button. 

A copy of the item will be placed in the MacDraft document. 

To drag and drop an item out of a catalog into an open MacDraft document UNSCALED

��� Click the required item in the library to select it. 
��� Holding down the mouse button, drag the item over the MacDraft document 

window.
��� Press the Shift key while dragging the item.
��� Release the mouse button. 

An unscaled copy of the item will be placed in the MacDraft document.

�   7.2 Layers

MacDraft  PE allows you to use multiple layers in a drawing, however only one layer can 
be active at a time. This means that you can draw and edit objects on only one layer at a 
time. The name and scale of the active layer appear beside the document name in the title 
bar. The number of layers you can use in a document is only restricted by the amount of 
memory you have.

You can assign a distinct name to each layer and change the order of layers. You can 
FKRRVH�WR�KLGH�VSHFLÀF�OD\HUV��ZKLFK�PDNHV�WKHP�ERWK�LQYLVLEOH�DQG�QRQ�SULQWLQJ���DQG�
\RX�FDQ�PDNH�REMHFWV�RQ�LQDFWLYH�OD\HUV�HLWKHU�DSSHDU�GLPPHG��JUD\��RU�VKRZ�WKHLU�ÀOO�
DQG�OLQH�DWWULEXWHV��(DFK�OD\HU�FDQ�KDYH�D�GLͿHUHQW�VFDOH��/D\HUV�DUH�FRQWUROOHG�WKURXJK�
the Layers palette and also by using the layer tools at the top right of the document 
window. 

WARNING: MacDraft Personal Edition will only support a maximum of 5 Layers.
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The Layers palette

Displaying the Layers palette

To open the Layers palette 

�� Choose Layers from the Window menu. 
The Layers palette appears 

Active Layer

Hidden Layer

Visible Layer

Selected Layer

Layers list

When you open a new MacDraft document, you start working on Layer-1. The names of 
all the existing layers appear in the layers list. 

Only one layer can be active at a time. The active layer is the only layer you can edit. In 
the Layers palette, a green circle appears beside the name of the active layer.
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Inactive layers can be hidden, grayed out or visible. An eye appears beside the names of 
visible layers, a washed out eye for the grayed layers and a blank square for the hidden 
layers.

Selecting layers in the layers list

You can select a single layer or a number of layers in the Layers palette.

To select a single layer 

��� Position the cursor on the layer’s name in the layers list and click it. 
The name of the selected layer will be highlighted in the list. 

To select multiple layers listed in order 

��� &OLFN�WKH�QDPH�RI�WKH�ÀUVW�OD\HU�\RX�ZDQW�WR�VHOHFW��
��� Press and hold down the Shift key. 

��� Holding down the Shift key, select the layer at the end of the set you wish to have 
selected. 

��� The names of the selected layers will be highlighted. 

To select multiple layers that are not listed in order

��� &OLFN�WKH�QDPH�RI�WKH�ÀUVW�OD\HU�\RX�ZDQW�WR�VHOHFW��
��� Press and hold down the Command key. 

��� Holding down the Command key, individually click all of the other layers you 
want to select. 

��� The names of the selected layers will be highlighted. 

Add New Layer

The Plus Symbol button is used to create new layers.

To create a new layer

�� Click the plus symbol button in the Layers palette.

The name of the new layer appears at the bottom of the list of layers in the palette. 
0DF'UDIW�DVVLJQV�WKH�GHIDXOW�QDPH�´/D\HU��µ�WR�QHZ�OD\HUV��ZKHUH�´�µ�LV�D�
QXPEHU�WKDW�UHÁHFWV�WKH�WRWDO�QXPEHU�RI�OD\HUV�LQ�WKH�GRFXPHQW�
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Rename a Layer

<RX�FDQ�HDVLO\�UHQDPH�OD\HUV��DVVLJQLQJ�GHVFULSWLYH�QDPHV�WKDW�UHÁHFW�WKH�FRQWHQWV�RI�WKH�
layers.

To rename a layer

��� In the Layers palette, move the cursor over the name of the layer 

��� Click the name once then click again straight after (Slightly slower than a double 
click).
The name will be highlighted and turn into a text editing area.

��� In the text area, type in a new name for the layer. 
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Hidden layers

$W�WLPHV�\RX�PD\�ÀQG�LW�FRQYHQLHQW�WR�KLGH�VRPH�RU�DOO�RI�WKH�LQDFWLYH�OD\HUV�RQ�WKH�
drawing. The contents of hidden layers are not only removed from the screen, they are 
also omitted from printed output. This allows you to print only the contents of certain 
layers. You cannot hide the active layer.

To hide inactive layers

�� Click the eye symbol next to the layer until a blank square appears. 

This will hide the current layer.  
The layers will be redisplayed when you click the blank square. (The eye will 
reappear)

Grayed out layers

The Grayed option is used to specify how the objects on inactive layers are displayed. 
*UD\HG�RXW�OD\HUV�DUH�ZLWKRXW�ÀOOV�DQG�ZLWK�WKHLU�ERUGHUV�GLPPHG��7KLV�KHOSV�WR�DYRLG�
confusion about which objects are on the active layer. However, you can choose to have 
WKH�REMHFWV�RQ�LQDFWLYH�OD\HUV�DSSHDU�ZLWK�WKHLU�ÀOOV�DQG�ERUGHU�DWWULEXWHV��LQFOXGLQJ�
colors and patterns. This allows you to preview your drawing before you print it.  

Viewing layers accurately

�� Click the eye symbol next to the layer, until it becomes a solid eye symbol . 

The layer will be displayed accurately. 
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To display objects on inactive visible layers as grayed

�� Click the eye symbol next to the layer you wish to gray out until the washed out 
Eye becomes visible.

The Layer will appear grayed out.
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7KH�GHIDXOW�VFDOH�IRU�HDFK�OD\HU�LV�WKH�VFDOH�WKDW�ZDV�GHÀQHG�LQ�WKH�Document Scale & 
Units dialog. When you start out with a new document, the default scale is 1:1; therefore, 
unless you change the default scale for the document using the Document Scale & Units 
dialog, the default scale for each new layer will be 1:1.   

To assign a new scale to a layer

��� Locate the layer you want to change the scale of.

��� Position the cursor over the over the scale to the right of the layer name.

��� Press and hold down the mouse button

The Layer Scale pop-up menu appears. 

��� Holding down the mouse button, drag until the scale you want to apply to the 
selected layer is highlighted, and release the mouse button.

The scale for the active layer appears on the title bar beside the document and 
layer names.
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NOTES: 
�� If there is text on the document you can choose if you want the text to be scaled 

or not.                                                                                                                        
�� If you change the default scale in the Document Scale & Units dialog, the layers 

that use the default scale will be changed to the new scale. The layers that you 
KDYH�JLYHQ�FXVWRP�VFDOHV�WR�ZLOO�EH�XQDͿHFWHG�E\�FKDQJHV�PDGH�WR�WKH�GHIDXOW�
scale. Custom scales will appear at the bottom of the scale pop-up menu in the 
Layers palette

Arrange Layers

As you add layers, each new layer is placed on top of the existing layers on the drawing, 
a process similar to placing transparent sheets of plastic on top of each other. The layer at 
the top of the layers list in the Layers palette is at the rear of the drawing, and the layer at 
the bottom of the list is at the front of the drawing. 

Objects on an upper layer appear on top of objects on a lower layer. If objects are opaque 
�WKDW�LV��ÀOOHG���DQG�RYHUODS�REMHFWV�RQ�D�ORZHU�OD\HU��WKH\�QDWXUDOO\�FRYHU�SRUWLRQV�RI�WKH�
objects beneath them. Sometimes you might want to move objects on a lower layer in 
front of an upper layer. To do this, you can rearrange the layers. 

To move a layer

��� Choose Layers palette from the window menu.

��� Select the layer you want to move.

��� While holding the mouse button down on the selected layer, drag it to the position 
you want the layer in the list.

As you drag the layer a blue line will appear showing where the layer position will 
be.
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The layer is moved as requested, and its name is also repositioned in the layers list.

To move multiple layers

��� Choose Layers palette from the window menu.

��� Select the layers you want to move.

��� While holding the mouse button down on the selected layers, drag them to the 
position you want them in the list.

��� The layers will be placed in the order they were previously.
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Merge Layers

MacDraft allows you to merge the objects on two or more layers into one layer. All the 
layers to be merged must have the same scale. 

To merge layers:

��� Select the layers you want to merge into one layer.

��� Click the Merge Layers button.

$�QHZ�OD\HU�QDPHG�0HUJHG�/D\HU����ZLOO�EH�FUHDWHG��ZKHUH���LV�WKH�QXPEHU�RI�
merged layers in the drawing. 

You can rename the layer to the desired name.

The layer can be treated as any other and the objects within those layers are now 
editable under one new layer.
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Delete Layer

<RX�FDQ�GHOHWH�VSHFLÀF�OD\HUV��DORQJ�ZLWK�DOO�WKHLU�FRQWHQWV��$OO�EXW�WKH�ODVW�OD\HU�LQ�WKH�
document can be deleted.

To delete layers

��� Select the layers you want to delete. 

��� Click the Delete Layers button.

NOTE: You can see how many objects are in a layer by looking at the number to the 
right of the layer scale.

Closing the Layers palette

To close the Layers palette

�� Click the close box at the top left of the palette.
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Selecting the active layer

When you want to edit objects, the layer that those objects are on must be the active layer. 
Only one layer can be active at a time and only objects on the active layer can be selected 
or edited. In the Layers palette, a green circle symbol appears beside the name of the 
active layer.

Using the Layers palette

To select the layer to be the active layer using the Layers palette

��� Move the cursor over the padlock to the left of the layer you want to be active.

��� Click the padlock symbol.

The symbol will now be a green circle, and the layer will be active.
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Using the Arrow tool

To select the layer to be the active layer using the Arrow tool

�� Hold down the Control and Option keys and click an object using the arrow tool. 

The layer that the selected object is on becomes the active layer.

Using the layer controls in the document window

In addition to the options available in the Layers palette, there are three layer control 
buttons placed on the top right side of the document window. 

Layer pop out menu

Layer Selection tool

To select the layer to be the active layer using the layer selection tool.

��� Click the layer button to display a pop-up menu listing the visible layers.

��� Select the name of the layer you want to edit from the pop-up menu to make it the 
active layer. 
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To select the layer to be the active layer using the Layer Selection tool

Sometimes you can see the object you want to edit, but you don’t remember which layer 
it is on. The Layer Selection�WRRO�RͿHUV�D�JRRG�ZD\�RI�JHWWLQJ�WR�D�YLVLEOH�OD\HU�TXLFNO\��
Once selected, the Layer Selection tool’s cursor allows you to click an object in another 
layer, automatically activating that layer.

��� Click the Layer Selection tool. 

The layer selection cursor appears. 

��� &OLFN�DQ�REMHFW�WKDW�LV�LQ�D�GLͿHUHQW�OD\HU��

The layer that the selected object is on becomes the active layer.
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�   8.1 Drawing Layout

Using MacDraft, you can create drawings of up to 178.5 inches high by 178.5 inches 
�������FP���<RX�GHÀQH�WKH�GHVLUHG�GUDZLQJ�VL]H�E\�XVLQJ�Page Setup options in 
conjunction with the Drawing Size feature. The Page Setup dialog, opened by choosing 
the Page Setup command in the File menu, determines the size of the individual pages 
that make up the overall drawing area. The Drawing Size feature in the Layout menu, 
has a graphical interface that lets you select the number of pages needed to achieve the 
desired overall size of the drawing. 

%HIRUH�\RX�GHÀQH�WKH�RYHUDOO�VL]H�RI�\RXU�GUDZLQJ�XVLQJ�WKH�Drawing Size feature, you 
should select the printer to be used, and set the Page Setup information for that printer in 
the Page Setup dialog. 

Chapter 8.0

Drawing Layout and Printing

NOTE: You will need to make sure your printer has been installed and the correct 
one set as default, before moving onto the Page Setup and Drawing size. For more 
information refer to your Printer or Printer Driver Documentation.

'HÀQLQJ�\RXU�page setup

The Page Setup options allow you to specify how you want your document to appear on 
the printed page. The Page Setup options available will be determined by the printer you 
selected in Print & Fax in the System Preferences.

Displaying the Page Setup dialog

�� From within MacDraft, open the File menu and choose Page Setup. 

A Page Setup dialog similar to the one over the page appears. 
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Page Setup options

Refer to your printer or printer driver documentation for complete details of the Page 
Setup options available. The most important choices: Paper, Orientation and Scale are 
discussed in the following sections. 

:KHQ�\RX�KDYH�ÀQLVKHG�VSHFLI\LQJ�WKH�Page Setup options, click the 2. button to close 
the Page Setup dialog. 

Paper

Selecting the paper size

��� Click the Paper pop-up menu to display the paper sizes available for your printer. 

��� Select the size of the paper that you will be printing on.
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Orientation

Selecting the page orientation

�� Click the Portrait icon to print objects vertically on the page. 

�� Click one of the Landscape icons to print objects horizontally on the page. 

Scale

Selecting the scale

Enter a percentage value into the Scale text box to reduce or enlarge the printout of your 
drawing. 

'HÀQLQJ�\RXU�drawing size

2QFH�\RX�KDYH�VSHFLÀHG�WKH�Page Setup�RSWLRQV�\RX�DUH�UHDG\�WR�GHÀQH�WKH�RYHUDOO�VL]H�RI�
the drawing.

To set the size of your drawing

��� Open the Layout menu and choose Drawing Size. 

A dialog appears, displaying the current total drawing size in the form of a block 
diagram.

NOTE: As MacDraft Personal Edition only allows you to produce drawings of a 
relatively small size, you may not be able to produce a drawing as large as your paper 
size. As most printers require some margin around the edges of the printed page, you 
will not be able to print to the full size of the paper. MacDraft will show appropriate 
page drawing areas (or block sizes) which take into account the required printer 
margins.
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The diagram is divided into blocks and represents the maximum drawing size 
available, each of the blocks representing a single page. The blocks that are 
darkened indicate the current drawing size. 

��� Position the cursor on one of the darkened page blocks. 

��� Press and hold down the mouse button. 

��� Holding down the mouse button, drag until you have activated the number of 
page blocks required to make up the drawing size you want, then release the 
mouse button. 

��� Click the 2. button to close the Drawing Size dialog.

NOTE: The MacDraft drawing window generally shows only a portion of the overall 
drawing. Therefore, when you change the drawing size it may not be noticeable until 
you zoom out or scroll to another area of the drawing.



Chapter 8 Drawing Layout and Printing320

Hiding and displaying page breaks

Page breaks are visual aids that can be useful when you create a large drawing. They can 
help you locate a particular area of the drawing quickly, and they allow you to see if an 
object happens to fall on the edge of a page, so you can move it if necessary. The page 
breaks are shown by default. 

To hide page breaks

�� Open the Layout menu and choose Hide Page Breaks. 

A checkmark appears against the command in the menu to show that it is active.

To display page breaks

�� Open the Layout menu and choose Hide Page Breaks again.

The checkmark will be removed from the command in the menu to show that it is 
inactive.
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�   8.2 Printing

MacDraft gives you options to choose how pages are printed. For example, you 
can specify the order in which pages in a document are printed and whether or not 
registration marks are printed. 

These options are set in the Drawing Size dialog.

Opening the Drawing Size dialog

To open the dialog

�� Open the Layout menu and choose Drawing Size. 

The Drawing Size dialog appears.  

Specifying how pages are numbered

You can choose to number pages by column or by row. In either case, page one appears in 
the upper left corner of the document. Page numbers are not added to the document with 
WKHVH�RSWLRQV�EXW��DV�WKH�SDJHV�DUH�SULQWHG�LQ�QXPEHU�RUGHU��WKLV�VHWWLQJ�DͿHFWV�WKH�SULQW�
order of the pages. 

To number pages

�� In the Drawing Size dialog, click one of the Page Numbering buttons, either by 
column (in ascending order from top to bottom), or by row (from left to right).
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Printing in reverse order

If your printer produces pages face up, it is useful to be able to print pages in reverse 
order so that the printed pages end up in order, starting with page one on the top.  

7R�SULQW�WKH�SDJHV�LQ�WKH�GRFXPHQW�IURP�WKH�ODVW�SDJH�WR�WKH�ÀUVW�SDJH

�� In the Drawing Size dialog, click the checkbox beside Print Last Page First. 

The pages will be printed in reverse order. 

Printing registration marks

If required, you can print crop marks at the corners of each printed page to show the 
edges of the drawing area. 

To print pages with registration marks

�� In the Drawing Size dialog, click the checkbox beside Print Registration Marks.

Printing a document

Before you print, make sure that you have chosen the printer you want to use from the 
Print & Fax��DQG�KDYH�VSHFLÀHG�DSSURSULDWH�Page Setup options (VHH�'HÀQLQJ�\RXU�SDJH�
VHWXS��&K����S����). 

Choosing your printing options

The printing options available will be determined by the printer selected in the Print 
Center. See your printer or printer driver documentation for details.   

To choose your printing options

��� Open the File menu and choose Print.
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A dialog similar to the one below appears.

��� Set the print options according to your requirements then click the Print button to 
produce your printed document. 



Chapter 9 Using Image Editing Options324

MacDraft includes a set of options available from the Image menu, that provides Settings, 
Filters�DQG�GLͿHUHQW�Modes for you to use when editing an Image. These give you the 
options you need to edit, deform even completely change an image you have in your 
document.

�   9.1 Adjusting Image Settings

Chapter 9.0

Using Image Editing Options

Negative

Inverts the image colors. 

Original Negative
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Blur & Blur a lot

%OXUULQJ�UHOLHV�RQ�WKH�PRYHPHQW�RI�SL[HOV�XVLQJ�ÀOWHUV�WR�GHÀQH�WKH�VWUHQJWK�RI�WKH�%OXU��
Using the standard Blur can be helpful when trying to correct small imperfections on the 
edge quality of an image. Blur a lot can be useful when adjusting larger areas, creating 
focus areas or correcting larger edge errors.

Sharpen & Sharpen a lot

The opposite of the blur settings. It uses the movement of pixels to adjust the visual 
preciseness of the edges of images. It can be used to correct an image that may be slightly 
EOXUUHG�RU�WR�À[�DQWL�DOLDVLQJ�SUREOHPV�RQ�LPDJH�DUHDV�

AutoFix

AutoFix allows you to correct contrast, color, brightness and sharpness with a single 
NH\VWURNH��,W�GHÀQHV�WKH�OLJKWHVW�DQG�GDUNHVW�SL[HOV�LQ�HDFK�FKDQQHO�DV�ZKLWH�DQG�EODFN��
then dynamically redistributes the intermediary pixel values. AutoFix also adjusts the 
contrast of edge detail, and therefore enhances sharpness. 

Brightness / Contrast & RGB

Allows you to adjust image colors, brightness and contrast. You can either click the 
Auto button to automatically make corrections, or use the sliders to make manual 
corrections.
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Holding down the Option key when choosing AutoFix allows you to customize its 
VHWWLQJV�WR�SURGXFH�VSHFLÀF�HͿHFWV�RU�DSSO\�FRUUHFWLRQV�WR�D�VHW�RI�LPDJHV��

Clipping

&OLSSLQJ�GHÀQHV�WKH�QXPEHU�RI�H[WUHPH�SL[HOV��DV�D�SHUFHQWDJH�RI�WKH�WRWDO�LPDJH��ZKLFK�
will have a value that exceeds the target value. This feature is useful for producing 
sparkles or shadows.

Strength

Enter a Strength�YDOXH�IURP���WR������7KH�KLJKHU�WKH�SHUFHQWDJH��WKH�VWURQJHU�WKH�HͿHFW�RI�
WKH�ÀOWHU��
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When you show a histogram of an RGB image, for example, you can view the 
distribution of all pixels within the image, or use the Channel pop-up menu to view the 
Red, Green, Blue, RGB, Hue, Saturation and Grayscale pixel distributions individually.

Radius

Enter a Radius value from 1 to 250 to determine the number of pixels used for calculating 
the sharpness of each point. Radius value should be adapted to image resolution. A 
UDGLXV�RI���RQ�D����GSL�LPDJH�KDV�DQ�HTXLYDOHQW�HͿHFW�RI�D�UDGLXV�RI���RQ�D�����GSL�LPDJH��

Threshold

Threshold�VSHFLÀHV�WKH�GLͿHUHQFH�LQ�EULJKWQHVV�OHYHOV�EHWZHHQ�DGMDFHQW�SL[HOV��IURP���WR�
255) before sharpening is applied to an edge. Lower values produce a more pronounced 
HͿHFW��

Histogram

A histogram is a graphic representation of the pixel value distribution in an image from 
the lowest (0 at the left) to the highest (255 at the right). 
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Hue / Saturation

Before/After

The Before and After images show your document as it is currently and as it will be if you 
DSSO\�WKH�VSHFLÀHG�Hue and Saturation changes. 

Scale

The Scale controls determine how the Before and After images are shown. Click the Fit 
EXWWRQ�WR�VFDOH�WKH�LPDJHV�VR�WKDW�WKH\�ÀW�WKH�DUHD�SURYLGHG��8VH�WKH�´+” and “-” buttons 
to increase and decrease the scale of the images as desired. You can also drag the image to  
see the desired area.

Hue

The Hue adjustment area shows how colors will be mapped. In the initial position the 
two color lines are identical, with each color in the top color line being mapped to the 
same color in the bottom color line. Move the Hue slider bar to the left or right to move 
the bottom color line and so change the colors in the image.



Chapter 9 Using Image Editing Options 329

Auto Option

Click the Auto button to automatically enhance image contrast and brightness. You can 
view the corrections in the preview window on the left side of the dialog. 

Auto Levels Settings

To set Clipping values, as well as to use the Color Picker�WR�GHÀQH�FRORU�WDUJHWV�IRU�
correcting weaknesses in the darkest, lightest and neutral points within an image, open 
the Levels dialog, then click the Options button to show the Auto Levels Settings dialog. 

Saturation

Move the Saturation slider bar to the right or left to increase or decrease the vibrancy of 
the colors in the image. 

Levels

The Levels�RSWLRQ�LV�SUREDEO\�WKH�PRVW�HFLHQW�IRU�FRUUHFWLQJ�FRPPRQ�LPDJH�ZHDNQHVVHV�
in black, white, neutral (gray), brightness, contrast and color gamma (linearity): 
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Clipping

7KLV�RSWLRQ�GHÀQHV�WKH�QXPEHU�RI�H[WUHPH�SL[HOV��DV�D�SHUFHQWDJH�RI�WKH�HQWLUH�LPDJH��
which will have a value exceeding the target value. This feature is very useful for 
producing sparkles or shadows. 

Color Targets

Click the Black, Grey or White button in the Auto Levels Settings dialog to choose a color 
picker for setting your targets. When the dialog appears, choose either the Apple RGB 
color picker and set target values for Red, Green and Blue, or the Apple HSV color picker 
and set target values for Hue, Saturation and Value. 
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We recommend that you set the values based upon how you plan to use your image. If 
you plan only to show your image on the screen, set the brightness of the target points as 
follows: 

Black: Red = Green = Blue = 0 or Hue = Saturation = Value = 0% 

White: R = G = B = 255 or H = 0; S = 0; Value = 100% 

Gray: R = G = B = 127 or H = 0; S = 0; Value = 50% 

If you intend to print your image, set the brightness of the target points as follows: 

Black: R = G = B = 3 or Hue = Saturation = Value = 3% 

White: R = G = B = 97 or H= 0; S = 0; Value = 97% 

Gray: R = G = B = 50% or H = 0; S = 0; Value = 50% 

:KHQ�\RX�KDYH�ÀQLVKHG��FOLFN�2. in both the Color Picker and Auto Levels 
Settings dialogs. 

Correcting an Image

Auto

Click the Auto button to automatically enhance image contrast and brightness. View the 
corrections in the preview window on the left side of the dialog.
Manual Corrections

Follow the steps below to manually correct an image's contrast and brightness:
��� With an image selected select Levels from the Setting option in the Image menu.
��� Choose the RGB option from the Channel pop-up menu.
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Black Point

Select the Black Point color sampler (on the left) and click a place on the image that 
should be black. The color of the pixel you selected becomes the target black.

White Point

Select the White Point color sampler (on the right) and click a place on the image 
that should be white. This color becomes the target white.

Neutral (Gray) Point

Select the Gray Point color sampler (in the middle) and click a place on the image 
that should be gray. This color becomes the target gray.

��� Click OK to apply the changes to your image.

Threshold mode

,I�\RX�KDYH�D�GLFXOW\�LGHQWLI\LQJ�DQ�LPDJHV�ZKLWH�RU�EODFN�SRLQWV��WKHUH
V�DQ�HDV\�ZD\�
to make them more apparent. While in the Levels dialog, hold down the Option key and 
move the white handle on the Input slider to the left. The preview will become black. As 
\RX�FRQWLQXH�WR�PRYH�WKH�VOLGHU�WR�WKH�OHIW��FRORU�SRLQWV�ZLOO�DSSHDU��7KH�ÀUVW�SL[HO�\RX�
will see are the brightest in the image, which you can now easily sample. 

Repeat the process, this time dragging the black handle on the Input slider to determine 
the images black point
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Bitmap Mode

Black and white images.

Grayscale Mode

8 bit images that contain up to 256 shades of gray. 

�   9.2 Changing Modes

This option allows you to choose whether the image mode is RGB, indexed, grayscale or 
bitmap. Note that this item is also found in the Info palette.

Gamma

Adjusting gamma allows you to change the brightness of the midtones without 
VLJQLÀFDQWO\�DͿHFWLQJ�WKH�LPDJH
V�KLJKWRQHV�DQG�VKDGRZV��7R�PRGLI\�*DPPD��GUDJ�WKH�
gray handle on the Input slider. The new Gamma value is displayed in its text box.

Output

Output sliders are used to reduce the image contrast, and therefore have the opposite 
HͿHFW�RI�WKH�,QSXW�VOLGHUV�

Reset

Clicking on Reset button restores the original image. 
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RGB Mode (Red, Green, Blue)

32 bit images that contain up to 16.7 million colors.

Converting Image Modes

Grayscale to Bitmap Mode

If you would like to convert a gray+scale image to black and white, choose the Bitmap 
option from the Mode submenu to show the Bitmap Mode dialog. 

You can convert a grayscale image to black and white either by Dithering black and 
white points, or by adjusting the Threshold so bright grays become white and dark grays 
become black. A higher Threshold value will convert brighter pixels to black.
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�   9.3 Using Filters

The Filter�PHQX�DOORZV�\RX�WR�DSSO\�D�ZLGH�UDQJH�RI�VSHFLDO�HͿHFWV�WR�\RXU�LPDJHV�

Add

Noise

This option applies random pixels to an image. You can enter a value between 1 and 999 
in the Add Noise dialog.

Monochrome

Click the Monochrome�RSWLRQ�WR�DSSO\�ÀOWHULQJ�WR�WKH�WRQDO�HOHPHQWV�LQ�WKH�LPDJH�
without changing the colors.
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Unsharp Mask

The Unsharp Mask�ÀOWHU�VKDUSHQV�DUHDV�LQ�WKH�LPDJH�ZKHUH�VLJQLÀFDQW�FRORU�FKDQJHV�
occur, by adjusting the contrast of edge detail to increase an image’s sharpness. This 
ÀOWHU�FDQ�EH�XVHIXO�IRU�VKDUSHQLQJ�DQ�LPDJH�WKDW�KDV�EHFRPH�EOXUU\�IURP�LQWHUSRODWLRQ�RU�
scanning. 

Strength

Enter a Strength�YDOXH�IURP���WR������7KH�KLJKHU�WKH�SHUFHQWDJH��WKH�VWURQJHU�WKH�HͿHFW�RI�
WKH�ÀOWHU�LV�

Radius

Enter a Radius value from 1 to 250 to determine the number of pixels used for calculating 
the sharpness of each point. The Radius value should be adapted to image resolution. A 
UDGLXV�RI���RQ�D����GSL�LPDJH�KDV�DQ�HTXLYDOHQW�HͿHFW�RI�D�UDGLXV�RI���RQ�D�����GSL�LPDJH��

Threshold

Threshold�VSHFLÀHV�WKH�GLͿHUHQFH�LQ�EULJKWQHVV�OHYHOV�EHWZHHQ�DGMDFHQW�SL[HOV��IURP���WR�
255) before sharpening is applied to an edge. Lower values produce a more pronounced 
HͿHFW��
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Angle

In degrees, the Angle determines the direction in which the object appears to be moving. 

Length

6SHFLÀHG�IURP���WR�����WKH�Length determines the intensity of the blur.

Effect

Custom Blur

The Custom Blur�ÀOWHU�DOORZV�\RX�WR�FKRRVH�DQ�H[DFW�EOXU�VWUHQJWK��%\�HQWHULQJ�D�YDOXH�
for the Radius, you can determine the number of pixels that will be used for calculations. 
7KH�ODUJHU�WKH�UDGLXV��WKH�VWURQJHU�WKH�HͿHFW��

Motion Blur

The Motion Blur�ÀOWHU�SURGXFHV�D�EOXUUHG�HͿHFW�VLPLODU�WR�WDNLQJ�D�SLFWXUH�RI�D�PRYLQJ�
object.
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Original Motion Blur

Posterize

The Posterize�ÀOWHU�OHWV�\RX�PRGLI\�WKH�QXPEHU�RI�JUD\V�RU�FRORUV�LQ�DQ�LPDJH��,W·V�XVHIXO�
IRU�FUHDWLQJ�VSHFLDO�HͿHFWV��VXFK�DV�LQ�ODUJH��ÁDW�DUHDV�LQ�D�SKRWRJUDSK��WR�PDNH�WKHP�ORRN�
more like a painting. 

Before applying the Posterize�ÀOWHU�WR�DQ�LPDJH��ZH�UHFRPPHQG�\RX�WR�ÀUVW�FRQYHUW�WKH�
image to a limited number of grayscales (such as six).
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Distortion

Distortion 2D/Distortion 3D

When the distort option is selected the dialog shown below will appear, use it to enter 
precise horizontal (to the right for positive numbers) and vertical (down for positive 
numbers) displacements for each corner of a selection.

Top Left Top Right

Bottom Left Bottom Right
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Shrink

The Shrink�ÀOWHU�EHQGV�DQ�LPDJH�LQZDUGV�RU�RXWZDUGV�ZLWK�UHVSHFW�WR�RQH�RU�PRUH�D[HV��
<RX�FDQ�HQWHU�SRVLWLYH��6KULQN�HͿHFW��RU�QHJDWLYH��6WUHWFK�HͿHFW��YDOXHV�LQ�WKH�Shrink 
dialog.

Vertical Effect

6SHFLÀHV�WKH�VWUHQJWK�RI�WKH�HͿHFW�RI�VKULQN�RU�VWUHWFK�YHUWLFDOO\�

Horizontal Effect

6SHFLÀHV�WKH�VWUHQJWK�RI�WKH�HͿHFW�RI�VKULQN�RU�VWUHWFK�KRUL]RQWDOO\�

Number of Waves

Corresponds to the number of axes used to shrink or stretch the image. For example, 
choosing one wave will shrink or stretch an image with respect to one axis situated at the 
middle of the image. 

Spherize

The Spherize�ÀOWHU�ZUDSV�DQ�LPDJH�DURXQG�D�VSKHULFDO�VKDSH��,W�LV�XVHIXO�IRU�JLYLQJ�
REMHFWV�DQG�WH[W�D�WKUHH�GLPHQVLRQDO�HͿHFW��
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Vertical Effect

$OORZV�\RX�WR�VSHFLI\�WKH�YHUWLFDO�HͿHFW�VWUHQJWK�

Horizontal Effect

$OORZV�\RX�WR�VSHFLI\�WKH�KRUL]RQWDO�HͿHFW�VWUHQJWK��

1RWH�WKDW�QHJDWLYH�YDOXHV�XQGR�WKH�HͿHFWV�DSSOLHG�E\�SUHYLRXV�XVH�RI�WKH�6SKHUL]H�ÀOWHU�

Remove

Scratch Thickness

Determines (from 1 to 16) the width of the scratches and dust that will be eliminated.

Dust and Scratches

7KLV�ÀOWHU�DOORZV�\RX�WR�HDVLO\�UHPRYH�GXVW�RU�VFUDWFKHV�IURP�DQ�LPDJH��
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Threshold

'HWHUPLQHV�KRZ�GLͿHUHQW�WKH�YDOXH�RI�SL[HOV�QHHG�WR�EH��IURP���WR������LQ�RUGHU�IRU�WKH�
ÀOWHULQJ�WR�DSSO\��1RWH�WKDW�ORZ�YDOXHV�PD\�DOWHU�XQLIRUP�FRORU�DUHDV�LQ�WKH�LPDJH��

Noise

The Noise�ÀOWHU�GHWHFWV�DUHDV�ZKHUH�VLJQLÀFDQW�FRORU�FKDQJHV�RFFXU�DQG�EOXUV�WKHP�
ZLWKRXW�DOWHULQJ�WKH�HGJHV��7KLV�KDV�WKH�HͿHFW�RI�UHPRYLQJ�QRLVH�ZKLOH�SUHVHUYLQJ�GHWDLO��

Radius

The radius (in pixels) determines the noise calculation area. Higher values produce 
VWURQJHU�HͿHFWV��

�   9.4 Exporting Images

Using this Export Image option will only export the selected image. To export the entire 
document as an image use the File menu, Export options.

Exporting

How to Export an Image:

��� Select the image you wish to export.

��� Go to the Image menu and select the Export Image... option or use the Export 
Image toolbar icon.

The Export Image As dialog appears.
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��� Type the name you want to give to your image in the Save As, text area.

��� 6HOHFW�WKH�GHVWLQDWLRQ�WR�VDYH�WKH�ÀOH�
��� Pick the image type you want from the pop-up menu and click the Options button 

to alter the settings for that image type.

��� Click the 2.�EXWWRQ�WR�VDYH�WKH�ÀOH�RI�Cancel to close the dialog without saving.
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JPEG Image Options

Select either JPEG 2000 or JPEG Image from the image pop-up menu. Then click the 
Options button and the following dialog will appear.

Photoshop / Truevision TGA & Windows BMP Image Options

Select either Photoshop, Truevision TGA or Windows BMP Image from the image pop-up 
menu and click the Options button and the options dialog appears.

Color Depth

The pop-up menu at the top of the dialog gives you the option to select the color depth of 
the image. The three options available are Best Depth (for a balanced setting), Color and 
Grayscale

Quality

Use the slider to select the quality you want for the image export, you can also type a 
WDUJHW�VL]H�IRU�WKH�LPDJH�ÀOH��

127(��7KH�KLJKHU�WKH�TXDOLW\�RI�WKH�LPDJH�WKH�KLJKHU�WKH�ÀOH�VL]H�ZLOO�EHFRPH��<RX�
can use the Target size�WR�OLPLW�WKH�VL]H�LQ�ZKLFK�WKH�LPDJH�ÀOH�FDQ�UHDFK�
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Choose the color depth that you require from the color depth pop-up menu, for the 
image you want to export.

PICT and QuickTime Options

Select either PICT or QuickTime Image from the image pop-up menu, and the image 
options dialog will appear.

Click the Options button to bring up the Compression Settings dialog.

Use the Compression Type pop-up menu to select one of the standard compression types 
available or select None and choose the compressor settings yourself.

NOTE: Some of the Compression Types�KDYH�GLͿHUHQW�Compressor settings available.
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PNG Image Options

Select the PNG Image from the image pop-up menu and click the Options button and the 
PNG Options dialog appears.

&KDQJH�WKH�FRORU�GHSWK�ZLWK�WKH�FRORU�GHSWK�SRS�XS�PHQX�DQG�FKRRVH�WKH�ÀOWHU�W\SH�
from the Filter pop-up menu.

Color Depth

The pop-up menu at the top of the dialog gives you the option to select the color depth of 
WKH�LPDJH��7KH�RSWLRQV�DYDLODEOH�DUH�KDYH�GLͿHUHQW�RXWFRPHV�WR�WKH�W\SH�RI�WKH�LPDJH� 

Filter

6HOHFW�D�W\SH�RI�ÀOWHU�IURP�WKH�SRS�XS�PHQX�WR�JHW�WKH�GHVLUHG�LPDJH�H[SRUW��$�ÀOWHU�LV�
used to alter the appearance of an object by changing its colors, shades and pixels.
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TIFF Image Options

Select the TIFF Image from the image pop-up menu and click the Options button and the 
TIFF Options dialog appears.

Color Depth

The pop-up menu at the top of the dialog gives you the option to select the color depth of 
WKH�LPDJH��7KH�RSWLRQV�DYDLODEOH�DUH�KDYH�GLͿHUHQW�RXWFRPHV�WR�WKH�W\SH�RI�WKH�LPDJH� 

Little Endian

(ͿHFWV�WKH�ZD\�LQ�ZKLFK�WKH�PHPRU\�VWRUHV�WKH�E\WHV�RI�WKH�LPDJH�
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�   9.5 Resizing Image / Canvas

Allows you to change the size and resolution of the image or the canvas:

Opening the Resize palette:

��� Select the image you wish to resize.

��� Go to the Window menu and select Resize. 

The Resize palette will appear.

��� Choose the tab for either Image or Canvas.

Image

Click on the image to be able to resize it in the Resize palette. You can use the Width and 
Height text areas to type in new values for the image size. You can either use the units 
selected for the document or Pixels, when changing the image size.
You can constrain the proportions so that any changes made to one dimension of an 
image with proportionately modify the other dimension. This prevents and image from 
becoming distorted. 
Lock Resolution: If you change the Pixel Width/Height or the Unit Width/Height the 
image will physically change on the screen, but the dpi will not change.
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Lock Pixel Width/Height: Change the Unit Width/Height the Resolution will change and 
the image will physically change on the screen. The same will happen with editing the 
Resolution.
Lock Unit Width/Height: Changing the Pixel Width/Height will change the resolution of 
the image not the physical size on the screen. Changing the resolution will update the dpi  
and pixel size but not physically on the screen.

Canvas

Click Canvas to increase the size of the frame around your image without changing the 
size of your image. This allows you to add borders or colors/patterns around the image 
ZLWKRXW�DͿHFWLQJ�WKH�VL]H�RI�WKH�RULJLQDO��

Position of image on the canvas

When resizing the canvas you can choose the way it re-sizes so that you can position the 
image where you want it. To do this you use the Select Pt button, to select the datum to 
resize from.
Positioning the Image on the canvas

��� Select the image.
��� Go to the resize palette and select the Canvas tab.
��� Click the Select Pt button and select the handle of the image that you want to 

resize from.The positioning works as follows:

Default

Bottom Right 
Datum

Bottom Left 
Datum

Top Left 
Datum

Right Datum

Left Datum

Bottom 
Datum

Top Datum

Top Right 
Datum
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�   A.1 File Menu

Appendix A

Menus

New

Use to create a new untitled document. Hold down the Option key and click New to 
create a new document without using your set preferences.

Open

Opens the standard Open dialog allowing you to locate and open other MacDraft 
documents, or Media Assistant Lite catalogs.

Close

Closes the document. Before closing, a dialog will ask if you want to save the changes 
made to the document. 
Hold down the Option key and this command changes to Close All. Use to close all 
open documents. Again dialogs appear asking if you want to save any changes made to 
documents.
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Save

Saves your drawing to disk. If the drawing has not been saved before, you will be asked 
to name the document and specify a location to save it. The drawing remains open. 

Save As

Opens the Save�GLDORJ�XVHG�WR�VDYH�D�FRS\�RI�WKH�FXUUHQW�GUDZLQJ�XQGHU�D�GLͿHUHQW�QDPH�
RU�LQ�D�GLͿHUHQW�ORFDWLRQ��<RX�ZLOO�EH�DVNHG�WR�QDPH�WKH�GRFXPHQW�DQG�RU�VSHFLI\�D�
location to save it. A copy of the drawing will be saved with the new name and/or in the 
new location. 

Revert

Reverts to the last saved version of the document. An alert appears, giving you the date 
DQG�WLPH�WKH�GRFXPHQW�ZDV�ODVW�VDYHG��DQG�DVNLQJ�\RX�WR�FRQÀUP�WKDW�\RX�ZLVK�WR�UHWXUQ�
to the last saved version.

Export

Opens the Export VXEPHQX�XVHG�WR�H[SRUW�D�ÀOH�LQ�3')��3,&7�LPDJH�RU�RWKHU�LPDJH�
formats. 

Page Setup

Opens the Page Setup dialog used to specify how you want your document to appear on 
the printed page. Options include paper size, orientation and scale.

Print

Opens the Print dialog used to print out the drawing. The printing options available will 
be determined by the selected printer, but usually include page range, number of copies 
and so on. 
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�   A.2 Edit Menu

Undo/Redo

Undo reverses the last operation performed. Redo performs an operation that was 
reversed by using the Undo command. There are 100 levels of Undo in MacDraft.

Cut

Removes a selected object from the drawing and places it on the Clipboard.  

Copy

Copies a selected object from the drawing and places it on the Clipboard. 
Hold down the Option key and this menu item changes to Copy Special. This command 
is used to place objects on the Clipboard as enhanced PICT images. 

Paste

Pastes an object from the Clipboard onto the drawing at the point where you click.
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Hold down the Shift key and this menu item changes to Paste Unscaled. Use this 
command to paste an object into a document and have it appear at its original size, 
UHJDUGOHVV�RI�DQ\�GLͿHUHQFHV�LQ�YLHZ�VFDOH�EHWZHHQ�WKH�REMHFW�DQG�WKH�GHVWLQDWLRQ�
document window. 

Clear

Removes a selected object from the drawing. 

Repeated Paste

Use to repeatedly paste an object onto a drawing.

Copy Attributes

8VH�WR�FRS\�DQ�REMHFW·V�JUDSKLF�DWWULEXWHV��ÀOO��SHQ�FRORU�RU�SDWWHUQ��OLQH�ZHLJKW�DQG�OLQH�
style... etc) and object information. 

Apply Attributes

Use to apply copied attributes to selected objects. 

Hold down the Shift key when you choose Apply Attributes and the Apply Attributes 
dialog appears. Use the Apply Attributes dialog to check and change the attributes before 
applying them to an object. Any changes made to the Apply Attributes dialog relate to the 
current apply action only.

Attributes Options

Opens the Attributes Options dialog used to check and, if necessary, change copied 
DWWULEXWHV�EHIRUH�DSSO\LQJ�WKHP��7KH�VHWWLQJV�UHPDLQ�DV�VSHFLÀHG�XQWLO�FKDQJHG�RU�XQWLO�
the application is closed. 

Duplicate

Use to make an exact copy of any object or line on the drawing. 

Hold down the Shift key and this menu item changes to Duplicate Without Offset. Use 
this option to create a duplicate that is placed directly on top of the original. 

Hold down the Control key and this menu item changes to Duplicate Unlocked. Use this 
command to avoid duplicating locked objects. All other objects in the selection will be 
duplicated.
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Select All

Selects all the objects on the active layer. 

Hold down the Shift key and this menu item changes to Select None. Use this option to 
deselect all selected objects.

Move

Opens the Move dialog which allows you to move objects or groups with precision by 
entering values from the keyboard.

Expand

Opens the Expand dialog used to increase the size of an object by multiplying its 
GLPHQVLRQV�E\�VSHFLÀHG�YDOXHV�

Contract

Opens the Contract dialog used to reduce the size of an object by dividing its dimensions 
E\�VSHFLÀHG�YDOXHV�

Reshape

Use the commands in the Reshape submenu to reshape an object so that straight lines 
and sharp corners become curved lines and rounded corners, or to reverse the smoothing 
action. 

Show Clipboard

Opens the Clipboard window.
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Font

The Font submenu lists the fonts installed on your system. Select the font you want to use 
from the list.

�   A.3 Text Menu
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Size

The Size submenu lists the text sizes available. Select the text size you want to use from 
the list. 

Style

The Style submenu lists text styles. Select the text style to use from the list.

-XVWLÀFDWLRQ

The -XVWLÀFDWLRQ submenu provides options for justifying text. Select a horizontal and/or 
YHUWLFDO�MXVWLÀFDWLRQ�RSWLRQ�IRU�WH[W��

Line Spacing

The Line Spacing submenu lists line spacing options for text. Select the line spacing you 
want to use from the list.
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Case

The Case submenu lists the case options available for text. Select the case option you 
want to use from the list. 

Select All Text

Selects all text objects in the current layer.

Hide Text

Hides text on the drawing. When this option is on, text is also omitted from printed 
output. 

Highlight Clipped Text

,I�WH[W�LV�OLNHO\�WR�RYHUÁRZ�WKH�WH[W�ER[�WKHQ�ZLWK�WKLV�RSWLRQ�WXUQHG�RQ�WKH�WH[W�ER[�ZLOO�
be highlighted in red. The text box should be increased in size to accommodate all of the 
text, and the red outline will disappear.
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�   A.4 Options Menu

Border Position

Opens a submenu that lists the options available for border positions. Choose the desired 
option from the submenu. 

Edit Colors

Opens the colors palette. Select a color from the palette to edit it.

Edit Patterns

Opens the patterns palette. Select a pattern from the palette to edit it.
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Cross Cursor

Choose to activate and deactivate the crosshair-style drawing cursor. When Cross Cursor 
is active, the cursor appears as a large crosshair cursor which extends into the drawing’s 
rulers. When Cross Cursor�LV�RͿ��WKH�FXUVRU�LV�GLVSOD\HG�DV�D�VPDOO�FURVV��
Tool Options

Opens the Tool Options dialog for the selected tool (if available).

�   A.5 View Menu

Zoom

Use the options in the Zoom�VXEPHQX�WR�LQFUHDVH�RU�GHFUHDVH�WKH�FXUUHQW�PDJQLÀFDWLRQ�
by a factor of two or four. 

Restore Prev. Zoom

&KDQJHV�WKH�YLHZ�EDFN�WR�WKH�SUHYLRXV�OHYHO�RI�PDJQLÀFDWLRQ�
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Home View

&KDQJHV�YLHZ�WR�GLVSOD\�DQ�XQPDJQLÀHG�YLHZ�RI�WKH�XSSHU�OHIW�FRUQHU�RI�GUDZLQJ��
Show Cursor Position

Choose Show Cursor Position to show or hide the cursor position indicator. When Show 
Cursor Position is on, the X and Y coordinate position of the cursor will be displayed 
at the bottom left of the document window. When Show Cursor Position�LV�RͿ��WKLV�
information does not appear. 

Show Area

Calculates the area value of a selected object and displays the result in the center of the 
object.

Hide Area

Hides the result of the area calculations for a selected object.

Show Toolbar

Makes the toolbar visible at the top of the document window.

Hide Toolbar

Hides the toolbar.

Customize Toolbar

Allows you to customize the available tools or options within the toolbar.
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Bring To Front

Moves the selected object to the front of the active layer.

Send To Back

Moves the selected object to the back of the active layer.

Move Forward One

Moves the selected object forward one level on the active layer.

Move Back One

Move the selected object back one level on the active layer.

Group

Links two or more objects so that they can be treated as a single object. 
Hold down the Shift key and this command changes to Ungroup.

�   A.6 Arrange Menu
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Ungroup

Converts grouped objects to their original individual state.

Rotate

Use to freely rotate a selected object.

Rotate To Zero

Choose to return rotated objects to their original orientations.

Rotate Options

Opens the Rotate Options dialog used to specify rotation for a selected object by entering 
precise units of rotation. 

Flip Horizontal/Flip Vertical

Flips selected objects horizontally/vertically.

Distribute On Line

Distributes selected objects along a straight line, and spaces them equally about their 
centers or datum points. 

Lock

Restricts objects so that they cannot be changed.

Unlock

Returns locked objects to their original condition so that they can be changed.
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�   A.7 Image Menu

Settings

7KLV�KDV�D�VHOHFWLRQ�LPDJH�HGLWLQJ�RSWLRQV�WKDW�HͿHFW�WKH�VHWWLQJV�RI�DQ�LPDJH�LQFOXGLQJ�
from Brightness/Contrast & RGB�WR�WKH�YLVXDO�HͿHFWV�RI�WKH�SL[HOV��VHH�$GMXVWLQJ�,PDJH�
6HWWLQJV��&K����S����).

Mode

Has the color mode options for an object (VHH�&KDQJLQJ�0RGHV��&K����S����).

Filter

+DV�D�UDQJH�RI�ÀOWHU�IRU�HGLWLQJ�WKH�ORRN�RI�DQ�LPDJH�FUHDWLQJ�YLVXDO�HͿHFWV��7KLV�LQFOXGHV�
WKH�DGGLWLRQ�RI�ÀOWHUV��HͿHFWV�VXFK�DV�EOXUV�DQG�GLVWRUWLRQ��VHH�8VLQJ�)LOWHUV��&K����S����).

Export Image

([SRUW�LPDJHV�DV�GLͿHUHQW�ÀOH�IRUPDWV��VHH�([SRUWLQJ�,PDJHV��&K����S����).
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�   A.8 Layout Menu

Set Scale/Units

Opens the Set Scale/Units dialog which lets you choose the units, default scale and 
dimension standards for a drawing. 

Set Grid

This submenu allows you to choose from the various grid snap options available in 
(QJOLVK�RU�PHWULF�VFDOHV��7KH�RSWLRQV�UHÁHFW�WKH�FXUUHQW�VFDOH�DQG�VL]H�XQLWV�FKRVHQ���
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Set Angle Snap

This submenu allows you to choose from the various angle snap options available.

Show Rulers

Choose to display or hide the rulers on the top and left sides of the drawing.

Scale Rulers

When Show Rulers is on, choose Scale Rulers to display rulers based on the current scale 
RI�WKH�GUDZLQJ��7KH�VFDOH�UXOHUV�DOVR�UHÁHFW�WKH�FXUUHQW�VL]H�XQLWV��
Standard Rulers

When Show Rulers is on, choose Standard Rulers to display the standard rulers which 
VKRZ�WKH�DFWXDO�VL]H�RI�WKH�GUDZLQJ�LQ�WKH�XQLWV�VSHFLÀHG�LQ�WKH�Set Scale and Units 
dialog. 

Snap to Object

Choose to turn Snap To Object RQ�RU�RͿ��:KHQ�Snap to Object is on, objects you draw or 
move snap to the vertices of nearby objects on the drawing. When Snap to Object�LV�RͿ��
objects you draw or move do not snap to nearby objects. 

Hide Grid Lines

Choose to hide or show the grid lines.

Hide Page Breaks

Choose to show or hide the page boundary lines.
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Drawing Size

Opens the Drawing Size dialog which allows you to set the size of the drawing.

�   A.9 Window Menu

Tile Windows

Choose to display open documents next to each other across and down the screen.

Stack Windows

&KRRVH�WR�GLVSOD\�RSHQ�GRFXPHQWV�RQH�RQ�WRS�RI�WKH�RWKHU��DQG�VOLJKWO\�RͿVHW�IURP�HDFK�
other. 

Show/Hide Palettes

Choose to show or hide the application palettes.

Tool

Choose to show or hide the Tool palette.

Attribute

Choose to show or hide the Attribute palette.

Dimension

Choose to show or hide the Dimension palette.
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Show Size

Choose to show or hide the Show Size palette.

Resize

Choose to show or hide the Resize palette.

Alignment

Choose to show or hide the Alignment palette.

Library

Choose to show or hide the Library palette.

Bring All to font

Brings all Tool palettes to the front.

[Drawing Names]

Open drawings are listed at the bottom of the Window menu. Select the drawing name to 
make it the active document. 

�   A.10 Help Menu

MacDraft Manual

Choose to open the MacDraft PE manual in Adobe Acrobat Reader or other PDF viewer 
(Preview).

Registration Information

Opens the Registration dialog used to register your product via the Internet.

Upgrade Information

Opens the Upgrade Information dialog used to obtain information (if any) about 
upgrades from the Microspot web pages.
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�   B.1 &RPPDQG�.H\V

MacDraft PE Menu
Hide MacDraft PE   Command H
Quit MacDraft PE   Command Q

File Menu
New     Command N
Open     Command O
Close     Command W
Close All    Command Option W
Save     Command S
Save As     Command Shift S
Page Setup    Command Shift P
Print     Command P

Edit Menu
Undo     Command Z
Redo     Command Shift Z
Cut     Command X
Copy     Command C
Paste     Command V
Paste Unscaled    Command Shift V
Clear     Command Backspace
Duplicate    Command D (Options - Drag)
'XSOLFDWH�:LWKRXW�2ͿVHW� � &RPPDQG�6KLIW�'

Appendix B

Special Usage of Keys
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Duplicate Unlocked   Command Control D
Select All    Command A
Select None    Command Shift A
Move     Command Shift M
Smooth     Command 
Unsmooth    Command Shift - 

View Menu
Zoom In 4X    Command 1
Zoom In 2X     Command 2 
Zoom Out 2X     Command 3 
Zoom Out 4X     Command 4 
Restore Prev. Zoom    Command [ 

Home View     Command Option H 

Arrange Menu
Bring To Front     Command F 
Send To Back     Command B 
Move Forward One    Command Shift F 
Move Back One    Command Shift B 
Group      Command G 
Ungroup     Command Shift G 
Ungroup     Command U 
Rotate      Command R 
Rotate To Zero     Command Shift R 
Rotate Options     Command Option R 
Distribute On Line    Command Shift T 
Lock      Command L 
Unlock      Command Shift L 

Window Menu
Minimize Window    Command M 
Show/Hide Palettes    Command Option K 
Show/Hide Tool Palette   Command Option 0 
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Show/Hide Attribute Palette   Command Option 1 
Show/Hide Dimension Palette   Command Option 3 
Show/Hide Show Size Palette   Command Option 4 
Show/Hide Resize Palette   Command Option 5 
Show/Hide Alignment Palette   Command Option 6

NOTE: Undo, Cut, Copy, Paste and Paste Unscaled can also be performed by using 
the function keys: F1, F2, F3, F4 and Shift-F4 respectively.

Notes

There are many Command Key, Command Shift Key and Command Option Key 
equivalents available. The following may be help you to remember them. 

$�&RPPDQG�6KLIW�.H\�FRPELQDWLRQ�XVXDOO\�GHQRWHV�GRLQJ�WKH�RSSRVLWH�RI��RU�VRPHWKLQJ�UHODWHG�WR��
WKH�HTXLYDOHQW�&RPPDQG�.H\�FRPELQDWLRQ��)RU�([DPSOH� 
Command A is Select All; Command Shift A is Select None. 
Command R is Rotate; Command Shift R is Rotate To Zero. 
Command P is Print; Command Shift P is Page Setup… 
Command S is Save; Command Shift S is Save As… 

$�&RPPDQG�2SWLRQ�.H\�FRPELQDWLRQ�XVXDOO\�GHQRWHV�FKRRVLQJ�RSWLRQV�IRU�WKH�UHODWHG�&RPPDQG 
.H\�FRPELQDWLRQ��)RU�([DPSOH��

Command A is Select All; Command Option A is Select Special… 
Command R is Rotate; Command Option R is Rotate Options… 
Command T is Align; Command Option T is Alignment Options… 

 
�   B.2 Support for dedicated function keys

MacDraft supports the dedicated function keys on the extended keyboard, both in text 
mode and normal drawing mode. These keys are help, home, end, page up, page down 
and forward delete. Holding down the Shift key and pressing the page up key performs 
page left, and holding down the Shift key and pressing the page down key performs page 
right.
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�   B.3�,Q�$SSOLFDWLRQ�0RGLÀHU�.H\V

Hold down the appropriate key to achieve the following results.

6KLIW�.H\

Diagonal Line 

tool:

Rectangle tool:

Circle tool:

Arc tool:

Polygon tool:

Freehand tool:

Rotation:

Moving objects:

Selecting objects:

(Normally constrains an action)

Constrains lines to snap at 45 degree increments.

Constrains the shape to a square. (Applies to rounded-corner, 
square-corner and elliptical-corner rectangles.)

�%\�UDGLXV�RU�E\�GLDPHWHU���&RQVWUDLQV�WKH�OLQH�XVHG�WR�GHÀQH�WKH�
radius or diameter to snap at 45 degree increments.

$UFV�E\�UDGLXV��&RQVWUDLQV�WKH�OLQH�XVHG�WR�GHÀQH�WKH�UDGLXV�WR�
snap at 45 degree increments.

Elliptical arcs: Constrains the size of the ellipse that is used to 
GHÀQH�WKH�DUF�DQG�DOORZV�\RX�WR�FKDQJH�WKH�VWDUWLQJ�DQJOH�RI�WKH�
arc without changing it's size.

Constrains the line segments to snap at 45 degree increments 
during creation.

Activates the eraser, allowing you to delete part of the freehand 
shape during creation by retracing the last drawn lines.

Constrains a line segment to a straight line.

&KDQJHV�WKH�URWDWLRQ�XQLWV��7KH�ÀUVW�SUHVV�RI�WKH�6KLIW�NH\�
activates the rotation in minutes; the second press activates the 
rotation in second.

When held down after dragging begins, constrains the 
movement of objects to a horizontal or vertical direction. With 
multiple objects pressing shift before dragging moves one object 
independently of other selected objects.

Extends the selection to include non-selected objects you click 
on. Also deselects the selected objects you click on.
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Distribute on line:

Pattern Editor 

dialog box:

Pointer tool:

Bezier Curves:

&RPPDQG�.H\

Rotation:

Zoom:

2SWLRQ�.H\

Drag:

Finger-Painting 

tool:

Zoom:

Selection 

Rectangle:

Align objects:

Tool icons:

&RQVWUDLQV�WKH�OLQH�XVHG�WR�GHÀQH�WKH�GLVWULEXWLRQ�RI�REMHFWV�WR�
snap at 45 degree increments.

Constrains the movement of the pointer and the Finger-Painting 
tool to a 90 degree angle.

Activates the alternative Zoom cursor (magnifying glass).

Constrains Bezier handle pairs to move in tandem.

(Normally releases a constraint)

Allows rotation in one degree increments. Also returns to the 
previous rotation units; takes you from rotation-in-seconds to 
rotation-in-minutes, and from minutes to degrees. Also returns 
you to the pointer mode when you click on the drawing.

Returns you to the pointer mode when you click on the drawing.

(Normally activates an optional mode or operation)

Duplicates the selected object you are dragging.

(In Pattern Editor dialog box). Resets the Finger-Painting tool 
color to the color you click on.

Activates the Zoom Out mode.

Selects all of the objects that are inside or touching the rectangle.

Aligns selected objects to one element in a group, rather than to 
the group as a whole.

Opens the optional dialog boxes for certain drawing tool icons: 
Parallel Lines, Fillets, Chamfers, Extend.
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Line, Polygon, 

3DUDOOHO��2;VHW�
and Perpendicular 

tools:

Space Bar

Pointer tool:

.H\�6SHFLDOV�	�
Combinations:

Pan Feature:

Deselect All:

Select All Text (In 
Open Text):

Cropping:

Drawing Lines/
Objects:

Dragging widget of 
object to snap to 
another object:

Moving to snap to 

Mid, Center and 

End:

While drawing, lines, polygon segments, polyline segments, 
parallel lines, parallel polygon segments, parallel polyline 
VHJPHQWV��DQG�SHUSHQGLFXODU�OLQHV��DQG�WKH�RͿVHW�GLVWDQFH�RI�
RͿVHW�OLQHV��VQDSV�WKH�OHQJWK�WR�WKH�FXUUHQWO\�DFWLYH�JULG�VQDS�
increment.

Activates the Pan feature when you drag while in the pointer 
mode. This allows you to scroll horizontally and vertically at the 
same time.

Shift-space bar constrains panning to 90 degree movement when 
pointer tool is selected.

Shift - Command - A deselects any selected objects.

Within a text block, Command - A selects all the text characters.

Shift - Option permits the cropping of a bitmap or pixel map, by 
dragging any edit handle. (Although it has been cropped, the 
rest of the image is still retained in memory, so you can resize 
using Shift - Option, to reveal the rest of the image.)

Command releases the active part of the object from the grid 
snap.

Command - Option when selecting a widget of an object and 
dragging allows you to snap that widget to another objects 
widget, when Snap to Object is turned on.

Command-Option drag the handle of an object, then release 
them and hold the M, C or E key to snap the movement to the 
Mid point, Center point or End point respectively.
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Appendix C

File Formats

�   C.1 Supported File Formats

0DF'UDIW�VXSSRUWV�GRFXPHQW�ÀOHV�LQ�WKH�IRUPDWV�OLVWHG�EHORZ��

Opening and saving MacDraft documents and stationery is discussed in Chapter 1 (see 
'RFXPHQW�KDQGOLQJ��&K����S�� and 6DYLQJ�DQG�H[SRUWLQJ��&K����S���), symbol libraries 
and libraries are discussed in Chapter 7 (VHH�6\PERO�OLEUDULHV��&K����S����). Files in other 
formats can be exported using the Export command (VHH�([SRUWLQJ�D�GRFXPHQW��&K����
S���), and can be brought into a MacDraft document using copy and paste or drag and 
drop (VHH�'UDJ�DQG�GURS��&K����S����). The conversion issues involved in opening/saving 
RU�LPSRUWLQJ�H[SRUWLQJ�WKH�UHPDLQLQJ�ÀOH�IRUPDWV�DUH�GLVFXVVHG�LQ�WKLV�DSSHQGL[��
0LFURVSRW�0DF'UDIW�FDQ�UHDG�ÀOHV�LQ�WKH�IROORZLQJ�IRUPDWV

�� MacDraft/PC Draft 
�� Stationery 
�� PICT  
�� Symbol Library   
�� MacDraw II   
�� Libraries 
�� 7,))�IRUPDW�ÀOHV��VXFK�DV�VFDQQHG�LPDJHV�
�� Spotlibrary

0LFURVSRW�0DF'UDIW�FDQ�ZULWH�ÀOHV�LQ�WKH�IROORZLQJ�IRUPDWV

�� MacDraft
�� Stationery 
�� PICT 
�� Spotlibrary  

0LFURVSRW�0DF'UDIW�FDQ�H[SRUW�ÀOHV�LQ�WKH�IROORZLQJ�IRUPDWV

�� BMP 
�� JPEG 
�� MacPaint 
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�� PhotoShop 
�� PICT 
�� PNG 
�� QuickTime Image 
�� SGI Image 
�� TGA 
�� TIFF
�� PDF

Opening documents in other formats

Many Documents in formats other than the MacDraft format can be opened directly from 
within MacDraft. Others, such as documents in TIFF format can be loaded into MacDraft 
(VHH�7,))�GRFXPHQWV��$SS�&��S�&��). 

To open a document in a format other than Microspot MacDraft format

��� Choose Open from the File menu. 

��� A standard Open dialog appears, listing documents in the current directory. 

��� If necessary, open the Enable�SRS�XS�PHQX��DQG�VHOHFW�HLWKHU�WKH�VSHFLÀF�GRFXPHQW�
format required, or All. 

��� Locate the document you want to open. 

��� Click the document name to select it. 

��� Click the Open button. 
MacDraft converts the drawing, and opens it in an untitled window. 

NOTE: Large or complicated drawings may take some time to convert.
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�   C.2 PC Draft PE

<RX�FDQ�RSHQ�ÀOHV�FUHDWHG�EHWZHHQ�YHUVLRQ�������WR�������DQG�KLJKHU�RI�3&�'UDIW�3(�LQ�
0DF'UDIW�3(�������+RZHYHU�0DF'UDIW�3(�����ÀOHV�DUH�QRW�FRPSDWLEOH�ZLWK�3&�'UDIW�3(�
and in turn cannot be opened.

PC Draft PE 1.0

7R�HQDEOH�\RX�WR�YLHZ�D�3&�'UDIW�3(�����ÀOH�LQ�0DF'UDIW�3(������\RX�ZLOO�QHHG�WR�RSHQ�
LW�LQ�DQ�HDUOLHU�YHUVLRQ�RI�0DF'UDIW�3(��YHUVLRQ�����RU�EHORZ���WKHQ�VDYH�WKH�ÀOH�LQ�WKDW�
version and open it in MacDraft PE version 6.0.

�   C.3 PICT Documents

Saving a document in PICT format

Saving a document as a PICT allows you to transfer images into other applications that 
support the PICT format. 

7KH�PDMRU�EHQHÀWV�RI�XVLQJ�WKH�3,&7�IRUPDW�DUH�WKDW�LW�PDNHV�LW�HDVLHU�WR�XVH�JUDSKLFV�
with certain page layout programs. Many word processors and page layout products can 
RSHQ�3,&7�ÀOHV�GLUHFWO\��WUHDWLQJ�WKHP�DV�JUDSKLFV�LQVHUWHG�LQ�WH[W�GRFXPHQWV���
To save a document in PICT format

��� Choose Save As from the File menu. 

��� Choose PICT from the Format pop-up menu in the Save dialog. 

��� Enter a new name for the document unless you intend to replace the existing 
MacDraft document with the PICT document. 

��� Click the Save button. 

When you choose to save a MacDraft document in the PICT format, some of the 
MacDraft attributes may be lost. However, this is usually not important for page 
layout programs, because these programs address a document merely as a picture.  

7KH�3,&7�IRUPDW�LFRQ�KDV�D�GLͿHUHQW�DSSHDUDQFH�IURP�D�0DF'UDIW�GUDZLQJ�
LFRQ��7KH�GLͿHUHQW�LFRQV�DUH�WR�KHOS�\RX�GLVWLQJXLVK�EHWZHHQ�VWDQGDUG�0DF'UDIW�
drawings and PICT documents. 
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Opening a document saved in PICT format

<RX�FDQ�RSHQ�D�0DF'UDIW�ÀOH�VDYHG�LQ�WKH�3,&7�RU�HQKDQFHG�3,&7�IRUPDW�IURP�WKH�
desktop by double-clicking, or from within MacDraft.  

To open a document saved in PICT format

��� Open the File menu and choose Open. 

��� Choose PICT from the Enable pop-up menu in the standard Open dialog. 

��� Locate and click the name of the document that you want to open. 

��� Click the Open button. 

MacDraft documents saved as PICT will not loose any information when reopened 
LQ�0DF'UDIW��XQOHVV�HGLWHG�LQ�DQRWKHU�DSSOLFDWLRQ�ÀUVW��

NOTE: The two known outstanding exceptions to this are: Area calculations 
and Point to Point dimension lines. The displayed Area calculations loose their 
links to the parent objects, and Point to Point dimension lines will be broken 
into text and line objects.
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�   C.4 TIFF Documents

TIFF stands for “Tag Image File Format.” It is a standard format for high-resolution 
images, and is often used to save images stored with scanning devices. 

0DF'UDIW�ZLOO�ORDG�FHUWDLQ�7,))�LPDJHV��IURP�ÀOHV�FRPSDWLEOH�ZLWK�WKH�7,))�����IRUPDW��
into drawings using the Import Image option. To be compatible with MacDraft, the 
ÀOH�PXVW�KDYH�D�ÀOH�W\SH�RI�´7,))µ���)LOHV�VFDQQHG�RU�FUHDWHG�XVLQJ�,%0��FRPSDWLEOH�
SHUVRQDO�FRPSXWHUV�FDQ�EH�ORDGHG��DV�ORQJ�DV�WKH�ÀOH�W\SH�WKH\�DUH�JLYHQ�ZKHQ�
transferred to the Macintosh is “TIFF”.) 

(DFK�7,))�ÀOH
V�LPDJHV�ZLOO�EH�SODFHG�LQ�WKH�FXUUHQW�OD\HU��7R�SODFH�LQ�D�VHSDUDWH�OD\HU��VHH�
below. The images will appear as pixel-map objects. You can move such objects to other 
layers using the Cut or Copy and Paste commands, or you can (for larger images) use the 
Merge Layers option in the Layers palette to combine them into layers with other parts of 
the drawing. 

NOTE: TIFF images, like other pixel-map objects, can be resized by dragging handles. 
Unlike bitmaps, some pixel maps do not resize proportionally, however you can get 
around this by selecting a pixel map and choosing Group from the Arrange menu. 
This will group the object to itself. It can then be resized proportionally like other 
MacDraft groups (VHH�5HVL]LQJ�ELWPDS�LPDJHV��&K����S����). 

127(��7R�ORDG�WKH�7,))�ÀOH�LQWR�D�VHSDUDWH�OD\HU��FUHDWH�D�QHZ�OD\HU�LQ�WKH�/D\HUV�
palette, with the appropriate name, before following the steps above.

/RDGLQJ�D�7,))�ÀOH�LQWR�0LFURVSRW�0DF'UDIW

7R�ORDG�D�7,))�ÀOH�LQWR�0LFURVSRW�0DF'UDIW

��� Choose Import Image... from the File menu. 
The Open dialog appears. 

��� Select TIFF from the Enable pop-up menu. 

��� /RFDWH�WKH�7,))�ÀOH�\RX�ZDQW�WR�RSHQ��
��� 'RXEOH�FOLFN�WKH�ÀOH�QDPH��

The image or images will be loaded into the MacDraft document.
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�   C.5 MacDraw II documents

When opened, MacDraw II documents appear in a new untitled MacDraft drawing 
window at a scale of 1:1 with English units (inches) used. Each layer from the original 
drawing is preserved.

Conversion issues

Usually, the converted drawing requires no special work on your part. However, 
GLͿHUHQFHV�EHWZHHQ�0DF'UDIW�DQG�0DF'UDZ�,,�PD\�PDNH�FHUWDLQ�DGMXVWPHQWV�QHFHVVDU\�
for some drawings. The areas of interest for converted drawings include “sticky notes,” 
scales (rulers), rotated bitmaps, line weights, end marks, text line spacing, smoothing, 
layers, and drawing size.

NOTES:
�� Some pixel maps may look like bitmaps, but still behave as pixel maps, because 

an image may have color attributes while including only the black and white 
colors.                

�� 0DF'UDIW�VWRUHV�HDFK�SL[HO�PDS�RQO\�RQFH�LQ�HDFK�GRFXPHQW�ÀOH��7KLV�PHDQV�WKDW�
you can copy a pixel map within a MacDraft drawing without increasing the 
drawing’s size on disk. 
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Notes (or “sticky notes”)

MacDraft converts a MacDraw II “sticky note” (a special text label included in a drawing) 
to a grouped object made of a text block and several polygons. The result looks like 
the original, but lacks the special characteristics (such as non-printing) of the original 
MacDraw II object. For example, to edit the text, you must ungroup the object, then use 
MacDraft’s own regular text editing methods on the text object.

Scales

0DF'UDIW�DQG�0DF'UDZ�,,�KDQGOH�VFDOHV�GLͿHUHQWO\��IRU�H[DPSOH��HDFK�SURGXFW�DOORZV�
D�GLͿHUHQW�VHW�RI�VFDOHV���%HFDXVH�RI�WKLV��0DF'UDIW�FRQYHUWV�DOO�VFDOHV�LQ�D�0DF'UDZ�
II drawing to 1:1 while preserving the on screen size of each object. For MacDraw II 
drawings with one or more non-1:1 scales, a method to insure a trouble-free conversion 
to MacDraft appears below. 

To prepare a scaled MacDraw II drawing for conversion to Microspot MacDraft

��� In the Finder, make a duplicate of the original drawing document. 

��� Open the MacDraw II application. 

��� Use the File menu’s Open command to open the duplicate document. 

��� Select all the objects of a particular scale, then choose Cut or Copy from the Edit 
menu. 

��� Create a new layer with a scale of 1:1. 

��� Paste the objects in using MacDraw II’s Rescale feature (Shift - Command - V).

NOTE: In MacDraw II, the only way to rescale existing objects is to use this 
variation of the Paste command. 

��� Save the drawing. 

��� Repeat steps 4 to 7 for each remaining scale. 

��� Quit MacDraw II.

To reapply the original (or similar) scales in Microspot MacDraft

��� Launch MacDraft. 

��� Use the File menu’s Open command to open the drawing.
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NOTE: MacDraft allows only one scale per layer.

��� If necessary, use the Layout menu’s Set Scale/Units command to change the 
drawing’s unit system (from English to Metric, for example). 

��� Choose Layers from the Window menu. 

��� In the Layers palette, select a layer. 

��� Open the Scale pop-up menu (it should currently read 1:1) and choose the scale 
you want for the objects in that layer. 

��� Repeat steps 5 and 6 for all layers that you want rescaled.

��� Close the Layers palette. 

��� Print, edit, or save the drawing as you would any MacDraft document. 

Rotated bitmaps

When MacDraft opens a MacDraw II document, any bitmaps that have been rotated 
return to their original orientation. For example, a bitmap rotated ninety degrees 
counterclockwise in MacDraw II appears in MacDraft in its original, unrotated form.

Line weights

0DF'UDIW�DQG�0DF'UDZ�,,�VXSSRUW�GLͿHUHQW�VHWV�RI�OLQH�ZHLJKWV��0DF'UDIW�FRQYHUWV�
MacDraw II line weights as follows: 

MacDraw II Line Weight (in pixels) Microspot MacDraft Line Weight (in pixels)

Less than 1   Hairline (1 / 300 inch*)
1 to 1.4999   1
1.5 to 2.4999   2
2.5 to 3.9999   3
4 to 5.9999   5

NOTES:
�� MacDraft automatically uses the geometric center of the bitmap as the center of 

rotation in this case.                

�� MacDraft can rotate bitmaps in ninety-degree increments (VHH�5RWDWLQJ�ELWPDSV��
&K����S����).  
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6 to 7.9999   7

8 to 9.9999   9

10 to 11.9999   11

12 and above   13

*MacDraft produces hairlines as thin as 1/300th of an inch, depending on printer 
resolution. Hairlines on some printed output may appear thicker than 1/300th of an inch. 

6HH�/LQH�ZHLJKW��&K����S���� for more information about working with line weights.

End marks

MacDraw II has two types of end marks (optional marks on the end of a line); MacDraft 
has sixteen. 

When a drawing is converted, each type of MacDraw II end mark changes to a particular 
type of MacDraft end mark; a regular (triangular) arrowhead becomes a black medium- 
sized arrowhead, while a concave arrowhead becomes a black concave arrowhead. 

Text line spacing

MacDraw II’s custom text line spacing will be preserved in drawings converted to 
0DF'UDIW�IRUPDW��/LQH�VSDFLQJ�FDQ�WKHQ�EH�PRGLÀHG��LI�QHFHVVDU\��WR�WKH�0DF'UDIW�FKRLFHV�
of Single Space, 1-1/2 Space, or Double Space. 

 
0DF'UDIW�DQG�0DF'UDZ�,,�KDQGOH�WKH�VPRRWKLQJ�RI�VKDSHV�LQ�GLͿHUHQW�ZD\V��LQ�
particular, sharp corners on an otherwise smooth MacDraw II shape may become 
rounded after conversion to MacDraft). For this reason, you should closely examine any 
smoothed shapes in a drawing you have converted to see if they require adjustment. 

If necessary, you can use the Unsmooth command (in the Edit menu’s Reshape submenu) 
to change a smoothed shape to a freehand object or polygon (depending on what it was 
before smoothing), move its edit handles as required, then re-smooth the object. See 
5HVKDSLQJ�DQ�REMHFW��&K����S���� for more information about smoothing and unsmoothing 
objects. 

NOTE: In MacDraft, end marks cannot be customized; their size adjusts automatically 
to match the line weight however. See End marks on page 3-42 for more information 
about using end marks. 
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Appendix D

Additional Information
With the addition of the new Library palette, the old Symbol Libraries and the Media 
$VVLVWDQW�/LWH�ÀOHV�KDYH�EHFRPH�REVROHWH��+RZHYHU�0DF'UDIW�FDQ�VWLOO�RSHQ��DGG��HGLW�
and use these libraries, despite the new format. We recommend if you still use the older 
formats, that you transfer your libraries to the new one as soon as possible. In case you 
are still using the old formats then the instructions for their use follow here:

�   D.1 Microspot Symbol Libraries

Symbol libraries give you the ability to save, catalog, and reuse standard images, or 
symbols.  You can take previously created symbols out of symbol libraries and put them 
directly onto your drawing.  With on-line symbol libraries you can create electrical and 
DUFKLWHFWXUDO�V\PEROV��RU�FRPPRQO\�XVHG�LPDJHV��OLNH�ORJRV��QRWLFHV��DQG�ÀJXUHV���<RX�
can then store them in an easy- to-access library document, and then insert the symbols 
into various drawings.  The symbols in the libraries retain all their drawing attributes, 
VXFK�DV�WKHLU�VFDOH��URWDWLRQ��DQG�REMHFW�LQIRUPDWLRQ�ÀHOGV��

Opening an Existing Symbol Library

You use the Open command in the File menu to open symbol libraries stored on disk.  
Once a symbol library is open, you can paste objects into it from your drawing, or copy 
symbols in the library and paste them into your drawing.

To open a symbol library stored on disk: 

��� Choose the Open command from the File menu. 
A dialog box will appear. 

��� Choose Symbol Library from the Enable pop-up menu. 
The list box will display the available symbol libraries in the current directory. 
If the symbol library you want is stored in another folder or on another disk: 

��� Use the dialog to locate the directory to view the contents of the folder that 
contains the symbol library you want. 

��� Select the name of the symbol library. 

��� Click on the Open button. 
The symbol library window will appear on the screen. 
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Shrinking the Library Window

You can shrink the symbol library window down to palette size by clicking the Change 
View button just underneath the list of symbols. 

With the Symbol Library window in this state you can quickly place symbols into a 
drawing.
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Saving a Symbol Library

You can assign a name to a symbol library to help organize your collection of symbols. 
For example, an architect might maintain a separate library for architectural symbols, or  
D�GHVNWRS�SXEOLVKHU�PLJKW�PDLQWDLQ�OLEUDULHV�IRU�ORJRV�DQG�ÀJXUHV�
To save a symbol library under a certain name: 

��� Open the File menu and choose Save or Save As. (Use Save As�WR�FUHDWH�D�QHZ�ÀOH�
and not overwrite the original.)

The standard Save dialog will appear.

��� Type in a name you wish to use for the symbol library. 

��� Use the directory list to specify the folder in which you want to save the library, if 
appropriate. 

��� Click on the Save button. 

7KH�V\PERO�OLEUDU\�ZLOO�EH�VDYHG�XQGHU�WKH�VSHFLÀHG�QDPH�LQ�WKH�VSHFLÀHG�IROGHU�
RU�RQ�WKH�VSHFLÀHG�GLVN��
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Inserting Objects into a Symbol Library

You can use MacDraft’s drawing tools to create objects and then insert them into a 
symbol library. The basic steps are as follows:

To insert objects in a library: 

��� Cut or Copy the object that you want to insert into a library from your drawing. 

��� Open a symbol library. 

��� Paste the object into the library.

The following text provides in-depth instructions on how to insert an object into a library:

��� Select the objects you want on the drawing.

If the symbol includes more than one object and you want the objects to be saved 
as a single symbol, make sure you group the objects together.  (6HH�*URXSLQJ�
2EMHFWV��&K����S�����)  If you try to move several ungrouped objects to a symbol 
OLEUDU\��HDFK�REMHFW�ZLOO�DSSHDU�DV�D�GLͿHUHQW�V\PERO��6HH�,QVHUWLQJ�0XOWLSOH�2EMHFWV�
,QWR�D�/LEUDU\��$SS�'��S�'��).

��� Open the Edit menu and choose Cut or Copy. 

��� Open a symbol library. 

If an existing symbol library is open, click on its window to make it active.  If no 
library is open, create a new library or open an existing library. 

When the symbol library you want is open and active.

��� Open the Edit menu and choose Paste. 

The symbol you cut or copied in MacDraft will appear in the symbol library.  The 
QDPH�´1HZ�6\PERO��µ��ZKHUH�´�µ�LV�D�QXPEHU�WKDW�LQFUHDVHV�DV�QHZ�V\PEROV�
are added) will appear in the name box and the list box.  Both entries will be 
highlighted.

NOTE: When you insert a new symbol into a library, the default name 
´1HZ6\PERO��µ��ZKHUH�´�µ�LV�D�QXPEHU�WKDW�LQFUHDVHV�DV�QHZ�V\PEROV�DUH�
added to the library) is assigned to the symbol. 
You can change the default name. The symbol names appear in a list box, and 
the current symbol is displayed in a viewing area at the bottom of the symbol 
library window. 
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The new name will appear in the symbol library’s list box in alphabetical order.

Naming Symbols

To change the name for a symbol in the library: 

��� Use the scroll controls beside the list box to display the name you want to change, 
if necessary. 

��� Click on the symbol name you want to change. 

��� Type a new name in the name box. 

��� Click on the Rename button. 

Searching for Symbols by their Names

,I�\RX�KDYH�D�ODUJH�QXPEHU�RI�V\PEROV�LQ�D�OLEUDU\��\RX�PLJKW�ÀQG�LW�FRQYHQLHQW�WR�VHDUFK�
for symbols by name.

To search for a symbol by name:

��� 7\SH�LQ�WKH�QDPH�RI�WKH�V\PERO�\RX�ZDQW�WR�ÀQG�

��� Click on the Find button, or use the Command “F” shortcut.

0DF'UDIW�ZLOO�DWWHPSW�WR�ORFDWH�WKH�QDPH�\RX�VSHFLÀHG��,I�D�QDPH�WKDW�PDWFKHV�LV�
found, MacDraft will highlight the symbol’s name in the list box and display the 
symbol in the viewing area. 

NOTE: Pressing Enter or Return after typing the new name will not preserve 
the name; you must click the Rename button or press Command - R. 

127(��7KH�QDPH�DVVLJQHG�WR�D�V\PERO�LQ�D�OLEUDU\�ÀOH�LV�SUHVHUYHG�DV�SDUW�RI�LWV�
object information when it’s pasted into a drawing. 

NOTE:  You do not have to enter the complete name.  If you enter part of the 
name, MacDraft will try to match what you enter with the appropriate symbol 
name. 
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Inserting Multiple Objects into a Library

To insert multiple symbols into a library at the same time:

��� Select the objects on the drawing that you want to insert into the symbol library. 

��� Choose Cut or Copy from the Edit menu. 

��� Activate a symbol library. 

��� Choose Paste from the Edit menu. 

All the selected objects will be assigned default names and inserted in the library.  
(The symbols are numbered according to the objects’ positions on the drawing.  
The object at the back of the drawing is named “NewSymbol-1”, the object in front 
of it on the drawing is named “NewSymbol-2”, and so on.)  You can rename all the 
symbols once they are in the library.

Editing Symbols

When a symbol is in a library, you cannot change its appearance directly (though you can 
paste it into a drawing at any time and resize, ungroup, or otherwise edit it, then paste it 
back into the library). You can, however, change a symbol’s object information and datum 
point.

Assigning a Datum Point to a Symbol

MacDraft lets you change the location of the datum point for each symbol.  A datum 
point is a reference point on an object. The datum point is important because you can use 
it as a reference point when you paste symbols into a drawing.

Each type of object has a default datum point.  For example, the default datum point for 
rectangles is the upper left vertex.  The default datum point for a grouped object (most 
symbols are grouped before pasting into a library) is the default datum point of the object 
at the back of the group.

Object on the back plane
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To assign a new datum point to a symbol:

��� Open the symbol library that contains the symbol whose datum point you want to 
change. 

��� Click on the name of the symbol you want in the symbol library list box. 

��� Click on the Datum button.  (You can also accomplish steps 2 and 3 by double-
clicking on the symbol’s name.) 

The edit handles associated with the symbol will appear.  The datum point is 
represented by an “X” marker on the symbol. 

��� If necessary, use the size box to display the entire symbol. 

��� &OLFN�LQVLGH�WKH�ERXQGLQJ�ER[��UHSUHVHQWHG�E\�WKH�HGLW�KDQGOHV��WR�GHÀQH�WKH�QHZ�
datum point. 
The “X” marker will appear where you clicked to mark the new datum point. 
To place the datum point in the center of the symbol:
�� Click on the Ctrl button.

127(���7KH�V\PERO·V�FHQWHU�LV�GHÀQHG�DV�WKH�FHQWHU�RI�WKH�V\PERO·V�´H[WHQW�µ��
The extent is the overall size of the symbol.
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To apply the datum point change to the symbol:
�� Click on the Done button.
<RX�FDQ�DOVR�ÀQLVK�HGLWLQJ�WKH�V\PERO·V�GDWXP�SRLQW�E\�FOLFNLQJ�RQ�WKH�QDPH�RI�
another symbol. 

$V�DQ�H[DPSOH��VXSSRVH�\RX�DVVLJQHG�D�À[HG�GDWXP�SRLQW�WR�WKH�ORZHU�ULJKW�YHUWH[�
on a rectangle, copied the symbol, and then pasted it into a drawing. 
You then reshaped the rectangle by dragging the handle associated with the lower 
right vertex toward the upper left corner of the drawing, as shown in the following 
ÀJXUH�

TECHNICAL NOTES: If you click near a vertex point (that is, a point where 
two edges meet, shown on screen by a major edit handle), the datum point 
marker will snap to that vertex. You can place the datum point anywhere 
within the bounding box. (The bounding box is the overall extent of the symbol 
or group.) However, a datum point located at the center of the object, or on a 
vertex point, has some special attributes of which you should be aware.  This 
W\SH�RI�GDWXP�SRLQW��FDOOHG�D�´À[HG�GDWXP�SRLQW�µ�UHWDLQV�WKH�VDPH�UHODWLYH�
position on the symbol even if you reshape or resize the symbol after you have 
pasted it onto a drawing.  However, if you resize a symbol that has a “free 
datum point” (a datum point that doesn’t appear on a vertex point or the center 
of a symbol) in such a way that you make the datum point appear outside the 
symbol’s bounding box, the datum point will revert to the default datum point 
position that applies to the object or the group.  This change only applies to the 
V\PERO�RQ�WKH�GUDZLQJ��7KH�RULJLQDO�V\PERO�LQ�WKH�OLEUDU\�ZLOO�QRW�EH�DͿHFWHG�

Fixed datum assigned to 
this vertex
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6LQFH�D�À[HG�GDWXP�SRLQW�ZDV�DVVLJQHG�WR�WKH�ORZHU�ULJKW�YHUWH[��WKH�GDWXP�SRLQW�ZLOO�
still appear on the lower right vertex. 
However, suppose you had assigned a free datum point that appeared in the lower 
right corner of the rectangle, but not on a vertex point. In this case, if you reshaped the 
rectangle in the same way as in the above example, the datum point on the symbol on 
the drawing would revert to the default datum point for rectangles, which is the upper 
left vertex. This would occur be- cause the reshape operation moved the free datum point 
outside the symbol’s bounding box. 

Inserting Symbols into a drawing

When you want to insert a symbol into a drawing, you select the symbol you want from a 
list containing the names of the symbols in the current library. MacDraft lets you preview 
a symbol before you paste it into your drawing.  The symbol you choose from the list of 
symbols appears in a viewing area at the bottom of the symbol library window. You can 
get symbol into a drawing by pasting it or placing it. 

To paste a symbol into a drawing:

��� Open the symbol library that contains the symbol you want to paste into your 
drawing. 

��� Click on the symbol name.  (If necessary, use the scroll controls to display the name 
of the symbol you want in the list box.) 

The chosen symbol will appear in the viewing area.
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��� Open the Edit menu and choose Copy. 

��� Activate the drawing you want by clicking on it. 

��� Click on the drawing where you want the symbol to appear. 

��� Open the Edit menu and choose Paste. 

The chosen symbol will appear where you clicked on the drawing.  The symbol’s 
datum point will be used as the reference point for the paste operation.  This 
means that the object’s datum point will appear where you clicked.

127(���,I�WKH�V\PERO�\RX�KDYH�VHOHFWHG�LV�WRR�ODUJH�WR�ÀW�LQ�D�GUDZLQJ��\RX�
won’t be able to paste it in. In such cases, you might try re-scaling the drawing 
to make room for the symbol. 
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WARNING: When the library appears as a palette, you cannot use the usual 
Cut, Copy, or Paste commands with it. To use those commands with a library, 
or to edit symbols’ datum points, names, or object information, you must click 
the zoom box at the upper right of the palette to put it back in “full window” 
mode.

Placing Symbols from the Palette

If you need to insert many symbols, or many copies of one symbol, into a drawing, it 
may be easiest to put the library window into its “palette” mode. When library is in 
palette mode, you can rapidly place symbols directly into the drawing. 

To shrink the symbol library window to palette mode:

�� Click the Change View button just below the list of symbols.

The library window will shrink to palette size. The list of symbols will appear as a 
pop-up menu.

To place a symbol in a drawing:

��� Use the library’s pop-up menu to choose a symbol by name. 

��� Click the Place button.

The pointer will change to an “X-shaped” cursor.

��� Move the cursor over the drawing. 

��� Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the 
symbol’s datum point will be aligned under the cursor at each click). 

��� Click the Pointer tool to exit the place mode.
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Using the Repeated Paste Function

You can use the Repeated Paste function, accessed from the Edit menu, to paste multiple 
copies of the same symbol onto various locations on a drawing.

To use the Repeated Paste function with symbols:

��� Copy the symbol you want. 

��� Activate a drawing window by clicking on it. 

��� Open the Edit menu and choose Repeated Paste.

When you choose Repeated Paste, you enter a special mode.  In this mode, an 
object on the Clipboard (in this case the symbol you copied) is pasted onto the 
drawing at each point on which you click.  While in this mode, you can scroll the 
ZLQGRZ�DQG�HYHQ�DFWLYDWH�GLͿHUHQW�OD\HUV�DQG�FRQWLQXH�WR�SDVWH�V\PEROV�

��� Click where you want the symbol to appear.

A copy of the symbol will appear at each point you click on the drawing (the 
symbol’s datum point will be aligned under the cursor at each click). 

To exit from the Repeated Paste mode:

�� Click on the Pointer icon.

Using Scaled & Unscaled Symbols

When you insert an object into a symbol library, MacDraft lists the units and scale in 
which the symbol was created at the top of the list box.  This information is stored with 
HDFK�V\PERO����<RX�FDQ�ÀQG�RXW�WKH�VFDOH�DQG�XQLWV�WKDW�DUH�DVVRFLDWHG�ZLWK�D�SDUWLFXODU�
symbol by clicking on the symbol’s name and then reading the information at the top 
RI�WKH�OLVW�ER[����,I�\RX�SXW�D�V\PERO�LQWR�D�GUDZLQJ�ZKRVH�VFDOH�LV�GLͿHUHQW�IURP�WKH�
symbol’s, the symbol will seem to grow or shrink to match the scale of  the drawing.  
However, you can choose to paste an unscaled symbol into drawings.  When you paste 
an unscaled symbol into a drawing, the symbol appears the same physical size on the 
drawing as in the library.

To paste unscaled symbols onto a drawing:

��� Click on the name of the symbol you want to paste. 

��� Click on the check box beside “Unscaled.” 

��� Copy and Paste or Place the symbol into a drawing. 
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The symbol will appear in its original size on the drawing. The “Unscaled” check 
box acts as a toggle. When it is checked, all symbols you copy and paste onto 
drawings will be unscaled until you uncheck it. 

Deleting Symbols from Symbol Libraries

To delete a symbol:

��� Open the symbol library that contains the symbol you want to delete. 

��� Click on the symbol name. 

��� Open the Edit menu and choose Clear or Cut. 

The symbol will be deleted from the library.

Closing a Symbol Library

To close a  symbol library:

�� Click in the symbol library’s close box.

OR

�� Open the File menu and choose Close.

If you insert any objects into a new symbol library and then close the library, a 
dialog box will appear asking if you want to save the changes. 

To save the library and its contents:

�� Click on the Yes button.

When you click on the Yes button, a dialog box will appear. (See the section titled 
“Saving a Symbol Library” in this chapter for more information.) 

To close the library without saving the library or its contents:

�� Click on the No button.
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�   D.2 Microspot Media Assistant Lite

The Media Assistant Lite features are discussed in depth in the Media Assistant Lite on-
line manual. You can open the manual from the Media Assistant Lite application’s Help 
menu. A very brief description of using Media Assistant Lite with libraries is provided 
here.

Open a catalog from within Microspot MacDraft

Media Assistant catalogs can be opened directly from within the MacDraft application.

To open a catalog

��� Open the File menu and select Open. 

The standard open dialog appears.

��� Choose All Documents from the Enable pop-up menu at the bottom of the dialog.

��� Locate the Media Assistant catalog you wish to use and click the Open button.
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Media Assistant Lite will be launched and the selected catalog will appear.

Adding items to a catalog

If you draw an object or group of objects in your MacDraft document, and wish to 
store that object or group for use in other documents, it is easy to do so using one of the 
following methods.

Using drag and drop

To drag and drop an object into an open catalog

��� Hold down the Command key. 

��� Click the object or group in your MacDraft drawing. 

��� Still holding down the Command key, drag the selection over the catalog window. 

��� Release the mouse button and the Command key. 

A copy of the object or group will be stored in the catalog. 

Using Cut/Copy and Paste

To Cut/Copy and Paste an object into an open catalog

��� Click the object or group in your MacDraft drawing. 

��� Choose Cut or Copy from the Edit menu. 

��� Click the Media Assistant Lite catalog you wish to store the object in. 

��� Choose Paste from the Edit menu. 

A copy of the object or group will be stored in the catalog.
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Retrieving data

When you want to use a symbol or graphic stored in a catalog in a MacDraft document, 
you can retrieve items for use in the following ways:

Using drag and drop

To drag and drop an item out of a catalog into an open MacDraft document

��� Click the required item in the catalog to select it. 

��� Holding down the mouse button, drag the item over the MacDraft document 
window. 

��� Release the mouse button. 

A copy of the item will be placed in the MacDraft document. 

Using Cut/Copy and Paste

To Cut/Copy and Paste an item from a catalog into an open MacDraft document

��� Click the required item in the catalog to select it. 

��� Choose Cut or Copy from the Edit menu. 

��� Click the MacDraft document you wish to place the item in. 

��� Choose Paste from the Edit menu. 

The item or a copy of it will be placed in the MacDraft document.

NOTE: Hold down the Shift key to choose Paste Unscaled from the MacDraft 
Edit menu (VHH�3DVWH�XQVFDOHG��&K����S����). 

Saving catalogs

Media Assistant Lite has an auto save feature that automatically saves catalogs each time 
a new item is added or items are changed, so there is no need to save the catalogs 
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�   D.3 Choosing Printers (OS X 10.2 & Below)

To choose a printer

��� Launch the Print Center application.

The Printer List window appears listing the available printers.

��� Select the printer you want to set as the default printer.

The printer name will be highlighted.
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��� Choose Make Default from the Printers menu.

A mark appears next to the printer name indicating that it is the default printer.

��� If you have changed the selected printer, an alert appears warning you to check 
your Page Setup options. 



Appendix D Additional InformationD-19

D

��� Click the Add Printer button.

The sheet appears.

To add a printer

��� Launch Print Center.

The Printer List window appears.
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If your printer is connected directly, choose the appropriate setting from the pop- 
up menu at the top of the dialog. 

If the printer is connected over the network, choose Apple Talk from this pop-up 
menu.

The connected printer appears in the list and will be highlighted.
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��� Click the Add button. 

��� The printer appears in the Printer List dialog and will be set as the default printer.

��� Quit Print Center.

NOTE: For further information about choosing your printer, see the documentation 
provided with your printer/printer driver.
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�   Gradient Fills and Strokes

7KH�ODWHVW�YHUVLRQ�RI�0DF'UDIW�QRZ�LQFOXGHV�*UDGLHQWV��ZKLFK�FDQ�EH�DSSOLHG�WR�ÀOOV�DQG�
strokes. You can create, edit and save new gradients into your documents. 

Available Gradient Types

The two main gradients types available are Linear and Radial, which have additional 
settings within them. The Linear gradient allows you to change the angle to alter the 
direction of the gradient and the Radial allows you to change the centre position of the 
gradient. Below are examples of the gradients types available.

Creating Linear gradients

Creating new gradients is easy and can be done by using the "New Gradient..." option 
located in the Options menu.

To create a Linear Gradient

��� Run MacDraft and open a new or existing document.
��� Go to the Options menu and select New Gradient...

 The New Gradient dialog will appear
��� Make sure the Linear option is selected in the gradient type pop up.

Phil Bunker
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Gradient Type

Color picker 2

Angle of gradient

Creates the gradient 
and adds it to the 
attributes pattern list

Gradient Preview

Color picker 1

Applies gradient to 
the selected object

Cancels the  gradient 
and closes the dialog

��� Click the Color Picker 1 square
 The Colors dialog will appear
��� Select a color and click the OK button
 The color will be added to the gradient
��� Click the Color Picker 2 square
 The Colors dialog will appear again
��� Select a color and click the OK button
 The color will be added to the gradient
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Area for adding extra 
colors to the gradient

Adding extra colors

To add extra colors to the gradient

��� &OLFN�DQ\ZKHUH�LQ�WKH�DUHD�GHÀQHG�E\�WKH�\HOORZ�OLQH�LQ�WKH�LPDJH�DERYH�
��� This will add a new color picker square to the gradient.
����Click the new color picker and follow the steps outlined in the previous section to 

change the color. When you add the new color the gradient will update.
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Changing the angle direction

To change the angle direction of the linear gradient

����Enter the desired angle into the Rotation text box.
����When you are happy with the settings click the OK button.
 The gradient will now be stored in the Attributes palette, pattern popup.

Creating Radial gradients

Creating new gradients is easy and can be done by using the "New Gradient..." option 
located in the Options menu.

To create a radial Gradient

��� Run MacDraft and open a new or existing document.
��� Go to the Options menu and select New Gradient...

 The New Gradient dialog will appear
��� Make sure the Radial option is selected in the gradient type pop up.
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Gradient Type

Color picker 2

Creates the gradient 
and adds it to the 
attributes pattern list

Gradient Preview

Color picker 1

Applies gradient to 
the selected object

Cancels the  gradient 
and closes the dialog

��� Click the Color Picker 1 square
 The Colors dialog will appear
��� Select a color and click the OK button
 The color will be added to the gradient
��� Click the Color Picker 2 square
 The Colors dialog will appear again
��� Select a color and click the OK button
 The color will be added to the gradient
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Adding extra colors

To add extra colors to the gradient

��� &OLFN�DQ\ZKHUH�LQ�WKH�DUHD�GHÀQHG�E\�WKH�\HOORZ�OLQH�LQ�WKH�LPDJH�DERYH�
��� This will add a new color picker square to the gradient.
����Click the new color picker and follow the steps outlined in the previous section to 

change the color. When you add the new color the gradient will update.

Area for adding extra 
colors to the gradient
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Moving the center of the radial gradient

To move the center of the radial gradient

����Click in the gradient preview area and the center will move to it.
����When you are happy with the settings click the OK button.
 The gradient will now be stored in the Attributes palette, pattern popup.
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Editing gradients

To edit a gradient

��� Go to the Options menu and select Edit Pattern / Gradient...

 The gradient will appear as a pop up
��� Select the gradient that you want to edit
 The gradient dialog will appear with the selected gradient.

��� Click the color you want to change
 The Colors dialog will display.
��� Select the new color you want to use and click OK.
 The new color will be added to the gradient.
��� You can also change the Rotation. Once happy with the changes click OK.

NOTE: Click the Preview check box when editing to view your changes live in the 
document. When you edit a gradient, any object that has the gradient applied will 
update with the changes. If you wish to use an existing gradient to create a new one, 
use the Duplicate gradient option.
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Duplicating gradients

6RPHWLPHV�\RX�PD\�ÀQG�WKH�QHHG�WR�FUHDWH�D�JUDGLHQW�VLPLODU�WR�DQ�H[LVWLQJ�RQH��7KLV�RS-
tion allows you to duplicate an existing gradient and then edit it, to create a new one.

To duplicate a gradient

��� Go to the Options menu and select Duplicate Pattern / Gradient...

 The gradient will appear as a pop up
��� Select the gradient you want to duplicate
 The gradient dialog will appear with the selected gradient.
��� Make the changes you want to the gradient
��� Click the OK button when you are happy.
 The New gradient will be added the patterns and gradient popup.

Applying gradients

Gradients can be applied as a Fill, Pen or Parallel line attribute.

To apply a gradient

��� Select the object(s) you want to apply the gradient to.
��� Go to the Attributes palette and select the gradient from the pattern popup menu 

IRU�HLWKHU�ÀOO��SDUDOOHO�OLQH��RU�SHQ�
 The gradient will be applied to the attribute of the selected object(s).

NOTE: Gradients cannot be applied to text.
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�   Creating new colors

You can now add new colors to your document without replacing an existing one.  

Creating a new color

To create a new color

��� Go to the Options menu and select New Color...

 The Colors dialog will appear.

��� Select the color you want and click the OK button.
��� 7KH�QHZ�FRORU�ZLOO�EH�DGGHG�WR�WKH�ÀOO�FRORU�SRSXS�IRU�ÀOOV��SDUDOOHO�OLQHV�DQG�SHQ�
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�   Creating new patterns

You can now add new patterns to your document without replacing an existing one.  

Creating a new pattern

To create a new pattern

��� Go to the Options menu and select New Pattern...

 The Patterns dialog will appear.

��� You can use this dialog to create a pixel pattern in the same way as editing a pat-
tern in previous versions.

��� To create a pattern, select a color from the color picker.
��� Use the pencil tool to click in the squares to generate a pixel gradient.
��� <RX�FDQ�DOVR�FKDQJH�WKH�JULG�VL]H�E\�VHOHFWLQJ�D�GLͿHUHQW�YDOXH�LQ�WKH�6L]H�SRS�XS�
��� The small box in the top left hand corner of the dialog will show a preview of the 

pattern you are trying to draw.
��� For more information on this dialog please refer to editing patterns in the 

MacDraft user Guide.

Color picker

Pencil tool
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([DPSOH�RI�D�EODFN�DQG�ZKLWH�SDWWHUQ�GUDZQ�WR�FUHDWH�D�ZHDYH�SDWWHUQ�HͿHFW�

([DPSOH�RI�D�FRORU�SDWWHUQ�WR�FUHDWH�D�JULOO�HͿHFW�IRU�PDWHULDOV�
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�   The Star Tool

0DF'UDIW�QRZ�RͿHUV�D�QHZ�VWDU�WRRO�DOORZLQJ�\RX�WR�HDVLO\�FUHDWH�WKRVH�VWDU�VKDSHV�ZLWK-
out the need to construct them with individual lines.  You can either draw a star from the 
center or from the edge.

Drawing a star from the edge

To draw a star from the edge

��� Go to the Tools palette and select Star from edge tool
 The cursor will change to a draw cross
��� Click the mouse button to place the start point.
��� Move the mouse until the desired size has been drawn.
��� &OLFN�WKH�PRXVH�EXWWRQ�WR�ÀQLVK�GUDZLQJ�

NOTE: You can also draw a star by simply clicking the mouse button and holding it 
down while dragging the shape out. Hold the SHIFT key down on the keyboard to 
constrain the angle.

Drawing a star from the center

To draw a star from the center

��� Go to the Tools palette and select Star from center tool
 The cursor will change to a draw cross
��� Click the mouse button to place the start point.
��� Move the mouse until the desired size has been drawn.
��� &OLFN�WKH�PRXVH�EXWWRQ�WR�ÀQLVK�GUDZLQJ�

NOTE: You can also draw a star by simply clicking the mouse button and holding it 
down while dragging the shape out. Hold the SHIFT key down on the keyboard to 
constrain the angle.
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Star tool options

To change the star tool options

��� Go to the Tools palette
��� Hold the Option key down and click one of the star tools.
 The star tool option dialog will appear.

5-sided, 25% 5-sided, 50% 10-sided, 75% 25-sided, 80%

��� Enter the number of points for the star.
��� Enter the percentage ratio for the thickness of the star.
��� Click OK.
��� Now draw the star as per the instructions outlines in drawing stars.
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�   Single key shortcuts

MacDraft now includes single key shortcuts for the Tools palette. The shortcuts keys for 
each tool set are displayed in their tooltip. Click the shortcut key again to cycle through 
the tools included in the set.

Available single key shortcuts

Tools
Arrow

Rotate

Marquee

Hand

Marker Symbol

Attribute

Zoom

Line

Special Line

Rectangle

Text

Regular Polygon

Rounded Corner Rectangle

Circles & Ellipses

Arcs

Irregular Polygon

Bezier & Curves

Parallel Lines

Stars

Shortcut
v

r

m

h

x

d

z

l

s

u

t

p

o

c

a

i

b

w

k

Tools included in set
-

-

Exclusive selection, inclusive selection

-

Marker, repeated paste, edit datum

-

-

Unconstrained, 90, 45, 30, 15, 5

Perpendicular, mid point, end point, center 
SRLQW��WDQJHQW�IURP��WDQJHQW�EHWZHHQ��RͿVHW
Rectangle from edge, rectangle from center

-

Edge to edge, center to edge, vertex to vertex, 
center to vertex

Proportional, constant, elliptical corners

Diameter, radius, 3-point, diagonal ellipse, 
centered ellipse, concentric circle.

Radius, 3-point, elliptical, concentric

Irregular polygon, polyline

Bezier, spline, freehand line & shape

Parallel line, parallel polyline, parallel polygon, 
extrude parallel line, extrude parallel polyline

Star from edge, star from center
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�   Additional Updates

Duplication menu

The duplication menu has been cleaned up and we have combined the duplication op-
tions into one main sub menu.

Activating the Arrow tool

In addition to the single key shortcut we have implemented the use of the escape key 
when in use of a tool. This means if you are drawing and hit the ESCAPE (esc) key on the 
keyboard it will exit the current tool and activate the Arrow tool.

Rotate 90 left & Rotate 90 right

These two tools have been moved from the tools palette to the toolbar.
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Creating your own library items

You can now drag your own items to custom libraries in the library palette without hold-
ing the command key down.

To create a custom library

��� Go to the Window menu and select Library

��� Click the gear symbol in the bottom left hand corner of the palette.
��� Select New Library...

 The Save dialog will appear.
��� Give your library a name and select a destination to save to.
��� Click the Save button.
 The new library will appear in the top section of the library palette.
��� Select the new library in the library palette so that it is highlighted. 

��� Group the objects in the document you want to add to the library
��� Drag the item to the lower section of the library palette
 The object will now be added to the custom library you created.
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u   The Welcome Screen

The latest version of MacDraft now includes a welcome screen to help get you started 
quicker and easier. 

Video Tutorials

There are four main buttons on the Home tab of the welcome screen, the first of which is 
Video Tutorials. Click this link to be taken to the latest video tutorials available at on the 
Microspot website.

Take a Tour

You can also take a tour of MacDraft and all of its features
To Take a Tour

1. Run the Welcome window via Help > Welcome to MacDraft.
2. Select Take a Tour
 The window will change to the Take a Tour Panel
3. Click the left and right arrows to scroll through the Take a Tour slider.
4. Click Skip Tour or press the 'Esc' Key to close the Welcome Screen.
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Next Slide

Close Take a Tour

Previous Slide

Community Forum

Selecting the Community Forum will redirect you to the community forum on the 
Microspot website. Here you can create a post, talk to other users, speak with technical 
support and view other peoples MacDraft work.

Help & Support

The Help & Support section of the Welcome Palette will redirect you to the Online sup-
port form at the Microspot website, submit your query here and a member of the Mi-
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crospot team will get back to your asap. 

The New Tab

The New Tab allows you to start a new blank document or select an existing template.

To Open a Blank Document

1. Select the New Tab in the Welcome Screen
2. Select the All category
3. Select Blank Document
4. Double Click Blank Document or with it selected Click Choose

To Open a Template

Select a Template

Open selected Template

Select Category

Open existing documents
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1. Select the New Tab in the Welcome Screen
2. Select the template you wish to open
 You can choose any category on the left of the welcome screen 
3. Double Click the template or with it selected Click Choose

To Open an Existing Document

1. Select the Open Existing button
2. Navigate to your file
3. Select Open

To Access your own pre made Templates

1. Select the 'My Templates' tab on the left hand side
2. Select the template you intend to open
3. Select 'Open' and your template will open
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The Recent Tab

The Recent tab allows you to open files that you have recently worked on. 

To Open a Recent Document

1. Select the Recent tab in the welcome window.
2. Select the document you wish to open
3. Either double click the document or select the Open button
4. Your file will now be open
 

Open selected Document
Select your Document

The Recent Tab

u   Smart Snapping

Smart Snapping allows you to snap one object to another object or align two objects by 
their centre, horizontally or vertically. This is all done by dragging the first object, once 
dragging you will notice red guides appear which show you this objects position in the 
document in regards to another object. 

To Turn Smart Snap on

1. Toggle the Smart Snap button in the Menu Bar, if the button is depressed then 
Smart Snap is on.

2. The other option is to go Layout > Smart Snap, select this to turn Smart Snap on
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How to use Smart Snap

1. Select an object in your document
2. Drag it below another object close to its center, you will notice a red centre line ap-

pear, the object is now aligned vertically

3. Drag the object to the side of another object close to its centre, you will notice a red 
centre line appear, the object is now aligned horizontally

Select Smart Snap
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4. Drag the object roughly to the centre of the other object, you will notice 2 red align-
ment lines appear, this shows that the object will be centered to the other object.

5. Drag the object to the edge of another object, it will Snap to the edge of that object 
and show a red line to show the edge that it has snapped to. 
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u Show Size

Show Size allows you to see the live X & Y size of your object as you are drawing it. It ap-
pears in a small black box next to the cursor itself. 

To turn the Show Size cursor on
1. Select the Show Size Menu Bar icon, if the icon is depressed then Show Size is on.

2. You can also turn it on via View > Show Size, select the menu item and Show Size 
will turn on

How to Use Show Size
1. With Show Size on, select the rectangle tool
2. Start to drag out a rectangle and notice it is updating the size of the rectangle
3. When you are happy with the size release the mouse to place the rectangle.  
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u The Helper Palette

The helper palette gives you information on how to use the tool you have selected and 
what keyboard shortcuts are linked to the tool. There is also a short animation which 
shows you an example of the tool being used. 

To Open the Helper Palette
1. The Helper Palette opens by default when the application is first run. 
2. If the Helper Palette is not open then go Window > Helper
3. The Helper Palette will now appear
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To use the Helper Palette
1. Open the Helper Palette via Window > Helper
2. Select the Rectangle tool
3. Notice the Helper Palette change to show the rectangle tool
4. Watch how the tool works, read step by step instructions or view which keyboard 

shortcuts are linked to the Rectangle tool

u Guides

Guides or 'Guide Lines' have been added to make creating your drawings so much easier. 
Use guides to correctly position and align your objects. 

To Create Manual Guides
1. Hold the cmd key down and click and drag a guide from the rulers
2. The top ruler will create a horizontal guide 

Selected Tool

Animation of Tool being used

Text instructions for tool

Scroll for Keyboard
Shortcuts
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3. The left hand ruler will create a vertical guide
4. Release the mouse to place a guide
5. To select an existing guide, hold the cmd+alt key then click the mouse
6. To remove a guide, select it and drag it into the dead zone. 

To Create a Vertical or Horizontal Guide
1. Go Options > Add Vertical Guide to add a vertical guide in the center of the docu-

ment
2. Go Options > Add Horizontal Guide to add a horizontal guide in the center of the 

document

To Create a guide in a particular position
1. Go Options > Add Guide by Position
2. A dialog will appear, chose either Horizontal or Vertical

 

3. Type in the position and guide will appear in document

To show or hide all guides
1. Select the Menu Bar item 'Guides'. 
2. Clicking this will show or hide all guides in the document depending on their cur-

rent state
3. If the button is depressed the guides will be shown
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Guides On

Guides Off

Guides icon is depressed (on)

Guides icon is not depressed (off)
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u Interface Colors

You can change the interface colors of MacDraft, including the Background color, Guide 
color and Grid color. This gives you complete control over your drawing space. 

To change your interface colors
1. Access the interface colors via Options > Interface Colors

2. Select 'Custom' for either Background, Grid & Page Breaks or Guides. We will select 
Background for this example. 

3. Click the color on the right to bring up the color dialog. 

4. Select your new color and click OK
5. Click OK in the Interface Color dialog
6. Your document will now have that color setting
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You can save your Interface color settings for all future documents by going MacDraft > 
Preferences > Application Defaults and selecting 'Custom Colors'

uCentered Drawing Area

We have centered the drawing area in MacDraft to give the user a more fluid and crisper 
drawing experience. This has also allowed the area around the document to act as a dead 
zone for users to place objects in when not using them. 
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u The Dead Zone

With MacDraft's new centered document comes the Dead Zone. The Dead Zone is the 
grey area around you drawing area which can be used to store objects that you are not 
currently using or intend to use in the future. It also acts as part of the way to create 
guides (see Guides). 

To use the dead zone
1. Select any object
2. Drag it into the grey area surrounding the document (dead zone)
3. The object is now in the dead zone and can be accessed whenever needed

Any objects stored in the dead zone will not be printed, this means that you can leave 
data that is important to the document but you do not wish to show, in the dead zone, ie 
notes or annotations. 

NOTE: You cannot draw or edit in the dead zone, items that need to be edited will need 
to be dragged back into the document window. 

uCreating and Using your own Templates

You can create, save and open your templates much easier in MacDraft 6.2. Save your 
template and access it from the welcome screen whenever MacDraft opens.
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To create your own template in MacDraft
1. Create your document 
2. When finished go File > Save as Template
3. The document will be saved as a .mp60 (template) file

To select your template via the template chooser
1. Run MacDraft so the welcome window appears OR go Help > Welcome Window
2. Navigate to the New Tab
3. Select the 'My Templates' section on the Left

4. Select your template
5. Select Open
6. Your template will now open
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u Updated Resize Palette

The Resize palette has been updated to include steppers which allow you increase or de-
crease the height or width of an object by one value dependant on your Grid Size. If your 
grid size is set to 1mm then pressing up on the height stepper will increase the height of 
your object by 1mm. 

To use the Resize Steppers
1. Open the resize palette via Window > Resize
2. Select your object
3. Press up or down on the height stepper
4. The value of the height field will increase or decrease depending on which you 

clicked
5. You can change how much this increase or decrease is by by changing the Grid Size 

via Layout > Grid Size
6. Select the apply button to confirm the changes

u Menu Bar Changes

We have restructured some of the menu bar options to incorporate the new features in 
MacDraft 6.2 to improve consistency. The changes are show in the images below.

Resize Steppers

Apply to Confirm changes
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The Options Menu

The View Menu

The Layout Menu

MacDraft 6.1.3 MacDraft 6.2

MacDraft 6.1.3 MacDraft 6.2

MacDraft 6.1.3 MacDraft 6.2
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u Printing Background Color

With the new interface colors added to MacDraft you may need to print your new Back-
ground color. This is easy to do in MacDraft 6.2

To Print Background Color
1. Open your MacDraft File
2. Go Options > Include Background Color When Printing
3. Print your document

u Display All Palettes

Users can now show and hide all palettes rather than only the existing opened palettes. 
This means you can quickly see all of the tools and options in MacDraft or quickly hide 
everything to view your document quickly and easily. 

To Display All Palettes
1. Select your MacDraft Document
2. Go Window > Display All Palettes
3. All of the MacDraft Palettes will appear

To Hide All Palettes
1. Select your MacDraft Document
2. Go Window > Show/Hide Palettes
3. All of the MacDraft Palettes will now disappear 
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Symbols
1:1 tool, using to change drawing view  145

A
absolute resize  109
adding

marker symbols to drawing  105
text to drawing  15

aligning
objects  249

using the Alignment palette  249
parallel lines, options for  94
text  206

Alignment palette, show/hide  A-18
angle snap  282

releasing objects from  283
setting  282, A-16
WXUQLQJ�RͿ�DQG�RQ��283
using  283

angular
dimension objects, resizing  125
display, choosing units for  292

annotating drawing  195
. See also area calculation, dimensioning, text

appearance, changing an objects  147
. See also�ÀOOV��FRORUV��SDWWHUQV��SHQ��OLQHV��ERUGHU�SRVLWLRQ

application requirements  1
arcs

by radius
changing the length of  62
changing the radius of  62
changing the size of  62
drawing  61
resizing  120
snapping to grid  63

by three points
changing the size of  64
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drawing  63
resizing  121

choosing tools for drawing  60
concentric

drawing  68
snapping to grid  69

drawing  60
the Arc tool  15

elliptical
changing the length of  67
changing the shape of  67
changing the starting angle of  66
drawing  65
resizing  121
snapping to grid  67

area, See Show Area
Arrange menu  A-12, B-2
arranging

layers  309
arranging objects  222, 242

bring to front  242, A-12
move back one  246, A-12
move forward one  245, A-12
send to back  244, A-12

Attribute palette, show/hide  A-17
attributes

. See also�ÀOOV��FRORUV��SDWWHUQV��SHQ��OLQHV��ERUGHU�SRVLWLRQ
applying  A-4

using the Attribute tool  16
changing  147

before applying  A-4
using the Apply Attributes dialog  190, 192
using the Attribute Options dialog  190, 193

using the Attributes palette  147
XVLQJ�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��148

checking before applying  A-4
using the Apply Attributes dialog  190, 192
using the Attribute Options dialog  190, 193

copying  188, 191, A-4
using the Attribute tool  16, 188
using the Edit menu  191

default  149
setting  149
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GLVSOD\LQJ�LQ�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��7
options  A-4
selecting

IRU�VSHFLÀF�REMHFWV��150
using the Attributes palette  148
XVLQJ�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��148

B
backgrounds, of pictures  193
Bezier curves, See curves, Bezier
bitmap images

clipping  133
editing  127
resizing  128
rotating  256

BMP format, exporting in  35
borders

. See also lines
border position  185, A-9

changing  186
drawing with a selected  186
KRZ�LW�DͿHFWV�REMHFWV��187
line centered  187
line inside  187
line outside  188
selecting  186

bring to front  A-12

C
calculating area  218
cancelling actions  37
case, of text  A-8
catalogs, See symbol libraries
centered ellipse, See ellipses, centered
center point

lines, See lines, center point
snap end of line to, See lines, snapping, to center point

changes
reversing  134

redo  135
revert  136
undo  135
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saving  32
changing

drawing size  25
drawing view See view, changing
drawing view, See view, changing
line length  42
object attributes

using the Attributes palette  147
XVLQJ�WKH�ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��148

size of square corner rectangle  45
the appearance of objects  147

circles
add dimension objects using the Circle center mark tool  17
by diameter

changing the size of  54
drawing  53
resizing  118

by radius
changing the size of  54
drawing  53
resizing  118

by three points
changing the size of  55
drawing  54
resizing  119

choosing tools for drawing  52
concentric

drawing  56
snapping to grid  57

drawing  52
using the circle tool  15

snapping to grid  56
clear objects  A-4

using the Clear function  238
Clipboard

show/hide  A-5
viewing the  230

clipping bitmap images  133
closing

all documents  A-1
the current document  35, A-1

colors
choosing the number of colors to display  151
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color table  151
creating new colors  Add-12
editing  152
REMHFW�ÀOO��154
SDUDOOHO�ÀOO��155
pen  157

command keys  10, B-1
concentric arcs, See arcs, concentric
concentric circles, See circles, concentric
constrained lines See lines, constrained
contracting objects  126, A-5
copy  227, A-3

an object out of a MacDraft document using drag and drop  225
attributes  188, A-4

using the Attribute tool  16
objects on drawing  A-3
of a document, saving  33
special  A-3

copy and paste
to move items within a MacDraft document  227
to transfer items from MacDraft to another application  231
to transfer items from one MacDraft document to another  228
using with Microspot Media Assistant catalogs

to add items  D-15
to retrieve data  D-16

creating
a new document  4, A-1
objects  37

cursor  27
cross cursor, show/hide  A-10
position indicator  278

hide  279, A-11
show  278, A-11

curves
Bezier

changing the shape of  80
correcting while drawing  79
drawing  78
drawing straight line segments  80
modifying  80

freehand
drawing  75
resizing  122



Index Idx-6

IN
D

EX

spline
changing the shape of  83
drawing  82

cut  227, A-3
cut and paste

using to remove items in a MacDraft document  227
using to transfer items from MacDraft to another application  231
using to transfer items from one MacDraft document to another  228
using with Microspot Media Assistant catalogs

to add items  D-15
to retrieve data  D-16

D
datum points of objects  106
default attributes  149
defaults, setting for parallel line tool options  93
deleting

layers  312
deleting text  201
deselecting objects  31
diagonal ellipses, See ellipses, diagonal
dimensioning

about dimension objects  207
angular dimension objects  209, 216

Angular dimension tool  17
choosing units for  292
resizing  125

circle dimension objects  213
Circle center mark tool  17, 216

Dimension palette  16, 207
drawing dimension objects  209–217
horizontal dimension objects  210

Horizontal dimension tool  16
linear dimension objects  209

reference points  209
resizing  124

perpendicular dimension objects  212
Perpendicular dimension tool  17

radial dimensions  208, 214
diameter dimension objects  215

Diameter dimension tool  17
radius dimension objects  214
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Radius dimension tool  17
resizing  124

resizing dimension objects  124
slope dimension objects  211

Slope dimension tool  16
types of dimension objects  208
vertical dimension objects  210

Vertical dimension tool  16
Dimension palette  16

show/hide  A-17
displaying

multiple document windows  17
page breaks  320
palettes  11
rulers  273
text  206
Tool palette  38

distributing objects  250
using the Alignment palette  252
using the Distribute on line command  250, A-13

document
close  A-1
close all  A-1
new

creating  A-1
creating from stationery  34

opening existing  5, A-1
from the File menu  5
from the Finder  5

revert to last saved version  A-2
save  A-2
save as  A-2
units and scale  286

displaying the Document Scale and Units dialog  286
units  287

decimal places  288
English or metric units  287
hide metric units  289
unit size  288

windows  7
displaying multiple  17

drag and drop
using to move objects  222
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using with Microspot Media Assistant catalogs
to add items  D-15
to retrieve data  D-16

drawing
aids  266
area  8
dimension objects  209–217
environment  37
layout  316
objects, using snap to object  285
page size, setting  24
position, changing using the Hand tool  14
scale, setting  23
select  A-18
size  318, A-17

changing  25
tools

choosing  38
using show size with  267

units, setting  21
duplicating objects  239, A-4

auto-spacing of objects  241
Duplicate command  239
duplicate unlocked  A-4
option-drag shortcut  239, 240
ZLWKRXW�RͿVHW��A-4

E
edges, snapping along their lengths  281
editing

colors  152, A-9
objects  37
patterns  159, A-9
text  201

using the Text tool  15
Edit menu  A-3, B-1
ellipses

centered  59
changing the size of  59
choosing tools for drawing  58
diagonal  58
drawing  58
resizing  119
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snapping to grid  60
elliptical arcs, See arcs, elliptical
enabling the application  2
end caps, for parallel lines  96
end marks, of lines  182
end point lines, See lines, end point
end point, snap end of line to See lines, snapping, to end point
expanding objects  125, A-5
exporting

documents  35
in BMP format  35
in JPEG format  35

export selected image, See image editing options, Exporting Images

F
ÀOH�IRUPDWV

opening documents in other  C-2
supported  C-1

File menu  A-1, B-1
ÀOO

REMHFW�ÀOO
color  154

changing an existing object  155
GUDZLQJ�ZLWK�D�VHOHFWHG�ÀOO�FRORU��154
selecting  154

pattern  171
changing an existing object  172
GUDZLQJ�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ��172
selecting  171

SDUDOOHO�ÀOO
color  155

changing an existing object  156
GUDZLQJ�ZLWK�D�VHOHFWHG�ÀOO�FRORU��156
selecting  155

pattern  173
changing an existing object  174
GUDZLQJ�ZLWK�D�VHOHFWHG�ÀOO�SDWWHUQ��174
selecting  173

ÀOO�DQG�OLQH�LQGLFDWRU�ER[HV��7, 148
accessing attribute pop-up menus via  148
selecting attributes using  148

Filters, image, See image editing options, Filters
ÁLSSLQJ�REMHFWV��261
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ÁLSSLQJ�DQ�REMHFW�RU�SLFWXUH��262
ÁLSSLQJ�WH[W��263
horizontally  A-13
vertically  A-13

font
select  A-6
size, select  A-7
style, select  A-7

formats
saving documents in other  34
VXSSRUWHG�ÀOH��C-1

formatting text  202
freehand curves

drawing  74
resizing  122

freehand drawing tools, choosing  74
freehand lines

changing the shape of  76
correcting while drawing  75
drawing  74, 75
drawing a straight line as part of  76
reshape

smooth  106
unsmooth  106

freehand shapes
changing the shape of  76
correcting while drawing  75
drawing  15, 75, 76
drawing a straight line as part of  76
reshape

smooth  106
unsmooth  106

resizing  122

G
gradients  Add-3, Add-6, Add-10, Add-11
grid

lines  284
show/hide  284, A-16

snap  279, 280
releasing objects from  281
setting  279, A-15
snapping edges and lines to  281
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WXUQLQJ�RͿ�DQG�RQ��281
grouping objects  247, A-12
groups, resizing  123

H
Hand tool, using to change drawing view  137
help  2
Help menu  A-18
hidden objects, selecting  29
hiding

Alignment palette  A-18
area calculations  221, A-11
Attribute palette  A-17
Clipboard  A-5
cross cursor  A-10
cursor position indicator  279, A-11
Dimension palette  A-17
grid lines  284, A-16
layers  306
metric units  289
page breaks  320, A-16
palettes  11, A-17
Resize palette  A-18
rulers  A-16
Show Size palette  273, A-18
text  206, A-8
Tool palette  A-17

hierarchical menus  9
Home View  A-11

selecting to change drawing view  145
KRUL]RQWDO�MXVWLÀFDWLRQ�RI�WH[W��204, A-7

I
image editing options  324

Exporting Images  342
JPEG Image Options  344
Photoshop / Truevision TGA & Windows BMP Image Options  344
PICT and QuickTime Options  345
PNG Image Options  346
TIFF Image Options  347

Filters  335
Add  335



Index Idx-12

IN
D

EX

Noise  335
Unsharp Mask  336

Distortion  339
Distortion 2D/Distortion 3D  339
Shrink  340
Spherize  340

(ͿHFW��337
Custom Blur  337
Motion Blur  337
Posterize  338

Remove  341, 342
Dust and Scratches  341
Noise  342

Modes  333
Bitmap Mode  333
Grayscale Mode  333
RGB Mode (Red, Green, Blue)  334

Converting Image Modes  334
Resizing Image / Canvas  348

Canvas  349
Image  348

Settings  324
AutoFix  325

Clipping  326
Radius  327
Strength  326
Threshold  327

Blur & Blur a lot  325
Brightness / Contrast & RGB  325
Histogram  327
Hue / Saturation  328

Before/After  328
Hue  328
Saturation  329
Scale  328

Levels  329
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Auto Levels Settings  329
Auto Option  329
Clipping  330
Color Targets  330
Correcting an Image  331
Gamma  333
Threshold mode  332

Negative  324
Sharpen & Sharpen a lot  325

LPDJH�ÀOWHUV� See�LPDJH�HGLWLQJ�RSWLRQV��ÀOWHUV
Image menu  A-14
image modes, See image editing options, modes
images, bitmap

clipping  133
resizing  128

image settings, See image editing options, settings
increasing object size, See expanding objects
installing the application  1
interrupting the screen redraw  146
irregular polygons, See polygons, irregular

J
joining

objects See attaching objects
JPEG format, exporting in  35
justifying text  A-7

K
keyboard shortcuts  Add-17
keys

Command  10, B-1
special usage of  B-1

L
layers  302–315

adding  304
arranging  309
deleting  312
grayed  306
hiding  306
merging  311
renaming  305
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selecting active  304, 313
using the Arrow tool  314
using the layer pop-up menu  314
using the Layer Selection tool  314

the Layers palette
closing  312
displaying  303

Layout menu  A-15
libraries, See symbol libraries
Library palette  298, A-18

new library  299
adding items to  301

opening a library  298
retrieving items from a library  302

drag and drop, scaled  302
drag and drop, unscaled  302

lines
attributes for  178
basic  40
center point  86

snapping to grid  87
changing the length of  42
choosing tools for drawing  40
constrained  40, 41
drawing

using the Line tool  14
using the Special line tool  15

end marks  182
changing  184
drawing with selected end marks  184
Selecting  183

end point  86
snapping to grid  87

freehand
changing the shape of  76
correcting while drawing  75
drawing  74, 75
drawing a straight line as part of  76
reshape

smooth  107
unsmooth  107

grid lines, show/hide  284
mid point  86
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snapping to grid  87
RͿVHW

drawing  91
snapping to grid  92

parallel, See parallel lines
perpendicular

drawing  85
snapping to grid  86

resizing  115
snapping

to center point  285
to end point  285
to grid  42, 281
to mid point  285

spacing for text  A-7
special  83

choosing tools for drawing  84
style  180

changing  182
drawing with a selected line style  181
selecting  180

tangent  88
between circles or arcs  89
from a circle or arc to a point  88

unconstrained  40, 41
weight  178

changing  180
drawing with a selected line weight  179
selecting  178

locking objects  264, A-13

M
MacDraft format, saving documents in  32
MacDraft manual  3, A-18
PDJQLÀFDWLRQ�SRS�XS�PHQX��XVLQJ�WR�FKDQJH�GUDZLQJ�YLHZ��144
marker symbols  105

adding to drawing  105
using the Marker symbol tool  16

marquee zoom  141
menu

Arrange  A-12, B-2
Edit  A-3, B-1
File  A-1, B-1
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Help  A-18
Image  A-14
Layout  A-15
Options  A-9
Text  A-6
View  A-10, B-2
Window  A-17, B-2

menu bar  9
menus

hierarchical  9
pop-up  39

Microspot Media Assistant  D-14
adding items to a catalog  D-15

using cut/copy and paste  D-15
using drag and drop  D-15

opening catalogs  D-14
retrieving data

using cut/copy and paste  D-16
using drag and drop  D-16

saving catalogs  D-16
mid point lines, See lines, mid point
mid point, line snapping to, See lines, snapping to mid point
Modes, image, See image editing options, Modes
moving

objects  222–238, A-5
move back one  246, A-12
move forward one  245, A-12
to back  244, A-12
to front  242, A-12
using drag and drop  222–227

PRGLÀHU�NH\V��224
the drag and drop process  223
to copy an object out of a MacDraft document  225
within a MacDraft document  224
with multiple objects  227

using the arrow keys  237
using the Move command  232

absolute move  232
relative move  234

using the Resize palette  235
absolute move  235
relative move  236

palettes  12
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show area calculation values  220
text  205

multiple objects, selecting  30

N
naming an untitled document  32
new document, creating  4, A-1
number of sides, setting for regular polygons  50

O
object attributes, See attributes
objects, changing the appearance of  147
RͿVHW�OLQHV� See�OLQHV��RͿVHW
opening

documents in PICT format  C-4
existing documents  5, A-1

from the File menu  5
from the Finder  5

Options menu  A-9
options, tool  13

P
page breaks, showing and hiding  320, A-16
page setup, set options  A-2
page size, setting the drawing  24
palette

Alignment, showing and hiding  A-18
Attribute, showing and hiding  A-17
Dimension  16

showing and hiding  A-17
Resize  235

displaying  108
showing and hiding  A-18

Show Size  266
showing and hiding  A-18

Tool  14
displaying  38
showing and hiding  A-17

palettes  10, 14
hide  11
hide all  A-17
move  12
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show  11
show all  A-17
using  11

palette tools  12
SDUDOOHO�ÀOO See�ÀOO��SDUDOOHO�ÀOO
SDUDOOHO�ÀOO� See�ÀOO��SDUDOOHO�ÀOO
parallel line objects, drawing  92

using the Parallel line tool  15
parallel lines

choosing tools for drawing  92
drawing  98
editing  98
extruding  102

from a line or edge  103
from a parallel object  104
snapping to grid  104

resizing  115
snapping to grid  99
tool options  93

alignment  94
end caps  96
line joints  97
line width  97
setting defaults  93
setting for selected object  94

parallel polygons
changing the shape of  101
drawing  99
resizing  122
snapping to grid  101

parallel polylines
changing the shape of  101
drawing  99
extruding  102

from a line or edge  103
from a parallel object  104
snapping to grid  104

resizing  122
snapping to grid  101

paste
. See also copy and paste, cut and paste
objects into drawing  A-3
repeated paste  229, A-4
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unscaled  229, A-4
patterns

creating new patterns  Add-13
editing  159, A-9
REMHFW�ÀOO��171
SDUDOOHO�ÀOO��173
pen  175
using  159

PC Draft PE  C-3
pen

color  157
changing an existing line/border  158
drawing with a selected pen color  158
selecting  157

pattern  175
changing an existing line/border  177
drawing with a selected pen pattern  176
selecting  175

perpendicular lines, See lines, perpendicular
PICT format  C-3

opening a document in  C-4
saving a document in  C-3

picture backgrounds  193
opaque  194
transparent  193

pointer
choosing the  28
mode, activating  28

polygons
irregular

changing the shape of  72
using major handles  72
using minor handles  73

choosing tools for drawing  69
drawing  15, 70
reshape

smooth  107
unsmooth  107

resizing  122
snapping to grid  73

parallel, See parallel polygons
regular

changing the size of  51
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choosing tools for drawing  49
drawing  15, 50
resizing  122
setting the number of sides  50
snapping to grid  52

polylines
changing the shape of  72

using major handles  72
using minor handles  73

drawing  70
parallel, See parallel polylines
reshape

smooth  107
unsmooth  107

resizing  122
snapping to grid  73

pop-up menus  39
for tools  12

positioning
borders  A-9
objects  279
text  205

printing
choosing your printer (OSX 10.2 and below)  D-17
GHÀQLQJ�3DJH�6HWXS��316

displaying the Page Setup dialog  317
orientation  318
paper  317
scale  318

options  321, A-2
display the Drawing Size dialog  321
registration marks  322
reverse order  322
specifying how pages are numbered  321

Q
quitting the application  36

R
rectangles

drawing  43
round corner  45
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changing the size of  48
choosing tools for drawing  46
drawing  15, 47
snapping to grid  49
with constant corners  46

resizing  116
with elliptical corners  46

resizing  117
with proportional corners  45

resizing  116
square corner

changing size of  45
choosing tools for drawing  43
drawing  15, 43

from center  44
from its corner  43

resizing  116
snapping to grid  45

redo  135, A-3
registering the application  3, A-18
registration marks, printing  322
regular polygon, See polygons, regular
relative resize  109
releasing objects from

angle snap  283
grid snap  281

removing, objects from drawing  A-3, A-4
repeated paste  229
requirements, application  1
reshaping

a block of paragraph text  198
freehand lines  107
freehand shapes  107
objects  106

smooth  106, A-5
unsmooth  106, A-5

polygons  107
polylines  107

Resize Image/Canvas, See image editing options, Resize Image/Canvas
Resize palette

displaying  108
moving objects using  235



Index Idx-22

IN
D

EX
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resize units  114
resizing

bitmap images  128
dimension objects  124
groups  123
objects  108

absolute resize  109
by changing the absolute values of one point  110
by changing the relative values of one point  113
displaying the Resize palette  108
relative resize  109
resize units  114
whole object by absolute values  109
whole object by relative values  111

restore previous zoom  A-10
to change drawing view  145

reversing changes  134
redo  135
revert  136
undo  135

revert  136
to last saved version of document  A-2

rotating
bitmaps  256
objects  252–264, A-13

centre of rotation, choosing the  256
choosing units for angular display  292
grouped objects  256
multiple objects  256
rotate options  258, A-13

amount of rotation  259
center of rotation  259
direction of rotation  259
the Rotate Options dialog  258

units of rotation, changing the  255
using show size with rotation  272
using the Rotate by 90° tool  16, 253
using the Rotate command  254
using the Rotate tool  14, 254
using the Rotate to zero command  257, A-13

text  256
round corner rectangles, See rectangles, rounded corner
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rulers  26, 273
hide  A-16
show  273, A-16
types  274

scale  274, A-16
standard  274, A-16

zero points, setting  275
independently  276
simultaneously  276

S
saving

changes  33
copy of a document  33, A-2
document as stationery  34
document in another format  33, 34
documents  32, A-2
in MacDraft format  32
in PICT format  C-3
untitled document  32

scale  286, 291
angular display  291

setting the rotation units  292
decimal places  292
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document  286
paste unscaled  229
rulers  274, A-16
setting for drawing  23, 290

screen redraw, interrupting  146
scrolling, to change drawing view  136
selecting

all objects  31, A-5
font  A-6

size  A-7
style  A-7

hidden objects  29
multiple objects  30
no objects  31, A-5
objects  27, 28

deselecting  31
using the Selection tool  14

text  32, 198
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all  A-8
the active layer  313
tools  38

send to back  244, A-12
setting

angle snap  282
grid snap  A-15
the drawing page size  24
the drawing scale  23
the drawing units  21

Settings, image, See image editing options, Settings
shapes See freehand shapes
shapes, freehand, See freehand shapes
shortcuts  Add-17
show

Alignment palette  A-18
area calculation  A-11
Attribute palette  A-17
Clipboard  A-5
cross cursor  A-10
cursor position  A-11
Dimension palette  A-17
grid lines  284, A-16
page breaks  A-16
palettes  A-17
Resize palette  A-18
rulers  A-16
show size palette  A-18
text  206, A-8
Tool palette  A-17

show area  218
hide  221, A-11
modifying calculation values  218

changing font attributes  219
detaching  220
moving  219, 220

show  A-11
show size  266

the Show Size palette  266
hide  273, A-18
show  266, A-18

using with drawing tools  267
arcs  271
circles and ellipses  270
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line tools  267
regular polygons  268
rounded-corner rectangles  269
square-corner rectangles  267
text tool  267

using with rotation  272
size

. See also show size
changing drawing  25
of objects

decreasing  126
increasing  125

Slope dimension tool  16
smooth objects  A-5

unsmooth objects  106
snap

set angle  A-16
snap to grid, set  A-15
to object  285, A-16

snapping lines
to center point  285
to end point  285
to mid point  285

special lines, See lines, special
spline curves, See curves, spline
square corner rectangles, See rectangles, square corner
stacking windows  18, A-17
standard rulers  274, A-16
star tool  Add-15
stationery

saving a document as  34
using for a new document  34

style, font, select  A-6
switching between drawings  20
symbol libraries  294

libraries available  294
Architecture  296
Electronic Schematic  296
Graphics Volume 1  295
Graphics Volume 2  295
Volume 5  297

Microspot Library Palette  298
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Microspot Media Assistant  D-14
Old symbol library format  297
Old symbol library formats  D-1
purchasing  297
sample library  294

T
tangent lines, See lines, tangent
text  195

aligning  206
case, selecting  A-8
deleting  201
editing  15, 201
entering  15, 195

paragraph text  196
regular text  195

formatting  202
before entering  202
changing the case  204
GHÀQH�DWWULEXWHV��203
existing  202

hiding  206, A-8
inserting into existing text  201
justifying  A-7
line spacing, selecting  A-7
moving  205
positioning  205
replacing  201
reshaping a block of paragraph text  198
rotating  256
scaling  291
selecting  32, 199

all  200, A-8
rotated text for editing  200
using the Arrow tool  200
using the I-beam pointer  199

showing  206, A-8
Text menu  A-6
tiling windows  17, A-17
tool options  13, 40, A-10

for parallel lines  93, 97
alignment  94
end caps  96
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setting defaults  93

Tool palette  14
hide  A-17
show  38, A-17

tools
palette tools  12
pop-up menus for  12
selecting  38
star  Add-15

transforming objects  222, 252

U
unconstrained lines, See lines, unconstrained
Undo  135, A-3
ungrouping objects  248, A-13
units

choosing for angular display  292
document, setting  21, 287
resize  114

unlocking objects  265, A-13
unscaled, Paste Unscaled  229, A-4
unsmoothing objects  A-5
untitled documents, saving  32
upgrade information  4, A-18

V
YHUWLFDO�MXVWLÀFDWLRQ�RI�WH[W��A-7
view  136

changing
by scrolling  136
by zooming in  138, 139, 143
by zooming out  138, 140, 143
using marquee zoom  141
using the 1 to 1 tool  16, 145
using the Hand tool  137
using the Home View command  145
XVLQJ�WKH�0DJQLÀFDWLRQ�SRS�XS�PHQX��144
using the Restore Previous Zoom command  145
using the Zoom commands  142
using the Zoom tool  16, 139
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Home View  A-11
view, changing using the Hand tool  14
viewing the Clipboard  230
View menu  A-10, B-2

W
Window menu  17, A-17, B-2
windows, document  7

stacking  18, A-17
switching between  20
tiling  17, A-17

Z
zero points of rulers, setting  275
zoom  16, A-10

commands  142
in  139, 143
marquee zoom  141
out  140, 143
restore previous  145, A-10
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