
Microspot

MacDraft Professional Tutorials
Powerful 2D Drafting, Design & Illustration

Copyright 1999-2019 by Microspot Limited. All rights reserved. Microspot MacDraft Professional is a trademark of 
Microspot Limited. All other products mentioned are trademarked by the appropriate companies.

Learning to use MacDraft
Getting started in the world of MacDraft

Tutorial Written by:
Angus MacDonald and J. Paul King.

Tutorial Edited & Designed by:
Phillip Bunker.

Microspot Tutorials
A step in the right direction  

1



Tutorial Learning to Use MacDraft Table of Contents ii

Abstract

1.0   Getting Started

	 1.1   Introduction

	 1.2   Setting the Size Units

	 1.3   Setting the Scale

	 1.4   Setting the Drawing Size & Layout

	 1.5   Rulers & the Cross Cursor

2.0   Tutorial Exercises

	 2.1   Starting the Tutorial

		  2.1.1   Finding the Tutorial Files

		  2.1.2   Opening the Floor Plan Document

	 2.2   Learning some Basic Skills

		  2.2.1   Using Zoom Out

		  2.2.2   Returning to Home View

	 2.3   Basic Setup for Drawing

		  2.3.1   Scale Function

		  2.3.2   Using Show Size

	 2.4   Completing the Floor Plan

		    2.4.1   Drawing the Parallel Lines

		    2.4.2   Layers

		    2.4.3   Libraries

		    2.4.4   Inserting a Symbol into a Drawing

		    2.4.5   Keyboard Command Equivalents

		    2.4.6   Moving an Object

		    2.4.7   Rotating an Object

		    2.4.8   Positioning Additional Symbols on the Drawing

		    2.4.9   Linear Duplication

		  2.4.10   Zoom In

		  2.4.11   Changing the Fill Pattern of an Existing Object

Page 4

Page 5

Page 6

Page 6

Page 8

Page 9

Page 10

Page 12

Page 13

Page 13

Page 13

Page 14

Page 14

Page 16

Page 16

Page 17

Page 19

Page 20

Page 21

Page 23

Page 26

Page 27

Page 28

Page 28

Page 29

Page 30

Page 33

Page 37

Page 37

Table of Contents



Tutorial Learning to Use MacDraft Table of Contents iii

		  2.4.12   Drawing with a Preset Fill

		  2.4.13   Drawing Rectangles

		  2.4.14   Circular Duplication

		  2.4.15   Drawing Circles

		  2.4.16   Drawing Polygons

		  2.4.17   Drawing Arcs		

	 2.5   Dimension Lines

		  2.5.1   Adding Dimension Lines

		  2.5.2   Linked Dimensions

		  2.5.3   Moving Dimension Lines

Page 39

Page 39

Page 41

Page 43

Page 45

Page 51

Page 54

Page 54

Page 58

Page 58



Abstract
In this tutorial you will use MacDraft to complete a 
floor plan layout. We have chosen a floor plan because 
we can incorporate many of the special features of 
MacDraft into this type of drawing. 

In this tutorial you will learn how to:

•	 Create a scaled drawing. 

•	 Use Show Size as a visual aid to draw to a precise 
size. 

•	 Draw with parallel lines. 

•	 Create precise circles, arcs, and polygons on a 
drawing. 

•	 Use Zoom In and Zoom Out to add detail to a 
drawing. 

•	 Use libraries to place objects into a drawing. 

•	 Rotate objects. 

•	 Duplicate objects one at a time, or in linear or 
circular arrays. 

•	 Use layers. 

•	 Add dimension lines to a drawing.

The tutorial has been written using the Fractional Feet 
& Inches Unit type.

For any queries during the tutorial, please use the 
MacDraft Professional documentation or contact our 
technical support from our website. You can also use 
the Forum on our website for reference. 

Tutorial Difficulty  (Shown on Front)
Microspot Tutorials are graded in a level of difficulty, 
where:

Beginners Tutorial - Requires no previ-
ous knowledge of the application.

Intermediate Tutorial - Requires some 
limited knowledge of the application.

Advanced Tutorial - Comfortable in 
using all aspects in the application.

1
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7

Accompanying Files:
There are some files available to you for this tutorial. 
These files can be located in the “~/Library/Microspot/
MacDraft Pro/Getting Started Tutorial” folder.

•	 Floor Plan

•	 Desks Library File



1.0 Getting Started

This first chapter will help to explain 
starting a document with Microspot 
MacDraft and the important areas to 
consider before you begin the draw-
ing process.
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1.1 Introduction

Before starting the exercises in this lesson, let us go over the general preparations you should make when starting a 
completely new drawing. 

MacDraft is a software tool that emulates a drafting board while giving you the advantages of creating and working 
with scaled images on a computer; you can easily make changes without physically erasing or discarding sheets of 
paper. 

One of MacDraft’s greatest strengths as a drafting and design tool is the way it enables you to define your drawing 
environment. Using simple commands and panel choices you can specify the default scale, drawing units, and page 
setup for the drawing.

The scaled environment automatically keeps track of the size and area of the objects you draw. You can show their 
dimensions using the Show Size feature, the various dimension tools, or the document rulers.

1.2 Setting the Size Units

Using MacDraft, you can draw with either English (feet and inches) or metric units, and MacDraft offers the most 
commonly used English-unit and metric scales. Once you choose a unit system for your drawing, you can define the 
scale to use.

To set the units for a drawing:

1.	 Open the Layout menu and choose Set Scale/Units. 

The Document Scale & Units dialog appears.

NOTE: If you expect to use the same settings repeatedly in your drawings, you can make these the default set-
tings for all new drawings, using the MacDraft Preferences from the MacDraft application menu.
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2.	 From the Unit Type pop-up menu, choose English or Metric depending on the type of units you want to use 
in the document. 

Once you choose the English or Metric system, you can choose the basic units for the drawing: Decimal 
Inches, Decimal Feet & Inches, Decimal Feet, Fractional Inches, or Fractional Feet & Inches in English-unit 
drawings; Millimeters, Centimeters, Decimeters, or Meters in metric drawings.
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3.	 Choose the units required from the Units pop-up menu.

NOTE: In metric drawings you can turn on “Hide Metric Units”. This prevents the unit abbreviations (“mm”, 
“cm”, and so on) from appearing when dimensions appear on the drawing. You can also specify the num-
ber of digits to display after the decimal point for both metric and English decimal units. 

1.3 Setting the Scale

Before starting a drawing, determine the sizes of the objects you want to draw, and the size of the paper on which 
you will print. For large drawings it is impractical to draw objects at their actual sizes; it is necessary to reduce them, 
yet still maintain their proper proportions. 

A scale, the ratio of the object’s size on the drawing to its size in the real world, accomplishes this. For example, if 
you choose a scale ratio of one-quarter inch equals one foot (1/4” = 1’), a line drawn ten inches long on a drawing 
would represent a line 40-feet long in the real world.

NOTE: When you paste an existing object into a drawing with a different scale, the object automatically adjusts 
in size to conform to the scale of the new drawing. The exceptions to this rule are text objects; when moving 
text objects onto a drawing with a different scale, an alert appears allowing you to choose whether or not to 
scale the text objects.
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To specify the default scale:

1.	 Open the Layout menu and choose Set Scale/Units. 

The Document Scale & Units dialog appears. 

2.	 Select the desired scale from the Default Scale pop-up menu or enter it in the Custom Scale boxes.

The new scale appears on the Default Scale button.

3.	 Click OK to close the dialog and apply the changes.

NOTE: The pop-up menu shows the scales available for the chosen unit system.

NOTE: In drawings that include more than one layer, you can set different scales for different layers. How-
ever, all the layers in a drawing must use the same unit system (English or metric).

1.4 Setting the Drawing Size and Layout

You can set a drawing’s page size, page orientation, and total size according to your needs. Page size is simply the 
size of the paper you will print on, and orientation is whether each page prints vertically or horizontally. 

You can create a drawing that prints over several sheets of paper. The maximum drawing size is approximately 14 
feet by 14 feet; it will vary slightly depending on the page size and orientation chosen. 

The choice of page size is subject to the page sizes available for the currently active printer; for example, if the current 
printer supports only A4-size or US Letter-size paper, you cannot print to larger or smaller sheets.

To set the page size and orientation for a drawing:

1.	 Open the File menu and choose Page Setup.

A Page Setup dialog similar to the one below appears.
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2.	 Select the paper size. 

3.	 Select the orientation for the page. 

4.	 Click OK.

The Page Setup dialog closes. The drawing now has the specified page size and orientation assigned to it.

To set the size of a drawing:

1.	 Open the Layout menu and choose Drawing Size.

The Drawing Size dialog appears, showing the current total drawing size in the form of a block diagram.

This diagram represents the maximum drawing size available; each block represents a single page. The dark 
blocks indicate the current drawing size. You can control the overall size and shape of the drawing by click-
ing in the diagram. 

2.	 Position the pointer on one of the activated page blocks and press down the mouse button. 

3.	 Holding down the mouse button, drag until you have activated the number of page blocks required to create 
the drawing size you want. 

4.	 Release the mouse button. 

5.	 Click OK. 

The MacDraft drawing window generally shows only a portion of the overall drawing, so when you change 
the drawing size it may not be noticeable in the window until you zoom out or scroll to another area of the 
drawing.

1.5 Rulers and the Cross Cursor

MacDraft’s rulers can help you to draw and position objects precisely on a drawing. They appear along the top and 
left sides of the drawing window and reflect the current position of the window. In magnified or reduced views 
(zoomed in or zoomed out), they update accordingly. 
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The rulers are especially useful in conjunction with MacDraft’s cross cursor. This cursor is composed of two lines that 
intersect at the cursor position and extend horizontally and vertically across the window into the rulers. The cross 
cursor only appears when a drawing tool is active. 

The rulers can show either on-screen sizes (Standard Rulers) or values that match the current scale and units.

To show MacDraft’s rulers (if not already visible):

•	 Open the View menu and choose Show Rulers.

The rulers appear and a checkmark appears by Show Rulers in the View menu.

To show scale rulers (if Show Rulers is on):

•	 Open the Layout menu and choose Scale Rulers.

To show standard rulers (if Show Rulers is on):

•	 Open the Layout menu and choose Standard Rulers.

To activate the cross cursor:

•	 Open the Options menu and choose Cross Cursor.

When you select a drawing tool, the cursor now appears as a pair of intersecting lines. A checkmark appears 
by Cross Cursor in the Options menu.

Now that you have seen the basic method of setting up a completely new drawing, you can begin the tutorial exer-
cises using a drawing that we have started for you.



2.0 Tutorial Exercises

In this chapter we will be working 
through some exercises that will en-
able you to become familiar with the 
general use of MacDraft, it’s tools 
and features. Using pre-prepared 
files you will work through a selec-
tion of key areas of interest.
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2.1 Starting the Tutorial

2.1.1 Finding the Tutorial Files

The files that we are going to use during these exercises are the “Floor Plan” MacDraft document and the “Desks” 
Library file. These files can be located in the “~/Library/Microspot/MacDraft Pro/Getting Started Tutorial” folder.

To find the tutorial files:

•	 Open your hard disk and locate the “Getting Started” tutorial folder.

The tutorial files will be inside.

2.1.2 Opening the Floor Plan Document

To open the Floor Plan document:

1.	 Go to the File menu in MacDraft.

2.	 Select the Open option.

The standard Open dialog appears.

3.	 Locate the “Getting Started” tutorial folder on your computer.

4.	 Within that folder find the “Floor Plan” document, select it and click Open.

The Floor plan document will open in MacDraft.

ALTERNATIVELY

1.	 Locate the “Floor Plan” document in the “Getting Started” tutorial folder.

2.	 Select the document, and drag it to the MacDraft application icon on the dock.

The Floor plan document will open in MacDraft.
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The Floor Plan document is a partially completed drawing, only part of which may be visible in the document win-
dow. What you see when you open it is a centered view of the drawing at its actual size (100% zoom level). This 
view is called the “home view.”

2.2 Learning some Basic Skills

When you need to access part of a drawing that is not currently visible in the document window, you can scroll to 
reposition the window. However, using the scroll controls to change your view of a large document only allows you 
to see and work in small portions of the drawing at a time; there will be many occasions when you want to view 
the entire document within a single window. To accomplish this, MacDraft incorporates a feature called Zoom Out.

2.2.1 Using Zoom Out

The Zoom Out function shows a view of your document, as it would appear from a distance. Using this feature, you 
can view either a single-page document or a multiple-page document by zooming out up to eight times. Each time 
you zoom out, your view becomes more distant and reveals a larger portion of your document.

You can change the zoom level using the View menu, the Drafting Tools on the left panel, or the Zoom control in 
the upper right corner of the application window. 

For this exercise, we will use the Zoom tool from the Drafting Tools on the left panel. If the left panel is not visible, 
open the View menu and choose Show Left Panel so that a checkmark appears next to it.
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To Zoom Out on a drawing:

1.	 Click the Zoom icon in the Drafting Tools panel.

5.	 Release the Option key and return to pointer mode by clicking the Pointer icon in the Drafting Tools panel. 

You have now reduced the view of the drawing by a factor of two (2x).

Notice that the page appears to be smaller, and more of the drawing is visible in the window. Zoom Out is 
an extremely valuable feature when working with large drawings. 

Now that you have learned how to use the Zoom Out function, let us return to the original view of the floor plan so 
that we can continue.

NOTE: If the Option key is NOT held down, the Zoom tool defaults to Zoom In mode. In this mode, a plus 
sign (+) appears inside the cursor and each time you click the mouse button you magnify your view of the 
drawing. 

2.	 Position the pointer on the drawing. 

The Zoom cursor (a miniature magnifying glass) appears. 

3.	 Press down the Option key. 

A minus sign (-) appears inside the Zoom cursor to show that you are in Zoom Out mode. 

4.	 Holding down the Option key, click the drawing once.
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2.2.2 Returning to Home View

The home view, you will remember, was described as “a centered view of the drawing at its actual size (100% zoom 
level).”. If you change your view by using Zoom In or Zoom Out, you can easily return to the home view.

To return to the home view:

•	 Open the View menu and choose Home View.

From the home view you can begin work on the floor plan exercise. Look at the partially completed floor plan on 
your screen and compare it with this completed one below.

Your job is to complete the exterior walls of the unfinished floor plan and then move furniture into the offices. You 
will be using several of MacDraft’s drawing tools and a combination of its many features to accomplish this task.

2.3 Basic Setup for Drawing

MacDraft offers many features you may want to use when composing a drawing. Generally, you should decide 
which features are important to you and go through a quick set up procedure, as we will do now. 

Before starting a drawing, consider the actual, real-world size of the subject you intend to draw. If the subject is very 
large, such as a floor plan, it would be impractical to draw it to its actual size. Therefore, you will probably want to 
draw the floor plan at a reduced size in order to fit it all onto a single document. Drawing to scale  is a method of 
reducing the size of an object to fit it on a drawing, while still maintaining the object’s proportions.
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2.3.1 Scale Function

Before you start drawing, you must choose the scale that you wish to use for the document. To do this, consider the 
actual size of the subject you want to create, and the size of the document you want to print. You can then deter-
mine the scale that you should use.

Grid divisions subdivide the drawing area. When English units are selected, at a scale of 1 to 1, the distance between 
the grid lines represents one inch. The scale determines what that one-inch-square grid on the drawing represents 
in the real world. 

If you want to draw a line that represents an object that is ten feet long, and fit the line on an 11-inch piece of paper, 
you might choose a scale of one inch equals one foot (1” = 1’). Using this drawing scale, a line ten inches long on 
your drawing would represent a line ten-foot long in the real world. Similarly, a square that is one inch by one inch 
on your drawing would represent a square that is one foot by one foot in the real world. 

The ability to draw to scale is a very valuable feature. It allows you to draw large objects on a small, manageable 
document. 

We will review this principle using the floor plan layout. Keep in mind that not all of the document may be visible in 
the document window. Let us check and see what scale is currently chosen for this floor plan.
 
Look at the title bar on the document window. The title bar shows the name of the document and the active layer. 
It also shows the current scale.

The title bar shows you that the current scale for the layer you are working on is 1”=10’.

To reduce the size of the floor plan by changing its scale:

1.	 Open the Layout menu and choose Set Scale/Units.
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The Document Scale & Units dialog appears.

Notice that the Default Scale button reads 1” = 10’, indicating again that the current drawing scale is 1” = 
10’.

2.	 Click the Default Scale pop-up menu. 

3.	 Drag until 1” = 20’ is selected.

4.	 Release the mouse button. 

5.	 Click OK. 

Notice that the floor plan is now one half of its original size. The new scale specifies that one inch in the 
drawing area represents 20 feet in the real world.
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Using this method, you can change the scale of a drawing created with a different scale setting. If you misjudge the 
scale and find that your drawing will not fit on the document, change the scale setting to one that is more suitable.

For this floor plan exercise, you need to change back to the original scale setting.

1.	 Open the Layout menu and choose Set Scale/Units. 

The Document Scale & Units dialog appears. 

2.	 Select 1” = 10’ from the Default Scale pop-up menu. 

3.	 Click OK. 

When you set the scale, other parts of the drawing environment are updated to conform to the scale change. For 
example, the grid snap  options are updated to provide snaps that represent incremental steps of the scale (and the 
size units). The grid snap can be thought of as an invisible network of magnets that allows you to move objects in 
even increments and draw objects with greater precision. 

With some understanding of the scale function, you are ready to learn about another of MacDraft’s convenient fea-
tures. With the scale set to 1” = 10’, you can be assured that each inch of a line on this drawing represents ten feet. 
But how do you know when you have successfully drawn a line10’ 3 1/2” long?

In some instances, it might be difficult to draw a line to a precise size. MacDraft assists you with this task by providing 
a constant digital display of the size of an object or line as you draw it. This feature is called Show Size.

2.3.2 Using Show Size

The Size pop-up provides you with a constant display of an object’s size while you are drawing it. The measurements 
displayed always reflect the current scale of the drawing. For example, we have chosen a scale of 1” = 10’ for our 
floor plan. If you were to draw a line from one grid line to the next, the length of the line would be displayed as ten 
feet, since one inch on the drawing represents ten feet in the real world. 

Using the Show Size function relieves you of calculating the actual size of each object on your drawing, regardless of 
the scale you have chosen. This feature is crucial when you need to draw to a precise size, as you will in this exercise.

To use the Show Size function:

•	 Open the View menu and choose Show Size so that a checkmark appears next to it.

The Size pop-up will now appear whenever you draw or resize an object.

For the Floor Plan, you will want the objects measured in feet and inches with a fractional display. For this exercise, 
Feet & Fractional Inches has already been set for you. Let us verify this:
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1.	 Open the Layout menu and choose Set Scale/Units. 

The Document Scale & Units dialog appears.

Notice that Fractional Feet & Inches appears on the long button at the top of the dialog. In an untitled Mac-
Draft document, where options have not been preset for you as they have in this tutorial, you would choose 
the size units with which you prefer to work (for example, centimeters, decimeters, meters, feet only, inches 
only, feet and inches, and so forth). 

As you can see, Fractional Feet and Inches has been chosen already. So when you draw an object, the Size 
pop-up will display the size of objects and lines using these units.

2.	 Click OK.

Now that you have determined how the sizes of objects are to be displayed on the drawing, you are ready to begin 
working on the Floor Plan.

2.4 Completing the Floor Plan

The floor plan is missing two exterior walls. Your first task is to add these. If necessary, use the Zoom Out function 
so that the entire drawing is visible on screen. This makes it easier for you to draw the walls.

If you need to Zoom Out on the drawing:

1.	 Click the Zoom icon in the Drafting Tools panel.

2.	 Press and hold down the Option key. 

3.	 Position the Zoom pointer on the drawing. 

The Zoom cursor appears on the screen. A minus sign appears in the center to confirm that you are in Zoom 
Out mode. 

4.	 Click the mouse button.
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5.	 Click the Pointer tool to return to pointer mode.

Parallel lines represent the exterior walls. Using MacDraft you can draw a single set of parallel lines, as well as poly-
gons and polylines with double lines. Since most of the exterior walls are already in place, you just have to complete 
the top and right walls. 

2.4.1 Drawing Parallel Lines

The easiest way to complete the walls is to use the polyline option for parallel lines. The Extrude Parallel Line and 
Extrude Parallel Polyline tools can now fuse new lines onto existing ones to create, for example, a wall contour that 
is a single object rather than a composite object as it would have been in earlier versions.

To choose the polyline option for parallel lines:

1.	 Point on the Parallel Line icon on the DraftingTools panel. 

2.	 Press down the mouse button. 

The Parallel Lines pop-up menu appears. 

3.	 Holding down the mouse button, drag until Polyline is highlighted. 

4.	 Release the mouse button.
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To finish the exterior walls:

1.	 Make sure that the Snap to Object option is on via the Layout menu.

2.	 Position the cross cursor on the end of the upper parallel line in the top left corner of the floor plan, and the 
cursor should snap to its position. 

3.	 Click the mouse button. 

4.	 Press down the Shift key. 

The Shift key constrains the lines to 90 degrees. 

5.	 Holding down the Shift key, drag to the right until you have created a pair of lines 59’8” long. The cross 
cursor and Smart Snapping guides make it easy to align the end of the parallel lines precisely with the outer 
line of the existing right hand wall.

Note that as you draw the lines, the Size pop-up gives you a constant display of their length. 

6.	 Click the mouse button. 

7.	 Drag downwards until the parallel lines meet the lines of the existing right hand wall. 

8.	 Double-click the mouse button. 

9.	 Release the Shift key.

Since the exterior walls are complete, it is no longer necessary to remain in a zoomed out view. If you zoomed out 
prior to drawing this then:

•	 Select the Pointer tool by clicking in the Drafting Tools panel.

•	 Open the View menu and choose Home View. 

The original view of the floor plan appears.
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In the next few pages you will perform the following tasks:

•	 Create a layer to hold the office furnishings.

•	 Use a library to furnish Mary’s and Bill’s offices, the reception, and main office areas. 

•	 Arrange chairs in a circular array around the table in the conference room. 

•	 Create a coffee table and cabinet in the reception area.

First, let us keep the office furnishings separate from the wall layout. We can do this by putting the furnishings on 
a separate layer.

2.4.2 Layers

Layers are useful because they allow you to physically separate the various components of your drawing. The objects 
on different layers are independent of each other; you can perform operations on objects on one layer without af-
fecting objects on other layers. 

The independence of the separate layers also gives you flexibility in controlling the way objects are “stacked” on a 
drawing. Stacking refers to the order in which the different layer planes are arranged on the drawing.

Let us begin by creating a new layer to hold all the office furnishings:

•	 On the right panel, click the second tab to open the Layers pane.
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When you open a new MacDraft document, you start out by working on Layer-1, the default layer.

Renaming Layers

Let us rename Layer-1 with the more meaningful name, “Wall Layout”:

1.	 Select Layer-1 in the Layers pane, then click in the name field. 

Its name becomes editable. 

2.	 Type “Wall Layout”.

3.	 Press the Enter (Return) key on the keyboard 

The new name, “Wall Layout”, replaces the name “Layer-1” in the layer name section. 

The layer Wall Layout is the active layer. You can tell which layer is active by the checkmark that appears 
beside its name. Only one layer can be active at a time. The active layer is the only layer you can edit.

Adding a New Layer

We can now add a layer to hold the office furnishings and call it “Furnishings”. With the Layers pane still open, you 
can create a new layer by simply clicking a button.

•	 Click the Plus (+) symbol.
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MacDraft assigns a default name to new layers; it assigned the name “Layer-1” to the layer you just added. Notice 
that the new layer appears underneath the Wall Layout layer with a checkmark beside it. When you add a new layer, 
it automatically becomes the active layer, therefore the checkmark now appears beside the new layer.

An eye beside a layer’s name also means that it is a visible layer. You have the option of hiding, graying out, or dis-
playing layers. You should rename the new layer with the more meaningful name “Furnishings,” just as we renamed 
the other layer “Wall Layout.”

1.	 Rename the new layer “Layer-1” to “Furnishings”. 

2.	 Press the Enter (Return) key on the keyboard. 

The new name, “Furnishings”, replaces the name “Layer-1” in the layer name section. 

Displaying Layers

By default, the contents of inactive layers are displayed. However, you can choose to ‘gray’ the contents of inactive 
layers. To show you how this works, let us choose to gray the contents of the Wall Layout layer.

To gray the contents of the Wall Layout layer: 

1.	 Click the eye icon next to the “Wall Layout” layer. 

The icon turns black and white to show that the layer is grayed out. 

2.	 Click the eye icon again to hide the layer completely

The icon disappears to indicate that the layer is hidden.

3.	 Click the space next to the “Wall Layout” layer where the eye icon was previously shown to display the layer 
again.

The icon reappears.

You need to make sure that the “Furnishings” layer is the active layer to be able to work on it. Check to see if the 
checkmark is next to the “Furnishings” layer.

To make a layer active:

•	 Click the padlock symbol beside the layer you want to make active.
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Now that you have created the Furnishings layer, let us begin furnishing Mary’s and Bill’s offices using the Desks 
library. 

2.4.3 Libraries

Libraries are used to save, catalog, and retrieve standard images. You can drag previously created symbols out of 
libraries and drop them directly onto your drawing. 

For this floor plan exercise, symbols of an executive desk set and a secretarial desk set have already been drawn for 
you, and are stored in a library. You will learn how to open the library and place a symbol on your drawing.

To open the library:

1.	 Click the gear icon at the bottom of the Library viewer, which is in the lower part of the right panel.

2.	 Choose Open Library from the pop-up menu.

The standard Open dialog appears.

3.	 Locate the library you want to open (the Desks.spotlibrary file in the Getting Started Tutorial folder), select 
it, and click Open.

The Desks library opens in the Library viewer.
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2.4.4 Inserting a Symbol into a Drawing

Now we are ready to place the executive desk set symbol into Bill’s office.

To place the symbol:

1.	 In the Library viewer, in the “Desks” library, click the Executive Desk Set item.

2.	 Select and hold down the mouse button on the item.

3.	 With the mouse button held down, drag the item into Bills section of the MacDraft document.

4.	 Release the mouse button.

The Executive Desk Set item is added to the document.

Position the desk in the center of Bill’s office, if it is not centered already:

1.	 Position the tip of the pointer anywhere on the desk set, except on one of its edit handles. (Edit handles are 
used to change an object’s size or shape.) 

2.	 Press and hold down the mouse button. 

3.	 Drag the desk into the center of the office. 

4.	 Release the mouse button.

Now that you have furnished Bill’s office with an executive desk set, you will need an additional one to place in 
Mary’s office. You could drag and drop another copy of the symbol into the drawing, but we will duplicate the desk 
you have placed in Bill’s office. Rather than choosing Duplicate directly from the Edit menu, let us look at a faster 
way to execute the command.
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2.4.5 Keyboard Command Equivalents

Certain menu items can be chosen by pressing a specific combination of keys on the keyboard, rather than using the 
mouse to make a selection from a menu. The Command key symbol and an additional character appear beside menu 
items that can be chosen from the keyboard in this way. You choose these items by holding down the Command 
key and pressing the appropriate character. For example, to choose Duplicate (which appears in the Duplication sub-
menu of the Edit menu), hold down the Command key and type “D” (uppercase or lowercase). The Edit menu will 
be highlighted for a moment, and a duplicate of the selected object will appear.

To duplicate the executive desk set:

1.	 Click the set to select it (if it isn’t already selected). 

2.	 Press and hold down the Command key. 

3.	 Press the D key (uppercase or lowercase) 

A duplicate of the desk set appears. It is selected, and ready for you to move into Mary’s office.

OR

4.	 Hold the Option key down

5.	 Drag the selected item to duplicate it.

2.4.6 Moving an Object

To move the duplicate set: 

1.	 Position the tip of the pointer anywhere on the desk set, except on one of its edit handles. (Edit handles are 
used to change an object’s size or shape.) 

2.	 Press and hold the mouse button down. 

3.	 Drag the duplicate into Mary’s office. 

4.	 Release the mouse button. 
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As you may have noticed in the finished floor plan example, the desk in Mary’s office is rotated 90 degrees to face 
Bill’s office. Therefore, you must rotate the desk.

2.4.7 Rotating an Object

On many occasions you will want to position an object at an angle other than horizontal or vertical. For this rea-
son MacDraft incorporates the Rotation function. This feature allows you to rotate lines and objects through a full 
360-degree range. 

The Size pop-up provides a constant visual display of the number of degrees you are rotating an object.

Now let us rotate Mary’s desk by 90 degrees.

1.	 Select Mary’s desk, if necessary. 

Edit handles appear on the desk set. 

2.	 Choose Rotate Tool from the Arrange menu (or hold down the Command key and type “R”).

3.	 Without pressing down the mouse button, move the cursor to the center of the window. 

The Rotation cursor appears. 

4.	 Holding down the mouse button, drag counter-clockwise until you have rotated the desk by 90°.

5.	 Release the mouse button. 

6.	 Click the Pointer tool to return to pointer mode.

As you drag, the Size pop-up shows you a constant visual display of the number of degrees you are rotating the 
object. If you make a mistake, or release the mouse button too soon, choose Rotate to Zero from the Arrange menu, 
then choose Rotate again, and rotate the object the correct number of degrees.
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With Bill’s and Mary’s offices furnished, you are ready to use the symbol for the secretarial desks, which will be 
placed in the reception and main office areas. 

2.4.8 Positioning Additional Symbols on the Drawing

The secretarial desk set symbol is also located in the Desks library. To place it in your drawing:

1.	 In the Library viewer, in the “Desks” library, click the Secretarial Desk Set item.

2.	 Select and hold down the mouse button on the item.

3.	 With the mouse button held down, drag the item into the main office area of the MacDraft document.

4.	 Release the mouse button.

The Secretarial Desk Set item is added to the document.

You will use this secretarial desk set for both the reception and the main office areas. Therefore, let us make a du-
plicate that you can use for furnishing the reception area. 

1.	 Make the floor plan drawing the active window by clicking it.

2.	 Make sure the Pointer tool is selected.

3.	 The secretarial desk set should still be selected; if it isn’t, click it. 

4.	 Open the Edit menu, choose Duplication, and then choose Duplicate from the submenu. 

5.	 Move the duplicate into the center of the reception area.

NOTE: You can also activate the Rotate tool by clicking its icon in the Drafting Tools panel, or you can rotate 
objects by exactly 90° using the Rotate Item 90 Degrees Left and Rotate Item 90 Degrees Right buttons in the 
upper toolbar. For more precise rotations, open the Rotate Options dialog from the Arrange menu.

Rotate tool
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As you may have noticed, in the finished example of the floor plan the reception desk is positioned in the upper left 
corner of the reception room, facing the main office area. You therefore have to rotate the desk.

To rotate the desk:

1.	 Select the secretarial desk in the reception area. 

2.	 Open the Arrange menu and choose Rotate Tool. 

3.	 Position the rotation cursor in the center of the window. 

4.	 Press down the mouse button.

5.	 Holding down the mouse button, drag clockwise, rotating the desk to 270°.

6.	 Release the mouse button. 

7.	 Click the Pointer tool to return to pointer mode.

To position the desk: 

1.	 Point on the desk. 

2.	 Press and hold down the mouse button over the desk. 

3.	 Drag the desk into the upper-left corner of the reception area. 
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4.	 Release the mouse button.

Next, we will complete the main office. The main office has eight secretarial work stations. Therefore, you need to 
make eight desk groups. The desks are arranged in two rows of four desks each, with each desk facing the recep-
tion area. 

First, rotate the desk in the main office area so that it faces the reception area.

To rotate the desk: 

1.	 Select the desk. 

2.	 Open the Arrange menu and choose Rotate Tool (or select the Rotation tool in the Drafting Tools panel). 

3.	 Move the Rotation cursor to the center of the window. 

4.	 Press down the mouse button. 

5.	 Holding down the mouse button, drag in a counter-clockwise direction until the Size pop-up reads 90°. 



Tutorial Learning to Use MacDraft Tutorial Exercises 33

6.	 Release the mouse button. 

7.	 Click the Pointer tool to return to pointer mode.

Now that you have rotated the desk, you need to move it into position, and then make seven more copies in two 
rows.

To position the desk:

1.	 Point on the desk. 

2.	 Press and hold down the mouse over the object to drag it. 

3.	 Drag the desk into position as shown.

Now that you have positioned this desk, we can use the Linear Duplication function to create the other seven 
desks. The desk should still be selected, If it is not, use the Pointer tool and click it.

2.4.9 Linear Duplication

Using Linear Duplication, you can duplicate an object or group in one or two directions at the same time. Here, you 
will create a row of duplicates, as detailed above, and simultaneously create a duplicate of that row.

To use Linear duplication:

1.	 Open the Edit menu and choose Linear from the Duplication submenu.
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The Linear Duplication dialog appears.

2.	 In the Number of Copies field, enter 4 (the total number of copies for the first row). 

3.	 In the Distance field, type 7’. 

Distances between objects will be in the units set for the drawing. 

4.	 In the Angle field, make sure 0 (zero) is entered, so the copies will appear to the right of the first desk.

5.	 Open the Direction pop-up menu, and then choose Two Directions. 

The choices for Two Directions become active.



Tutorial Learning to Use MacDraft Tutorial Exercises 35

You can also define the duplication interval by horizontal and vertical offset, entering an X and Y value to 
determine the positions of the copies.

6.	 Type 2 in the Number of Copies field. 

7.	 In the Two Directions section, click the Distribute: X & Y Offset radio button. 

The X and Y distance fields appear. 

8.	 In the Delta-X field, make sure 0 (zero) is entered, since you only need a vertical offset to create the second 
row. 

9.	 In the Delta-Y field, type 6’.
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10.	Click Duplicate. 

Eight desks appear, spaced as you specified. 
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You have just used a combination of functions to assist you in creating the two rows of desks for the main office 
area. As you can see, by using several of MacDraft’s features in conjunction with one another, you can perform many 
repetitive tasks quickly and easily. 

With the main office area completed, you are now ready to furnish the conference room. You will create a confer-
ence table and eight chairs. However, notice this room is small and therefore does not allow you much space for 
creating furniture. Drawing small objects, such as chairs, in a confined area could be very difficult, especially if you 
need to draw them to a precise size. 

A special feature of MacDraft, Zoom In, allows you to obtain a magnified view of the conference room so that you 
can work at a more detailed level. This feature is particularly useful when you want to add small details to a large-
scale drawing, such as this floor plan. 

2.4.10 Zoom In

The Zoom In function allows you to obtain a full-screen display of a selected portion of your drawing. Once you have 
zoomed in on a small portion of the drawing, and have added the necessary details, you can return to the normal, 
or home view of the drawing. 

We will use the Zoom In feature to add and position the furniture in the conference room.

To zoom in on the conference room:

1.	 Click the Zoom (magnifying glass) icon on the Drafting Tools panel. 

2.	 Without pressing down the mouse button, position the Zoom cursor over the conference room. 

3.	 Click the mouse button. 

4.	 Click the Pointer tool to return to pointer mode.

Each time you click a portion of the drawing that you want magnified, the power of magnification increases by two, 
up to a magnification of 32 times for a one-page drawing. Alternatively, you can use the Zoom control in the top 
right corner of the application window; choose a zoom level from the pop-up menu or type an exact zoom value 
and press Return.

Notice that the view of the conference room appears much larger now, and we have adequate space to draw furni-
ture. First, let’s give the conference table some definition by filling it with a pattern.

2.4.11 Changing the Fill Pattern of an Existing Object

MacDraft offers a variety of fill patterns to help you distinguish between similar objects, identify different layers on a 
drawing, and show textures and surfaces. Fill patterns also add definition and shape to your drawing. In this exercise, 
you will use a fill pattern for the conference table and chairs, a coffee table, and a cabinet. You will first fill an existing 
object with a particular pattern, then learn how to choose a preset fill that will appear inside all objects you draw. 

To add a fill pattern to the conference table:

1.	 The conference table is on the Wall Layout layer. To make this the active layer, click the padlock beside its 
name in the Layers pane.
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2.	 Select the conference table. 

3.	 Click the first tab on the right panel to open the Properties pane.

4.	 In the Colors & Patterns group, click the color well next to the “paint drops” icon.

5.	 Click the Pattern tab.
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2.4.12 Drawing with a Preset Fill

Now you are ready to draw the chairs around the conference table. To choose a preset fill, you must make sure that 
no objects on the drawing are selected before you make your fill choice.

1.	 Click a blank part of the drawing to deselect all objects.

2.	 In the Properties pane, click the color well next to the “paint drops” icon.

3.	 Click the Pattern tab.

4.	 Choose a suitable pattern and click it. 

The color well changes to display the pattern you chose as the current fill. All objects you draw will contain 
this pattern until you make another choice for the current fill.

2.4.13 Drawing Rectangles

To draw the first chair:

1.	 Return to the Furnishings layer by clicking the padlock besides its name in the Layers pane. 

6.	 Choose a suitable pattern and click it. The conference table is now filled with the pattern you chose.

Select the kitchen table and chairs in the upper right corner of the drawing and repeat steps 4-6 to fill those 
with the pattern too.
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You have created the first of five chairs that will be positioned around the conference table. You will use this chair 
with the Circular Duplication feature to create and position all of the other chairs. You can also select the circle table 
in the “Wall Layout” layer and make sure that it has the same fill pattern as all of the other items. Be sure to return 
to the “Furnishings” layer.

2.	 Select the Square-Corner Rectangle tool in the Drafting Tools panel.

3.	 Position the cursor above the table in the room next to Bill’s.

4.	 Click the mouse button. 

5.	 Drag to create a rectangle that is about 2’ by 1’ 6”. 

6.	 Click the mouse button to finish.

NOTE: If you have difficulty creating a rectangle of an exact size by dragging, create one of any size, and 
then open the Properties pane on the right panel and enter the size you want in the Width and Height 
fields in the Parameters group.
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2.4.14 Circular Duplication

As you may have noticed in the finished floor plan, the chairs around the conference table are rotated to face the 
table. Using Circular Duplication, you can duplicate objects or groups so that they appear arranged around a circle, 
rotated to match their positions. Let us start by returning to pointer mode.

1.	 Return to pointer mode by clicking a blank area of the drawing. 

2.	 Select the chair you just created. 

3.	 Open the Edit menu and choose Circular from the Duplication submenu. 

The Circular Duplication dialog appears.
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4.	 Enter 5 in the Number of Copies field.

5.	 Make sure that Distribute: Proportionally is selected and that the angle entered is 360°. 

These settings ensure that the distribution will be all the way around a circle. 

6.	 Make sure that Rotate Copies is turned on. 

7.	 Make sure that Next Mouse Click is chosen from the Duplication From pop-up menu. 

8.	 Click Duplicate. 

The centering cursor appears.

9.	 Move the centering cursor to the center of the table, then click the mouse button. 

A ring of 5 duplicate chairs appears, centered around the point you specified.

The conference room is now complete. Let us go back and look at our work from the home view (that is, the original, 
non-magnfied view). 

•	 Open the View menu and choose Home View.
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You now see the home view of the floor plan. In the finished floor plan example, the reception area had a round 
coffee table in the bottom left corner. 

To make this coffee table, you will zoom in on the reception area, just as you zoomed in on the conference room. 
While zoomed in on this area, you will also make a cabinet in the space between the reception area and main office 
area. 

These steps will complete all the detailed drawing in the floor plan. Let us begin by following these steps:

1.	 Click the Zoom icon in the Drafting Tools panel. 

2.	 Position the Zoom pointer so that it is in the middle of the reception area. 

3.	 Click the mouse button. 

4.	 Click the Pointer tool to return to pointer mode. 

Your new view shows the entire reception area and a portion of the main office.

2.4.15 Drawing Circles

You will use the Circle tool to create a round coffee table, three feet in diameter; and you will place the table in the 
reception area. 

MacDraft has three different tools to draw circles. You can draw a circle by its diameter, by its radius, or by three 
points. In this exercise, you will draw the circle by its diameter. Notice that within the Drafting Tools panel, the letter 
“D” appears inside the Circle icon. The “D” is a visual indicator to let you know that any circle you create will be 
drawn by diameter.

1.	 Select the Circle by diameter tool in the Drafting Tools panel.



Tutorial Learning to Use MacDraft Tutorial Exercises 44

Position the cursor in the bottom section of the reception area. 

2.	 Click the mouse button. 

3.	 Drag to the right to create a circle 3’ in diameter.

4.	 Click the mouse button to finish.

To make sure the circle is exactly 3’ across, select it and take a look at the Diameter field in the Parameters section 
of the Properties pane on the right panel. If the diameter is not correct, type 3’ and click Apply. 
 
The coffee table is complete, so let us position it in the reception area.

1.	 Return to pointer mode by selecting the Pointer tool from the Drafting Tools panel. 

2.	 Point on the circle. 

3.	 Press and hold down the mouse button over the object to drag it. 

4.	 Holding down the mouse button, drag the circle to the bottom left corner of the reception area.
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5.	 Release the mouse button.

With the coffee table in place, you are ready to complete the reception area by creating a cabinet in the upper right 
corner. Notice that in the finished floor plan example, the cabinet is an odd shape. You could create this cabinet by 
using the Constrained Line tool in conjunction with sets of short lines. However, a more efficient method is to use 
the Polygon tool.

2.4.16 Drawing Polygons

The polygon tool is used to create irregularly shaped objects easily. With this tool you can draw an uninterrupted 
series of straight lines. You can orient the lines at any angle. Then, when you are done, MacDraft automatically closes 
the object.

1.	 Select the Polygon tool in the Drafting Tools panel.

2.	 Position the cursor to the right of the reception desk.
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If you want any of the sides of a polygon to be horizontal or vertical, you can restrict the line to 90 degrees by hold-
ing down the Shift key while you draw. Because all the cabinet sides are either horizontal or vertical, using the Shift 
key will simplify the task of drawing the cabinet in this case. 

The Size pop-up will display the length of the line between the starting point and the present cursor position, allow-
ing you to draw line segments to a precise size.

3.	 Click the mouse button

4.	 Hold down the Shift key.  

5.	 Drag upwards to create a 1’6” line. 

6.	 Click the mouse button.

Notice that while you were drawing, the line remained perfectly vertical. By holding down the Shift key, you 
constrained the line to the vertical axis. 

7.	 Without pressing down the mouse button, move the cursor to the right to create a line that measures 9’ 
long. 

8.	 Click the mouse button.

Position cursor here
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We purposely had you draw a line that was too long so that we could introduce you to a special feature that lets you 
edit a polygon while you draw it.

Dynamic Editing of a Polygon

The Polygon tool features dynamic editing of the last point. This means that you can change the length and position 
of the last line drawn by moving the last selected point. 

Now let’s edit the 9’ line that you just created. If you have moved the cursor away from the end point of the last line 
segment, just reposition it onto that same point. 

Remember to hold down the Shift key to maintain a horizontal drawing plane.

1.	 Click the mouse button to reselect the end point. 

2.	 Move the cursor to the left until the line length reads 7’.

3.	 Click again to select the new end point position. 

Now that you have edited this line, let us continue with the cabinet. 

4.	 Without pressing down the mouse button, move the cursor downwards to create a line 1’6” long.
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5.	 Click the mouse button. 

6.	 Without pressing down the mouse button, move the cursor to the left to create a line 1’6” long.

7.	 Click the mouse button. 

8.	 Without pressing down the mouse button, move the cursor upwards to create a line 9” long.
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9.	 Click the mouse button. 

10.	Without pressing down the mouse button, move the cursor to the left again to create a line 4’ long.

11.	Click the mouse button. 

12.	Without pressing down the mouse button, move the cursor downwards to create a line 9” long.

13.	Double-click the mouse button.

Notice that when you clicked twice, the polygon automatically closed itself. This double-click technique is a conve-
nient, step-saving way of closing any polygon that you create. 

Now that you have created the cabinet, you are ready to move it into position.

1.	 Select the Pointer tool by clicking it in the Drafting Tools panel or pressing the Escape key. 

2.	 Point on the cabinet. 

3.	 Press and hold down the mouse button over the object to drag it. 

4.	 Holding down the mouse button, drag the cabinet into position. 
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You have added a coffee table and cabinet to the reception area of the drawing. The floor plan is now completely 
furnished. Let us return to the home view and see how the drawing looks.

•	 Open the View menu and choose Home View.

All that is left to do now is to create the conference room doorway, and add the dimension lines to the exterior walls. 

Let us start with the doorway. First we must make the Wall Layout layer active again before we can draw the door-
way. You can use the Layers pane in the right panel to select the active layer.

1.	 Go to the Layers pane and move the cursor over the padlock symbol beside the “Wall Layout” layer. 

2.	 Click the padlock.

The layer is now the active one, and the padlock is replaced by a checkmark.

Remember, the contents of the inactive layer may be grayed out depending on the settings for the layer. Therefore, 
the furniture on the Furnishings layer may now be grayed out.

Next, let us magnify our view to make the drawing task easier:

1.	 Click the Zoom tool in the Drafting Tools panel. 

2.	 Position the Zoom pointer so that it is directly over the door opening in the conference room.

3.	 Click the mouse button twice to zoom in 4x. 
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4.	 Click the Pointer tool to return to pointer mode. 

With the view of the doorway area magnified, you can now create the doorway. Generally, you use curved lines to 
draw doorways. The curve of the line shows the direction the door opens. The Arc tool offers the simplest way to 
represent a doorway.

2.4.17 Drawing Arcs

Remember that the pattern fill is still active. If you were to draw an arc now, it would have a pattern fill and appear 
on the drawing as a wedge. 

You want to create an arc with no fill. To create an arc with “No fill” defined as the current fill attribute, you must 
first make sure that no objects on the drawing are selected.

1.	 Click a blank part of the drawing to make sure no objects in the drawing are selected. 

2.	 In the Properties pane, click the color well next to the “paint drops” icon. 

3.	 Click the Pattern tab.

4.	 Select the “no fill pattern” option, which is the first option in the first row. 

The color well changes to display your choice as the current fill. 

To create the appearance of a doorway, you need to use a circular arc drawn by its radius. Notice that the letter “R” 
is currently displayed beside the Arc icon in the Drafting Tools panel, indicating that the Arc By Radius function is 
the current arc drawing option.
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2.	 Position the cursor on the right edge of the conference room door opening. 

3.	 Click the mouse button. 

4.	 Drag to the left until the cursor touches the starting point of the room wall.

5.	 Click the mouse button.

To complete the arc (doorway):

6.	 Move the cursor down and to the right. 

7.	 Click the mouse button when the Size pop-up reads “∆A° = 90°”.

To draw the arc:

1.	 Click the Arc tool on the Drafting Tools panel.
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If you accidentally release the mouse button at the wrong angle, you can easily edit the arc to obtain the correct 
angle.

To correct the arc angle:

1.	 Return to pointer mode by clicking a blank area of the drawing. 

2.	 Position the tip of the pointer on the edit handle on the end of the arc. 

3.	 Press down the mouse button. 

4.	 Holding down the mouse button, drag until the Size pop-up reads “∆A° = 90°”.

With the doorway complete, the final task on this floor plan is to add the dimension lines on the two exterior walls 
you created earlier. Zooming out to view the entire floor plan makes it easier to add the two dimension lines. Let us 
zoom out to add the lines.

1.	 Open the View menu and choose Home View.

If necessary to fit the complete drawing in the document window:

2.	 Click the Zoom icon. 

3.	 Press and hold down the Option key. 

4.	 Click the drawing to zoom out 2x. 

5.	 Click the Pointer tool to return to pointer mode.
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To display the horizontal distance between the top left and right corners of the exterior walls:

1.	 Make sure the Wall Layout layer is active and the left panel is visible.

2.	 If the left panel is not visible, open the View menu and choose the Show Left Panel command so that the 
checkmark appears next to its name. 

3.	 Click the Horizontal Dimension Line icon.

2.5 Dimension Lines

2.5.1 Adding Dimension Lines

Another convenient MacDraft feature, Dimensioning, gives you the ability to add dimension lines to show the size 
of the objects on your drawing. 

In this section you will create horizontal and vertical dimension lines to measure the length (in feet) of the exterior 
walls. 

The dimension lines that you will create are called associative dimension lines. These dimension lines will measure 
the distance from one end of the wall to the other. The dimension value is displayed to the scale of the drawing. 

Associative dimension lines have witness lines that extend from the ends of the dimension line to the points they 
measure. Witness lines are automatically generated when you create associative dimension lines. Linked dimension 
lines are automatically linked to their associated points. This means that if the points change position, the dimension 
lines will be updated automatically to reflect the new dimension. 

You create dimension lines using the Dimension Tools from the left panel.
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4.	 Position the “1st Point” cursor near the left corner of the top exterior wall, as shown in the figure below.

5.	 Click the mouse button. 

The point is marked, indicating the beginning point for the dimension line, and the “2nd Point” cursor ap-
pears.

6.	 Position the cursor near the top right corner of the top exterior wall.
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7.	 Click the mouse button. 

The point is marked, indicating the ending point for the dimension line, and the “Anchor” cursor appears.

To position the dimension line away from the wall:

8.	 Click about half a grid division above the wall to indicate where you want the dimension line to appear.

The dimension line shows the horizontal distance between the two points on which you clicked. 

To create the vertical dimension line for the far right exterior wall:

1.	 Click the Vertical Dimension Line icon. 
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2.	 Click the top corner of the right exterior wall to specify the beginning point of the dimension line. 

3.	 Click the bottom corner of the right exterior wall to specify the ending point of the dimension line. 

4.	 Click about half a grid division to the right of the lunchroom wall to indicate where you want the dimension 
line to appear. 

The dimension line will appear half a grid division away from the vertical exterior wall. 

5.	 Click the Pointer tool to return to pointer mode. 

Check the placement of your horizontal and vertical dimension lines with the following figure. You may want to 
increase or decrease the distance between the dimension lines and the exterior walls.
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You’ll see how you can move dimension lines soon. First, let us find out how linked dimension lines automatically 
update.

2.5.2 Linked Dimensions

As an example of how the dimension value of a dimension line is automatically updated, let us move one of the 
points the dimension lines are linked to, then change it back to its original position.

To move the point and see the dimension value update automatically:

1.	 Point on the left corner of the top exterior wall (the 1st Point selected when creating the horizontal dimen-
sion line) and press down the mouse button. 

2.	 Holding down the mouse button, drag to the left to move the end point of the wall. 

3.	 Release the mouse button.

Notice that the dimension line and its value have been updated automatically to reflect the new length of 
the wall. Since we want to leave the length of the exterior wall as it was previously, we will choose Undo 
immediately, before we perform any other action, to reverse the effects of the last command.

To revert the wall to its original length:

1.	 Open the Edit menu and choose Undo Resize. 

Notice that as the wall changed back to its original length, the dimension line and value also changed back 
to display the original position and value.

2.5.3 Moving Dimension Lines

You may want to move the dimension lines closer to the walls of the building or farther away. You can move hori-
zontal dimension lines up and down, and you can move vertical dimension lines to the left and to the right.

To move the vertical dimension line:

1.	 Click the vertical dimension line to select it. 

2.	 Position the cursor on one of the edit handles at the top or bottom of the line. 

3.	 Press and hold down the mouse button.

4.	 Holding down the mouse button, drag the line to the right about half a grid division. 

5.	 Release the mouse button. 

Notice that the witness lines change size so that they always remain under the end marks of the dimension 
line.

Dimensions are important in showing the sizes of objects in a drawing. With auto dimensioning, all you do is choose 
the type of dimensioning; click the first point; click the second point; and click off the line to indicate where the 
dimension line is to appear. Congratulations! You have now completed the floor plan exercise. 

If you would like to quit this session and return to the Finder:

6.	 Open the MacDraft application menu and choose Quit. 

The document and the MacDraft application close.
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