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1Chapter 1 Introduction

Chapter 1
Introduction

Welcome to Microspot MacDraft
MacDraft is the 2D CAD app that makes floor plan design, architectural drawing 
and illustration simple on the Mac. Create precise and professional 2D drawings 
in moments, with this easy-to-use, powerful and affordable drafting application. 
With its precise vector tools, smart units and fully-featured scaled environment 
MacDraft is designed to deliver an easy to use solution, without having to spend 
hours and hours learning how to use more complicated software. 

You'll find a comprehensive set of features, tools and options available to you 
with MacDraft. These will provide a smooth, fast and creative design experience, 
giving you the confidence to create your 2D CAD drawings, plans, illustrations 
and more.

This User Guide has information about the features and capabilities of Microspot 
MacDraft Professional. It is laid out to let you refer directly to a particular feature 
and obtain detailed instructions about its use. Before you proceed you should be 
comfortable with terms such as click, drag, select and choose. You should also be 
familiar with the general methods used in most Macintosh® applications such as 
moving and scrolling a window. If you are not, refer to your Macintosh owner’s 
guide.

Hardware and Software Requirements

•	 Macintosh System running MacOS 10.14 or later.

•	 Intel Processor

•	 2 GB RAM
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Installing Microspot MacDraft

After installing MacDraft from one of the following methods, it must be run from 
your hard disk and not from the physical media (DVD or USB).

To install Microspot MacDraft from a Download

1.	 Download your MacDraft installation files using the link provided in your 
sales email. If prompted for a username and password, these can be found in 
the same email.

2.	 Once the file has downloaded, double click the ZIP file to uncompress it. 
(The operating system may unzip the file automatically for you once it has 
downloaded, if so, move onto step 3)

3.	 Double-click the MacDraft DMG file to mount it. Then double-click the 
MacDraft installer and follow the on screen instruction.

4.	 The MacDraft software and its files will be installed where you specify on 
your hard disk.

Top Tip: Once MacDraft has installed it would be a good idea to store the 
downloaded DMG somewhere safe. This will mean you can use it again in the 
future if you need to re-install the application for any reason.

To install Microspot MacDraft from a DVD

1.	 Insert the MacDraft DVD into the DVD drive.

2.	 Double-click the MacDraft Installer.

3.	 Follow the instructions that appear.

4.	 The MacDraft software and its files will be installed where you specify on 
your hard disk.

To install Microspot MacDraft from a USB

1.	 Insert the MacDraft USB into the USB port.

2.	 Double click the USB from your Finder or Desktop.
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3.	 Double-click the MacDraft DMG file to mount it. Then double-click the 
MacDraft installer and follow the on screen instruction. 

4.	 The MacDraft software and its files will be installed where you specify on 
your hard disk.

Starting Microspot MacDraft

The first time you launch MacDraft you must enter a name and valid serial 
number to enable the software.

To enable Microspot MacDraft

1.	 Double-click the MacDraft application icon to launch the software.

2.	 Enter a name and valid serial number into the dialog that appears. 

3.	 The serial number must be valid for the version you are using. This will be 
supplied with the program or upgrade when purchased. 

4.	 Only when you have typed in your serial number, the Continue button 
becomes available. Click it to open the application.
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5.	 If you click the Cancel button, the application will run in demo mode and 
some of the features and menu options will be dimmed.

Important Note: A single serial number is for use on a single machine. If you wish 
to run MacDraft on multiple machines you may need multiple serial numbers or a 
network license which would be perfect for educational or business institutions. If 
you need further information on this contact Microspot directly. 

6.	 Next you will be met with a new prompt to choose your theme for MacDraft. 
You can choose Light mode, Dark mode or for MacDraft to automatically 
change based on your system preferences. 

7.	 Next a prompt will appear asking you to choose whether you would like 
MacDraft to open as a single screen application or using palettes. 

8.	 The next prompt is the What's New dialog. Here are a list of new features 
and a clickable link to the full list of new features in the current version of 
MacDraft.

9.	 The final prompt is the Welcome to MacDraft window. By default you will 
be met by this whenever you launch MacDraft. Here you can choose to create 
a new document, open an existing document, choose a template or gain help 
via online tutorials.   

Important Note: In the preferences of MacDraft Pro you can make change how 
MacDraft behaves on start up. You can set MacDraft to open a new document, 
an existing template or even to open the template chooser for you to pick a new 
template each time you go to make a drawing.  
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The Help Menu
The Help menu is used to open the MacDraft manual, product registration, 
upgrade information and online support.

MacDraft Manual (PDF)

The MacDraft Manual in PDF format is a digital version of the manual for quick 
reference while running MacDraft. The digital manual is included with the 
product and will be installed on your hard drive during the installation process.

Choose MacDraft Manual from the Help menu and a PDF of the Manual will 
open. You can then navigate through and read the manual on screen or print 
sections for your reference.

Registration Information

Choose Registration Information from the Help menu and you will be 
redirected to a web page where you can register your product.

Note: Registering your product is important as it gives you access to free technical 
support, makes upgrading your product easier and means you will be kept up to 
date with any information on future versions, releases and offers.

Upgrade Information

You can also obtain information (if any) about upgrades from the Upgrades web 
page by choosing Upgrade Information from the Help menu. 
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Note: Upgrades are different from updates. Upgrades are payable purchases for 
you to turn your current version into the latest. For example upgrading version 
7.0 to version 8.0. Updates are smaller incremental versions containing bug fixes 
and minor improvements and are free for registered users. For example, updating 
version 7.0 to version 7.0.1.

 

Online Support

You can obtain free online support (if you have registered your product) from the 
support ticket web page by choosing Online Support from the Help menu. 

Keyboard Shortcuts

The Keyboard Shortcuts in PDF format is a digital list of the keyboard shortcuts 
for quick reference while running MacDraft. Choose Keyboard Shortcuts from 
the Help menu and a PDF will open. You can then navigate through and read the 
shortcuts on screen or print for your reference.

Welcome to MacDraft...

Choose Welcome to MacDraft from the Help menu and it will open the 
Welcome to MacDraft panel, where you can access online PDF and Video 
tutorials.
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What's New...

Choose What's New... from the Help menu and it will open the What's New 
panel, where you can see what is new in the latest version of MacDraft.

Document Handling
You can open documents from the desktop or from within the application. 

Creating a New Document

There are a few ways to create a new document in MacDraft. You can either open  
a blank new document, open an existing file or you can use the template chooser.

Top Tip: You can choose how your new documents open by setting the Document 
Defaults in Preferences, available in the MacDraft menu. From here you can choose 
whether to always open a blank new document, use the template chooser or open a 
particular template. 

To open a new document when launching MacDraft

•	 When you launch MacDraft for the first time it will prompt the serial number 
panel and then will take you through the first time set up until you reach 
the Welcome to MacDraft panel where you can choose to create a new 
document, open a MacDraft template or browse your documents. 

•	 When you launch MacDraft after the first time, it will do one of the 
following, depending on your Application Defaults:

Show the Welcome to MacDraft Screen: The Welcome to MacDraft 
screen will appear allowing you to choose to create a new document, open a 
MacDraft template or browse your documents.

Show the Template Chooser: The Template Chooser panel will open giving 
you the ability to choose from a selection of default templates or your own 
templates.

Open New Blank Document: This will create a new blank document.

Use Template: This will open your chosen template as a new document each 
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time you launch MacDraft. 

To create a new document with the New Document Wizard

If you have chosen to create a new document via the Welcome to MacDraft 
window you will be met with the New Document Wizard. 

In this dialog you can choose the unit type, unit, Decimal places, paper size, 
scale, background color, grid color, page break color, guide color and smart snap 
color to create your perfect document. 

To open a new document when MacDraft is already running

•	 Choose New from the File menu.

Note: The New option in the File menu is controlled by the settings chosen in the 
Document Defaults from the Preferences... option in the MacDraft Menu.

Opening an Existing Document

Existing documents can be opened from the Finder, from MacDraft’s File menu 
or from the MacDraft Drawing Chooser.
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Notes: 
Only documents compatible with MacDraft version 5.6 or later (drawings and
symbol libraries) can be opened by the current version of MacDraft. Drawings 
created with earlier versions of MacDraft (or with Dreams®) require special 
treatment.

Files created in versions prior to 5.6 (e.g. 2.1 to 5.5), need to be opened in MacDraft 
version 5.6 > 6.2.1 and then re-saved, before they can be opened in the version 7.0. 
The document will have a "∆" symbol prefixed to the file name to distinguish it 
from the document created with the older version of the software.

MacDraft 8.0 has the same MD70 file format as seen in version 7. Files with an 
MD60 file format can still be opened in MacDraft 8.0 and will then need to be 
saved in the new file format.

To open an existing document with the Finder

•	 In the Finder, locate the document you want to open and double-click it.

Note: If you have any other versions of MacDraft on your machine, including 
Trial versions, double clicking a file may open one of those applications rather than 
the current open MacDraft. We recommend only having one version of MacDraft 
installed on a machine. 

To open an existing document from the File menu

You can open a document from the File menu, even if you already have another 
document open.

Note: MacDraft can open files in many other formats including DWG and DXF 
(see Appendix C File formats for more details).

•	 Choose Open from the File menu

The standard open dialog appears. Locate the document you want to open 
and either double-click its name or click once its name to select it and then 
click the Open button.

•	 Choose Open Recent from the File menu to see a list of your recent 
documents. Click one to open it. 
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To open an existing document from the Welcome to MacDraft window

You can open existing and recent documents from the welcome to MacDraft 
window. 

Note: The Welcome to MacDraft window will only display if you have 'always 
show on startup' ticked within its window, otherwise you can select it from the Help 
menu.

You can open your files via the Browse documents on your Mac option in the 
Welcome to MacDraft window. Select this option and the standard open dialog 
will appear, navigate this to find the file you wish to open. 

You will also see a list of your most recent documents in the right hand side of 
the Welcome to MacDraft window. Double Click any file here and it will open. 
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Opening Drawings made with older versions of MacDraft

As MacDraft has become a more powerful drafting tool, it's file formats have 
become more sophisticated. This means that some older MacDraft drawings must 
be converted through intermediate versions of the application before they can 
be opened with the current version of MacDraft. For example, drawings created 
with MacDraft 5.5 or earlier will be .mdd files and must be opened and saved 
using MacDraft 5.6 or higher before they can be opened in the version 7.0 of 
MacDraft. Microspot provides these versions for registered owners of the current 
version. 

Important Note: With older files it is important to remember that sometimes, 
depending on the content of the files, there can be losses or slight discrepancies in 
the data, meaning that some items may not display as expected.

The MacDraft Environment

The Single Screen Document Window

The MacDraft single screen allows you to access your document for viewing, 
creating and editing the drawing area. It is designed to offer you a drawing area 
with all the essential features of MacDraft within easy reach of your mouse. 
When you open the MacDraft application, the following screen appears.
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Floating Palettes

MacDraft can be run in single screen mode or floating palettes mode. In floating 
palette mode you can move all of the individual palettes around your screen or 
dual screens and put them where best suits you. 

Important Note: Switch from single screen to floating palettes via View > Switch 
to Palettes or switch to single screen via View > Switch to Single Screen. 

The Drawing Area

The drawing area is the part of the window that shows the grid divisions. These 
divisions are called grid lines. In English units, the distance between the grid 
lines represents one inch; in decimal feet, one tenth of a foot; and in metric units, 
one centimeter. You can use the grid lines as visual aids to assist you in your 
drawing. When you create a new document, MacDraft shows a document based 
on a single sheet of paper for the current output device. However, you can change 
the size of your document at any time to include multiple pages, allowing you to 
create very large drawings.

When you first open your document, the drawing area will be centered inside the 
document frame, to make it easier to work with.
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Note: The drawing area also includes a usable space around the page, which you 
can use to store items and create bleed areas for your drawings.

The Left Panel

The left panel holds the three main tool categories for Drawing Tools, Dimension 
Tools, Advanced Tools and Alignment Tools.  

Note: The left panel can be hidden and shown at any time using the "Show/Hide 
Panels" option in the Toolbar.

The Drawing tools 

All the main drawings tools for shapes, arcs, curves and much more. Select the 
tool to start using it. 

Pointer Tool: Image

Use to move and change the shape of objects, make menu choices and activate 
panel functions.

Rotation Tool: Image
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Use to rotate a selected object freely.

Selection Tool: Image

Use to select objects by drawing a selection rectangle around them.

Hand Tool: Image

Use to change the position of a drawing as an alternative to using the scroll bars.

Line Tool: Image

Use to draw straight lines at any angle (unconstrained lines) or lines that are 
restricted to a certain angle (constrained lines)

Special Line Tool: Image

Use to draw lines that are perpendicular to, tangent to or offset from some other 
object, or lines that start at the mid, end or center point of an existing object.

Square - Corner Rectangle Tool: Image

Use to draw squares and rectangles with square corners.

Text Tool: Image
Use to add text to a drawing or edit existing text.

Rounded - Corner Rectangle Tool: Image

Use to draw rounded-corner rectangles or squares.

Circle Tool: Image

Use to draw circles by diameter (D), by radius (R) or by three (3) points; and 
concentric circles.

Ellipse Tool: Image

Use to draw ellipses from the corners.

Arc Tool: Image

Use to draw arcs by radius (R) or three points (3); elliptical arcs (E); and 
concentric arcs.

Irregular Polygon Tool: Image
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Use to draw closed objects with two or more sides.

Irregular Polyline Tool: Image

Use to draw open objects with two or more sides.

Parallel Line Tool: Image

Use to draw parallel line figures (both single segments and open or closed 
parallel polygon figures) and extrudes pairs of lines from straight edges.

Regular Polygon Tool: Image

Use to draw symmetrical objects with from 3 to 16 equal sides, such as triangles, 
hexagons, and octagons.

Bezier Tool: Image

Use to draw a bezier curve controlled by bezier handles

Spline Tool: Image

Use to draw spline curves.

Freehand Line Tool: Image
Use to draw freehand lines.

Freehand Shape Tool: Image

Use to draw freehand closed shapes.

Star Tool: Image

Use to draw stars defined by a number of sides and thickness.

Marker Symbol Tool: Image

Use to draw a standard marker symbol. 

Repeated Paste Tool: Image

Use to paste objects that are stored on the clipboard repeatedly. 

Edit Datum Tool: Image

Use to change the datum (origin point) point of a selected object. 
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Attribute Tool: Image

Use to copy and assign object attributes.

Zoom Tool: Image

Use to zoom in or out on areas of a drawing.

1:1 Tool: Image

Select to return to a single magnification view of the current drawing area.

The Dimension tools 

All the dimension tools for horizontal, vertical, angled dimensions and much 
more. Select the tool to start using it.

Horizontal Dimension Tool: Image

Use to draw horizontal dimension lines. 

Vertical Dimension Tool : Image

Use to draw vertical dimension lines.

Slope Dimension Tool: Image

Use to draw sloped dimension lines. 

Perpendicular Dimension Tool: Image

Use to draw dimension lines perpendicular to straight lines and edges.

Diameter Dimension Tool: Image

Use to draw diameter dimension objects

Radius Dimension Tool: Image

Use to draw radial dimension objects 

Circle center mark Tool: Image

Use to draw center mark for circles, arcs and ellipses
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Angular Dimension Tool: Image

Use to draw angular dimension objects 

The Advanced tools:  PRO ONLY  

This contains a selection of advanced drawing tools for handling the adding and 
removing of material, fillets, adding and removing handles and more.

Add/Delete Handle Tool: Image PRO ONLY

Use to add or delete (if the Option key is pressed) edit handles on objects.

Attach/Join Tool: Image PRO ONLY

Use to attach open shapes and edges to form single objects.

Break Tool: Image  PRO ONLY

Use to break shapes into their component edges.

Add Tool: Image  PRO ONLY

Use to add two closed shapes together to form a single object.

Subtract Tool: Image  PRO ONLY

Allows use of a line or closed shape as a ‘cutter’ to subtract part of another 
closed shape.

Extend Line Tool: Image  PRO ONLY

Use to extend lines to their intersection or to a reference line.

Trim Lines Tool: Image  PRO ONLY

Use to trim ends from intersecting lines.

Fillet Tool: Image  PRO ONLY

Use to connect lines with an arc.

Chamfer Tool: Image  PRO ONLY

Use to create a beveled corner at the intersection of two lines.
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Mirror Tool: Image  PRO ONLY

Use to mirror objects across a user-defined axis. 

Link Tool: Image  PRO ONLY

Use to link two or more vertices together so that when one is moved the others 
move with it.

Unlink Tool: Image  PRO ONLY

Use to unlink two or more vertices so that they can be moved individually.

Unlink All Tool: Image  PRO ONLY

Use to unlink all vertices of a selected object.

Using the Tools   

You can activate any tool in a panel by positioning the pointer on the icon and 
clicking it. As long as the icon is highlighted, you can draw the object or perform 
the action associated with the icon.
When you start to use MacDraft, each tool has the default current option shown 
in the panel. To change the current tool, choose the desired tool from a pop-up 
menu that shows those available.

Using the Tool pop-up menus (sub-tools)   

Each panel holds icons that represent certain tools or functions. Some tools and 
functions have more than one option associated with them. These options relate 
either to how the objects are created or to different characteristics of the objects. 
For example, in the Tool panel the square-corner rectangle options relate to 
how you create a rectangle; either from a corner or from its center. On the other 
hand, the rounded-corner rectangle options relate to the characteristics of the 
rectangles’ corners; proportional, constant, or elliptical.

The options for each function and tool can be selected from pop-up menus.

Icons used to open pop-up menus have down arrows in he corner. Unlike pull-
down menus, which are opened by clicking a word in the menu bar, pop-up 
menus are opened by clicking an icon in the panel and holding down the mouse 
button.
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1.	 Click the appropriate icon in the panel and hold down the mouse button. A 
pop- up menu appears.

2.	 Holding down the mouse button, drag to the tool that represents the desired 
option.

As you drag, the menu items will be highlighted.

3.	 When the desired tool is highlighted, release the mouse button.

The pop-up menu disappears and the tool icon will be changed to show you 
the currently selected option.

The Tool Options   

Some of the tools have additional options you can set before you start drawing, 
which can be accessed via the Tool Options panel that appears at the top of the 
drawing area, when the respective tool is selected.

The Right Panel
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MacDraft’s most important options appear in three tabs in the right hand panel: 
The Properties, Layers and Swatches tabs control various attributes of the 
objects created and the Library Panel has all the Symbols and other items you 
wish to use in your document.

Using the right panel 

The right hand panel includes three tabs at the top allowing you to select between 
Properties, Layers and Swatches. You can select a tab at any time while using 
MacDraft. The tabs will only show the relevant information for the current 
document and the selection within the document area.

Note: The Properties tab displays content specific to the selection. This means that 
the options within the Properties tab will change when you select different objects. 
To set the defaults for drawing make sure nothing is selected in the document area 
and change the settings in the properties tab.

Opening the Properties, Layers and Swatches tabs

Each key tab is represented by an icon in the right hand panel. Select the 
respective icon to open the particular tab. The tab icon will turn green once 
selected.  

The Toolbar

The Toolbar at the top of the document window can be made available, if it is not 
already, by selecting Show Toolbar from the View menu. This option can also be 
used to hide the toolbar.
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Customizing the Toolbar

With the MacDraft Toolbar you have a selection of the most commonly used 
and useful options and menu items from within the application, which you can 
customize at any time.

1. Select the Customize Toolbar... item from the View menu.

2. The toolbar sheet will appear showing you the available tools and options. 

3. Locate the Tool or Option and drag it to the toolbar to place it.

4. You can also select whether or not you want to Use Small Size or If you want       
to see Icons, Icons & Text or just Text.

The Menu Bar

The menu bar across the top of the screen contains all the MacDraft pull-down 
menus available. A rightward pointing triangle beside a menu item indicates that 
more options relating to that menu item are available.

Using keyboard commands

Certain menu items can be chosen directly from the keyboard. The Command 
key symbol and a keyboard character appear beside menu items that can be 
chosen from the keyboard.

Choose these menu items by holding down the Command key, then pressing 
the relevant character key on the keyboard. For example, to choose Duplicate 
(from the Edit menu), hold down the Command key and press D (uppercase or 
lowercase). The Edit menu is highlighted for a moment, and a duplicate of the 
selected object appears.
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Document Tabs

MacDraft includes the option to display your documents as tabs in a single 
window. You can control this by selecting Show Tab Bar from the View menu.

Tip: To have your documents default displaying in the tab bar, you will need 
to change your system preferences. Go to the Apple menu and choose System 
Preferences... Select the Dock category and set the Prefer tabs when opening 
documents option to Always. 

The Window menu

The Window menu provides you with options for displaying multiple document 
windows and for moving easily to a particular open drawing.

Switching between drawings

1.	 Open the Window menu.

At the bottom of the Window menu, all the open MacDraft documents will 
be shown, with the active (topmost) drawing indicated by a checkmark.

2.	 Select the name of the drawing you want to work on.

The drawing you choose becomes active and will be shown in front of the 
other document windows or as the active tab.
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Top Tip: You can switch between tabs by using the Show Previous Tab and Show 
Next Tab options. You can also move a tab to new window by selecting the Move 
Tab to New Window option and merge windows into tabs by using the Merge All 
Windows option 

Document Gray Space

Surrounding the MacDraft document is a usable gray space. This allows you to 
store items that your are not always using, create bleeds for your documents and 
control the borderless overlapping of objects in your layout. 

Top Tip: The document gray space is a great place to store your symbols if you are 
drawing a plan layout. Its also perfect for working on page layouts and wanting to 
create full page spreads. Set you page size to have no margins, and you will be able 
to print full page borderless prints.

Getting Started
MacDraft is a software tool that emulates a drafting board while giving you the 
advantages of creating and working with scaled designs on a computer. You can 
easily make changes without physically erasing or discarding sheets of paper.

One of MacDraft’s greatest strengths as a drafting and design tool is the way it 
allows you to define your drawing environment. Using simple menu commands 
and panel choices, you can specify the default scale, drawing units and page 
setup you need for the drawing.

The scaled environment automatically keeps track of the size and area of the 
objects you draw. You can display their dimensions using the Show Size cursor, 
the various dimension tools or the on-screen rulers.

Note: If you expect to use the same settings in most of your drawings, you 
can make those settings the defaults for all new drawings, using the MacDraft 
application menu's Preferences option. If you expect to use several different sets 
of defaults, you can save each setup as a Template file and access it through the 
Drawing Chooser panel.
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Preferences  

MacDraft lets you define defaults that affect other MacDraft documents. The 
settings you save as defaults affect all documents, even existing documents, but 
document-level defaults affect only new documents you open.

Preferences - General Tab  PRO ONLY

Appearance  

MacDraft allows you to change the appearance of the application from Light 
Mode to Dark Mode or you can set this to change dependant on your system 
defaults. 

Interface Layout

Here you can change whether you want MacDraft to open as a single screen 
application or with floating palettes by default. 

On Startup  

This allows you to set what happens each time you run MacDraft from startup. 
You can have MacDraft:

•	 Show Welcome Screen - Choose this if you want to see the Welcome Screen 
when you launch MacDraft.

•	 Show Template Chooser - Choose this if you want to see the Template 
Chooser when you launch MacDraft.

PRO ONLY
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•	 Create a new empty drawing - Choose this if you want a new blank 
document to appear when you launch MacDraft. 

•	 Display the open file dialog - Choose this if you want the Open File Dialog 
to appear when you launch MacDraft. 

•	 Do nothing - Choose this if you want nothing to open when you launch 
MacDraft. 

Auto Save

MacDraft uses the macOS Auto Save feature. Auto Save monitors you as you 
work. When you pause, it saves the document. If you work continuously, Auto 
Save will perform a save every 5 minutes. 

Preferences - View Tab

Cursor Settings

•	 Click the Use the Cross Cursor checkbox and a when using a drawing tool 
the cross cursor will appear showing you where you cursor is in relation to 
the rulers. 

•	 Click the Display Cursor Position checkbox and a small Cursor Position 
box will appear in the bottom left of your document window giving you an 
XY position of the cursor. 

PRO ONLY
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Line Settings

•	 Click the Zoom Line Weights checkbox to make all documents open with 
the Zoom Line Weights function on.

•	 Click the Hide Line Styles checkbox to turn this option off and make all 
documents open with the line styles displayed on the screen.  

Page Settings

•	 Click the Show Page Breaks checkbox to make all documents open with 
page breaks displayed on them. 

•	 Click the Show Document Guides checkbox make all documents open with 
document guides displayed on them. 

Ruler Settings

Here you can change whether you wish to use the Standard Rulers or Scaled 
Rulers. You can also click the Show Rulers checkbox to make all documents 
open with visible rulers displayed on them. 

Grid Settings

Here you can change whether you wish to use the Dotted Grid or Square Grid. 
You can also click the Show Grid checkbox to make all documents open with a 
visible grid or no grid at all. 

Preferences - Drawing Tab PRO ONLY
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Simple Click Does

Controls what happens when the mouse button is clicked once, when a tool 
has been selected. You can either have a click start drawing the object via the 
selected tool e.g. Rectangle. Or you can have a simple click reselect the arrow 
tool. 

Object Linking

•	 Click the New dimensions are linked to objects checkbox to turn this 
option off. New dimensions drawn will not be linked to objects.

•	 Click the When opening a drawing, remove all existing object links 
checkbox if you wish all links between objects (including dimension objects) 
to be removed when a drawing is opened.

Snap Settings

•	 Click the Use Snap to Object checkbox to turn Snap to Object on by default 
when a new document is opened.  

•	 Click the Use Smart Snap checkbox to turn Smart Snap on by default when 
a new document is opened. 

•	 Click the Allow snapping to guides to turn Snap to Guides on by default 
when a new document is opened. 

Border Position

This controls the position of the border on an object and can be set to the inside, 
center or outside of the object. Choose one of these options to set it as your 
default for new documents. 
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Pen Style

This allows you to choose between square, beveled and rounded as a pen style. 
The pen is how the end of a line or joined section of a line appears. Your choice 
here will be set as default for new documents. 

Line Thickness

Click the stepper up or down to change the default thickness of your lines in new 
documents. 

Preferences - Text & Color Tab

Font Type

Select from the pop up menu the font you want to use by default in your new 
documents.

Style

Select from the pop up menu the style (regular, bold, italic etc) you want to use 
by default in your new documents. 

Character Size

Use the stepper to increase or decrease your default character (font) size for new 
documents. You can also type in the character size you want. 

Line Spacing

PRO ONLY
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Choose from Single Space, 1-1/2 Space or Double Space. This will be set by 
default for text in new documents. 

•	 Click the Highlight Clipped Text checkbox if you wish to have MacDraft 
display a red marker at the base of a text box, to show when the text has 
overflowed the size of the text box. 

Object Fill

Click the color box to choose your default fill color for objects in new 
documents. You can also use the stepper or type in a percentage value to set a 
default opacity for object fills. 

Parallel Line Fill

Click the color box to choose your default parallel line fill color for parallel lines 
in new documents. You can also use the stepper or type in a percentage value to 
set a default opacity for parallel line fills.

Stroke & Text Fill

Click the color box to choose your default stroke color for objects and text in 
new documents. You can also use the stepper or type in a percentage value to set 
a default opacity for stroke and text fills.  

Preferences - Printing Tab PRO ONLY
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Print Direction

Controls the direction the printing will take when multiple pages have been 
added to the drawing, using the Drawing Size dialog. 

Print Settings

•	 Click the Print Last Page First checkbox to print the last page first and 
continue to print the rest of your pages in reverse order by default. 

•	 Click the Print Registration Marks checkbox to print crop marks at the 
corners of each printed page to show the edges of the drawing area. 

•	 Click the Include Background Color when Printing to allow the 
background color of the document chosen in the interface colors dialog, to be 
printed or not. 

Preferences - Document Tab 

For New Documents

Click the pop up to choose how new documents are handled in MacDraft. You 
can choose to Show the Template Chooser, Open Blank Document, or Use 
Template.

Note: If you choose 'Use Template' you can choose from the second pop up a pre 
saved Template to open by default when you create a new document. 

PRO ONLY
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Interface Colors

Click the Interface Colors pop up to either set the colors for the Background, 
Grid & Page Breaks, Guides and Smart Snap lines to the default colors when the 
application opens or to Custom Interface Colors to choose the different colors 
yourself. 

•	 Click the color picker next to Background to set a custom background color 
for your new documents.

•	 Click the color picker next to Grid & Page Breaks to set a custom color for 
your grid and page break lines in your new documents.

•	 Click the color picker next to Guides to set a custom color for guide lines in 
your new documents.

•	 Click the color picker next to Smart Snap Lines to set a custom background 
color for your New documents.

Current Settings - Take Settings From The Current Document

This will open a separate panel, allowing you to choose the options you would 
like to capture from the current open document and save them as a preference, 
for new documents. 

Scale/Units and Layer Setup

•	 Units, Default scale, Places behind the decimal, Grid snap, Rotation and 
angular units.

Dimension Standards

•	 Current dimensioning standard (ANSI or metric).

•	 All options defined in the Dimension Standard dialog.

Dimension Tool Formats 
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•	 Current dimensioning tool setting.

•	 All options defined in the Dimension Format dialog.

Dimension End Marks 

•	 Current dimension end mark setting.

Drawing Size and Page Setup

•	 Drawing size.

•	 All options defined in the Page Setup dialog.

Fill Patterns and Colors

•	 Fill patterns.

•	 Colors in the document’s color table.

Line Settings

•	 Line weight, Line style, End marks, Pen color.

Text Settings

•	  Font, Size, Style, Spacing, Justification.

Snap to Object 

•	 Current Snap To Object setting.

Smart Snap 

•	 Current Smart Snap setting.

Snap To Guides 

•	 Current Snap To Guides setting.

Field Names

•	 Current Object Information Field Name definitions.

Note: When you click the OK button, MacDraft saves the defaults automatically. It 
makes no difference if you later save the current drawing file.
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You may configure a document exactly the way you want it, then decide that you 
want all new documents to have that configuration. MacDraft lets you set certain 
default settings, including scale, grid snap, colors and patterns. Once you have 
established these settings in a document, you can store them as defaults so that 
the same settings are present in each new drawing you create.

Setting document defaults is different from saving MacDraft template files. You 
can save many different template documents, each with its own different settings. 
However, you can keep only one set of defaults. Also, to use the settings saved in 
a template document, you have to open the stationery document, to use defaults, 
you simply create a new document.

To Restore Defaults

Click the Restore Defaults button to reset your preferences back to the original 
settings.

Overriding Defaults  PRO ONLY

You can open a new or existing document without using your custom default 
settings.

Note: To remove permanently any application defaults you have set for MacDraft, 
remove the file uk.co.microspot.md8pro.plist (or md8PE) from the Preferences 
folder. This will be located inside the Preferences folder, within the Library folder 
at user level.

To open a new document from within MacDraft, without using your default settings

1.	 Press and hold down the Option key.
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2.	 Choose New from the File menu.

3.	 Release the Option key.

To open a new document from the desktop, without using your default settings

1.	 Press and hold down the Option key. 

2.	 Double-click the MacDraft application icon.

Setting the Units  

With MacDraft you can draw using either feet and inches (English) or metric 
units. MacDraft offers the most commonly used English and metric unit scales. 
Once you choose a unit system for your drawing you can define the scale you 
want to use.

To set the units for a drawing

1.	 Open the Layout menu and choose Set Scale/Units.

The Documents Scale & Units dialog appears.

2.	 Click the pop-up button beside English or Metric, depending on the type of 
units you want to use in the document.

Whether you use the English or Metric system, you can choose the basic 
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units for the drawing: Decimal Inches, Decimal Feet & Inches, Decimal 
Feet, Fractional Inches or Fractional Feet & Inches in English drawings; 
Millimeters, Centimeters, Decimeters or Meters in metric drawings.

3.	 If necessary, change the units in the Units pop-up menu.

Note: In metric drawings, you can choose Hide Metric Units, which prevent the
unit abbreviations (mm, cm and so on) from appearing when dimensions are 
displayed on the drawing. 

You can also control the number of places displayed behind the decimal point in 
both metric and English decimal drawings.

When using fractional inches, the number of decimal places is set only for area 
displays in the show area option in the View menu.

Setting the Scale  

Before starting a drawing, you need to determine the sizes of the objects and the 
paper you are going to use. For large drawings it is impractical to draw objects 
at their actual sizes; it is necessary to reduce them, yet still maintain their proper 
proportions.

A scale, the ratio of the object’s size on the drawing to its size in the real world, 
accomplishes this. For example, if you choose a scale ratio of one-quarter inch 
equals one foot (1/4” = 1’), a line drawn ten inches long on a drawing would 
represent a 40 foot line in the real world.

Note: When you paste an existing object into a drawing with a different scale, the 
size the object is drawn at will automatically adjust to conform to the scale of the 
new drawing.

To specify the default scale

1.	 Open the Layout menu and choose Set Scale/Units. The Document Scale & 
Units dialog appears.

2.	 Click the Default Scale pop-up menu. The Default Scale pop-up menu 
shows the scales available for the chosen unit system. Select the scale you 
want to use.
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3.	 The new scale will be displayed.

4.	 Click the OK button to close the dialog and apply the changes.

Top Tip: In drawings that include more than one layer, you can set different scales 
for different layers if necessary. However, all the layers in a drawing must use the 
same unit system (English or Metric).

To specify a custom scale

1.	 Open the Layout menu and choose Set Scale/Units. The Document Scale & 
Units dialog appears.

2.	 Enter your custom scale in the Custom Scale text boxes and click the Apply 
button to set the scale.

3.	 The new custom scale will be displayed.

4.	 Click the OK button to close the dialog and apply the changes.
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Setting the Page Size  

You can set a drawing’s page size, page orientation and total size depending on 
your needs. If necessary, you can create a drawing that will print over several 
sheets of paper. The choice of page size is subject to the page sizes available with 
the currently active printer or printing device. For example, if the printer you’ve 
selected supports only letter-size and legal-size paper, you cannot print to larger 
or smaller sheets. You can also use custom sizes if it is supported.

To page size and orientation

1.	 Choose Page Setup from the File menu. 

The Page Setup dialog appears.

2.	 Select the paper size you want for printing your drawing.

3.	 Select the page orientation (horizontal or vertical) you want for printing your 
drawing.

4.	 Click the OK button to close the dialog. Your drawing will now have the 
desired page size and orientation assigned.

Changing the Drawing Size  

Open the Layout menu and choose Drawing Size. A dialog appears displaying 
the current total drawing size in the form of a block diagram.

This grid in the dialog represents the maximum drawing size available; each 
block represents a single page. The blocks that are darkened indicate the current 
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drawing size. You can control the overall size and shape of the drawing by 
clicking in the diagram. You can change the drawing size either graphically or by 
entering the number of pages in the text boxes. 

To change the drawing size graphically

1.	 Click one of the page blocks and hold down the mouse button.

2.	 Drag until you have activated the number of page blocks required for the 
drawing size you want and release the mouse button.

3.	 Click the OK button to close the dialog.

To change the drawing size numerically

1.	 Type how many pages you would like horizontally in the first text box.

2.	 Type the number of pages you would like vertically in the second text box.

3.	 Click the OK button to close the dialog.

Rulers and Cursors 

MacDraft’s on-screen rulers can help you draw and position objects in precise 
locations on your drawing. They appear along the top and left sides of the 
drawing window, and reflect the current position of the window during scrolling. 
At magnified views (zoomed in or out), they change size accordingly.

The rulers are especially useful in conjunction with MacDraft’s crosshair drawing 
cursor. The crosshair cursor extends horizontally and vertically across the 
window, into the rulers, when a drawing tool is active.
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Rulers

The rulers can show either on-screen sizes (standard rulers) or values that match 
the current scale and units. For example, on a 1/8” = 1' scale, the major scale 
ruler divisions will be in increments of 10 (10 ft., 20 ft., and so on).

To display Microspot MacDraft rulers:

•	 Choose Show Rulers from the View menu

The rulers will be displayed and a checkmark appears by the Show Rulers 
command in the View menu.

To display scale rulers (if Show Rulers is on):

•	 Choose Scale Rulers from the Layout menu.

To display standard rulers (if Show Rulers is on)
•	 Choose Standard Rulers from the Layout menu.

Cursors

To activate the crosshair cursor

•	 Choose Cross Cursor from the Options menu.

When a drawing tool is selected, the crosshair cursor appears. A checkmark 
appears by the Cross Cursor item in the Options menu.

To activate the small cursor

•	 Choose Cross Cursor from the Options menu again.

The checkmark disappears from the Cross Cursor command in the Options 
menu. When a drawing tool is selected, the cursor appears as a small plus.
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Top Tip: We recommend that you use the cross cursor when drawing CAD layouts 
as this will help you to maintain positioning and drawing throughout your designs. 
However when working on illustration and less uniform designs, it may be easier to 
use the standard cursor.

Interface Colors 

MacDraft's drawing area is made up of a number of elements that you can 
set your own custom colors for. You can set your own custom colors for the 
background of the document, gird and page breaks, guides and smart snap lines. 
These can also be set in your application defaults, for all documents.

To set a custom interface colors

1.	 Choose Interface Colors... from the Options menu

2.	 Click the color picker next to the interface element you want to change the 
color of and the system color picker will appear

3.	 Choose the color that you want and click the red close symbol in the top left 
hand corner of the color picker.

4.	 Click the OK button in the Interface Colors dialog to set the color.

Note: The background color will only print if you have the Include Background 
Color When Printing option turned on in the Options menu.

You can also set the default values by changing the pop-up next to the interface 
element back to default, or by clicking the restore defaults button.
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Grid Type 

MacDraft's has two main grid options. You can set your grid to a dotted grid or a 
square (graph paper) style grid. Each works in the same way with the grid snap 
options and can also be set in the Preferences.

To set the grid type

1.	 Choose Grid Type from the Options menu

A sub menu will appear

2.	 Choose Dotted or Square from the sub menu and the grid type will change in 
your document.

Note: You can set a custom grid color using the Interface Colors... option in the 
Options menu.

Starting a Drawing

With these settings in place, you’re ready to start drawing. The settings you 
defined: units, scale, page setup, drawing size, rulers, drawing cursor interface 
colors and grid type remain active until you change them.

Selecting Objects
You must always select an object before you can make any changes to it. Two 
fundamental principles of using MacDraft are as follows:

1.	 You select an item.

2.	 You choose what to do to the item you have selected.
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For example, if you want to change the line weight of an object, you first 
select it, then click the line weights pop-up in the Properties tab and make a 
selection.

You can select a single object which you want to change or (for some operations) 
you can select multiple objects in order to make the same change to each selected 
object simultaneously.

Once you have selected an object, small black squares appear on its borders or at 
each end. These squares are called edit handles. For example, a selected rectangle 
will have eight edit handles; a selected line will have one handle at each end 
point. The following procedures will show you various ways of selecting objects 
on your drawing.

Activating the Pointer Mode 

Before you can select an object on your drawing, you must first activate the 
pointer. The pointer is used to resize, edit and move objects on a drawing.

Choosing the pointer

To display Microspot MacDraft pointer:

•	 Position the cursor on the Pointer icon in the Tool panel and click it.

Note: When you move the cursor over the Tool panel, the cursor will temporarily 
turn into the arrow pointer to allow you to select a tool. You can also return to the 
pointer mode by pressing the ESC key on your keyboard. 

Selecting an Object 

An object is anything that you have created, including rectangles, circles, lines, 
arcs, freehand shapes and text.
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To select and object

1.	 Return to the pointer mode by clicking the Pointer icon or by clicking the 
ESC key on your keyboard.

2.	 Position the tip of the pointer on the object and click.

3.	 The object is selected and selection handles appear.

Note: To select a non-filled object, position the pointer exactly on the edge of the 
object (its border) and select it.

Selecting hidden objects 

To select an object hidden behind other objects

1.	 Position the pointer over the hidden object’s estimated location.

2.	 Double-click this place (once to select the front object and then once again to 
select the object hidden behind it).

3.	 You should now see the handles of the hidden object showing through the 
visible object.
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Once the hidden object is selected, you can move it or choose Bring to Front 
from the Arrange menu to move it in front of other objects.

Selecting multiple objects

Select multiple objects to make the same change to all the selected objects at the 
same time.

To select multiple objects using the Pointer

1.	 Select the first object by clicking it.

2.	 Press and hold down the Shift key.

3.	 Select additional objects by clicking them, then release the Shift key.

To select multiple objects using the Selection tools

1.	 Click the Inclusive Selection tool in the Tool panel.

2.	 Position the pointer above and to the left (for example) of the objects to be 
selected.

3.	 Holding down the mouse button, drag diagonally across until you have 
enclosed all the objects you want to select in a selection box and release the 
mouse button.
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Note: If you choose the Exclusive Selection tool and drag out a selection box to 
select multiple objects, all objects that the selection box touches will be selected, 
not just those that are completely enclosed.

Deselecting objects

You can use the Shift-click method to deselect selected objects. This capability 
allows you to exclude a specific objects from a selection.

To deselect an object

1.	 Return to the pointer mode by clicking the Pointer tool.

2.	 Hold down the Shift key.

3.	 Click the object you want to deselect and release the Shift key.

The edit handles will no longer appear on the deselected object.

Select None

To deselect all selected objects, use the Select None option.

To select none

1.	 Hold down the Shift key.

The Select All command in the Edit menu will be changed to Select None.

2.	 Choose Select None from the Edit menu.

All objects in the document will be deselected.
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Selecting all objects on a layer

To select all objects on the active layer

•	 Open the Edit menu and choose Select All.

Notice that all objects and text on the active layer are selected. If you choose 
Select All while you are in the text mode and have an insertion point selected 
in a text block, the entire text block will be selected.

Selecting text on your drawing

The two techniques for selecting text are: using the I-beam pointer (the text 
cursor) to select all or part of a piece of text; and using the arrow pointer to select 
a whole text object. The steps for each are outlined below.

Using the I-beam cursor to select text

1.	 Activate the Text tool in the Tools panel by clicking it.

2.	 Position the I-beam pointer on one side of the text you want to select.

3.	 Holding down the mouse button, drag the cursor through the character(s) 
until all the text you want to select is highlighted, and release the mouse 
button.

Using the arrow cursor to select text

•	 Click with the pointer on a text object.

Notice that edit handles appear around the text.

Select Special  PRO ONLY

The MacDraft Select Special command lets you select objects according to their 
type, graphical attributes or object information. For example, you could select all 
the circles that have a green fill and an object information name of Class A.

You can choose the Select Special command from the Edit menu. The Select 
Special dialog allows you to define the parameters of the objects you want to 
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select. Any combination of attributes can be used to define a selection: object 
type, object fill color or fill pattern, object pen color or pen pattern, line weight, 
line style or object information. All the items in the current (active) layer that 
match your specifications will be selected.

The Select Special dialog  PRO ONLY

Displaying the Select Special dialog

•	 Choose Select Special from the Edit menu.

The Select Special dialog appears.

The Select Special options  PRO ONLY

Object Type

Click the Object Type pop-up menu and choose the type of object to be selected. 
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•	 Choose All to select all types of objects.

•	 Choose Text to select only text objects. 

•	 Choose General Shape, and a further menu becomes available. Select a 
particular kind of shape from this pop-up menu.

•	 Choose Dimension, and a further menu becomes available. Select a 
particular kind of dimension from this pop-up menu.

Object pen and object  fill

If you click the Object Pen or Object Fill checkbox, the relevant Color and 
Pattern radio buttons become available.

•	 Choose Color from the pop-up and then click the related Color button, the 
Pen Color or Fill Color pop-up menu becomes available. Select a particular 
color to be used as part of your selection criteria.
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•	 Choose Pattern from the pop-up and then on the related Pattern button, the 
Pen Pattern or Fill Pattern pop-up menu appears. Select a particular pattern 
to be used as part of your selection criteria.

Line Weight

If you click the Line Weight checkbox, the Line Weight pop-up menu becomes 
available. Select a line weight to be used as part of your selection criteria.
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Line Style

If you click the Line Style checkbox, the Line Style pop-up menu becomes 
available. Select a line style to be used as part of your selection criteria.

Object Information

In addition to the visible attributes of objects, object information data can be 
used to determine selections. You can set these options by clicking the Object 
Information button in the Select Special dialog.

When you click the Object Information button, an Object Information dialog 
appears, where you can specify either all or some of a drawing’s object fields 
as part of your selection criteria. Click the checkboxes to specify which object 
information fields should be used to make the selection, then type the information 
into the relevant fields.
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Selecting objects using Select Special  PRO ONLY

To select objects using select special

1.	 Open the Edit menu and choose Select Special.

The Select Special dialog appears.

2.	 Set the select criteria.

3.	 Click the Select button.

All objects on the current layer that meet the criteria will be selected.

Saving and Exporting

Saving documents 

The Save function allows you to save a new document or any changes you have 
made to an existing document.

Saving and naming an untitled document 

When you first create a new document it will have the name untitled# (# indicates 
the number of your new document, for example untitled3). 

To save and name the document

1.	 Choose Save from the File menu.

The standard Save dialog appears.

2.	 Specify the location to save the document and enter a name for it.

3.	 You may use any character or symbol on the keyboard (except a colon {:} 
and {/}) You can also use uppercase or lowercase characters, with spaces 
between words.

4.	 Click the Save button.

The document will be saved at the location, and with the name specified.
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Note: To save a copy of the current document, click the Duplicate option in the 
File menu. This will open a duplicate of the document and allow you to save that 
duplicate as a new file, following the above steps.

Save changes made to a previously saved document

While working on your document, you should save it regularly to avoid possible 
losses or data damage to the files content.

To save changes made to a previously saved document 

•	 Select Save from the File menu.

The document on the disk will be updated to include all of the changes you 
have made to the content of your document.

Note: MacDraft uses the MacOS Auto Save to automatically save your document as 
you are going. This will be on by default but you can turn it on/off via the General 
tab in Preferences. 

Saving a copy of a document

By using the Duplicate command from the File menu you can save an existing 
document using another name without altering your original document.

To save a copy of a document 

1.	 Choose Duplicate from the File menu.

A duplicate of the original document will open.

2.	 Choose Save from the File menu

The standard Save dialog appears.

3.	 Specify the location to save the document and enter a name for it.

4.	 Click the Save button.

The document will be saved with the name and at the location specified.
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Saving a document as a Template

There are 2 ways to save a document as a MacDraft Template. The first is to use 
the standard save dialog if it is the first time saving the document, and the second 
is to use the Save As Template... option in the File menu.

Note: If you want to save a document and have it appear in the My Custom 
Templates section of the Template Chooser panel, then you will need to use the 
Save As Template... option in the File menu.

To save a template using the standard save option 

1.	 Choose Save from the File menu.

The standard Save dialog appears.

2.	 Specify the location to save the document and enter a name for it.

3.	 Click the File Format pop-up menu and choose MacDraft Template.

4.	 Click the Save button.

The template will be saved with the name and at the location specified. 

Exporting a document 

The Export option in the File menu can be used to export files as images such as 
PNG and JPEG, PDF documents and AutoCAD DWG and DXF files.

To export files 

1.	 Choose Export from the File menu.

A sub menu will appear displaying the export options.
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2.	 Choose PDF..., Image..., DWG... or DXF... from the sub menu.

A standard dialog appears

3.	 Give the file a name and choose the location to save it.

4.	 Click the Save button.

The file will be saved in the format you requested with the name and in the 
location specified.

Exporting as PDF

There are 3 different ways to Export as a PDF in MacDraft via File > Export > 
PDF. You can export the Content Only, the Whole Document or Page-by-Page.  
You can also choose whether you want to include the Document background 
color, a White background or a Transparent background. 

1.	 Open the File menu and choose Export.

2.	 In Export choose PDF, the PDF dialog appears.

3.	 Choose Content Only, the Whole Document or Page-by-Page and click 
Export.

4.	 The Save dialog will appear so choose your save location and an appropriate 
file name. 

5.	 Click OK and the file will be exported as a PDF. 

Exporting as an Image
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To export your file as an image you need to open the File menu and choose 
Export > Image. A dialog will appear offering you an array of different image 
formats to choose from. Choose your image format, set the quality level you 
would like and click save. 

Exporting as DWG

To export your file as a DWG you need to open the File menu and choose Export 
> DWG. A dialog will appear offering you an array of different DWG versions 
to choose from with DWG 2018, the latest format, set as default. Choose your 
version and click save. 

Exporting as DXF

To export your file as a DXF you need to open the File menu and choose Export 
> DXF. A dialog will appear offering you an array of different DXF versions 
to choose from with DXF 2018, the latest format, set as default. Choose your 
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version and click save. 

Closing documents

To close the current active document 

1.	 Open the File menu and choose Close.

If the document contains unsaved changes, a dialog appears asking if you 
want to save changes made to your document before closing it. 

2.	 Click one of the following buttons:

•	 Click the Save button to close the document and save the changes.

•	 Click the Delete button to close the document without saving

•	 Click the Cancel button to return to the document.

To close all documents 

1.	 Hold down the Option key.

The Close command in the File menu will be changed to Close All.

2.	 Choose Close All from the File menu.

If any documents contain unsaved changes, dialogs appear asking if you 
want to save changes made to your documents before closing them.
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3.	 Click one of the following buttons:

•	 Click the Save button to close the document and save the changes.

•	 Click the Delete button to close the document without saving.

•	 Click the Cancel button to return to the document.

All the open documents will be closed.

Quitting Microspot MacDraft
When you are finished using MacDraft you can quit the application and return to 
the desktop.

1.	 Open the MacDraft application menu and choose Quit MacDraft.

If your open document contains unsaved changes, a dialog appears giving 
you the chance to save changes made to your document before quitting.

2.	 Click one of the following buttons:

•	 Click the Save button to close the document and save the changes.

•	 Click the Delete button to close the document without saving.

•	 Click the Cancel button to avoid quitting and return to the document.
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Chapter 2
Creating and editing objects

Getting Started
The Drawing Environment

When you open a new document in MacDraft, the following conditions are preset 
unless you use templates or have set your own defaults/preferences already. 

•	 Document size is a single sheet of paper.

•	 Scale is set at 1:1 (one inch equals one inch).

•	 Grid lines are shown on the drawing area.

•	 Snap Grid is turned on.

•	 All lines and borders will be drawn with a one-pixel, solid-black line.

•	 All closed rectangles, circles, arcs polygons and freehand objects will be 
shaded with a white fill. Open objects will have no fill.

The method of drawing most objects is very similar: choose the tool, decide on 
a starting point, click the mouse button, drag to create the object, then release 
to finish. Drawing polygons, arcs and curves is a little different. Step-by-step 
instructions on how to draw and change the size of each type of object are in the 
following pages.

Top Tip: Drawing aids such as guides and snapping can make drawing in MacDraft 
much easier and faster. You will also find the cross cursor and object linking are a 
great help for working with your objects. In addition the standard and scaled rulers 
can provide a clear and precise value for your measurements.
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Cancelling actions

The current action can be cancelled (in most cases), while it is in progress.

To cancel the current action while it is in progress

•	 Press the Escape key

For example, when drawing a rectangle using the rectangle drawing tool, press 
the Escape key to cancel the entire drawing operation and return you to the 
Arrow (Pointer) tool.

Choosing Drafting Tools

The tools used to create objects are located on the Tool panel/palette. 

Displaying the Drafting Tools in the left panel

If the Drafting tools in the left panel are not shown, you can open them using the 
following methods.

•	 Choose Show Left Panel from the View menu, or

•	 Click the left-hand Show/Hide Panels button in the Toolbar.

•	 If the panel appears but the Drafting Tools themselves are not visible, go to 
the Window menu and select Drafting Tools, or click the small down arrow 
next to the Drafting Tools title in the left panel. 

The Drafting Tools appear on the left of the screen

Displaying the Drafting Tools palette

If you are running MacDraft in Palette View and cant see your Tools palette, you 
can open it in the following way.

•	 Choose the Window menu and select Drafting Tools. 

The Drafting Tools appear as their own floating palette. 
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The Drafting Tools section, whether in Palette view or Panel view,  hold 
icons that represent certain tools. Some tools are stacked with related tools. 
These provide different ways of creating the same type of object, or create 
similar objects with slightly different characteristics. For example, the different 
circle tools relate to how you create a circle; On the other hand, the rounded-
corner rectangle tools relate to the characteristics of the rectangles’ corners; 
proportional, constant, or elliptical.

When you start to use MacDraft, each tool has the default option shown on the 
panel/palette. To use a tool, you activate, or select, the appropriate icon. As long 
as the icon is highlighted, you can draw the object associated with the icon.

You can activate any visible tool in the Drafting Tools panel/palette by 
positioning the pointer on the icon and clicking it. To change the current tool in a 
set, click and hold the mouse on the desired tool to reveal the pop up menu then 
choose the desired tool from the pop-up menu.

Pointer Rotate Selection Tool

Polygon Polyline Parallel Line

Rectangle Text Rounded Rectangle  

Freehand Line Freehand Shape Star

Hand Line Special Line Tool

Regular Polygon Bezier Spline

Circle Ellipse Arc

Attribute Zoom 1:1

Marker Symbol Repeated Paste Edit Datum
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To exit a drawing tool mode, click the Pointer icon in the Drafting Tools panel/
palette, or press the ESC (Escape) key on your keyboard to return to the pointer.

Pop-up menus

The tools in a tool set are accessed by pop-up menus.

Icons used to access pop-up menus have arrow heads in their corners. Pop-up 
menus are opened by clicking an icon in the panel and holding down the mouse 
button.

To select an option from a pop-up menu
1.	 Click the appropriate icon in the Drafting Tools panel/palette and hold down 

the mouse button. 

A pop-up menu appears.

2.	 Drag the cursor to the item that represents the desired tool.

As you drag, the menu items will be highlighted.

3.	 When the desired menu item is highlighted, release the mouse button.

The pop-up menu disappears and the tool icon will be changed to show you 
the currently selected tool. 

As you drag, the menu items will be highlighted.

4.	 When the desired menu item is highlighted, release the mouse button.

The pop-up menu disappears and the tool icon will be changed to show you 
the currently selected tool.
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Top Tip: Each of the main tools have a keyboard shortcut key assigned to them 
to make it faster to select the tool you want to use. You can use this key to cycle 
through the available tools. For example the parallel line tools (wall drawing tools) 
have the "w" key. Click the "w" key multiple times to cycle through the available 
tools, without having to access the sub tools pop-up.

Tool Options

Some tools have options you can change associated with them. These are 
displayed at the top of the document window when the tool is selected. For 
example you can set the thickness of a parallel line before drawing it.

Drawing basic lines
MacDraft has two types of line tools: constrained and unconstrained. The 
constrained line tools are used to draw straight lines that snap to specified angle 
increments; the unconstrained line tool is used to draw straight lines at any angle.

Constrained lines can be drawn at increments of 5°, 15°, 30°, 45° and 90°

.

Top Tip: The drawing of the lines can be snapped to existing objects using the 
smart snap system. You can also snap to the end point, center point and mid point of 
objects by holding the E, C or M key down on the keyboard, while drawing.

Choosing line tools

Line tools are chosen from the Line tools pop-up menu in the Drafting Tools 
panel/palette.
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To choose a line tool

1.	 Hold down the mouse button on the line icon on the Tool panel.

The Line tools pop-up menu appears.

2.	 Drag until the line you want is highlighted, and release the mouse button.

The tool you choose appears on the Tool panel.

Top Tip: Press the "l" key on the keyboard to cycle through the line tools quickly. 
This is a faster way of selecting the individual line tools.

Drawing unconstrained lines

To draw an unconstrained line

1.	 Click the Unconstrained line tool in the Drafting Tools panel/palette. (If the 
Unconstrained line tool is not visible, select it from the Line pop-up menu.)

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Holding down the mouse button, drag in any direction until the line is the 
length you want and release the mouse button.

Note: If you hold the Shift key down while drawing the line will constrain to 
drawing a 45 degree angle.
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To draw an unconstrained line to a specific length

1.	 Click the Unconstrained line tool in the Drafting Tools panel/palette. (If the 
Unconstrained line tool is not visible, select it from the Line pop-up menu.)

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the length and angle of the line and click the OK button

The line will be drawn to the specified length and angle.

Note: To enter a length before drawing a line you need to have the Simple Click 
Does option in the Application Defaults set to Start Drawing Object.

Drawing constrained lines

To draw a constrained line

1.	 Choose the line tool showing the desired angle of constraint from the Line 
pop-up menu in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.
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3.	 Holding down the mouse button, drag until the line is the length you want 
and release the mouse button.

4.	 The line will be drawn at the angle specified. The diagram below shows a 
line constrained to 45 ̊.

Note: If you hold the Shift key while you draw using a constrained line tool, the 
line can be drawn at any angle (unconstrained).

To draw a constrained line to a specific length

1.	 Choose the line tool showing the desired angle of constraint from the Line 
pop-up menu in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the length and angle of the line and click the OK button

The line will be drawn to the specified length and angle.

Note: To enter a length before drawing a line you need to have the Simple Click 
Does option in the Application Defaults set to Start Drawing Object.

Changing the length of a line

It is easy to edit a line to change its length.
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To change the length of a line graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the line you want to change.

3.	 Position the tip of the pointer on one of the line’s handles.

4.	 Holding down the mouse button, drag until the line is the length you want 
and release the mouse button.

Top Tip: If you are editing a constrained line, you can hold the Shift key down 
while dragging the handle to maintain the angle it was drawn at.

To change the length of a line numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Tool panel/
palette.

2.	 Select the line you want to change.

3.	 Go to the Properties tab in the right hand panel or Properties Palette

4.	 Enter the length and angle in the Parameters section of the Resize Options 
in the Properties panel/palette. 

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type 30mm into the resize fields to resize the line. 
The smart unit system will convert the value for you.
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Snap to Grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or resize a line, the end of the line will snap 
to the nearest grid intersection point. Return to the pointer mode by clicking the 
Pointer tool in the Drafting Tools panel/palette.

•	 Hold down the Command key when drawing or resizing a line to avoid the 
line snapping to the grid.

•	 Hold down the Option key when drawing a line and the line length will 
increase in grid increment steps.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw an unconstrained line, it will 
snap to the angular grid.

•	 Hold down the Shift key when drawing an unconstrained line to avoid the 
line snapping to the angular grid.

Drawing rectangles
Rectangles can be drawn with square or rounded corners.

Square-corner rectangles

Square-corner rectangles can be drawn in two ways: from the corner (Diagonal) 
or from the center (Centered).

Choosing the square-corner rectangle tool

To choose a square-corner rectangle tool:

•	 Select the Square-corner rectangle tool in the Drafting Tools panel/palette.



68Chapter 2 Creating and editing objects

Drawing a square-corner rectangle from its corner

When you drawing a square-corner rectangle diagonally, you choose the position 
of one corner of the rectangle, then drag out the rest of the rectangle from that 
corner point.

To draw a rectangle from its corner

1.	 Choose the Square-corner rectangle tool from the Drafting Tools panel/
palette.

2.	 Position the cursor where you want one corner of the rectangle to appear on 
the drawing.

3.	 Press the mouse button.

4.	 Drag in any direction until the rectangle is the desired size, then click the 
mouse button to finish.

Note: If you hold the Shift key down while drawing a rectangle, it will be restricted 
to a square.

Drawing a square-corner rectangle from its center

When you draw a square-corner rectangle from its center, you center the 
rectangle round a specified point on the drawing.

To draw a rectangle from its center

1.	 Choose the Square-corner rectangle tool from the Drafting Tools panel/
palette.
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2.	 Position the cursor where you want the center of the rectangle to appear on 
the drawing.

3.	 Hold down the Option (alt) key on the keyboard and press the mouse button 
Drag in any direction until the rectangle is the desired size and click the 
mouse button to finish.

Note: Hold the Shift key down while drawing and it will be restricted to a square.

Drawing a square-corner rectangle to a specific size

1.	 Click the Rectangle tool in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the size of the rectangle and click the OK button

The rectangle will be drawn to the specified size.

Note: To enter a size before drawing a rectangle you need to have the Simple Click 
Does option in the Application Defaults set to Start Drawing Object.

Changing the size of a square-cornered rectangle

It is easy to edit a rectangle to change its size.

To change the size of a rectangle graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
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panel/palette.

2.	 Select the rectangle you want to resize.

3.	 Position the tip of the pointer on one of the edit handles.

4.	 Holding down the mouse button, drag until the rectangle is the size you want 
and release the mouse button.

The rectangle will be resized either diagonally or by its center, depending on 
the if you hold the Option (alt) key down while resizing.

Note: Hold down the Shift key and resize a rectangle using one of the corner edit 
handles and it will be restricted to its original proportions.

To change the size of a rectangle numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the rectangle you want to change.

3.	 Go to the Properties tab in the right hand panel/ Properties palette. 

4.	 Enter the size in the Parameters section of the Resize Options.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.
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Snap to Grid

If there is a snapping grid set for the document (using the Layout menu, and 
the Set Grid option), when you draw or resize a rectangle, the corners of the 
rectangle will snap to the nearest grid intersection points.

Hold down the Command key when drawing or resizing a rectangle to avoid the 
corners snapping to the grid.

Rounded-corner rectangles

Rounded-corner rectangles can be drawn with proportional (P), constant (C) or 
elliptical (E) corners. The type of rounded-corner rectangle you choose to draw 
will be determined by the way you wish the size and shape of the corners to 
change when you edit the rectangle.

•	 Rounded-corner rectangles with proportional (P) corners

When you resize a rounded-corner rectangle with proportional corners, the 
radius of the corners will remain proportional to the size of the rectangle as 
shown below.

•	 Rounded-corner rectangles with elliptical (E) corners

When you draw a rectangle with elliptical corners, the major and minor axes 
of the elliptical arcs that form the corners are determined by the size of the 

•	 Rounded-corner rectangles with constant (C) corners

When you resize a rounded-corner rectangle with constant corners, the 
corners will always have the same radius regardless of the size of the 
rectangle.
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rectangle; the size of the elliptical arcs on the corners grows or shrinks in 
proportion to the rectangle’s size.

Choosing a rounded-corner rectangle tool

Choose the desired tool from the Rounded-corner rectangle pop-up menu. To 
choose the Rounded-corner rectangle tool:

1.	 Click the Rounded-corner rectangle tool in the Drafting Tools panel/
palette and hold down the mouse button.

The Rounded-corner rectangle pop-up menu appears.

2.	 Holding down the mouse button, drag through the menu until the tool you 
want is highlighted, and release the mouse button.

The icon representing the tool you selected (P for proportional, C for 
constant, or E for elliptical) appears on the panel.

Drawing a rounded-corner rectangle

All the rounded-corner rectangles are drawn in the same way.

To draw a rectangle with the chosen corner style

1.	 Choose the desired tool from the Rounded-corner rectangle pop-up menu. 

2.	 Position the cursor at the point you want the first corner of the rectangle to 
appear on your drawing.
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Note: As the rectangle has rounded-corners this point will determine the corner 
position for the rectangle’s bounding frame.

3.	 Press the mouse button.

4.	 Drag in any direction until the rectangle is the desired size and click the 
mouse button to finish.

Note: Hold down the Shift key as you draw a rounded-corner rectangle and the 
shape of the rectangle will be restricted to a rounded-corner square.

Drawing a rounded-corner rectangle to a specific size

1.	 Click the Rounded-Rectangle tool in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear
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Changing the size of rounded-corner rectangles  

Rounded-corner rectangles can be resized in the same way as square-corner 
rectangles.

Changing the corner shape of rounded-corner rectangles

When you select a rounded-corner rectangle, an extra edit handle called the 
corner-edit handle appears, normally inside and near the upper left corner.

This edit handle is used to change the shape of the corners.

To change the corner shape of proportional and constant-corner rectangles

With proportional and constant-corner rectangles, you can drag the corner-edit 
handle in a diagonal direction to change the radius of the corner arc and reshape 
the rectangle.

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the rectangle you want to change.

3.	 Position the tip of the pointer on the corner-edit handle.

4.	 Hold down the mouse button and drag in one of the following directions:

•	 Drag downwards to the right to increase the radius of the corners.

•	 Drag upwards to the left to decrease the radius of the corners.

4.	 Enter the size of the rectangle and click the OK button

The rectangle will be drawn to the specified size.

Note: To enter a size before drawing a rectangle you need to have the Simple Click 
Does option in the Application Defaults set to Start Drawing Object.
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5.	 When the corners are the desired shape, release the mouse button.

To change the corner shape of elliptical-corner rectangles

When you draw a rectangle with elliptical corners, the elliptical arcs at the 
corners cover 90°. By dragging the corner-edit handle, you can change the radius 
of the arcs to change the shape of the corners. The arcs will still cover 90°.

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the elliptical-corner rectangle you want to change.

3.	 Position the tip of the pointer on the corner-edit handle.

4.	 Holding down the mouse button, drag until the corners are the shape you 
want and release the mouse button.

Unlike other rectangles with rounded corners, you can drag the corner-edit 
handle on elliptical-corner rectangles in any direction. The direction in which 
you drag the handle determines the shape of the corners. The figure below 
shows how you can use the corner-edit handle to reshape the corners.

•	 If you drag the handle to the extreme upper left corner, the corners 
appear almost square.

•	 If you drag the handle to the center, the entire rectangle appears as an 
ellipse.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and 
the Set Grid option), when you draw or resize a rectangle, the corners of the 
rectangle will snap to the nearest grid intersection points.

Hold down the Command key when drawing or editing a rectangle to avoid the 
edit handles snapping to the grid.
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Drawing regular polygons
A regular polygon is a closed object with equal sides and angles of equal length. 
The tools can be preset to draw shapes with from 3 to 64 sides. Depending on 
which regular polygon tool you select, you can draw a regular polygon from edge 
to edge, center to edge, vertex to vertex, or center to vertex.

Choosing a regular polygon tool

Choose the desired tool from the Regular polygon tool pop-up menu.

To choose a regular polygon tool

1.	 Click the Regular polygon tool in the Drafting Tools panel/palette and hold 
down the mouse button.

The Regular polygon tool pop-up menu appears.

2.	 Hold down the mouse button, drag through the menu until the tool you want 
is highlighted, and release the mouse button.

The icon representing the tool you selected appears on the panel.

Top Tip: Press the "p" key on the keyboard to cycle through the regular polygon 
tools quickly. This is faster way of selecting the individual regular polygon tools.

Setting the number of sides

The number of sides can be set before drawing the object.

To set the number of sides before drawing a regular polygon
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1.	 Select the regular polygon tool you want to use.

2.	 The Regular polygon tool options appear in a panel at the top of the 
document.

3.	 Enter the number of sides desired, then press the OK button.

Drawing a regular polygon

Drawing a regular polygon from edge or vertex

1.	 Choose the desired tool from the Regular Polygon pop-up menu.

2.	 According to the tool chosen, position the cursor at the point you want the 
edge or vertex of the polygon to appear on your drawing.

3.	 Click the mouse button, drag until the polygon is the desired size and release 
the mouse button to finish.

Top Tip: When you release the mouse button, the polygon is drawn as a single 
grouped object. If necessary, use the Ungroup command in the Arrange menu to 
ungroup the polygon for reshaping, breaking into separate items and so
on. Changing fills and line attributes and resizing can be performed while the object 
is still grouped.

Drawing a regular polygon from center

When you draw a regular polygon from its center, you center the rectangle round 
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a specified point on the drawing.

To draw a regular polygon from its center

1.	 Choose the Regular Polygon tool from the Drafting Tools panel/palette.

2.	 Position the cursor where you want the center of the regular polygon to 
appear on the drawing.

3.	 Hold down the Option (alt) key on the keyboard and press the mouse button.

4.	 Drag in any direction until the regular polygon is the desired size and release 
the mouse button to finish.

Note: Hold down the Shift key while drawing a regular polygon, and the angle of 
the diameter or radius of the polygon will snap to 45° increments.

Drawing a regular polygon to a specific size

1.	 Choose the Regular Polygon tool in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the size of the regular polygon and click the OK button

The regular polygon will be drawn to the specified size.

Note: To enter a size for drawing a regular polygon you need to have the Simple 
Click Does option in the Application Defaults set to Start Drawing Object.

Changing the size of a regular polygon

It is easy to edit a regular polygon to change its size.
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To change the size of a regular polygon graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the regular polygon to resize.

3.	 Position the tip of the pointer on one of the edit handles.

4.	 Holding down the mouse button, drag until the regular polygon is the size 
you want and release the mouse button.

To change the size of a regular polygon numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the regular polygon you want to change.

3.	 Go to the Properties tab in the right hand panel or Properties palette. 

4.	 Enter the size in the Parameters section of the Resize Options.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Note: Resize a regular polygon using one of the corner edit handles and it will be 
restricted to its original proportions.
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Snap to Grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or resize a regular polygon, the cursor will 
snap to the nearest grid intersection point.

•	 Hold down the Command key when drawing or editing a regular polygon to 
avoid the cursor snapping to the grid.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw a regular polygon, its diameter 
or radius will snap to the angular grid.

•	 Hold down the Shift key when drawing a regular polygon to avoid its 
diameter or radius snapping to the angular grid.

Drawing circles
You can draw a circle by its diameter (D), by its radius (R), by three points (3) or 
concentric to an existing circle.

Choosing Circle Tools

Choose how you want to draw circles by selecting one of the tools in the Circle 
pop-up menu.

To choose a circle tool

1.	 Click the Circle icon in the Drafting Tools panel/palette and hold down the 
mouse button.

The Circle pop-up menu appears.
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2.	 Holding down the mouse button, drag through the menu until the option you 
want is highlighted and release the mouse button.        

The tool you selected appears in the Tool panel.

Top Tip: Press the "c" key on the keyboard to cycle through the circle tools quickly. 
This is a faster way of selecting the individual circle tools.

Drawing a circle by diameter

To draw a circle by diameter

1.	 Choose Diameter from the Circle pop-up menu.

2.	 Position the cursor at the point you want to begin drawing the circle.

3.	 Click the mouse button, drag until the circle is the size you want, and release 
the mouse button to finish.

Note: Hold down the Shift key while drawing a circle by diameter and the diameter 
will be restricted to 45° increments.

To draw a circle by diameter to a specific size

1.	 Choose the Circle by diameter tool in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear
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4.	 Enter the diameter of the circle and click the OK button

The circle will be drawn to the specified diameter.

Note: To enter a size for drawing a circle you need to have the Simple Click Does 
option in the Application Defaults set to Start Drawing Object.

Drawing a circle by radius

To draw a circle by radius

1.	 Choose Radius from the Circle pop-up menu.

2.	 Position the cursor at the point you want the center of the circle to be on your 
drawing.

3.	 Click the mouse button, drag until the circle is the size you want, and click 
the mouse button to finish.

Note: Hold down the Shift key while drawing a circle by radius and the radius will 
be restricted to 45° increments.

To draw a circle by radius to a specific size

1.	 Choose the Circle by radius tool in the Tool panel.
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2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the radius of the circle and click the OK button

The circle will be drawn to the specified radius.

Note: To enter a size for drawing a circle you need to have the Simple Click Does 
option in the Application Defaults set to Start Drawing Object.

Changing the size of a circle drawn by diameter or radius

After you have drawn a circle by diameter or radius, you can change its size by 
dragging one of its edit handles.

To change the size of a circle drawn by diameter or radius graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the circle you want to change.

3.	 Position the tip of the pointer on one of its handles.

4.	 Press and hold down the mouse button, drag the handle until the circle is the 
desired size, and release the mouse button.

The circle will be resized either by diameter or by radius, depending on the 
tool originally used to draw it.
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To change the size of a circle drawn by diameter or radius numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the circle you want to change.

3.	 Go to the Properties tab in the right hand panel / Properties palette. 

4.	 Enter the size in the Parameters section of the Resize Options.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 

Drawing a circle by three points

Use the Circle by three points tool to draw a circle that passes through three 
specific points on your drawing.

To draw a circle by three points

1.	 Choose the Circle by three points tool from the Circle pop-up menu in the 
Tool panel.

2.	 Position the cursor on the first point through which you want the circle to 
pass and click the mouse button.

3.	 Move to the second point through which you want the circle to pass and click 
the mouse button.

4.	 Move the cursor to the third point through which you want the circle to pass 
and click this point.
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Three edit handles appear on the circle. The edit handles correspond to the 
three points used to define it.

Changing the size of a circle drawn by three points

You can change the size of a circle drawn by three points by moving its edit 
handles.

To change the size of a circle drawn by three points graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the circle you want to resize.

3.	 Position the cursor on one of the edit handles.

4.	 Press and hold down the mouse button.

5.	 Drag until the circle is the size you want and release the mouse button.

The circle will be redrawn to pass through the three points represented by the 
edit handles.

To change the size of a circle drawn by three points numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the circle you want to change.

3.	 Go to the Properties tab in the right hand panel / Properties palette.

4.	 Enter the sizes in the Parameters section of the Resize Options.
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Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to Grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or resize a circle drawn by three points, the edit 
handles will snap to the nearest grid intersection point.

Hold down the Command key when drawing or editing a circle to avoid the edit 
handles snapping to the grid.

Drawing concentric circles

With MacDraft’s Concentric circle tool, you can create new circles concentric 
to existing circles (sometimes called offset circles). The concentric circle will be 
of the same type and have the same line weight, line style and pen model as the 
original circle.

Concentric circles can be drawn in relation to any existing circle. Once drawn, a 
concentric circle is an independent circle that can be edited, moved or changed as 
required.

Note: The parent circle for the concentric circle must be in place before you choose 
the concentric circle tool.

To draw a concentric circle

Drawing a concentric circle from an existing circle takes two steps: Selecting the 
parent circle then clicking to specify the distance between the two.

To draw a circle concentric to an existing circle

1.	 Choose the Concentric circle tool from the Circle tools pop-up menu in the 
Drafting Tools panel/palette.
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The cursor will now read ‘Click Circle’, to let you know that you need to 
select a parent circle.

2.	 Click the parent circle.

The cursor will now read ‘Anchor’ and appears near a dotted copy of the 
parent circle to help you judge the distance between them.

3.	 Move the cursor until the concentric circle is the desired diameter, then click 
As you move the cursor, the dotted sketching circle follows it.

The concentric circle is drawn.

The cursor returns to ‘Click Circle’, to let you draw more concentric circles.

4.	 To exit the concentric circle tool, click the Pointer icon on the Drafting 
Tools panel/palette or click the Escape key on your keyboard.
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Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw a concentric circle, the radius of the concentric 
circle will snap to the nearest grid increment.

Drawing Ellipses
MacDraft provides two methods of drawing ellipses: diagonal and centered. The 
two types of ellipses differ in the way you draw and edit the ellipse. The ellipse 
tools are located in on the Drafting Tools panel/palette. When drawn, an ellipse 
has eight edit handles, four on its circumference and four defining its bounding 
rectangle.

Choosing an ellipse tool
To choose an ellipse tool

•	 Click the Ellipse tool in the Drafting Tools panel/palette.

Drawing an ellipse

To draw an ellipse click a starting point and drag until the ellipse is the desired 
size and shape then release the mouse. 

To draw a diagonal ellipse:

1.	 Choose the Ellipse tool from the Drafting Tools panel/palette.

2.	 Click the point you want a corner of the ellipse’s bounding rectangle to 
appear on your drawing.

3.	 Drag in a diagonal direction until the ellipse is the desired size, and click the 
mouse button to finish.
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Note: Hold down the Shift key as you draw an ellipse and the shape of the ellipse 
will be restricted to a circle.

To draw a centered ellipse:

1.	 Choose the Ellipse tool from the Drafting Tools panel/palette.

2.	 Position the cursor where you want the center of the ellipse to appear on the 
drawing.

3.	 Hold down the Option (alt) key on the keyboard and press the mouse button.

4.	 Drag in any direction until the ellipse is the desired size and click the mouse 
button to finish.

Note: Hold down the Shift key as you draw an ellipse and the shape of the ellipse 
will be restricted to a circle.

To draw an ellipse to a specific size

1.	 Choose the Ellipse tool in the Drafting Tools panel/palette.

2.	 Position the cursor at the point on the drawing that you want to start drawing.

3.	 Double click the mouse button.

The size dialog will appear

4.	 Enter the width and height of the ellipse and click the OK button

The ellipse will be drawn to the specified size.
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Changing the size of an ellipse

You change the size of an ellipse by dragging one of its eight edit handles.

To change the size of an ellipse graphically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the ellipse you want to resize.

3.	 Position the tip of the pointer on one of the edit handles, then press and hold 
down the mouse button.

4.	 Holding down the mouse button, drag the handle until the ellipse is the size 
you want, and release the mouse button.

Note: Hold down the Shift key and resize an ellipse using one of the corner edit 
handles and it will be restricted to its original proportions.

To change the size of an ellipse numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the ellipse you want to change.

3.	 Go to the Properties tab in the right hand panel/properties palette. 

4.	 Enter the sizes in the Parameters section of the Resize & Position.
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Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or resize an ellipse, the edit handles will snap 
to the nearest grid intersection point.

Hold down the Command key when drawing or editing an ellipse to avoid the 
edit handles snapping to the grid.

Drawing Arcs
You can draw circular and elliptical arcs; circular arcs can be drawn by radius or 
by three points. You can also draw arcs concentric to existing circular arcs.

Top Tip: When an arc is drawn with a fill, it appears as an object shaped like a 
piece of pie. To draw only the arc line, make sure that no objects are selected, then 
choose no fill from the Fill Color submenu, Fill Gradient and Fill Pattern submenu 
before you draw the arc.

Choosing an arc tool

Choose the arc tool required from the Arc pop-up menu in the Drafting Tools 
panel/palette.

To choose an arc tool

1.	 Click the Arc tool in the Drafting Tools panel/palette and hold down the 
mouse button.

The Arc pop-up menu appears.
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2.	 Holding down the mouse button, drag through the menu until the desired tool 
is highlighted, and release the mouse button.

The icon representing the tool chosen appears in the Drafting Tools panel/
palette.

Arc by Radius

Drawing an arc by radius

To draw an arc by radius, first define a radius, then project the arc the desired 
number of degrees around a circle.

To draw an arc by its radius

1.	 Choose Arc by radius from the Arc pop-up menu in the Drafting Tools 
panel/palette.

2.	 Position the cursor where you want to begin the radius of the arc, then click 
the mouse button.

3.	 Drag in any direction to draw a line that represents the radius of the arc. A 
ghosted circle will appear to represent the circle radius.  
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4.	 Click the mouse button again to place the first arc point.

5.	 Move the cursor away from the end of the radius line until you have created 
an arc of the desired number of degrees and click to place the arc end point.

Note: If you drag outside the border of the arc, a line extending from the arc’s 
border to the cursor will be drawn. This line allows you to align the ending point 
of the arc with other points on your drawing. Also hold down the Shift key while 
defining the arc’s radius to restrict the radius to an angle of increments of 45°.

Changing the radius of an arc drawn by radius graphically

To change the radius

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the arc you want to change.

3.	 Position the tip of the pointer on the edit handle in the middle of the arc’s 
border, then press and hold down the mouse button.

4.	 Drag until the radius is the length you want and release the mouse button.
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Changing the length of an arc drawn by radius graphically

To change the length

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the arc you want to change.

3.	 Position the tip of the pointer on one of the handles at either end of the arc, 
then press and hold down the mouse button.

4.	 Drag until the arc is the length you want, then release the mouse button.

Note: You cannot create a complete circle using the arc tool. If you drag past the 
beginning of the arc, it will collapse back to a shorter length.

To change the size of an arc numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the arc you want to change.

3.	 Go to the Properties tab in the right hand panel/ properties palette. 

4.	 Enter the sizes in the Parameters section of Resize & Position.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw an arc by radius, the cursor will snap to the 
nearest grid intersection point.

•	 Hold down the Command key when drawing or resizing an arc drawn by 
radius to avoid the cursor snapping to the grid.

If there is an angular snapping grid set for the document (using the Layout menu, 
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and the Set Angle Snap option), when you draw or edit an arc by radius, the 
radius line will snap to the angular grid.

•	 Hold down the Shift key when drawing or editing an arc by radius to avoid 
the radius line snapping to the angular grid.

Arc by three points

Drawing an arc by three points

When drawing an arc by three points, you specify three points on the drawing 
through which you want the arc to pass. This tool is useful when you do not 
know the length of the radius of an arc, but do know that the arc should pass 
through three different points in a drawing.

To draw an arc by three points 

1.	 Choose Arc by 3 points from the Arc pop-up menu in the Drafting Tools 
panel/palette.

2.	 Position the cursor on the first point through which you want the arc to pass, 
then click the mouse button.

3.	 Move to the second point through which you want the arc to pass. 

4.	 Click the mouse button.

5.	 Move the cursor to the third point through which you want the arc to pass, 
and click this point.

Note: You cannot create a complete circle by using the arc tool. If you drag past the 
beginning of the arc, it will collapse back to a shorter length.

Changing the size of an arc drawn by three points graphically

You can change the size of an arc drawn by three points by moving any one of 
the three handles that represent the three points originally used to define the arc.

To change the size of an arc drawn by three points

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.
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2.	 Select the arc you want to resize.

3.	 Position the tip of the pointer on the edit handle you want to move, then press 
and hold down the mouse button. 

4.	 Drag the handle to a new location on the drawing.

5.	 Release the mouse button.

To change the size of an arc by 3 points numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the arc you want to change.

3.	 Go to the Properties tab in the right hand panel/properties palette. 

4.	 Enter the sizes in the Parameters section of Resize & Position.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Elliptical Arcs

Drawing an elliptical arc
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You can use the Elliptical Arc tool to create elliptical arcs of a specific size and 
length. When you create an elliptical arc, you define an ellipse, then project an 
arc that is a portion of the ellipse. The actual size of the arc is determined by the 
size of the ellipse and the arc’s length is determined by the number of degrees 
you project it during creation.

To draw an elliptical arc

1.	 Choose Elliptical arc from the Arc pop-up menu in the Drafting Tools 
panel/palette.

2.	 Position the cursor on the point to be used as the center point for the ellipse 
that will be used to define the arc, then click the mouse button.

3.	 Drag until you have created an ellipse that is the size and shape you want, 
and click the mouse button.

4.	 Move the cursor until you have projected an arc that is the length you want 
and click this point.

Note: A line will extend from the center of the ellipse to the cursor. This is used to 
de ne the ending angle of the arc. If you drag outside the ellipse, the line will extend 
past the ellipse’s border; this allows you to align the ending angle of the arc with 
other points on your drawing.
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The elliptical arc will be drawn.

Changing the starting angle of an elliptical arc

Part of the process of defining elliptical arcs involves defining the starting angle 
of the arc. The starting angle of the elliptical arc is determined by the position 
of the cursor when you release the mouse button after defining the initial ellipse, 
however, by using the Shift key to constrain the size of the ellipse, you can 
change the position of the starting angle without changing the size of the ellipse.

To change the starting angle of the arc

1.	 Choose Elliptical arc from the Arc pop-up menu in the Drafting Tools 
panel/palette.

2.	 Position the cursor on the point to be used as the center point for the ellipse 
that will be used to define the arc, then click the mouse button.

3.	 Drag until you have created an ellipse that is the size and shape you want, 
then hold down the Shift key.

4.	 Drag the line that marks the starting angle to a new position.

5.	 The line marking the starting angle of the arc will follow the cursor’s 
movement, but the ellipse will not be resized.

6.	 Click the mouse button and the Shift key when the line is in the desired 
position for the starting angle of the arc.

7.	 Move the cursor until you have projected an arc that is the length you want, 
then click this place.

Editing an elliptical arc

There are two ways you can edit an elliptical arc: you can change its shape and 
you can change its length. When you change its shape, you change the major 
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and minor axes of the arc. When you change its length, you either increase or 
decrease the number of degrees the arc is projected.

Changing the shape of an elliptical arc

You can change the arc’s shape, without moving its end points, by dragging the 
edit handle in the middle of the arc’s border.

To change the shape of an elliptical arc

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the elliptical arc you want to change.

3.	 Position the tip of the pointer on the edit handle located in the center of the 
arc’s border, then press and hold down the mouse button.

4.	 Drag until the arc is the shape you want, and release the mouse button.

Changing the length of an elliptical arc

You can use the edit handles on the end points of an elliptical arc to change its 
length.

To change the length of an elliptical arc:

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the arc you want to change.

3.	 Position the tip of the pointer on one of the handles at either end of the arc, 
then press and hold down the mouse button.

4.	 Drag until the arc is the length you want, and release the mouse button.
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To change the size of an elliptical arc numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the arc you want to change.

3.	 Go to the Properties tab in the right hand panel/ properties palette. 

4.	 Enter the sizes in the Parameters section of Resize & Position.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw an elliptical arc, the cursor will snap to the 
nearest grid intersection point.

•	 Hold down the Command key when drawing or resizing an elliptical arc to 
avoid the cursor snapping to the grid.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw or edit an elliptical arc, the line 
of the ending angle will snap to the angular grid.

•	 Hold down the Shift key when drawing or editing an elliptical arc to avoid 
the line of the ending angle snapping to the angular grid.

Concentric arcs

Using the Concentric arc tool you can create new arcs that are concentric to 
existing circular arcs. The concentric arc will be the same type (radial or three-
point) and have the same line weight, line style and pen model as the original arc.

Concentric arcs can be created from any circular arc. Once drawn, a concentric 
arc is an independent object that can be edited, moved or otherwise manipulated 
as required.
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Note: The “parent” arc for the concentric arc must be in place before you choose 
the Concentric arc tool.

Drawing a concentric arc

Drawing a concentric arc requires two steps: selecting the source arc and 
specifying the offset distance.

To draw an arc concentric to an existing arc

1.	 Choose the Concentric arc tool from the Arc pop-up menu.

The cursor now reads “Click Arc”, to let you know to select an arc.

2.	 Click the source arc.

The cursor now reads “Anchor” and appears near a ghosted copy of the 
source arc, which helps you to position the concentric arc.

3.	 Move the cursor until the concentric arc is in the desired position.

As you move the cursor, the ‘ghost’ arc gets larger or smaller.

Once the concentric arc is drawn. The cursor returns to “Click Arc”, allowing 
you to create more concentric arcs if desired.
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Note: To exit the Concentric arc tool, click the Pointer icon in the Tool panel or 
press the Escape key on the keyboard. Also note that concentric arcs once drawn 
can be editing graphically or numerically using in the same way as normal arcs.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw a concentric arc, the radius of the arc will snap 
to the nearest grid increment.

To change the increment, choose a different value from the Layout menu’s Set 
Grid submenu.

Drawing irregular polygons and polylines
You can draw two types of multi sided irregular shapes: closed polygons and 
open polylines. Drawing irregular polygons and polylines is discussed in this 
section.

A polygon is a closed object made of three or more sides. It can be a complex, 
irregularly shaped object made up of many straight line segments. A polyline is 
an open object made of at least two straight line segments. The line segments 
used for either type of object can be of any length and drawn at any angle.

Choosing polygon tools

The type of multisided shape you can draw depends on the tool you choose from 
the Drafting Tools panel/palette.

To choose a polygon tool

•	 Click the Polygon tool you want to use in the Drafting Tools panel/palette.
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Drawing an irregular polygon or polyline

To draw an irregular polygon or polyline, you position the cursor and click to 
define the end points of the lines that make up the shape.

To draw an irregular polygon or a polyline

1.	 Choose the Irregular polygon or Polyline tool from the Drafting Tools 
panel/palette.

2.	 Place the cursor at the point you want to begin drawing the object, then click 
the mouse button.

3.	 Move until you have created a line that is the desired length and angle for the 
first side or line segment of the object.

4.	 Click the mouse button.

5.	 Move the cursor to draw the second line segment.

6.	 When the second line is the desired length and angle, click this point.

7.	 Move the cursor to draw the next line segment.
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8.	 When the line is the desired length and angle, click the mouse.

You may decide that you want to change a line segment after you have drawn 
it. You can change the length and orientation of the last line segment drawn 
by using the dynamic Editing feature.

9.	 To change the last line segment drawn, move the cursor back to the last 
defined point and click it.

The previous line will reattach to the cursor, allowing you to move the end of 
the line to a new position on the drawing.

10.	 Move the cursor to a new position on the drawing and click it.

The line will be drawn to the new position. 

11.	 Continue to draw the rest of the object.

Note: You can also press the Backspace (Delete) key to delete he last point placed.

12.	 When you reach the last point to be placed, double-click the point.

This double-click action completes the object.

•	 If you are drawing an irregular polygon, the last point you clicked will be 
connected to the starting point of the shape by a straight line.

•	 If you are drawing a polyline, the object remains open.
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Note: Hold down the Shift key while drawing an irregular polygon or polyline and
the angle of the current line segment will snap to increments of 45°.
The final point of a polyline can be snapped to the mid point, end point or center 
point of some existing objects by holding the C, M and E keys or by using the 
Smart Snap feature.

Changing the shape of an irregular polygon or a polyline

Irregular polygons and polylines, like other objects, have handles when they are 
selected. Unlike most objects, they have two different kinds of handles: major 
(the handles on the vertex points or corners) and minor (the handles at the mid 
points of the line segments).

A major handle is used to move the end point of a line, which could change both 
the length and angle of the lines connected at that handle. A minor handle is used 
to move a line segment without changing its length or angle.

Changing the shape using the major handles

To change the shape using the major handles

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the irregular polygon or polyline you want to change.

3.	 Position the tip of the pointer on one of the major handles, then press and 
hold down the mouse button.

4.	 Drag the handle to a new location on the drawing, and release the mouse 
button.

When you move the handle, the connecting lines will follow. As soon as you 
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release the mouse button, both lines will be redrawn according to the new 
handle location.

Changing the shape using the minor handles

To change the shape using the major handles

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the irregular polygon or polyline you want to change.

3.	 Position the tip of the pointer on one of the minor handles, then press and 
hold down the mouse button.

4.	 Drag the handle to a new location on the drawing, and release the mouse 
button.

As you drag the minor handle, the line moves, but its length and angle 
remain the same.

Changing the shape numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the irregular polygon or polyline you want to change.

3.	 Go to the Properties tab in the right hand panel/ properties palette.

4.	 Click the Select Point button below the Parameters section of the Resize 
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& Position Options and click one of the points on the irregular polygon or 
polyline.

5.	 Enter the sizes in the Parameters section of the Resize & Position Options.

Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and 
the Set Grid option), when you draw or edit an irregular polygon or polyline, 
the ends of the line segments or the edit handles will snap to the nearest grid 
intersection points.

•	 Hold down the Command key when drawing or editing an irregular polygon 
or polyline to avoid the lines or edit handles snapping to the grid.

•	 Hold down the Option key when drawing an irregular polygon or polyline 
and the line lengths will snap to the nearest grid increment.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw an irregular polygon or polyline, 
the line segments will snap to the angular grid.

•	 Hold down the Shift key when drawing an irregular polygon or polyline to 
avoid the line segments snapping to the angular grid.

Drawing freehand lines, shapes and curves
At times you may want to draw an object that has a different shape to those 
provided for you in the Drafting Tools panel/palette. For this reason, five 
freehand drawing tools are provided: Smooth Freehand lines, Polygonal 
Freehand lines, Freehand shapes, Bezier curves and Spline curves.

•	 The Smooth Freehand lines tool is used to draw open freehand objects with 
smooth curves.
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•	 The Polygonal Freehand lines tool is used to draw open freehand objects 
with small straight lines. 

•	 The Freehand shape tool is used to draw closed freehand objects.

•	 The Bezier curve tool is used to draw curves that are defined by four control 
points. The curve passes through only two of the control points, the other two 
control points are used to define the shape of the curve.

•	 The Spline curve tool is used to draw curves that are fitted to a series of 
defined points on your drawing. The curve passes through all the defined (or 
control) points.

Choosing a freehand drawing tool

Draw either an open freehand line (smooth or polygonal), a closed freehand 
shape, a Bezier curve or a spline curve by choosing the appropriate tool from the 
Drafting Tools panel/palette.

To choose a freehand drawing tool

•	 Click the Freehand drawing tool you want to use in the Tool panel.

Freehand lines or shapes

Drawing a freehand line or shape 

To draw a freehand line or shape

1.	 Choose the Smooth Freehand line, Polygonal Freehand line, or Freehand 
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shape tool from the Drafting Tools panel/palette.

2.	 Position the cursor at the point you want to begin drawing, then press and 
hold down the mouse button.

3.	 Drag the cursor in any direction, creating a line just as you would with a 
pencil.

4.	 When you have completed the smooth freehand line, polygonal freehand line  
or freehand shape, release the mouse button.

•	 If you are using the Smooth or Polygonal Freehand line tool the object 
remains open.

•	 If you are using the Freehand shape tool, the start and end points of 
your freehand line will be automatically joined by a straight line.

Correcting a freehand line or shape while drawing

When you are using the Smooth or Polygonal Freehand line or the Freehand 
shape tool, you can erase portions of the line that you are drawing by using the 
Shift key.

To correct a freehand line

1.	 When you have made an error while drawing a freehand line, continue to 
hold down the mouse button, but stop drawing the line by ceasing to move 
the mouse.

2.	 Press and hold down the Shift key.

An icon of an with eraser appears at the end of your freehand line.

3.	 Using the mouse to move the eraser, retrace the portion of the line that you 
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want to delete. The line will be erased.

4.	 Release the Shift key to continue drawing the object.

Drawing a straight line as part of a freehand object

The constrained drawing mode for a freehand tool allows you to draw straight 
line segments as part of a freehand object.

To draw a straight line as part of a freehand object

1.	 Start drawing an object using the Polygonal Freehand line or Freehand 
shape tool.

2.	 When you want to draw a straight line, hold down the Option key and drag 
the cursor in any direction until you have created a straight line that is the 
required length.

3.	 Release the Option key.

Changing the shape of a freehand object

You can drag the edit handles of a freehand object to change its shape.

To change the shape of a freehand object

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.
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2.	 Select the freehand object you want to change by clicking it.

3.	 Position the tip of the pointer on one of its edit handles, then press and hold 
down the mouse button.

4.	 Drag the handle until you have created the shape you want, and release the 
mouse button.

5.	 Continue to move other edit handles in the same way until you have obtained 
the shape you want.

Bezier curves

Drawing using the Bezier curve tool gives you a great deal of flexibility in 
creating original designs that feature elegant shapes and loops.

A Bezier curve is a type of curve defined by four points, called “control points.” 
Two control points define the end points of the curve, the others define the 
direction in which the curve is projected. When you select a Bezier curve, the 
four control points are represented by edit handles on the screen: two handles 
appear on the end points of the curve and two other handles appear on either side 
of the curve.

End Point Handle

End Point Handle

Directional Point Handles

Directional Point Handles
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The two handles on the end points are called “end point handles,” and the other 
two handles are called “direction point handles.” You can move the handles to 
modify and change the size of the Bezier curve.

When you create a Bezier curve, direction lines are used to indicate the slope 
and direction of the curves you draw. A direction line is a line between two 
control points, and is tangent to an end point.

You can draw a series of Bezier curves using the Bezier curve tool. Each 
individual curve actually passes through only the two end control points. The 
direction lines define the overall shape of the curve. When you draw a series of 
curves, the curves are connected at “joints” or end control points that are shared 
by two curves.

Creating Bezier curves

1.	 Choose the Bezier curve tool from the Drafting Tools panel/palette.

2.	 Position the cursor at the point you want the curve to begin, then press and 
hold down the mouse button.

This defines the first end control point of the curve.

3.	 Drag in the direction you want to project the curve.

A line with a handle at either end will be projected, the curve’s start point 
being at the center of the line. This is a direction line. One of the handles will 
be attached to the cursor. By dragging the handle, you indicate the direction 
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and slope of the curve. For example, if you drag the handle down all the way 
to the lower right corner of the screen, a curve sloping toward the lower right 
corner will result.

4.	 Release the mouse button.

The position of the cursor when you release the mouse button defines the first 
direction point.

5.	 Without pressing down the mouse button, move the cursor to the point 
you want the second end control point (the end point of the first curve and 
the start point for a next curve) to be, then press and hold down the mouse 
button. As you move the cursor the curve appears on the screen.

6.	 Holding down the mouse button, drag to define the curve’s second direction 
point (this will also define the first direction point of the next curve).

The first direction point of the next curve is associated with the handle that 
is attached to the cursor. The second direction point of the first curve is 
associated with the handle at the opposite end of the direction line.

The curve’s shape will change as you define the second direction point.

7.	 Release the mouse button.

8.	 To continue drawing curves, repeat steps six and seven above.

9.	 When you are ready to complete the shape

•	 When you have defined the control handle for the curve’s final point, 
double-click to complete the shape or,

•	 Move the mouse to the start point and the cursor will change to show a 
small circle. When that cursor appears, double click to create a closed 
Bezier curve shape.
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Top Tip: You can end a Bezier curve at any time with a curve, simply drag out a 
curve you want to finish with, then hold the Option key down on the keyboard and 
double click the previous point to finish the shape and remove unwanted handles.

Correcting a Bezier curve while drawing

When you are using the Bezier curve tool, you can erase portions of the curve 
that you are drawing by using the Backspace key.

To correct a Bezier curve

•	 When you have made an error while drawing a Bezier curve, press the 
Backspace key.

•	 The previous bezier point will be removed from the curve.

Drawing straight line segments

While drawing Bezier curves, you can draw straight line segments by clicking 
the mouse button instead of dragging the cursor with the mouse button held 
down.

To create a straight line segment

1.	 While drawing a Bezier curve, and after you have drawn at least one 
complete curve, move the cursor and click the new place.

The resulting line will be curved, but the next line will be straight.

2.	 Without pressing and holding down the mouse button, move the cursor to 
where you want the end point of the line to be, then click this point.

3.	 Continue moving the cursor and clicking to create a series of straight lines.

Note: Hold the Shift key down while drawing to constrain to a 45 degree angle.

Modifying Bezier curves

You can modify a Bezier curve by dragging the edit handles. Edit handles appear 
on Bezier curves that are selected. When you move the end point handles, you 
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move the end point of the curve; when you drag a direction handle, it exerts a 
“pull” on the curve closest to it and so changes its shape.

To move the end point of a Bezier curve

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the Bezier curve object you want to change by clicking it. 

Edit handles appear on the selected curve.

3.	 Position the tip of the pointer on one of the handles at either end of the curve, 
then press and hold down the mouse button.

4.	 Drag until the curve is the length you want, and release the mouse button.

To change the shape of a Bezier curve

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the Bezier curve object you want to change by clicking it.

Edit handles appear on the selected curve.

3.	 Position the cursor on one of the direction handles, then press and hold down 
the mouse button.

4.	 Drag until the curve is the shape you want, and release the mouse button. The 
curve will be reshaped to reflect the new position of the direction handle.
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Note: Hold down the Shift key while selecting and moving the direction handle, 
and the direction handle and its opposite direction handle will pivot around the 
point on the curve. This will change the shape of the two curves controlled by those 
two direction control points, and will keep the curve smooth.
If you drag a direction handle for the end point of a straight line segment, you 
reshape the straight line segment, causing it to become curved. You can create 
sharp corners on a Bezier curve by pulling both direction handles to one side or by 
dragging the direction handles of a direction line on top of an end control point.

Top Tip (Pro Version Only): You can add and remove handles on a Bezier curve 
after it has been finished, by using the Add/Remove handles tool in the Advanced 
Tools section of the Tool panel.

Spline curves

You can draw a type of curve that passes through a series of defined points on 
your drawing. This type of curve, called a spline curve, allows you to pick a 
series of points on a drawing and fit a curve to those points.

To draw a spline curve

1.	 Choose the Spline curve tool from the Drafting Tools panel/palette.



117 Chapter 2 Creating and editing objects

2.	 Position the cursor at the point you want the spline curve to start, then click 
the mouse button.

3.	 Move until you reach the point through which you want the curve to pass.

4.	 Click the mouse button again.

A straight line appears between the starting point and the cursor to show you 
the slope of the curve segment.

5.	 Move the cursor to the next point you want the curve to pass through and 
click it. A curve will be drawn through the three points defined so far.

6.	 Continue moving the cursor and clicking the mouse button until you have 
defined all the points the curve is to pass through.

Note: Press the Backspace (Delete) key at any time to delete the last point placed.

7.	 When you reach the last point, to complete the spline curve double-click to 
place the final point. 

Note: To make the spline curve a closed object, finish the curve on the starting point

Changing the shape of a spline curve

You can change the shape of a spline curve by dragging its control points.
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To change the shape of a spline curve

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting 
Tools panel/palette.

2.	 Select the spline curve object you want to change by clicking it.

3.	 Position the cursor on one of the edit handles (the edit handles represent the 
control points that were used to define the curve), then press and hold down 
the mouse button.

4.	 Drag to reposition the control point and modify the curve.

5.	 When the curve is the shape you want, release the mouse button.

Top Tip (Pro Version Only): You can add and remove handles on a Spline curve 
after it has been finished, by using the Add/Remove handles tool in the Advanced 
Tools section of the Tool panel.

Drawing special lines
MacDraft provides a selection of special line tools to make it easy to draw lines 
in relation to existing objects. Lines can be drawn perpendicular to existing lines 
or edges; from the mid, end and center points of existing objects; at a tangent to, 
or at a tangent between, existing circles or arcs; offset from existing lines.

Choosing special line tools

To draw a perpendicular line; a mid point, end point, or center point line; a 
tangent line; or an offset line, choose the appropriate tool from the Special line 
tools pop-up menu in the Drafting Tools panel/palette.
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To choose a special line tool

1.	 Click the Special line tool in the Drafting Tools panel/palette, then press and 
hold down the mouse button.

The Special line tools pop-up menu appears. 

2.	 Drag until the desired tool is highlighted.

3.	 Release the mouse button and the icon representing the special line tool 
chosen appears in the panel.

Perpendicular lines

The Perpendicular line tool is used for drawing lines perpendicular to existing 
lines, or perpendicular to the edges of polygons, circles, circular arcs or square-
cornered rectangles.

Once a perpendicular line is drawn, it becomes a normal unconstrained line. You 
can edit it, resize it, or move it away from its original position.

Note: The “anchoring” object for the perpendicular line must be in place before you 
choose the Perpendicular tool.

Drawing a line perpendicular to an existing object takes two steps: selecting the 
object to draw the line perpendicular to and specifying the end point.

Drawing perpendicular lines
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To draw a line perpendicular to an existing object

1.	 Choose the Perpendicular line tool from the Special line tools pop-up menu 
in the Drafting Tools panel/palette.

The cursor will now read “Click Line/Arc”, to let you know that you need to 
select a line, circular arc or the edge of an object.

2.	 Click the line, arc or object edge that the line is to be drawn perpendicular to.

The cursor will now read “Click Point”, to let you know that you need to 
select an end point for the perpendicular line.

3.	 Move the cursor to the point where you want the perpendicular line to end.

The perpendicular line’s starting point slides along the anchoring edge or line 
as you move the cursor.

Note: It is possible to draw a perpendicular line from a point not on the original 
shape, but on an invisible line or circle extended from it.
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4.	 Click to specify the end point of the line.

The perpendicular line is then drawn.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw a perpendicular line, the end of the line will 
snap to the nearest grid intersection point.

•	 Hold down the Command key when drawing a perpendicular line to avoid 
the line snapping to the grid.

•	 Hold down the Option key when drawing a perpendicular line and the line 
length will snap to the nearest grid increment.

Mid point, end point and center point lines

The Mid point, End point and Center point line tools are used to draw lines 
from the mid point, or end point of an existing straight edge or circular arc, or 
from the center of an existing object. These tools are found in the Special line 
tools pop-up menu in the Drafting Tools panel/palette.

Once a line is drawn with a Mid point, End point or Center point line tool, it 
becomes a normal unconstrained line and can be edited, resized and moved.

The Mid point and End point line tools can be used with straight-edged objects 
(lines, polylines, polygons and square-corner rectangles) and circular arcs. Any 
of these objects can be part of a group. The Center point line tool can be used 
with any individual shape.

Note: The “anchoring” object for the line must be in place before you choose the 
Mid point, End point or Center point line tool.
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Drawing Mid point, End point and Center point lines

Drawing a line from the mid, end or center point of an existing object takes two 
steps: selecting the object to draw the line from and specifying the end point.

All of these lines are drawn in the same way.

To draw a line from the mid, end or center point of an existing object

1.	 Choose the Mid, End or Center point line tool from the Special line tools 
pop-up menu in the Drafting Tools panel/palette.

The cursor will now read “Click Line/Arc” or “Click Object”, to let you 
know that you need to select a line, edge, circular arc or object.

2.	 Click the line, edge arc or object that the line is to be drawn in relation to.

The cursor will now read “Click Point”, to let you know that you need to 
select an end point for the line.

3.	 Move the cursor to the point where you want the line to end.

4.	 Click to specify the end point of the line.

The line will be drawn.
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Note: The final point of a mid point, end point or center point line can be snapped 
to the mid point, end point or center point of some other existing objects.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw a mid, end or center point line, the end of the 
line will snap to the nearest grid intersection point.

•	 Hold down the Command key when drawing a mid, end or center point line 
to avoid the line snapping to the grid.

•	 Hold down the Option key when drawing a mid point, end point or center 
point line and the line length will snap to the nearest grid increment.

Tangent Lines

MacDraft provides two ways to draw tangent lines from circles and circular arcs. 
The Tangent from tool draws a tangent from a circle or arc to any point, and the 
Tangent between tool draws a tangent from one circle or arc to another. Both 
of these tools are located in the Special line tools pop-up menu in the Drafting 
Tools panel/palette.

Once a tangent is drawn, it becomes a normal unconstrained line. You can edit 
and resize it or even move it away from its original position if necessary.

Note: The circles or arcs the tangent line is to be drawn in relation to must be in 
place before you choose a tangent line tool.

Drawing a tangent from a circle or arc to a point

Drawing a tangent from a circle or arc to a point involves two steps: selecting the 
object the line is to be drawn at a tangent to, then specifying the end point for the 
tangent line.

To draw a tangent from a circle or arc to a point

1.	 Select the Tangent from tool from the Special line tools pop-up menu in the 
Drafting Tools panel/palette.
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The cursor now reads “Click Circle/Arc”, to let you know that you need to 
select a circle or an arc.

2.	 Click the circle or arc.

3.	 The cursor now reads “Click Point,” to let you know that you need to select 
an end point for the tangent line.

Move the cursor; the tangent's starting point slides around the circle or arc.

Note: When drawing a tangent line from an arc, it is possible to draw a tangent line 
from a point not on the visible arc, but on its “invisible circle.”

4.	 Position the cursor on the point you want the tangent line to end and click it. 

The tangent line is drawn.
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Note: Normally the tangent will be drawn clockwise away from the arc or circle. 
You can draw the tangent counterclockwise by holding down the Option key before 
selecting the circle or arc, and keeping the Option key held down until the end point 
is specified.

Drawing a tangent between circles or arcs

Drawing a tangent from a circle or arc to another circle or arc involves two steps: 
selecting the first object, then selecting the second object.

The tangent’s final position depends on which half of each object you click.

To draw a tangent from a circle or arc to another circle or arc

1.	 Choose the Tangent between tool from the Special line tools pop-up menu 
in the Drafting Tools panel/palette.

The cursor now reads “1st Circle/Arc”, to let you know that you need to 
select a circle or an arc.

2.	 Click the circle or arc near the desired starting point for the tangent.
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The cursor now reads “2nd Circle/Arc”, to let you know that you need to 
select another object.

3.	 Move the cursor to the other object the tangent is to be drawn to and click 
close to the point you want the tangent line to end.

The tangent line is drawn.

Note: The final path of the tangent is determined by which half of each object you 
select. For any pair of circles or arcs, there are four possible tangent arrangements, 
as shown below.

Offset Lines

MacDraft’s Offset line tool is used to create single lines parallel to existing 
straight lines or edges. The offset line will have the same length, angle, line 
weight, line style and pen model as the original line or edge.

Offset lines can be created from any straight line or from any edge of a 
polygon, polyline or square-cornered rectangle. Once drawn, an offset line 
is an independent straight line object that can be edited, moved or otherwise 
manipulated as required.



127 Chapter 2 Creating and editing objects

Note: The “parent” object for the offset line must be in place before you choose the 
offset line tool. Also Parallel line objects can be created using the Parallel line tools.

Drawing an offset line from an existing object

Drawing an offset line from an existing object involves two steps: selecting the 
source line or edge and specifying the offset distance.

To draw an offset line from an existing object

1.	 Select the Offset line tool from the Special line tools pop-up menu in the 
Drafting Tools panel/palette.

The cursor now reads “Click Line/Edge”, to let you know that you need to 
select a line or the straight edge of an object.

2.	 Click the line or edge.

The cursor now reads “Click Point” and appears near a dotted copy of the 
source line, helping you to determine the offset distance.

3.	 Move the cursor to the desired position for the offset line and click it.
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The offset line is drawn.

The offset is a normal unconstrained line, which you can edit as needed. You 
can also use it as the base for a new offset line.

4.	 To exit the Offset line tool, click the Pointer icon in the Drafting Tools 
panel/palette or press the Escape key on your keyboard.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw an offset line, the offset distance for the line 
will snap to the nearest active grid line.

•	 Hold down the Command key when drawing an offset line to avoid the 
offset distance for the line snapping to the grid.

•	 Hold down the Option key when drawing a line and the offset distance for 
the line will snap to the nearest grid increment.

Drawing parallel line objects
MacDraft’s Parallel line tools are used to draw single sets of parallel lines or 
polygons and polylines with double lines. You can use parallel lines to create 
drawings of such things as walls, beams and frames. Various options can be set to 
specify how the parallel lines should be drawn.
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Choosing parallel line tools

You can use parallel line tools to draw a single set of straight lines, polylines or 
polygons, parallel line objects can also be extruded from existing straight edged 
objects. The appropriate parallel line tool is chosen from the Parallel line tools 
pop-up menu in the Drafting Tools panel/palette.

To choose a parallel line tool

1.	 Click the Parallel line tool in the Drafting Tools panel/palette, then press 
and hold down the mouse button.

The Parallel line tools pop-up menu appears.

2.	 Drag until the desired tool is highlighted.

3.	 Release the mouse button.

The icon representing the tool chosen appears in the panel.

Parallel line tool options

Various options (alignment, end caps, line joints and distance between lines) 
can be set for parallel line objects. These options are found in the Parallel Line 
Options panel that appears at the top of the drawing when the tool is selected.
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The parallel line tool options can be set as defaults to be used for all parallel 
objects drawn, existing parallel lines can be edited using the Properties panel/ 
properties palette.

Note: Parallel line options for extruded parallel line objects can be edited using the 
Parallel Line Options in the Properties panel.

Setting default parallel line tool options

To set parallel line tool options to be used for all parallel line objects drawn

1.	 Ensure that nothing is selected on the drawing. 

2.	 Select one of the Parallel line tools in the Drafting Tools panel/palette.

The Parallel Line options appear at the top of the drawing area.

3.	 Set the various options as desired. A complete description of the options 
available and their effects on parallel line objects follows later in this section.

The options set will be used for all parallel line objects drawn.

Setting parallel line tool options for selected objects

To set parallel line tool options for selected objects

1.	 Select the parallel line object you wish to change the attributes of.

2.	 Select the Properties tab in the right-hand panel/ properties palette and 
scroll down to the Parallel Line Options.

3.	 Set the various options as desired. A complete description of the options 
available and their effects on parallel line objects follows later in this section.

The selected object will be changed to reflect your choices.

Note: To change the thickness of individual parallel lines, click the "Select 
Segment" button, select the parallel line (hold Shift to select more than one), then 
change the value in the thickness text box. Press Escape to exit editing.

Alignment

There are three alignment choices for parallel line objects: left, center and 
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right. The alignment options are represented by three icons in the Parallel Line 
options. The small arrow indicates what part of the line is active.

Select the desired option by clicking the appropriate icon in the Alignment 
section of the Parallel Line options.

Alignment controls how parallel lines, polylines and polygons are drawn and 
how editing affects them. Specifically, the alignment options determine what is 
the leading edge of the parallel line object and what part of the shape is active. 
For example, when align left is the current option, the left parallel line will be 
drawn on the grid and edit handles appear on the left line when the parallel lines 
are selected.

How the alignment options affect parallel lines 

Align Center

When Align Center is on, the cursor appears between the lines during drawing. 
The center of the two lines will lie on the grid. When the parallel lines are 
selected, the edit handles appear between the ends of the line segments.

Align Left

The Align Left option is used to specify which of the parallel lines is active. 
The active line is the one that lies on the grid and is used to edit the shape. If you 
draw parallel lines while the Align Left option is on, the active line is determined 
by the direction you first drag during the creation of the shape. In general, if you 
drag up, the left line is active. If you drag down, the right line is active.

Align Right

As with Align Left, the Align Right option determines which of the two lines is 
active. When the Align Right option is on, the direction in which you first drag 
during creation determines which line is active. In general, if you drag up, the 
right line is active. If you drag down, the left line is active.
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Alignment and parallel polylines

The active alignment option determines how the parallel lines pivot around each 
ending point. When you define the ending point for a side, the end point of the 
active line (or the center of the two lines in the case of center alignment) is used 
as the ending point of the side. The inactive line pivots around the ending point, 
following the movement of the mouse.

End Caps

You can draw parallel lines and polylines with butt end caps, that is, with line 
segments that join the ends of parallel lines. You can choose to draw parallel lines 
and polylines with no end caps, with an end cap at either end or with end caps at 
both ends. Extruded parallel lines and polylines can be drawn with or without a 
final end cap.

Select the appropriate icon from the End Caps section in the Parallel Line 
options panel in the properties panel/ Properties palette.

•	 Parallel lines drawn without end caps.

•	 End caps at the start of the parallel lines. (That is, the end at which you 
pressed and held down the mouse button and started to draw the lines.)

Note: Extruded parallel lines cannot have end caps at the start of the parallel line 
segment because they will be connected to an existing parallel line and therefore 
will not have a start point to set the end caps for.

•	 End caps at the end of the parallel lines. (That is, the end at which you 
finished drawing the line or shape.)
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•	 End caps at both ends of the parallel lines.

Note: Extruded parallel lines cannot have end caps at the start of the parallel line 
segment because they will be connected to an existing parallel line and therefore 
will not have a start point to set the end caps for.

With Line 
Joints

Without Line 
Joints

Line joints

You can choose to draw parallel polyline shapes and polygons with line joints at 
the corners. When you choose this option, a line is drawn between the inside and 
outside lines where the sides meet. (This feature can be used to indicate miter 
joints.)

Select the appropriate icon from the Line Joints section in the Parallel Line 
options panel in the properties panel/ properties palette.

Note: Extruded parallel lines cannot be drawn with line joints
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Line Width

You can specify the distance between parallel lines by entering a value in the 
Thickness field in the Parallel Line options. The values you enter for the distance 
are real-world values that reflect the current size units. For example, if you are 
working on a document in which Fractional Feet & Inches and the scale 1/4” = 1' 
were currently defined, if you entered “6” as the distance, the distance between 
the lines would represent 6 inches in the real world.

Top Tip: You can use patterns, gradients and colors to fill the gap between parallel 
lines (this is great for when creating walls and partitions).

Parallel lines

You can set the options for parallel lines (alignment, end caps, line joints and 
distance between lines) in the Parallel Line options panel in the properties panel/ 
properties palette.

Drawing a single set of straight parallel lines 

To draw a single set of parallel lines

1.	 Choose the Parallel line icon from the Parallel line tools pop-up menu in 
the Drafting Tools panel/palette.

2.	 Position the cursor on the point you want the parallel lines to start, then press 
and hold down the mouse button.

3.	 Drag until the lines are the desired length, and release the mouse button.

4.	 When you release the mouse button, edit handles appear at the ends of the 
parallel line object. These can be used to change the length and orientation of 
the lines.
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Note: Hold down the Shift key while drawing a single set of parallel lines and angle 
of the lines will snap to 45° increments. The final point of a parallel line can be 
snapped to the mid point, end point or center point of some existing objects using 
the M, E and C keys on your keyboard or by using the Smart Snap option.

Editing a pair of parallel lines

To edit a pair of parallel lines

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the parallel lines to be edited.

3.	 Position the cursor on one of the edit handles, then press and hold down the 
mouse button.

4.	 Drag in any direction until the lines are the desired length and orientation, 
and release the mouse button.

To edit a pair of parallel lines numerically

1.	 Return to the pointer mode by clicking the Pointer tool in the Drafting Tools 
panel/palette.

2.	 Select the parallel line you want to change.

3.	 Go to the Properties tab in the right hand panel/ properties palette. 

4.	 Click the Select Point button below the Parameters section of the Resize & 
Position Options and click one of the points on the parallel line.

5.	 Enter the sizes in the Parameters section of the Resize & Position Options.
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Top Tip: If you are using English units but want to resize using a Metric unit 
type, you can enter it into the text box. For example, if your units are set to Feet & 
Fractional Inches, you can still type "30mm" into the resize fields to resize the line. 
The smart unit system will convert the value for you.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or resize a single parallel line, the end of the 
parallel line will snap to the nearest grid intersection point.

•	 Hold down the Command key when drawing or resizing a parallel line to 
avoid the line snapping to the grid.

•	 Hold down the Option key when drawing a parallel line and the line length 
will snap to the nearest grid increment.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw a parallel line, it will snap to the 
angular grid.

•	 Hold down the Shift key when drawing a parallel line to avoid the line 
snapping to the angular grid.

Parallel polylines and parallel polygons

You can draw two types of multi sided irregular shapes using parallel lines: 
closed polygons and open polylines. A parallel polygon is a closed object made 
of three or more sides. It can be a complex, irregularly shaped object made up of 
many straight parallel line segments. 

A parallel polyline is an open object made of at least two straight parallel line 
segments. The line segments used for either type of object can be of any length 
and drawn at any angle.

You can set the options for parallel polylines and polygons (alignment, end caps, 
line joints and distance between lines) in the Parallel Line options panel in the 
properties panel/ properties palette.
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Drawing polygons and polylines with parallel lines

To draw an irregular polygon or polyline with parallel lines, you position the 
cursor and click to de ne the end points of the parallel lines that make up the 
shape.

To draw a polygon or a polyline with parallel lines

1.	 Choose the Parallel polygon or Parallel polyline tool from the Parallel line 
tools pop-up menu in the Drafting Tools panel/palette.

2.	 Place the cursor at the point you want to begin drawing the object, then click 
the mouse button.

3.	 Move until you have created a parallel line that is the desired length and 
angle for the first side or line segment of the object. 

4.	 Click the mouse button.

5.	 Without pressing and holding down the mouse button, move the cursor to 
draw the second parallel line segment.
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6.	 When the second parallel line is the desired length and angle, click this point.

7.	 Without pressing the mouse button, move the cursor to draw the next parallel 
line segment.

8.	 When the parallel line is the desired length and angle, click this point.

You may decide that you want to change a parallel line segment after 
you have clicked to define its end point. You can change the length and 
orientation of the last parallel line segment drawn by using the Dynamic 
Editing feature.

9.	 To change the last parallel line segment drawn, move the cursor back to the 
last defined point and click it.

The previous parallel line will reattach to the cursor, allowing you to move 
the end of the parallel line to a new position on the drawing.

10.	 Move the cursor to a new position on the drawing and click it.

The parallel line will be drawn to the new position.

11.	 Continue to draw the rest of the object.

12.	 When you reach the last point to be placed, double-click this place. 

This double-click action completes the object.

•	 If you are drawing a parallel polygon, the last point you clicked will be 
connected to the starting point of the shape by a straight parallel line.
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•	 If you are drawing a parallel polyline, the object will remain open.

Note: Hold down the Shift key while drawing a parallel polygon or polyline and 
the angle of the current parallel line segment will snap to increments of 45°. The 
final point of a parallel polyline can be snapped to the mid point, end point or center 
point of some existing objects.

Changing the shape of parallel polygons and polylines

You can edit parallel polygons and polylines in the same way as you would 
normal polygons and polylines.

Note: The length and angle of the 2 parallel lines you are moving are displayed on 
the cursor while you are moving. 

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and 
the Set Grid option), when you draw or edit a parallel polygon or polyline, the 
ends of the parallel line segments or the edit handles will snap to the nearest grid 
intersection points.

•	 Hold down the Command key when drawing or editing a parallel polygon or 
polyline to avoid the lines or edit handles snapping to the grid.

•	 Hold down the Option key when drawing a parallel polygon or polyline and 
the line lengths will snap to the nearest grid increment.

If there is an angular snapping grid set for the document (using the Layout menu, 
and the Set Angle Snap option), when you draw a parallel polygon or polyline, 
the line segments will snap to the angular grid.

•	 Hold down the Shift key when drawing a parallel polygon or polyline to 
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avoid the line segments snapping to the angular grid.

Extruding parallel lines and parallel polylines

MacDraft’s Extrude parallel line and Extrude parallel polyline tools are used 
to draw parallel lines or parallel polylines from existing straight-edged objects, 
such as lines, rectangles or polygons. Although the extruded lines are actually 
separate line segments, they give the appearance of parallel lines.

Lines can also be extruded from parallel-line objects and between parallel line 
objects. This is useful in adding interior walls to a floor plan, for example.

The Extrude parallel line and Extrude parallel polyline tools are located in the 
Parallel line tools pop-up menu in the Tool panel.

You can set the options for extruded parallel lines and polylines (alignment, end 
caps, line joints and distance between lines) in the Parallel Line options panel in 
the properties panel/ properties palette.

Extruding parallel lines from an edge or line

To extrude parallel lines from a straight-edged object or line

1.	 Choose the Extrude parallel line tool from the Parallel line tools pop-up 
menu in the Drafting Tools panel/palette.
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2.	 Position the cursor over the edge you wish to extrude the parallel lines from, 
then click the mouse button.

3.	 Drag until the extruded lines are the desired length and orientation, then click 
the mouse button.

4.	 The extruded parallel line segment appears on the drawing. It is added to the 
earlier object as a pair of line segments.

Note: Hold down the Option key to constrain the extruded parallel line to be 
perpendicular to the original edge and make its length snap to the currently active 
grid-snap distance.

Extruding parallel polylines from an edge or line

To extrude parallel polylines from a straight-edged object or line

1.	 Choose the Extrude parallel polyline tool from the Parallel line tools pop-
up menu in the Drafting Tools panel/palette.

2.	 Position the cursor over the edge you wish to extrude the parallel polylines 
from, then click the mouse button.

3.	 Drag until you have created an extruded parallel line that is the desired length 
and angle for the first segment of the object, then click the mouse button.

4.	 Continue to draw the extruded parallel polylines as per the instructions for 
drawing parallel polylines.
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Extruding parallel lines or polylines from a parallel object

To extrude parallel lines or polylines from a parallel-line object

1.	 Choose the Extrude parallel line or Extrude parallel polyline tool from the 
Parallel line tools pop-up menu in the Drafting Tools panel/palette.

2.	 Position the cursor over the line you wish to extrude the parallel lines or 
polylines from, then press and hold down the mouse button.

3.	 Continue drawing as extruded lines or polylines.

Top Tip: You can connect the end of a parallel line or parallel polyline to another 
parallel line object, simply by moving the end of the extruded parallel line or 
polyline while drawing to overlap another parallel polyline or parallel line object.

Snap to grid

If there is a snapping grid set for the document (using the Layout menu, and the 
Set Grid option), when you draw or edit an extruded parallel line or polyline, the 
ends of the parallel line segments or the edit handles will snap to the nearest grid 
intersection point.

•	 Hold down the Command key when drawing or editing an extruded parallel 
line or polyline to avoid the lines or edit handles snapping to the grid.

•	 Hold down the Option key when drawing an extruded parallel line or 
polyline and the initial parallel line segment will be constrained to be 
perpendicular to the original edge, and the line lengths will snap to the 
nearest grid increment.
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Drawing Stars
MacDraft offers a Star tool allowing you to easily create star shapes without the 
need to construct them with individual lines. You can either draw a star from the 
center or from the edge.

Drawing a star from the edge

To draw a star from the edge

1.	 Go to the Drafting Tools panel/palette and select Star tool .

The cursor will change to a drawing cross.

2.	 Click the mouse button to place the start point.

3.	 Move the mouse until the desired size has been drawn.

4.	 Click the mouse button to finish drawing.

Note: Hold the SHIFT key down on the keyboard to constrain the angle.

Drawing a star from the center

To draw a star from the center

1.	 Go to the Drafting Tools panel/palette and select Star tool .

The cursor will change to a drawing cross.

2.	 Click the mouse button to place the start point.

3.	 Hold down the Option key on the keyboard and move the mouse until the 
desired size has been drawn.

4.	 Click the mouse button to finish drawing.

Note: Hold the SHIFT key down on the keyboard to constrain the angle.
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Star tool options

To change the star tool options

1.	 Select Star tool in the Drafting Tools panel/palette.

The Star tool options appear at the top of the drawing area.

2.	 Set the various options as desired. A complete description of the options 
available and their effects on parallel line objects follows later in this section.

The options set will be used for all star objects drawn.

3.	 Enter the number of points for the star.

4.	 Enter the percentage ratio for the thickness of the star.

5.	 Click OK.

6.	 Now draw the star as per the instructions outlined in drawing stars.

The Marker Symbol
The Marker Symbol tool is used to add a registration-type marker to a drawing in 
one simple step.

Select the Marker tool in the Drafting Tools panel/palette, then click the 
drawing one or more times to add as many markers as you need; each marker is 
centered on the point you click. Leave the Marker Symbol tool by holding down 
the Command key and clicking a blank area of the drawing or by clicking the 
Pointer tool in the Tool panel.
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Once a marker symbol is drawn, it exists as a group. It can be ungrouped to a 
circle and two crossed lines

Adding marker symbols to a drawing

To add marker symbols to a drawing

1.	 Choose the Marker symbol tool in the Drafting Tools panel/palette.

2.	 Place the cursor where you want the marker symbol to appear on the drawing 
and click the mouse button.

The marker symbol appears on the drawing centered on the point specified.

3.	 To add more marker symbols, repeat steps 2 as many times as necessary.

4.	 When you have finished adding markers, click the Pointer tool in the 
Drafting Tools panel/palette, or hold down the Command key and click 
a blank area of the drawing. You can also press the Escape key on your 
keyboard.

Datum Points
Each object in MacDraft has a datum point; this is a reference point used when 
you paste the object, rotate it, or manipulate it in other ways.

Each type of object has a default datum point, for example, the default datum 
point for a rectangle is the top left corner. It is possible to change the location of 
the datum point for any object.
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Assigning a new datum point to an object

To assign a new datum point to an object

1.	 Select the object to which you want to assign a new datum point by clicking 
it with the Pointer tool.

2.	 Either:

•	 Choose Edit Datum from the Edit menu or,

•	 Choose the Edit datum tool in the Drafting Tools panel/palette.

An “x” marker appears on the selected object at the current position for the 
datum point and the cursor will change to a “x”.

Move the cursor to the new position for the datum point and click it.

Note: The datum point can be located anywhere within a bounding rectangle that 
surrounds the object. In the case of most non rectangular objects, this will be an 
imaginary rectangle. If you click near a vertex point (that is, a point where two 
edges meet), the x marker will snap to that vertex.

The “x” marker appears at the point you clicked to mark the new datum 
point.

To place the datum point in the center of the object

1.	 Select the object to which you want to assign a new datum point by clicking 
it with the Pointer tool.
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2.	 Either:

•	 Choose Edit Datum from the Edit menu or,

•	 Choose the Edit datum tool in the Drafting Tools panel/palette.

3.	 Choose Center Datum from the Edit menu.

Note: The object’s center is defined as the center of the object’s “extent.” The extent 
is the overall size of the object.

To exit from the Edit Datum mode

•	 Click the Pointer tool in the Drafting Tools panel/palette, or;

•	 Press the Escape key on the keyboard.

Fixed and free datum points

Fixed datum points

A datum point located at the center of the object or on a vertex point is a fixed 
datum point and has some special attributes. It retains the same relative position 
on the object even if you reshape or resize the object.

An example of a fixed datum point

1.	 Assign a fixed datum point to the lower right vertex on a rectangle.

2.	 Resize the rectangle by dragging the handle on the middle of the right side 
towards the center of the rectangle.
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As a fixed datum point was assigned to the lower right vertex, the datum 
point will still appear on the lower right vertex.

Free datum points

A datum point that is not located at the center of the object or on a vertex point is 
a free datum point and does not retain the same relative position on the object if 
you reshape or resize the object.

An example of a free datum point

1.	 Assign a free datum point towards the lower right corner of a rectangle.

2.	 Resize the rectangle by dragging the handle on the middle of the right side 
towards the center of the rectangle.

As a free datum point was assigned to the lower right vertex, and that point is 
now outside the new object’s bounding rectangle, the datum point will revert 
to the default position within the object.

Datum points of groups

Grouped objects also have datum points. The default datum point for a grouped 
object is the default datum point of the item in the group that is farthest back on 
the drawing.
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Reshaping objects
There may be occasions when you want to reshape an object so that straight lines 
and sharp corners become curved lines and rounded corners; the irregular lines 
of an object to smooth lines. You can accomplish this conversion by using the 
Reshape submenu in the Edit menu.

The objects that the Reshape command can modify are polygons (drawn with the 
irregular polygon tool), polylines, freehand lines and freehand shapes.

Reshaping an object

To reshape an object

1.	 Select the object you want to reshape by clicking it.

2.	 Open the Edit menu and drag down until Reshape is highlighted.

The Reshape submenu appears.

3.	 Choose Smooth or Unsmooth (detailed explanations of the choices follow) 
and release the mouse button.

The object will be reshaped as you requested.
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Reshape options

The Smooth and Unsmooth commands affect different shapes in different ways.

Reshaping polygons and polylines

 A polygon can be smoothed to a curve that lies inside the original object 
(intersecting the midpoints of each line segment). When the smoothed polygon is 
selected, its original shape appears as a ghost outline.

A polyline can be smoothed to a curve that intersects the midpoints of each line 
segment of the original object, except for the segments closest to the ends. That 
is, the curve will skip over the first and last midpoints of the original polyline.

Polyline Smoothed Polyline

Selected Smoothed Polyline

If you select a polygon or polyline that has been smoothed using the Smooth 
command, and choose Unsmooth, the object will revert to its original shape.

Reshaping freehand lines and shapes

A freehand line or shape can be smoothed to a curve that lies close to the original 
object and passes near to the original vertices (the new edit handles appear at the 
old vertices). This new shape can be smoothed repeatedly until the desired effect 
is obtained.

If you select a freehand line or shape that has been smoothed using the Smooth 
command, and choose Unsmooth, the last stage in the smooth process will be 
undone.
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Note: If a freehand object includes sharp points, you can often get good results by 
deleting or adding handles before smoothing

Resizing Objects
Objects can be resized manually by dragging their handles, as discussed in the 
sections about drawing the various types of objects. MacDraft also includes a 
Properties panel. This provides a method for resizing objects by typing exact 
sizes and gives you more precise control over the size of objects.

Displaying the Properties panel

To display the Properties panel

The Properties panel is the first tab in the right hand panel. This panel will be 
open by default. If the panel is not open you can open it by:

•	 Go to the View menu and select Show Right Panel or;

•	 Click the Right Panel icon in the Show/Hide Panels toolbar item. If you are 
in palette mode, Properties will be in the Properties Palette. 

Freehand Shape Smoothed Freehand Shape
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•	 Scroll down to the Resize & Position Options.

The Resize & Position Options section of the Properties panel/ properties 
palette shows the size values and position of the currently selected object, if 
nothing is selected, the Resize Options & Position will not display.

Resizing objects

Different types of objects are resized in different ways. For example, you can 
resize a rectangle by specifying the exact height and width of the rectangle, 
whereas resizing an arc includes entering various angle values and a radius 
length. The individual sections following describe the resizing options for the 
different types of objects and the information you can enter to resize them.

You can resize objects by entering absolute or relative values for the whole object 
or, for some objects, a selected point on the object. Measurements are defined in 
the current layer’s scale and units, and changes are applied relative to the object’s 
datum point, unless the Select Point button is used. When relative values are 
entered, positive values increase measurements, negative values decrease them.

Note: When objects are resized, any dimension objects linked to them will be 
automatically resized as well.

Absolute resize values

•	 For a whole object, enter the values for the desired dimensions.

•	 For a point on the object, enter values for the desired location of the point.

Relative resize values

•	 For a whole object, enter values to be added to current dimensions.

•	 For a point on the object, enter values to move the point by.

Resizing a whole object by absolute values

In general terms, to resize an object by changing its absolute size values

1.	 Select the object you want to resize.

2.	 Ensure the Absolute tab is selected in the Resize & Position options.



153 Chapter 2 Creating and editing objects

3.	 Enter the new size values (such as Width and Height) that you want.

4.	 Click the Apply button or press the Return or Enter key.

The new size will be applied to the object.

Note: If the resize operation requires the object to be enlarged beyond the drawing 
area, a system beep sounds.

Resizing an object by changing the absolute values of one point

To resize an object by editing a single edit handle

1.	 Select the object you want to resize.

2.	 Ensure the Absolute tab is selected in the Resize & Position options.

3.	 Click the Select Pt button on the Resize Options section.

A select point sight cursor appears on the drawing.

4.	 Position the cursor on the point (edit handle) you want to edit and click it.

The Resize & Position Options shows the location of the point.
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5.	 Enter values for the new location for the edit handle and click the Apply 
button or press the Return or Enter key.

The new values will be applied to that edit handle, moving it and so resizing 
the object.

Note: If the resize operation requires the object to be enlarged beyond the drawing 
area, a system beep sounds.

Resizing a whole object by relative values

In general terms, to resize an object by changing its relative size values
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1.	 Select an object. Its current measurements are shown in the Resize & 
Position Options.

2.	 Ensure the Relative tab is selected in the Resize & Position options.

3.	 Enter values to increase (positive numbers) or decrease (negative numbers) 
the measurements to be changed.

4.	 Click the Apply button or press the Return or Enter key.

The measurement changes are applied to the object, making the appropriate 
dimensions larger or smaller.

Note: If the resize operation requires the object to be enlarged beyond the drawing 
area, a system beep sounds.
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Resizing an object by changing the relative values of one point

To resize an object by editing a single edit handle

1.	 Select an object. Its current measurements are shown in the Resize & 
Position options.

2.	 Ensure Relative tab is selected in the Resize & Position options.

3.	 Click the Select Pt. button in the Resize & Position options.

The select point sight cursor appears on the drawing.

4.	 Position the cursor on the point (edit handle) you want to edit and click it.

Zeros are shown in the Resize & Position options for the horizontal and 
vertical changes, showing that no new values have been entered.
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5.	 Enter values to increase (positive numbers) or decrease (negative numbers) 
the point’s position.

6.	 Click Apply or press the Return or Enter key.

The measurement changes are applied to the selected point, moving it and so 
resizing the object.

Note: If the resize operation requires the object to be enlarged beyond the drawing 
area, a system beep sounds. Using relative is a great way to increase the size of an 
object by a specific value and will resize from the point the object was drawn at.

Resize Units

The Resize & Position options use the scale and units of the current layer. When 
you select an object with the Resize & Position options visible, the values shown 
will reflect the scale. When you enter values to resize an object, you should use 
values appropriate to the current scale.

Note: If you enter unscaled units in a scaled drawing (for example, a width “4" ” 
in a 1/8”=1' drawing), you may get unexpected results (in that example, the four 
inches would appear in the drawing as 1/24 of an inch on screen and on paper).

If you don’t specify units with the values you enter, MacDraft will interpret the 
values according to the document’s current size units. The size units are set using 
the Scale and Units dialog which can be opened via the Layout menu.

Below are some examples of valid size and coordinate entries for some of the 
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available types of size units.

Decimal feet and inches

12.0'

110.3'

10'

10 in

12.3 is interpreted as 12.3'

Fractional feet and inches

23" = 1’11” 1 3/4”

1' 10-3/8”

Fractional inches

1"

123-3/4”

15 1/2

1/2

2-1/4

You can enter values greater than 12 inches if fractional inches are the current 
size units.

Resizing lines and parallel lines

Lines drawn with the unconstrained, constrained, parallel and special line tools 
can all be resized in the same way.
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L (Length) & Ao (Angle)

Changes the desired length and angle of the line. The specified angle is measured 
relative to the X-axis and the last point drawn on the line, this “finishing point”, 
will normally be the one that moves.

Select point

Allows you to select which end point of the line moves when you apply a new 
length or angle value.

Note: If you change the angle of a constrained line, it will become an unconstrained 
line, as constrained and special lines are only constrained when they're first entered.

Resizing rectangles

Square corner rectangles
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W (Width) and H (Height)

Changes the width and height of a rectangle. For example, to enlarge a 1" x 1" 
rectangle to 3" x 3", enter 3" in both fields. A diagonally drawn rectangle will be 
resized by shifting its bottom edge or right-hand edge (or both).

Select point

Allows you to select which edge or corner of the rectangle moves when you 
apply a new width or height (or both). For example, if you click Select Point and 
select the rectangle’s top middle handle, then enter a new height, the top edge 
moves up.

Rounded corner rectangles with proportional and constant corners

W (Width), H (Height), and Ra (Radius)

Changes the width and height of a rounded corner rectangle and the radius of the 
corner arc. Normally, the width and height values resize the rectangle by shifting 
its bottom edge or right-hand edge (or both).

Select point

Allows you to select which edge or corner of the rectangle moves when you 
apply a new width or height (or both). For example, if you click Select Point and 
select the rectangle’s top middle handle, then enter a new height, the top edge 
moves up.
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Rounded corner rectangles with elliptical corners

W (Width), H (Height), Xr (X-radius) and Yr (Y-radius)

Changes the width and height of a rectangle, and the vertical and horizontal 
radii of the elliptical corner arc. Normally, the width and height values resize the 
rectangle by shifting its bottom edge or right-hand edge (or both).

Select point

Allows you to select which edge or corner of the rectangle moves when you 
apply a new width or height (or both). For example, if you click Select Point and 
select the rectangle’s top middle handle, then enter a new height, the top edge 
moves up.

Resizing regular polygons

Regular polygons are resized in the same way as groups.

Resizing circles

Drawn by diameter

Diameter

Changes the diameter of the circle. The last point drawn normally moves as the 
circle is resized.

Select point

Allows you to select which end of the diameter line moves when you apply a 
new diameter value.
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Drawn by radius

Radius

Changes the radius of the circle. The handle on the circle’s circumference 
normally moves as the circle is resized.

Select point

Allows you to select which end of the radius line moves when you apply a new 
radius value. For example, if you click Select Point and select a radial circle’s 
center handle, then enter a new radius, the center handle moves as the circle is 
resized.
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Drawn by three points

X and Y locations

Changes the X and Y coordinates for the circle’s three edit handles. Absolute 
coordinates you specify are measured from the zero origins of the rulers.

Select point

Using the Select Point button has no additional effect on this object.

Resizing Ellipses

W (Width) and H (Height)

Changes the width and height of an ellipse. A diagonally drawn ellipse will 
normally be resized by shifting its bottom right edit handle, a centered ellipse 
will normally be resized without the center point moving.
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Select point

Allows you to select what portion of the ellipse moves when you apply a new 
width or height (or both). For example, if you click Select Point and select the 
ellipse’s top middle handle, then enter a new height, the top moves up.

Resizing arcs

Drawn by radius

A1°

Changes the angle of the arc’s starting point, measured in relation to the X-axis.

A2°

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

Ra (Radius)

Changes the radius of the arc.

Select point

Use of the Select Pt button has no additional effect on this object.

Drawn by three points

X & Y locations

Changes the X and Y coordinates for the arc’s three edit handles. Absolute 
coordinates you specify are measured from the zero origins of the rulers.
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Select point

Use of the Select Pt button has no additional effect on this object.

Elliptical Arcs

A1°

Changes the angle of the arc’s starting point, measured in relation to the X-axis.

A2°

Changes the angle of the arc’s ending point, measured in relation to the X-axis.

Xr (X-radius) and Yr (Y-radius)

Changes the horizontal and vertical radius of the arc.

Select point

Use of the Select Point button has no additional effect on this object.
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Resizing polygons and polylines, freehand shapes and curves

Because of the complexity of these objects, you can edit them only by using the 
Select Point cursor.

For example, if an object has several edit handles, each handle cannot be shown 
in the Resize options. Instead, you use the Select Point button to select a single 
handle, then specify a new location for it on the drawing.

X and Y coordinates

Changes the X and Y coordinates of a selected handle. Absolute values are 
measured from the zero origins of the rulers.

Select point

Allows you to select the handle to edit.

Note: The Resize options treat the direction handles on Bezier curve objects like 
any other edit handles.

Resizing groups
% (Percent)

Changes the size of the group proportionally by a percentage of its current 
size. Absolute values larger than 100% or positive relative values increase its 
size; absolute values smaller than 100% or negative relative values reduce it. 
Normally, the lower right corner moves as the group becomes larger or smaller.
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W (Width) and H (Height)

Changes the width and height of the group. A group will normally be resized by 
shifting its bottom edge or right-hand edge (or both).

Select point

Allows you to select which corner of the groups bounding frame moves when 
you resize it. For example, if you click Select Point and select the top left handle 
of the groups bounding frame, then enter an absolute percentage value of 200%, 
the top edge moves up and the left edge moves left.

Resizing groups manually

There may be times when you would like to enlarge or reduce the size of 
a grouped object. MacDraft gives you the ability to change a group’s size 
proportionally or non- proportionally (vertically or horizontally) by dragging the 
groups edit handles.

By changing the size of a group proportionally, you can maintain the original 
shapes of the individual objects within the group. Objects within the group 
become larger or smaller without becoming distorted.

To resize a group of objects proportionally

1.	 Select the group you want to resize.

2.	 Position the tip of the pointer on an edit handle on the corner of the group.

3.	 Press and hold down the mouse button.

4.	 Drag until the group is the size you want, and release the mouse button.
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The grouped object will be changed in size proportionally to its original size.

To resize a group non-proportionally

1.	 Select the group you want to resize.

2.	 Position the tip of the pointer on an edit handle on the corner of the group.

3.	 Press and hold down the mouse button and press the Shift key.

4.	 Holding down the mouse button and the Shift key, drag until the group is the 
size you want, and release the mouse button and Shift key.

Resizing Metapolygons

Metapolygons are the objects created when you use the Add command, Subtract 
command or Attach command to combine objects with different types of edges.

% (Percent)

Changes the size of the metapolygon proportionally by a percentage of its current 
size. Absolute values larger than 100% or positive relative values increase its 
size; absolute values smaller than 100% or negative relative values reduce it. 
Normally, the lower right corner moves as the metapolygon becomes larger or 
smaller.

W (Width) and H (Height)

Changes the width and height of the metapolygon. A metapolygon will normally 
be resized by shifting its bottom edge or right-hand edge (or both).
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Select point

Allows you to select which corner of the metapolygon’s bounding frame 
moves when you resize it. For example, if you click Select Point and select the 
metapolygon’s top left handle, then enter an absolute percentage value of 200%, 
the top edge moves up and the left edge moves left.

Resizing dimension objects

When objects (not circles) are resized, any dimension objects linked to them will 
be automatically resized as well. Also, when dimension objects are resized, if 
they are linked to an object, the object will also be resized.

Linear and radial dimensions

L (Length)

Changes length of the dimension object. Normally, the first reference point (the 
left end of a diameter or the center of a radius) remains fixed.

Select point

Allows you to select which reference point moves when you apply a new length.

Angular dimensions

A1°

Changes the angle of the dimension’s starting point, measured in relation to the 
X-axis.
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A2°

Changes the angle of the dimension’s ending point, measured in relation to the 
X-axis.

Ra (Radius)

Changes the radius of the dimension object.

Select point

Use of the Select Point button has no additional effect on this object.

Expand and contract objects
All MacDraft objects can be increased or reduced in size by multiplying or 
dividing the object’s dimensions by specified values or by percentage. You 
can choose whether or not to maintain the object’s proportions. The Expand/
Contract command in the Edit menu is used to resize objects in this way.

Expand

To resize an object using the Expand/Contract command

1.	 Select the object to be expanded. 

2.	 Choose Expand/Contract... from the Edit menu.

The Expand/Contract dialog appears.
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3.	 To maintain the object’s proportions, ensure that the Linked checkbox is on.

4.	 To change the object’s proportions, click the Linked checkbox to turn this 
option off.

5.	 Choose Percentage or Decimal Value from the pop-up menu.

6.	 Enter a value to multiply the X dimension of the object by.

Note: 100% and 1.0 is the original size of the object. To increase the size type a 
higher value than the original.

7.	 Enter a different value to multiply the Y dimension of the object by, if 
necessary.

8.	 Click the OK button.

9.	 The dimensions of the object are multiplied by the specified values and the 
object is expanded around its center point.

Note: The screen shot below shows a copy of the original shape in front of the 
expanded shape.
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Contract

To resize an object using the Contract command

1.	 Select the object to be contracted. 

2.	 Choose Expand/Contract... from the Edit menu.

The Expand/Contract dialog appears.

3.	 To maintain the object’s proportions, ensure that the Linked checkbox is on.

4.	 To change the object’s proportions, click the Linked checkbox to turn this 
option off.

5.	 Choose Percentage or Decimal Value from the pop-up menu.

6.	 Enter a value to multiply the X dimension of the object by.

Note: 100% and 1.0 is the original size of the object. To decrease the size type a 
lower value than the original.

7.	 Enter a different value to multiply the Y dimension of the object by, if 
necessary.

8.	 Click the OK button.

9.	 The dimensions of the object are divided by the specified values and the 
object is expanded around its center point.

Note: The screen shot below shows a copy of the original shape behind the 
contracted shape.
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Editing bitmap images
There may be occasions when you want to enlarge, reduce, distort or clip 
the shape of pictures or photos produced from a program such as Photoshop. 
MacDraft allows you to enlarge or reduce the size of a bitmap image without 
distorting the image; to change the size of a bitmap image in one direction only; 
and to clip an image.

Resizing bitmap images

To resize a bitmap image in one direction only

1.	 Select the bitmap image you want to resize.

2.	 Position the cursor on one of the edit handles in the middle of the bitmap’s 
bounding box, (that is, one of the handles on the top, bottom, left or right 
side).

3.	 Press and hold down the mouse button.

4.	 Drag until the bitmap image is the size you want.
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5.	 Release the mouse button. The image will be resized in the direction chosen.

To resize a bitmap image in two directions without maintaining proportions

1.	 Select the bitmap image you want to resize.

2.	 Position the cursor on one of the corner edit handles.

3.	 Press and hold down the mouse button.

4.	 Drag until the bitmap image is the size you want.

5.	 Release the mouse button. The image will be resized, in two directions, but it 
could be distorted.

To resize a bitmap image while maintaining its proportions

1.	 Select the bitmap image you want to resize.
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2.	 Position the cursor on one of the corner edit handles.

3.	 Hold down the Shift key, then press and hold down the mouse button.

4.	 Holding down the mouse button and the Shift key, drag until the bitmap 
image is the size you want.

5.	 Release the mouse button and the Shift key. The image will be resized, and 
its proportions maintained.

To resize a bitmap image using the Resize options

You can use the Resize & Position options in the Properties tab/ properties palette  
to change the size of an image in same way as other objects, by defining its 
physical width and height, dpi and pixel width and height.

Clipping bitmap images

To clip a bitmap image

1.	 Select the bitmap image you want to clip.

2.	 Position the cursor on one of the edit handles.

3.	 Hold down the Shift and Option keys, then press and hold down the mouse 
button.

4.	 Holding down the mouse button and the Shift and Option keys, drag to 
select a portion of the bitmap.



176Chapter 2 Creating and editing objects

5.	 Release the mouse button and the Shift and Option keys. The image will be 
clipped, and only the portion selected will be shown.

MacDraft doesn’t normally discard the unseen part of a cropped image; you can 
move the edit handles back out any time to reveal the unclipped image.

On the other hand, cutting a cropped image from a drawing, pasting it to the 
Clipboard, then copying it back into MacDraft will reduce the document’s size on 
disk, because the cropped data discarded during the cut/paste operation will no 
longer be stored.
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Notes: MacDraft does not allow cropping of grouped objects. You must ungroup 
any bitmap image you wish to crop.

•	 Some pixel maps and bitmaps, when ungrouped, become a set of several 
objects that together form one image. Each of these objects can be cropped 
individually.

•	 If a bitmap has a very low resolution (for example, if it has been resized to be 
much larger than it was originally), it may resize itself slightly during cropping. 
This is because its own pixels may be larger than the standard screen pixels. 
The image will expand or shrink so that none of its own large pixels are split by 
the cropped edge.

•	 MacDraft stores each pixel map only once in each document file. This means 
that you can copy a pixel map within a MacDraft drawing without increasing 
the drawing’s size on disk.

The Advanced tools PRO ONLY

The Advanced tools contain editing and object manipulation functions. There 
are tools to create fillets and chamfers, add handles to objects, break objects 
into their edges, extend lines to their intersections and automatically trim lines 
that overlap. This panel also provides many advanced tools such as the attach 
function, merge objects, cut, and mirror.

Displaying the Advanced tools  PRO ONLY

To display the Advanced tools

•	 Choose Show Left Panel from the View menu, or if in palette mode, select 
the Advanced Tools palette from the Window menu. 

•	 Choose left panel icon from the Show/Hide Panels toolbar item.

The Tools panel will appear and the Advanced tools are at the bottom, if in 
palette mode the Advanced Tools palette will appear. 
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Most of the tools in the Advanced tools are discussed in this section. The Mirror 
tool is discussed in Chapter 5 and the Link, Unlink and Unlink All tools are 
discussed in Chapter 4.

Adding and deleting handles  PRO ONLY

It is sometimes useful to add a handle to an object before editing it. Handles can 
be added to lines, square corner rectangles, polylines, polygons and freehand 
shapes.

Adding a handle

To add a handle to a shape

1.	 Click the Add/delete handle tool in the Advanced Tools panel/palette.

The cursor will turn into an arrow pointer with a plus sign attached to it. This 
shows you that you are in the add handle mode.

2.	 Position the tip of the pointer on the object’s border at the place you want a 
new handle and click it.

A new handle appears on the object at the point clicked.

You can drag the handle associated with the new vertex to reshape the object, 
just as you would any other handle.

Add/Delete Handles Attach/Join Break

Add Subtract Extend

Trim Manual Trim Fillet

Chamfer Mirror Link

Unlink Unlink All
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Note: When you add a handle to some shapes, minor (midpoint) handles will also 
be added.

Deleting a handle

Handles can also be deleted from objects. Sometimes this is a useful action 
before smoothing an object. When you delete a handle, the handle disappears and 
a straight line or curve (depending on the shape) will be drawn between the two 
handles that were the closest to the deleted handle.

To delete a handle

1.	 Click the Add/delete handle tool in the Advanced Tools panel/palette.

2.	 Press and hold down the Option key.

The cursor will turn into an arrow pointer with a minus sign attached to it. 
This shows you that you are in delete handle mode.

3.	 Position the tip of the pointer on the handle you want to delete and click it. 

The handle will be deleted.

Attaching and joining lines/objects  PRO ONLY

The Attach tool, in the Advanced tools, is used to join the edges of open objects 
together at their end points. For example, you can draw any combination of 
lines, polylines, open freehand shapes, curves or arcs, arrange them so vertices 
coincide, and finally attach them together to form a single open or closed object.

•	 If the edges of the combined objects are all straight line segments, the new 
object will be an ordinary polygon.
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•	 If any of the edges are curved, the new object will be a “metapolygon.”

Note: The objects to be attached together must be open. For example, you cannot 
attach two rectangles together. Closed objects such as rectangles, polygons or 
circles can be combined using the Add tool

Aligning objects to attach

When aligning the objects that are to be attached, the Snap to Object function 
can be helpful. The Snap To Object function allows you to align the vertex 
points of objects as you draw them. You can also accurately reposition the vertex 
points of objects so the vertex points coincide.

When you reposition (drag) vertex points, the object is normally resized. 
However, you can move a complete object by dragging a vertex point. This is an 
easy way of aligning vertex points.

To reposition an object by dragging a vertex point

1.	 Press and hold down the Option & Command key.

2.	 Position the cursor on the vertex point of one object that you want to align 
with a vertex point of another object.

3.	 Holding down the mouse button and Option & Command key, drag the 
vertex point to the other vertex point.

The first object will be moved rather than resized, and the vertex points will 
be accurately aligned.
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Attaching open objects together 

To attach open objects together

1.	 Align the vertex points of the objects you want to attach together.

Note: Edit handles are not shown on the vertex points that overlap. This shows that 
the vertex points are aligned.

2.	 Select the objects to attach.

3.	 Click the Join tool in the Advanced Tools panel/palette.

The objects will be joined together.

Breaking objects  PRO ONLY

You can break down some MacDraft objects into simpler objects using the Break 
tool in the Advanced Tools panel/palette.

Object components

Rectangles, polygons and polylines, spline or Bezier curve shapes, parallel-line 
objects and dimension objects can all be broken down into simpler components 
as detailed in the following list.
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Rectangles: Single lines

Round-corner rectangles (constant or proportional corners): Four single lines 
and four radial arcs.

Round-corner rectangles (elliptical corners): Four single lines and four 
elliptical arcs.

Polygons and polylines: Single lines.

Parallel lines (single): Single lines

Parallel polygons and polylines: Individual polygons and polylines.

Freehand objects: Single lines.

Spline and Bezier objects: Series of single-segment Bezier curves.

Dimension objects: Varies.

Metapolygons (objects with both curved and straight edges, created using 
the Add, Subtract or Attach tools): Each edge will become a separate object. 
For example, an object created by adding a circle and a polygon will break into a 
radial arc and several straight line segments.

Note: Once objects (other than polygons or polylines) are separated using the 
Break tool, they cannot be reassembled. The one exception to this is that the Undo 
command can reverse the Break tool’s effects immediately after its use.

Breaking an object into its component parts 

To break an object into its component parts

1.	 Select the object to be broken.

2.	 Click the Break tool in the Advanced Tools panel/palette.

The object will be broken down into simpler components.

Adding objects  PRO ONLY

You can use the Add tool in the Advanced Tools panel/palette to combine two 



183 Chapter 2 Creating and editing objects

objects together to form a single object.

When you add two overlapping objects, the edges that overlap disappear and 
the objects are fused together to form a single, composite object. You can 
apply a single fill, line weight, line style or set of object information to the new 
composite object.

If the edges of the combined objects are all straight line segments, the new object 
becomes an ordinary polygon.

If any of the edges are curved, the new object will be a “metapolygon”.

Adding two objects

To add two objects

1.	 Select the two overlapping objects you want to add together.

2.	 Click the Add tool in the Advanced Tools panel/palette.
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The selected objects will be added together.

Note: You cannot break the merged object into the original, individual components 
after you have merged them. However, you can use the Break tool to “disassemble” 
the added polygon or metapolygon into its component edges.

Subtracting objects  PRO ONLY

The Subtract tool is used to slice away part of one object with another object 
that lies above it.

The portion of the object under the cutting object will be removed. You can view 
the results by moving the cutting object to one side.

You can also use a straight line object to slice another object in two (this works 
even if the line doesn’t go all the way across the object).

If the edges of the cut object are all straight line segments, the new object will be 
an ordinary polygon.

If any of the edges are curved, the new object will be a “metapolygon”.
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Subtracting part of an object using another object 

To subtract part of an object using another object

1.	 Position the object to be used as the cutting object on top of the object to be 
cut into. If necessary, use the Arrange menu’s Bring to Front command. 
The cutting object must overlap part of the object to be cut into.

2.	 Select the cutting object and the object to be cut into.

3.	 Click the Subtract tool in the Advanced Tools panel/palette.

The portion of the object under the cutting object will be removed from that 
object. View the results by moving the cutting object to one side.

If the new object has all straight edges, it will be an ordinary polygon. If any of 
the edges are curved, the new object will be a “metapolygon”.

Note: The Subtract tool only works with two objects at a time.

Using a line to cut an object in two

If you use a line object and the Subtract tool to cut an object in two, the line 
only needs to cross part of the object. The Subtract tool automatically continues 
the cut straight across the rest of the object.

To use a line to cut an object in two

1.	 Position the line to be used as the cutting object on top of the object to be cut. 
If necessary, use the Arrange menu’s Bring to Front command.

The line must overlap part of the object to be cut; it doesn’t need to reach all 
the way across the object.

2.	 Select the line and the object to be cut.

3.	 Click the Subtract tool in the Advanced Tools panel/palette.
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The object under the cutting line will be sliced in two. You can view the 
results by moving the pieces and the cutting-line apart.

If the new object has all straight edges, it will be an ordinary polygon. If any of 
the edges are curved, the new object will be a “metapolygon”.

Extending lines  PRO ONLY

You can extend selected lines to various points on your drawing using the 
Extend tool.

There are a number of options available: you can extend two non-parallel lines to 
the point where they intersect; you can extend lines to make them intersect with a 
reference line; and you can extend lines to make them intersect with an existing, 
nonparallel line.

Extending two lines to a common intersection point 

To extend two lines to a common intersection point

1.	 Select the two non-parallel lines that you want to extend.

2.	 Click the Extend tool in the Advanced Tools panel/palette.

The two lines will be projected to the point at which they intersect.
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Note: In some cases, if one line is perpendicular to the other and the logical 
operation is to extend one line toward the other, MacDraft extends one line and not 
the other. If you select more than two lines and click the Extend icon, the Extend 
dialog appears. This allows you to extend lines toward a reference line or an 
existing line on the drawing. These options are discussed in the following pages.

Extending lines to intersect with a reference line

You can select one or more lines on a drawing then define an imaginary reference 
line to which you want to extend the lines. The lines to be extended can be 
parallel.

To extend lines to a reference line

1.	 Select the lines you want to extend.

2.	 Hold down the Option key (if only one, or more than two lines are selected, 
holding down the Option key is not necessary.)

3.	 Click the Extend tool in the Advanced Tools panel/palette.

The Extend dialog appears.

4.	 Release the Option key.

5.	 Ensure the ‘A reference line’ radio button is on.

6.	 Click the OK button.
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7.	 Without pressing and holding down the mouse button, move the cursor to the 
first position you wish to use to define the reference line.

If you move the cursor beyond the borders of the drawing area, the drawing 
will automatically scroll.

8.	 Press and hold down the mouse button. 

A dotted reference line appears.

9.	 Drag to define the reference line.

Note: If you hold down the Shift key while you drag, the line will snap in 45° 
increments.

10.	 When the reference line is in the correct position, release the mouse button. 
The lines will be projected toward the reference line, which will disappear.

Extending lines to intersect with a selection 

You can also extend selected lines toward an existing line or object on a drawing. 
The lines to be extended can be parallel to each other.

To extend lines toward an existing line on your drawing

1.	 Select the lines you want to extend.
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2.	 Press and hold down the Option key.

3.	 Click the Extend tool in the Advanced Tools panel/palette.

The Extend dialog appears.

4.	 Release the Option key.

5.	 Click the ‘A Selection’ radio button.

6.	 Click the OK button.

7.	 Position the tip of the pointer on the line to which you want the selected lines 
extended and click it.

If you move the cursor beyond the borders of the drawing area, the drawing 
automatically scrolls.

MacDraft will interpret the line you clicked as being infinite in length and 
extend the selected lines toward it.
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Trimming lines  PRO ONLY

The Trim tool is used to cause breaks in two intersecting lines at the point of 
intersection. When you trim a line, MacDraft adds a vertex point at the point of 
intersection. There are two trim choices: Automatic trim and Manual trim.

Trimming two intersecting lines 

To trim two intersecting lines

1.	 Select the two lines you want to trim.

2.	 Click either the Automatic Trim or Manual Trim icon on the Advanced 
Tools panel/palette.

•	 Automatic trim: MacDraft automatically removes the shorter pair of 
lines that result from the trim operation.

•	 Manual trim: MacDraft leaves all lines for you to remove if you wish.

The two lines will be broken at their point of intersection.
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Creating fillets  PRO ONLY

A two-line fillet is an arc of a given radius that is tangent to two line segments. 
There are many options for creating two-line fillets: you can specify the radius 
of the arc that results from the operation; you can indicate if you want to create 
a large or a small arc; and you can choose what to do with the line segments that 
are left over after the fillet operation is completed (for example, you can choose 
that MacDraft automatically removes the extra line segments, trims them and 
leaves them for you to remove or leaves them intact).

To create a two line fillet

1.	 Select two lines on the drawing.

2.	 Click the Fillet tool in the Advanced Tools panel/palette.

The Fillet Setup dialog appears.

3.	 Choose the Smaller arc or Larger arc from the first pop up.

4.	 Type in the desired radius for the arc.

5.	 Choose the Automatic trim, Manual trim or No trim 
from the next pop up to choose how MacDraft deals with 
the line segments after the fillet operation is completed.
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Note: The units for the values you enter are based on the size units that were 
set up in the Set Scale/Units dialog

•	 Automatic trim: The arc is drawn and the extra line segments are 
removed.

•	 Manual trim: The arc is drawn and the lines are broken at the points 
where they intersect with the arc. You can then select the extra line 
segments and remove them if you wish.

•	 No trim: The arc is drawn and the lines are left intact.
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6.	 Click the OK button.

If the two lines intersect each other, there are four possible quadrants in 
which the arc can be drawn. These are shown on your drawing.

7.	 Click the quadrant you want the arc to be drawn in. The fillet will be drawn 
as specified.

Creating chamfers  PRO ONLY

MacDraft’s Chamfer tool is used to create a beveled corner at the intersection of 
two lines.

There are several options for creating chamfers. You can specify the chamfer’s 
distance from the intersection point along each line; you can choose what to do 
with the line segments that are left over after the chamfer operation is completed 
(for example, you can choose to have MacDraft automatically remove the extra 
line segments, trim them and leave them for you to remove or leave them intact).

Creating a chamfer

You can create a chamfer between two lines either by selecting the lines, then 
clicking the Chamfer tool or by activating the Chamfer tool, then selecting the 
lines.

To create a chamfer

1.	 Select two lines on the drawing.
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2.	 Choose the Chamfer tool in the Tools panel.

3.	 Enter values in the Line 1 and Line 2 fields to specify how far along each line 
from the point of intersection (actual or projected) the chamfer is defined.

4.	 Click the Automatic trim, Manual trim or No trim radio button to choose 
how MacDraft deals with the line segments after the chamfer operation is 
completed.

•	 Automatic trim: The chamfer is drawn and the extra line segments are 
removed.

The Chamfer Setup dialog appears.

•	 Manual trim: The chamfer is drawn and the lines are broken at the 
points where they intersect with the chamfer. You can then select the 
extra line segments and remove them if you wish.
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•	 No trim: The chamfer is drawn and the lines are left intact.

5.	 Click the OK button.

The dialog closes. Chamfers drawn will now match the settings specified.

If no lines were selected before clicking the chamfer tool

1.	 Follow steps 2 to 5 previously.

2.	 The cursor will prompt you to select the first line. 

Click the first line.

3.	 The cursor will prompt you to select the second line. 

Click the second line.

4.	 The original lines will be extended or truncated to match the specified 
chamfer settings.

Note: Alternatively, select two lines on the drawing before you click the Chamfer 
tool in the Tools panel.

Object information  PRO ONLY

MacDraft allows you to associate names and other text information with objects 
or groups. For example, if an object or group represents a machine part with a 
particular name, stock number and manufacturer, you can name it and assign it 
the appropriate information. Then if you move or copy the shape, even into a 
library or other drawing, its name and other of information will remain with it.

Object information can be used as criteria for searches using the Find and 
Replace feature or for functions in a MacDraft report format.

Each object or group can have up to five text strings assigned to it. These text 
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strings are held in fields. The first field is always called “Name” and can be used 
to hold the name of the object. You can label the other four fields according to 
the information they will hold for your drawing’s objects. For example, if objects 
in a drawing need names, stock numbers and manufacturers (as mentioned 
above), you can define the second and third fields as “Stock Number” and 
“Manufacturer.” You can then enter that data for individual objects.

You can name data fields using the Edit Field Names command via the Data 
menu. You put data in fields for an object or group using the Properties panel.

Setting the field names  PRO ONLY

To set the field names for a drawing

1.	 Choose Edit Field Names from the Data menu or click the Edit Field 
Names button at the bottom of the Properties panel/ properties palette. 

The Edit Field Names dialog appears.

2.	 Double-click in a field name field and type the desired name.

Note: The field name can be up to 12 characters long and can contain any letters, 
numerals or punctuation marks (including spaces).

3.	 Press the Tab key to move to the next field.

4.	 Repeat steps 2 and 3 until all the field names required are entered, then click 
the OK button.
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The Edit Field Names dialog closes. You have changed the field name 
default for the drawing and any object that you enter data for will use the 
field names you have defined

Assigning object information  PRO ONLY

To assign object information to an item

1.	 Select an object or group.

2.	 Go to the Properties panel/ properties palette and scroll to the bottom of the 
properties to get to the object info text boxes.

3.	 Click in a field and enter the desired information.

4.	 Press the Tab key to move to the next field.

5.	 Repeat the steps 3 and 4 until all the required object information is entered.
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6.	 Click the OK button.

You have assigned one or more types of information to the item. You can now 
use the data as criteria for Find and Replace operations or manipulate them using 
the Report feature.

The item will retain its data if you copy and paste it, duplicate it or move it; even 
if you put it into a different MacDraft document or add it to a library.

Note: If you copy or move the item to a document with different field names, it will 
retain its object information, but the field names of the “host document” appear if 
you select the item.

Editing object information  PRO ONLY

You can change the object information of an object or group at any time.

To edit existing object information

1.	 Select the object or group to edit the object information for. 

2.	 Go to the Properties panel/ properties palette and scroll to the bottom of the 
properties to get to the object info text boxes.

3.	 Click in a field and edit the text as desired.

4.	 Repeat step 3 until all the data fields read as required

The object information for the selected item(s) has been revised.
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Object information for multiple objects  PRO ONLY

Object info for more than one item can be added to or edited, at the same time.

Note: When you edit the object information of multiple items, only the fields you 
edit will change.

Adding and editing object information

To add or edit object information for multiple items

1.	 Select the objects or groups (or both) to add the object information to, or edit 
object information for.

2.	 Go to the Properties panel/ properties palette and scroll to the bottom of the 
properties to get to the object info text boxes.

3.	 Add the desired information to the appropriate fields.

All the selected objects and groups will have the object information you 
specified. However, any object information fields you did not edit remain 
unchanged.

Replacing objects or object information  PRO ONLY

Object information can be replaced using the Find and Replace function.

Reversing changes
If you do something unintentionally or want to correct a mistake, MacDraft 
allows you to reverse certain actions. The Undo command reverses execution 
of the last action offering 100 levels of undo; the Redo command executes the 
previously reversed action; the Revert command returns you to previous saved 
versions of the document.

Undo

If you choose a command or perform an action and then wish that you had not 
done so, in most cases you can choose Undo to reverse the action or the effects 
of the command. There are 100 levels of Undo in MacDraft.
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To undo an action or command

•	 Open the Edit menu and choose Undo, or

•	 Press Command and Z on your keyboard.

If the action or command can be undone, the command will be listed beside 
Undo at the top of the Edit menu (Undo Delete after a deletion, for example).

If the action or command cannot be undone, Undo will be dimmed.

Redo

You can use the Redo command to re-execute an action or command that you just 
reversed using the Undo command. By using Undo and Redo you can experiment 
with your drawing and MacDraft’s features. For example, you could delete an 
object, observe the effect on your drawing, and choose Undo to reverse the 
deletion. If you then decided that the deletion produced the desired effect, you 
could choose Redo and the same object would be re-deleted.

To redo an action or command

•	 Open the Edit menu and choose Redo, or

•	 Press Command and Shift and Z on your keyboard.

The action or command you just reversed by choosing Undo will be listed 
beside Redo at the top of the Edit menu (Redo Delete after undoing a delete, for 
example).

Revert

If you execute a command that cannot be undone using the Undo command, 
or you make changes you are unable to delete but do not wish to save, you can 
eliminate any unsaved changes by reverting to the another saved version of your 
document.

To revert to a previously saved version of your document

1.	 Open the File menu and choose Revert To.

2.	 Choose Browse All Version... from the sub menu that appears.
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A screen appears showing all the different versions of the file that you can 
choose to revert to.

3.	 Choose the version of the file and click the Revert button.

Note: If you revert to a previously saved version of the document, all changes made 
since the last time it was saved will be deleted.

Drawing views
MacDraft offers various features for changing the view of your drawing. Using 
these features you can move the drawing in the document window so that you 
view a different part of the drawing, or you can zoom in or out on a portion of the 
drawing to see it in more detail or to see an overall view. Any view can be saved.

Changing the position of the drawing in the document window

To change the position of the drawing within the document window, you can 
scroll the drawing, use the Hand tool.

Top Tip: You can easily return to the top left corner of your drawing by using the 
Home View command via the View menu.

Scrolling

Scrolling in MacDraft drawings is accomplished just as it is in other Macintosh 
document windows by using the scroll bars at the edges of the windows. See 
your system documentation for details.

The Hand tool

The Hand tool provides an alternative method of moving the drawing within the 
document window.

To use the Hand tool

1.	 Click the Hand tool in the Drafting Tools panel/palette.
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The cursor turns into a hand.

2.	 Position the cursor over the drawing area, then press and hold down the 
mouse button.

3.	 Drag in any direction and the view moves with the hand.

4.	 Release the mouse button when the desired section of the drawing is shown 
in the document window.

Top Tip: Press the "h" key on the keyboard to select the Hand tool.

Zooming in or out on a drawing

When you work with a large document you may need to see the entire drawing at 
one time or you might need to obtain a close up view of a particular area so that 
you can add small details. MacDraft gives you the possibility to change the view 
of your drawing in either of these cases by providing features that allow you to 
zoom in or out of an area of the drawing. Zoom controls are provided via the 
Zoom tool in the Tool panel, by commands in the View menu and by a pop-up 
menu in the toolbar. There are also features that allow you to easily return to a 
preset or saved view.

Note: The current magnification of the drawing view is shown in the zoom pop-up 
in the toolbar. Also if you zoom out several consecutive times, and have text on 
your drawing, the text becomes too small to be displayed and only its edit handles 
will be shown.

Using the Zoom tool

•	 Click the Zoom tool in the Tool panel to select it.
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Zoom In

To use the Zoom tool to zoom in on an area of the drawing 

1.	 Select the Zoom tool from the Drafting Tools panel/palette.

The cursor will change to a magnifying glass with a plus sign inside it to 
show that you are about to increase the magnification of the drawing.

2.	 Position the cursor over the area of the drawing you wish to zoom in on and 
click. 

The magnification of the drawing view will be increased, and the view will 
be centered around the position of the cursor.

Zoom Out

To use the Zoom tool to zoom out on an area of the drawing

1.	 Select the Zoom tool from the Drafting Tools panel/palette.

2.	 Press and hold down the Option key.

The cursor will change to a magnifying glass with a minus sign inside it to 
show that you are about to decrease the magnification of the drawing.

3.	 Position the cursor over the area of the drawing you wish to zoom out on and 
click.

The magnification of the drawing view will be decreased one level, and the 
view will be centered around the position of the cursor.

4.	 Continue clicking to zoom out further.

Marquee zoom

The Zoom tool can also be used to perform marquee zooms.

To use the Zoom tool to perform a marquee zoom

1.	 Select the Zoom tool from the Drafting Tools panel/palette.

The cursor will change to a magnifying glass with a plus sign inside it to 
show that you are about to increase the magnification of the drawing.
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2.	 Position the cursor over the drawing.

Press and hold down the mouse button, and drag over the area you want to 
zoom in on.

The inner rectangle shown in the screen shot above is the area selected with 
the Zoom tool. The outer rectangle represents the actual area that will be 
shown in the document window when the mouse button is released.

3.	 Release the mouse button to display the portion of the document selected.

Zoom commands

The Zoom commands are found in the Zoom submenu in the View menu.

•	 Zoom out: Choose Zoom Out from the View menu.

The magnification of the drawing view will be decreased.

•	 Zoom in: Choose Zoom In from the View menu.

The magnification of the drawing view will be increased.

Zoom pop-up menu

The current magnification of the drawing view is shown in the toolbar. If you 
click this area, a magnification pop-up menu appears. You can also type the 
percentage of zoom you would like to use.
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•	 Choose a magnification value from this pop-up menu to zoom in or out on 
your drawing.

Restore previous zoom

The Restore Previous Zoom function allows you to return to the previous 
magnification of your drawing, regardless of the current magnification.

To return to the previous magnification

•	 Choose Restore Previous Zoom from the View menu.

The view will zoom in or out to the previous magnification.

Note: You can use this command to alternate between two magnification levels. 
For example, you could do some detailed editing at high magnification, use Restore 
Previous Zoom to examine the whole image, then use Restore Previous Zoom again 
to zoom back in and continue the detailed work.

Controlling the appearance of lines/borders in zoomed-in views  PRO ONLY

When you zoom in on objects, you can decide if you want to have lines and 
borders become magnified in proportion to the current zoom factor.

Normally, lines and borders are not magnified. For example, a 3-pixel line 
appears as a 3- pixel line even in a view magnified to 200%. However, you can 
choose that lines and borders should be magnified when you zoom in on them. 
For example, a 3-pixel line will appear to be 6 pixels in width if you zoom in to 
200% magnification.

The command that controls the appearance of lines and borders in zoomed in 
views is Zoom Line Weights in the Options menu.
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To make line weights appear larger in zoomed-in views than in the normal view 

•	 Choose Zoom Line Weights in the Options menu.

A check mark appears by the menu item, and line weights will be magnified 
in zoomed in views.

To make line weights remain constant regardless of the current magnification factor

•	 If there is a check mark against Zoom Line Weights in the Options menu, 
choose Zoom Line Weights.

The check mark will be removed, and lines and borders will not be magnified 
by the current zoom factor.

Home view

The view which appears on the screen when you first open a MacDraft document 
is called the Home View. This view shows the unmagnified view of the upper 
left corner of the document.

To display the home view

•	 Choose Home View from the View menu.

An unmagnified view of the upper left corner of the document is shown.

1:1 tool

You can easily return to an unmagnified view of the current area of the document 
by using the 1:1 tool in the Tool panel. This is useful if you have zoomed in on a 
detail and now want to see it at single magnification, but don’t want to return to 
the upper left corner of the drawing as when using the Home View command.

To return to an unmagnified view of the current working area 

•	 Click the 1:1 tool on the Drafting Tools panel/palette.
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The view will be changed to an unmagnified view of the current area.

Saved views  PRO ONLY

You can save any view of your drawing. Saved views can be of any part of the 
image and at any magnification. This feature allows you to move quickly to and 
from different areas of your drawing and different magnifications.

To save a view  PRO ONLY

1.	 Display the view you want to save. 

2.	 Choose Save View from the View menu.

The Save View dialog appears.

3.	 Enter a name for the view.

By default, MacDraft will assign the Command key equivalent to the first 
five views you save. This means that you will be able to display a saved view 
by pressing down the Command key and typing the number that corresponds 
to the saved view; Command-5, Command-6 and so on.

4.	 If you don’t want the Command key equivalent to be assigned to a view, 
click the Use checkbox to turn this option off.

5.	 Click the OK button to save the view.

The name of the view is added to the bottom of the View menu.

Displaying saved views  PRO ONLY

You can display a previously saved view in two ways: by choosing the view’s 
name from the View submenu or by using a Command key equivalent (this 
method can only be used for up to five views).       
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To display a saved view

•	 Choose the name of the desired view from the View menu.

Deleting saved views  PRO ONLY

When you save a view, the commands Delete View and Delete All Views are 
added to the View menu.

To delete a saved view

1.	 Open the Delete View submenu in the View menu.

2.	 Choose the name of the view you want to delete from the Delete View 
submenu. 

The saved view will be deleted. If the view had a Command key equivalent 
associated with it, that number will now be available for use again

To delete all views

1.	 Select Delete All Views from the View menu.

An alert appears asking you to confirm that you want to delete all views.

2.	 Click the Delete button to delete all views.

Interrupting the screen redraw  PRO ONLY

If you are working on a large, complicated drawing and you perform an action 
(such as zooming) that requires the screen to be redrawn, it may take some time 
for the screen redraw to be completed. If you decide that you want to interrupt 
the screen redraw before it is completed, you can do so.

•	 To interrupt the screen redraw: Press and hold down the Command key 
and the period (.) key

•	 To redo the screen redraw: Press and hold down the Option key and click 
the Pointer tool icon in the Tool panel.
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Chapter 3
Changing the appearance of 

objects

In many drawings, you may want to change the appearance of objects to help 
differentiate between them. You can change their appearance by filling objects 
with washes (solid fills), gradients and patterns; by drawing lines and object 
borders with different colors, patterns, line weights, line styles and pen styles; by 
drawing lines with different end marks; and by choosing different positions for 
object borders.

You can define attributes for fills and lines that will be applied to all objects you 
draw or you can change the attributes of existing objects.

When the application is launched, the default values are white fill, black pen, no 
pattern, line weight 1 point, plain line style.

Object Attributes
Most attributes are chosen from various pop-up menus in the Attribute section 
of the Properties panel/ properties palette. Others are chosen from the options 
menu or the Swatches panel.

The Attributes options

Displaying the Attribute options

To open the Attribute options

•	 Go to the Properties panel (right panel, first tab)/ properties palette and the 
Attribute Options for colors, patterns, gradients, line weights, line styles and 
end marks will be displayed at the top of the panel.
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Selecting attributes using the Attribute options

Selecting attributes is discussed in detail in later sections of this chapter, but in 
general: 

•	 Change the attributes of existing objects by selecting the object, opening the 
appropriate menu in the Attribute options, then making your choice.

•	 Change the drawing’s default attributes (the fill, line weight and so on that 
will be applied to all new objects you draw) by making sure nothing is 
selected, then opening the appropriate menu and choosing an attribute.

Default attributes

The attributes that you can select for objects before you draw them are Fill color 
and pattern, and Parallel line fill color and pattern. The pen attributes (that is, 
the attributes associated with lines and object borders) that you can define for 
objects before you draw them include pen style, color and pattern, line weight 
(thickness), line style (solid and dashed lines), end marks (symbols at the ends of 
lines), and border position. The option for each of these attributes that is currently 
active is called the ‘default attribute’.

The current default fill and pen attributes appear on the lines and borders of the 
objects you draw.

Note: You cannot apply both a fill color and fill pattern to an object unless you 
define a colored fill pattern.
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When nothing is selected on the drawing, the default attributes are shown in the 
Attribute options in the Properties panel/ properties palette. When an object is 
selected, the Attribute options show the attributes of that object.

Setting default attributes

To change the current default attributes for fills and lines

1.	 Activate the Pointer tool on the Drafting Tools panel/palette.

Note: Make sure that there is nothing selected on the drawing.

2.	 From the pop-up menus in the Attribute options, choose the fill and/or line 
attributes you want to apply to all objects you create.

The attributes you choose will automatically be applied to all objects until 
you make other choices for the default attributes.

Selecting attributes for specific objects

You can change the fill and line attributes for selected objects without affecting 
the default fill and line attributes.

To define the fill and/or line attributes for selected objects

1.	 Select the object or objects you want to change.
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2.	 From the pop-up menus in the Attribute options, choose the fill and/or line 
attributes you want to apply to the selected objects.

The chosen attributes will be applied only to the selected objects. The default 
attributes will not be changed.

Using colors
With MacDraft you can use color in a variety of ways: to fill objects with solid 
colors, to fill objects with color patterns, to draw the borders of objects and to 
color text. The use of solid colors is referred to as a “wash,” and the use of colors 
to draw lines and object borders is referred to as the “pen color.” The color 
you choose for the pen is applied to text as well. You can also use colors in fill 
patterns and to fill the gaps between parallel lines.

The color table

The color table contains the colors used in a document. Each new document 
contains a number of preset colors, which you can edit and any new colors 
you create. The preset colors and the colors you edit or create are stored in the 
document’s color table.

The color table is represented on your screen as a submenu that shows all the 
preset colors and all the colors that have been created and used in the document.

The colors in the color table can be chosen from the Attribute options in the 
Properties panel/ properties palette and can be edited or new ones created via 
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the Swatches panel, you can also apply colors, patterns and gradients via the 
swatches panel but this will be discussed in more detail later. 

Note: Any colors created or edited in the Swatches panel will be available for 
selection in the attributes submenu in the Attribute options. You cannot use the 
Swatches panel to apply attributes, only to edit and create them. 

In addition when you paste objects from a different document that has colors that 
are not present in the target document’s color table, the colors from the source 
document are preserved in the objects that are pasted, and will be added to the target 
document’s color table.

Editing colors

You can edit the existing colors in the color table to add your own colors.

When you edit an existing color, the existing color is replaced with the new color 
in the color table.

Note: If you edit a color that has been used in the document, the objects that contain 
the edited color will be updated with the new color.

To edit a color in the color table

1.	 Open the Swatches panel and locate the color you want to edit.

2.	 Double-click the mouse button on the color you want to edit or select the 
color with a single mouse click and choose Edit from the options menu (the 
Gear symbol).
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The Color Picker dialog appears.

3.	 Use the controls in the Color Picker dialog to choose a new color.

Note: The Color Picker dialog is specific to the operating system. For full details on 
how to use it refer to the operating system documentation.

4.	 When you have chosen a new color, close the Color Picker dialog using the 
red X in the top left hand corner of the dialog and return to MacDraft.

The new color you chose replaces the color you selected to edit.
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New colors

You can create new colors in the Swatches panel/ palette to add your own colors.

When you add a new color, it will be added to the Attributes submenu.

To create a new color

1.	 Open the Swatches panel and click the plus (+) symbol in the bottom left 
hand corner.

A submenu will appear.

Select New Color from the submenu and the Color Picker dialog appears

2.	 Use the controls in the Color Picker dialog to choose a new color.

3.	 When you have chosen a new color, close the Color Picker dialog using the 
red X in the top left hand corner of the dialog and return to MacDraft.
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The new color you chose is appears in the Swatches panel and is available 
for selection the Attributes pop-up.

Duplicating colors

You can duplicate existing colors in the Swatches panel/ palette to add your own 
colors. Duplicating a color is a good when you want to get a new color close to 
the existing one.

When you duplicate a color and create a new one, it will be added to the 
Attributes submenu.

To duplicate a new color

1.	 Open the Swatches panel/ palette and select the color you want to duplicate 
with a single mouse click.

2.	 Choose Duplicate from the options menu (the Gear symbol).

The Color Picker dialog appears.

3.	 Use the controls in the Color Picker dialog to choose a new color.
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4.	 When you have chosen a new color, close the Color Picker dialog using the 
red X in the top left hand corner of the dialog and return to MacDraft.

The new color you chose is appears in the Swatches panel and is available 
for selection the Attributes pop-up.

Object fill color

You can use a solid color to fill the interiors of objects. Filled objects are opaque 
and you can select them by clicking their borders or anywhere within them. If a 
filled object is on top of another object, it hides the object beneath it from view.
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Selecting the fill color

To select the fill color

1.	 Open the Fill Color pop-up menu in the Attribute options section of the 
Properties panel/ properties palette.

2.	 Locate the fill color you want to use and click the mouse button to select it.

The selected fill color will be shown on the color picker in the Attribute 
options.

Note: If you choose "/" (for No fill) from the Fill Color submenu as the current fill 
color, the objects you draw will be wire frame shapes.

You must draw polylines, freehand lines and curves with No fill if you want end 
marks to appear on the lines

You can set the fill color before or after you draw the object.

Applying a Fill Color from Swatches

You can now apply a color to an object directly from the Swatches Panel/ Palette. 

To draw an object with a selected fill color

1.	 Select the object you wish to apply a color from the swatches panel/ palette 
to. 

2.	 Open the swatches panel/ palette. 
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3.	 Click a color to select it.

4.	 Right Click the color. 

5.	 Choose Apply to Fill and the object will now have its fill set to the desired 
color. 

Drawing an object with a selected fill color

To draw an object with a selected fill color

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired fill color from the Fill Color pop-up menu in the Attribute 
options in the Properties panel/ properties palette.

3.	 Draw an object.

4.	 The object will be drawn with the specified fill color.

Note: The chosen fill color will be used for objects until you choose another fill 
color as the default.

Changing the fill color of an existing object

To change the fill color of an existing object

1.	 Select the object you want to change the fill color of in your document.

2.	 Select the desired fill color from the Fill Color pop-up menu in the Attribute 
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options in the Properties panel/ properties palette.

The fill of the selected object will be changed to reflect the chosen fill color.

Parallel fill color

MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and 
closed parallel polygons) can include fill colors (including No Fill) between their 
component edges.

Note: In addition to parallel fills, parallel objects can also have pen colors, patterns 
and object fills.

Selecting the parallel fill color

To select the parallel fill color

1.	 Open the Parallel Fill Color pop-up menu in the Attribute options in the 
Properties panel/ properties palette.
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2.	 Select the desired parallel fill color. The selected parallel fill color will be 
shown on the color picker in the Attribute options.

You can change the parallel fill color before or after you draw the parallel 
line object.

Drawing a parallel line object with a selected fill color

To draw a parallel line object with a selected fill color

1.	 Return to the pointer mode, by selecting the Pointer tool in the Tools panel. 
(make sure nothing is selected in the document.)

2.	 Select the desired fill color from the Parallel Fill Color pop-up menu in the 
Attribute options in the Drafting Tools panel/palette.

3.	 Draw a parallel line object.

The object will be drawn with the specified fill color.

Note: The chosen parallel fill color will be used for objects until you choose another 
parallel fill color as the default.

Changing the fill color of an existing parallel line object 

To change the fill color of an existing parallel line object

1.	 Select the parallel line object to change its fill color.

2.	 Choose the desired parallel fill color from the Parallel Fill Color pop-up 
menu in the Attribute options in the Properties panel/ properties palette.
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The fill of the selected parallel line object will be changed to reflect the 
chosen fill color.

Pen color

This section describes how to use colors to draw lines, borders and text. You use 
the Pen Color pop-up menu in the Attribute options to choose pen colors. You 
can use different pen colors to help distinguish between objects.

Selecting the pen color for lines, borders and text

To select the pen color

1.	 Open the Pen Color pop-up menu in the Attribute options in the Properties 
panel/ properties palette.

2.	 Choose the desired pen color. The selected pen color will be shown on the 
color picker in the Attribute options.

Note: If you choose "/" (for No ink) from the Pen Color submenu as the current pen 
color, the lines, borders or text you draw will be invisible. Edit handles appear on 
selected objects drawn with no ink, but the lines, borders or text will not appear on 
the screen or on printed drawings.

You can change the pen color before or after you draw an object or enter text.
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Drawing a line or object, or entering text, with a selected pen color

To draw a line or object, or enter text, with a selected pen color

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired pen color from the Pen Color pop-up menu in the 
Attribute options in the Properties panel/ properties palette.

3.	 Draw a line or object or enter the text.

The line, object or text will be drawn with the specified pen color.

Note: The chosen pen color will be used for lines, borders and text until you choose 
another pen color as the default.

Changing the pen color of an existing line, object or piece of text 

To change the pen color of an existing line, object or piece of text

1.	 Select the line, object or text to change the pen color of.

2.	 Choose the desired pen color from the Pen Color pop-up menu in the 
Attribute options in the Properties panel/ properties palette.

The line or border of the selected object, or the selected text, will be changed 
to reflect the chosen pen color.
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Showing and hiding fills

You can choose to hide fills, including colors and patterns, on your drawing. 
When you turn fills off, only the borders of filled objects appear.

To hide line fills

•	 Open the Options menu and choose Hide Fills.

Objects appear as wire frame shapes, and a check mark appears next to the 
Hide Fills command.

To display fills

•	 Open the Options menu and choose Hide Fills again.

Objects will be drawn with their respective fills, and the check mark 
disappears from next to the Hide Fills command.

Using patterns
Fill patterns provide an effective way to distinguish between objects. Two 
reasons you might want to use different fill patterns within a drawing would be 
to improve its aesthetics or to add meaningful information to the drawing. In a 
technical drawing, an architect or engineer might use a variety of fill patterns and 
inks to differentiate between various object types or textures within the drawing. 
MacDraft offers a selection of standard fill patterns to complement your drawing. 
You can use the existing patterns, customize them or create your own.

Editing patterns

The edit patterns feature allows you to change the patterns available in the 
pattern fill submenus from the Attribute options in the Properties panel. When 
a pattern is edited, the pattern fill submenus will be updated to show the new 
pattern, and the new pattern will be saved with the document. If a pattern that 
has been used to fill objects is edited, the objects will be changed to reflect the 
revised pattern. You can also duplicate and create new patterns, which will be 
added to the bottom of the available patterns.
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The Edit Pattern dialog

To open the Edit Pattern dialog

1.	 Open the Swatches panel/ palette and locate the pattern you want to edit.

2.	 Double-click the mouse button on the pattern you want to edit or select the 
pattern with a single mouse click and choose Edit from the options menu 
(the Gear symbol).

The Edit Pattern dialog appears.
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The edit pattern field

The large box in the center of the Edit Patterns dialog is the edit pattern field. It 
shows a magnified view of the bits that make up the pattern. The pattern is edited 
within this field.

Pattern preview

The box in the upper left corner of the Edit Pattern dialog shows a preview of the 
pattern as it appears on the drawing. It is updated as the pattern is edited in the 
Edit Pattern field. 

The pattern grid

The pattern grid can be defined as 8 x 8, 16 x 16, 32 x 32, 64 x 64, 128 x 128, 
256 x 256 or 512 x 512 grid squares.

To specify the pattern grid

•	 Select 8 x 8, 16 x 16, 32 x 32, 64 x 64, 128 x 128, 256 x 256 or 512 x 512 
from the grid size pop-up menu.

Scale with Scale turned off

Grid Size Increased

If the Scale box is turned off, as the grid size is increased, the pattern is replicated 
to fill the new area.

For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 
16, then to 32 x 32. At each stage, four copies of the contents of the Edit Pattern 
field are used to fill the new grid. Notice that although the contents of the Edit 
Pattern field change, the Pattern Preview field remains the same.
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Grid size decreased

If the Scale box is turned off, as the grid size is decreased, the pattern is divided 
and applied to the new area.

For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 
x 16, then to 8 x 8. At each stage, the contents of the top left quarter of the Edit 
Pattern field are used to fill the new grid.

Scale with Scale turned on

Grid Size Increased

If the Scale box is on, as the grid size is increased, the pattern in the Edit Pattern 
field remains the same, but is divided up into more squares.

For example: In the dialogs below, the grid size is increased from 8 x 8 to 16 x 
16, then to 32 x 32. At each stage, the contents of the Edit Pattern field remain the 
same, but the pattern is divided into more grid squares. Notice that the contents 
of the Pattern Preview field are scaled up at each stage.

Grid size decreased

If the Scale box is on, as the grid size is decreased, the pattern in the Edit Pattern 
field remains the same but is divided into less grid squares. Colors are averaged 
out in this process.
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For example: In the dialogs below, the grid size is decreased from 32 x 32 to 16 
x 16 then to 8 x 8. At each stage, as four grid squares are combined to make one 
new grid square, the average color of the four squares is used for the new square. 
Notice that the contents of the Pattern Preview box are scaled down at each stage.

Color mode

Patterns can be edited in two modes: black and white, and color/grayscale.

Pattern editing tools

The tools at the left of the pattern edit field are used to edit the current pattern.

   The Overlay tool

The Overlay tool is used to apply a pattern over the one in the Edit Pattern field. 

To apply a pattern over the one in the Edit Pattern field

1.	 Click the Overlay tool and hold down the mouse button. The Fill Patterns 
submenu appears.

2.	 Holding down the mouse button, drag the cursor over the pattern you wish to 
apply, and release the mouse button.
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3.	 The selected pattern will be applied over the current contents of the Edit 
Pattern field using the current color.

   The Invert tool

The Invert tool is used to invert the color of the bits in the Edit Pattern field. In 
black and white mode, this action will change all the black bits to white and all 
the white bits to black. If color bits are included in the pattern, when the Invert 
tool is used, each bit will be changed to the color on the opposite side of the color 
wheel to the original color, and the brightness will also be inverted. For example, 
a light pink color will become a dark green/blue, while a dark red will become a 
light green/blue.

To invert the color of the bits in the Edit Pattern field 

•	 Click the Invert tool.

The color of the bits in the Edit Pattern field will be inverted

   The Flip horizontal tool

The Flip Horizontal tool is used to flip the pattern in the Edit Pattern field 
around the vertical axis.

To flip the pattern in the Edit Pattern field around the vertical axis 

•	 Click the Flip Horizontal tool.

The pattern will be flipped.
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   The Flip vertical tool

The Flip Vertical tool is used to  flip the pattern in the Edit Pattern field around 
the horizontal axis.

To flip the pattern in the Edit Pattern field around the horizontal axis 

•	 Click the Flip Vertical tool.

The pattern will be flipped.

   The Pencil tool

The Pencil tool is used to add or delete individual bits or series of bits, or to draw 
lines in the Edit Pattern field.

To add bits to the Edit Pattern field one at a time

1.	 Click the Pencil tool and move the cursor over the Edit Pattern field.

2.	 Click the Edit Pattern field to add a square of the current color.
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To add a series of bits

1.	 Click in the Edit Pattern field and drag, holding down the mouse button.

2.	 Bits showing the current color will be added to the pattern as you drag.

3.	 Release the mouse button when you are finished.

To draw lines

•	 Constrain the movement of the Pencil tool to a horizontal or vertical 
direction by holding down the Shift key while you drag. To delete black bits 
in Black and White mode

•	 Select the Pencil tool and click the black bits you want to delete. To delete 
color bits in the Color mode

•	 Hold down the Command key, then click the color bits to be deleted. 

The Eye dropper tool

You can use the Option key to change the pencil tool to an eye dropper, and use 
this to choose the color of any bit in the Edit Pattern field as the current color.

1.	 Select the Pencil tool, hold down the Option key and move the pointer into 
the Edit Pattern field.

The pointer will change to an Eye Dropper tool.

2.	 Click the Eye Dropper tool on the bit of the color you require to be the 
current color.

The current color will be changed to reflect your choice.

Note: Release the Option key to start using the color you have picked.

   The Finger tool

The Finger tool is used to blend together the current color and the color of any 
bit in the Edit Pattern field, or the colors of adjacent bits in the Edit Pattern 
field. 
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To blend the current color with the color of any bit in the Edit Pattern field

1.	 Select the Finger tool.

The Finger cursor shows the current color, which is the first of the two 
colors to be used in the blending process.

2.	 Move the cursor over the Edit Pattern field and click the bit with which you 
want to blend the current color.

The bit clicked will change to a new color that is the average of the Finger 
cursor color and the color of the bit clicked. The Finger cursor color will 
also be updated to show the new color.

To blend the colors of a series of bits

1.	 Select the Finger tool.

2.	 Click in the Edit Pattern field and, holding down the mouse button, drag the 
Finger cursor across bits of varying colors.

The average of the color values of the Finger cursor color and the bits 
dragged across will be calculated, and applied to the bit.

Note: If you hold down the Shift key while dragging, the movement of the Finger 
cursor will be constrained to a horizontal or vertical direction.

When you release the mouse button, the Finger cursor shows the color last 
applied to a bit. To reset the Finger cursor color to the current color, click the 
Finger tool icon again. To reset the Finger cursor color to a color in the pattern, 
hold down the Option key and click one of the colors in the pattern.
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Note: The Finger tool can be selected in Black and White mode, but the mode is 
automatically changed to color.

   The Paint Bucket tool

The Paint Bucket tool is used to change bits in the Edit Pattern field to the 
current color. 

To change bits in the Edit Pattern field to the current color

1.	 Click the Current Color button and choose the color from the Pattern 
Color pop-up menu.

2.	 Click the Paint Bucket icon and then click a bit in the Edit Pattern field.

The bit clicked and all bits of the same color connected to it, are changed to 
the current color.

3.	 If you hold down the Option key with the Paint Bucket tool selected, the 
tool will be changed to the Eye Dropper tool. Click a bit in the Edit Pattern 
field with the Eye Dropper tool to select the color of that bit as the current 
color.

   The Hand tool

The Hand tool is used to move the pattern within the Edit Pattern field.

To move the pattern within the Edit Pattern field

1.	 Click the Hand tool and move the cursor over the Edit Pattern field.

2.	 Holding down the mouse button, drag the pattern to reposition it within the 
Edit Pattern field, and release the mouse button.
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   The Black and White tool

This tool is used to convert patterns to black and white.

To convert patterns to black and white

•	 Click the Black and White tool.

Any bits used in the pattern that are more than 50% saturated will be changed 
to black. Bits that are less than 50% saturated will be changed to white.

   The Current Color tool

You can work with only one color at a time while editing patterns. The selected 
color is called the current color and is shown in the tool panel of this dialog. With 
this tool you open the Pattern Color menu.

To change the current color

1.	 Click the Current Color button and hold down the mouse button.

The Pattern Color pop-up menu appears

2.	 Holding down the mouse button, drag to select the color you want to use, and 
release the mouse button.

The selected color will be shown on the Current Color tool. This color will 
be used for pattern editing until another color is chosen.
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Note: The current color is always black when you operate in black and white mode.

Choosing a color which is not available in the Pattern Color menu

The Other button in the Pattern Color pop-up menu allows you to select colors 
that are not available in the Pattern Color menu.

To choose a color which is not available in the Pattern Color menu

1.	 Click the Current Color button and hold down the mouse button. 

The Pattern Color pop-up menu appears

2.	 Click the Other button.

The Color Picker dialog appears.
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3.	 Select a color from the Color Picker.

4.	 When you have chosen a new color, close the Color Picker dialog using the 
red X in the top left hand corner of the dialog and return to pattern editor.

The color selected will be shown on the Current Color button.

Clearing the current pattern

At times, you may want to clear all the bits from the Edit Pattern field and start 
afresh rather than alter an existing pattern.

To clear all the bits from the Edit Pattern field

•	 Click the Clear button and the field will be cleared.

Filling the entire field

If you need to fill the entire field with the current color you can do this with one 
mouse click using the Fill button.

To fill the entire field

•	 Click the Fill button.

The entire Edit Pattern field will be filled with the current color. 

Zoom

If you need to zoom in or out of the pattern you can do this using the zoom pop-
up menu.

To zoom in or out of the pattern

•	 Click the Zoom pop-up menu and choose the desired zoom level and the 
Edit Pattern field will zoom to your selection. 

Revert

•	 Click the Revert button to return to the pattern you originally selected to 
edit. Any changes you have made will be lost.
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Undo

•	 Click the Undo button to remove the effects of your last action only.

Cancel

•	 Click the Cancel button to close the Edit Pattern dialog and return to your 
MacDraft drawing without making any changes to the fill patterns.

OK

•	 Click the OK button to close the Edit Pattern dialog and return to your 
MacDraft drawing accepting the changes you have made to the selected fill 
pattern. The fill submenu will be updated to show the new pattern, and the 
new pattern will be saved with the document. If a pattern that has been used 
to fill objects is edited, the objects will be changed to reflect the revised 
pattern.

New patterns

You can create new patterns in the Swatches panel/ palette to add your own 
patterns.

When you add a new pattern, it will be added to the Attributes submenu.

To create a new pattern

1.	 Open the Swatches panel and click the plus (+) symbol in the bottom left 
hand corner and a submenu will appear.

Select Pattern from the submenu and the Edit Pattern dialog appears

2.	 Use the controls in the Edit Pattern dialog to create a new pattern.

3.	 When you have created your new pattern click the OK button

The new pattern you created appears in the Swatches panel and is available 
for selection the Attributes pop-up.

Duplicating patterns

You can duplicate existing patterns in the Swatches panel/ palette to add your 



238 Chapter 3 Changing the appearance of objects

own patterns. Duplicating a pattern is a good when you want to get a new pattern 
close to the existing one.

When you duplicate a pattern and create a new one, it will be added to the 
Attributes submenu.

To duplicate a new color

1.	 Open the Swatches panel/ palette and select the pattern you want to duplicate 
with a single mouse click.

2.	 Choose Duplicate from the options menu (the Gear symbol).

The Edit Pattern dialog appears.

3.	 Use the controls in the Edit Pattern dialog to create a new pattern.

4.	 When you have created your new pattern click the OK button

The new pattern you created appears in the Swatches panel and is available 
for selection the Attributes pop-up.

Object fill patterns

You can use a pattern to fill the interiors of objects. Filled objects are opaque and 
you can select them by clicking their borders or anywhere within them. If a filled 
object is on top of another object, it hides the object beneath it from view.

Selecting the fill pattern

To select the fill pattern

1.	 Open the Fill Pattern pop-up menu in the Attribute options section of the 
Properties panel/ palette.

2.	 Locate the fill pattern you want to use and click the mouse button to select it.

The selected fill pattern will be shown on the color picker in the Attribute 
options. You can set the fill color before or after you draw the object.
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Drawing an object with a selected fill pattern

To draw an object with a selected fill pattern

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired fill pattern from the Fill Pattern pop-up menu in the 
Attribute options in the Properties panel/ palette.

3.	 Draw an object.

The object will be drawn with the specified fill pattern.

The Fill Indicator box in the lower left corner of the window will change to 
indicate the pattern you chose.

Note: The chosen fill pattern will be used for objects until you choose another fill 
pattern as the default.

Changing the fill pattern of an existing object 

To change the fill pattern of an existing object

1.	 Select the object you want to change the fill pattern of in your document.

2.	 Select the desired fill pattern from the Fill Pattern pop-up menu in the 
Attribute options in the Properties panel/ palette.
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The fill of the selected object will be changed to reflect the chosen pattern.

Parallel fill pattern

MacDraft’s parallel-line objects (single parallel lines, open parallel polylines and 
closed parallel polygons) can include fill patterns (including No Fill) between 
their component edges.

Note: In addition to parallel fills, parallel objects can also have pen colors and 
patterns, and object fills.

Selecting the fill pattern

1.	 Open the Parallel Fill Pattern pop-up menu in the Attribute options section 
of the Properties panel/ palette.

2.	 Locate the fill pattern you want to use and click the mouse button to select it.
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The selected fill pattern will be shown on the color picker in the Attribute 
options. You can set the fill color before or after you draw the object.

Drawing a parallel line object with a selected fill pattern

To draw a parallel line object with a selected fill pattern

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired parallel fill pattern from the Parallel Fill Pattern pop-up 
menu in the Attribute options in the Properties panel/ properties palette.

3.	 Draw a parallel line object.

The object will be drawn with the specified fill pattern.

Note: The chosen parallel fill pattern will be used for objects until you choose 
another parallel fill pattern as the default.

Changing the fill pattern of an existing parallel line object

To change the fill pattern of an existing parallel line object

1.	 Select the parallel line object to change the fill pattern of.

2.	 Select the desired parallel fill pattern from the Parallel Fill Pattern pop-up 
menu in the Attribute options in the Properties panel.

The fill of the selected parallel line object will change to reflect the chosen 
fill pattern.
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Pen Pattern

This section describes how to use patterns to draw lines and borders. Use the Pen 
Pattern pop-up menu in the Attribute options to choose pen patterns. You can use 
different pen patterns to help distinguish between objects.

Selecting the pen pattern for lines and borders 

To select the pen pattern

1.	 Open the Pen Pattern pop-up menu in the Attribute options in the 
Properties panel/ properties palette.

2.	 Choose the desired pen pattern. The selected pen pattern will be shown on 
the picker in the Attribute options.

Note: If you choose "/" (for No ink) from the Pen Pattern submenu as the current 
pen pattern, the lines and borders you draw will be invisible. Edit handles appear on 
selected objects drawn with no ink, but the lines or borders will not appear on the 
screen or on printed drawings.

You can change the pen pattern before or after you draw the object.

Drawing a line or object with a selected pen pattern

To draw a line or object with a selected pen pattern

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
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Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired pen pattern from the Pen Pattern pop-up menu in the 
Attribute options in the Properties panel/ properties palette.

3.	 Draw a line or object.

The line or object will be drawn with the specified pen pattern.

Note: The chosen pen pattern will be used for lines and borders until you choose 
another pen pattern as the default.

Adding a pen pattern from the swatches panel/palette

To add a stroke pattern from the swatches/palette to an object

1.	 Select the object you wish to apply a pen pattern to.

2.	 Open the swatches panel/ palette

3.	 Click the pattern you desire to highlight it

4.	 Right click (CTRL Click) and a pop up will appear

5.	 Choose Add to Stroke

6.	 The pattern will now be applied to the stroke/pen of the object

Note: Pen patterns are also referred to as Strokes, like a stroke of a pen to create the 
rectangle. 
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Changing the pen pattern of an existing line or object

To change the pen pattern of an existing line or object

1.	 Select the line or object to change the pen pattern of.

2.	 Select the desired pen pattern from the Pen Pattern pop-up menu in the 
Attribute options in the Properties panel/ properties palette.

The line or border of the selected object will be changed to reflect the chosen 
pen pattern.

Showing and hiding fills

You can choose to hide fills, including colors and patterns, on your drawing. 
When you turn fills off, only the borders of filled objects appear.

To hide line fills

•	 Open the Options menu and choose Hide Fills.

Objects appear as wire frame shapes, and a check mark appears next to the 
Hide Fills command.

To display fills

•	 Open the Options menu and choose Hide Fills again.

Objects will be drawn with their respective fills, and the check mark 
disappears from next to the Hide Fills command.
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Gradient Fills and Strokes
MacDraft includes Gradients, which can be applied to fills and strokes. You can 
create, edit and save new gradients into your documents.

Available Gradient Types

The two main gradients types available are Linear and Radial, which have 
additional settings within them. The Linear gradient allows you to change the 
angle to alter the direction of the gradient and the Radial allows you to change 
the centre position of the gradient. Below are examples of the gradients types 
available.

Creating new linear gradients

Creating new gradients can be done using the Swatches panel/ palette.

To create a new linear gradient

1.	 Open the Swatches panel/ palette and click the plus (+) symbol in the bottom 
left hand corner and a submenu will appear.

2.	 Select Gradient from the submenu and the New Gradient dialog appears

3.	 Make sure the Linear option is selected in the gradient type pop up.

4.	 Double-click the Color Picker 1 square 

The Colors dialog will appear

5.	 Select a color and close the Color Picker dialog using the red X in the top left 
hand corner of the dialog and return to Edit Gradient dialog. 
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6.	 Double-click the Color Picker 2 square

The Colors dialog will appear again

7.	 Select a color and close the Color Picker dialog using the red X in the top left 
hand corner of the dialog and return to Edit Gradient dialog.

The color will be added to the gradient

Note: You can add extra colors to a gradient easily. Follow the steps in the next 
section to add extra colors.

Gradient Type

Color Picker 1

Applies the gradient to 
the selected object.

Closes the dialog without 
creating the gradient

If applied to an object, the 
changes will be previewed

Gradient Preview

Angle

Color Picker 2

Changes the opacity 
of the selected color

Closes the dialog, 
creates the gradient 
and adds it to the 
gradient attributes

Deletes the selected 
color from the 
gradient
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Adding extra colors

To add extra colors to the gradient

1.	 Click anywhere in the area defined by the red line in the image above.

2.	 This will add a new color picker square to the gradient.

3.	 Double-click the new color picker and follow the steps outlined in the 
previous section to change the color. When you add the new color the 
gradient will update.
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Changing the angle direction

To change the angle direction of the linear gradient

1.	 Enter the desired angle into the Rotation text box.

2.	 When you are happy with the settings click the OK button.

3.	 The gradient will now be stored in the Swatches panel/ palette, and available 
for selection in the Attribute options section of the Properties panel/ palette.

Deleting colors

To delete colors from the gradient

1.	 Select one of the color markers by clicking it with a single click.

2.	 Click the Trash/Bin icon to delete the selected color from the gradient.

Note: This operation cannot be undone, so make sure you want to delete the color 
from the gradient before doing so.

Creating new radial gradients

Creating new gradients can be done using the Swatches panel/ palette.
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To create a new radial Gradient

1.	 Open the Swatches panel/palette and click the plus (+) symbol in the bottom 
left hand corner and a submenu will appear.

2.	 Select Gradient from the submenu and the Edit Gradient dialog appears

3.	 Make sure the Radial option is selected in the gradient type pop up.

4.	 Double-click the Color Picker 1 square 

The Colors dialog will appear

5.	 Select a color and close the Color Picker dialog using the red X in the top left 
hand corner of the dialog and return to Edit Gradient dialog. 

6.	 Double-click the Color Picker 2 square

The Colors dialog will appear again

Gradient Type

Color Picker 1

Applies the gradient to 
the selected object.

Closes the dialog without 
creating the gradient

If applied to an object, the 
changes will be previewed

Gradient Preview 
(Drag inside here to 
move the center of 
the radial gradient)

Color Picker 2

Changes the opacity 
of the selected color

Closes the dialog, 
creates the gradient 
and adds it to the 
gradient attributes

Deletes the selected 
color from the 
gradient
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7.	 Select a color and close the Color Picker dialog using the red X in the top left 
hand corner of the dialog and return to Edit Gradient dialog.

The color will be added to the gradient

Note: You can add extra colors to a gradient easily. Follow the steps in the next 
section to add extra colors.

Adding extra colors

To add extra colors to the gradient

1.	 Click anywhere in the area defined by the red line in the image above.

2.	 This will add a new color picker square to the gradient.

3.	 Double-click the new color picker and follow the steps outlined in the 
previous section to change the color. When you add the new color the 
gradient will update.
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Moving the center of the radial gradient

To move the center of the radial gradient

1.	 Click in the gradient preview area and the center will move to it. 

2.	 When you are happy with the settings click the OK button.

The gradient will now be stored in the Swatches panel and available for 
selection in the Attributes options in the Properties panel.

Deleting colors

To delete colors from the gradient

1.	 Select one of the color markers by clicking it with a single click.

2.	 Click the Trash/Bin icon to delete the selected color from the gradient.

Note: This operation cannot be undone, so make sure you want to delete the color 
from the gradient before doing so.
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Editing gradients

To edit a gradient

1.	 Open the Swatches panel/ palette and locate the gradient you want to edit.

2.	 Double-click the mouse button on the gradient you want to edit or select the 
gradient with a single mouse click and choose Edit from the options menu 
(the Gear symbol).

The Edit Gradient dialog appears.

3.	 Click the color you want to change 

The Colors dialog will display.

4.	 Select a color and close the Color Picker dialog using the red X in the top left 
hand corner of the dialog and return to Edit Gradient dialog.

5.	 You can also change the Angle. Once happy with the changes click OK.

Note: Click the Preview check box when editing to view your changes live in the 
document. When you edit a gradient, any object that has the gradient applied will 
update with the changes. If you wish to use an existing gradient to create a new one, 
use the Duplicate gradient option.
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Duplicating gradients

Sometimes you may find the need to create a gradient similar to an existing one. 
This option allows you to duplicate an existing gradient and then edit it to create 
a new one.

To duplicate a gradient

1.	 Open the Swatches panel/ palette and locate the gradient you want to 
duplicate.

2.	 Single mouse click the gradient and choose Duplicate from the options menu 
(the Gear symbol).

The gradient dialog will appear with the selected gradient.

3.	 Make the changes you want to the gradient

4.	 Click the OK button when you are happy.

The New gradient will be added the patterns and gradient popup.

Applying gradients

Gradients can be applied as a Fill, Pen or Parallel line attribute.

To apply a gradient

1.	 Select the object(s) you want to apply the gradient to.

2.	 Go to Attribute options in the Properties panel/ palette and choose a 
gradient for either the fill, parallel line or pen.

The gradient will be applied to the attribute of the selected object(s).
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Line and Border Attributes
The attributes that define the appearance of lines and borders are sometimes 
referred to as the ‘pen model’ simply, the ‘pen’ or the 'Stroke'. The attributes 
for the pen include pen style, line weight, line style and end marks. The border 
position of an object can also be specified.

The various options for each attribute are selected using pop-up menus in the 
Attribute options or, in the case of pen style and border position, from the 
Options menu or the Properties panel. Pen color or pattern are discussed in 
previous sections of this chapter.

Note: Many of the pen model attributes you choose do not affect only lines, they 
also affect the borders of objects. For example, when you select a certain line 
weight and color, these attributes will be applied to line segments used to draw 
rectangles, circles, polygons and so on.

Pen Styles  PRO ONLY

There are three types of pen style: Mitre Blade, Bevel Blade and Round. The 
pen style options apply to lines and objects.

The pen style affects the width of angled lines and the appearance of the ends of 
lines and of joins.

•	 Mitre Blade (QuickDraw): Angled lines will have pointed ends and will be 
proportionally thicker than a horizontal or vertical line.

•	 Bevel Blade (Accurate width): Lines remain a constant width regardless of 
their angle. The line ends will be straight.

•	 Round (Accurate width): Lines remain a constant width regardless of their 
angle. The line ends will be rounded.

Blade (Beveled) Blade (Mitred) Round
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Selecting pen styles  PRO ONLY

To select a pen style

1.	 Open the Pen Style submenu in the Options menu.

2.	 Drag until the desired pen style is highlighted.

3.	 Release the mouse button. A check mark appears next to the selected pen 
style on the submenu.

You can change the pen style before or after you draw the line or object.

Note: You can also change the Pen Style by selecting the desired style at the bottom 
of the Properties panel. This can be done when an item is selected or not.

Drawing an object with a selected pen style   PRO ONLY

To draw an object with a selected pen style

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the desired pen style from the Pen Style submenu in the Options 
menu or at the bottom of the Properties panel/ properties.

3.	 Draw an object.

The object will be drawn with the specified pen style.

Note: The chosen pen style will be used for objects until you choose another pen 
style as the default.
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Changing the pen style of an existing object  PRO ONLY

To change the pen style of an existing object

1.	 Select the object to change the pen style of.

2.	 Select the desired pen style from the Pen Style submenu in the Options 
menu or at the bottom of the Properties panel/ properties.

The selected object will be changed to reflect the chosen pen style.

Line weight

Line weight refers to the thickness of lines and borders. Line weight is measured 
in pixels (picture elements).

They vary in size from hairline to 13 pixels. The numbers beside the line weights 
indicate the number of pixels that make up the line weight.

Note: Although the hairline, 0.5 and 0.75 line weights appear as one point thick 
on the screen, they will print at their designated weights on any printer with a 
resolution of 300 dpi or more.

Selecting line weights To select the line weight

1.	 Open the Line Weight pop-up menu in the Attribute options section of the 
Properties panel/ palette.

2.	 Drag until the line weight you want is highlighted.
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3.	 Release the mouse button and the selected line weight will be shown on the 
pop-up menu.

You can change the line weight before or after you draw the line or object.

Drawing a line or object with a selected line weight 

To draw a line or object with a selected line weight

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/ palette. (make sure nothing is selected in the document.)

2.	 Choose the desired line weight from the Line Weight pop-up menu in the 
Attribute options section of the Properties panel/ properties palette.

3.	 Draw a line or object.

The line or object will be drawn with the specified line weight.

Note: The chosen line weight will be used for lines and borders until you choose 
another line weight for the default line weight attribute.

Changing the line weight of an existing line or object

To change the line weight of an existing line or object

1.	 Select the line or object to change the line weight of.
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2.	 Choose the desired line weight from the Line Weight pop-up menu in the 
Attribute options section of the Properties panel/ properties palette.

The line or border of the selected object will be changed to reflect the chosen 
line weight.

Note: For information about how to make line weights appear either magnified or at 
their normal size while in a zoomed in view, please refer to zoom line weights.

Changing Line Weight by typing an exact number

MacDraft also allows you to manually type in a specific line weight from 0 to 13 
and up to two decimal places in accuracy. For example, you might find you want 
a line weight that isnt as thin as 2 but also isnt as thick as 3. You can achieve this 
by typing the value in.  

To change the line weight by typing an exact number

1.	 Select a line or object in the document.

2.	 Click in the stroke & line options, the current text will highlight.

3.	 Type in the value you want the line or object to change to. 

4.	 The value in the text field will change, as will the thickness of the stroke of 
the selected object. 
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Line style

The term ‘line style’ refers to whether a line is solid or one of an assortment 
of dashed lines. You can use the preset line styles provided with MacDraft or 
customize them in the professional version to make your own. You can use line 
styles in object borders and straight lines.

Selecting line styles 

To select the line style

1.	 Open the Line Style pop-up menu in the Attribute options section of the 
Properties panel/ properties panel.

2.	 Drag until the line style you want is highlighted.

3.	 Release the mouse button and the selected line style will be shown on the 
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pop-up menu.

You can change the line style before or after you draw the line or object.

Drawing a line or object with a selected line style 

To draw a line or object with a selected line style

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel. (make sure nothing is selected in the document.)

2.	 Choose the desired line style from the Line Style pop-up menu in the 
Attribute options section of the Properties panel/ properties palette.

3.	 Draw a line or object.

The line or object will be drawn with the specified line style.

Note: The chosen line style will be used for lines and borders until you choose 
another line style for the default line-style attribute.

Changing the line style of an existing line or object

To change the line style of an existing line or object

1.	 Select the line or object to change the line style of.

2.	 Choose the desired line style from the Line Style pop-up menu in the 
Attribute options section of the Properties panel/ properties palette.
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The line or border of the selected object will be changed to reflect the chosen 
line style.

Editing line styles  PRO ONLY

MacDraft provides you with a variety of preset line styles. You can use these line 
styles or customize them to suit your needs. When you create your own custom 
line styles, each line style can be made up of numerous dashes and gaps. You can 
specify the length of each dash and gap.

To select a line style to edit

1.	 Open the Options menu and drag until Edit Line Styles is highlighted.

The Edit Line Styles submenu appears.

2.	 Holding down the mouse button, drag until the line style you want to edit is 
highlighted, and release the mouse button.

The Edit Line Style dialog appears. The line style you chose to edit appears 
in a box below the ruler.

To edit the line style

1.	 The default measurement for the lengths of dashes and gaps is inches. To use 
centimeters to measure the lengths of dashes and gaps, click the cm radio 
button.

2.	 Without pressing down the mouse button, move the cursor onto the box 
containing the line. A flag appears above or below the line style (depending 
on whether you point above or below the line). You use the flag to specify 
the length of dashes and gaps. When you point above the line, the flag turns 
white to show you are ready to add gaps to the line. When you point below 
the line, the flag turns black to show you are ready to add dashed segments.
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3.	 You can edit the line in the following ways.

•	 To add a gap or a dashed segment: Position the cursor above the line 
to add a gap or below the line to add a dashed segment. Without pressing 
down the mouse button, move the pointer to where you want the dash or 
gap to begin. As you move the pointer, notice that the flag moves along 
with it. Press and hold down the mouse button, drag to the right until the 
dash or gap is the length you want and release the mouse button.

•	 To shorten a segment: Position the cursor near the segment you want 
to shorten. Holding down the mouse button, drag to the left until the 
segment is the length you want and release the mouse button.

•	 To erase the line style: Position the cursor near the right end of the line. 
Hold down the mouse button, drag to the extreme left end of the line and 
release the mouse button. Notice that a tick mark on the ruler follows 
the movement of the flag. The tick marks show the beginning and end 
of each segment (either dash or gap). Notice also that the sample line 
style below the line will be changed to reflect the new style and shows 
you how the line style will appear on a document. The line style will be 
repeated after the last segment of the line.
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Note: You can create a line style with segments that extend beyond the limit of the 
edit box. Although the edit box will not show these segments, the sample below the 
box shows you how the line will appear on the drawing.

4.	 When you have finished editing the line style, click one of the following 
buttons.

•	 OK: To accept the modified line style and place the line style into the 
Line Style pop-up menu for use with lines and borders.

•	 Revert: To revert to the original line style (the line style you originally 
chose to edit).

•	 Cancel: To close the dialog without applying your changes.

Showing and hiding line styles  PRO ONLY

If your drawing contains many objects with line styles, you might want to 
increase the rate at which the screen is redrawn by hiding the line styles while 
you work. When line styles are hidden, solid lines appear on the lines and objects 
instead of the line styles.

To hide line styles

•	 Open the Options menu and choose Hide Line Styles.

Lines will be drawn with solid lines, and a check mark appears next to the 
Hide Line Styles command.

To display line styles

•	 Open the Options menu and choose Hide Line Styles again.

Lines will be drawn with their respective line styles, and the check mark 
disappears from next to the Hide Line Styles command.

End marks

End marks are symbols on the ends of lines that are used for annotating 
drawings. You can make end marks appear on lines by using a set of end marks 
in combination with the Line tools, the Polyline tool, the Freehand Line tool, 
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the Bezier curve tool or the Spline tool.

Note: The end marks you can use for the above objects are separate from the end 
marks you use for dimension lines. Dimension line objects can only be edited in the 
professional version of MacDraft.

Selecting end marks

To select end marks

1.	 Open the Start or End pop-up menu in the End Marks section of the 
Attribute options in the Properties panel/ palette.

2.	 Drag until the desired end marks are highlighted.

•	 Drag down the Start pop-up menu to choose a left end mark; it appears 
at the beginning of a line.

•	 Drag down the End pop-up menu to choose a right end mark; it appears 
at the end of a line.
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3.	 Release the mouse button and the selected end marks will be shown on the 
pop-up menu.

You can change the line style before or after you draw the line or object.

Note: Polylines, freehand lines, Bezier curves or splines must contain No Fill if you 
wish to add end marks to them.

Drawing a line or object with selected end marks 

To draw a line or object with selected end marks

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Choose the desired end marks from the Start or End pop-up menu in the 
End Marks section of the Attribute options in the Properties panel/ 
properties palette.

3.	 Draw a line or object.

The line or object will be drawn with the specified end marks.

Note: The chosen end marks will be used for lines and borders until you choose 
other end marks for the default end marks attribute.

Changing the end marks of an existing line or object 

To change the end marks of an existing line or object

1.	 Select the line or object to change the end marks of.

2.	 Choose the desired end marks from the Start or End pop-up menu in the 
End Marks section of the Attribute options in the Properties panel/ 
properties palette and choose the size they should be.

The line or object selected will be changed to reflect the chosen options.
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Border positions

There are three types of border position: Line Inside, Line Centered and Line 
Outside. The border position options apply to objects only, not to lines.

All three border positions affect objects differently, these differences are 
discussed later in this chapter. In general though, border position is important 
with regard to how objects are aligned. MacDraft uses the position of an object's 
edit handles to align objects. It is important to keep this in mind when you align 
objects, as border position controls the position of the edit handles relative to the 
width (that is the line weight) of the border.

Border position applies only to square-corner and rounded-corner rectangles, 
parallel line objects, circles and arcs. You can draw these objects with a certain 
border position or change the border position of selected objects.

Selecting border positions

To select a border position

1.	 Open the Border Position submenu in the Options menu.
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3.	 Release the mouse button. A check mark appears next to the selected border 
position on the submenu.

You can change the border position before or after you draw the line or 
object.

Note: You can also change the Border Position by selecting the desired style at the 
bottom of the Properties panel/ properties palette. This can be done when an item is 
selected or not.

Drawing an object with a selected border position 

To draw an object with a selected border position

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Choose the desired border position from the Border Position submenu in the 
Options menu or at the bottom of the Properties panel/ properties palette.

3.	 Draw an object.

The object will be drawn with the specified border position.

Note: The chosen border position will be used for objects until you choose another 
border position as the default.

2.	 Drag until the desired border position is highlighted.
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Changing the border position of an existing object 

To change the border position of an existing object

1.	 Select the object to change the border position of.

2.	 Choose the desired border position from the Border Position submenu in the 
Options menu or at the bottom of the Properties panel/ properties palette.

The border of the selected object will be changed to reflect the chosen border 
position.

How border position affects objects

Border position determines the location of the edit handles on the border of an 
object, and as MacDraft uses the edit handles as reference points for alignment 
and size calculations, border position affects the alignment and size readings of 
objects.

Line Inside: When you draw an object with the border 
position Line Inside, the border of the object appears 
between the cursor and the object during creation. When you 
select an object created with the border position Line Inside, 
the edit handles appear on the outside of the object. When 
Show Size is on, the size shown represents the entire object, 
including its borders.

Line Centered: When you draw an object with the border 
position Line Centered, the cursor appears centered within 
the object’s borders during creation. When you select an 
object created with the border position Line Centered, the 
edit handles appear in the center of the objects borders. 
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When Show Size is on, the size shown is the size of the object 
measured from the center of the object’s borders.

Line Outside: When you draw an object with the border 
position Line Outside, the border of the object appears outside 
the cursor during creation. When you select an object created 
with the border position Line Outside, the edit handles 
appear on the inside of the object. When Show Size is on, the 
size shown is the size of the object’s interior, excluding the 
object’s borders.

Copying Attributes
An object’s graphic attributes (fill, pen color or pattern, line weight and line style 
etc.) and object information can be copied and applied to another object using 
either the Attributes tool or the Copy Attributes and Apply Attributes commands 
in the Edit menu. The Apply Attributes command can be used to apply changes 
to all of the objects selected, while the Attributes tool applies changes only to the 
object clicked.

Any settings for applying attributes will be stored only while the application is 
running.

The default options for applying attributes are to apply only graphic attributes, 
not object information.

Copying attributes using the Attributes tool

To copy attributes using the Attributes tool

1.	 Click the Attributes tool in the Drafting Tools panel/ palette.

2.	 Click an object.

The default attributes will be applied to the object.

3.	 With the Attributes tool still selected, hold down the Option key and click an 
object.

The cursor turns into an empty eye dropper.
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The object’s pen and fill attributes will be copied

4.	 Release the Option key, the cursor turns into a full eye dropper.

5.	 Click another object to apply the copied pen and fill attributes to it.

Notes: 

•	 Attributes will be applied only to the object clicked, even if that object is part 
of a group.

•	 The apply action can be undone by selecting Undo Eye Dropper from the Edit 
menu immediately after the apply action.

•	 Hold down the Command key and click in the drawing window with the 
Attributes tool, and the tool reverts to the Arrow tool.

Copying attributes using the Edit menu

To copy attributes using the Edit menu

1.	 Select the object from which you want to copy attributes.
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2.	 Open the Edit menu and choose Copy Attributes.

The object’s graphical attributes and object information will be stored.

3.	 Select the object or objects to which you want to apply these attributes.

4.	 Open the Edit menu and choose Apply Attributes.

The copied attributes will be applied to the selected object or objects.

Picture Backgrounds 

Transparent pictures

There may be occasions when you position a picture object on top of another 
object, and want the lower object to show through the background of the 
foremost. Do this by importing images such as PNG or Photoshop PSD that have 
transparent backgrounds.

To make the background of a picture transparent

•	 Make sure that the images already have transparent backgrounds with them, 
you can then drag them into MacDraft or import them from the file menu.
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Opaque picture backgrounds

•	 Choose a color from the Fill Color pop-up menu, or a pattern from the Fill 
Pattern pop-up menu in the Attributes options in the Properties panel/ 
properties palette.

What was a transparent background will now be the color or pattern you 
selected. You can make it transparent again by selecting the No Fill option in 
either of the pop-ups.
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Chapter 4
Annotating your drawing

Annotation describes or gives information about an object in a drawing. In 
MacDraft, annotation is of four kinds: text, dimension objects, area calculation 
and perimeter calculation.

Text   
Text, in a MacDraft document, consists of all letters, punctuation and numbers. 
Once text is created, it is recognized as a single object and you can then use most 
functions with it, such as moving and duplicating.

The Text function allows you to use a variety of fonts, styles, and character sizes. 
You can arrange text lines with single spacing, one and a half spacing, or double 
spacing. Text can also be justified within each individual text block and all text 
can be hidden or displayed.

Entering Text

You can enter text in two ways: using the regular text mode or the paragraph text 
mode. In the paragraph text mode, you drag to define a text rectangle of a certain 
size with the Text tool, and the text you enter into the rectangle automatically 
“wraps” when it reaches the side of the rectangle.

Regular Text

In the regular text mode, you click the drawing to define an insertion point, then 
type in the text. You define the end of a line of text by pressing the Return key.

To enter regular text (i.e. text that does not automatically “wrap”) 

1.	 Activate the Text icon in the Drafting Tools panel/palette by clicking it.
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Notice that when you activate the text icon and then move the cursor onto 
the drawing area, the cursor turns into an I-beam pointer. The I-beam pointer 
indicates that you are in the text insertion mode.

2.	 Position the I-beam pointer where you want to begin inserting text and click.

A flashing vertical bar appears at the point where you clicked to show that 
you can now begin typing.

3.	 Enter the text by typing on the keyboard.

You can continue to enter text in various places on your drawing by moving 
the I- beam pointer to the desired place, clicking it, and typing.

Notes: 

•	 If you make a typing mistake as you are entering text, simply use the backspace 
key to remove the error and then type the correct character.

•	 To start a new line in the same text block, just press the Return key and 
continue to type.

4.	 After you have finished entering text, click the Pointer tool or press the 
Escape key on your keyboard.

Paragraph text

On many occasions, you may wish to enter a paragraph of text and restrict it to 
a certain rectangular shape, such as a column. MacDraft’s paragraph text feature 
allows you to define a rectangle of any size, then type text into it. As you enter 
the text into the rectangle, the words will automatically wrap around to the next 
line when the letters reach the edge of the rectangle. If you type to the bottom of 
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the rectangle, the text will be scrolled within the rectangle to keep the line you 
are typing visible.

Entering paragraph text

You can define the paragraph text by drawing a rectangle with the Text tool.

To enter paragraph text with the Text tool

1.	 Activate the Text tool.

2.	 Position the I-beam pointer where you want to begin entering text.

3.	 Press and hold down the mouse button.

4.	 Drag in a diagonal direction until you have defined a rectangle that is the size 
you want, and release the mouse button.

5.	 Start entering text via the keyboard.

6.	 When you are finished, click the Pointer tool or the Escape key on your 
keyboard to end the text entry.

Reshaping a block of paragraph text

To reshape a block of paragraph text

Once the paragraph of text is entered, you can reshape the paragraph using the 
edit handles.

1.	 Return to the pointer mode.

2.	 Select the paragraph of text by clicking it.

Edit handles appear on the text block.
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3.	 Position the tip of the pointer on one of the edit handles.

4.	 Press and hold down the mouse button.

5.	 Drag until the paragraph is the shape you want.

6.	 Release the mouse button.

Note: If you select regular text (entered using the Text tool) and try to reshape the 
paragraph using the edit handles, you will actually resize the font rather than the 
paragraph.

Selecting/editing text

Sometimes you need to edit text you have previously entered on your drawing. 
MacDraft gives you various ways to edit text: replacing an existing word or line 
of text by selecting it and retyping in its place; inserting characters or words at 
the end of existing text or at any selected point in the text; and backspacing to 
delete text.

Before you can edit a piece of text, you must select it. You can select text by 
using the pointer while in the pointer mode, or by using the I-beam pointer. 
(When you select text using the pointer mode, any changes you make will affect 
the entire text block.)
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Selecting text

Using the I-beam pointer to select text

1.	 Click the Text tool icon in the Drafting Tools panel/palette.

2.	 Position the I-beam pointer to either side of the text you want to change.

3.	 Press and hold down the mouse button.

4.	 Drag through all the text you want to edit, and release the mouse button.

Notice that the text becomes highlighted as you drag through it. Using this 

method of selecting allows you to select a single character or an entire block 
of text.

To select a word:

•	 Position the I-beam pointer on the word you want to select and double-click. 

To extend the selection of text

1.	 Position the I-beam pointer on the first word you want to select.

2.	 Click and hold down the mouse button.

3.	 Drag through the text until all the words you want to select are highlighted, 
then release the mouse button.

To select a range of text

1.	 Position the I-beam pointer at the starting point for the range and click.

2.	 Press down the Shift key.

3.	 Position the I-beam pointer on the ending point for the range.

4.	 Still holding down the Shift key, click this point.



278Chapter 4 Annotating your Drawing

5.	 Release the mouse button and the Shift key.

The text between the specified starting and ending points will be selected.

Using the Arrow tool To select text

•	 Position the pointer on the block of text that you want to select and click it.

Notice that a rectangle and/or a set of edit handles appears around the text, 
indicating that it is selected. This method of selecting text allows you to 
change the text attributes (including the font, size, and style) of the selected 
text block.

Selecting rotated text for editing 

To select rotated text

1.	 Activate the Text tool in the Drafting Tools panel/palette.

2.	 Click the block of rotated text you want to edit.

The text will temporarily be rotated to zero degrees (horizontal orientation) 
allowing you to edit it.

3.	 When you are through editing the text, click the Pointer tool or press the 
Escape key on your keyboard.

The text returns to its rotated position.

Note: If you print rotated text on a printer that is not PostScript®-compatible, the 
text will print out at the resolution of the printer hardware.

Selecting all text

You can select all the text in the active layer on the current document if you want 
to make a global change to text attributes.



279 Chapter 4 Annotating your Drawing

To select all text on the active layer in the document

1.	 Return to the pointer mode.

2.	 Open the Text menu, from the menu bar and choose Select All Text.

Editing text

Replacing existing text

Once you have selected any portion of text, you can immediately replace it 
by simply typing in the new text. As soon as you begin typing, the old text 
disappears. As you enter the new text, all of the non-selected text in the line will 
automatically adjust to make room for the text you are entering.

Inserting text into existing text

On many occasions you may need to insert a single character, word or sentence 
into an existing piece of text.

To insert text

1.	 Activate the Text tool in the Drafting Tools panel/palette.

2.	 Position the I-beam pointer on the desired insertion point and click it.

3.	 Type in the character or words that you wish to insert. (Keep in mind that 
you can press the Delete key or backspace to delete characters or words.)

In this mode, you can continue to pick insertion points in other pieces of text 
on your drawing and edit them as well.

4.	 Once you have completed all the editing that you want to do, click the 
Pointer icon in the panel.

Deleting selected text

There are two simple ways to delete text that you have selected. 

Either:

•	 Open the Edit menu and choose Cut or Clear, or

•	 Press the Delete key or Backspace key



280Chapter 4 Annotating your Drawing

Formatting text

You can choose the way you want to present text either before entering the 
text, or by changing the text after it has been entered. There are many options 
to choose from to obtain the effect that you desire. MacDraft allows you to 
use many different font types, sizes and styles for text. You can format text by 
choosing options from the Text menu or the Properties panel/ properties palette.

Formatting text before entering it

To format text before entry

1.	 Make sure that no text is selected on the drawing before you make each 
choice.

2.	 Choose the text attributes you want from the Text menu’s submenus or from 
the Properties panel/ properties palette.

The current attributes for text, such as font, size, and style are marked with 
check marks in the appropriate menus. These check marks show you what 
attributes will be applied to the text you enter.

Formatting existing text

You can change the font, size and style of any existing text. You can change the 
text attributes for a given piece of text by selecting the text and then opening the 
submenu associated with the attribute you want to change.

To format existing text

1.	 Select the text you wish to change. Choose the text attributes you want from 
the Text menu’s submenus or the Properties panel/ properties palette.
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2.	 Each time you make a choice from the Text menu or Properties panel/ 
properties palette, the selected text will change to reflect that choice.

Define attributes for text

To define the font

1.	 To change the font either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Font pop-up menu in Text Options in the Properties panel/ 
properties palette.

2.	 Choose the font you would like to use.

To define the point size for text

1.	 To change the font size either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Size menu in Text Options in the Properties panel/ properties 
palette.

2.	 Choose the size of the font you would like to use, type in the size, or use the 
steppers to increase or decrease the size. 

To define the style

1.	 To change the font style either:

•	 Open the Font submenu from the Text menu, or

•	 Click the Style pop-up menu in Text Options in the Properties panel.

2.	 Choose the style you would like to use.

Note: The style popup in the Properties panel will show the full list of styles 
attributed to that font. However the Text menu will only display the basic styles.
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To justify text

1.	 To set the justification either:

•	 Open the Justification submenu from the Text menu, or

•	 Use the Justification buttons in Text Options in the Properties panel.

2.	 Select the horizontal justification (left, center or right) you want to use.

3.	 Select the vertical justification (top, middle or bottom) you want to use.

To set the line spacing

MacDraft offers you flexibility in choosing line spacing (also known as 
“leading”) options to suit your needs. You can have Single, 1 1/2, or double space 
between lines of text.

1.	 To set the spacing either:

•	 Open the Line Spacing submenu from the Text menu, or

•	 Click the Spacing pop-up menu in Text Options in the Properties 
panel.

2.	 Choose the spacing (Single Space, 1 1/2 Space or Double Space) you would 
like to use.

Changing the case of text

On some occasions you may enter a piece of text in one case, such as lowercase, 
and then decide that you want it in uppercase or in title format. You could clear 
the text and reenter it; however, MacDraft allows you to change the case of 
existing text.
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To change the case of existing text

1.	 Select the text that you want to change by clicking it.

2.	 Open the Transformations submenu from the Text menu.

3.	 Holding down the mouse button, drag until the case option you want is 
highlighted.

The results of each choice are as follows:

•	 UPPERCASE: Converts all selected text to uppercase.

•	 lowercase: Converts all selected text to lowercase.

•	 Title Text: Capitalizes the first character of each word in selected text.

Moving text

Once you have created a block of text, you can move it to a different location on 
your drawing if necessary. Notice that when you create a line of text and then 
click anywhere else, the text becomes surrounded by a box or edit handles. This 
indicates that MacDraft recognizes the piece of text as an object. You can move 
the text just as you would move any other object.

To move a piece of text

1.	 Position the cursor over the text block.

2.	 Press and hold down the mouse button until the white arrow pointer appears.

3.	 Drag the text to its new position, and release the mouse button.

Aligning Text

There are two ways to align text. Justifying text within the text block and 
aligning text with an object or another piece of text that is treated as an object.

To align text with another piece of text or an object

1.	 Click the text to be aligned to select it.

2.	 Open the Arrange menu and choose Alignment Options.

The Alignment Options dialog appears.
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3.	 Choose the alignment method you want, and click the OK button.

4.	 Click the object with which you want the text block aligned (if necessary).

The selected text and objects will snap into alignment according to the 
specified alignment attribute.

Note: You can also align objects using the Alignment panel.

Clipped Text

If text is likely to overflow the text box then with clipped text turned on the text 
box will be highlighted with a red line and icon. The text box should be increased 
in size to accommodate all of the text, and the red line and icon will disappear. 

To turn clipped text on

•	 Choose Highlight Clipped Text from the Text menu (a tick will be next to 
it), or

•	 Click the Highlight Clipped Text checkbox (will contain a tick) in Text 
Options in the Properties panel/ properties palette.

To turn clipped text off

•	 Choose Highlight Clipped Text from the Text menu (the tick will no longer 
be next to it), or

•	 Click the Highlight Clipped Text checkbox (will not contain a tick) in Text 
Options in the Properties panel/ properties palette.

Resizing using clipped text icon

When Highlight Clipped Text is turned on, an icon appears with a red line on the 
text boxes that have text overflowing. You can either resize the text box manually 
or use the icon to resize it automatically.



285 Chapter 4 Annotating your Drawing

To resize overflowed text with highlight clipped text turned on

•	 Double click the red icon on the highlight clipped text red line, or

•	 Select the text object and drag one of the handles to resize the height of the 
text box, until the text fits. 

Text Flow

MacDraft allows you to flow text from one text box to another using Text Flow. 
You could set multiple text boxes around the document or create columns of text 
which flow up and down like a newspaper. 

To create a Text Flow

1.	 Select the Text tool in the Drafting Tools panel/palette.

2.	 Click and drag the mouse to create the size and shape of your first text box.

3.	 Type in your text.

Note: You can either type all of your text now or simply a single word. There needs 
to be something in the text box for the text box to be placed. 

4.	 Press the Esc key to confirm your text. 

	 The first text box is placed. 

5.	 Click the Grey link button on the top right of the text box. 

6.	 The cursor will change to a link text cursor. 

7.	 Click and drag the mouse to draw your second text box. 

One of two things will now happen. If your original text box overflowed with 



286Chapter 4 Annotating your Drawing

text the additional text will now appear in the second text box. If the original 
text box didnt overflow then you will be presented with a blank second text box. 
If you continue to type in text box 1 the text will flow naturally into text box 2. 

Note: If you select any linked text box you will see a dashed line showing the text 
box it links to. This is particularly helpful if you have yet to add the text as the text 
box itself may not be visible.  

There is no limit to the amount of text boxes you can link to flow your text 
across. To link/ flow text to a third, fourth etc text box simply repeat steps 5 to 7 
from the To Create a Text Flow section above. 

Spelling and grammar

MacDraft uses the system spelling and grammar options, that can be accessed 
and used for the selected text and text objects in the document. These options are 
accessed via the contextual (right hand mouse click) menu, when a text object is 
selected.

To set the spelling and grammar options

1.	 Select and highlight a piece of text

2.	 Right hand mouse click (hold the Control key down and click) on the 
selected text.
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The contextual menu appears.

3.	 Choose Spelling and Grammar

4.	 Set the options you want to use. 

•	 Show Spelling and Grammar: Displays the spelling and grammar 
dialog for the selected text box.

•	 Check Document Now: Checks for spelling and grammar mistakes.

Note: You can also check spelling and grammar via the menu. Click Text then 
Spelling and Grammar then choose from Show Spelling & Grammar or Check 
Document Now. 

Vector Text

MacDraft allows you to convert your text elements to 100% vector graphics. This 
will give you the ability to edit the attributes of the text element as if it was a 
normal vector object. In addition it will allow you to manipulate parts of the text 
to create your own unique text styles for personal branding and logo design.

To turn your text into vector graphics

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 Select the text object you want to turn into vector graphics by single clicking 
it with the mouse.

3.	 Choose Create Outlines from the Text menu

4.	 The selected text object will be turned into vector graphics and be editable.
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Notes: 

•	 Now that the text is vectors, you can edit the handles, add pattern and gradient 
fills and even add borders to it.

•	 When you have turned your text into vector graphics you can no longer add 
more text to it using the text tool.

Hiding/displaying text

Hiding text

At times, you may want to temporarily hide all of the text on a document. If you 
choose to hide all the text, and then print the document, the text will not appear 
on the output. You might use this feature to hide all the text before you produce 
a test print of a drawing to shorten the printing time. If you are working on a 
complex drawing with many elements, you could use this feature to minimize the 
amount of time it takes to redraw the screen after you scroll or zoom.

To hide all text

•	 Open the Text menu and choose Hide Text.

To hide text only on the active layer

•	 Open the Text menu and choose Hide Text On Active Layer. 

Text on the drawing will be temporarily removed from the screen and from any 
printed output until you choose to re-display the text. A check mark appears 
beside Hide Text and Hide Text On Active Layer in the Text menu.

Re-displaying text
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When you want to make the text visible again on the screen and on your output, 
you can choose the Hide Text or Hide Text On Active Layer command again.

To re-display all text:

•	 Open the Text menu and choose Hide Text. The check mark next to the 
option will no longer be there.

To re-display text on the active layer

•	 Open the Text menu and choose Hide Text On Active Layer. The check 
mark next to the option will no longer be there.

Dimension Objects 

About dimension objects

MacDraft’s Dimension tools allow you to add dimension lines to your drawing 
so that you can display and print the sizes of (or distances between) various lines 
and objects. Dimensions show sizes and distances in real-world units according 
to the scale of the drawing. In addition, MacDraft can show and print the size of 
an angle. Angular dimensions appear in degrees of arc, regardless of the scale of 
a drawing.

MacDraft’s dimensions are specialized objects that can incorporate a range of 
recognized drafting formats and standards, including witness lines, extension 
gaps, and so on. Custom formatting of dimensions is only available in the 
professional version of MacDraft.

Linked dimensions

Dimension objects that are drawn with reference to object vertices will be linked 
to those points by default. This means that if the object is resized, the dimension 
object and the value associated with it will be updated to reflect the new size.

Linking and unlinking  PRO ONLY

If you don't wish your dimensions to be linked as default, turn them off in 
application preferences. Object vertices and dimension objects can be linked and 
unlinked using some of the Advanced tools in the Tool panel.
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The Dimension Tools

The dimension objects are created and controlled using the tools and pop-up 
menus of the Drafting Tools panel/palette.

To display the Dimension tools

•	 Choose Show Left Panel from the View menu and a tick will appear next to 
it to let you know the Tools panel is visible, Or

•	 Click the left panel icon of the Show/Hide Panels toolbar item, Or

•	 If in Palette mode, go Window > Dimension 

To close the Tools panel

•	 Choose Show Left Panel from the View menu again and a tick will no 
longer be next to it and the Tools panel will disappear.

•	 Click the left panel icon of the Show/Hide Panels toolbar item again.

•	 If in Palette mode, click the red X in the palette. 

Linear dimensions 

Linear (horizontal, vertical, sloped, or perpendicular) dimensions can consist 
of a single dimension span, several dimensions chained together, or several 
dimensions measured from the same baseline.
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The type of linear dimension required is selected from the Dim. type pop-up 
menu in the Dimension options in the Properties panel/ palette.  PRO ONLY

Linear dimensions can use existing vertices, corners, and so on as their points of 
reference. If the Snap to Object feature is active, the dimension tools will snap 
the reference points to existing corners and handles

Radial dimensions

Radial dimensions appear as straight lines (like linear dimensions), but measure 
the radius or diameter of an existing circle, ellipse, or arc.

Single Dimension

Chained Dimensions

Baseline Dimensions
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Angular dimensions

Angular dimensions measure the angle of arc between any two straight lines 
or edges of square-cornered rectangles, polygons, or polylines (single-line or 
parallel). The lines or edges need not intersect.

Dimension standards and formats  

MacDraft follows recognized drafting and design standards for dimensioning 
in English units (as mandated by the American National Standards Institute, or 
ANSI) and metric units (matching the BS-308, DIN, ISO, and JIS standards). 
These standards, which you can modify in MacDraft to meet your own needs, 
control the sizes and lengths of such dimension elements as witness lines, leader 
lines, gaps between elements and so on. A drawing’s dimension standards are 
displayed and set using the Dimension Standard dialog.

To display the Dimension Standard dialog

1.	 Choose Set Scale/Units... from the Layout menu.

2.	 The Document Scale & Units dialog appears. Click the Custom... button in 
the Dimension Standard area of the dialog.
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The Dimension Standard dialog appears.

Details of the options available in the Dimension Standard dialog are 
provided later in this chapter.

MacDraft Professional also allows you to control the formats of dimension 
objects. You can define whether a dimension object’s text is displayed 
horizontally, how dimension arrows are positioned, where (and whether) leader 
lines appear, and so on.

To open the Dimension Format dialog  PRO ONLY

•	 Click the Format button in the Dimension section in the Properties panel/ 
properties palette.

The Dimension Format dialog appears.
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Details of the options available in the Dimension Format dialog are 
provided later in this chapter.

Dimension Standards

Although MacDraft’s dimension standards follow approved guidelines for 
English unit and metric drawings, you can adjust them to meet your own needs.

These attributes are controlled using the Dimension Standards dialog. They can 
be adjusted for selected dimension objects or set as defaults to determine the 
attributes for all dimension objects drawn subsequently.

To change the dimension standard defaults for a drawing

1.	 Choose Set Scale/Units... from the Layout menu.

2.	 The Document Scale & Units dialog appears. Click the Custom... button in 
the Dimension Standard area of the dialog.

3.	 Click and type values in the appropriate fields to change standards as needed.

4.	 Click the OK button to close the dialog.

The Document Scale & Units dialog appears again. The Dimension 
Standard: Status: Field will now read “Customized.”

5.	 Click the OK button.

The dimension standards you revised will now be the standards for all new 
dimension objects.



295 Chapter 4 Annotating your Drawing

Note: Click the Revert to Standard button in the Dimension Standard dialog to 
return all the settings in the dialog to the ANSI or Metric standard values.

Changing the dimension standards for existing dimensions  PRO ONLY

To change the dimension standards for existing dimension objects

1.	 Select the dimension object or objects to be changed.

2.	 Click the Format button in the Dimension section in the Properties panel/ 
properties palette.

The Dimension Format dialog appears.

3.	 Click the Standards... button.

The Format Dimension Standard dialog appears.
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4.	 Click and type values in the appropriate fields to change standards as needed.

5.	 Click the OK button to close the dialog.

The Dimension Format dialog appears again.

6.	 Click the OK button.

The dimension objects you selected are now revised as you specified. For 
details on the effects of each standard attribute see the next section.

Note: The format of individual Circle Centre Marks cannot be changed. The 
document default values will always be used.

Dimension standard attributes

Dimension Text
Dimension Line

Witness Extension

Witness Line Gap

Leader Line

Tolerance Text

Dimension Text Gap

Outside Line Length

Witness Line

Witness extension

The Witness Extension is the length the witness line extends beyond the 
dimension line itself. (Units indicate distance on screen and on the printed 
drawing, not in scaled units.)

Witness line gap

The distance from each reference point to the beginning of its witness line. (Units 
indicate distance on screen and on printed drawing, not in scaled units.)
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Dimension text gap

The distance from any side of the dimension text to the dimension line or arc. 
(Units indicate distance on screen and on printed drawing, not in scaled units.)

Leader length

The length of a leader line connecting the dimension text to the dimension line 
or arc. (Units indicate distance on screen and on printed drawing, not in scaled 
units.)

Outside line length

The length of the lines indicating a linear dimension when the dimension object 
is formatted so that the lines are outside the witness lines, pointing “inward.” 
(Units indicate distance on screen and on printed drawing, not in scaled units.)

Tolerance text

A percentage value determining the point size of tolerance text (if any) relative to 
the dimension value text. Values can range from 25% (one-fourth the size of the 
dimension text) to 200% (twice the size of the dimension text). 

Tolerance space scale

A percentage value determining the line spacing when two lines of tolerance 
value text appear together (either two tolerance values or tolerance limits). 

The percentage is relative to the size of tolerance text itself, and ranges from 
25% (one-fourth of a line) to 200% (two lines, or double spacing). Since a 
100% setting single-spaces the text, values less than 100% percent may result in 
overlapping, depending on the font chosen for the dimension object. 

Circle center length

The length of each of the two crossed lines that mark the center point of a circle.

Circle center gap

The distance between the end point of a circle center line and the line that 
extends through the circle’s perimeter.
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Circle center extension

The distance that the circle center lines that pass through the circle’s perimeter 
extend outside the perimeter.

Circle Center Length

Circle Extension

Circle Center Gap

Although the values are given in screen units rather than scale units, Circle 
Center marks change size as appropriate if a whole drawing is rescaled.

Note: The format of individual Circle Centre Marks cannot be changed. The 
document default values will be always used.

Dimension formats  PRO ONLY

Some of the attributes for dimension objects can be adjusted both as drawing 
defaults to determine the attributes for dimension objects drawn subsequently, 
and for existing dimensions. These attributes are controlled using the Dimension 
Format dialog.

To change dimension format defaults for a whole drawing

1.	 Make sure no objects are selected by clicking a blank area of the drawing.

2.	 Click the Format button in the Dimension section in the Properties panel/ 
properties palette.

The Dimension Format dialog appears.
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3.	 From the Dimension Type pop-up menu, choose the type of dimension 
(Linear, Radial, or Angular) that you want to set new defaults for.

4.	 Adjust the settings as needed.

5.	 If you want to set defaults for more than one dimension type, repeat steps 3 
and 4.

6.	 When you are finished, click the OK button.

The dialog disappears, and the formats you revised will now be the defaults 
for all new dimension objects.

To change the dimension formats for existing dimension objects

1.	 Select the dimension object or objects.

2.	 Click the Format button in the Dimension section in the Properties panel/ 
properties palette.

3.	 Adjust the settings as needed, then click the OK button.

The dialog disappears, and the selected objects will be changed as you 
specified.
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Dimension format attributes  PRO ONLY

Dimension Text
Dimension Line

Witness Extension

Witness Line Gap

Leader Line

Tolerance Text

Dimension Text Gap

Outside Line Length

Witness Line

Dimension type (available only when no object is selected in the document)

This pop-up menu controls which type of dimension object (linear, radial or 
angular) you want to set the defaults for.

Text display

This pop-up menu controls whether dimension text is displayed horizontally on 
the drawing, or along, above, or below a dimension, extension, or leader line.

Text centered

Click this checkbox if you wish dimension text to be centered on a dimension 
line or dimension arc.

Text framed

Click this checkbox if you wish dimension text to appear within a frame.

Witness lines

Click this checkbox if you wish witness lines to be displayed. 

Arrows inside

Click this checkbox if you wish the dimension lines to appear inside the witness 
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lines (if any). If this checkbox is turned off, dimension lines will be displayed 
outside the witness lines (if any). 

Note: Hold down the Option key when entering dimension objects to toggle 
between arrows inside on/off.

Dim. round off (available only for selected objects)

Select a value from this pop-up menu to specify how dimension values are 
rounded off. (The values available for rounding off are in the scale and units of 
the drawing.)

Leader

Applicable only when dimension text appears horizontally outside a dimension 
object, choose an option from the pop-up menu to specify whether a leader line is 
displayed and whether it extends from a dimension line to the left or to the right. 

R, D symbol

Applicable only to radial dimensions, this item controls whether the radius or 
diameter symbol is displayed and whether it leads or follows the dimension 
value.

Tolerance

Choose an option from this pop-up menu to specify how many tolerances are 
displayed:

•	 None: No tolerances are displayed.

•	 One: Shows a single “plus/minus” value determined by the Tol. 1 field.

•	 Two: Shows a “plus” value from the Tol. 1 field and a “minus” value from 
the Tol.2 field (e.g. “333cm +1cm -2cm”).

•	 Limits: Shows two dimension values calculated from the Tol. 1 and Tol. 2 
fields in place of original dimension value (e.g. “331 cm / 334 cm” in place 
of “333 cm”).

Tol. 1 and Tol. 2



302Chapter 4 Annotating your Drawing

Enter values in these fields to specify values for tolerance to be displayed, as 
described above.

Dimension label (available only for selected objects)

Click this checkbox to turn this option on and enter text in the Dimension Label 
field to replace an existing object’s dimension text with the specified text string. 
Any tolerances will be hidden if this option is chosen.

Top Tip: If you need to type an angular degree symbol (°) in the label, use Shift-
Option-8 on your keyboard.

Revert to standard (available only when no object is selected in the document)

Click the Revert to Standard button to return all the settings in the dialog to the 
ANSI or Metric standard values.

Standards... (available only for selected objects)

Click the Standards... button to display the Format Dimension Standard 
dialog.

Dimension end marks

MacDraft’s dimension lines and dimension objects can have end marks; usually 
arrows or slashes at the ends of a dimension line. You can specify different 
end marks for each end of the line. The end marks for dimension objects are 
controlled by the pop-up menu in Dimension section of the Properties panel.

Note: The end marks for ordinary lines are controlled by the End Marks pop-up 
menu in the Attribute section of the Properties panel.

To change the end marks of an existing dimension object

1.	 Select the dimension object.

2.	 Move the cursor to the Start or End pop-up menu in the End Marks section 
of the Dimension options in the Properties panel/ properties palette and hold 
down the mouse button.
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The pop-up menu opens.

3.	 Drag until the desired end marks are highlighted.

•	 Drag down the Start pop-up menu to choose a left end mark; 

•	 Drag down the End pop-up menu to choose a right end mark; 

4.	 Release the mouse button and the selected end marks will be shown on the 
dimensions line.

To set the end marks before drawing a dimension object

1.	 Make sure nothing on the drawing is selected.

2.	 Move the cursor to the Start or End pop-up menu in the End Marks section 
of the Dimension options in the Properties panel/ properties palette and hold 
down the mouse button.

3.	 Move the cursor to highlight the desired end marks (see above).

4.	 Release the mouse button.

The end marks you specified appear on any new dimension objects you 
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draw and will be shown on the Dimension options in the Properties panel/ 
properties palette.

Drawing dimension objects

MacDraft’s dimension objects include linear (horizontal, vertical, sloped, or 
perpendicular), radial (radius or diameter), and angular dimensions. Once 
created, dimension object’s attributes, such as color, line style, text font, and so 
on can be controlled in the normal way.

Note: Dimension objects are drawn using the current default pen model.

If the dimension object is not linked to an object, it can be independently resized 
and edited much like other MacDraft shapes. In addition, different components of 
a dimension object can be treated independently once the object is disassembled 
using the Break tool available in the Advanced Tools panel/palette.

Note: Using the Break tool on a dimension object will automatically unlink it from 
its associated object.

Linear dimensions Reference points

The user-defined reference points for linear dimensions can be either part of 
existing objects (on corners or edges) or independent points on the drawing. To 
show an object’s size precisely, and to automatically link the dimension object to 
the existing object, it is usually necessary to put the dimension’s reference points 
on the object’s corner points (or other edit handles).

Linear dimension modes

MacDraft’s linear dimension tools (horizontal, vertical, slope, and perpendicular) 
let you display and print distances between points, either in pairs (single 
dimensions), strung together (chained dimensions), or from a single starting point 
(baseline dimensions).

Single

Instructions for drawing single dimension lines are given in the following 
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sections:

Horizontal dimension objects, Vertical dimension objects, Slope dimension 
objects and Perpendicular dimension objects.

Chained  PRO ONLY

For all linear dimension tools, you can draw a string (or chain) of linear 
dimension lines, one after the other. The Chained mode of the dimension tool 
creates a series of single dimension objects, which can be moved, resized, or 
edited independently.

1.	 Open the Dimension Options section of the Properties panel/ properties 
palette, and choose Chained.

2.	 Select a linear dimension tool from the Dimension Tools panel/ palette.

The cursor will now read “1st point.”

3.	 Click the first point for the dimension line.

The cursor will now read “Next Point.”

4.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

5.	 Click the drawing where you want the text box to appear.

The distance between the first two points appears, and the cursor will now 
read “Next Point.”

6.	 Click the next point for the dimension line.
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The cursor will read “Anchor” again.

Note: If you hold down the Shift key, you can constrain the placement of the next 
dimension text block to the same plane as the first segment’s text.

7.	 Click the place in the drawing area where you want the next text box to 
appear. The distance between the second and third points appears, and the 
cursor will now read “Next Point.”

8.	 Continue steps 6 and 7 until you want to exit the dimension-drawing mode; 
to do this, hold down the Option key and click the drawing area.

The dimension objects will be complete, with the appropriate distances 
between the various points selected displayed where specified.

Baseline  PRO ONLY

MacDraft lets you draw several linear dimension lines from one starting point; 
this is called the “Baseline” dimension mode.

1.	 Open the Dimension Options section of the Properties panel/ properties 
palette, and choose Baseline.

2.	 Select a linear dimension tool from the Dimension Tools panel/palette.

The cursor will now read “1st point.”

3.	 Click the first point for the dimension line. (This will be the base point for all 
the dimension objects created in this process.)

The cursor will now read “Next Point.



307 Chapter 4 Annotating your Drawing

4.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

5.	 Click the place in the drawing area where you want the text box to appear.

The distance between the first two points appears, and the cursor will now 
read “Next Point.”

6.	 Click the location for the end point of the next dimension line.

The cursor will read “Anchor” again.

7.	 Click the place in the drawing area where you want the next text box to 
appear.

The distance between the first and third points appears, and the cursor will 
now read “Next Point.”

8.	 Continue steps 6 and 7 until you want to exit the dimension-drawing mode; 
to do this, hold down the Option key and click the drawing area.

The dimension objects will be complete, with the appropriate distances from 
the first baseline point to the various other points displayed at the locations 
specified.

The Baseline mode of the dimension tool creates a series of single dimension 
objects, which can be moved, resized, or edited independently.

Horizontal dimension objects

The horizontal dimension tool creates dimension lines that are constrained to 
horizontal orientation. When edited, moved, or resized, horizontal dimension 
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objects retain their original angle of orientation.

To draw a single horizontal dimension line

1.	 Select the Horizontal dimension tool from the Dimension Tools panel/
palette.

The cursor will now read “1st point.”

2.	 Click the first point for the dimension line (an object's corner, if desired).

The cursor will now read “2nd Point.”

3.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

4.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the horizontal distance between 
the two points displayed where you specified.

5.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Vertical dimension objects

The vertical dimension tool creates dimension lines that are constrained to 
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vertical orientation. When edited, moved, or resized, vertical dimension objects 
retain their original angle of orientation.

To draw a single vertical dimension line

1.	 Select the Vertical dimension tool from the Dimension Tools panel/palette.

The cursor will now read “1st point.”

2.	 Click the first point for the dimension line (an object's corner, if desired).

The cursor will now read “2nd Point.”

3.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

4.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the horizontal distance between 
the two points displayed where you specified.

5.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Slope dimension objects

The slope dimension tool is used to create dimension lines running in any 
direction on a drawing. Slope dimensions can be edited, moved, or resized, and 
the angle changed.
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5.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Perpendicular dimension objects

The perpendicular dimension tool creates dimensions perpendicular to lines or to 
the edges of square-cornered rectangles, polygons, and polylines (single-line or 
parallel-line). When edited, moved, or resized, perpendicular dimension objects 
retain their original angles of orientation.

To draw a single slope dimension line

1.	 Select the Sloped dimension tool from the Dimension Tools panel/palette.

The cursor will now read “1st point.”

2.	 Click the first point for the dimension line (an object's corner, if desired).

The cursor will now read “2nd Point.”

3.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

4.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the horizontal distance between 
the two points displayed where you specified along the slope.
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To create a perpendicular dimension line

1.	 Select the Perpendicular dimension tool from the Dimension Tools panel/
palette.

The cursor will now read “Click Line/Edge.”

2.	 Click the line or edge for the first point of the dimension line.

The cursor will now read “2nd Point.”

3.	 Click the second point for the dimension line.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

4.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the perpendicular distance from 
the edge of the object to the point you chose.

5.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Radial dimension objects

MacDraft’s radial dimension tools let you display and print the radius or diameter 
of a circle, arc, or ellipse.
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Notes: 

•	 Radial dimensions are not rotated together with the ellipses and elliptical arcs 
after dimensions are applied.

•	 Also, ellipses or elliptical arcs can display a radius or diameter only along their 
major and minor axes.

Radius dimensions

To apply a radius dimension to an object

1.	 Select the Radius dimension tool from the Dimension Tools panel/palette.

The cursor will now read “Click Circle/Arc”.

2.	 Click the circle, arc, or ellipse.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

Notes: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point 
where the dimension text is to appear. This option does not work with ellipses and 
elliptical arcs.

3.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the radial distance shown where 
you specified.
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4.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Diameter dimensions

To draw a diameter dimension

1.	 Select the Diameter dimension tool from the Dimension Tools panel/
palette.

The cursor will now read “Click Circle/Arc”.

2.	 Click the circle, arc, or ellipse.

The cursor will now read “Anchor,” and include an outline of the 
dimension’s text box.

Notes: To constrain the angle of the dimension line to 45° increments, after 
selecting the circle, hold down the Shift key while clicking the anchor point where 
the dimension text is to appear.

3.	 Click the place in the drawing area where you want the text value to appear.

The dimension object will be complete, with the diameter distance appearing 
where you specified.
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4.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Circle center marks

MacDraft’s Dimension tools include a special tool for indicating the center of 
circles, ellipses, and arcs.

To apply a Circle center mark

1.	 Select the Circle center mark tool from the Dimension Tools panel/palette.

The cursor will now read “Click Circle/Arc”.

2.	 Click the circle, arc, or ellipse.

The Circle Center mark appears over the object

3.	 Click the Pointer tool or Esc key on your keyboard to exit dimension mode.

Angular dimension objects

MacDraft’s Angular dimension tool lets you display and print the angles 
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between different lines or edges, whether they intersect or not. You can apply an 
angular dimension object to any pair of straight lines or edges of square-cornered 
rectangles, or to polygons or polylines (single-line or parallel-line).

To apply an angular dimension

1.	 Decide which two lines or edges you want to apply the dimension object to.

2.	 Select the Angular Dimension tool from the Dimension Tools panel/palette.

The cursor will now read “Click 1st Line”.

3.	 Click the first line or edge.

The cursor will now read “Click 2nd Line”.

4.	 Click the second line or edge.

The cursor will now read “Anchor”, and include an outline of the 
dimension’s text box.

5.	 Click the drawing where you want the text value to appear.

The dimension object will be complete, with the angle between the two edges 
displayed where you specified.

6.	 Click the Pointer tool or the Escape key on your keyboard to exit the 
dimension mode.

Notes: To display the obtuse rather than acute angle between two lines or edges, 
hold down the Option key after selecting the second edge, while clicking the point 
where the dimension text is to appear.
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Linking and unlinking dimension objects  PRO ONLY

Dimension objects that are drawn with reference to object vertices will be linked 
to those points by default. This means that if the object is resized, the dimension 
object and the value associated with it will be updated to reflect the new size.

Object vertices and dimension objects can be linked and unlinked using some of 
the tools in the Advanced Tools section of the Tools panel or Advanced Tools 
palette. These tools can be used to link object vertices with other object vertices 
in the same way.

Displaying the Advanced tools  PRO ONLY

To display the Advanced tools

•	 Choose Show Left Panel from the View menu, or

•	 Choose left panel icon from the Show/Hide Panels toolbar item.

The Tools panel will appear and the Advanced tools are at the bottom.

Link Unlink Unlink All

Link  PRO ONLY

Dimension objects (and other objects) can be linked by positioning the dimension 
object on an object vertex and using the Link tool from the Advanced tools 
to link the two objects at that point. Once linked, a dimension object will be 
automatically updated if the object it is linked to is resized.

Notes: Dimension objects are automatically linked to object vertices when they are 
first drawn if the preference is enabled in the MacDraft Professional Preferences.

To link objects

1.	 Draw or locate the objects, or object and dimension object, to be linked.
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2.	 Position the objects so that a vertex point of one object is at the same location 
as a vertex point of the other object.

Other vertex points can be linked in the same way.

Unlink  PRO ONLY

Dimension objects (and other objects) can be unlinked from an object by using 
the Unlink tool from the Drafting Tools panel/palette to break the link between 
the two objects at a specific point. Once unlinked, a dimension object will not be 
updated if the object it was previously linked to is resized.

To unlink objects

1.	 Locate the objects, or object and dimension object, to be unlinked.

2.	 Open the Drafting Tools panel/palette (if necessary) and select the Unlink 

3.	 Open the Drafting Tools panel/palette and select the Link tool. 

The cursor will be displayed with a question mark next to it.

4.	 Click the points that are to be linked.

The vertex point of the dimension object will be linked to the other object. If 
the object is resized the dimension object will be automatically updated.
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tool.

The cursor will be displayed with a question mark next to it.

3.	 Click the points that are to be unlinked.

The vertex point of the dimension object will be unlinked from the other 
object. If the object is resized the dimension object will not be updated.

Other linked objects can be unlinked in the same way.

Unlink all  PRO ONLY

You can break all the links for an object by using the Unlink All tool from the 
Drafting Tools panel/palette to break all the links associated with a selected 
object. This will be faster than using the Unlink tool if an object is linked to 
another object at more than one point, or is linked to several different objects, 
and you want to remove all the links.

To unlink all objects

1.	 Select the object (or dimension object) you wish to remove all links from.
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2.	 Open the Drafting Tools panel/ palette and select the Unlink All tool.

3.	 Click Cancel to return to the drawing without removing the links, or click 
Remove to remove all the links from the selected objects.

If you click Remove, all the links will be removed from the selected object. 
If dimension objects were selected, or linked to the selected objects, they will 
no longer be updated if the object is resized.

Breaking dimension objects  PRO ONLY

The Break tool in the Drafting Tools panel/palette can be used to separate 
dimension objects into distinct lines and so on. This is necessary when you want 
to give different line attributes to different parts of a dimension object.

Notes: Using the Break tool on a dimension object automatically unlinks it from its 
associated object.

In most cases, the components of a dimension object are the same after the use 
of the Break tool; that is, their positions and attributes will not change. Once 
the object is broken apart into separate objects, each new object can be moved, 
edited, resized, or otherwise changed like any other MacDraft object.

Notes: A dimension object that has been broken apart cannot be converted back 
(“reassembled”) into a dimension object. The partial exception to this is the fact that 
if the Undo command is used immediately after using the Break tool it will reverse 
the break. However, if elements from a broken-apart dimension object are edited, 
moved, or deselected, the Undo command will not be able to reverse the break.
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Breaking apart a dimension object  PRO ONLY

To break apart a dimension object

1.	 Select the dimension object you want to break apart. 

2.	 Open the Drafting Tools panel/palette and select the Break tool.

The dimension object will become several objects of different types, each of 
which can be edited individually.

Effects of the break tool on dimension objects  PRO ONLY

Different kinds of dimension objects are affected in different ways by the Break 
tool. In all cases, reference points will be lost.

Linear or radial dimensions

Linear or radial dimensions will become an unconstrained point-to-point 
dimension line, with or without end marks as determined by the original object. 
Any witness, extension, or leader lines become unconstrained individual lines, 
and any frame around the dimension text will be deleted.

Angular dimensions

An angular dimension becomes an unfilled radial arc. Any extension arcs become 
separate unfilled radial arcs, and witness or leader lines become unconstrained 
individual lines.

Dimension labels and tolerances

Dimension labels and tolerances become ordinary text objects. Any frame around 
the dimension text will be deleted.

Circle center marks

Circle center marks become individual unconstrained lines.
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Area calculation
MacDraft’s automatic Area Calculation feature can determine and show the area 
of a selected object for you. If you later change the size of the object, the size 
shown changes automatically.

This feature can calculate the areas of simple objects, like rectangles and circles, 
or complex objects, such as complex polygons and freehand shapes. When the 
area of an object is calculated, it always reflects the current scale and units.

Show Area

To calculate the area of an object

1.	 Select the object whose area you want to determine.

2.	 Open the View menu and choose Show Area.

The result of the area calculation will be shown in approximately the center 
of the object.

Modifying area calculation values

MacDraft allows you to change the appearance and/or positioning of area 
calculation values. The current font attributes, including font type and size, are 
used for these values. MacDraft uses the Macintosh system font (usually 13-point 
Lucida Grande) as the preset font and size when you create a new document. 
There may be times when this font size is inconvenient, such as when area values 
are shown on small objects, and the size of the text value overwhelms the size of 
the object.

MacDraft gives you the flexibility to change the value’s font type and size. In 
addition, it allows you to separate the values from their related objects and move 
them to any location on your drawing. In the case of small objects with area 
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values, you can move the area values away from the object. If you want to tidy 
up your drawing, you can move these values into an information table. If you 
change the size of an object, the calculated value in the table will be updated 
automatically to reflect the object’s or line’s new size.

Changing font attributes

To change the font attributes before you use show area

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/ palette. (make sure nothing is selected in the document.)

2.	 To change the font either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Font pop-up menu in Text Options in the Properties panel/
palette.

3.	 Choose the font you would like to use.

4.	 To change the font size either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Size pop-up menu in Text Options in the Properties panel/
palette.

5.	 Choose the size of the font you would like to use.

6.	 Implement the area calculation feature.

The area calculation value text (and any subsequent text entered) will be 
shown in the font and at the text size specified.

To change the font attributes for existing area calculation values

1.	 Select the area calculation value you want to change.

2.	 To change the font either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Font pop-up menu in Text Options in the Properties panel/
palette.
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3.	 Choose the font you would like to use.

4.	 To change the font size either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Size pop-up menu in Text Options in the Properties panel/
palette.

5.	 Choose the size of the font you would like to use.

The area calculation value text selected will be shown in the font and at the 
text size specified.

Note: If you are printing to a PostScript printer, choose a laser printer font to obtain 
a high-quality output.

Moving area calculation values

Area calculation text can be moved away from an object, but if the object is 
subsequently moved, the area calculation text maintains its position relative to 
the object. For example: If you moved the area calculation text from the center of 
a rectangle, repositioned the text above the rectangle, then moved the rectangle, 
the text would follow the movement of the rectangle and remain above it.

Alternatively, the area calculation text can be detached from an object and placed 
in a fixed location. If the object is moved the area calculation text remains in 
its specified position. This unique feature offers an extreme level of flexibility, 
especially if you want to place the values into an information table.

In both cases, the area calculation value remains associated with the object, and 
will be updated if the object is edited.

Moving attached area calculation values

Use this method if you want the area calculation text to remain attached to the 
object it is associated with. The text maintains its position relative to the object.

To move an attached area value
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1.	 Position the cursor on the area value.

2.	 Press and hold down the Shift key.

3.	 Press and hold down the mouse button.

4.	 Release the Shift key.  

5.	 Holding down the mouse button, drag the value to the desired location, then 
release the mouse button.

The area value text will be shown at the specified location, but maintains its 
position relative to the object if the object is moved.

Note: To constrain the movement of the value to a horizontal or vertical direction, 
keep holding the Shift key down as you drag the value to its new location.

Detaching and moving area calculation values

Use this method if you want the area calculation text to be detached from the 
object it is associated with. The text remains in the fixed position even if the 
object is moved. The value remains associated with the object and will be 
updated if the object is edited.

To detach and move area calculation values

1.	 Select the area value you want to detach and move.

2.	 Drag it to the desired position, and it will be detached from the object.

The text remains in the position specified even if the object is moved.

You can reattach the area value by using the Shift key, as explained in 
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"Moving attached area calculation values".

Hide Area

If a selected object shows an area calculation, the View menu command Hide 
Area will be available.

To hide the area calculation display

1.	 Select the object with the area you wish to hide.

2.	 Open the View menu and choose Hide Area.

The area calculation for the selected object will be no longer shown.

Perimeter calculation
MacDraft’s automatic Perimeter Calculation feature can determine and show the 
perimeter of a selected object for you. If you later change the size of the object, 
the size shown changes automatically.

This feature can calculate the perimeter of simple objects, like rectangles and 
circles, or complex objects, such as complex polygons and freehand shapes. 
When the perimeter of an object is calculated, it always reflects the current scale 
and units.

Show Perimeter

To calculate the perimeter of an object

1.	 Select the object whose perimeter you want to determine.

2.	 Open the View menu and choose Show Perimeter.

The result of the perimeter calculation will be shown in approximately the 
center of the object.
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Modifying perimeter calculation values

MacDraft allows you to change the appearance and/or positioning of perimeter 
calculation values. The current font attributes, including font type and size, are 
used for these values. MacDraft uses the Macintosh system font (usually 13-point 
Lucida Grande) as the preset font and size when you create a new document. 
There may be times when this font size is inconvenient, such as when area values 
are shown on small objects, and the size of the text value overwhelms the size of 
the object.

MacDraft gives you the flexibility to change the value’s font type and size. In 
addition, it allows you to separate the values from their related objects and move 
them to any location on your drawing. In the case of small objects with perimeter 
values, you can move the perimeter values away from the object. If you want to 
tidy up your drawing, you can move these values into an information table. If 
you change the size of an object, the calculated value in the table will be updated 
automatically to reflect the object’s or line’s new size.

Changing font attributes

To change the font attributes before you use show perimeter

1.	 Return to the pointer mode, by selecting the Pointer tool in the Drafting 
Tools panel/palette. (make sure nothing is selected in the document.)

2.	 To change the font either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Font pop-up menu in Text Options in the Properties panel/
palette.

3.	 Choose the font you would like to use.

4.	 To change the font size either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Size pop-up menu in Text Options in the Properties panel/
palette.

5.	 Choose the size of the font you would like to use.

6.	 Implement the perimeter calculation feature.
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The perimeter calculation value text (and any subsequent text entered) will 
be shown in the font and at the text size specified.

To change the font attributes for existing perimeter calculation values

1.	 Select the perimeter calculation value you want to change.

2.	 To change the font either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Font pop-up menu in Text Options in the Properties panel/
palette.

3.	 Choose the font you would like to use.

4.	 To change the font size either:

•	 Open the Font submenu from the Text menu and choose Show Fonts, or

•	 Click the Size pop-up menu in Text Options in the Properties panel/
palette.

5.	 Choose the size of the font you would like to use.

The perimeter calculation value text selected will be shown in the font and at 
the text size specified.

Note: If you are printing to a PostScript printer, choose a laser printer font to obtain 
a high-quality output.

Moving perimeter calculation values

Perimeter calculation text can be moved away from an object, but if the object is 
subsequently moved, the perimeter calculation text maintains its position relative 
to the object. For example: If you moved the perimeter calculation text from the 
center of a rectangle, repositioned the text above the rectangle, then moved the 
rectangle, the text would follow the movement and remain above it.

Alternatively, the perimeter calculation text can be detached from an object and 
placed in a fixed location. If the object is moved the perimeter calculation text 
remains in its specified position. This unique feature offers an extreme level of 
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flexibility, especially if you want to place the values into an information table.

In both cases, the perimeter calculation value remains associated with the object, 
and will be updated if the object is edited.

Moving attached perimeter calculation values

Use this method if you want the perimeter calculation text to remain attached 
to the object it is associated with. The text maintains its position relative to the 
object.

To move an attached perimeter value

1.	 Position the cursor on the perimeter value.

2.	 Press and hold down the Shift key.

3.	 Press and hold down the mouse button.

4.	 Release the Shift key.  

5.	 Holding down the mouse button, drag the value to the desired location, then 
release the mouse button.

The perimeter value text will be shown at the specified location, but 
maintains its position relative to the object if the object is moved.

Note: To constrain the movement of the value to a horizontal or vertical direction, 
keep holding the Shift key down as you drag the value to its new location.

Detaching and moving perimeter calculation values

Use this method if you want the perimeter calculation text to be detached from 
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the object it is associated with. The text remains in the fixed position even if 
the object is moved. The value remains associated with the object and will be 
updated if the object is edited.

To detach and move perimeter calculation values

1.	 Select the perimeter value you want to detach and move.

2.	 Drag it to the desired position, and it will be detached from the object.

The text remains in the position specified even if the object is moved.

You can reattach the perimeter value by using the Shift key, as explained in 
"Moving attached perimeter calculation values".

Hide Perimeter

If a selected object shows an perimeter calculation, the View menu command 
Hide Perimeter will be available.

To hide the perimeter calculation display

1.	 Select the object with the perimeter you wish to hide.

2.	 Open the View menu and choose Hide Perimeter.

The perimeter calculation for the selected object will be no longer shown.

Subscript & Superscript

MacDraft has the ability to create subscript and superscript text. You can also edit 
the position of text in relation to the baseline by raising it or lowering it. You can 
use these functions to create text such as 42o or H2O.

To create subscript text

1.	 Select the Text tool in the Drafting Tools panel/ palette.

2.	 Draw out a rectangle of paragraph text by clicking and dragging the cursor. 

3.	 Type text including the characters you wish to make subscript.

4.	 Press the Esc key or choose the pointer tool to confirm the text. 

5.	 With the cursor tool selected, highlight the characters you wish to make 
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subscript. 

6.	 Go to the Text menu

7.	 Go to the Transformations sub-menu

8.	 Go to the Baseline sub-menu

9.	 Choose Subscript. 

	 The Text will update and will now be subscript. 

Note: You can edit how high or low a character appears on the Baseline via the Text 
> Transformations > Baseline submenu. 

To create superscript text

1.	 Select the Text tool in the Drafting Tools panel/ palette.

2.	 Draw out a rectangle of paragraph text by clicking and dragging the cursor. 

3.	 Type text including the characters you wish to make superscript.

4.	 Press the Esc key or choose the pointer tool to confirm the text. 
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5.	 With the cursor tool selected, highlight the characters you wish to make 
superscript. 

6.	 Go to the Text menu

7.	 Go to the Transformations sub-menu

8.	 Go to the Baseline sub-menu

9.	 Choose Superscript. 

	 The Text will update and will now be superscript. 

You can edit how high or low your text appears along the baseline. The baseline 
is the default line that text is written on when you start typing. The position of the 
text can be increased or decreased incrementally via the Baseline options in the 
Text menu. 

To raise text above the baseline

1.	 Highlight the text you wish to edit

2.	 Go to the Text menu

3.	 Go to the Transformations sub-menu 
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4.	 Choose Raise

	 The highlighted text will be raised once

Note: If you follow steps 1 to 4 again the text will raise again. You can keep doing 
this until the text is the height you desire.  

To lower text below the baseline

1.	 Highlight the text you wish to edit

2.	 Go to the Text menu

3.	 Go to the Transformations sub-menu 

4.	 Choose Lower

	 The highlighted text will be lowered once

Note: If you follow steps 1 to 4 again the text will lower again. You can keep doing 
this until the text is the depth you desire.  
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Chapter 5
Transforming and arranging 

your objects

Once created, objects in your MacDraft drawing can be moved, duplicated, 
transformed, and arranged in many different ways. To avoid objects being altered 
in error, items can be locked, and a find and replace feature allows multiple 
identical changes to be performed quickly. These features are discussed in this 
chapter. MacDraft offers several useful drawing aids that help you to position 
objects easily.

Top Tip: The application can convert units for you. (i.e. If you are working 
in inches but type "mm" after the number the application will convert those 
millimeters to inches.)

Moving objects
You may create an object, then decide you want to move it to a new location on 
your drawing or into a different drawing. MacDraft provides several different 
methods of moving objects: drag and drop; cut/copy and paste; the Move 
command; the Resize options; the arrow keys; and the Position command. 
Objects can also be removed permanently by using the Clear function.

Drag and drop

Drag and drop can be used to move objects to/from a MacDraft document to/
from a variety of locations.

Drag and drop an object or group of objects from a MacDraft document to:

•	 The same document window (to move or copy the object or group).
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•	 The Library Window. 

Drag and drop an object or group of objects into a MacDraft document:

•	 Library Window.

•	 Any PICT file can be dragged directly into a MacDraft document window.

•	 Items in other image and graphics file formats, such as JPEG and PDF files, 
can be dragged into MacDraft.

The drag and drop process

In its simplest form, drag and drop can be used to move an object or group of 
objects within a MacDraft document. To perform other drag and drop actions, 
you must press additional “modifier” keys. The modifier keys required to perform 
specific actions are described later in this chapter.

To use drag and drop

1.	 Select the object you want to move by clicking it.

2.	 Position the cursor over the object.

3.	 Press down a modifier key if required (see next section).

4.	 Press and hold down the mouse button.

Note: Be careful not to position the pointer on an edit handle when you move an 
object. Edit handles are for changing the size and shape of an object

5.	 Holding down the mouse button, drag the object to its new location.

6.	 Release the mouse button.
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When you drag objects, “ghost” images of the objects will be visible as you 
drag them. The original stays in place until you release the mouse button.

Drag and drop modifier keys

Various keys perform a special function when used during the process of clicking 
the object(s) to be dragged. Once the drag action is started, these modifier keys 
have no effect and can be released. The same modifier keys may perform other 
functions when used during the process of releasing the mouse button to drop the 
dragged object(s).

Using drag and drop within a MacDraft document

To move an object within a MacDraft document using drag and drop

•	 No modifier key is required.

To copy an object within a MacDraft document using drag and drop

•	 Hold down the Option key at any time.

The original object selected remains in place, and a copy of it will be placed 
at the new location.

To constrain the movement of an object

•	 Hold down the Shift key while dragging an object to constrain the object's 
movement to either a horizontal or vertical direction.

Note: If you drag an object beyond the borders of the drawing area, the drawing 
automatically scrolls. In additions objects can be placed in the area around the 
document space, but they will not print or export.



336Chapter 5 Transforming and Arranging Objects

Using drag and drop to move an object via its anchor point

You can drag an object via one of its anchor points. If you want to move an 
object such as a rectangle via one of its corners you can do so by selecting the 
object to highlight is anchor points, then hold down the Option & Command keys 
and click and drag the anchor point of the rectangle. Release the mouse and keys 
to place. 

Note: The modifier keys are very important here. If you dont use them you will 
simply resize the object rather than moving it. If you have Object Snap on you can 
snap the point you are moving to another. 

Using drag and drop with multiple objects

To move multiple objects or grouped objects, simply select the objects or group 
you want to move, then drag the objects or group to a new position.

Alternatively, hold down the Shift key to drag only the object or group clicked, 
rather than all of the selected objects. Release the Shift key once the drag action 
has been started.

Cut/copy and paste

By using the Cut, Copy and Paste functions, you can remove or copy objects 
from one location on your drawing, then paste them into another location in the 
same drawing, a different drawing, or a different application.

The Cut function deletes selected objects from the drawing and places them on 
the Clipboard.

The Copy function makes a copy of selected objects and places the copy on the 
Clipboard, while leaving the original objects in place.

You can place several objects on the Clipboard as long as they are selected and 
cut or copied at the same time. The objects are stored on the Clipboard until 
you are ready to paste them onto the drawing, or until you use the Cut or Copy 
function again.
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Using cut/copy and paste within a single MacDraft document

Cut and paste

1.	 Select the object you want to move.

2.	 Open the Edit menu and choose Cut.

The selected object is removed from the drawing.

3.	 Click the place where you want to paste the cut object.

4.	 Open the Edit menu again and choose Paste.

The object reappears at the location where you clicked.

You can continue to paste objects that have been cut into as many areas on 
your drawing as you like by simply selecting the insertion point and choosing 
Paste from the Edit menu. The objects remain on the Clipboard until you 
cut or copy a different object on your drawing, then the first object will be 
replaced with the new object on the Clipboard.

Copy and paste

The Copy and Paste functions allow you to make a copy of an object and paste 
the copy into another area of the drawing without affecting the status of the 
original. 

1.	 Select the object you want to copy.

2.	 Open the Edit menu and choose Copy.

A copy of the object will be stored on the Clipboard for your use.

3.	 Click the place where you want to paste the copy.

4.	 Open the Edit menu again and choose Paste.

The object will be pasted in at the new location.

You can continue to paste objects that have been copied into as many areas 
on your drawing as you like by simply selecting the insertion point and 
choosing Paste from the Edit menu. The objects remain on the Clipboard 
until you cut or copy a different object on your drawing, at that time the first 
object will be replaced with the new object on the Clipboard.
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Note: All Cut, Copy and Paste commands can be sped up using keyboard shortcuts:
Cut (CMD + X), Copy (CMD + C) and Paste (CMD + V).

Using cut/copy and paste to transfer items from one MacDraft document to 
another 

Cut and paste

MacDraft allows you to cut/copy and then paste all or part of a drawing into 
another MacDraft document.

To cut or copy part of a drawing

1.	 Select all or the part of the drawing you wish to place in another document.

2.	 Open the Edit menu and choose Cut or Copy.

The selected objects will be stored on the Clipboard.

To paste objects into a different MacDraft document

1.	 Open the document into which you wish to paste the objects stored on the 
Clipboard.

2.	 Click the place where you want to paste the objects into the drawing.

3.	 Open the Edit menu and choose Paste.

The objects that you cut or copied will be pasted into the specified location.

Note: When you cut or copy objects from one drawing and paste them into another 
drawing, the objects that you pasted take on the scale of the new drawing. For 
example, if you copy an object from a drawing with a scale of 1" = 20', then paste 
it into a drawing with a scale of 1" = 10', the object would appear twice as large as 
it did on the original drawing. In reality, the object is still the same size, but it is 
represented at the new scale. To avoid this use the Paste Unscaled feature.

Paste unscaled

If you hold down the Shift key, the Paste command in the Edit menu changes 
to Paste Unscaled. Use the Paste Unscaled command to paste an object into a 
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document and have it appear at its original size, regardless of any differences in 
view scale between the object and the destination document window.

Repeated paste

You may often want to use an object on your drawing in more than one location. 
To accomplish this you can use either the Copy and Paste functions, the 
Duplicate function or the Repeated Paste function. These functions save you the 
time of redrawing the object again and again.

The Repeated Paste function is used to paste multiple copies of the same object 
into various locations on a drawing. When using Repeated Paste, any object on 
the Clipboard is pasted into the drawing at each point you click. While in this 
mode, you can scroll the window and continue to paste in objects.

To use the repeated paste function

1.	 Open the Edit menu and choose Cut or Copy.

2.	 Select the Repeated Paste tool in the Tool panel/palette or open the Edit 
menu and choose Repeated Paste.

The cursor changes to an “X”.

3.	 Click the point you want to paste the object.

4.	 Continue to move the cursor and click the areas on the drawing until you’ve 
pasted as many copies of the object as you want into your document.
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A copy of the object appears at each point you click the drawing. The object’s 
datum point will be used as the reference point for the paste operation.

5.	 Click the Pointer tool or Escape key on your keyboard when you have 
finished pasting.

Using cut/copy and paste to transfer items from MacDraft to other 
applications

At times you may want to use MacDraft in conjunction with other applications, 
such as a word processor. For example, you may want to paste a chart into 
MacDraft to enhance its appearance, then paste it into a layout document.

Transferring objects from Microspot MacDraft

To transfer objects to other applications using the clipboard:

1.	 Select the object or objects you want to move.

2.	 Open the Edit menu and choose Cut or Copy.

The selected objects will be placed on the Clipboard.

3.	 Switch to another application and once you leave MacDraft, all objects on 
the Clipboard will be converted to the PICT format.

4.	 In the new application, open the Edit menu and choose Paste.

The cut or copied objects appear as a PICT image in the new application’s 
document window.

The Move command

With the Edit menu’s Move command, you can move objects or groups with 
great precision by entering values from the keyboard.

Objects can either be moved to a specific location (absolute move), or moved by 
a specified amount (relative move). The setting for Absolute or Relative mode 
in the Move dialog will be stored for subsequent openings of the dialog, until the 
application is closed.

The coordinates or distances are shown in the current layer's scale and units. The 
Move a Copy option places a copy of the selection in a specified location while 
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leaving the original in place.

In MacDraft Professional you can also move objects or groups you select to 
another layer. Because the Move dialog opens with the selection’s current 
location entered, you can easily move or copy it to the same spot on a different 
layer. This can be useful, for example if you need to show walls or posts in the 
same location on many layers in a plan view drawing.

Note: The Move command can only move or copy objects between layers that have 
the same scale. To move objects between layers with different scales, use the Cut or 
Copy and Paste commands.

The datum point of the selected object or group is used as the reference for 
moving. Therefore, to move an object, you specify the desired location (the X 
and Y coordinates) of the object’s datum point. If you select multiple objects or 
groups, MacDraft uses the datum point of the top left item as the reference.

Absolute move

To move objects or groups to a particular location on the drawing

1.	 Select the objects or groups you want to move.

2.	 Open the Edit menu and choose Move.

The Move dialog appears.

3.	 Choose Absolute from the Position pop-up menu if necessary. The current 
location of the selection will be shown.
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4.	 Type in the X and Y coordinate values for the new location.

5.	 To move the selection to another layer, choose the layer name from the To 
Layer pop-up menu. PRO ONLY

6.	 To leave the original in place, moving only a copy, click the Move a Copy 
checkbox.

7.	 Click one of the following buttons:

•	 Apply: To apply the changes and leave the dialog open.

•	 Close: To close the dialog without applying the changes.

•	 Done: To apply the changes and close the dialog.

8.	 The selection (or a copy of it) is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the 
coordinate system is the upper left corner of the window. The rulers along the top 
and left sides of the window are used to control the zero origins. In this default 
coordinate system, X values increase from left to right and Y values increase 
from top to bottom. You can change the zero origins of the rulers.

Note: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Relative move

In relative movement, positive values for distance move items to the right (in the 
∆X field) or downward (in the ∆Y field). Negative values move items to the left 
or upwards.

To move items relative to their original position

1.	 Select the objects or groups you want to move.

2.	 Open the Edit menu and choose Move. 

The Move dialog appears.

3.	 Choose Relative from the Position pop-up menu if necessary. The starting 
position will be shown as zeroes in the ∆X (horizontal change) and ∆Y 
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(vertical change) fields.

4.	 Enter values to move the selection by into the ∆X and ∆Y fields.

5.	 To move the selection to another layer, choose the layer name from the To 
Layer pop-up menu. PRO ONLY

6.	 To leave the original in place, moving only a copy, click the Move a Copy 
checkbox.

7.	 Click one of the following buttons:

•	 Reverse: To apply the entered values as though they were negative 
amounts.

•	 Apply: To apply the changes and leave the dialog open.

•	 Close: To close the dialog without applying the changes.

•	 Done: To apply the changes and close the dialog.

8.	 The selection (or a copy of it) is moved to the new location.

Note: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

The Resize options

Most of the controls in the Resize options are discussed in Chapter 2. However 
the Resize options can also be used to move a single object or group, within the 



344Chapter 5 Transforming and Arranging Objects

current active layer, and these controls are discussed in this section.

To display the Resize & Position options

1.	 Open the right panel by choosing Show Right Panel from the View menu or 
if you are in palette mode, the Propeties Palette from the Window menu. 

A tick will be next to the menu item  

2.	 Open the Properties panel/ palette and scroll down to the Resize options.

Note: You can also show and hide the right panel using the Show Hide Panels 
toolbar item for quick access. The Select Pt button is not relevant to the move 
operation and has no use when moving objects.

Moving objects using the Resize & Position options

The Resize & Position panel / palette's Position X and Y fields can be used to 
move a selected object or group to an absolute position on the drawing or by 
relative horizontal and vertical distances. All movement is defined in the units 
and scale of the active layer.

Absolute move

To move objects or groups to a particular location on the drawing

1.	 Select the objects or groups you want to move.

2.	 Open the Resize & Position options in the Properties panel / palette.
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3.	 Choose Absolute from the Position toggle options if necessary. The current 
location of the selection appears.

4.	 Type in the X and Y position values for the new location.

5.	 Click the Apply button.

The selection is moved to the new location.

The default zero origin for both rulers (the point where X=0 and Y=0) of the 
coordinate system is the upper left corner of the window. The rulers along the top 
and left sides of the window are used to control the zero origins. In this default 
coordinate system, X values increase from left to right and Y values increase 
from top to bottom. You can change the zero origins of the rulers.

Note: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Relative move

In relative movement, positive values for distance move items to the right (in the 
X field) or downward (in the Y field). Negative values move items to the left or 
upwards.

To move items relative to their original position

1.	 Select the objects or groups you want to move.

2.	 Open the Properties panel / palette and scroll down to the Resize & Position 
options.

3.	 Choose Relative from the Position toggle options if necessary. The starting 
position will be shown as zeroes in the X (horizontal change) and Y (vertical 
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change) fields.

4.	 Enter values to move the selection by into the X and Y fields.

5.	 Click the Apply button.

The selection is moved to the new location.

Note: If the move operation requires the object to be moved beyond the edge of the 
drawing, an alert appears.

Moving using the arrow keys

Selected objects and groups can be moved using the arrow keys on the keyboard.

When a grid snap is on, each press of an arrow key moves (or “nudges”) the 
current selection one grid increment in the appropriate direction: left, right, up, 
or down. If no grid snap is on, the selection moves one screen pixel (1/72 of an 
inch) for each keystroke.

Press and hold down the Command key and press an arrow key to release the 
selection from the grid snap and allow the selection to be moved by one pixel.

The Position command  PRO ONLY

Sometimes you may decide that a drawing you have started needs to be moved so 
that the items appear on a different area of the page when printed.

One way to move the whole drawing is to select all objects, then drag them to a 
better position, however this can only be done for one layer at a time.

MacDraft’s Position command allows you move all the objects on all layers at 
one time, by specifying where you want the top left corner of the image to be. 
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You enter values to show how far you want the image to be from the top and left 
edges of the drawing window.

Note: When a drawing is printed, the edge of the drawing window represents the 
edge of the printable area on the page, which is usually a little smaller than the 
whole page.

Positioning your drawing on the page  PRO ONLY

To change the drawing’s position on the page

1.	 Choose Position... from the Layout menu.

If the document contains objects, the Position dialog appears. (If there are 
no objects in the drawing the Position dialog does not appear, and an alert 
sounds.)

The onscreen position of the current upper left corner is shown in the dialog.

Note: There may not be an object at that location because the corner is defined by 
an imaginary rectangle that encloses all objects on all layers of the drawing. The 
location shown reflects all layers, even those that are currently hidden.

As the Position Document dialog is used to control the position of the 
drawing on the printed page, the values shown do not reflect the drawing’s 
scales or rulers, but the actual distance on the screen (and on the printed 
page). This means that even if the drawing is set to show ten feet per inch, 
with the zero points of both rulers in the center of the image, the Position 
Document dialog shows the onscreen distances from the left and top edges 
of the drawing window, in the current document’s onscreen units, whether 
inches or centimeters.

2.	 Select the Left (X) field and enter the distance you want the image to be from 
the left edge of the drawing window (and from the left edge of the print area 
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on the finished page).

3.	 Select the Top (Y) field and enter the distance you want the image to be from 
the top edge of the drawing window (and from the top of the print area on the 
finished page).

4.	 Click the OK button.

Your entire drawing will be moved within the document window according 
to your specifications.

Note: If you enter values that are too large, an alert appears telling you the range 
of possible values. If this happens, click the alert box’s OK button, then enter new 
values in the X and Y fields as needed.

MacDraft lets you move objects partly or entirely off the page. This happens if 
you enter a negative value or an extremely large positive value for one or both 
fields. Negative values move the top left corner of the image beyond the top or 
left edge of the document, and large positive values could move the bottom right 
corner of the image beyond the bottom or right edge of the document.

If you accidentally move part of your drawing beyond the drawing window, you 
can bring it back by using the Edit menu’s Undo command immediately or by 
using the Position command again and entering different values in the X and Y 
fields as needed.

The Clear function

Objects can be removed permanently from the drawing using the Clear function. 
The object can only be recalled by using Undo.

Top Tip: You can also press the Delete key or the Backspace key on your keyboard 
to delete the selections. You may also be able to recall something before the deletion 
by using the Revert To command in the File menu.

Using the Clear function

To clear a single object

1.	 Select the object to be deleted from the drawing by clicking it.
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2.	 Open the Edit menu and choose Clear.

The selected object will be removed from the drawing.

To clear multiple objects

1.	 Select the objects to be deleted from the drawing by Shift-clicking them, or 
by using the selection rectangle.

2.	 Open the Edit menu and choose Clear.

The selected objects will be removed from the drawing.

To clear the entire contents of a layer

There may be times when you want to throw away all the contents of the active 
layer and start over again. To accomplish this:

1.	 Open the Edit menu and choose Select All.

All the objects on the active layer will be selected.

2.	 Open the Edit menu again and choose Clear.

All the objects on the active layer will be removed from the drawing.

Top Tip: You can also use the keyboard shortcut CMD + A to select all data on the 
active layer. Do this and then press the delete or backspace key to quickly delete all 
data on the active layer. 

Duplicating objects
Objects can be duplicated by using the Duplicate command or by using the 
Linear and Circular duplication features.

The Duplicate command

The Duplicate command is used to make an exact copy of any object or line on 
the drawing. The duplicate object is placed in front of the original in a slightly 
offset position, and is selected. You can then drag the duplicate into the desired 
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position on your drawing.

Using the Duplicate command To duplicate an object

1.	 Select the object you want to duplicate.

2.	 Open the Edit menu and choose Duplicate form the Duplication submenu.

The object is duplicated. The duplicate object is placed in front of the 
original in an offset position, which is 1 increment of the current grid 
horizontally and vertically.

3.	 To make a second or third duplicate, simply choose the Duplicate command 
again, and again. Each new duplicate appears in front of the previous one.
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Top Tips:

•	 Hold down the Shift key and the Duplicate command changes to Duplicate 
without offset. Use this option to create a duplicate that is placed directly on 
top of the original.

•	 The keyboard shortcut for Duplicate is CMD + D.

•	 Hold down the Control key to avoid duplicating locked objects. All other 
objects in the selection will be duplicated.

•	 Hold down the Option key and drag the item to duplicate.

Auto-spacing of duplicate objects

If you want to create a row or column of identical, evenly spaced objects, the 
Duplicate function incorporates an auto-spacing feature that allows you to 
determine the distance and angle you want between objects. You can then make 
new duplicates that will be automatically placed at that distance and angle.

To use auto-spacing during creation

1.	 Select the object to be duplicated.

2.	 Open the Edit menu and choose Duplicate or Duplicate With No Offset 
form the Duplication submenu.

3.	 Position the cursor over the selected duplicate, hold down the mouse button, 
drag the duplicated object to the desired position relative to the original, and 
release the mouse button. (Alternatively move the duplicate using the arrow 
keys on your keyboard.)
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4.	 Open the Edit menu and choose Duplicate from the Duplication submenu.

Notice that the second duplicate is automatically placed in the same position 
relative to the first duplicate as the first duplicate is to the original.

5.	 Keep choosing Duplicate to produce as many duplicates as you need or use 
CMD + D to quickly place more duplicates. 

Linear duplication  PRO ONLY

The Linear Duplication feature allows you to make many duplicates of objects 
or groups, laid out in straight lines or arrays, in just a few steps.

The Linear Duplication dialog allows you to specify the distance and angle 
of duplication, as well as the number of directions (one or two) for duplicating 
selections.

You can also define the duplication interval by horizontal and vertical offset. 
(Duplication distances appear in the scale and units of the drawing).

The Linear Duplication dialog  PRO ONLY

•	 Choose Linear from the Duplication submenu in the Edit menu to open the 
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Linear Duplication dialog.

One or two directions

Linear duplication can be used to produce single rows and columns of 
duplicates, or to produce sets of rows or columns (arrays).

One Direction

Choose One Direction from the Direction pop-up menu if you wish to create a 
single row or column of duplicates.

Two Directions

Choose Two Directions from the Direction pop-up menu if you wish to create 
multiple rows or columns of duplicates.

Number of copies

Enter the number of copies desired.

Distance and angle

Click the Distance & Angle radio button to define the space between duplicates 
by entering values in the Distance and Angle fields.

Distance

Enter the distance you want between copies. Distances between objects will be 
set in the drawing’s scale and units.
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Angle

In the Angle field, type the desired angle of duplication.

Angle values increase counterclockwise: zero degrees is straight to the right, 
90° is straight up, 180° is straight to the left, and 270° is straight down the page. 
Negative values make the angles increase in the opposite (clockwise) direction.

X and Y offset

The duplication interval can also be defined by horizontal and vertical offset, 
entering an X and Y value to determine the positions of the copies.

Click the X & Y Offset radio button to activate the X and Y fields. Positive 
values move the duplicate down and to the right, negative values move duplicates 
up or to the left.

∆X: Enter the desired horizontal offset for each duplicate.

∆Y: Enter the desired vertical offset for each duplicate.

Duplicating in a single direction  PRO ONLY

To duplicate an object or group in a single direction

1.	 Select the object or group to be duplicated.

2.	 Open the Edit menu’s Duplication submenu and choose Linear... The 
Linear Duplication dialog appears.

3.	 In the Number of Copies field, type the total number of copies you want 
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(including the original).

4.	 Click the Distance & Angle or X & Y Offset radio button.

5.	 Enter values in the Distance and Angle fields, or the X and Y Offset fields.

6.	 Click OK and a line of duplicates appears, beginning with the original 
selection.

Duplicating in two directions  PRO ONLY

With Linear Duplication, you can duplicate an object or group in two directions 
at the same time. You create a row or column of duplicates and simultaneously 
create duplicates of that row or column.

Two-direction duplication can create rectangular arrays in the simplest case, or 
sets of rows and columns offset at any combination of distances or angles.
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To duplicate in two directions

1.	  Select the object or group to be duplicated.

2.	 Open the Edit menu’s Duplication submenu and choose Linear... 

The Linear Duplication dialog appears.

3.	  As detailed in the preceding section, specify the first direction’s number of 
copies and their duplication offset, by distance and angle or X/Y offset.

4.	 Choose Two Directions from the Direction pop-up menu.

The choices for Two Directions become active.

5.	 Enter the second direction’s number of copies and their duplication offset, by 
distance and angle or X/Y offset.

The Two Directions settings define the number and locations of the 
duplicates of the row or column defined by the One Direction settings.

6.	 Click OK.

The duplicates appear: an “original” row or column as defined by the settings 
under One Direction, and duplicates of that row or column defined by the 
settings under Two Directions.
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Circular duplication  PRO ONLY

At times you may want multiple copies of shapes or groups to appear in circular 
arrangements on a drawing. You can achieve this effect by carefully copying, 
dragging, and rotating objects, but it’s usually easier to use MacDraft’s circular 
duplication feature.

The circular duplication options allow you to duplicate objects or groups so that 
they appear arranged along a circle or arc, or in concentric circles or arcs.

The Circular Duplication dialog PRO ONLY

•	 Choose Circular from the Duplication submenu in the Edit menu to open 
the Circular Duplication dialog.
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Duplication From: Circle center 

X,Y: Enter the X,Y coordinates for the point you wish to duplicate the objects 
around, or use the Next Mouse Click option below.

Duplication From: Next mouse click

Choose the Next Mouse Click options from the Duplication From pop-up 
menu if you want to specify the point you wish to duplicate the objects around 
by pointing and clicking the drawing. When you choose Next Mouse Click then 
click OK, the dialog disappears and the centering cursor will be shown over your 
drawing. Click the desired center point.

First circle/arc Number of copies

Enter the number of copies of the object that you want to end up with, including 
the original.

Rotate copies

Click the Rotate Copies checkbox if you wish the duplicates to be rotated 
according to their position on the circle/arc.

By object’s

•	 Center: Choose Center from the By Object's pop-up menu to specify that 
the duplication should be performed in relation to the center of the object.

•	 Datum: Choose Datum from the By Object's pop-up menu to specify that 
the duplication should be performed in relation to the object’s datum point.



359 Chapter 5 Transforming and Arranging Objects

Distribute

•	 Proportionally: Click the Proportionally radio button to space the copies 
evenly around the circle or arc.

•	 Incremental: Click the Incremental radio button to position each copy a 
specified angle from the previous copy.

Angle

•	 If you selected proportionally, enter a value for the sweep of the circle or arc.

•	 If you selected incremental, enter a value for the angle between each copy.

Concentric circles/arcs 

Total number: Enter the total number of concentric circles or arcs you wish to 
produce.

Radius: Enter the distance (in the scale and units of the drawing) you want 
between the concentric circles or arcs.

Shift copies: Enter a value to specify the amount of angular shift between each 
circle or arc.

Using circular duplication  PRO ONLY

To duplicate an object or group in a single circle  PRO ONLY

1.	 To duplicate an object or group in a single circle.

2.	 Choose Circular from the Duplication submenu in the Edit menu. The 
Circular Duplication dialog appears.

3.	 In the Number of Copies field, type the total number of copies you want 
(including the original).
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4.	 Ensure that Distribute: Proportionally is selected, and that the angle 
entered is 360°. These settings ensure that the copies will be distributed all 
the way around a circle.

5.	 Choose Center from the By Object's pop-up menu to distribute in relation to 
the object’s center.

6.	 Ensure that Rotate Copies is on, so that each copy is rotated according to its 
position on the circle.

7.	 To locate the Circle Center (the center of distribution), ensure the Next 
Mouse Click choice is on, click OK to close the dialog, then click the 
desired center point.

A ring of duplicates appears, centered around the point, and according to the 
settings, you specified.
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Note: You can hold down the C, E or M key whilst moving the cross hair to snap to 
the Centre (C), Edge (E) or Mid-Point (M) of the desired object. 

To duplicate an object or group proportionally along an arc  PRO ONLY

1.	 Select the object or group you want to duplicate.

2.	 Choose Circular from the Duplication submenu in the Edit menu. The 
Circular Duplication dialog appears.

3.	 Enter the total number of copies you want (including the original).

4.	 Ensure Distribute: Proportionally is selected.

This distributes the copies evenly along the arc you specify in the next step.

In the Angle field, enter the total degrees for the sweep of the arc.

Note: A positive angle value yields a counterclockwise sweep, a negative value 
yields a clockwise sweep.

5.	 Click Center to fix the distribution between the duplicates’ centers.

6.	 Click Rotate Copies so that each copy is rotated according to its position on 
the arc.

7.	 To locate the Circle Center (the center of distribution), ensure the Next 
Mouse Click choice is on, click OK to close the dialog, then click the 
desired center point.
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The duplicates appear, proportionally filling the arc you defined, centered 
around the point you specified.

The position of the original object relative to the circle center determines the 
starting angle and the distribution radius of the duplicates.

To duplicate an object or group incrementally along an arc  PRO ONLY

1.	 Select the object or group you want to duplicate.
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2.	 Select Circular from the Duplication submenu in the Edit menu. The 
Circular Duplication dialog appears.

3.	 Enter the total number of copies you want (including the original).

4.	 Ensure Distribute: Incremental is selected.

5.	 In the Angle field, enter the degrees desired between copies.

This setting spaces each copy by the number of degrees you specify.

Note: A positive angle value yields a counterclockwise sweep, a negative value 
yields a clockwise sweep.

6.	 Click Center to fix the distribution between the duplicates’ centers.

7.	 Click Rotate Copies for each copy to be rotated according to its position on 
the arc.

8.	 To locate the Circle Center (the center of distribution), ensure the Next 
Mouse Click option is on, click OK to close the dialog, then click the 
desired center point.
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The duplicates appear, incrementally spaced at the angle specified. The 
position of the original object relative to the circle center determines the 
starting angle and the distribution radius of the duplicates.

Duplicating concentric circles or arcs  PRO ONLY

To duplicate a selection in multiple circles or arcs, you use the same methods as 
in single circle duplication to define a single ring or arc, you can then specify the 
number of concentric circles or arcs, the distance between additional circles or 
arcs, and the shift angle (if any) for each circle or arc.

To duplicate a selection in basic multiple arcs or circles  PRO ONLY

1.	 Select the object or group you want to duplicate.
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2.	 Select Circular from the Duplication submenu in the Edit menu. The 
Circular Duplication dialog appears.

3.	 Follow the steps described in To duplicate an object or group in a single 
circle.

4.	 In the Concentric Circles/Arcs: Total Number field, enter the number of 
circles or arcs desired.

5.	 In the Radius field, enter the distance desired (in the drawing’s scale and 
units) between concentric circles or arcs.

This value defines the distance each additional arc or circle appears outside 
the first arc or circle; it does not affect the distance from the innermost circle 
or arc to the center of the array.

6.	 To locate the Circle Center (the center of distribution), ensure the Next 
Mouse Click choice is on, click OK to close the dialog, then click the 
desired center point.

The duplicates appear, in the number of concentric circles or arcs you 
defined, centered around the point you specified.
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To duplicate a selection in multiple arcs or circles using the Shift Copies 
option  PRO ONLY

1.	 Define the initial circle and concentric circles as in the example above.

2.	 In the Shift Copies field, enter the number of degrees to shift each concentric 
circle or arc from its inner neighbor.

This angle define the angular shift of each additional arc or circle, moving 
outward from the innermost arc or circle; it does not affect the incremental or 
sweep angle within each circle or arc.
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3.	 To locate the Circle Center (the center of distribution), ensure the Next 
Mouse Click choice is on, click OK to close the dialog, then click the 
desired center point.

The duplicates appear, in the number of concentric circles or arcs you 
defined, each shifted by the specified angle.

Arranging objects
You can use some of the commands in the Arrange menu to manipulate 
the positions of objects. You can perform the following actions using these 
commands: move objects backwards and forwards; group and ungroup objects; 
align and distribute objects. The tools in the Alignment panel / palette can be 
used also to distribute and align objects. The commands in the Arrange menu 
affect only the objects on the active layer.

Moving objects backwards and forwards

When you create multiple objects on the same layer, the newest object created 
appears on the top plane, while the oldest object appears on the bottom plane, 
that is, each new object appears on the plane above the previous object. At times, 
you might want to move an object in front of or behind other objects on the same 
layer. The functions that allow you to do this are Bring to Front, Send to Back, 
Move Forward One, and Move Back One.
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Bring to front

If an object is currently behind other objects, you can move it in front of the other 
objects on the layer by using the Bring to Front function.

1.	 Select the object you want to move to the foreground.

2.	 Open the Arrange menu and choose Bring to Front.

The selected object will be moved in front of all the other objects.

Top Tip: Use keyboard shortcut CMD + Shift + ] to bring the object to the front. 
You can also use CMD + ] to move the object Forward one space rather than all the 
way to the front should you prefer. 

Send to back

To reposition an object behind all other objects on the layer

1.	 Select the object you want to move to the background.
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2.	 Open the Arrange menu and choose Send to Back.

The selected object will be moved behind all the other objects.

Top Tip: Use keyboard shortcut CMD + Shift + [ to bring the object to the front. 
You can also use CMD + [ to move the object Forward one space rather than all the 
way to the front should you prefer. 

Move forward one

To move an object forward one level

1.	 Select the object you want to move forward.
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2.	 Open the Arrange menu and choose Move Forward One. 

The selected object will be moved forward one level.

Move back one

To move an object back one level

1.	 Select the object you want to move back one level.

2.	 Open the Arrange menu and choose Move Back One. 

The selected object will be moved back one level.

Grouping and ungrouping objects

Grouping objects

In a drawing that contains several individual objects, you might want to group 
some objects together so that you can treat them as a single object. When objects 
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are grouped together, most functions you choose will be performed on the entire 
group just as though it were a single object.

To group several objects together

1.	 Select all the objects that you want in the group.

2.	 Open the Arrange menu and choose Group.

Notice that the objects are now surrounded by a single set of edit handles. This 
indicates that all objects within the edit handles are part of this group and will 
be treated as a single object. You can perform any function on the group, such as 
move, duplicate or fill, and the entire group responds to that command. Once you 
have grouped several objects, you cannot reposition or edit any individual object 
or piece of text within the group unless you first ungroup the objects.

Ungrouping objects

If you no longer require a set of objects to be grouped, or if you need to edit one 
of the individual objects, you can use the Ungroup function to return the objects 
to their individual status.

To ungroup objects:

1.	 Select the group of objects by clicking one of the objects. 

2.	 Open the Arrange menu and choose Ungroup.

Notice that each object has its own set of edit handles again. This is an 
indication that the objects are no longer part of a grouped set, and that you 
can now select and edit each object individually.
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Aligning your objects

Aligning objects

Aligning objects means to line objects up relative to some other point. You can 
specify exactly how the objects should be aligned using the Alignment Options 
dialog, the Align Again command and the Alignment panel. The Alignment 
panel is used to align objects with each other; the Alignment Options dialog 
is used to align specified parts of objects with specified parts of other objects, a 
reference point or the grid; the Align Again command is used to align objects 
according to the current settings in the Alignment Options dialog.

Alignment Options dialog  PRO ONLY

•	 Select Alignment Options from the Arrange menu. 

The Alignment Options dialog appears.

The Alignment Options dialog provides controls to specify which part of 
a selected object should be aligned with which part of a reference object, a 
reference point or the grid.

To align selected objects to a reference object  PRO ONLY

1.	 Select the object(s) to align.
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2.	 Choose Alignment Options... from the Arrange menu. 

The Alignment Options dialog appears.

3.	 On the grid representing the selected object(s), click the grid squares to 
specify which parts of the selected object(s) are to be aligned, or click the 
‘Datum’ checkbox below the grid.

4.	 Click the ‘to a Reference Object’ button.

5.	 On the grid representing the reference object, click the grid squares to specify 
which parts of the reference object the selected object(s) are to be aligned 
with, or click the ‘Datum’ checkbox below the grid.

6.	 Click the Align button. The cursor will be displayed as ‘click reference 
object’.

7.	 Click the object to be used as a reference for the alignment.
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The selected object(s) will be aligned with the reference object according to 
your settings.

Note: To align objects to one element of a group (rather than to the group as a 
whole), hold down the Option key when the click reference object cursor appears, 
then click the element of the group to which you want to align the other objects.

To align selected objects to a reference point:  PRO ONLY

1.	 Select the object(s) to align.

2.	 Choose Alignment Options... from the Arrange menu. The Alignment 
Options dialog appears.

3.	 On the grid representing the selected object(s), click the grid squares to 
specify which parts of the object(s) are to be aligned, or click the ‘Datum’ 
checkbox below the grid.
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4.	 Click the ‘to a Reference Point’ button.

5.	 Click the Align button. The cursor will be displayed as ‘click reference 
point’.

6.	 Click the point to be used as a reference for the alignment.

7.	 The selected object(s) will be aligned with the reference point according to 
your settings.

To align objects to the current grid  PRO ONLY

1.	 Select the object(s) to align.
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2.	 Choose Alignment Options... from the Arrange menu. 

The Alignment Options dialog appears.

3.	 On the grid representing the selected object(s), click the grid squares to 
specify which parts of the object(s) are to be aligned, or click the ‘Datum’ 
checkbox below the grid.

4.	 Click the ‘to the Grid’ button.

5.	 Click the OK button. The selected object(s) will be aligned to the current 
grid according to your settings.
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Align Again command  PRO ONLY

Use the Align Again command in the Arrange menu to align objects according 
to the settings specified in the Alignment Options dialog.

To align objects using the Align Again command

1.	 Select the object(s) to be aligned.

2.	 Choose Align Again from the Arrange menu.

Accordingly to the settings in the Alignment Options dialog, the Click 
Reference Object or Click Reference Point cursor appears. 

3.	 Click the reference point or object.

4.	 The selected object(s) will be aligned according to the settings currently held 
in the Alignment Options dialog.

Alignment Tools

The Alignment Tools provides tools for you to carry out the most common 
alignment options. They can be found in the left hand panel if running MacDraft 
in single screen mode or on the Alignment Tools Palette in palette mode. 

To display the Alignment Tools panel/palette

•	 If MacDraft is running in Single Screen Mode, click the Toggle Left Pane 
button in the menu bar. The Alignment Tools will appear at the bottom of the 
panel. 

Note: You may need to 'Show' or 'Hide' the toolset. This can be done via the small 
arrow to the right of the 'Alignment Tools' title or you can go Window > Alignment 
Tools, either way will show the tools in the left panel. 

•	 If MacDraft is running in Palette Mode, click Window > Alignment Tools. 
This will launch the palette and all Alignment Tools will be available. 

Note: 'Alignment Options...' is the only tool/option in Alignment toolset which is 
only available in MacDraft Pro. This is covered earlier in the User Guide. 
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To use the Alignment panel/palette

1.	 Select the object(s) to be aligned.

2.	 In the Alignment panel, click the desired alignment button.

3.	 The cursor will be displayed as ‘Click Reference Object’.

4.	 Click the object to align the other object(s) with.

5.	 The selected object(s) will be aligned with the reference object according to 
the alignment tool chosen.

Note: To align objects to one element of a group (rather than to the group as a 
whole), hold down the Option key when the click reference object cursor appears, 
then click the element of the group to which you want to align the other objects.

Aligning objects to the document

The Alignment panel/palette provides tools for you to align your selections to 
the document.

1.	 Select the object(s) to be aligned.

2.	 Open the Alignment panel/palette 

3.	 On the grid representing the areas of the document, click the grid squares to 
specify which parts of the document you want the selection to be aligned to.

The object will be aligned to the selected area of the document.
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Distributing your objects

Objects can be positioned and aligned along a defined line. This can be done 
using the Distribute on Line command or using options in the Alignment panel/
palette.

Distribute on Line command

The Distribute on Line function allows you to position and align selected 
objects along a line that you define. The objects are distributed according to their 
level on the drawing, i.e. the object farthest back appears on the distribution line 
first, and the foremost object appears last. By default, the objects automatically 
align themselves along their centers, and will be equally spaced apart on the line. 

You can also choose to align the objects according to their datum points.

To distribute objects on a line

Align to Top Right CornerAlign to Top Right Corner

Align to Bottom Right CornerAlign to Bottom Right Corner

Align to Right CenterAlign to Right Center

Align to Top Center

Align to Bottom Center
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1.	 Select the objects to be distributed.

2.	 Open the Arrange menu and choose Distribute on Line.

3.	 Move the pointer to the point on your drawing where you would like to place 
the first object.

4.	 Press and hold down the mouse button.

5.	 Drag in the direction you want to distribute the objects.

6.	 Release the mouse button.

The objects will be distributed along the line you specified. Their center 
points will be spaced equally apart along the line.
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Note: To align objects according to their datum points, press and hold down the
Option key before you open the Arrange menu and choose Distribute on Line. To 
constrain the line the objects are to be distributed along, hold down the Shift key as 
you draw the line and it will snap to 45-degree increments.

To use distribute options in the Alignment panel/palette

The distribute controls in the Alignment panel/palette distribute objects in the 
same way as the distribute command, but the line is defined for you.

1.	 Choose Show Left Panel from the View menu and the left panel will appear. 
Select the Alignment Tools panel from the tab system at the top of the left 
hand panel. If running palette mode, choose Alignment Palette from the 
Window menu. 

2.	 Select the objects on the drawing to be distributed.

3.	 Click the appropriate button to distribute the objects horizontally or vertically 
by center or by datum point.

4.	 The objects will be distributed along a line in the manner specified.

Distribute Horizontally 
by Center

Distribute Horizontally 
by Datum

Distribute Vertically 
by Center

Distribute Vertically 
by Datum
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Transforming objects
Objects can be transformed by rotating, flipping or mirroring them.

Rotating objects by 90°

MacDraft provides several tools and commands that can be used to rotate objects 
freely or by specified amounts.

To rotate an object 90° anti-clockwise around its center

•	 Select an object in the drawing then choose the Rotate Left 90° option from 
the Arrange menu, or.

•	 Click the Rotate Left 90° toolbar item.

To rotate an object 90° clockwise around its center

•	 Select an object in the drawing then choose the Rotate Right 90° option 
from the Arrange menu, or.

•	 Click the Rotate Right 90° toolbar item.
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To rotate an object 90° anti-clockwise around its datum point

•	 Select an object in the drawing, hold down the Option key on your keyboard, 
then choose the Rotate Left 90° option from the Arrange menu. 

In this example the datum point is marked by a small circle.

To rotate an object 90° clockwise around its datum point

•	 Select an object in the drawing, hold down the Option key on your keyboard, 
then choose the Rotate Right 90° option from the Arrange menu.

Rotate tool and Rotate command

The Rotate tool and Rotate Tool command allow you to rotate objects by any 
angle you want. You can rotate objects in various increments using the mouse; to 
enter a specific value through the keyboard, use the Rotate Options.
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You can rotate single objects, multiple objects, or grouped objects. Unless you 
specify otherwise, selected single or multiple objects will rotate around their 
individual centers. If you wish you can also specify the center of rotation for 
selected objects.

To enter rotation mode

•	 Choose Rotate Tool from the Arrange menu, or

•	 Click the Rotate tool in the Tools panel/palette

To exit rotation mode:

•	 Click the Pointer tool in the Tools panel/palette or press the Escape key on 
your keyboard.

Rotating an object:

1.	 Select the object to be rotated.

2.	 Choose the Rotate tool from the Tools panel/palette or the Rotate Tool 
command from the Arrange menu.

3.	 Position the cursor in the window, then press and hold down the mouse 
button.

The cursor changes into a rotation indicator.

4.	 Holding down the mouse button, drag in a circular direction until you have 
rotated the object the desired amount, and release the mouse button.

The exact number of degrees being rotated can be seen in the Show Size 
block next to the cursor as you rotate.
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To rotate an object in specific degree increments

•	 Go to the Layout menu and change Set Angle Snap to what you want and 
then use the Rotate tool from the Tools panel/palette or the Rotate Tool 
command from the Arrange menu.

Changing the rotation units

To rotate an object in minutes or decimal fractions

1.	 Press and release the Shift key while rotating an object.

2.	 Continue to drag in a circular direction to rotate the objects in minutes.

The number of degrees remains fixed.

To rotate an object in seconds

1.	 Press and release the Shift key twice while rotating an object.

2.	 Continue to drag to rotate the objects in seconds.

As you rotate the object in seconds, the number of degrees and minutes are 
constrained.
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Returning to previous rotation units

You can return to the previous rotation units (from seconds to minutes, and 
minutes to degrees) by using the Command key.

To return to the previous rotation units

•	 Press the Command key while in the rotation mode, or

•	 Return to the Pointer tool and then reselect the Rotate tool or Rotate Tool 
command in the Arrange menu.

Rotating multiple objects

When rotating multiple objects, by default each object rotates around its 
individual center.

Rotating grouped objects

When rotating a grouped object, all the objects in the group rotate around the 
center of the group, unless you specify a different center of rotation.

Rotating text

The rotation feature works exactly the same way when you rotate a text block as 
it does when you rotate other objects. 

Rotating bitmaps

Rotate your bitmap image in the same way you would rotate another object.

Choosing the centre of rotation

Objects are usually rotated about their centers, however you can also specify any 
point on the drawing as the center of rotation.

To rotate objects around a specified point

1.	 Select the objects you want to rotate.

2.	 Choose the Rotate tool from the Tools panel/palette or the Rotate Tool 
command from the Arrange menu.
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3.	 Position the cursor on the point you want to use as the center of rotation. You 
can use the scroll controls to move to a part of the drawing that is outside 
your current view.

4.	 Press and hold down the Option key.

5.	 Press and hold down the mouse button.

6.	 Holding down the mouse button and the Option key, drag in a circular 
direction until you have rotated the object the desired number of degrees.

7.	 Release the mouse button and the Option key.

Rotate to zero command

The Rotate to zero command allows you to return an object to its original angle 
of rotation.

To return an object to its original angle of rotation

1.	 Select a rotated object.

2.	 Choose Rotate to Zero from the Arrange menu.

The object will be returned to its original angle of rotation.
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Rotate options

You can use the keyboard to directly enter the rotation values in degrees, 
minutes, and seconds using the Rotate Options dialog.

The Rotate Options dialog

To display the Rotate Options dialog

1.	 Select the object or objects you want to rotate.

2.	 Choose Rotate Options from the Arrange menu. 

The Rotate Options dialog appears.

Amount of rotation

The fields available to enter the rotation amount vary depending on the Angular 
Display option selected in the Document Scale and Units dialog. The above 
screen shot shows the field that appears when decimal degrees are selected.

To enter an amount for rotation, double-click the appropriate field and type your 
desired value.
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Direction of rotation

The default direction for rotation is counterclockwise. To rotate an object in a 
clockwise direction, click the Clockwise checkbox.

Center of rotation

The default center of rotation is the center of the selected object or objects. To 
rotate objects about their datum, click the Datum of object(s) radio button.

To rotate objects about a specified reference point, click the A reference point 
radio button.

If the A reference point radio button is on, the Rotate Options dialog disappears 
and the Rotation cursor will be shown over the drawing. Click the point you 
want to use as the center of rotation.

To rotate an object or objects using Rotate options

1.	 Select the object or objects you want to rotate.

2.	 Choose Rotate Options from the Arrange menu. 

The Rotate Options dialog appears.

3.	 Enter the desired angle of rotation.

4.	 Specify the direction and center of rotation.
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5.	 Click the Rotate button. 

6.	 Specify the reference point to rotate about if necessary.

The selected object or objects will be rotated the specified number of 
degrees, minutes, and seconds around the requested center of rotation.

Flipping objects

Sometimes you may want to display the reverse image of an object. For this, 
MacDraft has the Flip Horizontal and Flip Vertical commands.

You can duplicate an object and then use one of the Flip functions to create the 
other side of that object for the sake of symmetry, as well as convenience.

Note: Pictures can be flipped as well as objects, however text is treated slightly 
differently and described later in the section.
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To flip an object or picture horizontally

1.	 Select the object you want to flip.

2.	 Open the Arrange menu and choose Flip Horizontal. 

The object will be flipped about its vertical axis.

To flip an object or picture vertically

1.	 Select the object that you want to flip.
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2.	 Open the Arrange menu and choose Flip Vertical. 

The object will be flipped about its horizontal axis.

Flipping text

Text is not flipped in the same way as objects, as often it does not make sense to 
produce a mirror image of text. However you may well want to flip a group that 
includes text, and have the text shown in its correct position and orientation in 
relation to the objects in the group. If you do want to produce a mirror image of 
text, choose the Mirror text style in the Text menu.
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•	 Flip horizontal: The position of the text in the group is flipped, but the text 
remains at the same orientation.

•	 Flip vertical: The position of the text in the group is flipped, and the text is 
rotated through 180°.

Mirroring objects

The Mirror tool is used to mirror an object or group at any specified angle. The 
mirroring can either move and flip the original selection or make a turned copy 
while leaving the original in place. The mirror image of your selected items 
appears across the axis you define, opposite the original’s position, and the same 
distance from the axis as the original. You define the axis of mirroring with a 
temporary onscreen reference line.

The Mirror tool is located in the Advanced tools in the left panel or, if in palette 
mode, in the Advanced tools palette.

To open the Advanced Tools panel/palette

•	 If in single screen mode choose Show Left Panel from the View menu and 
the left panel will appear. You may need to show the Advanced tools via the 
Window menu. 

•	 If in palette mode, choose the Advanced tools palette from the Window 
menu. 

Original Group Flip Horizontal Flip Vertical
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Note: Bitmap or pixel-map objects (such as those pasted in from a paint-type 
program or leaded in from TIFF files) will not be reversed, but will appear at the 
position defined by the mirror operation. Also text objects cannot be mirrored using 
this the Mirror tool.

Mirroring an object or group

To mirror an object or group

1.	 Select the object or group to be mirrored.

2.	 Choose the Mirror tool from the Tools panel/palette.

The cursor changes to a white arrowhead.

3.	 Move the cursor to the first point you’ll use to define the reference line.

4.	 Press and hold down the mouse button. A dotted reference line appears.

5.	 Holding down the mouse button, drag to de ne the reference line (the axis of 
mirroring).
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Note: If you hold down the Shift key, the line snaps in 45-degree increments.

6.	 Once the reference line is at the desired angle, release the mouse button.

The selection will be mirrored across the plane you defined with the 
reference line.

The precise angle of the mirroring line can be seen in the Show Size block 
next to the cursor as you draw the reference line.

Mirroring a copy of an object

Sometimes you may need a mirror-image of an object, but still want to leave the 
original in place. You can specify that a copy is mirrored by using the Mirror 
tool configuration dialog.

To mirror a copy of an object or group

1.	 Open the Tools panel/palette if necessary.



396Chapter 5 Transforming and Arranging Objects

2.	 Hold down the Option key and click the Mirror tool.

The Mirror Setup dialog appears.

3.	 Click the Mirror Copy of Object(s) radio button, then click OK.

4.	 Follow the steps required to mirror an object, as described above.

A copy of the selection will be mirrored across the axis you defined with the 
reference line, while the original remains in place.

Lock and Unlock
You may sometimes want to make sure that objects on your drawing are not 
moved or changed by mistake. To do this you can use MacDraft’s Lock feature to 
make sure certain objects remain unchanged.
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Locking objects

To lock objects

Locked objects on the drawing cannot be edited, moved, copied, pasted, or 
deleted. None of MacDraft’s functions affect locked objects.

1.	 Select the objects you want to lock.

2.	 To lock either;

•	 Open the Arrange menu and choose Lock.

•	 Press the CMD + L keys at the same time. 

•	 Click the Lock icon on the toolbar. 

You may need to add the Lock option to the toolbar by customizing the 
toolbar.

The objects will be locked and the edit handles change to red to indicate this.

Unlocking objects

You may later realize that you need to edit locked objects. To do this, you must 
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first unlock them.

To unlock objects

1.	 Select the locked objects you want to unlock.

2.	 To unlock either;

•	 Open the Arrange menu and choose Unlock.

•	 Press the Shift + CMD + L keys at the same time. 

•	 Click the Unlock icon on the toolbar. 

You may need to add the Unlock option to the toolbar by customizing 
the toolbar.

The objects will be unlocked and the edit handles will be shown normally.

Find and replace  PRO ONLY

Sometimes you may need to find certain objects or groups quickly in a large 
drawing. Scrolling and examining all the items in a drawing to find the one you 
want can be time consuming and inaccurate, so instead you can use MacDraft’s 
Find and Replace feature.

The Find/Replace dialog  PRO ONLY

The Find/Replace dialog provides tools to automatically find and select objects 
or groups that have names or other object information assigned to them. This is 
most useful for finding items that have been copied many times in a drawing. The 
Find/Replace dialog also allows you to replace found objects with other objects.

Displaying the Find/Replace dialog  PRO ONLY

To open the Find/Replace dialog

•	 Choose Find/Replace from the Data menu.

The Find/Replace dialog appears.
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Entering information into the Find/Replace dialog 

Object Information fields  PRO ONLY

You define the objects to be found by specifying which of the object information 
fields assigned to them you want to search by.

Type in text

You can manually type the desired object information into the appropriate object 
information fields. Note that any typing errors affect the results of the search 
and may cause the wrong objects to be found. Alternatively use the Use Mouse 
button as described in the next section.

Use Mouse button

The quickest way to define search criteria is with the Use Mouse button, which 
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lets you enter all of an item’s object information instantly by clicking that object.

1.	 In the Find/Replace dialog, click the Use Mouse button.

The Find/Replace dialog disappears and the selection cursor appears over 
your drawing.

2.	 Click the object for which you wish to enter object information.

The object information for the selected object is shown in the object 
information fields.
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Check boxes

Click the checkbox next to each object information field that you want to use in 
your search. If check boxes are on, but you do not want to use these options in 
your search, click the check boxes to turn them off.

Note: It is possible to find objects or groups that share some object information 
data, but are not identical. For example, two items might have the same name but 
different part numbers and both would be found if 'Name' was on and 'Part Number' 
was not.

Layers

Objects or groups can be found and replaced in either the current layer or in all 
layers of a drawing. Click the All Layers checkbox to search on all layers.

Finding objects using the Find/Replace dialog  PRO ONLY

Finding objects  PRO ONLY

To find objects or groups with particular object information

1.	 Make sure the objects or groups you want to find have object information 
assigned to them, and that one of them is visible in the drawing window.

2.	 Choose Find/Replace from the Data menu.

The Find/Replace dialog appears, with no information entered

3.	 In the Find section of the dialog, type in the desired object information for 
each field, or enter the information using the Use Mouse button.

Note: In drawings with many items that have object information, temporarily 
clicking the Find fields check boxes to turn this function off can speed up the typing 
of Find criteria.

4.	 Activate or turn off the object information field check boxes as necessary.

5.	 Click the All Layers checkbox to search on every layer of the drawing.

6.	 The total number of items found will be displayed at the lower left.
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Selecting found objects  PRO ONLY

To select objects found using the Find/Replace dialog

1.	 Follow the previous instructions to find objects based on their object 
information.

2.	 In the Find/Replace dialog, click the Find Next button.

The first matching object will be selected, and the remaining number of 
objects or groups that meet the find criteria will be shown at the bottom left 
of the Find/ Replace dialog (that is, the initial count will be reduced by one).

3.	 Continue to select matching objects by clicking the Find Next button.

4.	 When you have finished finding or replacing objects, click the close box at 
the upper left of the dialog to close it.

Replacing objects using the Find/Replace dialog  PRO ONLY

When you use the Find feature, you will often want to replace the objects or 
groups you find with different items. The Replace options in the Find/Replace 
dialog can be used to replace some or all of the found items with other individual 
objects or groups.

When an object is replaced, the datum point of the replacement object occupies 
the same location as the datum point of the original object.

Notes: 

•	 An object or group to be used to replace another object or group must have 
object information assigned to it.

•	 The replacement object must also be unique; that is, it must have a unique set 
of data in its object information fields.

Choosing a replacement object  PRO ONLY

Enter the object information into the Replacement object fields by typing the 
information  directly into the fields or using the Use Mouse button as described 
in the previous section. 
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Finding and replacing objects  PRO ONLY

To find and replace objects or groups

1.	 Enter the find criteria as discussed previously.

2.	 Enter the information for the replacement object.

3.	 Click the Find Next button.

4.	 The Find/Replace dialog shows the number of objects or groups that match 
the find criteria, and the first matching object will be selected.

•	 To find the next object that matches the find criteria, click the Find Next 
button.

•	 To replace this particular found object, click the Replace button.

•	 The selected object will be replaced with a copy of the object you 
defined as the replacement.

•	 To replace all matching objects or groups, click the Replace All button.

•	 All objects that match the Find criteria will be replaced.

•	 Click Undo to reverse the replacement of the last single object or group.

5.	 When you have finished finding and replacing objects, click the close box at 
the upper left of the dialog.

Replacing objects and/or object information  PRO ONLY

When objects are found according to their object information, you can choose 
to replace either the entire object (including its object information), the object 
information only (leaving the visible object), or the visible object only (leaving 
the object information intact).

The desired option is chosen from the Replace pop-up menu in the Find/Replace 
dialog. The default setting is to replace the object and data together.
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To replace an object and its data

•	 Choose Object & Data from the Replace pop-up menu.

Any items chosen for replacement will be replaced, and their object 
information will also be replaced.

To replace only an object

•	 Choose Object Only from the Replace pop-up menu.

Any items chosen for replacement will be replaced, but their object 
information will remain unchanged.

To replace only an object’s data

•	 Choose Data Only from the Replace pop-up menu.

Any items chosen for replacement will have only their object information 
replaced, the visible objects will remain unchanged.

C, E and M Modifier Keys
MacDraft is able to snap objects to the mid point (M) or end point (E) of a 
straight edge or circular arc, or to the center (C) of an object. This is done by 
holding down the M, E or C key while drawing a line or moving an object. 

Drawing a line to the mid, end or centre point of an existing object or line

To draw a line to the mid point of an existing edge or line

1.	 Choose the line tool from the Tool panel/palette.

2.	 Press and hold down the M key. The cursor will read "Mid?".
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3.	 Still holding down the M key, bring the cursor near the edge of the object or 
line you wish to snap the end point of the line to. The line will snap to the 
mid point of the existing object or line that is near the cursor. 

4.	 Finish the line by releasing the mouse button.

The line apears on the drawing between the starting point and the mid point of 
the specified edge or line. The cursor reverts to the line tool, allowing another 
line to be drawn. 

Notes: 

•	 A line or object can be drawn to the End point of an existing line or object in 
the same way, by holding down the E key and positioning the line near the End 
of the line or object. 

•	 A line or object can be drawn to the Centre point of an existing line or object 
in the same way, by holding down the C key and positioning the line near the 
Centre of the line or object. 

Moving an object to the mid, end or centre point of another object 

To move an object to the centre point of another object

1.	 Select object one and start to drag it towards object two. 

2.	 Press and hold the C key. 

3.	 Still holding the C key down, drag object one towards object two until it 
snaps to the centre of object two.

4.	 Finish the movement by releasing the mouse button. 
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Notes: 

•	 A line or object can be moved to the End point of an existing line or object in 
the same way, by holding down the E key and positioning the object near the 
End of the next line or object. 

•	 A line or object can be moved to the Mid point of an existing line or object in 
the same way, by holding down the M key and positioning the object near the 
Mid point of the next line or object.
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Chapter 6
Drawing aids

MacDraft offers several useful features that make your drawing tasks much 
easier: show size, rulers, cursor position indicator, grid snap, angle snap, grid 
lines, snap to object and line snapping, guides, and document units and scale. 
This chapter discusses these drawing aids in detail.

Show Size Cursor
MacDraft is a precision drawing application designed to help you create detailed 
drawings. The Show Size Cursor function makes it easier to draw objects 
precisely because it provides a continuous display of an object’s size as you draw 
or resize it. It also shows the degree of rotation as you rotate objects.

The units displayed in the Show Size Cursor are determined by the current 
options chosen in the Document Scale & Units dialog.

Displaying the Show Size Cursor

To turn the Show Size Cursor on

•	 Choose Show Size from the View menu (a tick appears next to it), or

•	 Click Show Size from the Toolbar (The toolbar item highlights). 

The Show Size cursor appears while drawing, dragging or resizing.
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Using the Show Size Cursor with drawing tools

Line tools

When using line tools (including the Perpendicular, Tangent, Parallel, and 
Extrude tools), the Show Size Cursor displays the length (X) of the line and the 
angle(A°) at which the line is drawn.

Square-corner rectangles

When drawing square-corner rectangles, the Show Size Cursor displays the width 
(X) and height(Y) of the rectangle.

Text tool

When drawing a rectangle to define the block for paragraph text, the Show Size 
Cursor displays the width (X) and height(Y) of the rectangle.
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Regular polygons - Side to side

When drawing a regular polygon from side to side, the Show Size Cursor 
displays the side to side diameter (D) of the polygon.

Regular polygons  - Center to side

When drawing a regular polygon from center to side, the Show Size Cursor 
displays the center to side radius (R) of the polygon.

Regular polygons  - Vertex to vertex

When drawing a regular polygon from vertex to vertex, the Show Size Cursor 
displays the vertex to vertex diameter (D) of the polygon.
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Regular polygons  - Center to vertex

When drawing a regular polygon from center to vertex, the Show Size Cursor 
displays the center to vertex radius (R) of the polygon.

Rounded Corner Rectangles - Proportional and constant

When drawing a proportional or constant corner rectangle, the Show Size Cursor 
displays the height(Y) and width(X), and the radius(R) of the corners.

Rounded Corner Rectangles - Elliptical

When drawing an elliptical-corner rectangle, the Show Size Cursor displays the 
height (Y) and width(X) of the rectangle, and the major and minor radii of the 
arcs on the corners.
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Circles by diameter

When drawing a circle by diameter, the Show Size Cursor displays the diameter 
(D) of the circle.

Circle by radius

When drawing a circle by radius, the Show Size Cursor displays the radius (R) of 
the circle.

Ellipses

When drawing an ellipse, the Show Size Cursor displays the width(X) and height 
(Y) diameters of the ellipse.
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Concentric circles

When drawing a concentric circle, the Show Size Cursor displays the radius (R) 
of the circle.

Arcs By radius

As you drag to create the radius of an arc, the Show Size Cursor displays the 
length of the radius(R) and the starting angle(A ̊). The starting angle is the angle 
between the line attached to the cursor and the X-axis.

Once you release the mouse button and move the mouse to create the arc, the 
Show Size Cursor changes to display: the difference between the starting angle 
and the ending angle of the arc, i.e., the actual number of degrees through which 
the arc passes(∆A ̊); the angle between the ending angle (shown on-screen by the 
line attached to the cursor) and the X- axis (A ̊).

Arcs by three points

As you create an arc by three points, the Show Size Cursor does not become 
active until you are moving from the second to the third point in the arc. At that 
time, it shows the entire arc angle (A°).
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Elliptical arcs

When you start drawing an elliptical arc, the Show Size Cursor displays the 
height(Y) and width(X) of the ellipse used to define the size of the arc. It also 
shows you the starting angle (A ̊), which is the angle between the line attached 
to the cursor and the X-axis.

When you finish defining the size and the starting angle of the arc, the Show 
Size Cursor shows you: the difference between the starting angle and the ending 
angle, i.e. the actual number of degrees through which the arc passes(∆A ̊); the 
angle between the ending angle (shown on-screen by the line attached to the 
cursor) and the X-axis (A ̊).

Irregular polygons

When using irregular polygon or polyline tools (including the double-line 
polygon or polyline tools), the Show Size Cursor displays the length (X) of the 
line and the angle(A°) of the line, for each side of the polygon as it is drawn.
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Using Show Size with rotation

When rotating an object, the Show Size Cursor displays how much you have 
rotated the object(A°).

Angles of rotation range from zero to 360 degrees, moving counterclockwise 
from a rightward-pointing or “due East” orientation.

You can rotate objects in degrees, minutes and seconds, or in degrees and 
decimal fractions.

Hiding the Show Size cursor

To turn the Show Size Cursor off

•	 Choose Show Size from the View menu (a tick disappears), or

•	 Click Show Size from the Toolbar (Highlight state is removed). 

The Show Size Cursor disappears

Rulers
Rulers are used as drawing aids to help you position objects in precise locations 
on your drawing. Rulers appear along the top and left side of the drawing.
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The displayed rulers reflect the current position of the window during scrolling, 
and their scale reflects the current magnification level.

Displaying rulers

To display rulers

•	 Open the View menu and choose Show Rulers.

The rulers will be displayed, and a check mark appears by the Show Rulers 
command in the View menu.

Types of rulers

MacDraft offers two types of rulers: standard and scale.

Standard rulers

Standard rulers show the actual size of the drawing in the units specified in the 
Set Scale and Units dialog.

To display standard rulers (if Show Rulers is checked)

•	 Open the Layout menu and choose Standard Rulers.

The rulers show the actual size of the drawing, in this example, in inches.
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Scale rulers

Scale rulers reflect the current drawing scale of your document. For example, on 
a 1/4” = 1' scale, the major ruler divisions will be in increments of four: 4 ft., 8 
ft., and so on.

To display scale rulers (if Show Rulers is active)

•	 Open the Layout menu and choose Scale Rulers.

The rulers show the drawing measurements according to the scale specified.

In this example, the scale is 1/4" = 1' and the size units are set at fractional 
feet and inches.

Setting the rulers’ zero points

There may be occasions when you want to change the zero point of the rulers 
from the upper left corner of your drawing to some other convenient point on 
the drawing. For instance, you may want to set the zero point of the rulers to one 
edge of an object so that you can position other objects relative to that particular 
point. For this reason, MacDraft allows you to change the ruler zero points.

When you change the zero point of one or both of the rulers, the positioning of 
the new zero point is dependent upon the grid snap. You can change the zero 
point of either the top or left ruler independently, or change the zero points of 
both rulers at the same time.
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Setting the zero points of the rulers independently

To change the zero point of either the top or the left edge ruler independently of the other

1.	 Position the tip of the pointer on either ruler, at the place you want the new 
zero point for that ruler to be, and click.

To change the zero point of either the top or the left edge ruler back to the upper left corner

•	 Position the tip of the pointer in the box where the two rulers cross at the 
upper left corner of the drawing window and click.

The zero points will be reset.

The zero point is repositioned as specified.
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Setting the zero points of both rulers simultaneously

You can change the zero points of both rulers simultaneously by using the cursor. 
In this way, you can easily align the zero points of both rulers to a particular 
point on your drawing.

To set the zero points for both rulers at the same time

1.	 Position the tip of the pointer in the box where the two rulers cross at the 
upper left corner of the drawing window.

2.	 Press and hold down the mouse button.

3.	 Drag diagonally downward and to the right until the cursor is positioned on 
the new zero point you want for both rulers.

Release the mouse button.
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4.	 The zero points of both rulers are repositioned as specified.

To reset the zero points of both rulers to the upper left corner of your drawing

•	 Position the tip of the pointer in the box where the two rulers cross at the 
upper left corner of the drawing window and click.

The zero points will be reset.

Cursor position indicator
The cursor position indicator shows the position of the cursor (that is, the 
crosshair cursor, the arrow pointer, and the various other cursor icons) on your 
drawing. This allows you to determine accurately the starting and ending points 
of an object, and also gives you the ability to discover the precise position of any 
point on your drawing.

The cursor position indicator shows the absolute position of the cursor in 
relation to the zero origin. The zero origin of the cursor position (X=0, Y=0) 
is determined by the zero points on the rulers. Therefore, if you move the zero 
points on the rulers, the zero origin of the cursor position indicator also changes. 
This feature is very useful, especially when you want to make measurements 
relative to a specific point on your drawing.

The cursor position indicator reflects the drawing environment. The X/Y position 
of the cursor’s position is displayed according to the scale of the drawing and in 
the size units that are currently selected.
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Activating the cursor position indicator

To activate the cursor position indicator

•	 Open the View menu and choose Show Cursor Position.

The X/Y position of the cursor will be shown on the bottom left corner of the 
document window as shown below.

As you move the cursor around on your drawing, the cursor position 
indicator shows the cursor’s X/Y position relative to the current zero points 
set for the rulers.

Hiding the cursor position indicator

To hide the cursor position indicator

•	 Open the View menu and choose Show Cursor Position .

The cursor position disappears, and the check mark will be removed from the 
Show Cursor Position command in the View menu.

Document guides
You may sometimes want to place guides in your drawing, that you don't want 
to print, but would like to use as a reference for drawing and editing objects. 
MacDraft offers vertical and horizontal document guides that can be placed either 
at an exact position on the drawing or manually by dragging and placing them.
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Adding a guide to an exact position

To place a guide exactly

1.	 Open the Options menu and choose Add Guide by Position...

The Add Guide dialog appears.

2.	 Either;

•	 Click the Horizontal radio button and type a value in the Y position 
field, where you want the horizontal guide to be placed.

•	 Click the Vertical radio button and type a value in the X position field, 
where you want the vertical guide to be placed.

3.	 Click the OK button

The guide you have chosen will be placed at the position you specified.



422Chapter 6 Drawing aids

Adding a vertical guide to the center

•	 Open the Options menu and choose Add Vertical Guide...

The Vertical Guide will be added to the center of the document.

Note: If you have multiple pages in the document, the guide will be centered across 
the whole document, not just one page.

Adding a horizontal guide to the center

•	 Open the Options menu and choose Add Horizontal Guide...

The Horizontal Guide will be added to the center of the document.

Note: If you have multiple pages in the document, the guide will be centered across 
the whole document, not just one page.

Adding a guide manually

You can add a Horizontal or Vertical guide by dragging one from the respective 
rulers. This options allows you create guides quickly when you do not need to be 
specific in their position.

To add a horizontal guide manually

1.	 Hold down the Command key on your keyboard.

2.	 Move the cursor to the horizontal (top) ruler.
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3.	 While still holding the Command key down, click and hold the mouse 
button down inside the top ruler.

4.	 With the Command key and mouse button held down, drag downwards until 
the guide is in the position you want.

5.	 Release the mouse button

The horizontal guide will be added.

To add a vertical guide manually

1.	 Hold down the Command key on your keyboard.

2.	 Move the cursor to the vertical (left) ruler.

3.	 While still holding the Command key down, click and hold the mouse 
button down inside the left ruler.

4.	 With the Command key and mouse button held down, drag to the right until 
the guide is in the position you want.

5.	 Release the mouse button

The vertical guide will be added.
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Removing a guide from the drawing

Sometimes you might want to remove a guide that you have already placed. This 
can be done by dragging the guide in the dark space that surrounds the document.

To remove a guide

1.	 Move the tip of the mouse pointer to the guide you want to remove 

2.	 Hold down the Command and Option keys on your keyboard.

3.	 The cursor will change to a line and two arrows

4.	 While still holding the Command and Option keys down, click and hold 
the mouse button and drag the guide into the dark space surrounding the 
document area.

5.	 Release the mouse button and Command and Option keys.

The guide will be removed.

Positioning objects
MacDraft provides several features to aid in the precise positioning of objects: 
grid snap, angle snap, grid lines, snap to object, smart snap, snap to guides and 
line snapping. The grid snap and angle snap features allow you to superimpose an 
invisible network of “magnets” over your drawing so that objects can be drawn, 
moved, or resized precisely and easily. Grid lines provide visual guidelines that 
assist you in drawing. Snap to object allows you to position one object directly 
next to another, smart snap puts reference lines on other objects, snapping 
to guides allow you to align to the reference guides you have added and line 
snapping allows you to snap the end of lines to a specified point on another 
object.
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Grid snap

You should set the grid snap to the smallest length you need in or between 
objects in your drawing. For example, if you wanted to draw a line that is 5 3/4 
inches long, you should set the grid snap to one-quarter inch. With the grid snap 
set this way, the cursor will snap to every quarter-inch increment as you draw the 
line. Values shown in the Set Grid submenu will be always given in the current 
scale and unit system.

Setting the grid snap

Before you set the grid snap, you should choose a scale to be used for your 
drawing. The grid snap setting should be appropriate for that scale.

To choose a new grid snap

1.	 Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu appears. A check mark indicates the document’s 
current grid snap.

The Set Grid submenu shows the grid spacing for the current scale. Each 
scale has its own set of possible grid spacings. For example, a scale of 1:1 
(1"=1") in fractional units will have increments as small as 1/64th of an inch 
and as large as 1/4 of an inch.

2.	 Holding down the mouse button, drag through the submenu until the grid 
snap you want is highlighted, and release the mouse button.
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The grid snap remains as set until it is changed again.

Using the grid snap function

When a grid snap other than None is chosen, any object you draw or move will 
automatically be positioned to the nearest grid snap position. You will not be 
able to begin or end a draw or move action between the grid snap positions. For 
example, if you were moving an object with the grid spacing set at 1/4 inch, the 
object would move in quarter inch increments. You can activate or deactivate the 
grid snap to suit your needs at the time.

Turning the grid snap off and on

At times you may want to turn off the grid snap when you draw or move objects.

To turn off grid snap

1.	 Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu appears.

2.	 Choose None to turn off the grid snap.

To turn on grid snap

1.	 Open the Layout menu and drag until Set Grid is highlighted.

The Set Grid submenu appears.

2.	 Choose the desired grid snap.

Releasing objects from the grid snap

You can temporarily suspend the grid snap function by holding down the 
Command key as you move or draw an object. This technique allows you to 
position an object on a location that does not fall at a grid snap point.

Note: If you turn the grid snap off while drawing or moving an object, that object 
will be removed from the grid. This means that it will be difficult for you to draw 
lines or borders tangential to the object, or align the object with other objects. In 
order to place the object back on the grid, use the Align to Grid function.
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Snapping edges and lines along their lengths

As you draw an object with grid snap on, its edges get longer by small 
increments as they jump to the closest grid snap point. Rather than a line or edge 
snapping to the grid, hold down the Option key as you draw and the line or 
edge length will snap to increments of the current grid snap. For example, if the 
current grid snap is 1/4" and you draw a 30° line while holding down the Option 
key, the line length will grow in quarter inch increments.

Re-align to grid using Alignment Options  PRO ONLY

There will be times when actions you take will result in objects existing in the 
MacDraft document that are not on the current grid. This means that it will be 
difficult for you to draw lines or borders tangential to the object, or align the 
object with other objects. You can reposition objects on the grid by using the 
align to grid option, inside the Alignment Options... from the Arrange menu.

Angle snap

You should set the angle snap to the angle you need in or between objects in 
your drawing. For example, if you wanted to draw a line at an angle of 14°, you 
should set the angle snap to 2°. With the angle snap set this way, the cursor will 
snap to two degree increment as you draw the line.

Setting the angle snap

To choose a new angle snap

1.	 Open the Layout menu and drag until Set Angle Snap is highlighted.

The Set Angle Snap submenu appears. A check mark indicates the 
document’s current angle snap.
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The Set Angle Snap submenu shows the possible angle choices. 

2.	 Choose the angle snap you want.

The angle snap remains as set until it is changed again.

Using the angle snap function

When an angle snap other than None is chosen, objects you draw or edit (that 
angle is relevant to) will be positioned automatically to the nearest angle snap 
position. You will not be able to draw lines between the angle snap positions. 

You can activate or deactivate the angle snap to suit your needs at the time.

Turning the angle snap off and on

At times you may want to turn off the angle snap when you draw objects.

To turn off angle snap

1.	 Open the Layout menu and drag until Set Angle Snap is highlighted.

The Set Angle Snap submenu appears.

2.	 Choose None to turn off the angle snap.

To turn on angle snap

1.	 Open the Layout menu and drag until Set Angle Snap is highlighted.

The Set Angle Snap submenu appears.

2.	 Choose the angle snap you want.

Releasing objects from the angle snap

You can temporarily suspend the angle snap function by holding down the Shift 
key as you draw an object. This technique allows you to draw an object at an 
angle that is not an angle snap line.

Note: Set a custom angle snap by choosing Custom in the menu.
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Grid lines

Grid lines provide visual guidelines that assist you in drawing. Choose Dotted or 
Square from the Grid Type option in the Options menu.

Hide/show the grid lines

The grid lines are shown by default, but you can hide them if you wish.

To hide grid lines

•	 Open the View menu and drag until Show Grid Lines is highlighted.

The grid lines are hidden and the check mark will be removed from beside 
Show Grid Lines in the View menu.

To show grid lines

•	 Open the View menu and drag until Show Grid Lines is highlighted.

The grid lines will be shown again, and a check mark appears by Show Grid 
Lines in the View menu.
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Snap to object

The snap to object feature allows you to position one object directly next to 
another. When snap to object is enabled, the cursor will snap to the vertices of 
existing objects. For example, you could draw a line and make one of its end 
points coincide precisely with the corner of a rectangle. By default, the Snap to 
Object function is active when you open a new MacDraft document.

To turn off snap to object

•	 Open the Layout menu and choose Snap to Object.

The check mark will be removed from the command, and snap to object will 
be turned off.

To turn on snap to object

•	 Open the Layout menu and choose Snap to Object.

Snap to object will be turned on, and a check mark appears next to its name 
in the Layout menu.

Line snapping

MacDraft is able to snap the final point of a line to the mid point or end point of a 
straight edge or circular arc, or to the center of an object. This is done by holding 
down the M, E or C key while drawing a line.

Note: These snap keys can be used when drawing unconstrained lines, including 
lines drawn with the Mid point, End point and Center point line tools and Tangent 
from line tool.

The mid point and end point snap keys, M and E, can be used when drawing 
a line to straight edged objects (lines, polylines, polygons and square-corner 
rectangles); any of these objects can be part of a group. The end point key, E, 
can also be used to snap the end of a line to the end of a circular arc. The center 
key, C, can be used to snap the end of a line to the center of any closed shape, 
including shapes within groups, but not with text objects, dimension objects, 
bitmap or pixel objects.
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Drawing a line to the mid point of an existing edge or line 

To draw a line to the mid point of an existing edge or line

1.	 Choose a line tool from the Tool panel and begin drawing the line. 

2.	 Press and hold down the “M” key. The cursor will read “Mid”.

3.	 Still holding down the “M” key, bring the cursor near to the edge or line you 
wish to snap the end point of the line to.

The line will snap to the mid point of the existing edge or line that is near the 
cursor.

4.	 Finish the line by releasing the mouse button.

The line appears on the drawing between the starting point and the mid point 
of the specified edge or line. The cursor reverts to the line tool, allowing 
another line to be drawn. 

A line can be drawn to an end point of an existing edge, line, arc or center of 
an object in the same way, by holding down the “E” or “C” key instead of 
the “M” key.
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Smart Snap

MacDraft offers a range of snapping options but one of the most powerful is 
the Smart Snap system. With this turned on you can align objects while you are 
drawing, resizing and position to other objects in the document. The Smart Snap 
system draws a number of reference lines on the screen as objects interact and 
coincide with each other, helping you to positions and draw things correctly.

To turn off smart snap

•	 Open the Layout menu and choose Smart Snap.

The check mark will be removed from the command, and snap to object will 
be turned off.

To turn on smart snap

•	 Open the Layout menu and choose Smart Snap.

Smart snap will be turned on, and a check mark appears next to its name in 
the Layout menu.

Using smart snap 

1.	 Make sure Smart Snap is turned on.

2.	 Draw two shapes in your document, such as two rectangles.
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4.	 Position the rectangle as you prefer, using the smart snap reference lines to 
help you snap the position to the correct place.

The Smart Snap reference lines can be used when you are drawing objects, 
resizing them or moving them. Smart Snap allows you to snap and align to the 
edges, center and mid points of objects.

Snap to Guides

With the use of MacDraft's document guides, you can snap your objects to them 
while you are drawing resizing or moving. This will make it much easier for you 
to position your objects when using guides.

To turn off snap to guides

•	 Open the Layout menu and choose Snap to Guides.

The check mark will be removed from the command, and snap to guides will 
be turned off.

3.	 When the rectangles are drawn, select one of the rectangles and start moving 
it towards the other rectangle.

When the rectangle gets closer to the other rectangle you will see smart snap 
reference lines appear.
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To turn on snap to guides

•	 Open the Layout menu and choose Snap to Guides.

Snap to Guides will be turned on, and a check mark appears next to its name 
in the Layout menu.

Snapping between layers

When using multiple layers in your documents you'll find that most of the 
snapping facilities work between the layers. This means you can align objects on 
one layer with those on another layer. This option can be turned on and off while 
you are drawing.

To stop snapping between layers

1.	 Start drawing or moving your object(s).

2.	 Hold down the Control key on your keyboard.

The snapping between layers will be disabled.

Note: Holding the Control key down will only disable snapping between layers. 
The snapping options will still work on the current layer.

Document units and scale
When setting up the drawing environment, you can choose the units in which 
you want to work. The units chosen affect the Show Size Cursor, the grid lines 
and grid snap, the scale options and rulers, dimension, perimeter calculations, 
area calculations and the units of rotation. The unit options can be set in the 
Document Scale and Units dialog.

Displaying the Document Scale and Units dialog

1.	 Open the Layout menu and choose Set Scale/Units.

The Document Scale & Units dialog appears.
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2.	 Make any changes as discussed in the next section, and click the OK button 
to close the dialog and apply the changes.

Units

English or metric units 

To choose the units

•	 Choose English or Metric from the Unit Type pop-up menu, depending on 
the type of units you want to use in the document.

Unit size

To select the unit size

1.	 Click the units pop-up menu.
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2.	 Choose the unit size option you want. Your choice appears on the button. The 
numerical values shown on the drawing reflect the chosen units.

Decimal places

If you chose a metric or decimal English unit size, you can also specify the 
number of decimal places that you want to be displayed in numerical values. 
You can choose either one, two, three, or four places behind the decimal point, 
as well “None” (no places) to show integers only. Values will be rounded off to 
the selected number of decimal places. The default number of places behind the 
decimal is two. In larger scales, the number of decimal places allowed for display 
may be reduced automatically.

To change the number of decimal places

1.	 In the Document Scale and Units dialog click the Places pop-up menu. The 
decimal places pop-up menu appears.

2.	 Choose the desired number of decimal places.

Once you have made your choice and closed the dialog, all numerical values 
will be rounded off to the selected number of decimal places.
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Hide metric units

To hide metric units

1.	 In the Document Scale & Units dialog, choose Metric from the Unit Type 
pop-up menu 

The Hide Metric Units check checkbox becomes available.

2.	 Click the Hide Metric Units checkbox.

The option will be on, and the unit names will not be shown with the 
drawing’s dimension line and area values.

Scales

Before starting a drawing, you need to determine the sizes of the objects, and the 
paper you are going to use. For large drawings it is impractical to draw objects 
at their actual sizes; it is necessary to reduce them, yet still maintain their proper 
proportions.

A scale accomplishes this. A scale is the ratio of the object’s size on the drawing 
to its size in the real world. For example, if you choose a scale ratio of one 
inch equals ten feet (1" = 10'), a line drawn ten inches long on a drawing would 
represent a 100-foot line in the real world. MacDraft offers 25 different Feet 
& Inches scales and 22 Metric scales for your use plus a custom scale facility. 
This versatility allows you to create a drawing at one scale, and then have it 
automatically converted to a different scale.

You can also have multiple drawings, all at different scales, displayed on the 
screen at the same time. This makes it easy for you to copy and paste between 
drawings. When you paste an object into a drawing with a different scale, the 
object automatically adjusts in size to conform to the scale of the new drawing. 
Alternatively you can use the Paste Unscaled command to paste an object into 
another document at its original size.

Note: The scale you choose is used as the default scale for the document. You can 
assign a different scale to each layer on your drawing if you wish. The default scale 
you specify in the Document Scale & Units dialog will be assigned to new layers. 
If you change the default scale in the Document Scale & Units dialog, any layers 
using the default scale will be rescaled.
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Specifying the scale

To specify the Default scale

1.	 In the Document Scale & Units dialog, click the Default Scale pop-up 
to open the Scale pop-up menu. The options available depend on the units 
chosen.

2.	 Choose the scale you want.

The new scale will be shown in the Default Scale button.

3.	 Click the OK button to close the dialog and apply the changes.

The dialog disappears and your drawing now reflects the new scale
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To specify the Custom scale

1.	 Enter the scale you wish to use in the text fields provided.

2.	 Click the Apply button or press the Enter key.

3.	 If you create a drawing at one scale, and then decide later to change to a new 
scale, simply follow the steps outlined above to choose a new scale. In most 
cases the appearance of the objects on the drawing will either grow or shrink 
depending on the new scale chosen, however if there is text on the document 
you can choose if you want the text to be scaled or not.

Scaling text

If you change the scale of a document that contains text, an alert appears asking 
if you want to scale the text or not.

•	 Click Yes if you want the text to be resized according to the new scale, or

•	 Click No if you wish the text to be shown at the size it currently is on screen.

Note: Scale can be also changed in any layer via the Layer panel/palette. Change 
the scale of a layer by choosing it from the layer pop-up, next to the layer you want 
in the Layers panel/palette.

Angular display

The Angular Display choices let you specify the units in which you want rotation 
and angular dimensions to be shown and calculated.

You can choose to display the rotation units in decimal degrees (e.g. 63.58o), in 
degrees and minutes (e.g. 51o 14'), in degrees, minutes and seconds (e.g. 47o 22' 
30"), or in user defined units.
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Setting the rotation units 

To specify the rotation units

•	 In the Document Scale & Units dialog, choose one of the units types from 
the Angular Display pop-up menu, depending on the type of units you want 
to use in the document.

User defined units

If you choose User defined units, you can specify the number of units to a circle 
by typing a value in the Units to a circle field.

With a value of 16 units to a circle, at one decimal place, 90 degrees will be 
displayed as 4.0.
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Decimal places

If you choose decimal degrees or user defined units for the units of angular 
display, you can also select the number of decimal places you would like to be 
displayed for angular values.

To change the number of decimal places

1.	 Click the Places pop-up menu below the Angular Display.

The decimal places pop-up menu appears.

2.	 Choose the desired number of decimal places.

Once you have made your choice and closed the dialog, all angular values 
will be rounded off to the selected number of decimal places.
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Chapter 7
Libraries and Layers

Symbol libraries
Symbol libraries give you the ability to save, catalog, and reuse standard images 
or symbols. Previously created symbols can be taken out of symbol libraries and 
placed directly into your drawings. 

You can also create your own electrical and architectural symbols or commonly 
used images; these can then be stored in easy-to-access libraries, and inserted 
into drawings as required. 

The symbols in the libraries retain their drawing attributes, such as their scale and 
rotation.

Symbol libraries available

Depending on which MacDraft product you are using either App Only, Home & 
Garden, Starter or Complete, MacDraft has a number of libraries available.

•	 MacDraft App Only: Includes a sample library of 100 items

•	 MacDraft Home & Garden: Includes 2 libraries containing over 1100 items.

•	 MacDraft Starter: Includes 5 libraries containing over 5500 items.

•	 MacDraft Complete: Includes 11 libraries containing over 7500 symbols. 

Purchasing symbol libraries

Contact Microspot directly for information on purchasing additional libraries or 
upgrading to Home & Garden, Starter or Complete packs.
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Microspot Library Palette

Microspot Libraries are now available as a Library file (.spotlibrary). The Library 
viewer is built into the application making the use of the libraries much faster 
and more efficient. You can use the library to drag and drop existing Microspot 
Symbols or create new libraries of your own items. 

Opening the Library Palette

The Library system opens as its own window/palette whether you are in single 
screen mode or palette mode. As there is alot of content stored within the Library 
palette this means it only needs to be loaded as you need it, not every time 
MacDraft is opened. 

To open the Library Palette

1.	 Select Window from the menu bar

2.	 Choose 'Show Library' 

The Library palette will appear. 
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Opening a Library in the Library panel

To open a library

1.	 Open the Library palette by going Window > Show Library. 

2.	 Once the Library palette has opened, click the Options pop-up menu (Circle 
with 3 dots Symbol) at the bottom of the library and choose Open Library...

The standard open dialog appears.

3.	 Locate the library you want to open and click the Open button.

The library will open and be added to the list.

Note: The file type you will be looking for is '.spotlibrary' this is the library file 
format and will be required to load a library into MacDraft.

4.	 Your library will appear under the My Custom Libraries section on the left 
hand side of the Library palette.
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Creating a new library

If you draw an object or group of objects in your MacDraft document, and wish 
to store that object or group in a library it can be done using the following.

To create a new library file

1.	 Open the Library palette by going Window > Show Library. 

The library palette will appear.

2.	 Click the Plus symbol in the bottom left hand corner of the library.

The standard Save dialog will appear.

3.	 With the Save dialog open you can now give the library a name and select a 
location to save it to. Then click Save.

The new library will appear in the My Custom Libraries section on the left 
hand side of the Library palette.

Adding items to the library

1.	 Select the Library you wish to copy the item to via the library list menu in 
the left hand side of the Library palette.

2.	 Select the object or group in the MacDraft document that you want to put 
into the library.

3.	 Hold down the Command key.
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4.	 Whilst holding the Command key down, drag the selection to the Library 
section window.

The library item will appear in the library panel, inside the selected library.

Note: You can also add multiple selections to the library however they will go in as 
a single item.

Removing a library

1.	 Open the Library palette by going Window > Show Library. 

The library palette will appear.

2.	 Select the Library you wish to remove via the library list on the left hand side 
of the Library palette. 
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3.	 Click the Minus symbol in the bottom left hand corner of the library section.

4.	 The selected library will now have been removed.

Note: Removing a library from the Library palette, will not delete it from your 
machine. You can go and add it to the library palette again if you want to. Also you 
are unable to remove pre-installed libraries from the library panel.

Retrieving items from a library

When you want to use a symbol or graphic stored in a library in a MacDraft 
document, you can retrieve items for use by the following.

To drag and drop an item out of a library into an open MacDraft document

1.	 Click the required item in the library to select it.

2.	 Holding down the mouse button, drag the item over the MacDraft document 
window.

3.	 Release the mouse button.

A copy of the item will be placed in the MacDraft document.

To drag and drop an item out of a catalog into an open MacDraft document UNSCALED

1.	 Click the required item in the library to select it.

2.	 Holding down the mouse button, drag the item over the MacDraft document 
window.

3.	 Press and hold the Shift key while dragging the item.

4.	 Release the mouse button.

An unscaled copy of the item will be placed in the MacDraft document.
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Layers
MacDraft allows you to use multiple layers in a drawing, however only one layer 
can be active at a time. This means that you can draw and edit objects on only 
one layer at a time. The name and scale of the active layer appear beside the 
document name in the title bar. The number of layers you can use in a document 
is only restricted by the amount of memory you have.

You can assign a distinct name to each layer and change the order of layers. You 
can choose to hide specific layers (which makes them both invisible and non-
printing), and you can make objects on inactive layers either appear dimmed 
(gray) or show their fill and line attributes. Each layer can have a different scale. 
Layers are controlled through the Layers panel/palette.       

When printing, all layers are printed, not just the currently active layer.

The Layers panel

Displaying the Layers panel

•	 If in Single Screen Mode, choose Show Right Panel from the View menu 
and select the Layers tab.

•	 If in Palette Mode, choose Layers from the Window menu

The Layers palette appears
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Layers list

When you open a new MacDraft document, you start working on Layer-1. The 
names of all the existing layers appear in the layers list.

Only one layer can be active at a time. The active layer is the only layer you can 
edit. In the Layers panel, a white circle appears beside the name of the active 
layer to let you know its the one you are working on.

Inactive layers can be hidden, grayed out or visible. An eye appears beside the 
names of visible layers, a washed out eye for the grayed layers and a blank 
square for the hidden layers.

Selecting layers in the layers list

You can select a single layer or a number of layers in the Layers panel/palette.

To select a single layer

•	 Position the cursor on the layer’s name in the layers list and click it. The 
name of the selected layer will be highlighted in the list.

To select multiple layers listed in order

1.	 Click the name of the first layer you want to select.

2.	 Press and hold down the Shift key.

3.	 Holding down the Shift key, select the layer at the end of the set you wish to 
have selected.

The names of the selected layers will be highlighted.

To select multiple layers that are not listed in order

1.	 Click the name of the first layer you want to select.

2.	 Press and hold down the Command key.

3.	 Holding down the Command key, individually click all of the other layers 
you want to select.

The names of the selected layers will be highlighted.
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Add New Layer

The Plus Symbol button is used to create new layers.

To create a new layer

•	 Click the plus (+) symbol button at the bottom of the Layers panel/palette.

The name of the new layer appears at the bottom of the list of layers in the 
panel. MacDraft assigns the default name “Layer-#” to new layers, where “#” 
is a number that reflects the total number of layers in the document.

Rename a Layer

You can easily rename layers, assigning descriptive names that reflect the 
contents of the layers.

To rename a layer

1.	 In the Layers panel, move the cursor over the name of the layer.

2.	 Click the name once then click again straight after (Slightly slower than a 
double click).

3.	 The name will be highlighted and turn into a text editing area.

4.	 In the text area, type in a new name for the layer.
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Note: You can also rename a layer by selecting it and then choosing Rename from 
the options menu (gear symbol) at the bottom of the Layers panel.

Hidden layers

At times you may find it convenient to hide some or all of the inactive layers on 
the drawing. The contents of hidden layers are not only removed from the screen, 
they are also omitted from printed output. This allows you to print only the 
contents of certain layers. You cannot hide the active layer.

To hide inactive layers

•	 Click the eye symbol next to the layer until a blank square appears. This will 
hide the current layer.

The layers will be re-displayed when you click the blank square. (The eye 
will reappear)

Grayed out layers

The Grayed option is used to specify how the objects on inactive layers are 
displayed. Grayed out layers are without fills and with their borders dimmed. 
This helps to avoid confusion about which objects are on the active layer. 
However, you can choose to have the objects on inactive layers appear with 
their fills and border attributes, including colors and patterns. This allows you to 
preview your drawing before you print it.

Viewing layers accurately

•	 Click the eye symbol next to the layer, until it becomes a solid eye symbol. 
The layer will be displayed accurately.
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To display objects on inactive visible layers as grayed

•	 Click the eye symbol next to the layer you wish to gray out until the half and 
half eye symbol becomes visible.

The Layer will appear grayed out.

Layer Scale

You can assign different scales to the various layers in your document. This 
allows you to include details within an overall floor plan drawing, or details of a 
part of a machine within the drawing of the entire machine.

The default scale for each layer is the scale that was defined in the Document 
Scale & Units dialog. When you start out with a new document, the default scale 
is 1:1; therefore, unless you change the default scale for the document using the 
Document Scale & Units dialog, the default scale for each new layer will be 1:1.

To assign a new scale to a layer

1.	 Locate the layer you want to change the scale of.

2.	 Position the cursor over the over the scale to the right of the layer name.

3.	 Press and hold down the mouse button

The Layer Scale pop-up menu appears.
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4.	 Holding down the mouse button, drag until the scale you want to apply to the 
selected layer is highlighted, and release the mouse button.

The scale for the active layer appears on the title bar beside the document 
and layer names

Notes: 

•	 If there is text on the document you can choose if you want the text to be scaled 
or not.

•	 If you change the default scale in the Document Scale & Units dialog, the 
layers that use the default scale will be changed to the new scale. The layers 
that you have given custom scales to will be unaffected by changes made to the 
default scale. Custom scales will appear at the bottom of the scale pop-up menu 
in the Layers panel.

Arrange Layers

As you add layers, each new layer is placed on top of the existing layers on the 
drawing, a process similar to placing transparent sheets of plastic on top of each 
other. The layer at the top of the layers list in the Layers panel is at the rear of 
the drawing, and the layer at the bottom of the list is at the front of the drawing.

Objects on an upper layer appear on top of objects on a lower layer. If objects 
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are opaque (that is, filled), and overlap objects on a lower layer, they naturally 
cover portions of the objects beneath them. Sometimes you might want to move 
objects on a lower layer in front of an upper layer. To do this, you can rearrange 
the layers.

To move a layer

1.	 Open the Layers Palette or click the Layers tab in the right panel.

2.	 Position the cursor on the layer’s name you want to move in the layers list.

3.	 Click and hold the mouse button down.

4.	 While holding the mouse button down on the selected layer, drag it to the 
position you want the layer in the list.

As you drag the layer a highlight colored line will appear showing where the 
layer position will be.

The layer is moved as requested, and its name is also repositioned in the 
layers list.
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To move multiple layers

1.	 Open the Layers Palette or click the Layers tab in the right panel.

2.	 Select the layers you want to move.

3.	 Click and hold the mouse button down.

4.	 While holding the mouse button down on the selected layers, drag them to 
the position you want them in the list.

5.	 The layers will be placed in the order they were previously.

Merge Layers

MacDraft allows you to merge the objects on two or more layers into one layer. 
All the layers to be merged must have the same scale.

To merge layers:

1.	 Select the layers you want to merge into one layer.

2.	 Open the Options pop-up (gear symbol) menu in the Layers panel/palette 
and select Merge Selection.

A new layer named Merged Layer-#, will be created, where # is the number 
of merged layers in the drawing.

You can rename the layer to the desired name.

The layer can be treated as any other and the objects within those layers are 
now editable under one new layer.
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Delete Layer

You can delete specific layers, along with all their contents. All but the last layer 
in the document can be deleted.

To delete layers

1.	 Select the layers you want to delete.

2.	 Either;

•	 Click the Minus (-) symbol button, or

•	 Open the Options pop-up (gear symbol) menu in the Layers panel and 
select Delete Layer.

Note: You can see how many objects are in a layer by looking at the number to the 
right of the layer scale.
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Selecting the active layer

When you want to edit objects, the layer that those objects are on must be the 
active layer. Only one layer can be active at a time and only objects on the active 
layer can be selected or edited. In the Layers panel, a tick symbol appears beside 
the name of the active layer.

Using the Layers panel

To select the layer to be the active layer using the Layers panel

1.	 Move the cursor over the padlock to the left of the layer you want to be 
active.

2.	 Click the padlock symbol.

The symbol will now be a tick, and the layer will be active.
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To select the layer to be the active layer using the Layer Selection tool

Sometimes you can see the object you want to edit, but you don’t remember 
which layer it is on. The Layer Selection tool offers a good way of getting to a 
visible layer quickly. Once selected, the Layer Selection tool’s cursor allows you 
to click an object in another layer, automatically activating that layer.

1.	 Click the Layer Selection tool in the Layers panel.

2.	 The layer selection cursor appears.

3.	 Click an object that is in a different layer.

The layer that the selected object is on becomes the active layer.

Print Active Layer option  PRO ONLY  

The File menu’s Print Active Layer command can be used to print layers 
separately, either at their full sizes or reduced to fit each layer on a page. You can 
also use Print Active Layer to print the currently shown layer.

Loading layers from another document  PRO ONLY

MacDraft provides you with a method to load a layer from one MacDraft 
document into another. When you load a layer, the layer’s contents and scale 
information are imported into your open MacDraft document.
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To load a layer into the active MacDraft document   PRO ONLY

1.	 Open the File menu and choose Load Layer.

A standard open dialog appears.

2.	 Locate and select the document you want to load.

3.	 Click the Open button.

A dialog listing the layers in the selected document appears.

4.	 Select the layer you want from this list and click the Load button.

The layer you have chosen will be loaded into your open document as the 
active layer.



460Chapter 8 Drawing layout and printing

Chapter 8
Drawing layout and printing

Drawing Layout
Using MacDraft pro, you can create drawings of up to 1,785 inches high by 
1,785 inches (4533cm). MacDraft PE is restricted to 17 inches high by 17 inches 
(43.18cm) You define the desired drawing size by using Page Setup options 
in conjunction with the Drawing Size feature. The Page Setup dialog, opened 
by choosing the Page Setup command in the File menu, determines the size of 
the individual pages that make up the overall drawing area. The Drawing Size 
feature in the Layout menu, has a graphical interface that lets you select the 
number of pages needed to achieve the desired overall size of the drawing.

Before you define the overall size of your drawing using the Drawing Size 
feature, you should select the printer to be used, and set the Page Setup 
information for that printer in the Page Setup dialog.

Note: You will need to make sure your printer has been installed and the correct 
one set as default, before moving onto the Page Setup and Drawing size. For more 
information refer to your Printer or Printer Driver Documentation.

Defining your page setup

The Page Setup options allow you to specify how you want your document to 
appear on the printed page. The Page Setup options available will be determined 
by the printer you selected in the System Preferences.

Displaying the Page Setup dialog

•	 From within MacDraft, open the File menu and choose Page Setup.
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A Page Setup dialog similar to the one below appears.

Page Setup options

Refer to your printer or printer driver documentation for complete details of the 
Page Setup options available. The most important choices: Paper, Orientation 
and Scale are discussed in the following sections.

When you have finished specifying the Page Setup options, click the OK button 
to close the Page Setup dialog.

Paper

Selecting the paper size

1.	 Click the Paper Size pop-up menu to display the paper sizes available for 
your printer.

2.	 Select the size of the paper that you will be printing on.

Note: As most printers require some margin around the edges of the printed 
page, you will not be able to print to the full size of the paper. MacDraft shows 
appropriate page drawing areas (or block sizes) which take into account the required 
printer margins.
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Orientation

Selecting the page orientation

•	 Click the Portrait icon to print objects vertically on the page.

•	 Click the Landscape icon to print objects horizontally on the page.

Scale

Selecting the scale

Enter a percentage value into the Scale text box to reduce or enlarge the printout 
of your drawing.

Defining your drawing size

Once you have specified the Page Setup options you are ready to define the 
overall size of the drawing.

To set the size of your drawing

1.	 Open the Layout menu and choose Drawing Size.

A dialog appears, displaying the current total drawing size in the form of a 
block diagram.
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The diagram is divided into blocks and represents the maximum drawing size 
available, each of the blocks representing a single page. The blocks that are 
darkened indicate the current drawing size.

2.	 Position the cursor on one of the darkened page blocks.

3.	 Press and hold down the mouse button.

4.	 Holding down the mouse button, drag until you have activated the number of 
page blocks required to make up the drawing size you want, then release the 
mouse button.

5.	 Click the OK button to close the Drawing Size dialog.

Note: The MacDraft drawing window generally shows only a portion of the overall 
drawing. Therefore, when you change the drawing size it may not be noticeable 
until you zoom out or scroll to another area of the drawing.

To set the size of your drawing numerically

1.	 Open the Layout menu and choose Drawing Size.

A dialog appears, displaying the current total drawing size in the form of a 
block diagram.
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2.	 Type the number of pages you would like in the No. of Pages text fields.

The graphic area will update to reflect your values.

3.	 Click the OK button to close the Drawing Size dialog.

Hiding and displaying page breaks

Page breaks are visual aids that can be useful when you create a large drawing. 
They can help you locate a particular area of the drawing quickly, and they allow 
you to see if an object happens to fall on the edge of a page, so you can move it if 
necessary. The page breaks are shown by default.

To hide page breaks

•	 Open the View menu and choose Show Page Breaks. The check mark will 
be removed from the command in the menu to show that it is inactive.

To display page breaks

•	 Open the View menu and choose Show Page Breaks again. A check mark 
appears against the command in the menu to show that it is active.
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Printing
MacDraft gives you options to choose how pages are printed. For example, you 
can specify the order in which pages in a document are printed and whether or 
not registration marks are printed.

These options are set in the Drawing Size dialog.

Opening the Drawing Size dialog

•	 Open the Layout menu and choose Drawing Size.

The Drawing Size dialog appears.

Specifying how pages are numbered

You can choose to number pages by column or by row. In either case, page one 
appears in the upper left corner of the document. Page numbers are not added to 
the document with these options but, as the pages are printed in number order, 
this setting affects the print order of the pages.

To number pages

•	 In the Drawing Size dialog, click one of the Page Numbering buttons, 
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either by column (in ascending order from top to bottom), or by row (from 
left to right).

Printing in reverse order

If your printer produces pages face up, it is useful to be able to print pages in 
reverse order so that the printed pages end up in order, starting with page one on 
the top.

To print the pages in the document from the last page to the first page

•	 In the Drawing Size dialog, click the Print Last Page First checkbox.

The pages will be printed in reverse order.

Printing registration marks

If required, you can print crop marks at the corners of each printed page to show 
the edges of the drawing area.

To print pages with registration marks

•	 In the Drawing Size dialog, click the Print Registration Marks checkbox.

Printing a document

Before you print, make sure that you have chosen the printer you want to use, 
and have specified appropriate Page Setup options. 

Choosing your printing options

The printing options available will be determined by the printer selected in the 
Print Center. See your printer or printer driver documentation for details. 

To choose your printing options

1.	 Open the File menu and choose Print.

A dialog similar to the one over the page appears.
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2.	 Set the print options according to your requirements then click the Print 
button to produce your printed document.
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Chapter 9
The report feature  PRO ONLY

Often, you may want to extract information from your drawing in the form of a 
report (a Bill of Materials, for example), or you may need a report detailing the 
properties of objects in your drawing, such as perimeter, area, length, or other 
measurements.

Reports can be very useful for such things as determining the cost of a project or 
counting items in a drawing, such as furniture in an office layout or components 
in a mechanical drawing.

Any change made to your drawing will be reflected in your reports. Once you 
create a report, you don’t have to remember if you’ve changed the length of a 
wall or added furniture or fixtures to a layout. MacDraft’s automatic updating of 
any data you’ve designated for a report can save you hours of work and prevent 
many mistakes.

MacDraft reports can include data about any objects to which you’ve assigned 
object information, such as name, type or manufacturer. In the Report Format 
window, you designate which items of object information you want to include 
as criteria, which functions (Count, Height, Length, Width, X Dimension, Y 
Dimension, Area, Perimeter, or Total) you want performed on the data, label the 
items if necessary.
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Setting up a report  PRO ONLY

Getting started  PRO ONLY

Displaying the Report Formats dialog  PRO ONLY

Most report actions, including creation of a new report, begin with the Report 
Formats dialog. The dialog shows the names of all a drawing’s reports, an area 
for creating the contents of the report, as well as loading reports in from other 
drawings.

To display the Report Formats dialog

•	 Choose Report Formats... from the Data menu.

Creating a new report   PRO ONLY

To create a new report

•	 Click the Plus button in the Report Formats dialog.

A default name for the report appears in the list box and the text field.
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Renaming a report  PRO ONLY

It may often be helpful to have a more descriptive name for a report than the 
default name provided.

To rename a report

1.	 Select the name of the report that you wish to rename from the report list in 
the Report Formats dialog.

2.	 Either

•	 Type a new name into the text field.

•	 Choose Rename from the gear symbol at the bottom of the reports list.

3.	 The report’s name in the list box will be updated.

Opening a report  PRO ONLY

•	 Select a report name from the report list in the Report Formats dialog. 

The report format window for the selected report appears.
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Defining the report  PRO ONLY

Reports include three basic elements: Functions, such as COUNT; Criteria for the 
functions (for example, you can COUNT all objects with Name = Stepping Stone 
and Type = Aggregate); and text for headings and notes. You must specify what 
you want each report to contain.

You set up a report mainly by using the row pop-up menus in the Report Format 
window. These let you quickly define whether a row will contain text, criteria, or 
a function. All you need to do is click at the end of the row and make your choice 
from the pop-up menu that appears.

Criteria Bar Text Results

Functions Object Information
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Specifying a report’s text fields  PRO ONLY

The default condition for rows is text; any row not marked otherwise in the left-
most column is a text row. You can enter text in the row’s cells just by clicking 
and typing.

You can also choose Text from the row menu to define a text row. Text is used for 
any headings and comments you wish to appear on the report.

To set up a report’s text

1.	 In the report format window, choose a row you want to use for text.

In a new report, each row will be blank in all columns, showing that they are 
text rows.

2.	 Click in the cell where you want to have text, then type the text, except for 
the first column which is reserved for criteria.

3.	 Move to the next cell, if necessary, by pressing the Tab key.

Note: Text can be wider than a single column, if the next cell in the row is empty.

4.	 Repeat steps 2 and 3 until all the text is in place.

Setting up a report’s criteria bars  PRO ONLY

Choosing Criteria from the row menu makes that row a criteria bar. Each column 
in the criteria bar will have a menu containing the list of object field names 
you can use for criteria. You can choose a field name for a column or leave it 
undefined.
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To set up a report’s criteria bars:

1.	 In the Report Format window, choose a row you want to use for criteria.

2.	 Open the Row pop-up menu at the left end of the row and choose Criteria.

The row will read CRITERIA in the first column, showing that it is a criteria 
bar. All the cells in the bar will read Undefined.

3.	 Move the cursor to a cell in the criteria bar where you want to enter a criteria, 
and click it.

A pop-up menu listing the drawing’s field names, Results and fx Name 
appears.
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Note: The field names will be either the default field names or the field names you 
have defined for the drawing

4.	 Choose the field you want for the criterion in this column. 

The field name appears in the criteria bar.

5.	 Repeat steps 3 and 4 until you have entered all the criteria required for this 
criteria bar.

6.	 If you want more than one criteria bar in the report, repeat steps 1 through 5 
as needed.

The report format window below shows the criteria Name and Type in the 
criteria bar.
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The results column  PRO ONLY

Sometimes not all the columns in the Report Format window are needed, or the 
Results column may be required to appear before other columns in a report. The 
position of the Results column can be adjusted using the pop-up menu in any 
Criteria Bar.

To make a report with fewer than six columns, one of the middle columns can 
be changed to Results and the column on the right of the report changed from 
Results to Undefined.

To move the results column

1.	 Move the cursor to the column in the criteria bar in which you want to 
display results, and click it.

2.	 Choose Results from the pop-up menu that appears.

“Results” appears in the criteria bar.

3.	 Move the cursor to the column in the criteria bar in which the results were 
previously to be displayed, and click it.

4.	 Choose Undefined from the pop-up menu that appears.
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“Undefined” appears in the criteria bar.

Displaying and printing report function names  PRO ONLY

In some MacDraft reports, you may want to display the names of the functions 
used (Area, Count, and so on). The current function’s name can be automatically 
inserted in any cell of a function row using the “ƒx Name” option in the Criteria 
Bar’s pop-up menu. The function name then appears automatically in that cell 
when the report is printed.

Note: Once a function name is inserted, it can be edited like the content of any 
other text cell (for example, abbreviating “Perimeter” to “Prmtr”). However, if the 
function of a row is changed, the name of the new function will overwrite whatever 
was in that cell.
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To insert the name of a function

•	 In the desired column of the Criteria Bar, open the criteria pop-up menu and 
choose ƒx Name.

The function names appear in that column in all function rows controlled by 
that Criteria Bar.

A report’s function rows  PRO ONLY

MacDraft’s report formats can display the individual or total lengths, widths, 
heights, areas, and perimeters of objects, or sets of objects, chosen by the object 
information you specify. The reports can also display the count, or total number, 
of objects that match your criteria.

Adding a function to your report is as easy as choosing it from the row menu. 
Once you’ve done so, the name of the function will be displayed at the beginning 
of the row. To set the criteria for the function, you enter the desired Object 
Information into the column under the appropriate field name.

Functions

MacDraft’s reports extract different types of information from different types 
of MacDraft objects. All the functions except Count give results measured 
according to the scale and units of the layers containing the objects.

Area

Shows the area of an object, or the sum of the areas of multiple items or items 
in a group. (This function does not show a value for text objects and dimension 
objects.)
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Count

Shows the total number of objects and groups that meet the criteria 

Height

Shows the unrotated vertical size of an object or group, or the sum of vertical 
sizes of multiple items. For example, if a one-inch square has been rotated 45 
degrees, this function will still show its height as one inch. (This function does 
not show a value for text objects and dimension objects.)

Length

Shows the longest measurement of an object or group, or the total of the longest 
measurements of multiple items. For lines, linear dimension objects, and radial 
dimension objects, this is the distance between the two ends or reference points. 
For most other objects, the length is the longer of the horizontal or vertical (X or 
Y) extents of the object; if the object has been rotated, the value is determined as 
if the object had not been rotated. (This function does not show a value for text 
objects and angular dimension objects.)

Perimeter

Shows the length of a line, the perimeter of any other object or group, or the total 
of these measurements of multiple items. (This function does not show a value 
for text objects and dimension objects.)

Width

Shows the unrotated horizontal size of an object or group, or the sum of 
horizontal sizes of multiple items. For example, if a one-inch square has been 
rotated 45 degrees, this function will still show its width as one inch. (This 
function does not show a value for text objects and dimension objects.)

X-dimension

Shows the horizontal size, measured along the horizontal axis, of an object or 
group, or the sum of horizontal sizes of multiple items. For example, if a one-
inch square has been rotated 45 degrees, this function will show its X-dimension 
as about 1.4 inches. (This function does not show a value for text objects and 
dimension objects.)
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Y-dimension

Shows the vertical size, measured along the vertical axis, of an object or group, 
or the sum of vertical sizes of multiple items. For example, if a one-inch square 
has been rotated 45 degrees, this function will show its Y-dimension as about 
1.4 inches. (This function does not show a value for text objects and dimension 
objects.)

Total

MacDraft’s “Total” function allows an item’s object information fields to be 
treated as a quantity. When the report is run, MacDraft adds up all of the numeric 
values in that field from the objects that match the criteria specified.

Setting up a report’s function rows  PRO ONLY

To set up a report’s function rows

1.	 In the report format window, choose a row you want to use for a function.

2.	 Open the Row pop-up menu at the left end of the row and choose a function.
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3.	 The row displays the name of the function in the first column, showing that it 
is a function row.

4.	 If you want more than one function row in the report, repeat steps 1 through 
2 as needed.

5.	 In the report format window, the count and length have been selected.

You can continue to define additional rows of functions using the same field 
names, or insert a new criteria bar to change the field names used in the functions 
that follow. (Each function row is controlled by the closest criteria bar above 
it.) Inserting criteria bars and adding functions below them allows you to create 
comprehensive reports that may extend over multiple pages if needed.

The Total function  PRO ONLY

In some MacDraft reports and drawings, one graphical object may be required 
to represent more than one “real-world” item. For example, to help determine 
equipment costs, one symbol of a workstation might need to stand for five actual 
workstations. Then, if ten such symbols are included in a drawing, a report can 
be set up to show that a total of 50 workstations were used.
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MacDraft’s Total function allows an item’s object information fields to be treated 
as a quantity. When the report is run, MacDraft adds up the numeric values in the 
specified field for objects that match the stated criteria.

To set up a Total function in a report format

1.	 Define one of the drawing’s object information field names as “Qty” or some 
similar term.

2.	 Draw a workstation symbol (for example) and give it object information of a 
certain name, brand, and so on, then assign a quantity of “5” in the Qty field.

3.	 Duplicate the symbol as required.
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4.	 In a report format, set up a Criteria Bar including the necessary field names 
as criteria.

5.	 Include the function “Total(Qty)” in the report format.

6.	 Enter the function’s criteria, either by typing or with the Object Information 
insertion cursor.

7.	 All the numeric values in the field named by the Total function (Qty.) will be 
summed up and displayed in the Results column.

Note: The field used by the Total function does not need to have an identical value 
for each object, the function will add up all numeric values from that field from 
all objects that match the specified criteria. If a field contains any non-numeric 
characters, it will count as zero.
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Adding object information  PRO ONLY

MacDraft uses the field names in the report’s criteria bars to search for objects or 
groups that match object information entered in the function rows. The results of 
the functions for the found objects are then displayed in the Results column.

Object information must be entered in each function row. If you remember the 
object information needed (and its exact spelling), you can type it directly into 
the function row under the appropriate field names (listed in the criteria bar 
above). However, you can also use the Obj. Info button to select an example of 
the object in the drawing. The Object Information of the selected object will be 
inserted into the appropriate criteria fields.

To enter the object information for an item

1.	 In the report format window, click in a function row.

A flashing text-insertion cursor appears in the cell you clicked.

2.	 Click the Obj. Info. button at the bottom left of the report format window.

The report format window temporarily disappears, and the cursor appears 
with a question mark attached to it.

3.	 In the document window, click the object you want to use for the function’s 
criteria.
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Note: You can only select an object that has object information assigned to it.

Note: The object can be on any visible layer

The Report Window reappears, and the selected row shows the object’s 
information in the appropriate columns.

4.	 If you want object information in more than one function row in the report, 
repeat steps 1 to 3 as needed.

Note: If an object’s data is in a column that is Undefined in the criteria bar, it will 
be treated as a text label and will be ignored by the function.
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In the report format window below, the following object information has 
been inserted: name “Stepping Stone”, type “Aggregate”; name “Outlet”, 
type “Single”; name “Facing”, type “Brick”.

Changing the appearance of a report  PRO ONLY

You can make various changes to a report’s appearance, depending on how you 
want it to be displayed. Report text can have a particular font and size; text can 
be justified in cells, columns or rows; rows can be inserted or deleted; and the 
width of columns can be changed.

Formatting text  PRO ONLY

Setting the text font and size   PRO ONLY

•	 With the Report Format window active, open the Text menu and make the 
appropriate selections from the Font and Size submenus. 

Your choices will be applied to the whole report.

Changing the justification of text  PRO ONLY

You can apply different text justifications to cells, rows or columns by using the 
Text menu’s Justification submenu.
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Justifying text  PRO ONLY

To change the justification of text

1.	 In the Report Format window, make a selection.

2.	 Open the Text menu’s Justification submenu.

3.	 Choose the desired horizontal Justification.

4.	 Open the Justification submenu again.

5.	 Choose the desired vertical justification.

The text will be justified as specified.

Selecting text to justify   PRO ONLY

To select the text in a single cell

•	 In the Report Format window, click the cell to be changed. 

To select all the text in a row

•	 In the Report Format window, click the first cell in a row, or hold down the 
Shift key and click the row control button.        

       The row will be selected.

To select all the text in several rows

1.	 In the Report Format window, click the first cell in a row, or hold down the 
Shift key and click the row control button.

The row will be selected.
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2.	 Press and hold down the Shift key.

3.	 While holding down the Shift key, click the next row’s first cell.

4.	 Repeat step 3 until all the rows needed are selected.

To select all the text in a column

•	 In the Report Format window, click the top cell in a column.

The column will be selected.

To select all the text in several columns

1.	 In the Report Format window, click the top cell in a column. 

The column will be selected.

2.	 Press and hold down the Shift key.

3.	 While holding down the Shift key, click the top cell in the next column.

4.	 Repeat step 3 until all the columns needed are selected.

Changing columns and rows in a report  PRO ONLY

Changing the width of a column  PRO ONLY

To change the width of a column

1.	 In the Report Format window, move the cursor to the right edge of a 
column control (the top cell in a column).

The cursor changes to the column adjustment cursor.
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2.	 Hold down the mouse button and drag left or right to define the new column 
width.

3.	 When you have defined the width you want, release the mouse button. The 
column will assume the width you specified.

Inserting a row  PRO ONLY

To insert a row

1.	 In the Report Format window, click the first cell in a row (next to the row 
control button) or hold down the Shift key and click the row control button.

The row will be selected.
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2.	 Choose the Insert Row from the Options menu (gear symbol) in the bottom 
right hand corner of the Report Format window.

Note: If you select several rows and choose Insert Row, the same number of rows 
will be inserted above the selected rows. If you choose Insert Row with no rows 
selected, a new row will be added to the bottom of the report.

Removing a row  PRO ONLY

To remove a row

1.	 In the Report Format window, click the first cell in a row (next to the row 
control button) or hold down the Shift key and click the row control button.

A new row appears above the selected row.
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The row will be selected.

2.	 Choose the Remove Row from the Options menu (gear symbol) in the 
bottom right hand corner of the Report Format window.

The row is deleted, and the rows below it move up.

Loading a report from another drawing PRO ONLY

Each MacDraft report format is stored as part of a drawing file. After you have 
created reports for several drawings, you may find that a report format created for 
one drawing would be useful in another drawing. The Load feature in the Report 
Formats dialog lets you copy report formats into the current drawing file.

Once a report is loaded into a drawing, it uses the field names defined for that 
drawing, no matter what the field names were in its source file. However, it 
retains the order of the fields, and any text-display attributes already defined.



491 Chapter 9 The report feature

To load a report from another drawing  PRO ONLY

1.	 Choose the Data menu’s Report Formats... command.

The Report Formats dialog appears.

2.	 Choose the Load from the Options menu (gear symbol) in the left hand 
section of the Report Format window.

3.	 A dialog listing the MacDraft drawings in the current directory appears.

4.	 Locate the file that contains the report you want to open and select it.

5.	 Click the Open button.

A dialog listing the report formats in the selected MacDraft document 
appears.

6.	 Click the name of the report format you want.

7.	 Click the Load button.

The Report Formats dialog appears again, with the report you chose 
displayed in the list of the current drawing’s report formats. 
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Deleting a report  PRO ONLY

You can delete a report by using the Minus button in the Report Formats dialog.

Note: You cannot undo the deletion of reports.

1.	 Choose the Data menu’s Report Formats... command.

The Report Formats dialog appears.

2.	 In the list of reports, select the report to be deleted.

3.	 Click the Minus button.

An alert appears asking you to confirm that you want to proceed.

4.	 Click OK to delete the report, or click the Cancel button to close the alert 
without deleting the report.
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Printing a report  PRO ONLY

You can print a report by using the standard Print dialog.

1.	 Choose the Data menu’s Report Formats... command.

The Report Formats dialog appears.

2.	 In the list of reports, select the report to be printed.

3.	 Choose Print from the File menu.

A dialog similar to the one over the page appears.

4.	 Set the print options according to your requirements then click the Print 
button to produce your printed document.
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Chapter 10
Troubleshooting

Although we hope that you never have any issues when running your MacDarft 
application, all computers and software have their own incompatibilities and 
can sometimes run into issues. This chapter identifies several of the common 
problems you may run into and includes recommendations to fix them.

If you don't find the answer you are looking for in this section you can contact 
our support team free of charge, by emailing support@microspot.co.uk or by 
going to the Help & Support section at www.microspot.com.

When dealing with technical issues it is important that you make sure that your 
machines meet or exceed the system requirements for running MacDraft. Also 
bear in mind that the more data, such as images and objects that you include in 
your documents the greater the amount of available RAM is used for running 
MacDraft on your machine.

LEGAL DISCLAIMER

IMPORTANT - READ CAREFULLY BEFORE FOLLOWING TROUBLESHOOTING TIPS

Microspot and MacDraft has made every effort to make the information contained in 
this guide accurate, complete and useful. However, inaccuracies, errors and omissions 
may occur. All recommendations, statements and procedures are given without 
warranty of any kind. The user assumes all risks associated with the use of this guide.



495 Chapter 10 Troubleshooting

Performance or functionality issues
Because MacDraft has a set of application and new document preferences to refer 
to, you may encounter some preference-related issues when using MacDraft. 
Most performance or functionality related issues, such as the speed of loading 
files, issues with cursors not displaying and redraw problems, can be fixed by 
deleting your preferences as per the instructions below.

How do I delete my MacDraft preferences?

Before following the steps below to delete your preferences, make sure that you 
have saved all of your work and quit MacDraft. The following steps will describe 
how to delete your current preference file, so that MacDraft can create new 
default preferences.

To delete you preferences:

1.	 Open the Finder

2.	 Click the Go menu

The Go menu options will appear

3.	 Hold the Option (alt) key down and the Library option will appear.

4.	 Still holding the Option (alt) key down, select the Library menu item. 

NOTE: If running 10.12 Sierra select Go to Folder from the Go menu and 
type ~/Library, then click the OK button

The Library folder at user level will open.

5.	 Open the Preferences folder.

6.	 Look for and delete the following files (you may not see them all)

•	 uk.co.microspot.md8pro.plist

•	 uk.co.microspot.md8pro.lockfile.plist

•	 uk.co.microspot.md8pro.plist.lockfile

7.	 Close the Finder Window
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8.	 Relaunch MacDraft

MacDraft will run using a default set of preferences

Performing these steps should have fixed most of the performance related issues 
you may be having. It is also important to note that once you relaunch the 
MacDraft application a new set of preference files will be created.

File opening issues
Sometimes you may experience issues with opening particular files in MacDraft. 
There could be a number of reasons for this and some of which may require a file 
to be opened in an older version. To determine the issue and in turn the fix for 
these issues we must first find out the documents file type, then we can look at 
ways to get the files to open correctly.

How do I know what type of document I have?

Every document has a specific file extension attributed to it. However sometimes 
those file extensions are not visible and sometimes they could have been altered 
by someone else. The true file type extension is stored within the data of the file 
itself and can be found by viewing the file in a text editing application, such as 
Apple's Text Edit.

To find out what the document type is:

1.	 Launch a text editing application, for example Text Edit.

2.	 Choose Open... from the File menu

3.	 Locate the document you are interested in and select it 

4.	 Click the Open button.

The data in the file will open in a new text document. Most of the 
information will seem to be incoherent letters, symbols and numbers.
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5.	 The important information is located in the first part of the text. Locate the 
first few characters of the text file and it will tell you the true file extension 
for the document you have opened.

The following are file types that you may expect to see:

•	 MDD: This is an old MacDraft document type that cannot be opened in 
MacDraft 7 or higher. You will need to open it in an earlier version and 
resave it in a newer format.

•	 MD60: This is the previous MacDraft document that can be opened in 
MacDraft 7 or higher.

•	 MD70: This is the current MacDraft 7 document type and will open 
MacDraft 7 or higher.

•	 AC1032: This is a DWG 2018 file type and should be able to be opened 
in MacDraft 7 or higher.

What do I do if my file is an old MDD file type?

If you have some old files created in MacDraft version 5.5 and below or possibly 
old PC Draft files, you will notice that their file type is MDD. MacDraft 7 can 
no longer open MDD files, however you can open the files in an older version of 
MacDraft, such as version 6.2 and then re-save the file as an MD60 file.

To open and re-save an MDD file:

1.	 Launch MacDraft 6.2.

2.	 Choose Open... from the File menu

3.	 Locate the document you are interested in and select it 

4.	 Click the Open button.

The content of the MDD file will display on the screen

5.	 Select Save As... from the File menu

The standard Save dialog appears

6.	 Give the file a name and choose a location to save it in (make sure that 
MacDraft is selection in the format pop-up).
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7.	 Click the Save button

A copy of the MDD file will now have been saved as an MD60 file with the 
name you chose and in the destination you specified.

You can now open the MD60 file as normal in MacDraft 7 or higher. Please note 
that depending on the age of the MDD file, there may be some items that are lost 
or slightly different when you save it as an MD60. If this is the case you, may 
need to redraw or add certain parts to the drawing once opened in MacDraft 7 or 
higher. Always check the content of your files before saving them.

File corruption issues 
There are some instances where a file can become damaged or corrupt. This 
can be caused by many different factors and without looking deep into the data 
structure its often difficult to determine the cause. However there is one thing 
that you can do to maybe recover some of the data before sending the file to our 
support team for testing.

What do I do if my file is an MD60 or MD70, but still wont open?

The first thing you can do is make sure that the file is actually an MD60 or MD70 
file, by following the steps in File Opening Issues - How do I know what type 
of document I have?

If you find that the files are actually MD60 or MD70 files, but they still do not 
open, then one thing you can do is attempt to load the content of the layers into 
MacDraft Pro separately.

To load a layer into the active MacDraft document:

1.	 Open the File menu and choose Load Layer.

A standard open dialog appears.

2.	 Locate and select the document you want to load.

3.	 Click the Open button.

A dialog listing the layers in the selected document appears.

4.	 Select the layer you want from this list and click the Load button.
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The layer you have chosen will be loaded into your open document as the 
active layer.

If the above steps worked then the data in that layer has successfully been 
recovered and placed in another document. If there are other layers, repeat the 
steps for each one until all are loaded or it is unable to load one of them.

Serial number and version issues 
If you are having trouble locating your serial number for upgrading or support 
purposes or you are unsure as to what version of MacDraft you are running, there 
are some quick and easy steps to follow to get the information you need.

How do I find the serial number I'm using in MacDraft?

The serial number you are using in MacDraft can be found in the Enter Serial 
Number dialog.

To find your serial number:

1.	 Launch MacDraft.

2.	 Choose Enter Serial Number... from the MacDraft menu. 

Note: If you don't see the Enter Serial Number option, you are running an 
Mac App Store version, and therefore will need to provide your App Store 
order ID#

The Enter Serial Number dialog appears. 

You can see the serial number you are using in this dialog. Copy the serial 
number and maybe store it in a secure text document in case you need it at a 
later date.

3.	 Click Cancel when ready to return to using MacDraft.

How do I find out what version I am running?

There are 2 ways to find out what version of MacDraft you are running. The first 
is to check the About dialog and the second is to decode part of the serial number. 
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To find what version I am running in the About dialog:

1.	 Launch MacDraft.

2.	 Choose About MacDraft from the MacDraft menu.

The About MacDraft dialog appears and you can see the version of 
MacDraft you are running.

3.	 Close the dialog when ready to return to using MacDraft.

To find what version I am running from my serial number:

The two most important parts of the serial number, to determine the version and 
product are the first two blocks. In the example below you can see which of the 
blocks we mean and how to determine what they mean.

MDFT - V800 - XXXX - XXXX - XXXX - XXXX

In the above example the first section of the serial number MDFT tell us that it is 
a MacDraft Professional serial number. The second section of the serial number 
tells us the version. Therefore V800 means that this is a MacDraft version 8.0 
serial number.

Library content issues 
Sometimes users have noticed that their library files and content are not showing 
up when they select them. This could be caused by a couple of things. The first 
being that the library has been removed from the list (if its a custom library) and 
the second being that you have a search term entered in the Library search field.

How do I add my own library to the Library panel?

Sometimes if you have moved a library that you created you will find that the 
content does not display correctly in MacDraft. This means you will need to re-
add the library to the library panel so that you can access its content again.

1.	 Open the Library panel by selecting Show Right Panel in the View menu.

The right panel will appear and the Library is at the bottom.



501 Chapter 10 Troubleshooting

2.	 Once the Library panel has opened, click the Options pop-up menu (Gear 
Symbol) at the bottom of the library.

The standard Open dialog appears.

3.	 Locate the library you want to open and click the Open button.

The library will open and be added to the list.

4.	 Click the pop-up at the top of the library section and select the library you 
have just added.

Removing a search term from the Library panel?

Sometimes if you have searched for a particular item in the Library panel, you 
leave the text you entered in the search field. This will cause only those items to 
display, so later when you select a library to use its content, but forgot to remove 
the search term, it will seem as if all your library content has disappeared. Simply 
delete the search term form the search field and all your items should reappear.

PDF exporting issues 
There have been some questions regarding how to export the whole page of a 
document as a PDF, or simply the content itself.

How to export the whole page as a PDF

1.	 Go to the File menu and choose Export... 

2.	 Choose PDF

3.	 A window will appear allowing you to choose how you wish to export your 
PDF, choose 'Whole Document'.

How to export the content only as a PDF

1.	 Go to the File menu and choose Export... 
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2.	 Choose PDF

3.	 A window will appear allowing you to choose how you wish to export your 
PDF, choose 'Content Only'.

How to export a Page-by-Page PDF

1.	 Go to the File menu and choose Export... 

2.	 Choose PDF

3.	 A window will appear allowing you to choose how you wish to export your 
PDF, choose 'Page-by-Page'.
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Appendix
Menus, Shortcuts and File 

Format Support

Menu Commands

File Menu

New

Use to create a new or display the Template Chooser. How this behaves will 
depend on the options you have chosen for Application and Document defaults.

Open...

Opens the standard Open dialog allowing you to locate and open your 
documents.

Open DWG/DXF with options...  PRO ONLY

Opens the standard Open dialog allowing you to locate and open your DWG or 
DXF files and then define the options for opening the files.

Load Layer...  PRO ONLY

Opens the Load Layer dialog used to load a layer from another document into the 
current document.
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Close

Closes the document. Before closing, a dialog will ask if you want to save the 
changes made to the document.

Hold down the Option key and this command changes to Close All. Use to close 
all open documents. Again dialogs appear asking if you want to save any changes 
made to documents.

Save...

Saves your drawing to disk. If the drawing has not been saved before, you will 
be asked to name the document and specify a location to save it. The drawing 
remains open.

Duplicate

Duplicates the current document and its contents and allows you to save it under 
a different name.

Revert To

Gives access to a revert system, giving you access to multiple iterations of your 
file, which you can choose from to revert to. 

Save As Template...

A special save dialog for putting your templates in the correct place, so they are 
usable in the template chooser dialog.

Import Image...

Opens the standard Open dialog allowing you to locate and open your images.

Export

Opens the Export submenu used to export a file in PDF, image formats, DWG 
and DXF.
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Page Setup

Opens the Page Setup dialog used to specify how you want your document to 
appear on the printed page. Options include paper size, orientation and scale.

Print

Opens the Print dialog used to print out the drawing. The printing options 
available will be determined by the selected printer, but usually include page 
range, number of copies and so on.

Print Active Layer  PRO ONLY

Opens the Print dialog used to print out the currently active layer only. The 
printing options available will be determined by the selected printer, but usually 
include page range, number of copies and so on.

Edit Menu

Undo/Redo

Undo reverses the last operation performed. Redo performs an operation that 
was reversed by using the Undo command. There are 100 levels of Undo in 
MacDraft. 

Cut

Removes a selected object from the drawing and places it on the Clipboard.

Copy

Copies a selected object from the drawing and places it on the Clipboard.

Paste

Pastes an object from the Clipboard onto the drawing at the point where you 
click.

Hold down the Shift key and this menu item changes to Paste Unscaled. 
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Use this command to paste an object into a document and have it appear at its 
original size, regardless of any differences in view scale between the object and 
the destination document window.

Clear

Removes a selected object from the drawing.

Repeated Paste

Use to repeatedly paste an object onto a drawing.

Copy Attributes

Use to copy an object’s graphic attributes (fill, pen color or pattern, line weight 
and line style... etc) and object information.

Apply Attributes

Use to apply copied attributes to selected objects.

Duplication

Allows you to duplicate selected objects with or without offset and in linear and 
circular arrays.

•	 Duplicate 

Creates a duplicate of the selected object with an offset.

•	 Duplicate Without Offset: 

Creates a duplicate that is placed directly on top of the original.

•	 Duplicate Unlocked:  PRO ONLY

Use this command to avoid duplicating locked objects. All other objects in 
the selection will be duplicated.
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•	 Duplicate Unlocked Without Offset:  PRO ONLY

Use this command to avoid duplicating locked objects. All other objects in 
the selection will be duplicated in the same place as the originals.

•	 Linear:  PRO ONLY

Use this command to display the linear duplication dialog for defining 
duplication in a linear array.

•	 Circular:  PRO ONLY

Use this command to display the linear duplication dialog for defining 
duplication in a circular array.

Select All

Selects all the objects on the active layer.

Hold down the Shift key and this menu item changes to Select None. Use this 
option to deselect all selected objects.

Select Special  PRO ONLY

Opens the Select Special dialog which allows you to select objects according to 
their type, graphical attributes or object information.

Move

Opens the Move dialog which allows you to move objects or groups with 
precision by entering values from the keyboard.

Expand/Contract

Opens the Expand/Contract dialog used to increase or decrease the size of an 
object by multiplying its dimensions by specified values.

Reshape

Use the commands in the Reshape submenu to reshape an object so that straight 
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lines and sharp corners become curved lines and rounded corners, or to reverse 
the smoothing action.

Edit Datum

Allows you to define a new datum point for a selected object.

Text Menu

Font

The Font submenu lists Show Fonts dialog, Bold, Italic and Underline styles, and 
Bigger and Smaller text size steps.

•	 Show Fonts

Displays the system Fonts panel for choosing the font you would like to use, 
the size and other font related options.

•	 Bold, Italic and Underline

Sets the font style to Bold, Italic or Underline. For more style options 
attributed to the fonts you have chosen, use the Show Fonts command.

•	 Bigger and Smaller

Increases or decreases the font size incrementally, each time you click these 
commands.

Justification

The Justification submenu provides options for justifying text. Select a horizontal 
and/or vertical justification option for text.

Line Spacing

The Line Spacing submenu lists line spacing options for text. Select the line 
spacing you want to use from the list.
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Transformations

The Transformations submenu lists the case options available for text. Select the 
case option you want to use from the list.

Mirror Text

Mirrors the text currently selected.

Select All Text

Selects all text objects in the current layer.

Hide Text

Hides text on the drawing. When this option is on, text is also omitted from 
printed output.

Hide Text On Active Layer

Hides text on the currently active layer.

Highlight Clipped Text

If text is likely to overflow the text box then with this option turned on the 
text box will be highlighted in red. The text box should be increased in size to 
accommodate all of the text, and the red outline will disappear.

Create Outlines

Use this options to turn your selected text objects into vector shapes.

Spelling & Grammar

Use to check spelling and grammar across the document.

Options Menu

Border Position
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Opens a submenu that lists the options available for border positions. Choose the 
desired option from the submenu.

Pen Style  PRO ONLY

Opens a submenu that lists the options available for pen styles. Choose the 
desired option from the submenu.

Zoom Line Weights  PRO ONLY

Choose to turn Zoom Line Weights on or off. When Zoom Line Weights is on, 
lines and borders are magnified in proportion to the current zoom factor. When 
Zoom Line Weights is off, line widths are displayed as they would appear at a 
normal view, regardless of zoom factor.

Hide Line Styles  PRO ONLY

Choose to turn Hide Line Styles on or off. When Hide Line Styles is on, lines 
drawn with line styles will be displayed as plain lines. When Hide Line Styles is 
off, lines appear drawn with the line style applied.

Edit Line Styles  PRO ONLY

The Edit Line Styles submenu lists the available line styles. Select a line style 
from the list to edit it.

Add Horizontal Guide  

Adds a horizontal reference guide to the center of the document.

Add Vertical Guide  

Adds a vertical reference guide to the center of the document.

Add Guide by Position...  

Opens a guide by position dialog, that allows you to choose which guide to add 
and the exact position it should be placed in the document.

Grid Type 
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Opens a submenu that lists the two grid type options. Use this to select either a 
dotted grid or square grid.

Interface Colors 

Opens a dialog that allows you to choose the colors you want to use for 
background, grid and page breaks, guides and smart snap lines.

Include Background Color when Printing 

Choose to allow the background color of the document chosen in the Interface 
Colors dialog, to be printed or not.

Hide Fills  PRO ONLY

Choose to turn Hide Fills on or off. When Hide Fills is on, fill colors and patterns 
applied to objects are not displayed. When Hide Fills is off, fill colors and 
patterns are displayed. 

Cross Cursor

Choose to activate and deactivate the crosshair-style drawing cursor. When 
Cross Cursor is active, the cursor appears as a crosshair which extends into the 
drawing’s rulers. When Cross Cursor is off, the cursor will be a small cross.

View Menu

Show Tab Bar

Choose to turn the tab bar on or off. When Show Tab Bar is on, all documents 
will be opened as tabs instead than new windows. When Show Tab Bar is off, 
documents will be opened in new windows.

Show All Tabs

Use to display all of the tabs currently open in MacDraft.

Zoom In

Use this option to increase the magnification of the view in increments.
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Zoom Out

Use this option to decrease the magnification of the view in increments.

Restore Prev. Zoom

Changes the view back to the previous level of magnification.

Home View

Changes view to display unmagnified in the upper left corner of drawing.

Show Cursor Position

Choose Show Cursor Position to show or hide the cursor position indicator. 
When Show Cursor Position is on, the X and Y coordinate position of the cursor 
will be displayed at the bottom left of the document window. When Show Cursor 
Position is off, this information does not appear.

Show Size Cursor

Choose to turn the Show Size cursor information on or off. With the Show Size 
options turned on the cursor information will display the position and size of 
objects as they are drawn, moved or resized. With the Show Size option turned 
off, the cursor information will not display.

Show Rulers

Choose to turn the rulers on or off. With Show Rulers turned on the rulers will be 
visible. With Show Rulers turned off, the rulers will be hidden.

Show Guide Lines

Choose to turn the guide lines on or off. With Show Guide Lines turned on the 
guide lines will be visible. With Show Guide Lines turned off, the guide lines 
will be hidden.

Show Grid Lines

Choose to turn the grid lines on or off. With Show Grid Lines turned on the grid 
lines will be visible. With Show Grid Lines turned off, the grid lines will be 
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hidden.

Show Page Breaks

Choose to turn the page break reference lines on or off. With Show Page Breaks 
turned on the page break reference lines will be visible. With Show Page Breaks 
turned off, the page break reference lines will be hidden.

Switch to Single Screen / Floating Palettes

Choose this to display MacDraft in single screen mode or with floating palettes. 

Show Left Panel

Choose to show and hide the left panel in the application window.

Show Right Panel

Choose to show and hide the right panel in the application window.

Show Area

Calculates the area value of a selected object and displays the result in the center 
of the object.

Hide Area

Hides the result of the area calculations for a selected object.

Show Perimeter

Calculates the perimeter value of a selected object and displays the result in the 
center of the object.

Hide Perimeter

Hides the result of the perimeter calculations for a selected object.

Hide Toolbar
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Choose to hide and show the toolbar containing quick access options that you 
frequently use.

Customize Toolbar...

Use this options to customize and choose the frequently used commands that are 
displayed and accessible from the toolbar.

Save View  PRO ONLY

Opens the Save View dialog used to name and save specific views.

Delete View  PRO ONLY

Opens a submenu that lists the saved views. Select one of the view names to 
delete it.

Delete All Views  PRO ONLY

Deletes all views that were previously saved.

[View Names]  PRO ONLY

Saved views are listed at the bottom of the View menu providing a quick method 
of displaying a view.

Enter Full Screen

Choose this option to expand the application to full screen mode, which covers 
the whole screen and hides the menu bar.

Arrange Menu

Bring To Front

Moves the selected object to the front of the active layer.

Send To Back

Moves the selected object to the back of the active layer.
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Move Forward One

Moves the selected object forward one level on the active layer.

Move Back One

Move the selected object back one level on the active layer.

Group

Links two or more objects so that they can be treated as a single object. Hold 
down the Shift key and this command changes to Ungroup.

Ungroup

Converts grouped objects to their original individual state.

Rotate Tool

Use to freely rotate a selected object.

Rotate Left 90°

Use to rotate the selection 90 degrees counter-clockwise.

Rotate Right 90°

Use to rotate the selection 90 degrees clockwise.

Rotate To Zero

Choose to return rotated objects to their original orientations.

Rotate Options

Opens the Rotate Options dialog used to specify rotation for a selected object by 
entering precise units of rotation.

Flip Horizontal/Flip Vertical

Flips selected objects horizontally/vertically.
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Align Again  PRO ONLY

Use to align objects according to the settings specified in the Alignment Options 
dialog.

Alignment Options  PRO ONLY

Opens the Alignment Options dialog which provides controls to specify which 
part of a selected object should be aligned with which part of a reference object, 
a reference point or the grid.

Distribute On Line

Distributes selected objects along a straight line, and spaces them equally about 
their centers or datum points.

Lock

Restricts objects so that they cannot be changed.

Unlock

Returns locked objects to their original condition so that they can be changed.

Data Menu  PRO ONLY

Edit Field Names  PRO ONLY

Opens the Edit Field Names dialog that allows you to label the object information 
fields according to the information they will hold for your drawing’s objects.

Find/Replace  PRO ONLY

Opens the Find/Replace dialog which provides tools to automatically find and 
select objects or groups that have names or other object information assigned to 
them.

Report Formats  PRO ONLY
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Opens the Report Formats dialog which allows you to create, load, delete, 
rename, and edit report formats.

Layout Menu

Set Scale/Units

Opens the Set Scale/Units dialog which lets you choose the units, default scale 
and dimension standards for a drawing.

Set Grid

This submenu allows you to choose from the various grid snap options available 
in English or metric scales. The options reflect the current scale and size units 
chosen.

Set Angle Snap

This submenu allows you to choose from the various angle snap options 
available.

Scale Rulers

When Show Rulers is on, choose Scale Rulers to display rulers based on the 
current scale of the drawing. The scale rulers also reflect the current size units.

Standard Rulers

When Show Rulers is on, choose Standard Rulers to display the standard rulers 
which show the actual size of the drawing in the units specified in the Set Scale 
and Units dialog.

Snap to Object

Choose to turn Snap To Object on or off. When Snap to Object is on, objects you 
draw or move snap to the vertices of nearby objects on the drawing. When Snap 
to Object is off, objects you draw or move do not snap to nearby objects.
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Smart Snap

Choose to turn Smart Snap on or off. When Smart Snap is on, objects you draw 
or move snap to reference lines of nearby objects on the drawing. When Smart 
Snap is off, objects you draw or move do not snap to nearby objects.

Snap to Guides

Choose to turn Snap to Guides on or off. When Snap to Guides is on, objects you 
draw or move snap to reference guides you have added to the document. When 
Snap to Guides is off, objects you draw or move do not snap to the guides.

Drawing Size

Opens the Drawing Size dialog which allows you to set the size of the drawing.

Position

Opens the Position dialog which allows you to move all the objects on all layers 
of a drawing at the same time.

Window Menu

Minimize

Hides the current window to the dock.

Zoom

Expands the current window into full screen mode.

Show Previous/Next Tab

Opens the previous or next document tab if you have Show Tab View turned on 
and have more than one document open.

Move Tab to New Window



519Appendix Menus, Shortcuts and File Format Support

Use this if you have a document open in a new tab and want to open it as a new 
window instead.

Merge All Windows

Use this options to merge all separate windows into a tab view. All windows will 
now display as tabs in a single window.

Show/Hide Panels

Use this options to show or hide the left and right panels.

Bring All to front

Brings all windows to the front.

Show Library

Choose to bring the Library palette to the front of the screen.

[Drawing Names]

Open drawings are listed at the bottom of the Window menu. Select the drawing 
name to make it the active document.

Help Menu

MacDraft Manual

Choose to open the MacDraft manual in Adobe Acrobat Reader or other PDF 
viewer (Preview).

Tutorials

Choose to view tutorials to help you get started with MacDraft.

Registration Information

Opens the product registration web page on the internet.
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Upgrade Information

Opens the upgrade web page on the internet.

Online Support

Opens the online support web page on the internet.

Keyboard Shortcuts

Choose to view the keyboard shortcuts available in MacDraft.

What's New...

Opens the What's New panel, which describes some of the new features in this 
version of MacDraft.

Get Started...

Opens the Getting Started panel, which displays general information and links to 
MacDraft tutorials and guides.

Welcome to MacDraft

Choose to launch the welcome window.

Template Chooser...

Opens the Template Chooser panel, which allows you to choose between the 
different templates available in MacDraft for open a new document. 

You can also access your recently opened documents and open existing 
documents through the standard open dialog.

Menu Command Keys

MacDraft Menu
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Hide MacDraft Command H

Quit MacDraft Command Q

File Menu

New Command N

Open... Command O

Open DWG/DXF with Options... Command Shift O

Close Command W

Save... Command S

Duplicate Command Shift S

Page Setup... Command Shift P

Print... Command P

Edit Menu

Undo Command Z

Redo Command Shift Z

Cut Command X

Copy Command C

Paste Command V

Paste Unscaled Command Shift V

Clear Command Backspace

Duplicate Command D

Duplicate Without Offset Command Shift D
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Duplicate Unlocked Command Option Control D

Duplicate Unlocked Without Offset Command Shift Control D

Select All Command A

Select None Command Shift A

Select Special... Command Option A

Move... Command Shift M

Edit Datum Command E

View Menu

Zoom In Command 2

Zoom Out Command 3

Restore Previous Zoom Command 1

Home View Command Shift H

Hide/Show Toolbar Command Option T

Save View... Command 0

Enter Full Screen Command Control F

Arrange Menu

Bring to Front Command Shift ]

Send to Back Command Shift [

Move Forward One Command ]

Move Backward One Command [

Group Command G
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Ungroup Command Shift G

Rotate Tool Command R

Rotate to Zero Command Shift R

Rotate Options Command Option R

Align Again Command K

Alignment Options Command Option K

Distribute on Line Command Shift T

Lock Command L

Unlock Command Shift L

Window Menu

Minimize Command M

Show Previous Tab Control Shift Tab

Show Next Tab Control Tab

Notes

There are many Command Key, Command Shift Key and Command Option Key 
equivalents available. The following may be help you to remember them.

A Command Shift Key combination usually denotes doing the opposite of, or 
something related to, the equivalent Command Key combination. For Example, 
Command A is Select All; Command Shift A is Select None. Command R is 
Rotate; Command Shift R is Rotate To Zero. Command P is Print; Command 
Shift P is Page Setup... Command S is Save; Command Shift S is Duplicate...

A Command Option Key combination usually denotes choosing options for the 
related Command Key combination. For Example, Command A is Select All; 
Command Option A is Select Special... Command R is Rotate; Command Option 
R is Rotate Options... Command T is Align; Command Option T is Alignment 
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Options...

MacDraft Tool Shortcuts
The tools in the Drafting Tools section of the Tools (Left) panel have single 
key shortcuts assigned to them. Some of the tools have sub tools, which can be 
accessed by clicking the assigned keyboard shortcut key to cycle through them.

Arrow v

Rotate r

Marquee Selection m

Hand h

Line l (click to cycle through)

Special Line s (click to cycle through)

Rectangle u

Text t

Rounded Rectangle o (click to cycle through)

Circle c (click to cycle through)

Ellipse e

Arc a (click to cycle through)

Irregular Polygon i

Polyline y

Parallel Line w (click to cycle through)

Regular Polygon p (click to cycle through)

Bezier b
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Spline j

Freehand f

Freehand Shape g

Star k

Registration Mark x

Paste Repeated q

Edit Datum n

Attributes Dropper d

Zoom z

Contextual Menus
MacDraft allows you to access commonly associated options and commands, by 
using the contextual menu (right-hand mouse click). The contextual menu can be 
shown by either clicking the right hand muse button when an object is selected, 
or by pressing the Control key on the keyboard and clicking an object.

Application Modifier Keys
Hold down the appropriate key to achieve the following results.

Shift Key Normally constrains an action

Diagonal Line tool: Constrains lines to snap at 45 degree increments.

Rectangle tool: 
Constrains the shape to a square. (Applies to 
rounded-corner, square-corner and elliptical-corner 
rectangles.)
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Circle tool: 
(By radius or by diameter). Constrains the line 
used to define the radius or diameter to snap at 45 
degree increments.

Arc tool:

Arcs by radius: Constrains the line used to define 
the radius to snap at 45 degree increments.

Elliptical arcs: Constrains the size of the ellipse 
that is used to define the arc and allows you 
to change the starting angle of the arc without 
changing it's size.

Polygon tool: Constrains the line segments to snap at 45 degree 
increments during creation.

Freehand tool:

Activates the eraser, allowing you to delete part of 
the freehand shape during creation by retracing the 
last drawn lines.

Constrains a line segment to a straight line.

Rotation: 
Changes the rotation units. The first press of the 
Shift key activates the rotation in minutes; the 
second press activates the rotation in second.

Moving objects:

When held down after dragging begins, constrains 
the movement of objects to a horizontal or vertical 
direction. With multiple objects pressing shift 
before dragging moves one object independently 
of other selected objects.

Selecting objects:
Extends the selection to include non-selected 
objects you click on. Also deselects the selected 
objects you click on.

Distribute on line: Constrains the line used to define the distribution 
of objects to snap at 45 degree increments.

Pattern Editor dialog box: Constrains the movement of the pointer and the 
Finger-Painting tool to a 90 degree angle.

Pointer tool: Activates the alternative Zoom cursor (magnifying 
glass).

Bezier Curves: Constrains Bezier handle pairs to move in tandem.

Command key Normally releases a constraint
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Rotation:

Allows rotation in one degree increments. Also 
returns to the previous rotation units; takes you 
from rotation-in-seconds to rotation-in-minutes, 
and from minutes to degrees. Also returns you to 
the pointer mode when you click on the drawing.

Zoom: Returns you to the pointer mode when you click 
on the drawing.

Option key Normally activates an optional mode or 
operation

Drag: Duplicates the selected object you are dragging.

Finger-Painting tool: (In Pattern Editor dialog box). Resets the Finger-
Painting tool color to the color you click on.

Zoom: Activates the Zoom Out mode.

Add/Delete Handle: Activates the Delete Handle mode.

Selection Rectangle: Selects all of the objects that are inside or touching 
the rectangle.

Align objects: Aligns selected objects to one element in a group, 
rather than to the group as a whole.

Line, Polygon, Parallel, 
Offset and Perpendicular 
tools:

While drawing, lines, polygon segments, polyline 
segments, parallel lines, parallel polygon 
segments, parallel polyline segments, and 
perpendicular lines, and the offset distance of 
offset lines, snaps the length to the currently active 
grid snap increment.

Space Bar key

Pointer Tool
Activates the Pan feature when you drag while 
in the pointer mode. This allows you to scroll 
horizontally and vertically at the same time.

Key Specials & 
Combinations:

Pan Feature: Shift-space bar constrains panning to 90 degree 
movement when pointer tool is selected.

Deselect All: Shift - Command - A deselects any selected 
objects.
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Select All Text (In Open 
Text):

Within a text block, Command - A selects all the 
text characters.

Cropping:

Shift - Option permits the cropping of a bitmap or 
pixel map, by dragging any edit handle. (Although 
it has been cropped, the rest of the image is still 
retained in memory, so you can resize using Shift - 
Option, to reveal the rest of the image.)

Drawing Lines/ Objects: Command releases the active part of the object 
from the grid snap.

Dragging widget of object 
to snap to another object:

Command - Option when selecting a widget of an 
object and dragging allows you to snap that widget 
to another objects widget, when Snap to Object is 
turned on.

Moving to snap to Mid, 
Center and End:

Command-Option drag the handle of an object, 
then release them and hold the M, C or E key to 
snap the movement to the Mid point, Center point 
or End point respectively.

File Formats
MacDraft supports document files in the formats listed below.

Microspot MacDraft can read files in the following formats

•	 MacDraft (MD60 & MD70) /PC Draft (MD60)

•	 Templates

•	 Library Files (Spotlibrary)

•	 DXF  PRO ONLY

•	 DWG  PRO ONLY

•	 TIFF format files, such as scanned images

•	 PDF and other image formats.

Microspot MacDraft can write files in the following formats
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•	 MacDraft 

•	 Library Files (Spotlibrary)

Microspot MacDraft can export files in the following formats

•	 DWG  PRO ONLY

•	 DXF  PRO ONLY

•	 JPEG

•	 JPEG-2000

•	 PNG

•	 OpenEXR

•	 TIFF

•	 PDF

DXF Format Documents  PRO ONLY

DXF is a standard file type for exchanging images among different graphics and 
drawing programs. MacDraft lets you save MacDraft drawings as DXF files 
and open DXF files created with other programs. (The DXF file format was 
developed by AutoDesk®, Inc., the manufacturer of AutoCAD®.)

Exporting a document in DXF format  PRO ONLY

To export a document as a DXF file

1.	 Choose DXF from the Export submenu in the File menu.

The standard Save dialog appears.

2.	 Enter a name for the document (if the file is destined for a non-Macintosh 
computer, you may need to limit the number of characters in the file name).

3.	 Specify a location to save the document.

4.	 Choose the DXF version from the File Version pop-up menu.
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5.	 Click the Export button.

The DXF file will be saved with the name and at the location specified.

DXF export issues   PRO ONLY

Because the DXF format does not handle as many kinds of shapes and attributes 
as MacDraft’s own file format, certain attributes in a MacDraft drawing are 
changed in the resulting DXF file. These changes are defined by the following:

•	 The image moves to the upper left corner of the drawing window.

•	 Circles, arcs, and straight lines become one pixel thick. Other object outlines 
retain their line weights.

•	 All shapes lose their fills.

•	 Custom line styles are limited to eleven segments (dashes or blanks).

•	 Rectangles (including squares) become polygons.

•	 Rounded-corner rectangles become polygons (with many sides emulating the 
corner arcs).

•	 All three types of circles (radial, diametric, and three-point) become radial 
circles.

•	 Ovals (ellipses) become polygons with many sides.

•	 Radial and three-point arcs become radial arcs. Elliptical arcs expand to 
polygons emulating full ellipses.

•	 Parallel objects become sets of line segments (one segment per side or end 
cap).

•	 Freehand shapes become polygons (mid-segment edit handles added).

•	 Bezier curves become many-sided polylines (open polygons).

•	 Splines become many-sided polylines.

•	 Smoothed freehand lines and shapes and polygons or polylines become 
many-sided polygons or polylines.
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•	 Dimension objects become simple lines or arcs, with circles, polygons, or 
lines emulating the end marks; witness lines become simple lines and value 
text blocks become independent text objects.

•	 Area calculation text becomes an independent text object.

•	 Bitmap objects, including high-resolution pixel maps, are omitted.

•	 Text assumes the default application font, preserving the upper-left position 
of the original text object.

•	 Each line of a multiline text object becomes at least one separate text object. 
Each point at which the text style changes within a line begins a new text 
object. For example, a line ending with one boldfaced word would become 
two text objects; a line containing one boldfaced word in the middle would 
become three text objects.

•	 Each line of a rotated multi-line text object becomes a separate text object, 
rotated about its own center. (To line these objects up properly after 
conversion to DXF, rotate them back to the horizontal, group them, then 
rotate the group to the desired angle.)

Opening a document in DXF format  PRO ONLY

To open a DXF document automatically

1.	 In MacDraft, choose Open from the File menu.

The standard Open dialog appears.

2.	 Locate the file you wish to open.

3.	 Click the file name to select it.

4.	 Click the Open button.

The DXF image appears in a new untitled MacDraft drawing.

To open a DXF document automatically

1.	 In MacDraft, choose Open DWG/DXF with Options from the File menu.
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The standard Open dialog appears.

2.	 Locate the file you wish to open.

3.	 Click the file name to select it.

4.	 Click the Open button.

The Set Scale/Units dialog appears.

5.	 Set the desired scale and units and click OK.

The DXF image appears in a new untitled MacDraft drawing.

Note: The Set Scale/Units dialog that precedes the DXF import does not recalculate 
the DXF file into a new scale or onscreen size, it only determines what scale will be 
applied to the drawing. The onscreen size of the drawing must be determined in the 
source program.

DXF import issues  PRO ONLY

MacDraft can open DXF files created using other programs, subject to various 
limitations. Before opening a DXF file with MacDraft, or if you are having 
trouble opening a DXF file, read over the following list of issues.

•	 Scale and Units: The Set Scale/Units dialog that precedes the DXF import 
does not recalculate the DXF file into a new scale or onscreen size. It only 
determines what scale will be applied to the drawing. The onscreen size of 
the drawing must be determined in the source program.

•	 These DXF items are not supported by MacDraft: X-Refs (External 
References); 3-D objects or entities; solid objects or entities; block attributes.

•	 If a DXF file created using AutoCAD does not open in MacDraft, make sure 
that all unused items (blocks, layers, and so on) have been purged from the 
source file. If there is resident information from deleted blocks, the DXF 
files will not open. Also, before creating the DXF file, it’s best to explode 
and purge nested blocks, as these increase the complexity of files, sometimes 
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making them unopenable.        

•	 When generating a DXF file select a text DXF export format in your source 
program. (Some programs offer a binary DXF output, which is not supported 
by MacDraft.)

•	 If a drawing opens in MacDraft, but some or all of it is off of the page, use 
the Layout menu’s Position command to properly position the drawing on 
the page. (Different CAD programs use different X / Y origin points, as well 
as handling curves differently. The result of these translations can cause the 
drawing to import partially or entirely off of the page.)

•	 If some or all of the drawing entities are not visible in the imported file, 
choose the Edit menu’s Select All command, then use the Attribute panel’s 
Pen Color or Pen Pattern pop-up menu to assign the objects a new pen 
color. You may need to repeat this for each layer. When importing a DXF 
file, MacDraft matches the objects’ original colors to its active color table. 
Sometimes the result of a color match can be difficult to see (white ink on a 
white background, for example). Assigning a new pen color remedies this.

DWG Format Documents  PRO ONLY

MacDraft includes a DWG File Exchange Library, so MacDraft is able to read 
and write files in DWG format.

Opening a document in DWG format  PRO ONLY

To open a DWG document automatically

1.	 In MacDraft, choose Open from the File menu.

The standard Open dialog appears.

2.	 Locate the file you wish to open.

3.	 Click the file name to select it.

4.	 Click the Open button.

The DWG image appears in a new untitled MacDraft drawing.
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To open a DWG document automatically

1.	 In MacDraft, choose Open DWG/DXF with Options from the File menu.

The standard Open dialog appears.

2.	 Locate the file you wish to open.

3.	 Click the file name to select it.

4.	 Click the Open button.

The DWG Layout dialog will appear.

5.	 Choose which layout you wish to open and click OK.

The Document Scale & Units dialog appears.

6.	 Click the button beside English or Metric, depending on the type of units that 
were used in the document. Whether you use the English or Metric system, 
you can choose the basic units for the drawing: Decimal Inches, Decimal 
Feet & Inches, Decimal Feet, Fractional Inches or Fractional Feet & Inches 
in English drawings; Millimeters, Centimeters, Decimeters or Meters in 
Metric drawings.

7.	 If necessary, change the units in the Units pop-up menu.

8.	 Select the scale you want.

9.	 Click the OK button to close the dialog.

The DWG Unit dialog displays.

DWG files use non-specific units of measurement. Enter a value to specify 
how many DWG units there should be per foot or per meter in the drawing 
to be displayed. The document will now continue to open. Various status 
dialogs will show during the process. If any objects are detected in the 
drawing that cant be displayed it will show a dialog similar to the one shown 
below, telling you what it cannot display.

You are given the options of continuing or stopping. You may also ask for the 
dialog not to be shown again and simply skip other objects it cannot display.

DWG import issues  PRO ONLY
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Currently MacDraft does not support objects in DWG documents that contain 
hatches. The first time such an object is encountered during the read process, 
a dialog appears informing you that the type of object is not supported. These 
objects will not be read into the MacDraft document. 

Exporting a document in DWG format  PRO ONLY

To export a document as a DWG file

1.	 Choose DWG from the Export submenu in the File menu.

The standard Save dialog appears.

2.	 Enter a name for the document (if the file is destined for a non-Macintosh 
computer, you may need to limit the number of characters in the file name).

3.	 Specify a location to save the document.

4.	 Choose the DWG version from the File Version pop-up menu.

5.	 Click the Export button.

The DWG file will be saved with the name and at the location specified.

Image formats  PRO ONLY

MacDraft allows you to open image formats such as PNG, JPEG, PDF etc. 

Opening images  PRO ONLY

To open images

1.	 In MacDraft, choose Open from the File menu.

2.	 Locate the file you wish to open and click the file name to select it.

3.	 Click the Open button.

Note: You can also drag an image into the document or onto the application icon.


